
 

 1 of 5 
 

United States: 
Phone: 518.285.6000 

Fax: 518.285.6070 

Sales: 800.327.8627 
Government Sales: 800.619.2333 

Technical Support: 518.285.7283 

Technical Support Fax: 518.285.6080 
www.pbinsight.com 

 

Canada: 
Phone: 416.594.5200 

Fax: 416.594.5201 

Sales: 800.268.3282 
Technical Support:.518.285.7283 

Technical Support Fax: 518.285.6080 

www.pbinsight.ca 

 

Europe/United Kingdom: 

Phone: +44.1753.848.200 
Fax: +44.1753.621.140  

Technical Support: +44.1753.848.229  

www.pbinsight.co.uk 
 

Asia Pacific/Australia: 

Phone: +61.2.9437.6255 
Fax: +61.2.9439.1773 

Technical Support: 1.800.648.899 
www.pbinsight.com.au 

 

© 2012 Pitney Bowes Software Inc. All 
rights reserved. MapInfo, Group 1 

Software, and MapInfo Professional are 

trademarks of Pitney Bowes Software Inc. 

All other marks and trademarks are 

property of their respective holders. 

 
May 2012 

 

AnySite 9.0 
Software Release Notes 

 
This document provides information about installation of and known issues for the AnySite 

9.0 version of software.  System Administrators installing AnySite™ are encouraged to 

review and provide users with this document before installing AnySite 9.0.   

 

Installation 
 
Upgrades from AnySite 8.8.X to AnySite 9.0 are not supported.  AnySite 9.0 requires a new 
“fresh” installation of software due to the new features and enhancements.  If you have an 
existing AnySite 8.8.X version installed, you must move or copy specific files to a location 
outside of the AnySite application directory.   Each release of AnySite includes data and/or 
software updates.  
 
There is a new 9.0 Install Guide which will guide you through the new install process and 
migrating custom data.  Please refer to this document at the following location: 
 

http://www.pbinsight.com/support/product-documentation/details/anysite 
 

New to AnySite 
 

Modified Installer  

 
AnySite is now fully Windows 7 32/64 bit supported.  It can now be installed on a Windows 7 
operating system without special instructions.  The user will also experience the following 
improvements: 

 Fewer pop-ups during the install process   

 Progressive guidance during the install process  

 Improved error handling and user advisories during the install process  

 

Bing Maps Integration 
 
For a more contemporary mapping experience, AnySite 9.0 is integrated with Bing Maps.  A 
Basic Bing Maps Preference is set as the default and is ready for you to view.  In the default 
Bing Map Layers, you have three Bing layers:  Street, Hybrid & Aerial.     

 

Web-Service Geocoding 
 
The default Geocoder in AnySite now utilizes the Envinsa Online Services (EOLS) geocoder 
service, which allows access to the most accurate locations around the world through the 
integration of multiple geocoders and datasets with MapView, reverse IP, and culture to 
provide the most relevant and accurate results.   
 
The EOLS web-service geocoder requires an internet connection, provides small batch 
capabilities, and the data is updated twice a year.  An AnySite license will provide access to 
a limited number of transactions annually.  The traditional MapMarker Geocoder is still 
available. 
 

The Geocoding service can be altered by going to the Configurator > Tools > Edit 
Application INI file and modifying the Method. 

http://www.pbinsight.com/support/product-documentation/details/anysite
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Web-Service Drivetime 
 
AnySite provides the ability to create trade areas using drivetime. The drivetime tool allows you to create 
isochrones based on the distance from your site in minutes for up to three trade areas.  AnySite now offers 
the Envinsa Online Services Routing service as a drivetime option.  Drive Time IsoChrones can be useful for 
determining potential markets or advertising and analysis for retail purposes.  The Envinsa Routing service 
requires an internet connection, provides small batch capabilities, and the data is updated twice a year.  An 
AnySite license will provide access to a limited number of transactions annually.  The traditional ATS 
Freeway drive time is still available and is the default service. The ATS Freeway data was last updated with 
the 2006 Tiger streets network data.  There are no future plans to update this data. 

 
The DriveTime service can be altered by going to the Configurator > Tools > Edit Application INI file and 

modifying the Method. 

 

Improved Reporting 
 
AnySite 9.0 adds the ability to output reports into two new formats: 

 Microsoft Excel 

 XML (Extensible Markup Language) 
 

MS Excel 
The new output formats work with all of the existing Report Types in AnySite.  For clarity, the report 
types have not changed in AnySite 9.0.   
 
The Excel Reporting component allows for an Excel template to define the style, content, and 
layout of the reports.  The default Excel template is defined in the AnySite.ini file. 
 
When a report is created in AnySite, the settings in the Instructions Worksheet direct AnySite on 
how to output the contents of the report.  When the report is created all content, layout, and styles 
are applied.  Once the resulting report is created, the Instruction worksheet no longer has any 
impact on the report. 
 
Key Considerations: 

 Supports Excel 2007 and later versions (xlsx extension) 

 Charts from AnySite are ignored and not included in the Excel document.  Charts defined 
in the template are supported. 

 A Map image (if defined in a report per Configurator) is included and is placed on a tab as 
defined in the Instruction worksheet.  Only a single map is supported. 

 

XML 
The XML output options that AnySite 9.0 offers will typically be used by those who are able to write 
software to read the XML content.   

 
The following excerpt from the AnySite.ini file shows the settings for selecting XML as the default 
report output options. 
 
[Reports] 

;Set the default report format for individual report selections. 

; 1 = RTF; 2 = TXT; 3 = CSV; 4 = DBF; 5 = TAB; 6 = XLSX; 7 = XML 

DefaultReportFormat=7 

 

;Set the default Excel template for reports. (XLSX type; looks in the 

Template folder) 

DefaultExcelTemplate=ExcelReportTemplate.xlsx 
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Web-Publishing 

 
AnySite 9.0 offers users the ability to connect, communicate, and collaborate so that all users in an 
organization have access to the same sites and reports.  There are two different ways to share sites with 
your audience: 
 
1.  Share a site via email.  To share a site via email, save the site by clicking on File > Save As and save to 

a location on your computer.  Once saved, users can then attach the site to an email for distribution. 
 
2.  Share a site via Magnify® v3.0. This Add-On to AnySite allows subscribers to publish locations, trade 
areas and reports to the web. Once a site is created and saved in AnySite, authors can then load it in 
Magnify for instant access to everyone in their group who has appropriate permissions.  In Magnify, click on 
the Open/Create Site icon > Load from SIT File, navigate to your saved .sit file, and click Upload. 

 
 
To run a report for the site you just opened, click on the Reports icon and use the drop down box to see the 

listing of reports.  
 
Magnify allows AnySite users to: 

 Publish AnySite content via the Web to Magnify subscribers. 

 Produce identical mapping and reporting for AnySite generated polygons between desktop and 
Magnify users. 

 Leverage a single data license per user AnySite and Magnify. 
 
Note: Magnify can only be used if you have purchased a license for it.  Go to www.magnifymaps.com to 
register for an account.  Enter promo code: ASWP811M. 

 
Layer Wizard  
 
The Map Layer Wizard automates the task of adding a map layer to an existing map using limited styling 
and definition.  
 

To open the Layer Wizard, do one of the following actions: 

 On the toolbar, click the Layer Wizard icon 

 On the Layer Control pane, click Edit Layer Properties > Add New > Layer Wizard 
 

The wizard will guide a user through the process of adding a layer.  The options that you see vary 
depending on your choices for the source of data, the data attributes and the object type. 
 
Note: The Configurator is the best option for adding layers that require complex styling and definition. 
 

Help Files 
 
AnySite 9.0 provides multiple Help files. 

 8.8 Features – This reference source contains all features that were native to the last version of 
Anysite. 

 9.0 New Features – This reference source contains the new features that are new to AnySite 9.0 
and all features that have been modified from 8.8. 

 Troubleshooting – This is a web-help file that contains common issues and workarounds that are 
reported by users.  This file will be continually updated. 

 

Retiring Functionality 
 

ImageConnect Aerial Imagery 
 

The GlobeXplorer / ImageConnect Aerial imagery has been removed from the Web Service Manager. 
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Known Issues 
 

Install Interrupted 

 

When installing on a machine that has a previous version of AnySite installed, you will receive an Install 

Interrupted error and the install will abort.  AnySite 9.0 cannot be installed on a machine where a previous 

version of AnySite exists. Back-up your custom files to a safe location (see the 9.0 Install Guide for complete 

instructions), uninstall the existing version of AnySite, install AnySite 9.0 and then copy the back-up of your 

custom files into the appropriate AnySite directory. 

 
Installing Disks & AutoPlay Warnings 
 

Windows 7 has a default “AutoPlay” feature.  As a result, a “View Files” dialog box prompting for action may 
pop up when inserting additional media (OEM MapMarker etc) during the install process: ignore this 
message and close with the red X.     
 
When prompted for an additional media after the initial Installation Disk, do not select “OK” until the initial 

disk has been removed, the requested disk inserted, and the machine has loaded the disk.  Once you know 
the machine has loaded the disk, then click “OK”.  The “Cancel” button allows you to skip a disk.     

 

AnySite License Installation Error 
 

After installing the AnySite license, you may receive a "Program may not have installed correctly" error. This is 

a Program Compatibility Assistant bug on Win7.  The program installed correctly.  Click "Program Installed 

Correctly".   

 

MapMarker Data Not Found 
 

When launching AnySite for the first time with MapMarker as the Geocode service (as set in the AnySite.ini 

file), you may get a MapMarker Data Not Found message regarding the location of the MapMarker address 

data.  The data installed correctly.  Click “OK’ to close the dialog box.   

 

TEMP Directory 

If C:\Temp directory does not already exist, you will need to create one by going to the root directory of C:\> 
Click New Folder.  Input Temp for folder name.  This directory is needed for Batch Loader and will not 

complete successfully without it.   

 

TEMP Directory Contains a DOT in the Path 
 

When creating a drivetime, you may receive an error message that states: Temp directory contains a dot in 
the path.  Follow the following steps if you receive this error message: 
 
 

1. Check to see if the C:\Temp directory does not already exist.  If not, then create one by:   
a. Locate the root directory of C:\> Click New Folder and name the folder “Temp”. 

2. Launch Configurator and Click Tools>Edit Application INI file.   
a. Search file for “TempDir=C:\TEMP” 
b. Remove the semicolon in front of “TempDir=C:\TEMP” 

i. The instruction should read as follows: 
;*Alternative temp directory for Freeway .dll cannot use non-standard file names (incl. .-/). 
;*Users must have write access to the directory assigned.   

c. Remove semi-colon and type in new path of “TempDir=C:\TEMP” 

3. Save the ini file, then close Configurator and re-launch AnySite.exe. 
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EOLS Web-Service Drivetime Issues 
 
Drivetime Order 

The drive time logic occasionally reverses the drawing order of the drivetimes, placing the largest drivetime 

on top and hiding additional drivetimes.  

 
Isolated Drivetime 

 
The drive time logic occasionally creates one complete but isolated drivetime outside of the remaining 
drivetimes.  For example, a 3 min & 7 min drivetimes are stacked properly but the 5 min drivetime is isolated 
in a neighboring location.   

 
Returns a Rectangle 

The drive time logic occasionally returns a large rectangle.  This indicates that there was a failure in the 

web-service to fetch a drivetime. 

Note     All three issues are rarely encountered issues and may be related to a bug in the EOLS web-

service.  If you encounter any of these issues, please record the following items below for tech support.  

 
“Cannot Read Polygon (Bna file has invalid node count)“ Error  
If the drivetime isoChrone is over 20 minutes or in a complex area the node count is too high in the polygon 
for AnySite to read it or the isochrones “fetch” has exceed the amount of time allotted in the Drivetime web-
services.ini file settings.  Recommended settings are Small, Medium and Large isochrones are provided in 
the 9.0 New Features Help Guide.  

   

Bing Map Issues 
 

Map Resolution 
 
The resolution of the Bing map or Bing map labels may be substandard at times. This is in part the nature of 
geometry and texture resolution of a satellite image/photograph but there is an issue when trying to flatten a 
picture of a curved earth into a predefined AnySite template.  If the map renders out of focus, use your “pan” 
tool to move the map slightly.  Often when it redraws you get a better quality image.  

 
Label Resolution 
 
To improve label resolution, especially for large-scale printing, go to Configurator > Tools > Edit Web 
Services.ini > go to the Bing section > edit ExtraDetail instruction to True or False (default is True).  This a 
personal preference setting.   

 

Info Tool Not Working with Bing Map Preference 

 

Bing Maps are actual pictures and there are no layers present.  The Info Tool will  

not work without layers present. 

 
Default View Renders Slow with Retail StreetPro Map Preference 

 
When setting the default map preference to 2010 and Later Multi-Net StreetPro, the map view may be slow 
to render.  This is due to the zoom levels for several layers being set incorrectly.  If you license Retail 
StreetPro, a replacement Map Preference can be downloaded from the troubleshooting guide within 
AnySite.  Go to Help > Troubleshooting and locate the Multi-Net StreetPro Map Preference topic. 

 


