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Installing StreetSweeper Pro
Follow these instructions if you are installing StreetSweeper Pro for the first time.

 1. Before you begin
 2. Downloading the installer
 3. Running the installer
 4. Install the application
 5. Downloading Canada Post data
 6. Install the latest data
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 7. Keep your data updated
 8. Automate the update process
 9. Troubleshooting

 Before you begin

Before installing StreetSweeper Pro, please ensure that your system meets the following minimum 
requirements:

 l Operating System: Windows 10 or later
 l Processor: Intel i5 or equivalent
 l Memory: 8 GB RAM
 l Storage: 3 GB of free disk space
 l Graphics: DirectX 11 compatible graphics card
 l Internet Connection: Required for software activation and updates.

 Downloading the installer

 1. Open your web browser and navigate to the Streetsweeper Pro Official Website.
 2. Go to the Download StreetSweeper Pro Updates section.
 3. Click on the latest StreetSweeper Pro Windows version download link to download the installer.

 Running the installer

 1. Locate the downloaded installer Zip file (StreetSweeperPro_X.X.XX.zip), where X is the version 
number in your Downloads folder.

 2. Unzip the file.
 3. Double-click the installer to run the setup.exe file.
 4. If prompted by User Account Control, click Yes to allow the installer to make changes to your 

device.
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 Install the application

 1. Follow the on-screen instructions in the installation wizard.
 2. Read and accept the License Agreement.
 3. Choose the installation directory. The default directory is recommended.
 4. Select Install to begin the installation process.
 5. Once the installation is complete, click Finish to exit the installer. 

StreetSweeper Pro is now installed on your system.

 Downloading Canada Post data

 1. Go to StreetSweeper Pro Monthly Data Section.
 2. Navigate to the latest StreetSweeper Pro Available Data link.
 3. Select the file for download. The first 2 digits indicate the year, and the second 2 digits indicate 

the month.
 4. Unzip this file.

 Install the latest data

Install SSProDataXXXX.exe on your computer.

 1. Choose the installation directory. The default directory is recommended.
 2. Click Install to begin.

 Keep your data updated

Monthly updates:
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 1. Check the StreetSweeper Pro Download Page once a month for the latest data from Canada 
Post.

 2. Repeat the installation steps to install new data.

 Automate the update process

 1. Download and install IntelliLink® Desktop, a Windows application that keeps your Pitney 
Bowes software products current with the latest software and data file updates. This will allow 
you to manage updates in one place.

 2. The IntelliLink® Desktop download link is located at the bottom of the StreetSweeper Pro 
Download Page.

 Troubleshooting

If you encounter any issues during installation, please refer to the Support Page.

Registering for an account in the License Manager
All new users must register for an account. The registration link is located at the bottom of the login 
form.

 1. Select Sign up Now to register as a new user.
 2. Fill in the registration form and input all the required information.
 3. Select Register.
 4. After your information has been verified, you will be able to log in to the application with your e-

mail and password.

Related Topics

 l Logging into the License Manager in StreetSweeper Pro
 l Resetting passwords in the License Manager in StreetSweeper Pro
 l Adding Additional Users to StreetSweeper Pro
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Logging into the License Manager
Once you have registered your account, you can log into the License Manager.

 1. Input your login credentials and select Sign In.
 2. An authentication window will appear. Input the authentication code and select Submit. The 

code can be sent to your email by selecting Send one time code.

Related topics

 l Registering for an account in the License Manager in StreetSweeper Pro
 l Resetting passwords in the License Manager in StreetSweeper Pro
 l Adding additional users to StreetSweeper Pro

Adding additional users
To allow your additional users to access StreetSweeper Pro, set them up in the License Manager.

 1. Select an available serial number from the drop-down menu. Enter the new user’s email 
address into the On Boarding Email text box.

 2. An email will be sent to the new user with the serial number needed to register.

Related topics

 l Registering for an Account in the License Manager in StreetSweeper Pro
 l Logging into the License Manager in StreetSweeper Pro
 l Resetting passwords in the License Manager in StreetSweeper Pro

Logging into StreetSweeper Pro
To open StreetSweeper Pro, double click its icon or select the program from your Start bar.

 l Logging in as a new user
 l Logging in using an existing account
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Logging in as a new user

Once the login screen appears:

 1. Select Register New User.

 2. Enter the required information to set up your account. Once your information has been verified, 
you will be able to log in using your email address and password.

 3. Enter your email and password.
 4. Select Login.

Logging in using an existing account

Once the login screen appears:
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 1. Enter your email and password.
 2. Select Login.

Exiting or logging out of StreetSweeper Pro
You can exit the application or log out an individual user.
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 1. To exit the application, select File > Exit. This will close the application and log out the user.
 2. To log out a user but leave the application open, select File > Logout.

Setting default data paths
This function allows you to specify the default directories for input and output files, the usual work 
directory, and the directories that contain Canada Post and table file databases.

 1. Select the Settings icon then Settings > System Configuration.
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 2. Select the Data Files tab.

 3. Select the Browse button and navigate to the appropriate folder for each directory.
 4. If the File Input and File Output folders will not remain constant, you can check Remember 

Last Path.StreetSweeper Pro will then return to the last location you selected for input or output 
files.

 5. When you are satisfied with your changes, select Update.

Setting up default company information
The company information entered into StreetSweeper Pro will be applied to reports. This information 
only needs to be entered once and then is stored as a default. The information can be updated at any 
time by returning to this screen.

 1. Select the Settings icon then Settings>System Configuration.
 2. Select the Mailer Information tab.
 3. Enter the name and contact information that will be printed on reports.
 4. Select CPC Account Numbers and IDs to enter the company’s Canada Post account number, 

contract number (if applicable) and NCOA Terms of Use ID (if applicable).
 5. Select Accept.
 6. After verifying the information is correct, select Update.

Entering your customer's information
StreetSweeper Pro provides a database of your customer information, including name, address, and 
associated Canada Post account information. You will be able to select a customer when creating a 
Project. Their information will then appear on Canada Post reports.

It is mandatory to create a customer record with an End User Terms of Use ID if you will be processing 
their file against NCOA.

Once customer information is entered, it will be shared and accessible to other users on your account.
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 1. Select Settings > Customer Information.
 2. Select Add Customer.
 3. Enter the information you wish to appear on Project reports.
 4. If applicable, select CPC Account Numbers and IDs to enter your customer’s Canada Post 

account, contract, and Terms of Use information. Select OK.
 5. Select Update. You may now close the screen.

Related topics

 l Creating and entering your End User Terms of Use ID

Creating a project in StreetSweeper Pro
New users will learn how to create a new project file in StreetSweeper Pro. You will import a data file to 
start a new project.

 1. Select File > New Project. You can also create a new project by clicking the +New Project 
icon from the dashboard. You will import a data file to start a new project. 

You can import a variety of different data formats into your project. These include:
 l MS Acess
 l MS Excel
 l Text files (.tab, .csv, fixed length)
 l DB2
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 2. When prompted by your browser, select your input file.

 l MS Access or MS Excel input file
 l Text format input file
 l Fixed length input file

MS Access or MS Excel input file

 1. Select the table or worksheet you are using for your project.

Text format input file

 1. Select your text file format.
 2. Select your Character Set, if applicable.
 3. Indicate whether your first row is a header row.
 4. Indicate if all columns should be loaded as text.
 5. Select Continue.

Fixed length input file

 1. Select Fixed Length fields as the format of the text file.
 2. Select your Character Set, if applicable.
 3. Indicate whether your first row is a header row.
 4. Indicate if all columns should be loaded as text.
 5. Select Continue.
 6. The application will attempt to auto-detect fixed length fields. Adjustments can be made using 

the field entry boxes on the right or by adjusting fields on the bottom display. There are options 
to enter fields by length and to load or save profiles.

 7. When you are satisfied with the file setup, select OK.

Related topics

 l Setting up your Project in StreetSweeper Pro
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Setting up a Project
After opening your input file, the Field Mapping screen will appear. If your input file is MS Excel, click 
the checkbox beside Remove Header Row.

 1. Under Project Details:
 a. Enter the Project name if you do not want the default file name.
 b. If required, select a Customer.
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 2. To split a combined first and last name field, select the appropriate Split Name_1 Field option.

 3. If you are using a saved Profile, select from Profile.
 4. Identify the fields in your file by dragging the appropriate Field Name from the left column to the 

first field of the displayed data. Where possible, StreetSweeper Pro has identified address 
fields.
 a. If you drop a field in the wrong location, drag it back to the left column.
 b. To merge two fields together, drop the same Field Name onto two different data rows.
 c. Use the scroll bars to see more of your data.

 5. When your fields have been identified, select OK. If any of your fields have been merged, you 
will be asked to drag them into the correct order.

Saving a Project in StreetSweeper Pro
You can save your Project with a user-selected or default filename.

Pitney Bowes Quick Start Guide November 2024 15



 1. Select File > Save or File > Save As.

 2. When prompted by your browser, select your destination folder. Enter a filename or keep the 
default name assigned by the application.

 3. Select Save.

Exporting your Project file
You can export your Project file at any point.

 1. Select Presort > Export File.

 2. Choose the fields you wish to have exported in your file by checking the appropriate boxes 
under Select Information.

 3. Choose the type of records to include in your export file by selecting the relevant status codes in 
the Filter Records By box. Uncoded records (foreign or with a missing or invalid postal code) 
can be excluded from the file by checking the Exclude Uncoded box.

 4. If you have run NCOA and/or CMA processing on your file, you can select the types of records 
to export by checking the appropriate options in the NCOA box.

 5. If you have presorted your file, you can export your file in presort order by ensuring the Presort 
Sequence box has been checked under Presort Data.
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 6. Select the format of your export file using the drop-down under Output Format. If you wish to 
export duplicate fields, ensure Output Duplicate Fields is checked.

 7. If you have selected a flat file export format (csv, tab, fixed length, specified delimiter), you can 
select the appropriate character set using the options in the Character Set box.

 8. When you are satisfied with the options you have selected, select OK. Choose an output folder 
and filename to save your file.

Setting up default options for correcting Projects
Users can set standard options for correction processing of Projects. These defaults can be 
overridden for a specific Project by changing the options prior to correction. These changes will not 
update the default options.

 1. Select the Settings icon and select Set Correction Options.

 2. Indicate what type of processing should be applied to Projects. The default is 
Correction/Validation. If Validation Only is selected, no corrections will be made to Projects.

 3. Indicate how records should be cased during processing.
 4. Check Shorten Address if Canada Post approved abbreviations should be used for street 

types and directions.
 5. Check French Accents if these should be applied during processing.
 6. Indicate how unit information should be displayed within the address block. Units can be 

displayed before the street address, also known as Western Style, or use a keyword such as 
unit or suite.

 7. Check Add Postal Code space to ensure all valid and corrected Postal Codes have a space 
between the first three and last three characters.

 8. Check Format Valids if valid records should also have the selected formatting options applied.
 9. Check Validate Rural Based Only on Postal Code if correction on these records should only 

consider the Postal Code.
 10. Check the appropriate language option to specify if records should be corrected to English, 

French, or a combination of both.
 11. Check Display address accuracy statement after correction/validation to have the 

Statement of Accuracy automatically open after processing is complete.
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When you have completed setting your default options, select OK to save them. You can return at any 
time to modify your default settings.

Viewing the statement of accuracy

If Display address accuracy statement after correction/validation was selected as a correction 
option, the Statement of Accuracy will automatically open after processing is complete. It can also be 
opened by selecting Address Tools > Statement of Accuracy.

Correcting a project
After creating a Project, you can correct and validate address records.

 1. Select Address Tools > Address Correction.

 2. Default options will be shown. Any of these options can be changed for this Project only. 
Changes made on this screen will not override the existing defaults.

 3. If you would like a customer name displayed on the report, select the appropriate customer from 
Mailing on Behalf Of. Customers displayed here were set up under Settings > System 
Configuration and Options > Customer List.

When you have completed setting your options, select OK to process your Project.
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Updating records in your database with move 

information
Processing your Project against Canada Post’s National Change of Address (NCOA) service will allow 
you to update recipients who have moved. If your record matches the NCOA database, the address 
will be updated, if an updated address is available, or marked as a nixie if the updated address is not 
available.

IMPORTANT: Prior to processing, you must have EITHER a valid Canada Post End User Terms of 
Use ID number for your company OR a valid Service Provider Terms of Use ID for your company 
PLUS a valid End User Terms of Use ID for your customer. To receive a Service Provider or End User 
Terms of Use ID number, you must have or create an account at www.canadapost.ca/ncoa then agree 
to the appropriate terms of use.

IMPORTANT: Your file must have been run through correction/validation or validation-only to enable 
the NCOA processing option.

IMPORTANT: You must have sufficient NCOA credits in your account to process your file. You will 
require the same number of credits as records in your Project. Please speak with your StreetSweeper 
Pro sales representative to purchase NCOA credits.

IMPORTANT: StreetSweeper Pro NCOA processing includes the option to run your file against a non-
Canada Post database of deceased individuals. This option is included in your NCOA credit.

 1. Ensure you have run correction/validation or validation-only on your Project.
 2. Select NCOA > Process NCOA.
 3. Verify that name fields have been appropriately identified. NCOA processing requires an 

individual’s first and last name or a company name.
 4. Using the dropdown under Options, select the End User associated with this file.
 5. Check the Run Deceased button if you wish to process your file against this additional 

database.
 6. The default option is to have all matching records updated and all nixies and deceased records 

purged automatically after processing. If you prefer to see the results prior to purging, uncheck 
Purge NCOA under Options.

 7. Select Proceed to start NCOA processing.

Setting default presort options
StreetSweeper Pro has default presort settings. These settings can be customized to your needs.
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 1. Select the Settings icon then Settings > System Configuration.

 2. Select the Options tab.

 3. Set one of more of the following options: 
 l Break String On: select if the break indicator should appear on the first piece, last piece, or 

both the first and last piece of the project’s bundles, containers, or pallets.
 l Bundle string: “*” is used as the default. To change this, enter another character.
 l Container string: “*” is used as the default. To change this, enter another character.
 l Pallet string: “P” is used as the default. To change this, enter another character.
 l City string: “!!” is used as the default. To change this, enter another character.
 l  Container/Bundle column add bundle breaks: the default is to include bundle breaks on 

your print file. If you do not want bundle breaks, check this option.
 l OEL stars on front and end of bundle: the default is for OEL stars to only be added to the 

front of a bundle. to add OEL stars at both the front and end of a bundle, check this box.
 l OEL Number of stars: the default is 2 stars. To change this, enter another number.

 4. Select Update to save your changes.

Presorting your project
The presort process will prepare your mailing to be eligible for postal discounts.

 1. Select Presort > Presort. If you are using a saved Profile, select using the drop-down above 
the Save and Delete buttons.

 2. Using the calendar tool under Drop Date, enter the day you intend to bring the mail to a Canada 
Post depot.
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 3. If applicable, select the appropriate customer or enter the customer’s account and contract 
numbers manually. Clicking the + button will allow you to enter new customer information 
directly from this screen.

 4. Using the checkboxes, select which types of addresses you want to include in the presort. If the 
box is not checked, these addresses will be flagged as uncoded.

 5. Select Additional Options, as appropriate.
 6. Using the drop-down, select the Residue Office. This is Canada Post depot that you will be 

taking the mail. If the depot is not listed, you can use the + button to add the location.
 7. Select your Mail Type from the drop-down.
 8. Select your Piece Size from the drop-down. The container type will be automatically selected 

based on the piece size.
 9. If you will be using pallets or monotainers, select the appropriate option. If you will be brick 

piling, check this box.
 10. Enter in the Measurements of your mail piece. The bundle and container maximums are 

calculated based on the piece weight and thickness. These values can be adjusted if required.
NOTE: Length and width are only required if you are brick piling.

 11. If you wish to save these specifications as profile, click Save under the Profile drop-down.
 12. When you are satisfied with the options, click Proceed to process your project.

 13. When the presort is complete, your Mailing Summary will appear on screen.
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Exporting your presort print file
After presorting your Profile, you can export the results for printing. If required by Canada Post, this 
process will also create the Mailing Plan for uploading into Canada Post’s shipping tools.

 1. Select Presort > Export Presort.

 2. Choose the fields you wish to have exported in your file by checking the appropriate boxes 
under Select Information.

 3. Choose the type of records to include in your export file by selecting the relevant status codes in 
the Filter Records By box. Uncoded records (foreign or with a missing or invalid postal code) 
can be excluded from the file by checking the Exclude Uncoded box.

 4. If you wish your file to be exported in presort order, ensure the Presort Sequence box has been 
checked under Presort Data.

 5. Select the format of your export file using the drop-down under Output Format. If you wish to 
export duplicate fields, ensure Output Duplicate Fields is checked.
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 6. When you are satisfied with the options you have selected, select OK. Choose an output folder 
and filename to save your file.
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