This product contains the Regex++ library
Copyright © 1998-2000
Dr. John Maddock

PostScript is a trademark of Adobe Systems Incorporated.
PCL is a trademark of Hewlett Packard Company.

ICU License - ICU 1.8.1 and later
Copyright (c) 1995-2006 International Business Machines Corporation and others
All rights reserved.
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, provided that the above copyright notice(s) and this permission notice appear in all copies of the Software and that both the above copyright notice(s) and this permission notice appear in supporting documentation.

Otherwise all product names are trademarks or registered trademarks of their respective holders.
Contents

ABOUT THE CONTENT AUTHOR CLIENT ........................................ 7
  User accounts and passwords ............................................. 8
  Time-out ........................................................................ 8
  Installing the Content Editor ............................................ 8

WORKING WITH MESSAGES .................................................. 9
  Projects and folders .......................................................... 9
  Message areas .................................................................. 9
  Languages ........................................................................ 10
  Creating and editing messages .......................................... 10
  Submit for review ............................................................. 11

Managing Message Properties .............................................. 13
  Signals ............................................................................ 14
  Priority .......................................................................... 14
  Sampling rate .................................................................. 15

Specifying Effective Dates ................................................ 15

Using Conditions .............................................................. 15

Attachments ...................................................................... 18

Previewing ......................................................................... 19

Reports .............................................................................. 20

ABOUT THE CONTENT EDITOR ............................................ 21

Editing features .................................................................. 22
  Menus and toolbars .......................................................... 22
  Measuring and positioning aids ....................................... 23
  Selecting text and graphics ............................................. 24
  Using the clipboard ......................................................... 24
Contents

Undo and redo ................................................. 24
Find and replace ............................................ 25
Boundary indicators ........................................... 25
Keyboard shortcuts ............................................ 25

Creating paragraphs ......................................... 27

Entering and formatting text ................................ 27
Right to left text entry ....................................... 28
Default editor font ......................................... 28
Changing the language mapping ......................... 29
Formatting marks ............................................. 29
Hyphenation ................................................. 30
Spell checking ............................................... 30

Positioning text .............................................. 31
Paragraph alignment ........................................ 31
Spacing ....................................................... 32
Indentation .................................................. 33
Tab stops ...................................................... 34
Rotating text ................................................ 35

Bullets and numbering ....................................... 36

Importing paragraph content .............................. 37

Data fields .................................................... 37
URL links ...................................................... 38

Working with graphics ....................................... 40

Anchors and positioning .................................... 40
Co-ordinates and dynamic positioning .................. 41

Drawing shapes .............................................. 41
Using images ................................................ 42
Contents

Text boxes .................................................. 43
   Rotating text ........................................... 44
Selecting and adjusting graphics .......................... 44
   Moving and resizing ................................... 45
Layout ...................................................... 48
   Runaround margins .................................... 49
Order of graphics ........................................ 49

USING TABLES ........................................... 50
   Table positioning ...................................... 51
   Editing tables ......................................... 52
   Borders and shading .................................. 53

THE REVIEW PROCESS .................................. 54
   The Review Cycle ...................................... 54
   Reviewing messages ................................... 55
      Tips on reviewing .................................... 56
      Comment History ..................................... 57

INDEX ..................................................... 58
About the Content Author client

The Content Author client is used for creating, maintaining and reviewing messages that provide dynamic content for publications produced by Designer.

Content Author is a web client that runs in your local browser. Authors, reviewers and readers use the same client although the views that are available will depend on the roles you are assigned.

To launch Content Author: enter the URL provided by your Content Author administrator into your web browser and the logon screen will be displayed. Enter your user name and password.

You can change your login password.

A Content Author session will automatically time out after a period of inactivity but it is recommended that you explicitly log out when required.

The tabs shown depend on the roles assigned to you.

Message filter
The list can be filtered to show a subset of messages. Choose your selection and press Search.

Click on a message name to open it or hover to select other view options.

By default the Messages list is sorted by project, folder and message name. Click on a column header to sort another way.

Ten messages will be shown per page by default. When there is more than one page, you can change this by hovering over the Displaying 10 rows message and selecting a different number.

You can change your login password.

A Content Author session will automatically time out after a period of inactivity but it is recommended that you explicitly log out when required.

The tabs shown depend on the roles assigned to you.

Message filter
The list can be filtered to show a subset of messages. Choose your selection and press Search.

Click on a message name to open it or hover to select other view options.

By default the Messages list is sorted by project, folder and message name. Click on a column header to sort another way.

Ten messages will be shown per page by default. When there is more than one page, you can change this by hovering over the Displaying 10 rows message and selecting a different number.
User accounts and passwords

The Content Author administrator is responsible for creating user accounts and the roles and permissions they identify. Your account will be assigned an initial password that you can change at any time. Contact your administrator if you forget your password or believe you need different levels of access.

To change your password: select the Change Password option at the top of the Content Author home page. You will be asked to enter your existing password and then enter and confirm your new password. Click Change to save the password.

Time-out

By default a time-out is specified for Content Author which will disconnect you from your session after a long period of inactivity. In order to continue you will need to log in again. If you were currently editing a message any changes you made will be preserved locally and restored once you login again, but you should save them at the earliest opportunity.

Installing the Content Editor

The Content Editor is the part of Content Author that allows you to work with actual messages. If your installation was configured to install this as an ActiveX control, then you will be asked to install it on your computer when you first create or view a message. You may also be asked to install the control when the component has been upgraded on the Content Author server.
Working with messages

A message is the basic design object of the Content Author environment. It is a segment of page content intended to be placed within documents composed by Designer.

Messages are created and maintained by authors within a framework set up by the Content Author administrator. This includes the projects and folders to which messages are added and the message areas for which messages are targeted. The administrator may also create preview applications to allow you to see how your message will look in the context of the intended document design. Readers can view messages – their content and attributes, but cannot edit or change them.

Projects and folders

Messages are always created within a project structure created by an administrator. A project is made up of one or more folders that contain the actual messages.

Projects are typically used to organize messages according to the main Designer publications they will be used with. For example you might have projects for “Travel Insurance Renewals” or “Savings Account Statements”. Folders typically group messages according to the same theme or project phase. For example, you might have folders for “Loyalty Scheme” or “Winter Campaign”.

Work with your administrator to understand the projects and folders you need to use.

Message areas

Message areas represent reserved space in document designs for which messages are scheduled for inclusion. They can be thought of as rectangles that define the maximum size of an individual message.

Messages occupy the entire width of the message area but not necessarily the entire height. Simple document designs may have a single message area to which a range of full size messages are conditionally applied. More complex designs may allow for a range of messages to be placed one after another in a single area until the available height is used up. A document design may also have more than one message area and you may be able to target a particular message at any or all such areas. Messages may also be inserted directly
Working with messages

into the main flow of the document, where they will not be restricted to dimensions of the message area but will be the same width as the rest of the text. You will need to work with the administrator to establish the appropriate area for your message and its optimum size.

Languages

A message’s language attribute is an additional selection criteria that may be used by some Designer publications to select only those messages suitable for a particular language. The language specified for the message is compared with the active Locale within the main application and the message can only be selected where there is a match.

Creating and editing messages

Before creating a new message you must be aware of the project and folder to which the message needs to be added, the message areas to which it should be scheduled and, optionally, the language attribute to be applied to the message. Other attributes can be specified later.

To create a new message:

1. From the Author view in Content Author select New Message.

2. Select the Project and Folder you want the message to be included in and at least one Message area. Note that you may only be allowed to select a single message area depending on restrictions defined by the administrator. If required select a Language from the drop-down list. The message will then only qualify for inclusion when the Designer system locale uses that language. You can also enter a Comment as required.

3. Click Create to open the message in the editor.
Working with messages

To work with an existing message: click on a message name in the Content Author home page. The Content page is loaded by default;
– or –
hover over a message name in the Content Author home page and select the page you initially want to work with.

To save a message: in the editor, select the Save option;
– or –
use the Save as option to save the message with a new name. Changes made since the message was last saved will only be in the new copy.

To copy a message: hover over the message name in the Content Author home page and select Copy. Enter a new name for the copy and, if appropriate, choose whether to include its attachments.

To delete a message: click on the required message in the Content Author home page to open it in the editor. Select the Delete message option and confirm the deletion.

Submit for review

When a message is created or amended the author must submit it for review. Before a message can be deployed for production it must be approved by all the reviewers assigned by the administrator to the project to which it applies. You can see who the reviewers for a particular message are on the Details page of the content editor.

If a reviewer denies a message the review cycle is stopped and the author is informed by e-mail.

For full details of the review and approval cycle see “The Review Process” on page 54.
To submit a message for review: in the Content Author home page open the required message in the editor and select the Submit for review option.

Reviewers are informed by e-mail when a review is required. You can track the review process using the History tab for the message.
Managing Message Properties

After a new message has been added you can use the Details tab to add or amend the message properties. Note that certain message properties such as Mandatory, Sampling Rate, Signals etc. may not be available depending on restrictions defined by the administrator.

To work with message properties: click on a message name in the Content Author home page to load it into the content editor then click the Details tab. Specify the properties as required. See the following sections for details.

<table>
<thead>
<tr>
<th>Message</th>
<th>Priority Renewals</th>
<th>Status</th>
<th>Draft</th>
<th>Projects</th>
<th>Travel Insurance Renewals</th>
<th>Folder</th>
<th>Loyalty Scheme messages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Created on 17/05/2007 by Admin</td>
<td>Last Modified on 17/05/2007 by Admin</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Message</td>
<td>Priority Renewals</td>
<td>Revision</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Always Effective</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Start Date</td>
<td>21/02/2007</td>
<td>End Date</td>
<td>13/09/2007</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mandatory</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Priority</td>
<td>Urgent</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sampling Rate</td>
<td>0</td>
<td>Language</td>
<td>English (United States of America)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Message Areas:
- Warnings and Exceptions: Type = Single Use, Width = 10.01cm, Height = 10.01cm
- Special Offers: Type = Single Use, Width = 5.08cm, Height = 5.08cm

Signals:
- Name: HP try 4, Description: Use headed paper
- Remove

Comment:
This message will only be shown when the

Reviewers: Sue, Ted

NOTE THAT A READER CAN VIEW MESSAGE PROPERTIES BUT CANNOT EDIT OR CHANGE THEM.

Comments are local to Content Author—they are not passed to Designer with the message.

You can also amend the Name, Language and Message Area that were specified when the message was created.

Any signals applied to the message are listed here. You can add more if available or remove them.

The reviewers list indicates the people who are scheduled to take part in the review process for the project the message has been created in.
Signals

A signal assigned to a message is an indication to Generate to perform a set of actions as specified in the Designer when that message is placed in a document. For example to use headed paper from a specific input tray on the printer. Provided that signals are available for a message, you can add more than one to a message and the same signal can be assigned to more than one message. The name and description indicate what the effect of the actions will be. Contact your Content Author administrator for more information.

Note that you can only add and remove signals if the message status is draft or not approved.

Priority

Messages are selected for inclusion in specific documents according to a range of criteria – most notably conditions. At production run-time several messages may be valid for the same message area in a particular document. In such circumstances the priority of the message determines the order in which the Designer publication will attempt to place messages in the space available.

The priority categories that are available are determined by the Content Author administrator. There will always be a Default priority which is automatically assigned to new messages unless you change it. This indicates the message has no particular priority requirement and will be selected after messages with specific priorities have been dealt with.

To set the message priority: when editing a message, select the Details tab and choose the required priority level from the Priority list.

Mandatory messages

Messages can also be defined as Mandatory which indicates that the message must always be included in any document for which they are valid according to selection criteria. If a mandatory message cannot be placed in a document for which it is valid Generate will take the action defined by the administrator. Use this setting with care: by default the application will abort at this point although other options are available.

To make the message mandatory: when editing a message, select the Details tab and select the Mandatory option.
Sampling rate

The sampling rate restricts the maximum number of times an individual message may be included in any single production run of a publication. For example, if the sampling rate is set at 500, the message will be included for a maximum of 500 times only, even if the rules and conditions allow the message to be included more than this. This may be useful for instance, where you want to limit the number of times a particular offer is made to your customers. The default rate is 0, meaning there is no restriction.

Specifying Effective Dates

It may be important to specify the dates between which a message is valid and can be included in documents. For example, if the message includes details of a special offer there may be an expiry date for the offer. In this case it is important that the message is not included in a production run after the offer has expired.

When a message is created, by default, no such date restrictions are applied.

To set effective dates:

1. While editing a message, select the Details tab.

2. Select Always effective if you require the message always to be included in production runs, disabling the Start Date and End Date.
   – or –
   enter the required dates in the Start Date and End Date fields – in the format dd/mm/yyyy – or click in either data field and use the calendar to select the dates.

Using Conditions

Messages are selected for inclusion in specific documents according to a range of criteria. Some criteria are generalized such as where the language attribute or effective dates are used. Where you want to use specific criteria you will need to include one or more conditions in a message.

Note that a reader can view conditions but cannot edit or change them.
Conditions can be used either specifically to select a message for inclusion or specifically to exclude it. An individual message can contain multiple Select-if or Exclude-if conditions. You can choose if the action applies when either one or all conditions are satisfied in each category. If both Select-if and Exclude-if conditions are specified for a single message Exclude-if will win if both categories are satisfied.

Each condition must include one or more comparison statements that compare the value of a particular data field with another value. For example, you may have a comparison that looks for the string "South-East" in the Area data field or where Balance field has a value greater than 100. Where multiple statements are coded you can choose whether any or all of the comparisons must be satisfied for the condition to be true.

The administrator may have applied pre-defined global conditions to the project you are working on. Additionally the administrator may also flag one or more such conditions as Auto which means they are automatically applied to all messages within the project. Where this is not the case you may choose to apply such conditions as required or create new ones.

To apply existing conditions to a message: while editing a message select the Conditions tab. The available conditions are listed for both the Select-if and Exclude-if categories. Check the conditions you want to use with the message. Note that ‘auto’ conditions are automatically selected.

To create a condition:

1. While editing a message, select the Conditions tab.
2. In either the Select-if or Exclude-if category click Add New Condition.
3. Add comparisons.

In the Comparisons section click Add New Comparison. Complete the dialog fields. Repeat for other comparisons if required.
Global indicates conditions pre-defined by the administrator. Auto indicates global conditions that are always applied to messages in this project.

Where multiple conditions are used in a Select or Exclude category indicate if All or Any must be true.

Conditions and comparisons that are not global can be deleted.

Where multiple comparisons are used indicate if All or Any must be satisfied for the condition to be true.

To view the details of a comparison click the summary.

Adding a new comparison:

<table>
<thead>
<tr>
<th>Left Operand</th>
<th>Operator</th>
<th>Right Operand</th>
</tr>
</thead>
<tbody>
<tr>
<td>Age</td>
<td>&gt;</td>
<td>18</td>
</tr>
</tbody>
</table>

Comparisons For Condition 'New Condition'

<table>
<thead>
<tr>
<th>Left Operand</th>
<th>Operator</th>
<th>Right Operand</th>
</tr>
</thead>
<tbody>
<tr>
<td>Amount Paid</td>
<td>=</td>
<td>Balance</td>
</tr>
<tr>
<td>Data Field</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Constant</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Amount Paid (Number): 0.99999999

17
Attachments

An attachment is a message that is associated with another ‘parent’ message. Attachments keep associated messages together within the Content Author review cycle and ensure that they only appear when their parent is placed in a document. For example, you may want to use attachments where you have a range of messages containing the text of terms and conditions relating to a special offer but you only want one of these to appear in a document when the offer to which they relate has already been placed.

It is important to note that the attachment attributes themselves do not guarantee that the attached message will appear when its parent is selected or be within the same message area. An attachment must have message areas assigned in the normal way and is subject to regular selection criteria including conditions, priority, language, and so on. You must ensure the criteria permit an attachment to be selected when its parent is placed in a document.

An attachment differs from a regular message in the following ways:

- An attachment will only be selected for a document when its parent has already been placed.
- The effective dates and sample rate attributes are assumed to be the same as the parent unless these are specifically defined for the attachment.
- The effective date of an attachment must be within the range specified for its parent (the actual range specified for the attachment may be different provided it is within this range).
- In the production system attachments will be selected ahead of other messages with the same priority.

Additionally a parent record differs from a regular message because:

- It cannot be approved while any of its attachments are in review.

Messages can have one or more attachments associated with them, and more than one message can use the same attachment. Both message and attachment must be in the same project folder. An attachment cannot itself have an attachment.

To list and work with attachments for a message: while viewing or editing the message click the Attachments tab.

To attach the message to other messages: click Add as attachment, and select the required messages from the Attachments window and click OK.

To attach the message to a new message: select Add as attachment to new message to create a new parent message. The new message will be loaded in the editor. The original message will automatically be attached to the new message.
To add attachments to the message: click Add attachment. The Attachments window will list available messages that can be used as attachments. Select the messages you want to attach and click OK.

To create a new attachment for the message: click Add new attachment. The new attachment message will be loaded in the editor and will automatically be attached to the original message.

Previewing

You may be able to preview message content within the context of sample output from the Designer publication for which it is intended. This option is only available when the administrator has previously set up a preview application suitable for your project. You can, if required, use the conditions associated with the message as part of the process but note that this may result in the message being excluded in some sample documents.

A message preview should produce one or more PDF files each containing a document output by the application. The number of documents is determined by the sample data assigned by the administrator.

To preview a message:

1. While editing a message select the Preview Message option.
2. Choose the application you want to preview from the list.
3. Choose whether or not to process the conditions associated with the message and whether to include all messages from the same folder.
4. Click Preview. When they are ready the preview documents will be listed for you to open in Adobe Reader.
Reports

Reports can be generated that list messages in specific review states and categories. Only messages that are in the projects to which you are assigned will be included in the report.

**To generate a report:** in the editor click the Reporting tab and select the type of report you require from the list. Then select the criteria you want for the report and click View Report. The report will be generated and displayed in the Message Report Viewer window.

You can export and save the report in various formats … … and print it.

Search for any text in the report … … and refresh the screen.
About the content editor

The content editor is where the actual messages that will appear within document pages are viewed and designed. It includes standard text editor features plus some tools that deal specifically with messages. Authors can edit more than one message at the same time – each will appear in a separate window. The layout of the menus and toolbars can be customized to some extent. Readers can only view messages and their attributes; they can’t change them in any way.

A message can contain text and graphics, and the size of the workspace in which you create it represents the size of the message area that has been selected for the message. Where multiple areas are selected the largest width and height is represented. Remember that document designs often expect more than one message in a message area so while your message will always occupy the entire width of the area it does not necessarily have to occupy the entire height.

Note that not all editing features may be available to every author.

Borders and shading

Borders and shading can be applied to a message area but note that this will force the message to occupy the height of the entire area.

To apply borders and shading to a message area: on the Format menu select Borders and Shading.

To zoom in or out of the edit area: from the View/Zoom menu and select Zoom in or Zoom out. You can also change the zoom percentage in the toolbar.
About the content editor

Design Resources

Resources such as fonts, images, data fields and so on must be added to the Content Author repository by an administrator before they can be used with messages. Content Author also provides administrators the ability to restrict the design resources that can be used with messages in particular projects and folders. Such restrictions are referred to as a domain and are often used to ensure a common style across messages and the overall document design.

Editing features

The editor provides standard editing features that enable you to view and to create messages. The menus and toolbars give you access to all the editing options. The layout of these can be customized to some extent.

Text and graphics can be copied and moved by selecting it and using the clipboard as a temporary store for it. If you make a mistake when editing, you can retrace your steps using the undo and redo options.

Menus and toolbars

The menu gives you access to most of the editor functions and commands. You will also be able to access many of these using the toolbar buttons or keyboard access keys, both of which will be shown on the menu. Note that you may have to press the <Alt> key in order to see the access keys.

Buttons are grouped together into a range of separate toolbars that cater for a particular group of editor functions. You can hide toolbars that you don’t need to work with to simplify the layout, or to make more space for the editor window. For instance, if your design does not include any shapes you may want to hide the drawing toolbar. You can also move the toolbars in relation to one another to suit your own style of working.

To hide or display a toolbar: on the View menu click Toolbars and then clear or select the relevant toolbar check box.

To move a toolbar: drag its docking bar to a new position.
Measuring and positioning aids

You can customize the unit of measure (UOM) used by the editor to suit your requirements. The UOM specified is used in rulers and coordinate displays.

The preferred UOM is also used as the default in dialogs that require a measurement although you can override this as required. You can specify a different UOM simply by adding one of the following abbreviations after the number.

<table>
<thead>
<tr>
<th>UOM</th>
<th>Specify</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>inches</td>
<td>in</td>
<td>2.1 in</td>
</tr>
<tr>
<td>centimeters</td>
<td>cm</td>
<td>1.2 cm</td>
</tr>
<tr>
<td>millimeters</td>
<td>mm</td>
<td>32 mm</td>
</tr>
<tr>
<td>points</td>
<td>pt</td>
<td>12 pt</td>
</tr>
<tr>
<td>picas</td>
<td>pi</td>
<td>2 pi</td>
</tr>
</tbody>
</table>

The on-screen rulers help you with positioning objects accurately. The top ruler is also used when setting tab stops and indents for paragraph text. You can turn off the ruler display if required by using the View/Ruler option.

You can also use the grid to help with placement. You can set the grid size to your preference and optionally have graphics snap to grid intersections when you are creating or moving them.

To set all grid, ruler and UOM preferences: from the Tools menu select Options and apply settings as required.

To override ruler settings and UOM: right-click on the ruler and select from the drop-down list.

To turn the grid on and off: click on the Toggle Grid button – or – on the View menu click Grid.
About the content editor

Selecting text and graphics

When you want to move, delete, or overwrite design elements you must first select what you want to work with. You can do this either by using the mouse or via the keyboard, refer to “Keyboard shortcuts” on page 25 for further information.

To select text and graphics using the mouse: use one of the following shortcuts:

- Anything: drag across it from beginning to end.
- A word: double-click in it.
- A paragraph: triple-click in it.
- Start a selection: click at start of selection.
- End a selection: hold down SHIFT and click at end of selection.

To cancel a selection: click anywhere else on the page or press any arrow key.

To delete selected elements: use the Delete key on the keyboard or click Clear from the Edit menu.

Using the clipboard

You can copy, cut and paste design elements using the system clipboard. This is an easy way of transferring content both within the editor and to and from other applications. refer to “Keyboard shortcuts” on page 25 for further information.

Undo and redo

If you create, edit or format a design element by mistake, you can reverse the action by using the Undo command. Similarly, if you undo an action by mistake, you can use the Redo command to switch back again. You can undo actions progressively, each time restoring to the state before the previous change was made, up to a limit of 10 previous actions.

To undo an action: click the Undo button – or – on the Edit menu click Undo. Note that the action that will be canceled is shown in the Undo command.

To reverse an undo action: click the Redo button – or – on the Edit menu click Redo. Note that the action that will be reversed is shown in the Undo command.
Find and replace

You can search and make changes to text, fonts and data fields in a message by using the find and replace feature. You can replace specific instances or change every occurrence within the message. Note that not all features may be available to every author.

To find and replace: from the Edit menu select Find and Replace. Select the relevant tab to search for text, fonts or objects.

Boundary indicators

You can optionally choose to show the outline of layout areas such as text boxes, address blocks, charts and so on. Boundaries are indicated by a grey outline around the layout area.

To switch boundaries on and off: click the toolbar button – or – from the View menu choose Show Boundaries.

Note that by default boundaries are switched on.

Keyboard shortcuts

You can use keyboard shortcuts to move the focus to a frequently used menu option or command without using the mouse. This section lists the keyboard shortcuts available in the content editor.

To access toolbar options:

Select magnification from the zoom box: CTRL+SHIFT+Z
Select font size from the size box: CTRL+SHIFT+P
Select the font from the font box: CTRL+SHIFT+F
Select text color options: CTRL+SHIFT+C

To exit from the toolbar controls, press the “Esc” (Escape) key.
About the content editor

To select paragraph design elements:

- A character to the right: SHIFT + →
- A character to the left: SHIFT + ←
- A line before: SHIFT + ↑
- A line after: SHIFT + ↓
- To end of line: SHIFT + END
- To beginning of line: SHIFT + HOME
- All: CTRL + A or on Edit menu click Select All

To use the clipboard:

- Copy selected text and graphics onto the clipboard: on Edit menu click Copy or press CTRL+C
- Move (i.e. copy and delete) selected text and graphics onto the clipboard: on Edit menu click Cut or press CTRL+X
- Paste contents of the clipboard into the message: on Edit menu click Paste or press CTRL+V
- Paste contents of the clipboard, such as content from a spreadsheet or PDF into the message: on Edit menu click Paste Special. If applicable, select the format you want to use to paste the contents and click OK.

To navigate through browser frames:

- Move to Next Frame: F6
- Move to Previous Frame: SHIFT + F6
Creating paragraphs

Entering and formatting text

Paragraphs are created simply by typing with the insertion point positioned in the message. A new paragraph is automatically created when you press the return key. You can also create new paragraphs by double-clicking in any open space below the previous paragraph in the message.

Text will automatically wrap onto new lines when the available width is exceeded, using hyphenation when specified, although you can force particular text strings to be kept together on the same line if required. Pressing the Shift and Return keys together forces a new line without creating a new paragraph.

When you start typing, the text is created using the active format – the font being used, its style, color and so on. You can change the format at any time or amend the format of existing text as required. Note that when you move the insertion point into existing text, the current format will be picked up from the text to the right of the insertion point. You can, of course, change the format before typing. Note that not all features may be available to every author.

Text attributes are normally specified using the text formatting toolbar. Note that you can specify a global default font – see “Default editor font” on page 28.

Changes to the formatting of text will be applied to any highlighted text, or, if none is highlighted then to any new text that is entered at the insertion point.

To show the text formatting toolbar: select View/Toolbars/Text Formatting from the menu.

To adjust the formatting of text: highlight the text to be changed and either use the text formatting toolbar options – or – on the Format menu click Font. This will invoke the Font dialog box where you can format the selected text.

To stop a line breaking at a space: use Shift+Ctrl+Space to insert a non-breaking space character.
Creating paragraphs

To keep text together: highlight the relevant text and on the Edit menu select Keep together

- or -

use the Keep together button on the text formatting toolbar.

This replaces all spaces with non-breaking spaces to keep as much of the text as possible on a single line. Hyphenation will not be applied. Note that the keep together attribute will remain in force and be applied to all new text until specifically cleared.

Right to left text entry

The default direction of paragraph text is determined by the active Windows input language (see “Changing the input language” on page 28). This is generally left to right, but for languages such as Arabic, would be right to left.

When the direction is right to left, text is entered using the keyboard in the same manner as if typing left to right text. Paragraphs can include bidirectional text and you must ensure that the direction of the paragraph is correct.

To set the direction of a paragraph to right to left: invoke the corresponding Paragraph dialog box. Under Presentation set the alignment as required and the direction to right to left.

- or -

use the Right-to-left button on the Text formatting toolbar.

Default editor font

The editor's default font is used for text entered in messages. The default font is set using the Options dialog box and enables you to choose the font, point size etc.

You can use the formatting toolbar to change font attributes without affecting the default font. Changes made to the default font do not affect the text in existing messages.

To change the default font: select Tools/Options. Click the Edit tab and choose the required font.

Changing the input language

The input language controls how characters will be mapped to the font used within an output datastream – i.e. the code page to be used. Normally the intended language of text is automatically assumed from the active Windows input language when characters are entered. In some exceptional circumstances this may not be the case and you will need to set the intended language for specific text. You can use the Unicode Language option for complex scripts and languages that do not map to a standard Windows character set.
To set the language of existing text: highlight the text you want to change and select Tools/Set language. Select a supported language and click OK.

Changing the language mapping

Normally the default encoding for an input language is sufficient. However, there may be situations when you may want to change that encoding, for instance to view a field from a data format that uses a different encoding scheme to the one used by the publication. This option is only used for viewing content in the Content Editor and is done to prevent the Windows operating system from automatically substituting fonts in a publication.

An additional option is available for changing the language mapping when text is entered in the Content Editor using a Windows Input Method Editor (IME). If this option is selected when characters are entered into a message using the IME, the characters displayed in the message will use the mappings that correspond to the custom code page in the Designer and not the character set associated with the language and font of the IME.

To change the language mapping:

1. Select Tools/Options and select the Language/Encoding mapping tab.
2. Select the language you want to change and click Modify.
3. Select the code page you want to use from the Encoding list and click OK.
4. The new mapping is now displayed in the Options dialog box. Click OK.

To use custom code pages for keyboard entry: select Tools/Options and select the Language/Encoding mapping tab and click the Use custom code pages for keyboard entry option.

To reset the language mapping: select Tools/Options and select the Language/Encoding mapping tab and click Reset All.

Formatting marks

Formatting marks are non-printing characters that indicate controls within paragraphs such as end markers, spaces, tab characters and so on. Displaying them shows you exactly what you have typed and can help to highlight layout problems, for example, where you have
Creating paragraphs

typed several spaces rather than a tab character. Hiding them shows you more how the finished message might look. Even if formatting marks are showing, they will not be in the final output.

**To show/hide formatting marks:** click the Formatting Marks button or select View/Show all Paragraphs to switch them on or off.

**Hyphenation**

The Designer document in which messages are to be placed may have hyphenation switched on and this will automatically be applied to the messages as they are included by Designer. However you can override this for any paragraph in the message. Note that hyphenation is not shown in the editor but may be seen when previewing the message – see “Previewing” on page 18.

**To turn off hyphenation for a specific paragraph:** select the relevant paragraph and on the Format menu click Paragraph. In the Presentation section of the Paragraph dialog box select the Don’t hyphenate option.

**Spell checking**

Spell checking is performed using the dictionary associated with the language of the text. You can change this dictionary if required to use a specific variant of the language – subject to your license keycode.

If text is selected, then only this will be checked, otherwise, all text will be checked. You can customize the way the spell checker works by changing the spell settings – for instance, whether to check abbreviations, whether to remember previous changes.

**To run the spell checker:** on the Tools menu select Spell check.

**To change the spell settings:** on the Tools menu select Spell settings and change the settings as required. Click Dictionaries to change the dictionary used for specific languages.

**To change the language:** on the Tools menu select Set language and choose the required language. This will be used for the selected text. or, if none is selected, for the complete message.
Positioning text

Paragraphs are positioned in relation to one another and the edges of the message area. You can customize how they are aligned (or justified) between the left and right edges, any indentation to be used from those edges, the line spacing within individual paragraphs and the gap required between adjacent paragraphs.

Tab stops can also be used to align text within a paragraph.

Paragraph alignment

Paragraphs are aligned between their left and right indentations – shown as on the ruler. Alignment is applied to the whole paragraph, so if you want a different layout for certain lines, you must create a separate paragraph for them.

To align a paragraph: use one of the following buttons on the Text Formatting toolbar:

- Left
- Centered
- Right
- Justified
- Fully justified

– or –

on the Format menu click Paragraph. In the Presentation section of the Paragraph dialog box set the required Alignment option.
Spacing

You can specify both space before and after a paragraph, and space between lines within a paragraph.

For paragraphs you can specify both the amount of space to be inserted after the preceding paragraph, and the amount of space before the following paragraph. If consecutive paragraphs have conflicting ‘before’ and ‘after’ values then the greater value will be used – for example if two paragraphs have the space above set to 0.1” and the space after set to 0.2”, then the paragraph spacing will be 0.2”.

Line spacing determines the space between the lines within a paragraph.

- **Single**: represents the standard amount of line spacing for the largest font in the paragraph. 1.5 lines and Double are increments of this default.
- **Multiple**: as for Single, but uses the value specified as a multiple of the line, e.g. 1.2 will increase the line spacing by 20%; 0.8 will decrease it by 20%.
- **At least**: lines will be spaced by at least the specified amount, but will be more as required by the content of each line.
- **Exactly**: lines are spaced using the specified value, regardless of the size of the content of a line.

Line spacing is measured from the bottom of the line upwards, so if you specify a value in At that is much larger than the font, the additional space is above the line. This can affect the gap between paragraphs as the paragraph spacing is applied in addition to line spacing.

Paragraph and line spacing should be used in preference to inserting blank paragraphs between text, as it gives more control over the overall layout in the message. For instance, if a paragraph doesn't quite fit you may be able to reduce the paragraph spacing and the line spacing so that it does – say by using Multiple to reduce the line spacing by a small amount, e.g. 0.7 of a line.

To adjust paragraph or line spacing: on the Format menu click Paragraph. In the Paragraph section of the Paragraph dialog box set the required Spacing options.
Creating paragraphs

Indentation

Paragraphs are, by default, positioned at the left and right edges of the message. However, you can specify a gap between these edges and the paragraph by applying indentation.

To indent a paragraph: move the left and right indent markers on the ruler to the required positions – or – on the Format menu click Paragraph. In the Indentation section of the Paragraph dialog box set the Before text and After text indentation.

Indenting the first line

You can indent the first line of a paragraph in relation to other lines it contains.

To indent the first line: move the first line indent marker on the ruler to the required position – or – on the Format menu click Paragraph and select First Line from the Special indentation drop-down list. Enter the amount to indent in the By field.

Hanging indent

A hanging indent is where all lines except the first one are indented. The hanging indent is measured from the left, or first line indent.
Creating paragraphs

To create a hanging indent: move the hanging indent marker on the ruler to the required position
– or –
on the Format menu click Paragraph. Select Hanging from the Special indentation drop-down list. Enter the amount to indent in the By field.

Tab stops

Any number of tab stops can be specified in a paragraph. They can be left, right, centered, or aligned on a character. A character tab will align on the first occurrence of the specified character. If this is not in the text, then a tab the same as the paragraph justification will be used.

If there are no tab stops specifically set in a paragraph, then, by default, tab stops will be set at regular intervals on the ruler. These will be the same as the paragraph alignment, e.g. right tabs in a right aligned paragraph.

<table>
<thead>
<tr>
<th>Tab selector</th>
<th>Tab stop</th>
</tr>
</thead>
<tbody>
<tr>
<td>☐</td>
<td>left</td>
</tr>
<tr>
<td>☐</td>
<td>centered</td>
</tr>
<tr>
<td>☐</td>
<td>right</td>
</tr>
<tr>
<td>☐</td>
<td>character</td>
</tr>
</tbody>
</table>
Creating paragraphs

To insert a tab stop: click the tab selector on the ruler until the required tab stop is shown. Then click on the ruler at the position where you want to place the tab stop. The tab stop will be inserted on the ruler – or – on the Format menu click Tabs. The Tabs page of the Paragraph dialog box will be displayed. Specify a tab stop and click Add.

To move a tab stop: either select the tab stop on the ruler and drag it to its new position – or – on the Format menu click Tabs, select the relevant tab stop from the list and enter the new position under Tab Stops/Position.

To modify an existing tab stop: on the Format menu click Tabs, select the tab stop from the list and change its Alignment, Character and Dot leaders as required.

To remove a tab stop: either select the tab stop on the ruler and drag it off the ruler – or – on the Format menu click Tabs, select the tab stop from the list and then click Remove, or click Remove All to delete all tab stops.

To remove all tab stops: on the Format menu click Tabs and then click Remove All.

To set default tab stops: on the Format menu click Tabs. Enter the interval between tab stops under Default Tab Stops.

Dot leaders

Dot leaders can be used between tab stops to help readability. When a leader is applied to a tab, a row of dots is inserted between the end of preceding text and the current tab stop. This is typical of table of contents and similar styles.

To insert a dot leader: on the Format menu click Tabs, select the tab stop from the list and tick Dot leaders.

Rotating text

Text can be rotated only when it is in a text box, see “Rotating text” on page 44 for details.
Bullets and numbering

Bullets or numbering can be applied to paragraphs if you want to emphasize them or to create lists. When they are applied the paragraph indentation will automatically be changed to suit. Numbering can be reset at any time back to ‘1’ and you can add a character to follow the number, for example, a dot. You can specify a different font (or font attribute) for the bullet or numbering character. By default, bullets use the ‘•’ character, but you can change this, if required, to a different character.

To set bullets or numbering: use the Bullet or Numbering toolbar buttons
- or -
on the Format menu click Paragraph and on the Numbering/Bullets page select the style that you want.

A hanging indent is automatically applied with a tab between the bullet/number and the text.

To format bullets and numbering:
on the Format menu click Paragraph and on the Numbering/Bullets page select formatting as required.

To turn off bullets or numbering: de-select the appropriate toolbar button.
- or -
on the Format menu click Paragraph and on the Numbering/Bullets page select None.
Creating paragraphs

Importing paragraph content

You can include RTF content created outside Content Author in your message. You can import the contents of an RTF file directly into your message, and also copy and paste the RTF – see “Using the clipboard” on page 24 for details.

The text, colors, tabs and justification used in the RTF are included when it is imported. Only fonts that are available in Content Author will be imported – otherwise the nearest matching font will be used. Images are not imported.

Text in RTF format may be slightly different depending on which application it was created by. Should you experience inconsistencies, open the RTF file in Windows WordPad and save it (as an RTF file). You can then import from this file.

To import RTF content: from the Insert menu select RTF. Browse to the RTF file and click Open.

Data fields

Data fields are inserted into the body of a message in order to customize messages and make them more personal at run time. For example, you may wish to include the customer's name in the message. A data field is a link to information in the Designer publication. The actual information will be substituted in the production environment.

Data fields are selected from a list of those that are available for the message, and inserted directly into the text at the current insertion point. They are displayed in a gray box. The data field name may have been truncated to provide a better representation of the actual length of the eventual data, for example, the data field 'Amount' could be truncated to 'Am', to represent a two digit number.
**Creating paragraphs**

**To insert a data field:** in the *Insert* menu click *Data Field*—or—click the tool button. Choose a data field from the *Message data fields* dialog box and click *Insert.*

**URL links**

URL links can be included in applications that are intended for web enabled output. If they are used in non–web enabled output then the display text or graphic is still shown, but the link will be inactive.

Strings and message data fields can be used for the URL link values. For information on data fields, see “Data fields” on page 37.

**To create a URL link:** in the *Insert* menu click *URL Link*—or—click the toolbar button. In the *Configure URL Link* dialog box specify the options for the link.

**To create a URL link for an image:** select the image and from the *Format* menu click on *Shape.* In the *Image* tab, select *Clickable image* and specify the options for the link. Use the *Alternative text* option to specify the tooltip. This text is also shown if the image cannot be displayed.

**To edit a URL link:** highlight or click in the URL and in the *Format* menu click *Field.* Change the options for the link as required in the *Configure URL Link* dialog box.
To test a URL link: hover over the link and hold down Ctrl and click the left mouse button. Your internet browser will start up with the URL in the address.
Working with graphics

In a message you can insert images and text boxes, or you can draw simple graphics using the editor's drawing tools. These are known collectively as shapes.

Text boxes are treated as graphics. The rectangle shape of a text box can be filled and given a border as for other graphics and it has the same controls for flowing into paragraph text. Unlike other graphics however, a text box is intended to contain other presentation objects.

You can control how graphics interact with paragraphs by specifying how text flows in relation to individual graphics and how much margin space is required where text flows around.

You are able to specify the order in which overlapping graphics are presented and can use the tools provided to align and space graphics in relation to one another.

Anchors and positioning

A graphic is always positioned in relation either to a paragraph or to the message area; this is known as its anchor. There are three different types of anchor – inline, anchored and fixed.

When a graphic is inserted it is initially anchored according to the type of graphic. When you move the cursor over the graphic the type of anchor used is displayed. You can change the anchors of individual graphics once they have been inserted.

The following anchor types are available:

- **In-line**
  Positioned as a character within paragraph text. Paragraph line spacing will be increased to accommodate the graphic, unless it has been set to an ‘exact’ value. In-line is the default for images.

- **Anchored**
  Positioned relative within the message flow. In the vertical plane the object is offset in relation to the previous paragraph or the top of the message if no paragraph exists. In the horizontal plane the offset is always in relation to the left side of the message. Anchored is the default for shapes, such as lines, rectangles, ovals and text boxes.

- **Fixed**
  Positioned at a specified offset in relation to the top left corner of the message.
To change the anchor type: select the graphic and from the Format menu select Shape. In the Layout tab under Flow select the required anchor type and click OK.

**Co-ordinates and dynamic positioning**

Graphics using anchored or fixed methods are typically positioned by dragging the object to the required position in the message or by specifying co-ordinates as constant values using the shape properties, see “Moving and resizing” on page 45 for details.

You can also use data fields to specify co-ordinates which means that the graphic can have dynamic offsets that differ from message to message.

To position using co-ordinates: select the shape and on the Format menu click Shape. In the Layout tab select the required unit of measurement. Choose the appropriate value object using the value option button for the X and Y offsets.

**Drawing shapes**

You can create simple graphics directly in the message by using the shape drawing tools. These include lines, rectangles and ovals. You can customize the line thickness, shading, fill color etc. used for such shapes. When you create a new shape the attributes of the previously created shape will be used. You can adjust these by editing the shape’s attributes once it has been created.

Graphics are, by default, anchored to a paragraph. However you can change this once the graphic has been drawn, see “Anchors and positioning” on page 40.

Note that some or all shapes may not be available to every author.

To draw a shape: click in the paragraph that you want the graphic anchored to and on the Insert menu select the required shape or click the appropriate toolbar icon. Click where you want to start drawing and drag out the shape to the required size. Note that holding down SHIFT while drawing will create a square, a circle, or a horizontal or vertical line.
To change shape attributes: select the shape in the editor and on the Format menu click Shape. Use the Attributes tab to set the required color, shading and line settings.

To change the corners of a rounded rectangle: select the rectangle and drag the internal handle. Both the amount and the shape of the curve will change.

Using images

Images can be inserted into a message area provided that the message area is large enough. The image is initially inserted at the insertion point as an in-line graphic but, as with all shapes, you can change its anchor type – see “Anchors and positioning” on page 40. If the image is too large for the message area you will be able to save the message but you will not be able to submit it for review.

An image can also be used as a URL link (for PDF, HTML and eHTML datastreams only) by selecting the Clickable image option. See “URL links” on page 38 for details.
To insert an image:

1. Click in the paragraph where the image is to be inserted.
2. From the Insert menu select Image – or –
click the Image button in the Objects toolbar.
3. Use the Open dialog box to select the image
you want to insert.

To change the image used: select it and from
the Format menu choose Shape. Select the Image
tab in the Image dialog box and enter or browse
for a different image.

Text boxes

A text box is used as a container for specific message content and can be drawn anywhere in a
message area. It can contain anything that a message can – text, images and so on – and you
can apply colored borders and shading to it. This allows message content to be placed at any
position in the message. Text boxes can be embedded within text boxes as shown in the
example.

The dimensions of a text box are as drawn. If
content does not fit you must resize the text
box appropriately. It is important to note,
however, that data fields can cause the text
box to overflow in production. Any content
that does overflow the available space will be
lost.

Text boxes are, by default, anchored to a
paragraph. This can be changed once the text
box has been drawn; see “Anchors and
positioning” on page 40.

To create a text box: click in the paragraph where you want the text box anchored and
from the Insert menu select Text Box
– or –
use the Text Box button in the Objects toolbar.
Drag out the box to the required size. A text box will be created with an empty paragraph. Enter
content as normal.
To change text box line and fill settings: select the text box and on the Format menu click on Shape. Use the Attributes tab to customize the settings. See “Drawing shapes” on page 41 for more information.

Rotating text

Only text that is inside a text box can be rotated – by 90°, 180° or 270°.

The text box itself will not be rotated, although it will adjust to cater for extra lines. However, you may need to resize it to the required dimensions once the text has been rotated.

To rotate text within a text box: place the pointer inside the text box and on the Format menu select Rotate Text – or use the Rotate button in the Text Formatting toolbar.

Selecting and adjusting graphics

In order to adjust a graphic, you must first select it. When it is selected, handles are displayed on the corners and sides of a bounding box. The pointer will indicate how the graphic is anchored.

You can also select an existing graphic from the dialog box, cycling through them in the order they were created. This means that when you have changed the attributes for one graphic, you can move on to another one and change it without closing the dialog.
Note that white handles indicate that the graphic is open for input, e.g. a text box is ready for you to type in. Black handles indicate that the graphic is just selected, and can be moved, or if appropriate, resized.

**To select a graphic:** click anywhere in the graphic or on its border.

**To select multiple graphics:** select the first graphic and then hold down SHIFT whilst you click the others

– or –

use the Select Objects toolbar button and drag across all the graphics, ensuring that you enclose them all completely.

**To view the next or previous graphic:** on the relevant shape formatting dialog box use the next or previous buttons.

**To select all graphics:** click the Select Objects toolbar button to turn the select mode on and on the Edit menu click Select All.

**To deselect a graphic when many are selected:** hold down SHIFT and click the graphic.

The handles will disappear from the graphic when it is deselected.

Moving and resizing

Graphics other than those using an inline anchor can be moved either directly within the message, or with precision using the settings in the dialog box. Graphics can be resized in the same way.

You can also align graphics to each other, or move them so that the space between them is evenly distributed.

**To move a graphic:** hover over the graphic and when the movement pointer displays, drag to its new position

– or –

select it in the editor and use the arrow keys to nudge it

– or –

select it in the editor and on the Format menu click Shape. Under the Layout tab enter the new position for the top left corner of the graphic. You can also use any object or function that supplies a value to specify co-ordinates to position the graphic, see “Co-ordinates and dynamic positioning” on page 41 for details.
To resize a shape: select the graphic and drag any of the handles to the new size. – or – on the Format menu click Shape. Under the Attributes tab enter the new Width or Height amounts as appropriate. If you enter a value of zero for the width or height of a line, then the line will become horizontal (width=0) or vertical (height=0).

Aligning

If you have several graphics in a message, you can line them up with each other. They can be aligned on their edges or so that the middle of each graphic lines up.

All graphics that are selected will be aligned with each other. They are aligned inside an imaginary box drawn around all the selected graphics, for instance, aligning graphics on the left will place them against the left of this box; aligning them in the center will align the centers of each graphic in the center of the box. It is important to ensure that the relevant graphic is in the correct position before alignment, for example, the right most graphic when aligning right.

To align graphics: select the graphics and on the Format menu click Align or Distribute and select one of the following alignment options:

- Left – align with the leftmost graphic
- Centered between the leftmost and the rightmost graphics
- Right – align with the rightmost graphic
- Top – align with the topmost graphic
- Middle – between the topmost and the bottommost graphics
- Bottom – align with the bottommost graphic
**Distributing**

Graphics can be distributed so that the space between each graphic is the same. The graphics on the outside stay in the same position, and all those in between are moved so that the space between the borders of each graphic is evenly distributed. This is only available when there are three or more graphics selected.

**To distribute graphics:** select the graphics, and on the *Format* menu click *Align or Distribute* and select one of the following distribution options:

- Distribute horizontally – left to right
- Distribute vertically – top to bottom
Working with graphics

Layout

Depending on the type of anchor, you can choose how adjacent text should flow around the graphic or whether the text should appear behind or in front of it, and its alignment across the page.

Graphics that are anchored inline are treated as just another character in the text and the line spacing will normally be increased automatically to accommodate them.

**To select the runaround properties for a graphic:** select the graphic and on the *Format* menu click on *Shape*. On the *Layout* tab click the required *Wrapping style*:

- **Square**: Text will flow evenly around the graphic.
- **Top and Bottom**: Text will flow down to the graphic and continue after it.
- **Left**: Text will only be placed to the left of the graphic.
- **Right**: Text will only be placed to the right of the graphic.
- **Behind**: Text will flow over the graphic.
- **In Front**: The graphic will sit on top of any text.

**To select the alignment for a graphic:** select the graphic and on the *Format* menu click *Shape*. On the *Layout* tab set the *Flow* to *Anchored* and click the required *Horizontal alignment*:

- **Other**: The graphic will be aligned according to the co-ordinates specified in *Position*.
- **Left**: The graphic will be aligned with the left margin of the paragraph, with text flowing to the right.
- **Center**: The graphic will be placed centrally between paragraph margins, with text flowing to the right and to the left.
- **Right**: The graphic will be aligned with the right margin of the paragraph, with text flowing to the left.
Runaround margins

When a graphic is placed in the message you can specify how far away any text that flows around it should be. The margins and the runaround properties together determine how the graphic sits within the content of the message. Most graphics only have external margins, but text boxes have internal margins as well. These determine how far text and graphics that are inside the graphic are from the border.

To set the margins of a graphic: select the graphic and on the Format menu click on Shape. On the Margins tab enter the required Internal or External margins.

Order of graphics

As graphics are inserted onto the page they are initially layered in the order they are placed on the page. This means that later graphics will be displayed over earlier graphics if they overlap. You can adjust this order as required.

You cannot move graphics in front of or behind text in this way. You must use the runaround properties of the graphic to do this – see “Layout” on page 48.

Note that you can cycle through graphics in their 'layer' order by using the previous and next buttons at the bottom of the Image dialog box.

To move a graphic forwards or backwards one layer: select the graphic and on the Format menu point to Order and select either Bring Forward or Send Backward.

To move a graphic in front of or behind all other graphics: select the graphic and on the Format menu point to Order and select Bring To Front or Send To Back.
Using tables

Tables can be used in messages, enabling you to position content in a structured way without using tab characters. Text and graphics are aligned in rows and columns – as with most word processing tools.

A table is made up of one or many **rows**. By default, row height is automatically maintained to suit the contents but you may specify a minimum or fixed height if desired.

<table>
<thead>
<tr>
<th>Plan number</th>
<th>123456789</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offer</td>
<td>$100.56</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Valid until</th>
<th>Aug 29 2008</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frozen until</td>
<td>Feb 14 2009</td>
</tr>
<tr>
<td>Period</td>
<td>Oct 02 - Dec 02</td>
</tr>
</tbody>
</table>

Each row can have one or many **cells**. By default, rows have the same number of cells which are aligned to form a **column** …

… but individual cells can be resized, added, deleted or, within a row, merged together to form a custom grid.

To enter text, graphics or data into a table, click in a cell and proceed as normal. Row height adjusts automatically but cell width must be adjusted manually if required.

<table>
<thead>
<tr>
<th>Open Plan Mobile Service</th>
<th>99 00</th>
</tr>
</thead>
<tbody>
<tr>
<td>Your Points</td>
<td>14.21</td>
</tr>
<tr>
<td>You save</td>
<td></td>
</tr>
</tbody>
</table>

To resize columns of aligned cells hover over a separating line then click and drag. To resize an individual cell press and hold Ctrl while dragging.

To resize an entire table, click on it and then use one of the drag handles. The left and right handles adjust cell widths. The bottom handle adjusts the minimum height of rows.

<table>
<thead>
<tr>
<th>Internet Service</th>
<th>49.95</th>
</tr>
</thead>
<tbody>
<tr>
<td>DSL Installation</td>
<td>FREE!</td>
</tr>
<tr>
<td>Equipment fee</td>
<td>FREE!</td>
</tr>
<tr>
<td>Setup Fee</td>
<td></td>
</tr>
<tr>
<td>Speed Allocation</td>
<td>384k, 128k</td>
</tr>
<tr>
<td>You pay only</td>
<td>49.95</td>
</tr>
<tr>
<td>Total Savings</td>
<td>$208.43</td>
</tr>
</tbody>
</table>

To resize columns of aligned cells hover over a separating line then click and drag. To resize an individual cell press and hold Ctrl while dragging.

To enter text, graphics or data into a table, click in a cell and proceed as normal. Row height adjusts automatically but cell width must be adjusted manually if required.

<table>
<thead>
<tr>
<th>Open Plan Mobile Service</th>
<th>99 00</th>
</tr>
</thead>
<tbody>
<tr>
<td>Your Points</td>
<td>14.21</td>
</tr>
<tr>
<td>You save</td>
<td></td>
</tr>
</tbody>
</table>

To resize columns of aligned cells hover over a separating line then click and drag. To resize an individual cell press and hold Ctrl while dragging.

To enter text, graphics or data into a table, click in a cell and proceed as normal. Row height adjusts automatically but cell width must be adjusted manually if required.

<table>
<thead>
<tr>
<th>Internet Service</th>
<th>49.95</th>
</tr>
</thead>
<tbody>
<tr>
<td>DSL Installation</td>
<td>FREE!</td>
</tr>
<tr>
<td>Equipment fee</td>
<td>FREE!</td>
</tr>
<tr>
<td>Setup Fee</td>
<td></td>
</tr>
<tr>
<td>Speed Allocation</td>
<td>384k, 128k</td>
</tr>
<tr>
<td>You pay only</td>
<td>49.95</td>
</tr>
<tr>
<td>Total Savings</td>
<td>$208.43</td>
</tr>
</tbody>
</table>

To select an entire row or column click near the outside edge when the arrow appears.
To create a table: position the insertion point where you want to insert the table and from the Table menu select Insert/Table. Specify the number and size of rows and columns as required.

Table positioning

A table within a message is always positioned in relation to the object selected when it was inserted. You cannot move a table except by cutting and pasting it so that it is relative to a different object.

If you want to position a table at a fixed position in a message or at fixed offset from an object you will need to include it in a text box.

As with other presentation objects you can edit the table’s properties to change the amount of space to be left between the table and the objects that appear before and after it in the message.

By default, a table is positioned as close as possible to the left hand margin. You can specify an indent to shift it to the right if required.

To customize table positioning properties: on the menu click Table/Properties. Use the General page to select special positioning options.
**Editing tables**

Content is added to a table by clicking in a cell then typing text, adding a data field or inserting an object as you would elsewhere. You cannot insert another table within a table cell.

Each table row starts off with a default minimum height. As content is added to the table, the height of individual rows will automatically grow to fit by default. You can specify that rows have a different minimum height or that they may not exceed a maximum height.

To adjust row height: select any part of the table and on the menu click *Table/Properties/Table*. Use the Advanced page to select the appropriate Row Height setting and specify a measurement if required.

When new rows or cells are added they adopt the attributes and dimensions of the currently selected element by default.

To add a row, column or cell: place the insertion point in an existing cell of the table, and from the *Table* menu click *Insert* and select the required row, column or cell option.

Most of the common resizing and editing operations can be performed using mouse operations. However, you may want to specify precise settings for some rows and cells.

When cells are deleted or resized, all remaining cells to their right retain their existing dimensions but close up to the left.

To resize cell widths: select the cells to be adjusted and from the Table menu select *Properties/Cell*. In the Cell dialog box enter a new Width and click OK.

Adjacent cells in a row can be merged together to form a single cell (existing content will also be merged). This can be used, for example, for a description that applies to more than one column.

To merge cells: select the relevant cells and from the Table menu click *Merge cells*.

To delete tables rows, columns or cells: click in or select what you want to delete, and from the Table menu click *Remove* and select the required table, row, column or cell option.
Borders and shading

You can customize the borders and shading used for cells, rows, and tables. For borders, you can specify the width and color of the line to be used for each edge of a cell, row, or table. You can also specify rounded corners for the table. For shading, select the color to be used to fill the cell behind any contents it might have. As with all color issues, bear in mind the capabilities of your target output environment when setting these options.

The settings you specify for a selection of cells are applied individually to each selected cell.

To adjust borders and shading:

1. Select the table, row or cells to be amended.
2. From the Table menu, select Properties and Table, Row, or Cell as appropriate.
3. On the Style page of the Table Properties dialog box specify the required color and line settings.
   
   For borders use the edge palette to select the edges you want to be changed. Note that any unselected edges will have existing settings removed.

   For shading, select a shading percentage for the color – 0 will be no color; 100 will be full color.

4. Click Apply to see the effect of your changes or click OK to apply the new settings and close the dialog box.

Tables can have rounded corners. They are applied to each corner of the table, on every page if the table overflows. The rounded corner is drawn in corner cells only; if the size specified is larger than the cell can accommodate, then that particular corner will not be rounded. Note that you may have to adjust the cell margin or format to prevent the contents of a cell overprinting the rounded corner.

To specify rounded corners for a table: select the table and from the Table menu, select Properties. On the Style page of the Table Properties dialog box select Enable rounded corners and specify the required radius of the curve.

SEE “SYSTEM VARIABLES” ON PAGE 172 FOR FURTHER INFORMATION.
The Review Process

In Content Author every new or updated message must be approved by each assigned reviewer before it becomes available for deployment to the production system. Reviewers are assigned responsibility for the messages in one or more Content Author projects by an administrator. The Content Author review mechanism can include automated e-mail notifications to those involved in the process.

The Review Cycle

An administrator specifies who should be involved in reviewing messages. Review groups are created and assigned to specific projects and all messages in the project must be reviewed by the users indicated in the groups. The sequence of the reviewers within the groups and the sequence of the review groups within a project dictates the review order. It can be specified that either all reviewers, or any one reviewer, in each review group must approve a message before it can be deployed to the production system.

Provided Content Author is configured appropriately e-mail notifications are sent to reviewers in turn once the preceding reviewer in the sequence has approved a message. If a message is denied an e-mail is sent to the author; similarly when it has completed the review process successfully. Messages that are waiting for you to review will be shown in the Reviewer tab when you next log in.

Once In production a new revision of the message must be created before it can be edited again. Administrators and authors with access to the message can do this.

A list of the reviewers is shown in the Properties tab for a message. You can monitor the progress of a message through the review cycle on the History page of the message properties view. The following statuses are used during the review process:

- **Draft.** A newly created message always starts in Draft status.
- **Being Reviewed.** A new or amended version of the message is in review.
- **Unapproved.** A message has been denied by a reviewer and not yet resubmitted.
- **Awaiting production.** All reviewers have approved but the message is not yet deployed.
- **In production.** Has been deployed to the production system.
The Review Process

Awaiting Expiry. The message has been set to expire but is not yet deployed.

Expired.

To see the review status: select a message from the Messages list and then click the History tab to display the current review status of the message.

To see the review cycle list: select a message from the Messages list and then click the Details tab to display the list of reviewers associated with the message.

Reviewing messages

When you log on to Content Author as a reviewer, all messages that are ready for you to review are listed. They are shown by project and folder. Messages are displayed in the Message view and you can make any comments in the Comments window.

Note that if you are part of a review group where any reviewer can review, messages reviewed by someone else in the group will be removed from your list.

Messages shown will have been approved by all preceding reviewers, as, if a message is not approved, it is immediately returned to the author, corrected and then re-submitted to the review cycle again.
The Review Process

To review a message: click the message name in the Messages list. Once you are satisfied click the Approve Message option. Or click Deny Message to return it to the author.

Tips on reviewing

Review both the content and the message properties found in the Summary page.

Check that a sensible priority has been used and that effective dates are correct.

Check that the conditions associated with the message will mean it is selected for the appropriate documents.

Check any message comment in the Details page for any information relevant to the review.

If the administrator has set up a preview application for use with the project use the Preview Message option to see how it will look within the context of a Designer publication.

If it is available for the text language used in the message use the spell checker to verify it.

Provide comments about your review. These are stored with the message and are available to other reviewers and authors.
To run the spell checker: on the Tools menu select Spell Check.

Comment History

Previous comments made about a message can be viewed in the History tab of the message. You can see all comments and status changes since the message was first submitted for review. As you will only receive messages that have been approved by all preceding reviewers, you can use this to confirm that previous comments have been actioned satisfactorily.

To view previous comments: while editing the message click the History tab. Click on a Comment to display it in full.
Index

A

access key 22
Administration Client
    comments window 56
administrator 7, 9, 54
after text indentation of paragraph 33
aligning
    characters 35
    graphics 46
    text 31
anchors 40
    fixed 40
    in-line 40
areas
    message 9
    attachments 18
attributes of shapes 42
authors 7, 9, 21, 54
auto conditions 16
awaiting expiry status 55
awaiting production status 54

B

before text indentation of paragraph 33
behind, moving text 48
Being reviewed
    message reviewed status 54
bidirectional text 28
borders
    message 21
    tables 53
boundaries 25
Bring forward option 49
Bring to front option 49
bullets 36

cancel
    a selection 24
    an editing action 24
cells 50
    adding to tables 52
    merging in tables 52
    resizing 52
character alignment tab stop 35
checking spelling 30
Clear option 24
clickable image 38, 42
clipboard 24
color
    of a message 21
    of font 27
    of shapes 42
columns
    transaction tables 52
    columns in transaction tables 52
comments
    message 10, 13
    review 57
    viewing 57
comments window 56
conditions
    in messages 15
connection time-out 8
Content Author 7
    changing password 8
content editor 8, 10, 11, 21–25
coordinates 41
copy message 11
copying
    using the clipboard 26
Cut option 26

data fields
    finding 25
    in messages 37
    inserting into a message 38
    replacing 25
dates 15
decimal alignment tab stop 35
default tab stops 35
delete message 11
deleting
    selection 24
details 13
dictionaries 30
direction of text 28
distributing graphics 47
docking bar 22
dot leader 35
Draft status 54
drawing 41

editing message content 21
editor 8
effective dates 15
    setting 15
end of section marker 29
Exclude-if 16
expired status 55
external margins 49
<table>
<thead>
<tr>
<th>Index F – M</th>
</tr>
</thead>
</table>

**F**
- fill color, of a message 21
- fill color, of shapes 42
- filter message list 7
- find and replace
  - fonts 25
  - text 25
  - values 25
- first line indent 33
- fixed anchor 40
- folders 9
- fonts
  - default 28
  - find and replace 25
  - formatting text 27
- formatting marks 29

**G**
- global conditions 16
- graphics 40–49
  - aligning 46
  - anchoring 40
  - bring forwards 49
  - distributing 47
  - drawing 41
  - margins 49
  - moving 45
  - order of 49
  - positioning 40, 41
  - resizing 45
  - selecting 24, 44
  - send backwards 49
- grid
  - in content editor 23

**H**
- hanging indent 33
- height
  - of shape 46
  - of table row 52
- history
  - review comments 57
  - spelling
    - adding words 30
- horizontal lines 46
- hyphenation 30

**I**
- images
  - inserting 42
  - selecting 24
- URL link 38, 42
- in front, moving text 48

**indentation** 33
- first line 33
- in-line anchor 40
- internal margins 49

**J**
- justification of lines in paragraphs 31

**K**
- keep together 27, 28
- keyboard access key 22

**L**
- language 10
  - and encoding mapping 29
  - set language option 28
  - specifying the input language 28
- leader, in tab stops 35
- line width of shapes 42
- lines
  - drawing 41
  - horizontal and vertical 46
  - spacing 32
- login password 7

**M**
- mandatory messages 14
- margins
  - graphics 49
- markers, non-printing 29
- measuring 23
- menus 22
- merging table cells 52
- message areas 9
  - in the editor 21
- message filter 7
- message properties 13
- message status
  - Being reviewed 54
- messages
  - and attachments 18
  - comments 10, 13
  - conditions 15
  - copy 11
  - creating 10
  - delete 11
  - editing 10
  - mandatory 14
  - previewing 19
  - priority 14
  - reviewers 54
  - reviewing 54, 55
  - sampling rate 15
  - saving 11
  - signals 13, 14
submit for review 11
messages list 7
moving
  graphics 45

N

next shape 49
non-breaking space 27, 28, 29
non-printing characters 29
numbered lists 36

O

objects
  see also graphics
  aligning 46
  distributing 47
  ovals 41

P

paragraph marks 29
paragraphs 27–39
  alignment 31
  direction of text 28
  indentation 33
  justification 31
  Show all menu option 30
  spacing 32
parameters
  finding 25
  replacing 25
password
  changing 7
  changing in Content Author 8
paste special from clipboard 26
pasting from the clipboard 26
positioning graphics 40
previewing messages
  author 19
previous shape 49
priority
  of messages 14
projects 9
properties 13
properties of shapes 42

R

readers 7, 9, 21
rectangles
  drawing 41
redo a cancelled editing action 24
replace
  text, fonts, values 25
reports 20
reset paragraph numbering 36
resetting
  graphics 45
reverse an editing action 24
review comments 57
review cycle list 55
review cycles 54
review status 55
reviewers 7, 54
reviewing
  messages 54
right to left text 28
rotating text 35, 44
rounded corners for tables 53
rounded rectangles 41
rows
  adding to tables 52
in tables 50
RTF
  importing content into a document 37
  importing content into a message 37
ruler 23
runaround text properties 48

S

sampling rate 15
save message 11
Select all option 26
Select-if 16
selecting
  objects 24, 44
  text 24
selecting messages 19
Send backward option 49
Send to back option 49
Set language option 29
shading
  message 21
  shapes 42
  tables 53
shapes
  attributes 42
  drawing 41
  moving 45
  positioning 41
  resizing 45
shortcut key 22
signals 13, 14
size of shapes 42
soft return marker 29
spacing
  between lines 32
  between paragraphs 32
spell checking 30
spell dictionary 30
spell history
  adding words 30
spell settings 30
status bar – editor 11
submit for review 11
Index T – Z

T

- tab character marker 29
- tab stops
  - character 35
  - default 35
  - dot leader 35
  - inserting 34
  - leader 35
  - setting 35
- tables 50–53
  - adding rows, columns and cells 52
  - borders 53
  - creating 51
  - editing 52
  - merging cells 52
  - positioning 51
  - rounded corners 53
  - shading 53
- text 27–39
  - aligning 31
  - direction 28
  - find and replace 25
  - flow around objects 48
  - formatting 27
  - hyphenating 30
  - indentation 33
  - inserting in a message 27
  - keep together 27, 28
  - positioning 31
  - rotating 35, 44
  - runaround properties 48
  - selecting 24
- text boxes 43
- time-out of connection 8
- Toggle grid option 23
- transparent fill, shapes 42

U

- unapproved status 54
- undo an editing action 24
- units of measure 24
- UOM 23
- URL links 38

V

- value objects
  - find and replace 25
- values
  - finding 25
  - replacing 25
- variables
  - finding 25
  - replacing 25
- vertical lines 46

W

- width
  - of shape 46
- table cell 52
- Windows
  - input language 28

Z

- zoom 21