# Table of Contents

## Introducing Visual Engineer
- Enrichment Visual Engineer ......................................................... 8
- Enrichment Visual Engineer Plus Workflow ................................. 8
- FAQ ......................................................................................... 9
  - Getting Started FAQ ................................................................. 9
  - Analyzing Print Streams FAQ .................................................. 10
  - Developing Applications FAQ ................................................... 12

## Working with Print Streams
- Introduction to Working With Print Streams ............................. 14
- Print Stream Viewer Interface Overview .................................. 14
  - Toolbar ................................................................................. 16
  - Fields List ............................................................................. 16
  - Status Bar ............................................................................ 16
  - What do the Different Colors Mean? ....................................... 17
  - Right Clicking ....................................................................... 18
  - Keyboard Shortcuts ................................................................. 19
  - Displaying the Fields List ......................................................... 20
  - Searching for a Field ............................................................... 20
  - Searching for a String ............................................................. 21
  - Displaying an Explanation ....................................................... 22
  - Printing from the Viewer .......................................................... 23
  - Moving Around ..................................................................... 23
    - Paging Up and Down ............................................................. 23
    - Moving to the Next or Previous Document in the Set .......... 23
    - Going to the Current Field Position ................................. 24
    - Searching for Text Strings .................................................. 24
    - Zooming In and Out ............................................................ 24
  - Opening a Print Stream ............................................................ 25
    - Opening a Print Stream in the Data Viewer ....................... 25
    - Opening a Print Stream in the Graphic Viewer ................... 26
  - Downloading Print Streams from a Mainframe ..................... 27
    - Specifying Metacode Record Format .................................. 29
    - Specifying Mixed AFP Record Format ............................... 31
    - Specifying PCL Record Format ........................................... 33
    - Specifying FIX Print Stream Record Information .............. 34
  - Specifying Print Stream Properties ......................................... 34
    - Specifying Control Information Areas ................................. 37
    - Defining Page Layout ........................................................... 38
    - Defining DJDE Record Layout ............................................. 39
    - Defining a Copy Group and Page Format ......................... 40
    - Defining Sorting and Storage Options ............................... 41
    - Page Reordering .................................................................. 42
    - Duplex Processing ............................................................... 43
Enabling Variable Substitution ............................................. 44
Specifying Line Formats ..................................................... 44
Specifying Resources ......................................................... 45
Specifying Metacode Fonts .................................................. 46
Defining Page and Document Breaks ................................. 47
  Setting and Verifying Page Breaks ........................................ 48
  Setting and Verifying Document Breaks ............................. 49
Fields .................................................................................. 51
  Creating a Field ................................................................. 52
  Editing Field Properties ..................................................... 56
  Editing Field Reference Properties ................................. 60
  Extracting Variable-Length Text ....................................... 62
  Copying a Field ................................................................. 63
  Changing a Field's Location ............................................... 64
  Changing a Field Reference ................................................. 65
  Deleting a Field ................................................................. 65
  Deleting a Field Reference ................................................. 66
  Defining Address Fields ..................................................... 66
  Reporting Field Values ..................................................... 67
Input Definition Files .......................................................... 68
  Creating an Input Definition File ......................................... 69
  Using an Existing IDF as a Template ................................. 70
Control File Style ............................................................... 70
  Importing an Input Definition File ................................. 71
  Applying an IDF to a Print Stream ..................................... 71
  Previewing Enrichment Tags ............................................. 72
  Saving an Input Definition File ......................................... 73
  Adding Barcodes and Other Objects ................................. 73
  Adding Barcodes and Objects to AFP or Metacode Print Streams ........................................ 74
  Adding Barcodes and Objects to Non-AFP Print Streams ................................. 84

WORKING WITH CONTROL FILES

Introduction to Working With Control Files ....................... 86
  Using the Toolbar ............................................................. 86
  Using the Status Bar .......................................................... 87
  Using the Application Overview ....................................... 88
  Accessing the Shortcut Menu ............................................. 89
  Using Shortcut Keys .......................................................... 90
  Searching for a String ......................................................... 90
  Using the Messages Window ............................................. 91
  Code Formatting ................................................................. 93
  Changing Formatting Preferences .................................... 94
  Setting Environment Preferences .................................. 96
  Creating a New Control File ............................................ 99
Tags and Tag Groups .......................................................... 99
  Adding a Tag Group ............................................................ 99
  Adding a Tag ................................................................. 99
  Using Tag Group Templates ............................................. 100
Adding an Instruction .................................................. 102
Adding a Function ...................................................... 102
Editing a Function ...................................................... 103
Adding a Variable ....................................................... 103
Adding a Comment ...................................................... 104
Creating a Vault Journal File ................................. 104

**TESTING APPLICATIONS**

Running Application Test ........................................ 108
Viewing Output ....................................................... 110
Comparing Input and Output ................................. 111

**DEBUGGING**

Using the What's Wrong Feature .............................. 116
Checking Your Syntax .............................................. 116
Introducing Visual Engineer

In this section

Enrichment Visual Engineer ................................................................. 8
Enrichment Visual Engineer Plus Workflow ..................................... 8
FAQ .................................................................................................... 9
Enrichment Visual Engineer

Enrichment® Visual Engineer is a development tool that enables both IT and document production staff to analyze print streams and develop and test Enrichment applications.

- **Analyzing Print Streams**: With its interactive environment, Visual Engineer Plus allows you to display and analyze print streams that you want to use as input to Enrichment. You can identify documents and pages and graphically define fields.
- **Developing Enrichment Applications**: Visual Engineer Plus allows you to create control files and rule files using a graphical interface. It assists you in entering tags using the correct syntax, as well as in entering valid parameters. Visual Engineer Plus also provides template code for common functions such as adding barcodes; creating banner pages; and invoking Coding Accuracy Support System (CASS™) processing and Presort Accuracy Validation and Evaluation (PAVE) processing; and other operations.
- **Testing Applications**: Visual Engineer Plus allows you to execute your Enrichment application from your Windows environment, enabling you to instantly perform trial runs to prepare for production.

Additional information is available in the *Developer's Guide*, *Language Reference*, and *Sample Applications Guide*. You can access the *Developer's Guide* and *Language Reference* online from the Visual Engineer Help menu.

Enrichment Visual Engineer Plus Workflow

This section provides a quick reference to all the major steps in the Visual Engineer Plus workflow. Follow these steps to complete your project.

**Note**: While this is the recommended Visual Engineer Plus workflow, you can follow your own.

1. Open or create a control file. For instructions on creating a control file, see “Creating a New Control File” on page 99.
2. In the control file, add an `<INPUT>` tag group. For instructions on adding a tag group to a control file, see “Adding a Tag Group” on page 99.
3. In the newly created `<INPUT>` tag group, add the `<FILE>` tag to specify the file name of the print stream you wish to process. For instructions on adding a tag, see “Adding a Tag” on page 99.
4. Right-click anywhere in the `<INPUT>` tag group, and then select either the data viewer or the graphic viewer from the shortcut menu. For more information, see “Opening a Print Stream” on page 25.
5. Define the print stream's page breaks and/or document breaks. For more information, see “Setting and Verifying Page Breaks” on page 48 and “Setting and Verifying Document Breaks” on page 49.

6. Define the print stream's fields. For more information, see “Creating a Field” on page 52.

7. Use the appropriate tags and/or rule file logic to make the desired modifications to the input print stream. For more information, see the Enrichment Language Reference.

8. Test the application using the Enrichment Application Test. For instructions, see “Running Application Test” on page 108.

9. Once the job has finished running, view the output. For instructions, see “Viewing Output” on page 110. To view a side-by-side comparison of the input print stream and the output, use the compare tool. For instructions, see “Comparing Input and Output” on page 111.

FAQ

This section contains Visual Engineer frequently asked questions.

• Getting Started FAQ
• Analyzing Print Streams FAQ
• Developing Applications FAQ

Getting Started FAQ

Q Why would I want to use Enrichment Visual Engineer?

A Visual Engineer Plus allows you to analyze print streams, develop control files and rule files, and test your applications quickly and efficiently.

Q What changes will I need to make to my control file when I upload it to UNIX?

A You will need to make sure that all <FILE> tags in the control file are valid. For example, in UNIX there are no drive letters and the directory delimiter is "/" instead of "\"."
Q: What changes will I need to make to my control file when I upload it to z/OS?

A: You will need to make sure that all <FILE> tags in the control file are valid. On z/OS, you'll need to replace all the <FILE> values with appropriate DD names that point to the data set. If running with Finalist, the <LPCFINAL> tag must be changed. If running with MailStream Plus, the <STEP> tag must be changed. You may also have to take into account EBCDIC/ASCII issues.

Q: Can I run multiple copies of Visual Engineer Plus?

A: Yes, you can launch multiple applications, but we discourage this because having numerous applications open at once may be confusing.

Analyzing Print Streams FAQ

Q: How do I download or transfer print streams from a z/OS mainframe to use with Visual Engineer Plus?

A: Use the specifications below for the proper file extension and download method.

Table 1: File Extensions Used with Visual Engineer

<table>
<thead>
<tr>
<th>Print Stream Type</th>
<th>File Extension</th>
<th>IND$FILE Download As</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line printer data (see note)</td>
<td>*.LIN</td>
<td>CRLF ASCII</td>
</tr>
<tr>
<td>DJDE (see note)</td>
<td>*.DJD</td>
<td>CRLF ASCII</td>
</tr>
<tr>
<td>Metacode</td>
<td>*.MET</td>
<td>Binary with lengths added to each record by the PDRLNADD utility on z/OS</td>
</tr>
<tr>
<td>AFP line data (see note)</td>
<td>*.AFL</td>
<td>CRLF ASCII</td>
</tr>
<tr>
<td>AFPDS</td>
<td>*.AFP</td>
<td>Binary</td>
</tr>
<tr>
<td>AFP mixed-mode</td>
<td>*.AFM</td>
<td>Binary CRLF</td>
</tr>
<tr>
<td>PCL</td>
<td>*.PCL</td>
<td>Binary</td>
</tr>
<tr>
<td>PostScript</td>
<td>*.PS</td>
<td>Binary</td>
</tr>
</tbody>
</table>

Note: The download method indicated is for print streams with ANSI carriage controls. If a line printer data, DJDE, or AFP line data print stream has machine carriage controls, you must download the print stream as Binary CRLF.
Q  How do I use the input definition file?

A  You are not required to use an Input Definition File (IDF). However, if you choose to use one there are three approaches:

  • You can copy and paste the contents of the input definition file (IDF) into the control file.
  • You can use the <GETFILE> tag to include the IDF within a control file.
  • You can import the IDF.

Q  What do the different colors in print streams mean?

A  Visual Engineer applies colors to the different components of print streams viewed in the graphic viewer. The default colors are listed below. You can modify the color settings.

  • A magenta line indicates a page break.
  • A dark magenta or green line indicates a document break.
  • Cyan indicates header, trailer, and skip column areas. If fields are located in the header, trailer, or skip area, they are displayed in red.
  • Gray indicates the position at which a field exists on a phantom line. A phantom line is an area that does not currently contain a print record.
  • A dark blue outline indicates the highlighted text.
  • Solid green indicates the current field location.
  • A green outline indicates a field location.
  • Yellow indicates a field reference.
  • If a field reference and field location overlap, the overlapping area is displayed in cyan.

Q  How large a file can I download into Visual Engineer?

A  You can load as much data as you like. You are only limited by the amount of available memory you have. In general, you should keep print streams to a small but representative number of documents (5–100). Visual Engineer Plus will display up to 1 million records.
Developing Applications FAQ

Q
How can Visual Engineer Plus help me with my existing control files and rule files?

A
You can download your existing control files and rule files to take advantage of the Check Syntax utility. Visual Engineer Plus can compile your control file and rule file and generate an error report. You can then use this report to jump to the location of the error in your file. You can also execute the control file to test for processing errors. You can access information for the Enrichment error messages in the online help.

Q
How do I download files to use in Visual Engineer?

A
Control files and rule files are simple ASCII files. You can download them with the ASCII CRLF option on any mainframe terminal emulator, such as IRMA, Attachmate, IBM PC/3270, and so on.

It is recommended that you use the following file extensions:

• Control files: *.CON
• Rule files: *.RUL

Q
How do I upload the control file to the mainframe once I create it?

A
To upload the control file, use any terminal emulator, as mentioned above. Be sure to specify the ASCII CRLF option.
Working with Print Streams

In this section

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction to Working With Print Streams</td>
<td>14</td>
</tr>
<tr>
<td>Print Stream Viewer Interface Overview</td>
<td>14</td>
</tr>
<tr>
<td>Moving Around</td>
<td>23</td>
</tr>
<tr>
<td>Opening a Print Stream</td>
<td>25</td>
</tr>
<tr>
<td>Defining Page and Document Breaks</td>
<td>47</td>
</tr>
<tr>
<td>Fields</td>
<td>51</td>
</tr>
<tr>
<td>Input Definition Files</td>
<td>68</td>
</tr>
<tr>
<td>Adding Barcodes and Other Objects</td>
<td>73</td>
</tr>
</tbody>
</table>
Introduction to Working With Print Streams

To work with print streams in Visual Engineer Plus you use the print stream viewers. The Visual Engineer Plus print stream viewers let you interactively define the characteristics of a print stream, such as document breaks, page breaks, and fields. Specifically, you can use the print stream viewer to:

- **Develop control files**—The actions you take in the print stream viewer result in the appropriate tag groups being automatically created in the Enrichment control file. For example, you can create an entire Input tag group using the print stream viewer, without having to write any control file code.
- **Analyze print streams**—The viewer provides print stream analysis capabilities in the AFP, Metacode, PCL, and PostScript print stream environment.
- **Create audit reports**—The print stream viewer can automatically generate a list of all fields and their values which can be used for auditing purposes.

There are two print stream viewers in Visual Engineer Plus: the data viewer and the graphic viewer.

The data viewer can display the following types of print streams:

- Line printer data
- Xerox Metacode and DJDE
- AFP line data and AFP mixed-mode
- AFPDS
- PCL
- PostScript

The graphic viewer can display the following types of print streams:

- AFPDS
- Metacode
- PDF

Print Stream Viewer Interface Overview

This section provides an overview of the print stream viewer interface. The main components of the print stream viewer interface are described below. Note that this
example shows the data viewer but the information applies to both the data viewer and the graphic viewer.

For additional information, see:

- “Toolbar” on page 16
- “Fields List” on page 16
- “Status Bar” on page 16
- “What do the Different Colors Mean?” on page 17
- “Right Clicking” on page 18
- “Keyboard Shortcuts” on page 19
- “Displaying the Fields List” on page 20
- “Searching for a Field” on page 20
- “Searching for a String” on page 21
- “Displaying an Explanation” on page 22
- “Printing from the Viewer” on page 23
Toolbar

The toolbar provides quick access to various functions. When you place the cursor over a button, the status bar displays a brief explanation of the button. All functions displayed as buttons on the toolbar can be accessed from the menus. However, not all menu items are available from the toolbar.

Fields List

The Fields list is a drop-down list located on the toolbar. It contains all the fields in the current input definition file. You can use this list to locate a field in the print stream: when you select a field, it is highlighted and the cursor moves to the position where you defined the field.

Status Bar

When you place the cursor over a button on the toolbar, the status bar displays a brief description of the button as shown below.

Load an existing print stream for analysis

When your cursor is on an open line printer data, DJDE, AFP line data, or AFP mixed-mode print stream, the status bar displays the document, page, line, overprint record, and column number of the cursor position, as shown below.

DOC: 1 PAGE: 12 LINE: 1 OVERPRT: 1 COL: 21

When your cursor is on an open Metacode, PCL, PostScript, or AFPDS print stream, the status bar displays the document, page, record, and column of the cursor position, as follows:

DOC: 1 PAGE: 1 RECORD: 15 COL: 13
What do the Different Colors Mean?

A magenta line indicates a page break.

A dark magenta or green line indicates a document break.

Cyan indicates header, trailer, and skip column areas. If fields are located in the header, trailer, or skip area, they are displayed in red.

A dark blue outline indicates the current selection.

A green outline indicates an area that you have defined as a field.
Solid green indicates the current field location.

![Current Field Location]

Yellow indicates a field reference.

![Field Reference]

If a field reference and field location overlap, the overlapping area is displayed in cyan.

![Overlap Display]

**Right Clicking**

In the data viewer, when you click the right mouse button over a selected area in an open print stream (an area outlined in dark blue), a shortcut menu is displayed:

![Shortcut Menu]

The shortcut menu contains the following options:
• **Explain**: Displays an explanation of the hexadecimal code. For more information, refer to "Displaying an Explanation" later in this chapter.

• **Find String**: Allows you to search for a specified text string. For more information, refer to "Searching for Text Strings" later in this chapter.

• **Set Reference**: Allows you to create a field reference. For more information, refer to "Creating a Field" later in this chapter.

• **Set Location**: Allows you to create a fixed location field. For more information, refer to "Creating a Field" later in this chapter.

• **Set Skip Column Area**: Sets the number of contiguous columns on the left side of each record in the print stream to ignore during processing. When you set the skip column from the shortcut menu, Visual Engineer Plus defines the skip column area as being from the selected columns to the left of the page. For more information, refer to "Specifying Control Information Areas" later in this chapter.

• **Set Header Area**: Sets a header area to ignore during processing. When you set the header area from the shortcut menu, Visual Engineer Plus defines the area for the header as being from the current line to the top of the page.

• **Set Trailer Area**: Sets an area at the bottom of the page to ignore during processing. When you set the trailer area from the shortcut menu, Visual Engineer Plus defines the area for the trailer as being from the current line to the bottom of the page.

• **Set DJDE IDEN Area**: Allows you to control automatic detection and processing of DJDE line data and Metacode data. For more information, refer to "Defining DJDE Record Layout" later in this chapter.

• **Set DJDE Data Area**: Specifies the selected area as a DJDE data area.

---

**Keyboard Shortcuts**

You can perform many functions by using the shortcut keys listed on the menu to the right of the command. For example, you can find fields by pressing Ctrl+D.

<table>
<thead>
<tr>
<th>Search</th>
<th>Document</th>
<th>Field</th>
<th>Window</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find Fields ...</td>
<td>Ctrl+D</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Find String ...</td>
<td>Ctrl+S</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Find Next</td>
<td>Ctrl+R</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Find Previous</td>
<td>Ctrl+P</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

| Next Document | Ctrl+Down | Previous Document | |
| Next Page | Ctrl+Page | Previous Page | |
| Go To Current Field Location | | | |
Displaying the Fields List

The Fields list, shown below, is a list of all the fields defined for the print stream. The Fields list is located on the toolbar. When you select a field, the cursor moves to the field location, which is highlighted in green.

<table>
<thead>
<tr>
<th>Field</th>
</tr>
</thead>
<tbody>
<tr>
<td>%Address2</td>
</tr>
<tr>
<td>docid</td>
</tr>
<tr>
<td>OMR</td>
</tr>
<tr>
<td>%Address1</td>
</tr>
<tr>
<td>%Address2</td>
</tr>
<tr>
<td>%Address3</td>
</tr>
<tr>
<td>%Address4</td>
</tr>
<tr>
<td>%Actnum</td>
</tr>
</tbody>
</table>

Searching for a Field

The *Find Field* window lets you search for fields in the print stream. To access this window, open a print stream in the data viewer, and then select *Search > Find Fields*.

The fields in this window are described next.

- **Ignore search area restrictions defined for field**: This finds all possible values of the field you have selected in the Fields list, ignoring the search limitations provided in the *Field Information* window. (To access the *Field Information* window, right-click the field.) Clear this check box if you want to search only the areas specified in the field's *Field Information* window.

- **Wrap**: Visual Engineer Plus starts searching from the current cursor position to the bottom of the print stream. Select this check box to let Visual Engineer Plus wrap to the top of the print stream when it gets to the bottom. Clear this check box to search only from the current cursor position to the bottom of the print stream.
Searching for a String

The *Find String* window lets you search for a text string in the print stream. To access this window, open a print stream in the data viewer, and then select *Search > Find String*.

The fields in this window are described next.

- **Search String**: Type the string for which you want to search. You can type up to 100 characters. The "?" wild card can be used to represent any single character and the "*" wild card can be used to represent any string of characters. Each wild card counts as one character in the character limit.

  NOTE: When searching, Visual Engineer Plus looks only at the native data format.

- **String Type**: Select one of the following:
  - **Character**: The string is in alphanumeric format.
  - **HEX**: The string is in hexadecimal format.

- **Wrap**: Select this check box to continue searching from the top of the print stream when the bottom is reached. Visual Engineer Plus starts searching from the current cursor position and moves upward or downward (depending on whether the **Forward** box is checked). Clear this check box to search only from the current cursor position to the bottom or top of the print stream.

- **Forward**: Select this check box to search the print stream from the current position in the print stream to the bottom. Clear this check box to search from the current position in the print stream to the top.

- **Case**: Select this check box to conduct a case-sensitive search. Clear this check box to find strings that match the spelling but not necessarily the use of upper- and lower-case characters.

- **Start in column**: Select this check box to begin the search in a specific column. Then, type the column number in the text box. Clear this check box to search all columns in the print stream.
• **Starting column only**: Select this check box to search only the column specified in the **Start in column** field. Clear this check box to search from the starting column you specified to the end of the record.

Click the Find Next button to move to the next occurrence of the string. Click the Find Previous button to move to the previous occurrence of the string.

**Displaying an Explanation**

To display an explanation for a portion of the print stream:

1. Select the area for which you want an explanation. You can either select a string with the mouse or click on a single character anywhere on the print stream data.

2. Right-click the selected area, and then click **Explain**. The **Explanation** window appears. On this window, the HEX area displays the hexadecimal value of the data. The Explanation area displays a detailed description of the data.

![Explanation Window]

3. Click **OK** when you are finished viewing the explanation. If you clicked on a specific area in the **Explanation** window, the corresponding area remains selected in the print stream.

**Displaying an explanation of the entire print stream:**

You can display an explanation of the entire print stream by clicking **View > Line Formats**, checking the **Explanation** box, and then clicking **OK**.
Printing from the Viewer

You can print from both the data viewer and the graphic viewer. To print from a viewer, select *File > Print.*

Moving Around

There are a variety of ways you can navigate through a print stream in the viewers:

- Paging Up and Down
- Moving to the Next or Previous Document in the Set
- Going to the Current Field Position
- Searching for Text Strings
- Zooming In and Out

Paging Up and Down

To move to the next page, click the Next Page button (shown below) or select *Search > Next Page.*

To move to the previous page, click the Previous Page button (shown below) or select *Search > Previous Page.*

**Note:** You may need to set the top of page before the Next Page and Previous Page buttons will function properly. For more information, see “Setting and Verifying Page Breaks” on page 48.

Moving to the Next or Previous Document in the Set

You can quickly move to the next or previous document in the set with the Next Document and Previous Document buttons.

To move to the next document in the set, click the Next Document button (shown below) or select *Search > Next Document.*
To move to the previous document, click the Previous Document button (shown below) or select Search > Previous Document.

**Note:** You must define how to determine document breaks before the Next Document and Previous Document buttons will function properly. For more information, see “Setting and Verifying Document Breaks” on page 49.

## Going to the Current Field Position

You can jump to the current field position (the position at which you defined the currently selected field) at any time by clicking Search > Go to Current Field Location. The currently selected field is the field that is displayed in the Fields list. For more information about the Fields list, see “Displaying the Fields List” on page 20.

## Searching for Text Strings

Visual Engineer Plus allows you to search for a text strings in a print stream. To search for a text string in a print stream, follow these steps:

1. Click the Find String button (shown below) or select Search > Find. The *Find* dialog box is displayed.

2. Fill in the fields in the dialog box and click **OK**. If the string exists in the file, it is highlighted in blue.

3. To find the next occurrence of the search string, click the find Next String button (shown below) or select Search > Search Again. The next occurrence is highlighted.

## Zooming In and Out

You can zoom in on the print stream to make it easier to read or zoom out to view an entire page.

To make the print stream appear closer, click **View > Zoom In**.

To make the print stream appear further away, click **View > Zoom Out**.
Opening a Print Stream

These procedures describe how to open a print stream in Visual Engineer:

- Opening a Print Stream in the Data Viewer
- Opening a Print Stream in the Graphic Viewer
- Downloading Print Streams from a Mainframe
- Specifying Metacode Record Format
- Specifying Mixed AFP Record Format
- Specifying PCL Record Format
- Specifying FIX Print Stream Record Information

Opening a Print Stream in the Data Viewer

The data viewer can display the print stream data in native (ASCII or EBCDIC), non-native (ASCII or EBCDIC), and hexadecimal. It can also display an explanation of each line. You may want to set the line formats before you begin working. The native format is determined by the option you select for the Data Type on the Print Stream Properties window (File > Print Stream Properties). For example, if you select ASCII for the Data Type, the native format of the print stream is ASCII.

To open a print stream in the data viewer, follow these steps:

1. If you are downloading a print stream from a mainframe, first follow the procedure in “Downloading Print Streams from a Mainframe” on page 27.

2. Click the Open button (shown below). The Open dialog box is displayed.

3. Complete the fields and click OK. The Find Pages and Docs dialog box is displayed.

4. Click OK. One of the following occurs:
   - If you selected a line printer data, Postscript, DJDE, AFP line data, or AFPDS print stream, the print stream is loaded.
   - If you selected a Metacode print stream, the Metacode Record Format dialog box is displayed. Use this dialog box to specify the record text format (ASCII or EBCDIC) and the record blocking method used to prepare the print stream. For more information, see “Specifying Metacode Record Format” on page 29.
   - If you selected an AFP mixed-mode print stream, the Mixed AFP Record Format dialog box is displayed. Use this dialog box to specify the record text format (ASCII or EBCDIC) and the record blocking method used to prepare the
print stream. For more information, see “Specifying Mixed AFP Record Format” on page 31.

- If you selected a PCL print stream, the *PCL Record Format* dialog box is displayed. Use this dialog box to specify the end of record indicator and the record text format (ASCII or EBCDIC) for the print stream. For more information, see “Specifying PCL Record Format” on page 33.

- If you selected fixed length record line data, the *FIX Print Stream Record Information* dialog box is displayed. Use this dialog box to specify the fixed record length for a non-delimited print stream. For more information, see “Specifying FIX Print Stream Record Information” on page 34.

You can also open a print stream in hexadecimal format by right-clicking in a control file's Input tag group or Output tag group and then selecting *Data Viewer*. In order to use this method, you need to have both the `<FILE>` tag and `<NAME>` tag defined. If you use a DD name in the `<FILE>` tag, Visual Engineer will display a message asking if you would like to create an association between the DD name file and the `<FILE>` tag. If you choose to do so, a special comment will be placed in the control file on the line of the `<FILE>` tag. The comment contains the path to the file the user is viewing. For example,

```
<FILE> DD:INPUT1 //PB View File=C:\bundle2.afp
```

### Opening a Print Stream in the Graphic Viewer

The graphic viewer displays the print stream as it will appear when it is printed. When you are working with an AFPDS or metacode print stream, you can choose to use either the data viewer (described above) or the graphic viewer.

The graphic viewer does not support AFP line data or AFP mixed-mode.

To open a print stream in the graphic viewer, follow these steps.

1. Be sure that the directory that contains the fonts used in the print stream is defined in the Resources window. For more information, see “Specifying Resources” on page 45. If you do not have the fonts available then a default font will be substituted and the print stream may not display as intended.

2. Select *View > Graphic Viewer*.

3. Browse to the desired print stream and then click *Open*.

   If one or more resources is missing, a missing resources message appears.

4. Click *OK*. 
Working with Print Streams

The Missing Resources dialog box appears.

5. Do one of the following:
   - Click Save to save the list of missing resources to a log file. The default log file name is VEResource.log and the default location is the Visual Engineer installation directory.
   - Click Yes to specify the missing resources in the Resources Specification dialog box. See “Specifying Resources” on page 45 for more information.
   - Click No to continue without specifying the missing resources. As indicated previously, the print stream may not display as intended.

6. The Find Pages and Docs message appears. Click OK.

You can also open an AFP print stream in Graphic View by right-clicking the control file’s Input tag group or Output tag group and then selecting Graphic View. In order to use this method you need to have the <FILE> tag and <NAME> tag defined. If you use a DD name in the <FILE> tag, Visual Engineer will display a message asking if you would like to create an association between the DD name file and the <FILE> tag. If you choose to do so, a special comment will be placed in the control file on the line of the <FILE> tag. The comment contains the path to the file the user is viewing. For example,

   <FILE> DD:INPUT1 //PB View File=C:\bundle2.afp

Downloading Print Streams from a Mainframe

To download a print stream from a mainframe for use in Visual Engineer Plus, follow the procedure outlined below.

Step 1: Add Record Length Bytes to the Start of Each Record

You need to add record length bytes to the start of each record if either of the following is true:
• You are downloading a Metacode print stream
• You are downloading an AFP print stream that has either padded, truncated, or mixed line data

If neither of these applies to you, skip to Step Two: Transfer the File.

If either applies to you, add record length bytes to the start of each record by running the load module PDRLNADD (or another company's blocking software). You can find the PDRLNADD load module in the PDR.STREAMW.LOAD data set and the PDRLNADD REXX exec in the PDR.STREAMW.EXEC data set. For both of these, PDR is the HLQ under which Enrichment is installed. You must edit the PDR.STREAMW.EXEC(PDRLNADD) member to set the correct HLQ. You only need to do this once.

**Note:** The procedure below describes running PDRLNADD in an interactive mode. You can also run PDRLNADD as a batch application using the PDRLNADD JCL that is included in the STREAMW.JCL PDS. Follow the instructions in the header of the JCL.

To set the correct high-level qualifier, follow these steps.

1. Edit the PDRLNADD member in the PDR.STREAMW.EXEC data set.
2. Change the line `loadmod='PDR.STREAMW.LOAD(PDRLNADD)'` to reflect the HLQ under which Enrichment is installed. For example, `loadmod='SYS3.STREAMW.LOAD(PDRLNADD)'`.
3. Save your change.
4. Run PDRLNADD on a file by typing the following (with the appropriate parameters) at a TSO command prompt:

   ```
   %PDRLNADD PDR.INPUT(SAMPLE) PDR.OUTPUT(SAMPLE) length format include
   start rec numb
   ```

   **NOTE:** This uses the included REXX exec to handle file allocation.

   Where:

   • **PDR.INPUT(SAMPLE)** is the fully-qualified input print stream name without single quotes.
   • **PDR.OUTPUT(SAMPLE)** is the fully-qualified output print stream name, without single quotes.
   • `length` indicates the size of the length indicator on each record: 2 for two bytes or 4 for four bytes. The default is 2.
   • `format` indicates the order of bytes in the length indicator: M for maximum or P for PC. The default is P.
• include indicates whether the value of the length indicator includes the length indicator itself: I for include or E for exclude. The default is E.
• startrec is the starting record number to copy from the input to the output. The default is record 1.
• numb is the number of lines to copy from the input to the output. The default is 10 million lines or to the end of the input.

**NOTE:** You can invoke the PDRLNADD load module with %PDRLNADD as shown in the example above if PDR STREAMW EXEC is allocated in your SYSEXEC DD. If it is not allocated, you can invoke the load module with EX ‘PDR STREAMW EXEC(PDRLNADD)’.

Step 2: Transfer the File

Transfer the file from the mainframe using the file extension and "download as" setting appropriate for your print stream. Refer to the table below for the appropriate settings.

### Table 1: File Extensions Used with Visual Engineer

<table>
<thead>
<tr>
<th>Print Stream Type</th>
<th>File Extension</th>
<th>IND$FILE Download As</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line printer data (see note)</td>
<td>*.LIN</td>
<td>CRLF ASCII</td>
</tr>
<tr>
<td>DJDE (see note)</td>
<td>*.DJD</td>
<td>CRLF ASCII</td>
</tr>
<tr>
<td>Metacode</td>
<td>*.MET</td>
<td>Binary with lengths added to each record by the PDRLNADD utility on z/OS</td>
</tr>
<tr>
<td>AFP line data (see note)</td>
<td>*.AFL</td>
<td>CRLF ASCII</td>
</tr>
<tr>
<td>AFPDS</td>
<td>*.AFP</td>
<td>Binary</td>
</tr>
<tr>
<td>AFP mixed-mode</td>
<td>*.AFM</td>
<td>Binary CRLF</td>
</tr>
<tr>
<td>PCL</td>
<td>*.PCL</td>
<td>Binary</td>
</tr>
<tr>
<td>PostScript</td>
<td>*.PS</td>
<td>Binary</td>
</tr>
</tbody>
</table>

After you download your print stream, you can load it into Enrichment Visual Engineer and define the properties for that print stream.

**Specifying Metacode Record Format**

The *Metacode Record Format* window lets you specify the record format (length indicator position and size) and the text format (ASCII or EBCDIC) for a Metacode print.
stream. The window appears automatically when you open this type of print stream. (For instructions on how to open a print stream, see “Opening a Print Stream” on page 25.

The length indicator identifies the size of each record in bytes. You cannot read Metacode print streams on the PC unless each record has been prefixed with a length indicator. If your print stream does not contain length indicators, you must run the PDRLNADD load module (or another company’s blocking software) before you can load it into Enrichment Visual Engineer Plus.

There is no industry standard for length indicators.

The fields in this window are described next.

- **Size**: Sets the size of the record length indicator.
  - **2 bytes**: The size of the record length indicator is two bytes.
  - **4 bytes**: The size of the record length indicator is four bytes.
- **Order of Bytes**: Specifies the internal number storage format for the print stream.
  - **MSF (mainframe format)**: The most significant bytes come first (also referred to as big-endian format). This is the format used on mainframes and most UNIX systems.
  - **LSF (PC format)**: The least significant bytes come first (also referred to as little-endian format). This is the format used on Windows systems.
- **Inclusion**: Indicates whether the record length indicator includes the indicator itself.
  - **Includes indicator**: The record length indicator includes the length of the indicator itself.
• **Excludes indicator:** The record length indicator does not include the length of the indicator itself.

• **Reset Indicators to Standard Formats:** Sets the Size, Order of Bytes, Inclusion, and Text Format according to the software used to generate the print stream. Clicking one of these options will automatically change the settings in the other fields as appropriate.

• **Text Format:** Specifies the record text format.
  - **ASCII:** The record text format is ASCII.
  - **EBCDIC:** The record text format is EBCDIC.

### Specifying Mixed AFP Record Format

The *Mixed AFP Record Format* window lets you specify the record format (length indicator type) and the text format (ASCII or EBCDIC) for a mixed AFP print stream. The window appears automatically when you open this type of print stream. (For instructions on how to open a print stream, see “Opening a Print Stream” on page 25.

You cannot read mixed AFP print streams on the PC unless each record has been prefixed with a length indicator or unless the print stream contains CRLF. This length indicator identifies the size of each record in bytes. If your print stream does not contain length indicators or CRLF, you must run the PDRLNADD load module (or another company's blocking software) before you can load it into Visual Engineer Plus.

There is no industry standard for length indicators. The *Mixed AFP Record Format* dialog box lets you select any format. Or, you can select the name of the company whose software produced the print stream (and length indicators) to automatically set
the appropriate specifications.

![Mixed AFP Record Format](image)

The fields in this window are described next.

- **Record Format**: This specifies the following:
  - **Length indicator on each record**: Each record in the print stream contains a length indicator.
  - **No indicators (CRLF reqd)**: The records in the print stream do not contain length indicators. In this case, each record must end with CRLF. If you are transferring the file from a mainframe, transfer the file as binary (no translation) and CRLF. Or, use the PDRLNADD load module to prefix each record with a length indicator. If you select this option you do not need to complete the other fields in the Mixed AFP Record Format window.

- **Size**: Sets the size of the record length indicator.
  - **2 bytes**: The size of the record length indicator is two bytes.
  - **4 bytes**: The size of the record length indicator is four bytes.

- **Order of Bytes**: Specifies the internal number storage format for the print stream.
  - **MSF (mainframe format)**: The most significant bytes come first (also referred to as big-endian format). This is the format used on mainframes and most UNIX systems.
  - **LSF (PC format)**: The least significant bytes come first (also referred to as little-endian format). This is the format used on Windows-based systems.

- **Inclusion**: Indicates whether the record length indicator includes the indicator itself.
• **Includes indicator**: The record length indicator includes the length of the indicator itself.

• **Excludes indicator**: The record length indicator does not include the length of the indicator itself.

• **Reset Indicators to Standard Formats**: Sets the Size, Order of Bytes, Inclusion, and Text Format settings according to the software used to generate the print stream. Clicking one of these options will automatically change the settings in the other fields as appropriate.

• **Text Format**: Specifies the record text format.
  - **ASCII**: The record text format is ASCII.
  - **EBCDIC**: The record text format is EBCDIC.

**Specifying PCL Record Format**

The *PCL Record Format* window lets you specify the end of record indicator and the record text format (ASCII or EBCDIC) for a PCL print stream. The window automatically appears when you open this type of print stream. (For instructions on how to open a print stream, see “Opening a Print Stream” on page 25.

The fields in this window are described next.

• **Line Termination String in Hex**: Indicates the type of line termination string.
  - **CR/LF**: Click this button to specify X’0D0A’ as the line termination string.
  - **Linefeed**: Click this button to specify X’0A’ as the line termination string.

• **Text Format**: Specifies the record text format.
  - **ASCII**: The record text format is ASCII.
  - **EBCDIC**: The record text format is EBCDIC.
Specifying FIX Print Stream Record Information

The *FIX Print Stream Record Information* window lets you specify the record length of the fixed length record non-delimited print stream. This window automatically appears when you open this type of print stream. (For instructions on how to open a print stream, see “Opening a Print Stream” on page 25.

![FIX Print Stream Record Information Window](image)

In the *Record Length* field, specify a numeric value greater than zero.

Specifying Print Stream Properties

The *Print Stream Properties* window lets you define how Visual Engineer Plus interprets the print stream you loaded. To access this window, select *File > Print Stream Properties*. If the properties of your print stream are not defined properly, your input definition file will contain errors. Visual Engineer Plus sets all properties to the Enrichment defaults unless you modify them.

**Note:** You cannot change the print stream type after you have defined a field for the print stream. When you change the print stream type in this situation, the fields return to the default settings.
The fields in this window are described next.

- **Name**: A unique name of up to 50 characters for the input print stream. The name cannot contain spaces.
- **Host File**: The location and name of the file associated with the input. Use one of the following formats.
  - DD:ddname
  - DD:ddname(member)
  - 'qualifier.qualifier.qualifier'
  - 'qualifier.qualifier.qualifier(member)'

  The location and name can be up to 55 characters in length.

**NOTE**: If you are using Enrichment on a UNIX system, DD:ddname is the only valid host file name format.

- **Print Stream Type**: Select one of the following print stream types:
  - **Impact Line Data**: The input is line-printer data.
  - **Xerox DJDE line data**: The input is a Xerox DJDE line-data print stream.
  - **Xerox Metacode**: The input is a Xerox Metacode print stream.
  - **Xerox Metacode with Font Index**: The input is a Xerox Metacode with font index print stream.
  - **AFP Line Data**: The input is an AFP line-data print stream (that is, it contains no AFP [X'5A'] records and uses both a PAGEDEF and a FORMDEF to print).
• **AFP Fully Composed (AFPDS):** The input is an AFPDS print stream (that is, it contains only AFP [X'5A'] records and uses a FORMDEF).

NOTE: You cannot specify a channel type if you select AFP Fully Composed for the print stream type.

• **AFP Mixed (line with PTX):** The input is a mixed-mode AFP data print stream (that is, it contains some AFP [X'5A'] records and uses both a PAGEDEF and a FORMDEF to print).

• **PCL:** The input is a PCL print stream.

• **PostScript:** The input is a PostScript print stream.

• **Carriage Control:** Select one of the following:
  • **ANSI:** The input contains ANSI channel controls in column 1 that are of the same character set as the print stream.
  • **ANSI ASCII:** The input contains ASCII carriage controls in column 1 even if the print stream is EBCDIC.
  • **ANSI EBCDIC:** The input contains EBCDIC carriage controls in column 1 even if the print stream is ASCII.
  • **Machine:** The input has machine code carriage controls in column 1.
  • **None:** There are no carriage controls in column 1 of the input.

• **Data Type:** Select one of the following:
  • **ASCII:** The print stream is in ASCII format. This is the native character set for Windows and UNIX.
  • **EBCDIC:** The print stream is in EBCDIC format. This is the native character set for mainframe environments.

• **Layout Options:** See the following sections for information about the layout options.
  • **Control Information Areas:** See “Specifying Control Information Areas” on page 37.
  • **Page Layout:** See “Defining Page Layout” on page 38.
  • **AFP/DJDE Commands:** See “Defining DJDE Record Layout” on page 39.

• **Processing Options:** See the following sections for information about processing options.
  • **Sorting and Storage:** See “Defining Sorting and Storage Options” on page 41.
  • **Page Reordering:** See “Page Reordering” on page 42.
  • **Duplex Processing:** See “Duplex Processing” on page 43.
  • **Variable Substitution:** See “Enabling Variable Substitution” on page 44.
Specifying Control Information Areas

The Control Information Areas window lets you define regions of the print stream that you want Enrichment to ignore during processing (headers, trailers, and skip columns). You can also set the control areas, DJDE IDEN areas, and DJDE data areas by selecting the area you want in the print stream and then right-clicking.

The fields in this window are described next.

Header Control

- **Number of Records**: Select this option to specify the number of records at the top of the input to ignore during processing.
- **Header String**: Select this option to enter a string that will indicate that the end of the header has been reached.
- **Copy to Output**: Select this option to include the header lines in each output.
- **Loaded in Print Stream**: Select this option if the header records exist in the print stream being analyzed.

Other Control Areas

- **Trailer Lines**: Specify the number of records at the bottom of the input to ignore during processing. Select **Copy to Output** to include the trailer lines in each output. Select **Loaded in Print Stream** if the trailer records exist in the print stream being analyzed.
- **Skip Columns**: Specify the number of contiguous columns on the left side of each record in the print stream to ignore during processing. Select **Copy to Output** to
include the skip columns in each output. Select **Loaded in Print Stream** if the skip columns exist in the print stream being analyzed.

- **Skip string:** Type the data that Enrichment will use to fill skipped column space for records added during processing. You need to complete this field only if you selected the **Copy to Output** check box for skip columns. You can specify any alphanumeric text string, binary string, or hexadecimal string. If the string is a text string, enclose it in single quotation marks. Binary strings must begin with \texttt{b'} or \texttt{B'} and end with \texttt{'} . Hexadecimal strings must begin with an \texttt{x'} or \texttt{X'} and end with \texttt{'}.

**Note:** If you clear the Loaded in Print Stream check box for any value you supply for the **Header Lines**, **Trailer Lines**, or **Skip Columns** fields, the next time you open the input definition file Visual Engineer Plus will assume that the control information is loaded in the print stream. This can change field information. To correct the control information, clear the Loaded in Print Stream check box or boxes again.

### Defining Page Layout

The **Page Layout** window lets you define options for adding objects such as barcodes or text to the documents. To access this window, open a print stream, select **File > Print Stream Properties**, and then click **Page Layout**.

![Page Layout Window](image)

The fields in this window are described next.

#### Page Orientation

- **None:** Select this option if a page presentation is not defined in the copy group for an AFP input. If this is the case then Enrichment uses the presentation defined in the active FORMDEF.
• **Portrait**: Select this option if the copy group for an AFP input specifies that the page is vertically oriented (that is, the page is taller than it is wide).

• **Landscape**: Select this option if the copy group for an AFP input specifies that the page is horizontally oriented (that is, the page is wider than it is tall).

**Page Size**

• **Paper Size**: Type the width and height of the sheet of paper using the selected unit of measure.

• **Print Area**: Type the width and height of the printable area of each page using the selected unit of measure.

**Density (dpi)**

Select the density at which each page should print. If you select **Other**, type a number between 100 to 3,000 to indicate the specific number of pels per inch to print.

**AFP Copy Group Offset**

• **X**: Type the distance from the origin point to the x offset to establish where added objects should be placed. The setting can be from 0 to 100 inches, or the equivalent. The origin depends upon whether the FORMDEF is set for portrait or landscape presentation.

• **Y**: Type the distance from the origin point to the y offset to establish where added objects should be placed. The setting can be from 0 to 100 inches, or the equivalent.

**Defining DJDE Record Layout**

This window lets you control automatic detection and processing of DJDE line data and Metacode data. To access this window, open a print stream, select **File > Print Stream Properties**, and then click **AFP/DJDE Commands**.
The fields in this window are described next.

- **Identifier**: Type a constant string of up to 255 characters in length by which Enrichment can identify a Xerox DJDE record in the input.
- **Identifier is EBCDIC**: Check this box if the identifier you entered in the Identifier field is in EBCDIC.
- **Offset**: Type the number of columns before the DJDE prefix begins, not counting channel 1.
- **Skip**: Type the number of columns before the DJDE data begins, not counting channel 1.

### Defining a Copy Group and Page Format

The AFP Print Stream Information window lets you define a copy group and page format for all types of AFP line data. To access this window, open a print stream, select File > Print Stream Properties, and then click AFP/DJDE Commands.

The fields in this window are described next.

- **Copy Group**: Type up to eight characters to name the copy group you want to use.
- **Page Format**: Type up to eight characters to name the page format you want to use.
Defining Sorting and Storage Options

The Sorting and Storage window lets you define how to use temporary storage if you will be sorting or consolidating the input. To access this window, open a print stream, select File > Print Stream Properties and then click Sorting and Storage.

The fields in this window are described next.

- **Temporary Storage Method**
  - **Memory, then Hiperspace, then Disk**: Select this option to try memory, then Hiperspace, then disk until Enrichment finds a processing area that can hold all the input print streams.

  **NOTE:** Hiperspace is only available in mainframe environments.

  - **Hiperspace, then Disk**: Select this option to try Hiperspace and then disk until Enrichment finds a processing area that can hold all the input print streams.

  **NOTE:** Hiperspace is only available in mainframe environments.

  - **Memory**: Select this option to use memory only. This is the fastest I/O area. Use memory when the total size of all files being processed is less than 2 gigabytes or when you do not plan to sort, match, or presort.

  - **Disk**: Select this option to use disk only. This is the slowest I/O area. Use disk only for sorting or presorting very large files.

  - **Hiperspace (mainframe only)**: Select this option to use Hiperspace only. This is an area of moderate speed. Use Hiperspace for sorting or presorting large files.

  - **The input is sorted before Enrichment**: Select this check box if the documents in the input were previously sorted. Clear this check box if the documents in the input were not previously sorted.
• **Maximum Record Size**: Type the maximum length of records in the input, in the range 1 to 32,000 bytes, for use by VSAM files and Hiperspace.

• **VSAM Temporary Disk Names**: Type the VSAM file name or names in which to temporarily store input data using one of the following formats:
  
  • DD:ddname
    
    where ddname is the data definition of the ESDS VSAM file to use.
  
  • 'qualifier.qualifier.qualifier'
    
    where qualifier is each qualifier under which the ESDS VSAM file to use is stored. If you do not enclose the value in single quotes, the user ID from which Enrichment is invoked is automatically inserted as the first qualifier.

Each VSAM Temporary Disk Name input field sets one `<TEMPDISK>` tag.

**NOTE:** If you need to specify more than five VSAM files, you must do so manually.

---

**Page Reordering**

The *Page Reordering* window lets you specify how you would like to reorder the pages in each document of the print stream. To access this window, open a print stream, select *File > Print Stream Properties* and then click *Page Reordering*.

The fields in this window are described next.

• **None**: Select this option to leave the pages in the order in which they appear.

• **Reverse pages**: Select this option to reverse the order of all pages in each document.

• **Move first page to last**: Select this option to move the first page of each document so that it becomes the last page of the document.
• **Move last page to first**: Select this option to move the last page of each document so that it becomes the first page.

• **Imposition (booklet form)**: Select this option to order the pages for 2-up duplex page and position, adding up to three pages to achieve proper pagination for a booklet.

## Duplex Processing

The *Duplex Processing* window lets you define duplex options and control how objects are appended to or merged with this print stream. To access this window, open a print stream, select *File > Print Stream Properties*, and then click *Duplex Processing*.

![Duplex Processing Window](image)

The fields in this window are described next.

• **Input print stream is duplex**: Select this check box if the input is already formatted to print on both sides of a sheet of paper (duplex). Clear this check box if the input will print only on one side of the paper (simplex).

• Appending and Merging Controls: Select any of the following:
  
  • **Document must start on front of page**: Select this check box if the input must start on the front of a new sheet of paper. Clear this check box if the input need not start on the front of a new sheet of paper.
  
  • **Back of sheet must be blank**: Select this check box if each input document that ends on the front of a sheet of paper must leave the back of the sheet blank. Clear this check box if the back of the last page of each document need not be blank.

  • **Back of sheet must be blank**: Select this check box if each input document that ends on the front of a sheet of paper must leave the back of the sheet blank. Clear this check box if the back of the last page of each document need not be blank.
Enabling Variable Substitution

The Variable Substitution window enables Visual Engineer Plus to substitute variable values for variable names in the input. To access this window, open a print stream, select File > Print Stream Properties, and then click Variable Substitution.

Clear this check box to prevent the substitution of variable values for the variable names in the input. In this case, the variable names will print in the output.

Specifying Line Formats

You can display a print stream in native, non-native, and hexadecimal mode by using the Line Formats window. The native format is determined by the option you select for the Data Type on the Print Stream Properties window. For example, if you select ASCII for the Data Type, the native format of the print stream is ASCII.

Visual Engineer Plus can also provide a line-by-line explanation of hexadecimal data. The example below contains two lines of a print stream with all line formats displayed.

The line formats are displayed in the following order: native, non-native, HEX, and the HEX explanation. In this example, the first line is EBCDIC, the second line is ASCII, the third and fourth lines are HEX, and the fifth line is an explanation of the HEX data.

Hexadecimal values consist of two characters. Use the corresponding characters in the third and fourth rows to determine the hexadecimal value of the character in a column. For example, the hexadecimal value of the first character on the first line of the example is 5A.
To set the line formats for a print stream, click **View > Line Formats**. The **Line Formats** window is displayed.

The fields in this window are described next.

- **Native**: Select this check box to display the print stream using the character set associated with the print stream data format (ASCII or EBCDIC). (To set the print stream data format, select **File > Print Stream Properties**.)
- **Non-native**: Select this check box to display the print stream in the character set opposite to that associated with the print stream data format (ASCII or EBCDIC). (To set the print stream data format, select **File > Print Stream Properties**.)
- **HEX**: Select this check box to display the print stream data in hexadecimal format. HEX data is displayed in two lines.
- **Explanation**: Select this check box to display an explanation of the data. The explanation line is useful for AFP, PCL, PostScript, DJDE, and Metacode data.

### Specifying Resources

Use the **Resources Specification** window to provide the location of print resources that the graphic viewer needs to display the print stream properly. Examples of resources include fonts and (for Metacode print streams) logo files.

**Note**: Font files must not have a file extension. Remove the extension from the file name before using it with Visual Engineer.
To access this window, open a control file and then select Options > Resources.

The following fields and buttons are available:

- **Search Directory**: Specifies the directory that contains the resource you want to make available to the graphic viewer.
- **Browse**: Click this button to browse the file system and select the directory that contains the resource you want.
- **Add**: Click this button to add the path in the Search Directory field to the library collection.
- **Resources List**: Lists all of the current directories in the user library.
- **Remove**: Click this button to remove the highlighted item from the Resources List field.
- **Up**: Moves the selected resource up in the order of precedence. The resources listed in the Resources List field are searched in the order shown.
- **Down**: Moves the selected resource down in the order of precedence. The resources listed in the Resources List field are searched in the order shown.

**Specifying Metacode Fonts**

The Metacode Font Specification window lets you specify the fonts used in a Metacode print stream. You only need to specify Metacode fonts with this window if the DJDE FONTS parameter is not in the print stream. In most cases you do not need to specify Metacode fonts.

**Note**: Font files must not have a file extension. Remove the extension from the file name before using the font with Visual Engineer.
To access this window, open the control file that references the Metacode print stream then select **Options > Metacode Fonts**. Be sure to enter the fonts in the same order as they are specified in the print stream's JSL.

The following fields and buttons are available:

- **Font Name**: Enter the name of the font.
- **Add**: Click this button to add the font name to the font list.
- **Font List**: Lists all of the fonts defined for the print stream.
- **Remove**: Click this button to remove the highlighted font from the Resources List field.
- **Up**: Moves the selected font up in the order of precedence. The fonts listed in the Font List field must be listed in same order as they appear in the print stream's JSL.
- **Down**: Moves the selected font down in the order of precedence. The fonts listed in the Fonts List must be listed in the same order as they appear in the print stream's JSL.

### Defining Page and Document Breaks

After you open a print stream in Visual Engineer you must indicate where the page and document breaks are. For more information, see:

- “Setting and Verifying Page Breaks” on page 48
- “Setting and Verifying Document Breaks” on page 49
Setting and Verifying Page Breaks

Before you create any fields, you must set the page breaks in the print stream. Then, you should verify that Enrichment Visual Engineer Plus has correctly identified page breaks.

To set page breaks:

1. Select Document > Set Page Top or click the Set Page Top button. The Set Page Top dialog box is displayed.

2. Fill in the fields in the dialog box and click OK. The fields are listed described below.

   - **Standard**: Select this option if you want Visual Engineer Plus to automatically determine the page breaks based on standard techniques such as carriage controls, copy groups, Begin Page (BPG) structured fields, and DJDE headers.

   - **By Field Specification**: Select this option to define page breaks by the location of a certain field. Then, select the field that you want to use to identify the top of a page. In center box, you can select one of the following:

     - **Equals**: Select this option if you want a new page to start whenever the value in the field matches the specific entered to the right.

       If you select Equals, the HEX check box becomes available. Check this box if you want to specify a hexadecimal value for the field.

     - **Changes**: Select this option if you want a new page to start whenever the value in the field changes.

     - **Exists**: Select this option if you want a new page to start whenever the field appears, no matter what the value in the field happens to be.

   **NOTE**: When you use the By Field Specification option to set the page breaks, Visual Engineer ignores the settings on Field Information dialog box and searches for all occurrences of the field.
• **Automatically set field values**: Select this check box to automatically set the field specifications based on the field you selected prior to opening this dialog box.

• **Ignore copy groups and DJDE records**: Select this check box to ignore copy groups or Xerox DJDE records that would ordinarily indicate a page. Clear this check box to include copy groups or Xerox DJDE records when determining page breaks.

3. Click **OK**. Visual Engineer Plus finds all pages.

4. Verify that the number of pages is correct.

To verify page breaks:

Scroll through the print stream using the Next Page and Previous Page buttons to verify that the page breaks are in the correct place. Page breaks are indicated by a magenta line. You can also use the **Find Pages and Documents** command from the **Document** menu to help you verify that the print stream contains the correct number of pages. The **Find Pages and Docs** dialog box displays the number of pages and documents Visual Engineer Plus found. If the correct number of pages was not found, you need to change the page break options.

### Setting and Verifying Document Breaks

To set document breaks:
1. Select *Document > Set Document*. The *Set Document* dialog box is displayed.

2. Complete the fields described below.

   - **Method 1**: Select this check box if each document in the input contains a specific number of pages. Select the number of pages. This field sets the `<DOCUMENT>` tag's *type* parameter.

     **NOTE**: You can use this method with Methods 2, 3, and 4 to create logical OR conditions.

   - **Methods 2, 3 and 4**: Select these check boxes to define document breaks by the location of a certain field or fields. Then, specify those fields, their condition (exists, changes, or equals), a value for the condition, if necessary, and whether the value is hexadecimal. Specify multiple fields within each method to indicate logical AND conditions. Combine Methods 1, 2, 3, and 4 to create logical OR conditions. The options for each of these methods are further described below.

     - **Top (First) Page**: Select this option if the specified field indicates the first page of each document. This field sets the `<DOCUMENT>` tag's *type* parameter.

     - **Bottom (Last) Page**: Select this option if the specified field indicates the last page of each document. This field sets the `<DOCUMENT>` tag *type* parameter.
- **Equals**: Select this option if you want a new page to start whenever the value in the field matches the value entered to the right.

  If you select **Equals**, the **HEX** check box becomes available. Check this box if you want to specify a hexadecimal value for the field.

- **Changes**: Select this option if you want a new page to start whenever the value in the field changes.

- **Exists**: Select this option if you want a new page to start whenever the field appears, no matter what the value in the field happens to be.

- **Automatically set field values**: Select this check box to let Enrichment automatically set the **Equals**, **Changes**, or **Exists** drop-down list (and to supply the **Equals** value) when you select a field.

3. Click **OK**. Enrichment Visual Engineer Plus finds all documents. At this point you should verify that the number of documents is correct.

To verify document breaks:

Scroll through the print stream using the Next Document and Previous Document buttons to verify that Enrichment Visual Engineer Plus has correctly identified document breaks. Document breaks are indicated by a green or dark magenta line. You can also use the **Find Pages and Documents** command from the **Document** menu to help you verify that the print stream contains the correct number of documents. The **Find Pages and Docs** dialog box displays the number of documents Visual Engineer Plus found. If it did not find the correct document breaks, you will need to change the document break options.

**Fields**

You can work with fields in both the data viewer and the graphic viewer. For information on working with fields, see:

- “Creating a Field” on page 52
- “Editing Field Properties” on page 56
- “Editing Field Reference Properties” on page 60
- “Extracting Variable-Length Text” on page 62
- “Copying a Field” on page 63
- “Changing a Field’s Location” on page 64
- “Changing a Field Reference” on page 65
- “Deleting a Field” on page 65
- “Deleting a Field Reference” on page 66
- “Defining Address Fields” on page 66
- “Reporting Field Values” on page 67
Working with Print Streams

Creating a Field

There are two ways to identify a field: by a constant position on the page or a position relative to some constant string on the page. If the data is printed at the same position on the page every time, use a fixed field. If the data floats on the page but is always positioned relative to a constant string (text or hexadecimal), use a reference field.

For complex print streams, such as AFP and Metacode, you may want to display an explanation before you create a fixed or reference field. Visual Engineer can display a line-by-line explanation of either the entire print stream or a selected portion of the print stream. For more information, see “Displaying an Explanation” on page 22.

**Note:** Enrichment Visual Engineer Plus sets all field properties to the Enrichment defaults unless you modify them.

Creating a Reference Field

1. Open the print stream in which you want to create the field. For more information, refer to "Opening a Print Stream" earlier in this chapter.

2. Click **Field > Create Empty Field**. (If the Fields list is empty, you cannot select Create Empty Field from the Field menu. Go to step 3.)

   If you defined or edited a field that has not been saved or added to the Fields list, the Field Information Has Changed window is displayed. Click **Yes** to save the field or **No** if you do not want to save the changes to the field.

3. Use the mouse to select the static text that will serve as the reference point for the field. For example, if you want to create a field to capture the sender, you would set the text "FROM:" as the reference point because the name of the sender will follow this text.

   ```
   TO:  Lange, Douglas S.
   FROM:  Dan Kloeber
   DATE:  May 16, 1993
   SUBJECT:  Numbers, Plan Book Revisions
   ```

   **NOTE:** If you click on any alphanumeric string that is delimited by a blank (or that is delimited by a hex value that is less than 20), such as a word or ZIP Code™, Visual Engineer Plus automatically selects and outlines the string.

4. Click **Field > Set Reference**. The Field Reference dialog box is displayed.

5. Fill in the fields and click **OK**. For more information, see "Editing Field Reference Properties" below.
6. The field reference is highlighted in yellow. Use the mouse to select the location of the data you want to capture in the field. Continuing the example above, if you want to create a field to capture the sender and you have defined "FROM:" as the reference point, you would select the actual name, as shown below.

   TO:  Lange, Douglas R.
   FROM:  Dan Kloiber
   DATE:  May 16, 1993
   SUBJECT:  Numbers, Fian Book Revisions

7. Click Field > Set Location. The Field Reference dialog box is displayed.

8. If you are prompted with a Create Field window, select one of the following:

   • Create field from reference: Select this option if the field's position is relative to some other printable element in the print stream. For example, if you want to create a field that contains an account number and the account number data always appears after the string "Account Number: ", then you would use the string as a reference.

   • Create field from position in print stream: Select this option if the field's position is always the same in the Data view. This option is most often used with line data. It has limited use with AFPDS and Metacode because in these print streams text is always specified with coordinates.

   • Create field from position on page: Select this option if the field's position is determined by an absolute position specified on the page. This option is available only if the text you selected is preceded in the underlying print stream by an absolute position. Consider the following example:

     John Smith
     123 Main St.
     Anytown, IL 60532

     If the string "John Smith" is positioned by the print stream with an absolute X position of 600 pels and an absolute Y position of 400 pels, but the string "123 Main Street" is positioned using "relative X position of -300 pels" and "relative Y position of 100 pels", then you could choose the Create field from position on page option for the name "John Smith" and the field's position would be determined by the absolute positioning specified in the print stream data. The option Create field from position on page would not be available for the string
"123 Main St." because the print stream uses relative positioning to place the text on the page.

9. Complete the fields and click **OK**. For more information, see "Editing Field Properties" below.

10. If you do not have a control file open, select **Field > Add Field To List** to add the field to the Fields list. If you have a control file open the field is added automatically to the Fields list.

11. Verify that the field was properly defined. To do this, generate a report of all values for the field. For more information, see “Reporting Field Values” on page 67.

**Creating a Fixed Field**

1. Click **Field > Create Empty Field**. (If the Fields list is empty, you cannot select **Create Empty Field** from the **Field** menu. Go to step 4.)
2. If you defined or edited a field that has not been saved, the Field Information Has Changed window is displayed. Click Yes to save the field or No if you do not want to save the changes to the field.

3. If there is a field already selected in the Fields list, you will be asked whether you want to create a new field or modify the existing field. Make a selection and then click OK.

4. Use the mouse to select the location. For example, if a set of identification numbers appears in the same location on each page, you could use the mouse to select the number.

   ![Identification Number(s)](image)

   **NOTE:** If you click on any alphanumeric string that is delimited by a blank (or that is delimited by a hex value that is less than 20), such as a word or ZIP Code™, Visual Engineer Plus automatically selects and outlines the string.

5. Click Field > Set Field Location. The Field Reference dialog box is displayed.

   **NOTE:** If you are working with an AFP print stream and the print stream uses relative positioning to describe the text you selected, the Set Field Location option will be unavailable. In this case you must use a reference field for the text you selected. See "Creating a Reference Field" above.

6. Fill in the fields and click OK. For more information, see "Editing Field Properties" below.
7. The field is highlighted in green. If you do not have a control file open, select Field > Add Field To List to add the field to the Fields list. If you have a control file open the field is added automatically to the Fields list.

8. Verify that the field was properly defined. To do this, generate a report of all values for the field. For more information, see “Reporting Field Values” on page 67.

Editing Field Properties

The Field Information window lets you define the properties for a field. To access this window, right-click the field. The Field Information window also appears when you create a new field. You can identify fields by using either a fixed position from the top of the page or from a floating reference point. If the field you are defining does not have
a reference defined, some fields will be unavailable. You may notice some other fields are unavailable too depending upon the type of print stream you are analyzing.

The fields in this window are described next.

- **Name**: Enter up to 50 characters that will identify the field. The name cannot contain spaces. You must name field variables with a %%% prefix (field variables are used in rule files and in address processing). For example, %%%customer.

- **Actions**: This determines the modifications to be made to the field when Enrichment processes it. Select one of the following options.
  - **Extract only (no updates)**: Extracts and uses the field information. You do not need read-write access to the data.
  - **Extract and Replace**: Replaces the field information. You must have read-write access to the data. Click the **Replace Options** button on the **Field Location** dialog box to define the replacement value.

  **NOTE**: If the field is identified with %%% as a field variable, rule processing or cleansing may change the value of the field. The new field will replace the original field information in the print stream.

- **Delete Field Only**: Removes the specified field information.
- **Delete Record with Field**: Removes the entire record with the field information.
- **Delete Page with Field**: Removes the entire page with the field information.
- **Reference available for field**: Select this check box if a reference exists for this field. Clear this check box if no reference exists for this field.
• **Adjust position of field**: Select this check box if the field is not in the print stream you are analyzing. A message is displayed. Click **OK** and define the position of the field. Clear this check box if the field you are defining is located in the print stream.

**Location of Field - Vertical**

The **Vertical** area contains fields that allow you to specify the vertical position of the field you are defining.

- **Line or Record #**: Type the line or record number in which the field will begin. This field sets the `<LOCATION>` tag `ROW` parameter.
- **Overprint Record**: If more than one record creates a single printed line, type the record number in which the field will begin.
- **From**: This area allows you to specify the method that will be used to determine the vertical location of the field. The options are:
  - **Page Top**: Select this option if the vertical location of the field is set at a fixed position from the top of the page. This field sets the `<LOCATION>` tag `ROW` parameter.
  - **Reference**: Select this option if the vertical position of the field is measured from a reference point in the print stream.
- **Unit**: This area allows you to specify the units used to measure vertical position. The options are:
  - **Print Lines**: Select this option if the vertical position of the field is measured by lines of printed data.
  - **Record**: Select this option if the vertical position of the field is measured by records in the print stream data.

**Location of Field - Horizontal**

The **Horizontal** area contains fields that allow you to specify the horizontal position of the field you are defining.

- **Column**: Type or select the column number in which the field will begin.
- **Maximum Length**: Type or select the maximum length of the field information.
- **From**: This area allows you to specify the method that will be used to determine the horizontal location of the field. The options are:
  - **Column 1**: This option is selected if the horizontal position of the field is measured from column 1 of the print stream.
  - **Reference**: This option is selected if the horizontal position of the field is measured from a reference point in the print stream.
Searching Options

This area allows you to specify how Enrichment will search the print stream to find the field.

- **Pages to Search**: Select one of the following options from the drop-down list or specify a range of pages to search in the (range) field.
  - **First Page Only**: Searches only the first page of each document for this field.
  - **Last Page Only**: Searches only the last page of each document for this field.
  - **All Except First**: Searches all pages of a document except the first for the field.
  - **All Except Last**: Searches all pages of a document except the last for the field.
  - **All Pages**: Searches all pages of all documents for the field.
  - **Middle Pages (not first or last)**: Searches all pages of each document except the first and last.
  - **Page Range Specified Below**: Searches only the pages you specify in the (range) field.

- **(range)**: This field is available only if you select **Page Range Specified Below** in the **Pages to Search** field. Specify the range of pages in which you want to search using one of the following formats (where num is a number or page number):
  - **num**: Look for the field information on a specific page in each document.
  - **num1 num2**: Look for the field information in a range of pages in each document. Separate the page specifications with a space.
  - **num L**: Look for the field information in a range of pages that begins at page num and ends at the last page in each document. Separate the page specifications with a space.
  - **num1 L-num2**: Look for the field information in a range of pages that begins at page num1 and ends num2 pages before the last page in each document. Separate the page specifications with a space.
  - **L-num**: Look for the field information on a specific page that is num pages before the last page in each document.
  - **L-num L**: Look for the field information in a range of pages that begins num pages before the last page and ends on the last page in each document. Separate the page specifications with a space.
  - **L-num1 L-num2**: Look for the field information in a range of pages that begins num1 pages before the last page and ends num2 pages before the last page in each document. Separate the page specifications with a space.

For example, 3 L-1 indicates a range from page 3 to the second-to-last page.

- **Number to Find**: Determines when Enrichment should act upon a field. The options are:
  - **First One Only**: Finds and acts upon only the first occurrence of the field in each document within the specified page range.
• **First on Each Page:** Finds and acts upon the first occurrence of the field on each page within the specified page range.

• **All:** Finds and acts upon all occurrences of the field within the specified page range.

**NOTE:** This option does not apply to fields that are used to identify the top or bottom of a document or page.

• **Remove blanks from extracted field:** Determines when to remove blanks from the extracted field.
  - **Left (leading):** Removes blank characters to the left of the field information.
  - **Right (trailing):** Removes blank characters to the right of the field information.
  - **None:** Does not remove blanks from the field information.
  - **Both:** Removes blank characters on both the right and left side of the field information.

• **Extract Text Until:** Displays the `<TEXTUNTIL>` tag specifications. Click **Extract Text Until** to modify the specifications. For more information on `<TEXTUNTIL>`, refer to the Enrichment Language Reference.

**Replacement Options**

• **Same size as extracted/modified:** Select this option if the variable is the same size as the extracted or modified field.

• **Constant size:** Select this option to set the length of the field to a specific number of characters. For example, if you specify 10, the field will always be replaced with 10 characters even if the variable replacing the field is only five characters long (leaving five blank characters).

• **Expand and contract field:** Select this check box to expand or contract the field that is being replaced to match the size of the variable that is replacing it (removing any extra spaces or adding spaces to prevent overlapping). Clear this check box to leave the size of the target field as is.

• **Justification:** Select one of the following options from the drop-down list:
  - **Left:** Left-justifies the field value when you replace it.
  - **Right:** Right-justifies the field value when you replace it.

• **Pad string:** Type up to five characters to use as a pad for the variable if necessary.

**Editing Field Reference Properties**

The **Field Reference** window allows you to specify how to locate the static text that will serve as the field reference. To access this window for an existing reference string,
click the field reference and then select Field > Reference Properties. You can also open this window by right-clicking the reference. By default, field references are highlighted in yellow. If the field location and reference overlap, they are displayed in cyan.

**Note:** If the field reference and field location overlap, the Overlap window is displayed. Click Reference and then click OK.

The fields in this window are described next.

- **Field Name:** Type up to 50 characters to name the field. The name cannot contain spaces. You must name field variables with a %% prefix (field variables are used in rule files and in address processing). For example,%%customer.
- **Reference String:** Visual Engineer Plus automatically fills in the reference string and hex designation (if applicable) using the section of the print stream that was highlighted when the reference string was selected.
- **HEX:** Select this check box if the point you are going to use as a reference is a hexadecimal value. Clear this check box if the point you are going to use as a reference is an alphanumeric value.
- **Source line in native format:** Select this check box if the point you are going to use as a reference is in the same data format (ASCII or EBCDIC) as the overall file. Clear this check box if the point you are going to use as a reference is not in the same data format as the overall file.
Working with Print Streams

- **With cc**: Select this option to search only records beginning with the indicated channel number for the reference point. If the specified channel is a hexadecimal value, select the **HEX** check box described above.

- **All records**: Select this option to search all records in the print stream for the reference point.

- **From column**: Select this option to specify a column number in which to look for the *string* value.

- **Direction**: Select one of the following options to specify the direction to search the print stream for the field.
  - **Exact**: Searches only in the column you specified in the *From Column* field.
  - **Left**: Starts searching from column 1 up through the column you specified in the *From Column* field.
  - **Right**: Starts searching from the column you specified in the *From Column* box to the end of the line.
  - **Any column**: Select this option to search all columns for the start of the reference string.

**Extracting Variable-Length Text**

The *Extract Text Until* window allows you to specify how Enrichment will pick up a variable-length text field and to define treatment of intervening AFP codes or Metacodes. To access this window, open a print stream, click on the field you want, select **Field > Properties**, and then click **Extract Text Until**.

**Note**: Visual Engineer supports only the creation of the *<TEXTUNTIL>* tag. The actual function of the tag will not be carried out until Enrichment begins processing the print stream.

The fields in this window are described next.
• **Data Type:** This allows you to select how Enrichment will detect the end of the extracted text. The options are:
  
  • **None:** Select this option if you do not want to specify the `<TEXTUNTIL>` tag while you are in the *Extract Text Until* dialog box or if you want to remove the `<TEXTUNTIL>` tag specified for the field.
  
  • **String:** Select this option to tell Enrichment to pick up field information until the string specified in the *Data Value* field is encountered.
  
  • **Absolute x move:** Select this option to tell Enrichment to pick up field information until an absolute x move is encountered. This option is valid only for AFPDS, AFPMIXED, or METACODE inputs.
  
  • **Relative x move:** Select this option to tell Enrichment to pick up field information until a relative x move is encountered. This option is valid only for AFPDS, AFPMIXED, or METACODE inputs.
  
  • **Absolute y move:** Select this option to tell Enrichment to pick up field information until an absolute y move is encountered. This option is valid only for AFPDS, AFPMIXED, or METACODE inputs.
  
  • **Relative y move:** Select this option to tell Enrichment to pick up field information until a relative y move is encountered. This option is valid only for AFPDS, AFPMIXED, or METACODE inputs.
  
  • **End of record:** Select this option to tell Enrichment to pick up field information until the end of the record is encountered.
  
  • **Text:** Select this option to tell Enrichment to pick up field information until any AFP code or Metacode is encountered. This option is valid for any input type except PCL and POSTSCRIPT.
  
  • **Data Value:** The type of value you enter in this field varies according to your selection under *Data Type*, as follows:
    
    • If you set *Data Type* to *String*, *Data Value* is the string at which Enrichment should stop picking up field information. This can be in any valid string format allowed by Enrichment. A string containing spaces should be enclosed in a pair of single quotes or double quotes.
    
    • If you set *Data Type* to *Absolute x*, *Relative x*, *Absolute y*, or *Relative y*, *Data Value* is a size measured in the units specified in the *Units* field that determines the point at which Enrichment will stop picking up field information. Leave *Data Value* blank to stop picking up field information at the first move of the specified type.
    
    • If you set *Data Type* to *End of record* or *Text*, leave *DataValue* blank.

### Copying a Field

The *Copy Field* window allows you to copy an existing field to create an identical new field.
To copy a field, follow these steps:

1. Select the field you want to copy from the Fields list.

2. Click Field > Copy Field. The Copy Field window is displayed.

3. Type a unique name for the field in the To box. The name can be up to 50 characters in length and cannot contain spaces. You must name field variables with a %% prefix (field variables are used in rule files and in address processing). For example, %%customer. This field sets the <FIELD> tag's name parameter.

4. Click OK. The new field is added to the Fields list.

5. Do one of the following:
   - Right-click over the highlighted field to display the Field Information or Field Reference dialog box. Change properties as necessary and click OK.
   - Select an area and click the Set Field Reference button or the Set Field Location button to modify the field reference or the field location.

**Changing a Field's Location**

To change a field’s location:

1. Select the field whose location you want to change from the Fields list. The field location is highlighted in green, and if it has a reference, the reference is highlighted in yellow. If the field location and reference overlap, they are displayed in cyan.

2. Use the mouse to select the new location and click the Set Field Location button (shown below).

   The New Field window is displayed.

3. Click **Modify Current Field** to move the field location.
4. Click **OK**. The new field location is displayed in green.

## Changing a Field Reference

A field reference is a static string used by a reference field to indicate the relative position of a field. For example, if you were to define a field for an account number that appears in different locations on different documents, but always appears after the string "YOUR ACCOUNT NUMBER:“, the field reference for the field would be "YOUR ACCOUNT NUMBER:“.

The procedure below describes how to change the field reference for an existing reference field. For example, you could use this procedure to change the field reference "YOUR ACCOUNT NUMBER:“ to "ACCOUNT NUMBER:“.

To redefine a field reference, follow these steps:

1. Use the Fields list to select the field whose field reference you want to change. After you select the field, it is highlighted in green and the field reference is highlighted in yellow. If the field location and field reference overlap, they are displayed in cyan.

2. Use the mouse to select the new reference position.

   **Note:** If you click on any alphanumeric string that is delimited by a blank (or that is delimited by a hex value that is less than 20), such as a word or ZIP Code™, Enrichment Visual Engineer Plus automatically selects and outlines the string.

3. Click **Field > Set Field Reference**. The **New Field** window is displayed.

4. Click **Modify Current Field** to move the field reference to a new position.

5. Click **OK**. The new field reference is displayed in yellow.

## Deleting a Field

To delete a field, follow these steps:

1. Select the field you want to delete from the Fields drop-down list and then click anywhere on the print stream.

2. Click **Field > Delete Field from List**. A message is displayed asking if you want to delete the field.
3. Click Yes to delete the field. Visual Engineer Plus removes the field from the Fields list.

Deleting a Field Reference

To delete a field reference:

1. Use the Fields list to select the field whose field reference you want to delete. After you select the field, the field location is highlighted in green and the field reference is highlighted in yellow. If the field location and reference overlap, they are displayed in cyan.

2. Click Field > Delete Reference. The Delete Reference window is displayed.

3. Click Yes to delete the field reference.

Defining Address Fields

The Address Fields window allows you to specify fields that will be used for postal address cleansing. To access this window, open a print stream and then select Field > Set Address. You do not need to define address fields unless you need to locate the ZIP Codes within the addresses, or cleansing the addresses.
The fields in this window are described next.

- **Perform CASS Cleansing**: Select this check box if you want to cleanse all addresses in the print stream. Clear this check box if you do not want to cleanse all addresses in the print stream.
- **Use Address Block**: Select this option to define an address by position and then complete the following fields.
  - **Row**: Select the row number in which the address block begins.
  - **Column**: Select the column number in which the address block begins.
  - **Width**: Select the width of the address block.
  - **Set Position**: Click this button to automatically set the **Row**, **Column**, and **Width** fields of the address block based on the text you selected before you opened the **Address Fields** window.
  - **Number of Lines**: Select the number of lines (or records) in the address block.
  - **Printed Lines**: Select this option to specify the number of printed lines in the address block. Printed lines are the lines that will actually print on the page, as opposed to data records, which include the text as it appears when you view the print stream using an editor or browser, such as ISPF or Hex Workshop.
  - **Data records**: Select this option to specify the number of lines in the address block in data records. Data records are the lines that display when you browse the print stream using an editor or browser, such as ISPF or Hex Workshop, as opposed to printed lines, which are the lines that actually print on the page.
  - **Replace address if changed**: Select this check box to replace the address if it changed as a result of CASS™ cleansing. Clear this check box if you do not want to replace the address even if it changed as a result of CASS™ cleansing.
  - **First page only**: Select this check box to act upon the address on the first page of each document only. Clear this check box to act upon all occurrences of the address in each document.
- **Use Address Fields**: Select this option to define an address by identifying fields (up to six) corresponding to each line of the address.

### Reporting Field Values

The **Report Field** window lets you create a report of the current field for all fields. To access this window, select **Fields > Report Field Values**.

The field report lists the name, document number, page number, record or line number, column number, and value of each field as well as the total number of fields found. You can use a field report to verify that your fields were created properly. If the list does not contain all the fields you expected to find, verify that the fields, print stream properties, page identifiers, and document identifiers are defined properly. You can copy the
information from the report and paste it in another application, such as a spreadsheet or text editor.

The fields in this window are described next.

- **Current field only**: Use this option to report on the field currently selected in the Fields list.
- **All fields**: Select this option to report on all fields.
- **Ignore search area restrictions defined for field**: Select this check box if you want to find all possible values of the field you have selected in the Fields list, ignoring the search limitations defined on the Field Information window. (To access the Field Information window, right-click the field in the graphic viewer.

### Input Definition Files

An input definition file (IDF) contains the Input tag group tags that are automatically generated when you work with a print stream using the data viewer or graphic viewer. The Input tag group defines the path to the print stream as well as the locations of fields, control areas, and other properties. For more information on the Input tag group, see the Language Reference.

You can use an IDF to apply a set of input tags to different print streams. This would allow you to define things like fields once then reuse them in different control files.

IDF files are not required. Usually you will not create an IDF because the definitions you create while using one of the print stream viewers will be automatically transferred to the control file that was open when you launched the viewer. You only need to create an IDF if you want to reuse an input tag group in different control files or if you open a print stream without having a control file open.

An example of an input definition file is shown below.

```
<INPUT>
<NAME>INPUT
<FILE>c:\printstreams\letters.lin
<TYPE>l A
<DOC>T %ID_NUMBER CHANGE
<FIELD>%ID_NUMBER
```
Creating an Input Definition File

The input definition file contains the code that is generated when you work with a print stream in either the data viewer or the graphic viewer. This code is written to the control file from which you launched the viewer. However, you can also export the input tag group to an external file called an input definition file (*.IDF).

To create an input definition file, follow these steps:

1. Select File > Open and open the print stream for which you want to create an IDF. For more information, see “Opening a Print Stream” on page 25.

2. Verify that the page breaks are defined correctly. See “Setting and Verifying Page Breaks” on page 48.


4. Define all fields. See “Creating a Field” on page 52.

**NOTE:** You can delete a field or field reference at any time. See “Deleting a Field” on page 65 and “Deleting a Field Reference” on page 66.

5. (Optional) Create a report of the field or fields you just created. A field report contains a list of all the fields and their values and provides the document and page
number of each field. You can use this report to verify that the fields were created properly. See “Reporting Field Values” on page 67.

6. (Optional) Set the address fields. You do not need to define the address fields unless you will be finding the ZIP Codes within the addresses in the print stream, cleansing the addresses, or performing a postal presort. See “Defining Address Fields” on page 66.

7. (Optional) Specify whether to create a simple or verbose input definition file. See “Control File Style” on page 70.

8. (Optional) Preview the Enrichment control file tags that you just created. See “Previewing Enrichment Tags” on page 72.

9. Save the input definition file by clicking File > Save. See “Saving an Input Definition File” on page 73.

Using an Existing IDF as a Template

If you have an existing input definition file (IDF) you want to use as a template for a new IDF, click the File > Open to open the IDF. The Open dialog box is displayed. Select your IDF and click OK.

After you make your changes to the IDF you are using as a template, be sure to save it as another file. To do this, select Save As from the File menu. Or, you can create a completely new IDF by selecting New from the File menu.

Control File Style

The Control File Style window lets you select whether to generate a simple or verbose input definition file (IDF). It determines the level of detail in the input definition file that is created as a result of the modifications you make to the print stream (defining fields, top of page indicators, etc.). To access this window, open a print stream and then select View > Control File Style.

![Control File Style Window]

The fields in this window are described next:
• **Simple:** Select this option to create an input definition file without the Enrichment default parameters for the Input tag group tags included in the control file.

  **NOTE:** If you select to create a simple control file, Enrichment still sets the default values for all tags that are included in the input definition file but does not display them.

• **Verbose:** Select this option to create an input definition file that contains the Enrichment default parameters for all the Input tag group tags.

### Importing an Input Definition File

You can import an existing input definition file (IDF) into a control file. When you do this, the Input tag group in the control file is replaced with that in the IDF.

To import an IDF, place the cursor at the point in your control file where you want the Input tag group to appear, and then select *Code > Import New IDF*.

### Applying an IDF to a Print Stream

You can open an existing IDF and apply its field definitions, print stream properties, page breaks, and other settings to the print stream that is currently open in the print stream viewer. This allows you to:

• Modify an existing IDF
• Preview how an IDF will be applied to a print stream (that is, view the fields, page breaks, document breaks, etc.)

To apply an existing IDF to a print stream, follow these steps:

Select *File > Open* and open the print stream you want to work with.

Select *File > Open Input Definition*. The *Input Definition Summary* window appears. This window summarizes the number of lines in the print stream, the number of fields in the IDF that were applied to the print stream, any error messages that were
encountered, and the number of pages and documents in the print stream based on the page and document breaks defined in the IDF.

Previewing Enrichment Tags

You can view the tags that will be created as part of the input definition file for the print stream. To preview the tags in the input definition file:
1. Click View > Preview Tags. The Preview Tags dialog box is displayed. Refer to the Enrichment Language Reference for information on tags and their values.

2. Use the scroll bars to view any areas not currently visible. You can copy information from this dialog box to the clipboard and paste it into another application. To copy information, select the text and press Ctrl+C.

3. Click OK when you finish viewing the tags.

Saving an Input Definition File

To retain any changes you have made to an open input definition file, select File > Save. When you save an input definition file for the first time, Enrichment Visual Engineer Plus displays the Save As dialog box. Complete the fields and click Save.

To save the open input definition file as another file, select File > Save As. The Save As dialog box is displayed. Complete the fields and click Save.

Adding Barcodes and Other Objects

Visual Engineer allows you to easily add barcodes, AFP overlays, AFP page segments, TLEs, and text. For a complete listing of supported barcodes, see the Enrichment Developer’s Guide. For information on using Visual Engineer to add barcodes and other objects, see:

- “Adding Barcodes and Objects to AFP or Metacode Print Streams” on page 74
- “Adding Barcodes and Objects to Non-AFP Print Streams” on page 84
Adding Barcodes and Objects to AFP or Metacode Print Streams

To add a barcode to an AFP or Metacode print stream, follow these steps:

1. Open the control file.

2. Right-click on an Output tag group and choose View Output Model. If there are multiple inputs in the control file you will be prompted to select the input to which you want to add the object.

   **NOTE:** The View Output Model feature displays a graphical representation of one of the input print streams, allowing you to easily add objects to the print stream.

3. The Find Pages and Docs window appears. Click OK.

4. The Input Definition Summary window appears. Click OK.

5. Right-click in the AFP print stream and select Add New. The Add Object Type window appears.

6. Select the object type you want to add and then click OK. The Add Component window appears. Depending on the kind of object being added, up to six tabs will be displayed. Each tab is described below.
General Tab

The fields on this tab are described next.

- **Identifier**: Assigns an ID to this object. This can be any meaningful ID you choose.
- **Which Pages**: Specifies the pages of the document where the object will be added.
- **Range**: Specifies the page range in which to add the object (if you select Page Range Specified in the Which Pages field).
- **Output**: Specifies whether you want to add the object to all output print streams or just the current print stream.
- **Orientation**: Specifies the number of degrees to rotate a barcode or text on the physical page.
- **Color**: Applies a color to the object.
- **Reset Color**: Applies a color to any data after the object in the print stream.
- **Presentation Method**: Specifies whether or not to use BCOCA.
  - **Drawn**: The object will be drawn.
  - **BCOCA**: Indicates that you would like to use the BCOCA (Bar Code Object Content Architecture) to describe and generate 2OF5 and 3OF9 barcodes. Only print streams with a density of 1440 are fully supported by `<BCOCA>`. Barcodes produced by `<BCOCA>` can only be printed on printers that support the BCOCA architecture.
Parameters Tab

The **Parameters** tab allows you to specify the data that will be used to generate the object. The fields on this tab are described next.

- **Constant:** The value for the object you are adding is a constant string. The string you specify varies depending on the type of object.
  - For TEXT or TLE all characters are valid.
  - For 3OF9, only numbers, uppercase alphabetic characters, special characters (-, $, /, +, %), and the space character (EBCDIC=X'40', ASCII=X'20') are valid as constant values. In addition, the first and last characters of the barcode must be asterisks (*). The asterisks should not be included for 3OF9 if you specified BCOCA on the **General** tab.
  - For 2OF5 and Matrix 2OF5, only numeric characters (0 through 9) are valid as constant values.
  - For DataMatrix and PDF417, alphanumeric characters are valid.
  - For Code 128, all ASCII characters are valid.
  - For PLANET and POSTNET, up to 16 characters, 12 numeric characters (up to 14 numeric characters for PLANET) and 2 framing, non-numeric characters. For example, 1012345678901!.
  - For 4STATE, a sequence of digits from 0-3 that represent each bar in the barcode. You can use the FOURSTATE function to generate this sequence of digits.
• For <ADDTYPE> OMR, a numeric string to add in one of the following formats:
  – A literal numeric string that contains any whole number from 1 to 16383.
  – A binary string that contains up to 14 characters.
  – A hexadecimal string that contains from one to four characters. If the string contains four characters, the first character cannot exceed 3.
• For ChinaPost, only numeric characters (0 through 9) are valid as constant values.
• Variable or Field: A variable name or field to include in the added barcode or text.
• Name: The name of a variable or field that you want to use as data for the object.
• Index: If using an array variable, this specifies the element in the array to use to populate the object.
• Length: Varies based on the object type, as follows:
  • For TEXT, TLE, 2OF5, CHINAPOST, MATRIX25, 3OF9, FORM, IMAGE, PLANET, and POSTNET, CODE128, DATAMATRIX, and PDF417, length is the length in bytes of the variable value identified in the Name field. Enrichment uses the justify and pad values to correctly position and lengthen the variable value. For PLANET and POSTNET, the maximum length is 16, including the 2 framing non-digit characters. For FORM and IMAGE, the maximum length is 8.
  • For OMR, length is the maximum number of Optical Mark Recognition (OMR) marks to use for a variable (from 1 to 14). For OMR, you can set the variable name to the system variable %%OMR_EVEN or %%OMR_ODD, which adds an extra mark if necessary to ensure an even (%%OMR_EVEN) or odd (%%OMR_ODD) number of OMR marks.

You can specify a length value for OMR constants. This enables you to "pad" the space before another add part so that it begins in a fixed position.

OMR marks cycle from 1 to the total number of marks specified and then back to no marks to repeat the cycle, as in binary counting.
• For 4STATE, each digit represents a single bar and the length is the maximum number of bars.
• Pad Character: A single character to pad the variable value to length. The pad character can be a letter, number, special character, hexadecimal character, or blank. A space surrounded by single quotation marks (" ") indicates a blank pad character.
• Justification: Specifies how Enrichment should position a variable value that is shorter or longer than the length value, as follows:
  • Left-justify: If the value is shorter than length, Enrichment places pad characters after it. If the value is longer than length, Enrichment truncates it from the right.
  • Right-justify: If the value is shorter than length, Enrichment places pad characters before it. If the value is longer than length, Enrichment truncates it from the left.
• Add: Click this button to make the constant or variable from the top of the window part of the object you are adding (this is required if you want it to be included) When you click Add, the constant or variable appears on to the Components list. You can add multiple components.
• Remove: Select an item from the Components list and then click Remove to remove the item.
• **Update:** Click this button to modify a component that is already in the *Components* list.

• **Up/Down:** Changes the order of the components that are used to assemble the value of the added object. Select the component that you want to move up or down then click **Up** or **Down**.

### Position Tab

The **Position** tab allows you to specify the horizontal and vertical displacement of the added object from the origin point on the physical page. The fields on this tab are described next:

• **Select:** Allows you to select whether this position is for a single-up or multiple-up print stream.
  
  • **Position:** This position is for a single-up print stream.
  
  • **Positions for Multiple Up:** This position is for a multiple-up print stream.

• **Use HRI:** Check this box to include the text equivalent of the barcode (human readable information).
• **X**: The horizontal distance from the origin point to the top left corner of the barcode, OMR mark, overlay, or page segment or to the baseline of the added text. The distance can be from 0 to 24000 pels (or the equivalent).

• **Y**: The vertical distance from the origin point to the top left corner of the barcode, OMR mark, overlay, or page segment or to the baseline of the added text. The distance can be from 0 to 24000 pels (or the equivalent).

• **Unit**: The type of units in which you specified X and Y.

• **HRI Position**: Specifies the position of the HRI text to be included with the barcode. This is required if you select the **Use HRI** check box.
  
  • **X**: The horizontal distance from the origin point to the baseline of the 2OF5 or 3OF9 barcode’s HRI. The distance can be from 0 to 24000 pels (or the equivalent). This parameter is only valid with 2OF5 or 3OF9.
  
  • **Y**: The vertical distance from the origin point to the baseline of the 2OF5 or 3OF9 barcode’s HRI. The distance can be from 0 to 24000 pels (or the equivalent). This parameter is only valid with 2OF5 or 3OF9.

**HRI Font Tab**

For AFP printers only, the **HRI Font** tab allows you to specify the coded font to use to print added text or a barcode’s HRI on an AFPDS output.
The fields in this tab are described next.

- **Coded Font**: Check this box if you will be using the font name and the coded font local identifier that you specify on this tab for the HRI.
- **Font Name**: The name (up to eight characters in length) of the coded font. This is required if you select the Coded Font check box.
- **Code Page**: Specifies the code page to use to print added text or a barcode's HRI on an AFPDS output.
- **Coded Font Local Identifier**: The number of the coded font local identifier (1 to 127) to use when adding HRIs or text to AFPDS data. This is required if you select the Coded Font check box.

**Barcode Tab**

![Barcode Tab Image]

The **Barcode** tab allows you to specify parameters for the barcode you are adding. This tab is available if you selected to create any barcode object except ChinaPost. The fields in this window are described next.
Working with Print Streams

• **Narrow Width:** Varies based on the type of barcode you are adding, as follows. Valid measurements are from 1 to 20 pels or equivalent. The narrow value should not be greater than the wide value.
  - For 2OF5 and 3OF9, the width of the narrowest element in the barcode.
  - For 4STATE, the width of a bar.
  - For OMR, the thickness of the OMR mark.
  - For PLANET and POSTNET, the value can be THIN, NORMAL, or WIDE. Each of these values meets USPS® requirements for PLANET® and POSTNET™ barcodes.

• **Wide Width:** Varies based on the type of barcode you are adding, as follows. Valid measurements are from 2 pels to 1/4 inch or equivalent.
  - For IBM 3800 printers, the maximum value is 0.133 inches (32 pels) or the equivalent. Newer AFP printers do not have this limitation.
  - For 2OF5 and 3OF9, the width of the widest element in the barcode.
  - For 4STATE, the width of the gap between the bars.
  - For OMR, the width of the space between OMR marks.
  - Do not specify a value in this field for PLANET and POSTNET.

• **Height:** Sets the height of the bars in a drawn barcode when no font is used.
  - For 2OF5, 3OF9, and OMR, the height of the barcode. Valid measurements are from 1/24 to 2 inches or equivalent.
  - For 4STATE, the height of the tallest bar (ascender + tracker + descender).
  - For PLANET and POSTNET, the value can be SHORT, NORMAL, or TALL. Each of these values meets USPS® requirements for PLANET® and POSTNET™ barcodes.

• **Units:** For 2OF5, 3OF9, 4STATE or OMR, select the type of units for the values in the Narrow Width and Wide Width fields. Do not specify a value for PLANET and POSTNET.

BCOCA Area

The BCOCA area contains options for using the BCOCA (Bar Code Object Content Architecture) to describe and generate 2OF5 and 3OF9 barcodes. This area is only available if you selected BCOCA as the presentation method on the General tab. The fields in this area are described next.

• **Include check digit:** Select this box if you want to include a check digit at the end of barcodes. If an odd number of characters is specified for the barcode, Enrichment adds a checksum digit to the last character in the barcode. This checksum prints with the human-readable interpretation (HRI). Enrichment calculates the original sum as follows:

\[
\text{sum} = (\text{each odd-position digit}) \times 3 + (\text{each even-position digit})
\]

The checksum is a number that, when added to sum of the digits, creates a multiple of 10. For example, if the barcode value is 23456, the checksum is calculated this way.
way:

\[(2 \times 3) + (4 \times 3) + (6 \times 3) + 3 + 5 = 44\]

The checksum digit would be 6 (44 + 6 = 50, a multiple of 10). The HRI for the resultant barcode would be 234566.

When adding 2OF5 and 3OF9 barcodes, the checksum calculation is controlled by the Include Check Digit check box on the Barcode tab and is handled by the printer, not by Enrichment.

- **Place HRI**: Specifies where the HRI is to be printed. Choose one of the following:
  - **Default**: Prints HRI at default location.
  - **Above**: Prints HRI above symbol.
  - **Below**: Prints HRI below symbol.
  - **No**: Does not print HRI.
- **Print Asterisk**: Specifies whether or not the HRI should include the asterisk on both ends for 3OF9.
- **Suppress Trailing Blanks**: Specifies whether to remove trailing blanks from the value used to generate the barcode.
- **Print Barcode Symbol**: Prevents the barcode from being printed. If you select this box and also select the Use HRI check box on the Position tab, only the HRI will print.
Advanced Tab

The fields in this window are described next.

- **Reverse**: Reverses the order of the characters specified by all of the components listed in the Parameters tab. For example, if you specified the following components:

  
  ```
  %%Total_Pages
  %%Page_No
  %%Name
  ```

  where `%%TOTAL_PAGES` is 09, `%%PAGE_NO` is 03, and `%%Name` is BEN, selecting the Reverse check box would result in the following:

  NEB300900

- **Front Side**: The added object prints only on the front of duplex pages.
- **Back Side**: The added object prints only on the back of duplex pages.
- **Both Sides**: The added object prints on the front and back of duplex pages.
- **Conditional Add to Outputs**: If you select this box, the object will not be added if the value of the variable specified is either blank or null.
Adding Barcodes and Objects to Non-AFP Print Streams

To add barcodes to other output types, follow these steps.

1. Open the control file.

2. If you want to add the barcode to all outputs, place the cursor outside of all tag groups. If you want to add the barcode to a specific output, place the cursor in the corresponding Output tag group.

3. Select Code > Add. An Add tag group is inserted into the control file and populated with the required tags.

4. Right-click the red arrow next to the <ADDTYPE> tag and select Edit Assistant.

5. Fill in the fields. For additional information, click the Help button in the Edit Assistant.

6. Use the Edit Assistant to assign values to the other tags in the Add tag group.
Working with Control Files

In this section

Introduction to Working With Control Files................................. 86
Setting Environment Preferences ................................................. 96
Creating a New Control File....................................................... 99
Tags and Tag Groups............................................................... 99
Adding an Instruction................................................................ 102
Adding a Function................................................................. 102
Editing a Function..................................................................... 103
Adding a Variable..................................................................... 103
Adding a Comment.................................................................... 104
Creating a Vault Journal File..................................................... 104
Introduction to Working With Control Files

Visual Engineer provides a variety of tools that help you to work with control files. This section provides an overview of these features.

- “Using the Toolbar” on page 86
- “Using the Status Bar” on page 87
- “Using the Application Overview” on page 88
- “Accessing the Shortcut Menu” on page 89
- “Using Shortcut Keys” on page 90
- “Searching for a String” on page 90
- “Using the Messages Window” on page 91
- “Code Formatting” on page 93
- “Changing Formatting Preferences” on page 94

Using the Toolbar

The toolbar provides quick access to functions available from the menus. When you place the cursor over a button on the toolbar, the status bar displays a brief explanation of it.

When you have a control file open, Visual Engineer Plus shows two toolbars: one across the top of the window just below the menu bar and the other down the left side of the window. As was mentioned, all functions displayed as buttons on the tool bar can be accessed from the menus. However, not all menu items are available from the tool bar.

Horizontal Toolbar

The horizontal toolbar that is located under the menu bar is shown below. This toolbar provides access to some of the most commonly used functions, such as Open, Print, and Find.
Vertical Toolbar

The vertical toolbar down the left side of the window allows you to insert a template for each of the major tag groups, such as the Input tag and Add tag.

When you click a tag group template button, the template is inserted below the tag group where you placed your cursor. If your cursor is on a blank line or comment, the template is inserted after the tag group below the comment or blank line.

**Note:** The buttons on this toolbar insert tag group templates for stand-alone tags only. For example, you cannot use the Add button to place an `<ADD>` tag within an `<OUTPUT>` tag group. You must use the Insert Tags function on the Code menu to do this.

The template shown below is added when you click the Input tag toolbar button. You can edit these templates to customize them for your specific tasks. For example, you can edit the file `input.tmp` to add the `<COPYGROUP>` tag. For more information, see “Using Tag Group Templates” on page 100.

```xml
<input>
  <file/>
  <name/>
  <type/>
  <doc/>
  <field>
    <loc/>
  </field>
</input>
```

Using the Status Bar

When your cursor is on a tag in the editing window, the status bar (as shown below) displays the name of the tag and its parameters, the line number, the column number, and whether or not CAPS LOCK, NUM LOCK and Overprint are on.

When your cursor is on a button on the toolbar, the status bar (as shown below) displays a brief description of the button.
Using the Application Overview

The Application Overview provides a graphical outline of your control file. This feature makes editing your control file much easier. You can locate a tag group in a large file in seconds. You can also use the Application Overview to get a quick summary of the control file.

**Note:** The Application Overview is not available for rule files.

To display the Application Overview window, click View > Overview. The following window appears.

![Application Overview Window]

The Application Overview is divided into these sections:

- **General Setup and Data:** Displays the Environment and Table tag groups.
- **Input Streams:** Displays the Input tag groups.
- **Banners and Inserts:** Displays the Banner, Insertrec, and Insertpage tag groups.
- **Processes:** Displays Add, CASS, Sortmatch, and Rule tag groups.
- **Output Streams:** Displays the Output tag groups.

When you click an icon in the Application Overview, your cursor automatically jumps to that tag group in the control file.

You can also right-click on an icon to display a shortcut menu.

- Click **Find** to move the cursor to the icon's tag group in the control file.
- Click **Highlight** to select the entire tag group.
Accessing the Shortcut Menu

If you click the right mouse button when your cursor is in the control or rule file, a shortcut menu is displayed, as shown below.

The shortcut menu provides access to the following commands:

- **Undo**: Undo the last edit.
- **Redo**: Cancel the last undo.
- **Cut**: Cut the selected text from the file.
- **Copy**: Copy the selected text.
- **Paste**: Paste the text from the clipboard at the cursor position.
- **Topic Help**: Display help for the current tag.
- **What's Wrong?**: Get a brief description of any errors in the tag format.
- **Edit Assistant**: Display a description of the tag and the appropriate tag parameters in the status bar.
- **Insert Function**: Display a list of valid functions from which to choose.
- **Insert Tag**: Display a list of valid tags from which to choose.
- **Insert Variable**: Display a list of valid system variables from which to choose.
- **Comment Line**: Insert a comment at the cursor position.
- **Import IDF**: Import an input definition file (IDF) at the current cursor location.
- **Hex Viewer**: Opens the print stream specified in the `<FILE>` tag where the cursor is currently located using the data viewer.
- **Graphic Viewer**: Opens the print stream specified in the `<FILE>` tag where the cursor is currently located using the graphic viewer. This option displays a Metacode or AFP print stream in the format it would appear if it were printed.
Using Shortcut Keys

You can perform many functions by using the shortcut keys listed on the menu to the right of their corresponding commands. For example, you can insert a comment template by pressing CTRL+Q.

Visual Engineer supports the following shortcut keys:

- **CTRL+Q** Add a comment template to the current line.
- **CTRL+E** Launch Edit Assistant.
- **CTRL+A** Launch Application Overview.
- **CTRL+M** Open a window that displays Enrichment messages.

Visual Engineer also supports these common shortcuts:

- **CTRL+N** Create new file.
- **CTRL+O** Open file.
- **CTRL+S** Save file.
- **CTRL+P** Print.
- **CTRL+Z** Undo.
- **CTRL+X** Cut.
- **CTRL+C** Copy.
- **CTRL+V** Paste.
- **CTRL+→** Next word.
- **CTRL+←** Previous word.
- **CTRL+HOME** Top of document.
- **CTRL+END** Bottom of document.
- **HOME** Beginning of line.
- **END** End of line.

Searching for a String

The Find window allows you to search for a text string in the control file. To access this window, open a control file and select *Edit > Find.*
Type the string you want to find in the Find field. You can select the following options:

- **Match whole word only**: Only complete words that match the string you are searching for will be found. For example, if you select this option and type "in" in the Find field, the word "input" would not be found. If you do not select this option, then the "in" in "input" would be found.
- **Match Case**: Select this option to conduct a case-sensitive search. Clear this check box to find strings that match in terms of spelling, not necessarily in the use of upper-case and lower-case characters.
- **Regular Expression**: This treats the search string you enter as a regular expression, allowing you to use wild cards and other search characters.
- **Up**: Select this option to search from the current cursor position to the top of the file.
- **Down**: Select this option to search from the current cursor position to the bottom of the file.

To repeatedly search for the same string, use the F3 key.

To have Visual Engineer highlight all occurrences of the string you are searching for, click **Mark All**. You will see an indicator in the left margin of the control file next to each line where the string occurs. To remove the markers, select **Edit > Clear Marks**.

### Using the Messages Window

The Messages window (shown below) is located at the bottom of the Visual Engineer window. When you run the syntax checker, the messages window displays information
that may require your attention. For an explanation of the messages that appear double-click the message.

Undocking the Messages Window

You can move the messages window from the bottom of the Visual Engineer Plus window to another area of your screen by clicking on the vertical bar (shown below) and dragging it to the location you want. To re-dock the messages window, drag it back to the bottom of the Visual Engineer Plus window.
Code Formatting

Visual Engineer uses a variety of formatting conventions to make it easier for you to read and work with control file code. For example, field names may be displayed in blue or green and field values may be displayed in black.

The example below shows the tag names in bold black text, the comments in blue italics, the parameter values in black, and the variables in light green. However, you can change the color and character format of any display object. For instructions, see “Changing Formatting Preferences” on page 94.

Red Wavy Underlines

Red wavy underlines (shown below) appear when there is something wrong with the text you have typed. To identify the error, place your cursor on the underlined word and either click the What's Wrong button on the tool bar or right-click to display the shortcut menu and click What's Wrong. A dialog box describing the error is displayed. Click OK and fix the error. For more information, see “Checking Your Syntax” on page 116.

Blue Wavy Underlines

Blue wavy underlines (shown below) indicate that a tag is obsolete. An obsolete tag is a tag that is supported but not documented. The obsolete tag may not be supported in future releases of Enrichment.

Red Arrows

The red arrows at the end of a line (shown below) indicate that you must provide more information. When you have supplied the required information for the tag, the red arrow
disappears. For example, if a tag has three required parameters, the red arrow will be displayed until you have typed all three parameters.

```xml
<input>
  <file>▼
  <name>▼
</input>
```

**Automatic Indentation**

Visual Engineer Plus automatically indents your text as you type. For example, if you type `<INPUT>` and press ENTER, your cursor is automatically positioned under the letter `p` in `<INPUT>`, ready for you to type a tag in the Input tag group.

**IF Level Connectors**

Visual Engineer helps you maintain your IF, THEN, ELSE language structures by displaying connectors in the form of a bar down the left side of the window (as shown below). You can also locate the next or previous IF level with the Find IF feature. For instructions on turning IF level connectors on and off, see “Setting Environment Preferences” on page 96.

```plaintext
if $\$LPCRC = 0 then <output> REMINDER
  else <output> NONCLEAN
endif
```

**Changing Formatting Preferences**

The procedures below allow you to change the appearance of the Enrichment code.

**Changing Display Options**

You can change the color, size, and character format of the displayed text based on your preferences. For example, you could choose to display tags in black, comments in blue italics, and system variables in red to improve readability.

To set the display options:
1. Click Options > Display Style. The Display Style dialog box appears.

To select the font, size, and other font options for a particular field or text type, click Choose Font. A sample of the selected color and character format is displayed in the Sample area.

The font and size settings apply to all categories, not just the selected categories. It does not matter what category you have selected; the font and size apply to all.

To apply the default color, check the Automatic check boxes. To apply the default font, size, and color click Reset All.

2. Click OK.

Changing Environment Options

You can control other environment settings such as whether or not to display tags, variables, and functions in all lowercase, uppercase, initial capitalization, or leave them as is, whether or not to open the Overview window when you start the Visual Engineer, whether to identify downlevel tags, and so on.

To set the environment options:

1. Click Options > Environment. The Environment dialog box is displayed.

2. Set the display preferences, tag selection defaults, environments to support, and code style as desired.

3. If you edited any tag group templates, type the path of the new templates in the Group Template Path box. Visual Engineer Plus will use tag group templates from this directory first.

4. Click OK.
Changing Font Options

The Font function lets you change the font and size of the displayed text. For example, if you have trouble seeing the text because it is too small, you can increase the font size.

To change the font of the displayed text:

1. Click *Options > Display Style*.
2. Change any of the settings.
3. Click **OK**. The displayed text takes on the characteristics you assigned.

Setting Environment Preferences

The Environment window lets you change global settings related to the operating environment and appearance. To access this window, open a control file and then select *Options > Environment*.

- **Display Preferences**
  - **Display Overview window**: Select this check box to automatically open the Application Overview window when you start the Visual Engineer. The Application Overview window provides a graphic outline of your control file. For more information, see “Using the Application Overview” on page 88.
  - **Identify downlevel tags**: Select this check box to identify any downlevel tags you include in your control file with a wavy blue underline. Clear this check box to identify downlevel tags in the same manner as current tags.
• **Display IF levels:** Select this check box to display a bar connecting the IF level structures. Clear this check box to display the control file with marking the IF level structures.

• **Environments to Support**
  - **Print Streams**
    - **Impact:** Select this check box to display tags that are valid for impact print streams. Clear this check box to hide tags that are valid for impact print streams.
    - **AFP:** Select this check box to display tags that are valid for AFP print streams. Clear this check box to hide tags that are valid for AFP print streams.
    - **Xerox (DJDE and Meta):** Select this check box to display tags that are valid for Xerox print streams. Clear this check box to hide tags that are valid for Xerox print streams.
    - **PCL:** Select this check box to display tags that are valid for PCL print streams. Clear this check box to hide tags that are valid for PCL print streams.
    - **PostScript:** Select this check box to display tags that are valid for PostScript print streams. Clear this check box to hide tags that are valid for PostScript print streams.
  - **Operating Systems**
    - **MVS:** Select this check box to display tags that are valid for use on a z/OS operating system. Clear this check box if you are not running Enrichment on z/OS to hide tags that are valid on z/OS.
    - **Distributed (UNIX and Windows):** Select this check box to display tags that are valid for use on UNIX or Windows. Clear this check box to hide tags that are valid for use on UNIX or Windows.

• **Code Style**
  - **Tags:** Select one of the following to determine the case of the tags in your control file:
    - **As Is** to leave the case of the tags as they exist.
    - **Lower** to change the case of the tags to all lowercase letters.
    - **Upper** to change the case of the tags to all uppercase letters.
    - **InitCap** to change the case of the tags to initial capitalization.
  - **Functions:** Select one of the following to determine the case of the functions in your control file:
    - **As Is** to leave the case of the functions as they exist.
    - **Lower** to change the case of the functions to all lowercase letters.
    - **Upper** to change the case of the functions to all uppercase letters.
    - **InitCap** to change the case of the functions to initial capitalization.
  - **System Vars:** Select one of the following to determine the case of the system variables in your control file:
– **As Is** to leave the case of the system variables as they exist.
– **Lower** to change the case of the system variables to all lowercase letters.
– **Upper** to change the case of the system variables to all uppercase letters.
– **InitCap** to change the case of the system variables to initial capitalization.

**User Vars:** Select one of the following to determine the case of the user variables in your control file:
– **As Is** to leave the case of the user variables as they exist.
– **Lower** to change the case of the user variables to all lowercase letters.
– **Upper** to change the case of the user variables to all uppercase letters.
– **InitCap** to change the case of the user variables to initial capitalization.

**Rules:** Select one of the following to determine the case of the rules in your control file:
– **As Is** to leave the case of the rules as they exist.
– **Lower** to change the case of the rules to all lowercase letters.
– **Upper** to change the case of the rules to all uppercase letters.
– **InitCap** to change the case of the rules to initial capitalization.

**Apply:** Select one of the following to choose when to apply the environment settings.
– **Now:** Select this check box to apply the environment settings to the current code now. Clear this check box if you do not want to apply the environment settings to the current code now.
– **When file is opened:** Select this check box to apply the environment settings to a file when you open it. Clear this check box if you do not want to apply the environment settings to a file when you open it.
– **When template is inserted:** Select this check box to apply the environment settings to the template when you insert it. Clear this check box if you do not want to apply the environment settings to the template when you insert it.

**Tag Selection Defaults**
– **Show advanced tags:** Select this check box to display the advanced tags along with the basic tags. Clear this check box to display only the basic tags.
– **Show downlevel tags:** Select this check box to automatically show the downlevel tags in the selection list on the *Insert a Tag* dialog box. Clear this check box to display only the current tags in the selection list on the *Insert a Tag* dialog box.

**Group Template Path:** If you customized the tag group templates, type the path of the new templates. If you do not type the path of the new templates, the Visual Engineer will insert the default templates. For information about using customized tag group templates, refer to "Using Tag Group Templates" earlier in this chapter.

**Refreshing the Print Stream View:** When you modify a control file and have the print stream open in the graphic viewer or data viewer, the changes you make are not reflected in the print stream viewer unless you select **View > Refresh**. Note that this will not refresh the print stream with changes you make to the rules section of the control file.
Creating a New Control File

To create a new control file, click File > New. A blank file will be created. For instructions on adding tags to the file, see “Tags and Tag Groups” on page 99.

Tags and Tag Groups

Visual Engineer provides a number of features that make it easier for you to work with tags and tag groups. For information on working with tags and tag groups, see:

- “Adding a Tag Group” on page 99
- “Adding a Tag” on page 99
- “Using Tag Group Templates” on page 100

Adding a Tag Group

When you add a tag group, the beginning and ending tags, as well as the required internal tags, are placed in the control file. This is called a tag group template. To add a tag group template to a control file, follow these steps:

1. Place your cursor on the empty control or rule file or in the tag group under which you want to add another tag group.

2. Click one of the buttons on the vertical toolbar. The tag group template for the selected icon is inserted. If you place your cursor in a tag group, the template is inserted below the tag group in which you placed your cursor. If you place your cursor in a comment, the template is inserted below the tag group after the comment.

   NOTE: Place your cursor over a button to display a brief description on the status bar.

Adding a Tag

To add a tag, follow these steps.

1. Select Code > Insert Tags or right-click in the control file and click Insert Tag. The Insert a Tag dialog box is displayed. This dialog box provides a list of Enrichment
tags that are valid for the tag group in which your cursor is positioned. It also provides a brief description of each tag and lists its parameters.

2. To insert a tag, select one or more tag and then click **OK**. If the tag you want to insert is not listed, try checking **Show Advanced Tags**. This will display the advanced tags along with the basic tags. Clear this check box to display only the basic tags.

**NOTE:** You cannot insert obsolete tags. These must be entered manually, if at all. If you have an obsolete tag in your control file, Visual Engineer Plus displays a wavy blue line under it, as shown below. The wavy blue line simply indicates that the tag is undocumented and may not be supported in future releases.

3. A dialog box is displayed to help you complete the tag. Fill in the fields and click **OK**. The tag is added at the current cursor position.

To obtain information on the tag you just added, right-click on the tag and then click **Topic Help**. Or, place the cursor on the tag and click the **Edit Assistant** button on the toolbar.

### Using Tag Group Templates

A tag group template consists of all the required tags for that given tag group that are inserted into your control file or rule file when you click a tag group button on the toolbar or select a tag group from the **Code** menu. For example, when you click the Input button on the toolbar, the tags specified in the Input tag group template are inserted into the control file.

Visual Engineer Plus comes with tag group templates that are used by default. These tag group templates contain the required tags for each tag group. However, you can create customized tag group templates to fit your specific needs. For example, you can create a template for the Input tag group so that the `<ADDRESSBLOCK>` tag is always added when you insert the Input tag group into your control file.

To use customized tag group templates, follow these steps:
1. Browse to the installation location of Visual Engineer Plus. By default, this is `C:\Program Files\Pitney Bowes\Visual Engineer[version]`.

2. Make backup copies of all files with a .TMP extension and place the copies in a different folder. This allows you to revert to the default tag group templates if necessary.


4. Enter the tags that you want to have included by default when you add the tag group. For example, if you always want to include the `<ADDRESSBLOCK>` tag when you add an Input tag group, you would type something like this:

   ```xml
   <input>
   <file>
   <name>
   <type>
   <document>
   <field>
     <location>
   </field>
   <addressblock>
   </input>
   ```

5. Save and close the file. You must use the file names shown in the following table.

   Table 1: File Names for Tag Group Templates (Part 1 of 2)

<table>
<thead>
<tr>
<th>Template</th>
<th>File Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add tag group</td>
<td>Add.tmp</td>
</tr>
<tr>
<td>Banner tag group</td>
<td>banner.tmp</td>
</tr>
<tr>
<td>CASS tag group</td>
<td>cass.tmp</td>
</tr>
<tr>
<td>Control file comments</td>
<td>comment.tmp</td>
</tr>
<tr>
<td>Rule file comments</td>
<td>commentr.tmp</td>
</tr>
<tr>
<td>Environment tag group</td>
<td>environ.tmp</td>
</tr>
<tr>
<td>Field tag group</td>
<td>field.tmp</td>
</tr>
<tr>
<td>Input tag group</td>
<td>input.tmp</td>
</tr>
<tr>
<td>Insertpage tag group</td>
<td>insert.tmp</td>
</tr>
<tr>
<td>Insertrec tag group</td>
<td>insertr.tmp</td>
</tr>
<tr>
<td>Output tag group</td>
<td>output.tmp</td>
</tr>
<tr>
<td>Pagerule tag group</td>
<td>pagerule.tmp</td>
</tr>
</tbody>
</table>
6. In Visual Engineer Plus, select **Options > Environment**.

7. In the **Group Template Path** field, enter the path to the directory that contains your template. If you do not enter a path in this field, Visual Engineer Plus uses the default tag group templates instead of your customized tag group templates.

## Adding an Instruction

Enrichment supports the following instructions:

- IF...THEN...ELSE
- QUIT
- SELECT CASE
- FOR...NEXT
- DO...LOOP

To add one of these instructions to a rule file, begin typing the command.

## Adding a Function

To add a function:

1. Place your cursor between the `<RULE>` tags in the control file.

2. Click **Code > Insert Function** or right-click in the control file and click **Insert Function**. The **Insert a Function** dialog box is displayed.
3. Select a valid function from the list and click **OK**. The appropriate dialog box is displayed.

4. Complete the fields and click **OK**. The function is added at the current cursor position.

To obtain information on the function you just added, right-click on the function and then click **Topic Help**.

### Editing a Function

To edit a function in your rule file, right-click in the function and select **Edit Assistant**. You can also click the Edit Assistant icon in the toolbar (shown below).

### Adding a Variable

To add a variable:

1. Click **Code > Insert Variable** or right-click in the control file and click **Insert Variable**. The **Insert a Variable** dialog box is displayed. This dialog box provides a list of Enrichment variables from which you can choose. It also provides a brief explanation of each variable.

   ![Insert a Variable dialog box](image)

   - **Variable to Add**: You can either type the name of the variable you want to add or select the variable from the System Variables list. A brief description of the variable is displayed.
   - **System Variables**: Select a variable from this list of valid system variables. A brief description of the variable you select is displayed in the Variable to Add area.
Working with Control Files

- **User Variables:** This list contains all user-defined variables for the file. You can select a variable from this list to insert in the file.

2. Click **OK**. The variable is added at the current cursor position.

If you inserted a system variable, you can display online help for that variable. Right-click on the variable and click **Topic Help**.

## Adding a Comment

To add a comment to the header, click **Code > Comment Block** or click the Comment button on the vertical toolbar. Visual Engineer Plus adds the following comment template.

```xml
<! Control File: >
<! Author: >
<! Purpose: >
<! Customer: >
```

You can customize this template for your specific needs. For more information, see “Using Tag Group Templates” on page 100.

To add a comment to a line of code:

1. Place your cursor on the line where you want to add a comment.

2. Click **Code > Comment Line**. Visual Engineer Plus adds the beginning and ending comment characters.

   **NOTE:** If the current line already contains a comment, Visual Engineer Plus moves your cursor to the beginning of the comment instead of adding a new one.

3. Type your comment.

## Creating a Vault Journal File

Enrichment can create a Vault journal file for the print streams it processes, allowing you to archive Enrichment output in Vault. Visual Engineer aids in this process by automatically creating the control file code needed to define variables for each element in the DTD. These variables can then be used in rule file processing to populate the journal file with job-level and document-level data.
To create a journal file,

1. Select *Code > DTD*.

2. Specify the path to the eGAD DTD.

3. Specify a name for the XML element file. This file will contain the `<XMLELEMENT>` tag groups that Visual Engineer generates for the specified DTD. The file you specify here will be included in the current control file using the `<GETFILE>` tag.

4. Check **Define Vault variables**. This option uses a different name for the variables than that defined in the DTD. Usually, the variables defined by Visual Engineer follow the convention:

   `%%DTD_<ElementName>

   For example, the `<AcctNo>` element would be defined as this variable:

   `%%DTD_AcctNo`

   However, there are two elements that are mapped to system variables with special names. These are: `<DocInstanceID>` (mapped to `%%DOCGUID` instead of `%%DTD_DocInstanceID`) and `<JobGUID>` (mapped to `%%JOBGUID` instead of `%%DTD_JobGUID`).

5. Create an `<OUTPUT>` tag group. In the `<OUTPUT>` tag group,

   - Create and `<XMLFILE>` tag and specify a file name for the journal file.
   - Specify one or more `<XMLPART>` tags. The `<XMLPART>` tag indicates which XML elements to include in the journal file. The name you use in the `<XMLPART>` tag corresponds to the names you assigned to the XML elements with the `<XMLNAME>` tag.

   For example, the completed `<OUTPUT>` tag group may look similar to this:

   ```xml
   <output>
   <name> Output1
   <file> c:\myfiles\statements.afp
   <xmlfile> c:\myfiles\journalfile.txt
   <xml Part> jobdata H
   <xml Part> document D
   <xml Part> endeGAD T
   </output>
   ```

6. In the rule file, create logic to populate the variables defined in the `<XMLELEMENT>` tag groups. This will determine the values placed in the journal file's fields. For example,
<rule>
    <content>
        DOCUMENT:
        %%DTD_CustData_Addr[0] = %Name
        %%DTD_CustData_Addr[1] = %AddressLine1
        %%DTD_CustData_Addr[2] = %AddressLine2
        %%DTD_CustData_Addr[3] = %AddressLine3
    </content>
</rule>
Testing Applications

In this section

Running Application Test ................................................................. 108
Viewing Output ................................................................................ 110
Comparing Input and Output ........................................................... 111
Running Application Test

Visual Engineer’s Application Test allows you to execute your Enrichment application to test its accuracy, all within the control of your Windows workstation environment. Should you need to make modifications to your application and rerun the test, you can do so easily. Application Test allows you to instantly perform trials to create your final production-ready document.

**Note:** Application Test creates a temporary control file so that it is not necessary to save before testing.

If you will be testing an application that calls an external program, you must add the path to the external program to the Windows PATH environment variable. For example, if you will be testing applications that call Finalist for CASS™ processing, then add the Finalist program directory to the PATH environment variable.

To launch Application Test, select **Code > Launch Enrichment Engine**. The *Enrichment Application Test - Input Parameters* window appears. This window allows you to specify options for messages, traces, and other run-time settings.

The fields in this window are described next.

- **Appear in report:** Check this box to allow message numbers to appear in the report. If you do not check this box only the text of the message will appear, not the message number.
- **Error Level:** Specifies the level of error at which Enrichment processing stops.
  - **Severe:** Stops processing only if Enrichment issues a severe message.
  - **Warning:** Stops processing if Enrichment issues a warning or severe message.
• **Informational:** Stops processing when Enrichment issues an informational, warning, or severe message.

• **Length of message lines:** Specifies the width of Enrichment outputs messages.
  - **80 Characters:** Messages break to the next line every 80 characters.
  - **132 Characters:** Messages break to the next line every 132 characters.

• **Message File:** Specifies the file name for the Enrichment report.

• **Report Messages:** Specifies which messages Enrichment should include in the processing report:
  - **None:** Do not report messages.
  - **Severe:** Report only severe messages. Severe messages reflect conditions that cause Enrichment processing to stop.
  - **Warning, Severe:** Report warning and severe messages. Warning messages reflect error conditions that need not cause Enrichment to stop, but may produce unexpected processing results.
  - **Informational, Warning, Severe:** Report informational, warning, and severe messages. Enrichment displays informational messages to indicate progress during processing. Informational messages require no corrective action.
  - **Processing, Informational, Warning, Severe:** Report processing, informational, warning, and severe messages. Processing messages are more specific than informational messages, and may be helpful as troubleshooting aids.

• **Address Trace Settings:** Specifies whether to enable address cleanse tracing, which can be used to isolate problematic addresses during the cleanse process. The options are as follows:
  - **Display Input to ADDRSCAN:** Displays ADDRSCAN input.
  - **Display ADDRSCAN Output:** Displays ADDRSCAN results.
  - **Display Input to Finalist:** Displays Finalist® input.
  - **Display Finalist Output:** Displays Finalist® results.
  - **Documents to skip prior to trace:** Specifies the number of documents to process prior to enabling the trace.

• **Trace Level:** Specifies the level of trace information to include in the Enrichment Report. This switch is useful for troubleshooting, especially if there appear to be problems with Enrichment output.
  - **None:** Do not include trace information.
  - **Intermediate:** Include an intermediate amount of trace information.
  - **Full:** Include full trace information.

• **Other:** Additional options are available as follows:
  - **Syntax Check Only:** Checks the control file for correct tagging and syntax, but does not process input or output files. This switch is useful for troubleshooting control files.
• **Display command line:** Displays a window showing the command line equivalent of the options you selected. An example is shown below.

When Enrichment processing is complete, the return code is displayed and the *Output Display* window appears with the new print stream and the message file.

• Click **Viewer** to open the file in your default external viewer.
• Click **Graphic View** to open the file with the Enrichment graphic viewer.
• Click **Data View** to open the file with the Enrichment data viewer.

### Viewing Output

You can view the output of your application, enabling you to examine production-ready documents. It allows you to see the print stream enhancements you have applied to ensure that the results obtained with Application Test are accurate. The View capability provides you with a final quality assurance step in the application creation and testing process before moving the Enrichment application into production.

Before you use the View function for the first time, you should associate the file types of your print streams with a viewer. For example, you must associate .AFP files with an AFP viewer, .MET files with a metacode viewer, and so on for all your print stream file types.

To associate file types with a viewer, follow these steps:

1. In Windows, open Windows Explorer and browse to the directory in which your file is located.
2. Double-click on the file. The Open With dialog box appears.

3. Select the viewer you want.

4. Check the box **Always use this program to open these files**.

5. Click **OK**.

After you have associated the print stream file types with a viewer, follow these steps to view your output:

1. In Visual Engineer, place the cursor in the `<OUTPUT>` tag group for the output you want to view.

2. Click the **View** button (shown below).

You can also view input files and banner files by placing the cursor in an `<INPUT>` or `<BANNER>` tag group. The viewer will open the input banner or file specified by the `<FILE>` tag in the current group.

---

**NOTE:** You can also launch a viewer after you run a job through Enrichment Application Test. For more information, see “Running Application Test” on page 108.

---

**Comparing Input and Output**

The compare tool allows you to view a before-and-after comparison of your AFP or Metacode print stream. The input print stream is displayed next the output print stream.
with added, changed, and removed text and objects are highlighted. The compare tool allows you to see if your control file had the intended effect on the print stream.

To view a comparison of the input and output,

1. If you haven't done so already, run your Enrichment control file. For more information, see “Running Application Test” on page 108.

2. In the control file, place the cursor in the <OUTPUT> tag group's <FILE> tag for the output that you want to use for the comparison.

3. Right-click and select **Compare**.

4. If there are multiple inputs and outputs, you will be prompted to choose an input and output to compare.

5. The input print stream will display on the left side of the window and the output will display on the right.

6. Select which kinds of changes you want to highlight:
   - **•** —Highlight added objects and/or text. Added items appear in blue.
   - **•** —Highlight deleted objects and/or text. Deleted items appear in red.
   - **•** —Highlight changed objects and/or text. Changed items appear in purple.
7. Refresh the display by clicking this button:

8. Use the following buttons to scroll through the comparison print streams:
   
   - Scroll the input print stream down one page.
   - Scroll the input print stream up one page.
   - Scroll the output print stream down one page.
   - Scroll the output print stream up one page.
   - Scroll both the input and the output print stream down one page.
   - Scroll both the input and the output print stream up one page.

9. When you scroll through the print streams you need to refresh the display in order for the highlights to display. To refresh the display, click this button:
Testing Applications
Debugging

In this section

Using the What's Wrong Feature ..................................................... 116
Checking Your Syntax ..................................................................... 116
Using the What’s Wrong Feature

The red wavy underlines (shown below) indicate that there is something wrong with the tag or rule file syntax. Note that Visual Engineer Plus only checks the context and syntax. It doesn't check for all errors. Be sure to run the Check Syntax utility to locate any other errors. For more information, see "Checking Your Syntax" below.

```xml
<input>
  <field>
    <name>+</name>
  </field>
</input>
```

To find out what's wrong:

1. Place your cursor on the underlined word.
2. Click the **What's Wrong** button on the toolbar or right-click to display the shortcut menu and select **What's Wrong**. A dialog box describing the error is displayed.
3. Click **OK** and fix the error. The red wavy underline disappears when you correct the error.

Checking Your Syntax

The Check Syntax utility compiles the control or rule file and creates an error report. You can then use the error report to locate and resolve the errors.

To check the syntax:

1. Click **Code > Check Syntax**. The **Message** dialog box displays any errors.
2. Click on a message to go to the line or tag group in which the error occurs or double-click a message to display help.
3. Correct all errors and click **OK**.
Index

A

Address cleanse tracing 108
Address fields
  Creating 66
Application overview window 88, 96
Application test
  Running 108

B

Big endian 29, 31
Blanks
  Removing from a field 56

C

Carriage control 34
Case style 96
CASS cleansing 66
CASS tracing 108
Color coding 93
Colors
  In a Control File 9
  In print stream viewer 17
Comments 104
Compare tool 111
Control File
  Creating 99
  Uploading to UNIX 9
  Uploading to z/OS 9
Control information area 37
Copy group
  Defining offset 38

D

Density 38
DJDE data area 18
DJDE IDEN area 18
DJDE record layout 39
Document breaks 49
Duplex processing 43

E

Environment preference 96
Error level 108
Explanation 44

F

Field
  Address fields 66
  Changing a field reference 65
  Changing location 64
  Copying 63
  Creating 52
  Deleting 65
  Deleting a field reference 66
  Editing properties 56
  Reference properties 60
  Removing blanks 56
  Reporting values 67
  Specifying field position 56
File extensions
  For Control File 9
  For print streams 9
  For Rule File 9
Fixed field
  Creating 52
Formatting preferences
  Changing 94
Function
  Adding 102
  Editing 103
Functions
  Case style 96

G

Graphic viewer 25

H

Header area 18
Hex viewer 25
Hexadecimal
  Showing explanation 22
Host file 34

I

<IDF> 73
Input Definition File
  Applying to a print stream 71
  Creating 69
  Importing into a control file 71
  Saving 73
  Using 9
  Verbose vs. simple 70
  Viewing 72
  Instruction 102
<table>
<thead>
<tr>
<th>Index</th>
</tr>
</thead>
<tbody>
<tr>
<td>L</td>
</tr>
<tr>
<td><strong>Length indicator</strong></td>
</tr>
<tr>
<td>FIX 34</td>
</tr>
<tr>
<td>In Metacode print streams 29</td>
</tr>
<tr>
<td>In mixed AFP 31</td>
</tr>
<tr>
<td>PCL 33</td>
</tr>
<tr>
<td><strong>Line format</strong></td>
</tr>
<tr>
<td>44</td>
</tr>
<tr>
<td><strong>Line termination string</strong></td>
</tr>
<tr>
<td>33</td>
</tr>
<tr>
<td><strong>Little endian</strong></td>
</tr>
<tr>
<td>29, 31</td>
</tr>
<tr>
<td>M</td>
</tr>
<tr>
<td><strong>Message settings</strong></td>
</tr>
<tr>
<td>108</td>
</tr>
<tr>
<td><strong>Metacode</strong></td>
</tr>
<tr>
<td>Record format 29</td>
</tr>
<tr>
<td><strong>Specifying fonts</strong></td>
</tr>
<tr>
<td>46</td>
</tr>
<tr>
<td>N</td>
</tr>
<tr>
<td><strong>Native format</strong></td>
</tr>
<tr>
<td>25</td>
</tr>
<tr>
<td><strong>Next document/previous document</strong></td>
</tr>
<tr>
<td>23</td>
</tr>
<tr>
<td>O</td>
</tr>
<tr>
<td><strong>Order of bytes</strong></td>
</tr>
<tr>
<td>29</td>
</tr>
<tr>
<td><strong>Orientation</strong></td>
</tr>
<tr>
<td>38</td>
</tr>
<tr>
<td><strong>Output</strong></td>
</tr>
<tr>
<td><strong>Viewing</strong></td>
</tr>
<tr>
<td>110</td>
</tr>
<tr>
<td>P</td>
</tr>
<tr>
<td><strong>Page breaks</strong></td>
</tr>
<tr>
<td>48</td>
</tr>
<tr>
<td><strong>Page layout</strong></td>
</tr>
<tr>
<td>38</td>
</tr>
<tr>
<td><strong>Page orientation</strong></td>
</tr>
<tr>
<td>38</td>
</tr>
<tr>
<td><strong>Page reordering</strong></td>
</tr>
<tr>
<td>42</td>
</tr>
<tr>
<td><strong>Page size</strong></td>
</tr>
<tr>
<td>38</td>
</tr>
<tr>
<td><strong>Page up/Page down</strong></td>
</tr>
<tr>
<td>23</td>
</tr>
<tr>
<td><strong>PDRLNADD</strong></td>
</tr>
<tr>
<td>31</td>
</tr>
<tr>
<td><strong>Popup menu</strong></td>
</tr>
<tr>
<td>89</td>
</tr>
<tr>
<td><strong>Print stream</strong></td>
</tr>
<tr>
<td><strong>Naming</strong></td>
</tr>
<tr>
<td>34</td>
</tr>
<tr>
<td><strong>Opening</strong></td>
</tr>
<tr>
<td>25</td>
</tr>
<tr>
<td><strong>Opening in graphic viewer</strong></td>
</tr>
<tr>
<td>25</td>
</tr>
<tr>
<td><strong>Opening in hex viewer</strong></td>
</tr>
<tr>
<td>25</td>
</tr>
<tr>
<td><strong>Page layout</strong></td>
</tr>
<tr>
<td>38</td>
</tr>
<tr>
<td><strong>Properties</strong></td>
</tr>
<tr>
<td>34</td>
</tr>
<tr>
<td><strong>Specifying data type</strong></td>
</tr>
<tr>
<td>34</td>
</tr>
<tr>
<td><strong>Specifying type</strong></td>
</tr>
<tr>
<td>34</td>
</tr>
<tr>
<td><strong>Print stream data</strong></td>
</tr>
<tr>
<td><strong>About</strong></td>
</tr>
<tr>
<td>14</td>
</tr>
<tr>
<td><strong>Print streams</strong></td>
</tr>
<tr>
<td><strong>Downloading from z/OS</strong></td>
</tr>
<tr>
<td>9</td>
</tr>
<tr>
<td><strong>File extensions</strong></td>
</tr>
<tr>
<td>9</td>
</tr>
<tr>
<td><strong>Printing</strong></td>
</tr>
<tr>
<td>23</td>
</tr>
<tr>
<td>R</td>
</tr>
<tr>
<td><strong>Record format</strong></td>
</tr>
<tr>
<td>FIX 34</td>
</tr>
<tr>
<td>Metacode 29</td>
</tr>
<tr>
<td>Mixed AFP 31</td>
</tr>
<tr>
<td>PCL 33</td>
</tr>
<tr>
<td><strong>Reference field</strong></td>
</tr>
<tr>
<td><strong>Creating</strong></td>
</tr>
<tr>
<td>52</td>
</tr>
<tr>
<td><strong>Reordering pages</strong></td>
</tr>
<tr>
<td>42</td>
</tr>
<tr>
<td><strong>Rule file</strong></td>
</tr>
<tr>
<td><strong>Creating</strong></td>
</tr>
<tr>
<td>99</td>
</tr>
<tr>
<td><strong>Rules</strong></td>
</tr>
<tr>
<td><strong>Case style</strong></td>
</tr>
<tr>
<td>96</td>
</tr>
<tr>
<td>S</td>
</tr>
<tr>
<td><strong>Searching</strong></td>
</tr>
<tr>
<td><strong>For a field in a print stream</strong></td>
</tr>
<tr>
<td>20</td>
</tr>
<tr>
<td><strong>For a string in a print stream</strong></td>
</tr>
<tr>
<td>21</td>
</tr>
<tr>
<td><strong>For text in a control file</strong></td>
</tr>
<tr>
<td>90</td>
</tr>
<tr>
<td><strong>For text in a print stream</strong></td>
</tr>
<tr>
<td>24</td>
</tr>
<tr>
<td><strong>Shortcut keys</strong></td>
</tr>
<tr>
<td>90</td>
</tr>
<tr>
<td><strong>Shortcut menu</strong></td>
</tr>
<tr>
<td>89</td>
</tr>
<tr>
<td><strong>Skip column</strong></td>
</tr>
<tr>
<td>18</td>
</tr>
<tr>
<td><strong>Syntax checking</strong></td>
</tr>
<tr>
<td>116</td>
</tr>
<tr>
<td><strong>System requirements</strong></td>
</tr>
<tr>
<td>9</td>
</tr>
<tr>
<td><strong>System variables</strong></td>
</tr>
<tr>
<td><strong>Case style</strong></td>
</tr>
<tr>
<td>96</td>
</tr>
<tr>
<td>T</td>
</tr>
<tr>
<td><strong>Tag</strong></td>
</tr>
<tr>
<td><strong>Adding</strong></td>
</tr>
<tr>
<td>99</td>
</tr>
<tr>
<td><strong>Obsolete tags</strong></td>
</tr>
<tr>
<td>99</td>
</tr>
<tr>
<td><strong>Obtaining help on</strong></td>
</tr>
<tr>
<td>99</td>
</tr>
<tr>
<td><strong>Showing advanced tags</strong></td>
</tr>
<tr>
<td>99</td>
</tr>
<tr>
<td><strong>Tag group</strong></td>
</tr>
<tr>
<td><strong>Adding</strong></td>
</tr>
<tr>
<td>99</td>
</tr>
<tr>
<td><strong>Tag group template</strong></td>
</tr>
<tr>
<td>100</td>
</tr>
<tr>
<td><strong>Tag group templates</strong></td>
</tr>
<tr>
<td><strong>Path</strong></td>
</tr>
<tr>
<td>96</td>
</tr>
<tr>
<td><strong>Tags</strong></td>
</tr>
<tr>
<td><strong>Advanced</strong></td>
</tr>
<tr>
<td>96</td>
</tr>
<tr>
<td><strong>Case style</strong></td>
</tr>
<tr>
<td>96</td>
</tr>
<tr>
<td><strong>Filtering by operating system</strong></td>
</tr>
<tr>
<td>96</td>
</tr>
<tr>
<td><strong>Filtering by print stream format</strong></td>
</tr>
<tr>
<td>96</td>
</tr>
<tr>
<td><strong>Temporary storage</strong></td>
</tr>
<tr>
<td>41</td>
</tr>
<tr>
<td><strong>Testing applications</strong></td>
</tr>
<tr>
<td>108</td>
</tr>
<tr>
<td><strong>&lt;TEXTUNTIL&gt;</strong></td>
</tr>
<tr>
<td>62</td>
</tr>
<tr>
<td><strong>Trace level</strong></td>
</tr>
<tr>
<td>108</td>
</tr>
<tr>
<td><strong>Trailer area</strong></td>
</tr>
<tr>
<td>18</td>
</tr>
</tbody>
</table>
U

Uploading
  Control File to UNIX  9
  Control File to z/OS  9
User variables
  Case style  96

V

Variable
  Adding  103
Variable length text
  Extracting  62
Variable substitution  44
Visual Engineer
  System requirements  9
  Uses Of  8
  Workflow  8

W

What's wrong  116
Workflow  8