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Centrus® Desktop
Quick Start
Version 6.07.00.N
Centrus Desktop correctly parses, cleanses, standardizes, geocodes, spatially
codes, and demographically codes your data in a single pass. You can also include
your own data by using attributes, such as population counts, demographic
characteristics, or other information specific to a region or location.
This document accompanies Centrus Desktop and provides information on the
following topics:


Key Features



Modular Design



Installing and Configuring Centrus Desktop



Using the Menus and Toolbar



Setting the Processing Options



Processing Records



Using Quick Find



Using Map Viewer

For in-depth information on using Centrus Desktop, see the Centrus Desktop User
Guide. If you are unable to resolve a problem, Pitney Bowes Technical Support
Representatives can help guide you to a solution. You may contact a support
representative via the web, email, or phone:


Create a case in our Online Case Management System



Send an email to software.support@pb.com



Call our toll-free number, +1 800.367.6950.

Pitney Bowes
4750 Walnut Street, Suite 200
Boulder, CO 80301
© 2019 Pitney Bowes Software Inc.
All rights reserved.

1

Key Features

Key Features
Centrus Desktop offers the following main features:

2



Modular approach – Centrus Desktop uses a flexible modular design that lets
you license any or all of the components your organization needs.



Easy to configure – All you need is a single data path to prepare Centrus
Desktop for processing. Centrus Desktop automatically sets this path if you
follow the installation recommendations.



Save map options – You can save settings for Centrus Desktop to use every
time it draws a map.



Oracle and SQL Server support – Centrus Desktop has native Oracle and
SQL Server support for reading and writing to tables.



Visual data icons – Centrus Desktop provides icons for output fields to
visually distinguish the originating module for the data element.



Easy to configure business geographics modules – An alert appears when
you need to complete additional configuration, and includes information on
the type of configuration needed.



User-friendly menus and navigation – Centrus Desktop provides easy to
navigate menus for accessing tools and information.



Log file report – Centrus Desktop provides the ability to record processing
statistics and data file information to a log file report.



Data Viewer – Using Data Viewer you can validate the correct interpretation
of the information in your input file.



Verify option – Using the Verify option you can confirm the configuration of
each module before processing.



Import option – Using the Import option, you can add your own data and
attributes, such as population counts, demographic characteristics, or other
information specific to a region or location.



CASS Certified – The Centrus Desktop address correction and
standardization technology meets USPS Coding Accuracy Support System
(CASS) standards.



LACSLink Support – Centrus Desktop includes support for the USPS Locatable
Address Conversion System (LACSLink), which provides you with an
automated process to correct address lists for areas that have undergone
permanent address conversions.



DPV Support – Centrus Desktop includes support for the USPS Delivery
Point Validation (DPV) data, which provides the ability to validate the
accuracy of address information down to the physical delivery point.
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Modular Design
Centrus Desktop uses a modular design that provides you with the flexibility to
license any or all of the components your organization needs. You can expand
Centrus Desktop by adding one or more of the following modules:


Address Coding
This module cleanses addresses to the highest level, exceeding the USPS
CASS and Canada Post Corporation’s (CPC) Software Evaluation and
Recognition Program (SERP) standards. As Centrus Desktop corrects
addresses, it incorporates a comprehensive address-level geographic coding
function specifically designed to spatially enable your data. This process adds
key components to each database record including latitude, longitude, Census
Tract, and Block Group.



Demographics Coding
This module appends neighborhood-level demographics to each record,
giving you the information you need to understand your best customers and
target prospects with similar habits and lifestyles.



Spatial Coding
This module performs a variety of geospatial analyses that helps
organizations locate a specific set of points within a boundary (point-inpolygon), determine distance between two points, estimate distance between
two locations, or identify a set of points within a given mileage of a location.



Geographic Determination
This module provides a confidence level assignment for each spatial
comparison, which you can use to determine the likelihood that a given
address falls within a targeted area. The technology provides a confidence
score to every geographic assignment at all levels: address-level, ZIP+4,
ZIP+2, or ZIP Code. This technology can also determine minimum and
maximum distances from the input address to a line or point feature or to
determine the polygons in which the address falls.

Contact your sales representative for additional information on expanding your
Centrus Desktop capabilities.
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Installing and Configuring Centrus Desktop

Installing and Configuring Centrus Desktop
When you install and configure Centrus Desktop you need to:
1. Install the Centrus Desktop software
2. Install the data files
3. Start Centrus Desktop
4. Configure the data path

Step 1 – Installing the Centrus Desktop software
The Centrus Desktop software includes an easy to use installation wizard. You
can find detailed installation steps in the Centrus Desktop Installation Guide.

Writing log entries
By default, Centrus Desktop is installed to C:\Program Files
(x86)\Centrus\Desktop. On Windows Server 2012 and later, there are restrictions
writing to the Program Files directory. As a result, customers should write log
entries to a file location other than the default install location.

Step 2– Installing the data files
After you install the Centrus Desktop software, you need to install the data files.
Data files required for processing must reside on your system, or your system
must have direct access to the installation media. You can find detailed steps for
installing the data in the Centrus Desktop User Guide. You can find additional
information about the data supplied by Pitney Bowes in the Release Notes for the
Centrus Data Product Suite.
Pitney Bowes recommends that you install all the data files into the single default
directory specified during the installation of the data. This eliminates additional
data path configuration.

Step 3 – Starting Centrus Desktop
To Start Centrus Desktop:

 Select Programs > Centrus > Centrus Desktop from the Windows Start menu.
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Step 4 – Configuring the data path
If you installed all of your data files in the single default directory specified
during the installation of the data, the data paths on the Advanced Configuration
dialog should update automatically.
To verify or change the data path:

 Select File > Configuration from the menu options in the Centrus Desktop
application. The following dialog appears:

Tips/Tricks


You can specify additional directories by separating the directories with a
semi-colon (;).



You can browse to files located in other directories by clicking the Advanced
button in the Centrus Configuration dialog.

Centrus Desktop Quick Start

5

Using the Menus and Toolbar

Using the Menus and Toolbar
Centrus Desktop provides easy to navigate menus and toolbars for accessing
functionality.

Menus
The following menu options are available at the top of the Centrus Desktop
application:
File
New Task

Dismisses the current task and opens a new task, which
clears the input file, any spatial attribute files, and sets the
options and preferences to their default selections.

Open Task

Opens a saved task, which includes saved input files,
attribute files, and preferences.

Save Task/Save Task As
Saves the current input files, attribute files, and processing
options.
Configuration

Displays a dialog box where you can set the location of the
data files.

Edit
Clear Outputs for...
Clear All Outputs

Clears the outputs for the selected tab.
Clears all of the outputs.

Clear All Outputs Except....
Clears all of the outputs except for the tab selected.
Standardization Defaults/Geocode Defaults
Provides a way to automatically configure output fields.
Selecting Existing Fields matches inputs to outputs.
Selecting New Fields creates new fields and matches the
output to these fields.
Tools
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Quick Find

Provides access to information about a single address.

Data Viewer

Provides access to view the contents of the input file.

Map Viewer

Creates a map based on your input information.

Shape Layers

Provides a way to create and export .gsb files and to
generate a Primary Market Area (PMA).
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Process
Options

Displays a dialog where you can configure processing
options for each module.

Verify.../Verify All Confirms the configuration of the selected module, or all of
the modules, before processing.
Process Task

Interactively processes data records located in the input
file, providing a way to view the results for each record.

Batch Process Task Processes the data records loaded in the input file in a
batch. You must view the output file to see the results.
Help
Help Topics

Provides an interactive help system for Centrus Desktop.

About Centrus

Provides Centrus Desktop version and license information.

Toolbar
Clears
Current
Outputs
Opens
a Task

Opens a
New
Task

Accesses
Data
Viewer

Invokes the
Online Help
Verifies
Currently
Selected
Module

Displays
Process
Options

Accesses
Quick Find
Saves
a Task
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Mode
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Setting the Processing Options

Setting the Processing Options
For each module, you can configure options that control how Centrus Desktop
processes records. These options are applicable regardless of the type of
processing you select, and affect information available using Quick Find.
To change or review the process options:
1. Select Process > Options. The Centrus - Process Options window appears.

2. Select the tab for the module you want to configure.
Tabs available in the Centrus - Process Options dialog contain the following type
of information:


Address Coding Options
Determines how Centrus Desktop matches addresses, and the format of the
information returned.



Data Locator Options
Contains settings that determine how the Data Locator Module assigns
gender information to names, as well as the format of the returned names.



Point in Polygon, Closest Site, and Geographic Determination
Provide the ability to add spatial object files in the Centrus proprietary GSB
format and import popular GIS formats.

For detailed information on the tabs and the different tab options, see the Centrus
Desktop User Guide.
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Processing Records
When you process records you must:
1. Specify the input and output tables
2. Select input and output fields
3. (Optional) Verify your processing options
4. (Optional) Save the job file
5. Process the records

Step 1 – Specifying input and output tables
Using the Tables tab you can set the input file that contains record information
and determine the output file, if desired, for reviewing processed records.
To specify input and output tables:
1. Select the Tables tab. The following appears:

2. Click Browse in the Input Table section to select an input file containing
records.

Centrus Desktop Quick Start
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3. Optionally, set the Output Table options:
Note: If you select the In-Place Update checkbox in the Input Options section,
you do not need to identify an output table file and location. In-Place Update
overwrites the input file with the processed record results. With this method
you cannot retrieve your records in their original format unless you saved the
file in an alternate location. In-Place Update is not available for the following
data table types: SQL, Excel, ODBC, and Oracle.


Click Browse in the Output Table(s) section to select or create an output
table.



Optionally, select the Reject Records that are Not check box and identify
the rejection criteria.
Matched
Geocoded
Point In Polygon Coded
Standardized
Demographic Coded
Closest Site

Cannot find an address match for the record.
Cannot find latitude and longitude.
Point does not fall within any available polygon.
Cannot standardize record to USPS data.
Cannot find a demographic code for the record.
Record does not fall within range specified on the
Closest Site tab.

4. Optionally, set an audit file for a snapshot of the processing performed by
Centrus Desktop:


Select the Audit checkbox.



Browse to the location where you want to save the audit file.

5. Verify or change the Log file location.
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Step 2 – Selecting input and output fields
In the individual module tabs, you assign input fields from your input file to
preset fields in Centrus Desktop. You also assign address elements to a
corresponding output field. You assign input and output fields using the same
process, regardless of the module.
To select inputs and outputs in any module tab:
1. Select the appropriate tab for the module you want to configure.
The following is an example of a module tab with input and output selections.

2. Match fields in the input file to the Centrus Desktop data element in the
Define Input Fields section.
You assign input fields by selecting a field from the drop-down menu. The
address elements available for mapping depend on the input file

Centrus Desktop Quick Start
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3. Assign Centrus Desktop output data elements to output file fields in the
Assign Outputs section.
You assign output data elements by selecting an element and a corresponding
output field name and clicking Assign. The output field appears next to the
data element.
Assigned elements contain a letter icon indicating from which module you
assigned the output field: P (Point-in-Polygon), A (Address Coding), D
(Demographics), C (Closest Site), G (Geographic Determination), and L (Data
Locator).
If an appropriate output field does not exist (it is not shown in the Field Name
list), select the output data element and click New to add a new field to the
output table. A dialog appears where you enter specifics about the new field.

Tips/Tricks


You can assign output fields by selecting a field name and double-clicking the
output data element you wish to assign to that field, or by dragging and
dropping the element next to the field name you wish to assign.



Double-clicking an element without first selecting a field name creates a new
field.



You can unassign a field name by double-clicking the field name. Doubleclicking removes the field from the output list if the field is a new field.

Step 3 – Verifying your processing options
Before you process records, you can verify you have configured Centrus Desktop
properly for processing.
To verify the configuration:

 Select Process > Verify All.
If you have configured Centrus properly, a message appears indicating
Centrus Desktop did not find any errors. If you have not configured Centrus
Desktop properly, a message appears indicating what action you need to take
to successfully configure Centrus Desktop for processing.
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Step 4 – Saving the job file
Once you have specified the input and output information, you can save the job
settings for future use. This minimizes setup time and ensures that you process all
address information in the same manner.
To save your job settings:

 Select File > Save Task As from the File menu.
Tips/Tricks
Saving your task can help Centrus Technical Support answer questions regarding
processing.

Step 5 – Processing the records
After selecting input and output files, assigning the input and output fields, and
setting the processing options, you are ready to process records.
There are two types of processing: batch processing and interactive processing.
Batch processing provides you with a way to process all of the records in one
quick pass. You then view the results in the output file. With interactive
processing, you can view the processing results of each record as Centrus
Desktop processes the record. You can still view the results in the output file
when processing interactively.

Centrus Desktop Quick Start
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Batch Processing
To process in batch:
1. Select Process > Batch Process Task.
2. Optionally, configure your DPV and LACSLink processing information.
The Register Security Keys window only appears the first time you process
records using DPV or LACSLink information.

The USPS Mailer Information window appears if you have selected address
elements that contain DPV or LACSLink information

For more information on DPV or LACSLink, see the Centrus Desktop User Guide.
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Interactive Processing
To process interactively:
1. Select Process > Process Task.
2. Optionally, configure your DPV and LACSLink processing information.
The Register Security Keys window only appears the first time you process
records using DPV or LACSLink information.

The USPS Mailer Information window appears if you have selected address
elements that contain DPV or LACSLink information

For more information on DPV or LACSLink, see the Centrus Desktop User Guide.

Centrus Desktop Quick Start
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3. Click OK.
The first processed record appears. You can expand information in the Results
section by clicking the plus sign (+). You can click on individual modules, if
you have purchased that functionality, to see additional information.

4. Click Next to view additional records.
A message appears when Centrus Desktop finishes processing the records.

5. Click OK, to close the message window.
6. Click Done to dismiss the processing window.
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Using Quick Find
Quick Find provides access to a variety of information about a singular address.
Quick Find uses the Negate Longitudes, Census ID Content, Census ID Format,
and NAD settings specified in the Centrus Process Options dialog box. Quick
Find also includes a comprehensive Query function, which provides complete
access to the address standardization and geocoding database.
Note: For information on using QuickFind in a mode other than Standard mode, see
the Centrus Desktop User Guide.
To use Quick Find in Standard Mode:
1. Click the Quick Find button
or select Tools > Quick Find to start Quick
Find. The Centrus - Quick Find window appears:

2. Enter address information in the fields provided.
Note: You can enter a complete or partial address.

Centrus Desktop Quick Start
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Using Quick Find

3. Click Find to process the address.
The processed information appears in the Results section of the dialog box.
Click an item to expand or collapse the information.

Tips/Tricks
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Use the Multiline tab to paste multiple lines of text into Quick Find.



You can copy individual elements to the clipboard by right-clicking and
selecting Copy.



Click the Copy mailing address to clipboard button to copy the Firm Name
(if available), Address Line, and Last Line to another application. The copied
information is from the results tree, not the input boxes. Therefore, the
information is only available after a successful match.



Click Map at the bottom of the Standard tab to map the current address after a
successful match.



If a match is not made, you can click Query to view possible match scenarios.



Click Print to display the output in Notepad.
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Using Map Viewer
Map Viewer provides you with a way to see the location of the geocoded address,
as well as street layers and other spatial layers you defined.
To use Map Viewer:
1. Select Tools > Map Viewer. The Locator window appears:

2. Locate a street by entering the street address, city, state, and ZIP Code (if
known). Click the Zoom Street button to display all street segments in the
specified city with a matching street name.
– or –
Locate a city by entering either the city name and the state abbreviation, or a
ZIP Code. Click the Zoom City button to display the streets in the city or ZIP
Code within the map window.
Note: When using the Zoom Street function, enter only the street name in the
Street field. For example, enter West Louisiana Avenue as Louisiana.
The following are descriptions of the Map Viewer buttons, and the actions you
can complete by using each button:
Redraw

Redraws the map at the same scale.

Zoom In

Center

Zooms in on the current map view, increasing the
magnification while showing a smaller area.
Zooms out on the current map, decreasing the
magnification while showing a larger area.
Centers the map on the point that you click.

Select

Manually places a point on the map.

Info

Provides information about a street segment.

Zoom Out

Locator

Opens the Locator dialog box, where you can enter an
address or city to locate.
Layers
Opens the Layers dialog box, where you can set the
different layers and attributes that appear on the map.
Zoom to Extent Provides a way to choose a geographic layer (point, line,
or polygon) and zoom out to the smallest zoom that
contains all of the features.

Centrus Desktop Quick Start
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Help
OK

Opens the online help where you can find more
information on the active window.
Accepts the most recently geocoded location and closes
the Map Viewer.

Tips/Tricks
Centrus Desktop automatically includes spatial layers added with the Point-inPolygon, Closest Site, and Geographic Determination modules.
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