Notices
© 2006-2015 TomTom International BV. All Rights Reserved. This material is proprietary and the subject of copyright protection and other intellectual property rights owned or licensed to TomTom. The use of this material is subject to the terms of a license agreement. You will be held liable for any unauthorized copying or disclosure of this material.

Microsoft Bing: All contents of the Bing service are Copyright © 2015 Microsoft Corporation and/or its suppliers, One Microsoft Way, Redmond, WA 98052, USA. All rights reserved. Microsoft or its suppliers own the title, copyright, and other intellectual property rights in the Bing service and content. Microsoft, Windows, Windows Live, Windows logo, MSN, MSN logo (butterfly), Bing, and other Microsoft products and services may also be either trademarks or registered trademarks of Microsoft in the United States and/or other countries.

This product contains 7-Zip, which is licensed under GNU Lesser General Public License, Version 3, 29 June 2007 with the unRAR restriction. The license can be downloaded from http://www.7-zip.org/license.txt. The GNU License may be downloaded from http://www.gnu.org/licenses/lgpl.html. The source code is available from http://www.7-zip.org.

Products named herein may be trademarks of their respective manufacturers and are hereby recognized. Trademarked names are used editorially, to the benefit of the trademark owner, with no intent to infringe on the trademark.
# Table of Contents

## 1 - Introduction
- What is MapInfo Pro? 10
- Getting Started 12
- Getting Support 15
- Getting Technical Support 17

## 2 - What's New in MapInfo Pro
- New and Changed Features in MapInfo Pro 20
- Sample Data Enhancements 23

## 3 - The Basics of MapInfo Pro
- Starting and Leaving MapInfo Pro 25
- A Tour of the MapInfo Pro Desktop 26
- Data - Where MapInfo Pro Begins 33
- Understanding Your Data in MapInfo Pro 48
- Using Workspaces 49
- Reviewing the Windows in MapInfo Pro 51
- Working with Tables in the Table List 62
- Working with Layers in the Layer Control 66
- Working with Thematic Layers 78
- Working with Seamless Layers 81
- Working with MapInfo Manager Library Services 86
- Saving, Closing, and Exporting Your Work 87
- Using the Tools in the Tool Manager 93
- Multi-touch 94

## 4 - Configuring MapInfo Pro Preferences
- Summary of Preferences 97
- Setting Your Preferences 98
- Setting Your System Preferences 99
- Setting Your Startup Preferences 104
- Setting Your Directory Preferences 107
- Setting the Web Services Preferences 109
- Setting up a Geocoding Server 116
- Setting up a Routing Server 119
- Setting Your Performance Preferences 120
- Setting Your Style Preferences 120
- Setting Your Address Matching Preferences 122
- Setting Your Image Processing Preferences 123
- Setting Your Notification Preferences 124
- Setting Your Map Window Preferences 125
- Setting Your Layout Window Preferences 131
- Setting Your Browser Window Preferences 132
- Setting Your Legend Designer Window Preferences 132
- Setting Your Printer Preferences 134
- Setting Your Output Setting Preferences 137

## 5 - Understanding Your Data
- Working with MapInfo Tables 143
- Creating a Report of your Data 156
- Opening an Existing Report 157
- Saving a Report 157

## 6 - Graphing Your Data
- Selecting the Right Type of Graph 159
14 - Putting Your Data on the Map

How Do I Get My Data on the Map? 425
Displaying your Excel (.XLS or .XLSX) Data 427
Displaying your Access (.MDB or .ACCDB) Data 428
Displaying your SQLite Data 429
Displaying your Comma Delimited CSV Data 431
Displaying your dBase Data 432
Displaying your Lotus 1-2-3 Data 433
Displaying your ESRI Shapefile Data 433
Registering and Displaying your ASCII Data 435
Importing and Displaying GML File Data 436
Using Universal Data Directly 437
Opening MapInfo Pro Grid Files 441
Importing Graphic Files 441
Geocoding - Assigning Coordinates to Records 441
Putting Latitude/Longitude Coordinates on a Map 453
Displaying Your Data on the Map 455
Printing Your Results 458

15 - Working with Coordinate Systems and Projections

Working with Coordinate Systems 463
Building Blocks of a Coordinate System 469
Adding Projections to the MAPINFOW.PRJ File 477
Understanding Precision in MapInfo Pro 480
Understanding Affine Transformations 480
Using Earth and Non-Earth Maps 483

16 - Working with Data from a Web Service

Introduction to Web Services 486
Enhancing Map Data using a Web Map Service (WMS) 488
Enhancing Map Data using a Web Feature Service (WFS) 492
Geocoding using a Geocoding Server 495
Creating Routing Distance and Time Buffers 500
Enhancing Map Data using a Mapping Tile Server 503

17 - Specialized Topics in MapInfo Pro

Embedding MapInfo Pro Maps 511
Internet Connectivity and MapInfo Pro 514
Redistricting-Grouping Map Objects into Districts 516
Creating Expressions 520
Working with the MapBasic Window 533
Appendix A: Keyboard Shortcuts 537

Appendix A: Keyboard Shortcuts

Shortcuts for File Menu Items 537
Shortcuts for Edit Menu Items 537
Shortcut to Tools Menu Items 538
Shortcuts to Objects Menu Items 538
Shortcuts for Query Menu Items 539
Shortcuts for Options Menu Items 539
Shortcuts for Map Menu Items 540
Shortcuts for Window Menu Items 540
Shortcuts by Keystroke 541
Shortcuts for the Map or Layout Window 544
Shortcuts for the Browser Window 547
Shortcuts for the Legend Designer Window 553
Shortcuts for MapInfo Pro 555
Appendix B: Elements of a Coordinate System 558

Appendix B: Elements of a Coordinate System

Projections and Their Parameters 558
For More Information on Projections 587
Appendix C: Manually Creating a MapInfo_MapCatalog

Appendix C: Manually Creating a MapInfo_MapCatalog

Manually Creating a MapInfo_MapCatalog 590
Manually Making a Remote Table Mappable 592
Appendix D: MapInfo Map Interchange Format
File Versions and TAB, MIF/MID, and WOR Support 597

Appendix E: Glossary of Terms

Glossary of Terms 616
1 - Introduction

Welcome to the Pitney Bowes Software Inc. family of products. As the field of computer mapping continues to expand, Pitney Bowes Software Inc. leads the way with new products that are designed to fulfill users’ computer mapping needs from the most basic to the most specialized with MapMarker, our premier address matching product.

MapInfo Pro is a comprehensive computer mapping tool that enables you to perform complex geographic analysis such as redistricting, accessing your remote data, dragging and dropping map objects into your applications, creating thematic maps that emphasize patterns in your data, and much more.

This guide contains all of the information you need to learn about and be productive using MapInfo Pro.

In this section

- What is MapInfo Pro? 10
- Getting Started 12
- Getting Support 15
- Getting Technical Support 17
What is MapInfo Pro?

With MapInfo Pro, the power of computer mapping is at your complete disposal. You can display your data as points, as thematically shaded regions, as pie or bar charts, as districts, etc. You can perform geographic operations such as redistricting, combining and splitting objects, and buffering. You can also make queries against your data and access your remote data directly from MapInfo Pro.

For example, MapInfo Pro can show which branch store is the closest to your biggest customers. It can calculate the distances between customers and stores; it can show you the customers who spent the most last year; it can color-code the store symbols by sales volume. What makes it all come together is a visual display of your data on the map.

Mapping at a Glance

Huge quantities of information are available today, far more than ever before. Data abounds in spreadsheets, sales records, and marketing files. Paper and disk store masses of information on customers, stores, personnel, equipment, and resources. Thematic maps and graphs show distribution of customers for a marketing campaign.

![Thematic Map Example](image)

**Figure 1: Thematic Map Example**

Nearly all data has a geographic component. An estimated 85 percent of all databases contain some sort of geographic information such as street addresses, cities, states, postal codes, or even telephone numbers with area codes and exchange numbers.

Computer mapping can help you sort through all of this information, and using the geographic components in your data, display your results on a map. This lets you see patterns and relationships in the mass of information quickly and easily without having to pore over your database.
Using Your Own Data

To begin with, you can use the data you already have, in the form it is already in - spreadsheets such as Excel, databases such as Access, popular CAD packages, and other GIS applications, to name just a few. If your data is on a remote database, you can access it directly from MapInfo Pro. If you have data that is not already online, you can create database files right inside the product, or use data supplied by Pitney Bowes Software Inc. - such as census data.

Similarly, you can use any of thousands of maps available from Pitney Bowes Software Inc., everything from street and highway maps to world maps. You can also create your own maps, either in MapInfo Pro or with a drawing package. You can diagram anything - floor plans, flow charts, even brain anatomy - can be treated as a map and entered into the product.

After you have organized your data visually, you will save the results to files, or send them to any of the dozens of printers and plotters MapInfo Pro recognizes.

If you have your data on hand and you can read a map, you are just about ready to begin. Soon, we will show you an example of how easy it is to put MapInfo Pro's power to work for you.

But first, install MapInfo Pro following the instructions in the MapInfo Pro Install Guide. If you are new to the product, or new to computer mapping, we suggest you refer to The Basics of MapInfo Pro for an overview of basic mapping terms and concepts. Use the web-enabled tutorial to learn about its features, and become accustomed to the more common tasks and functions.

For more product and service information, you can connect directly from MapInfo Pro to our forum (on the Help menu, point to MapInfo on the Web), or consult our World Wide Web site (www.mapinfo.com).

Reviewing the MapInfo Pro Features

MapInfo Pro gives you the processing power of databases (including powerful SQL queries) and the visual power of maps, plus charts and graphs. It is an essential business tool for data analysis, sales, and presentations.

Here is a look at some of the features MapInfo Pro offers:

- Direct opening of files created with dBASE or FoxBASE, delimited ASCII, comma delimited CSV files, ESRI shapefiles, Lotus 1-2-3, Microsoft Excel, and Microsoft Access; importing of graphics files in a variety of formats; a function for creating database files from within the product.
- Multiple views of your data in Map, Browser, and Graph windows. Hot Views allow you to open multiple views of the same data and update them when you change any one view.
- Live ODBC access to remote database data, such to SQL Server.
- Seamless map layers that allow you to handle several map layers as if they were one layer.
- Legend Designer window, enabling you to create and customize legends for any map layer.
- Thematic maps to create analyses of your data with high visual impact, including grid surface themes, 3DMaps, and Prism maps.
- Use raster underlay capabilities to enhance your work session.
• Querying capabilities ranging from simple data selections from a single file to complex SQL queries from one or more files.
• Workspaces that save all your settings and views so you can start where you left off.
• HotLinks that let you launch files or URLs directly from a Map window.
• OLE embedding of Map windows into other applications.
• A comprehensive array of drawing and editing tools for customizing your maps.
• Thousands of ready-made maps and functions for creating your own maps.
• Crystal Reports, the industry-standard report-writing program, allows you to create reports of your tabular data directly in the product.
• A layout window for preparing output.
• Printing and export capabilities for high-quality output
• The ability to change the projection of your map for display or digitizing.
• Object processing functions that help to correct errors in data, set node snap tolerances for different objects, as well as thin nodes and polygons.

When it is time to run MapInfo Pro, you will feel right at home with its windowing environment. After you have organized your data visually, you will save the results to files, or send them to your printer or plotter.

For tips to help you succeed in using MapInfo Pro, see Ensuring Your Success in the Help System.

Accessing Your Documentation

MapInfo Pro Documentation Set

The MapInfo Pro User Guide contains a subset of the information found in the MapInfo Pro Online Help system. If you cannot find the information you are looking for, refer to the Online Help system, which is installed with the product.

Accessing MapInfo Pro Documentation

You can access the MapInfo Pro files in the Documentation subfolder located in your installation directory. You can read these files using Adobe Acrobat Reader, which is available on the installation DVD or by going to the Adobe web site:

http://get.adobe.com/reader

Getting Started

This section describes that a map is the visual representation of data files where each data file displays as a layer on the map.
MapInfo Pro helps you analyze your data on a map for activities such as appraisal, conservation, forecasting, planning, surveying, demarcating, tracking, or managing. You can tailor maps to your specific uses for analysis.

A map is a visual representation of data that has location. MapInfo Pro displays data on the Earth, such as country boundaries, but can also display data that is relative to itself, such as a building floor plan. Seeing data visually on a map gives you the locations of where things are, the relative importance of things through the use of symbols or colors, and the relationships between locations.

![Figure 2: World map showing relative literacy rates where each color represents a range of average values.](image)

Data must be in the form of tables. MapInfo Pro displays data tables as layers on a map. Each table is a single layer and a map may have many layers (tables) on display. For more information about how MapInfo Pro represents data on a map, see What is a Layer?

A data table organizes information by rows and columns, so that you can easily visualize and manage information in a database, such as SQL Server, or in data management software, such as Microsoft Excel. MapInfo Pro access data tables in a database directly or lets you import data tables to work with them directly in MapInfo Pro's native .TAB format.
Figure 3: Map displaying three layers: capitol cities, country boundaries, and ocean layers. A Query Browser window displays a table with the results of a simple selection.

Data is represented on a map as an object, such as a point to mark a location, a polygon to mark the boundaries of a region, or a line to mark a route.

Figure 4: A simple map showing store locations as points, circles as sales territories, and lines as roads and railways.

For more information about:

- Data, see Data - Where MapInfo Pro Begins.
- Map objects, see Map Objects as Part of Layers.
In MapInfo Pro you begin by opening your table of data and displaying it in a Map window. Each table you open displays as a separate layer. Before you launch MapInfo Pro, you will need to know where your data tables are located or you will need to set up access to your remote data source, which is described in Working with Data in a DBMS.

To help you visualize your data and give it context, open a few of the sample data tables that come with MapInfo Pro, such as country and county boundaries, roadways, or city locations. If you have not already done so, install the sample data from the MapInfo Pro DVD. For instructions on how to do this, refer to the MapInfo Pro Install Guide.

You are then ready to launch MapInfo Pro as described under Starting and Leaving MapInfo Pro.

There is a lot of information under A Tour of the MapInfo Pro Desktop that describes how to work with MapInfo Pro. Review this section and the other sections in The Basics of MapInfo Pro to learn how to work with this product.

For more information about working with data, see:

- Understanding Your Data
- Putting Your Data on the Map in the Help System
- Working with Data in a DBMS

Getting Support

Here at Pitney Bowes Software Inc., we are committed to your success and we provide a wide range of support to assist you in getting the results you are working toward.

Using the Status Bar

The Status Bar along the lower edge of your window provides helpful information during your mapping session and allows you to make some changes directly in the Status Bar. To control the display of the Status Bar, on the Options menu point to Show/Hide Status Bar.

Note: Not all entries display in the Status Bar at all times. Entries display when a feature is active.

- Status Bar Help: To find out what a command does, move the cursor over the command. A brief description of the command displays in the left pane of the Status Bar along the lower edge of your screen.
- Zoom, Map Scale, Cursor Location: View any one of these settings in the Status Bar. You can change which one displays directly from the Status Bar. Click the arrow on the right side of the box to display a popup list of the three options. Click the setting you want to display. The Status Bar automatically updates. These display settings are also controlled in the Map Options dialog box (on the Map menu, point to Options).
• **Editable Layers**: To keep track of which layer is currently editable, review the list of layers that display in the Status Bar. You can change the editable layer directly in the Status Bar. Click the arrow to the right of the box to display a popup list of the layers in the Map window. Click the layer you want to make editable. The Status Bar automatically updates, showing the new editable layer.

• **Selectable Layers**: The Status Bar indicates which layer the current selection is from. If there is nothing selected, the Status Bar reads: **Selecting: NONE**.

• **Browser window Records**: When viewing a table in a Browser, the record count displays in the Status Bar.

• **Snap-to-Node**: This **S** key toggle feature is in use when **SNAP** displays in the Status Bar.

• **Autotrace indicator**: This **T** key feature is in use when **AUTOTRACE** displays in the Status Bar.

• **Autonode indicator**: This **N** key feature is in use when **AUTONODE** displays in the Status Bar.

### Using the Help System

MapInfo Pro’s comprehensive Help System provides the information you need to learn and use the product more effectively. You can reach the information in several ways:

• Use the **Help System** screen to choose topics from "books". Click a book to display its topics, choose a topic from the list.

• Use the Search feature to search on a specific word. Type the word you want to search for in the first field, select the matching word in the second, and then the topic in the third box. MapInfo Pro displays the topic in the pane on the right.

• Use the Index feature to find a topic quickly. Type the first few letters of the word you are looking for. The index entry that most closely matches your entry is highlighted. Click the index entry you want to display.

• Use the **Favorites** tab to collect and store topics you want to refer to frequently.

• Context-Sensitive Feature: Press the **F1** key to receive more information on any menu command or dialog box. The Help window for that item displays.

• Quick Access to the publications web site: Click the underlined Pitney Bowes Software Inc. name at the bottom of each topic page to go to the Pitney Bowes Software Inc. web site. From here you have access to product information, upcoming events, tech tips, and a complete set of documentation.

### MapBasic Available Free of Charge on the Web

The MapBasic development environment is a free download available from [www.mapinfo.com](http://www.mapinfo.com). To get your copy, go to [www.mapinfo.com/mapbasic](http://www.mapinfo.com/mapbasic). There is also information there about building custom applications and integrating MapInfo Pro into your application using the MapBasic development environment. For additional SDK development environments, go to [www.mapinfo.com/mapxtreme](http://www.mapinfo.com/mapxtreme).

To obtain your free copy of MapBasic and access other resources to enhance your use of MapInfo Pro, you need to register on the Pitney Bowes Software Inc. site before accessing this download page.
Getting Technical Support

Pitney Bowes Software Inc. offers a free support period on all new software purchases and upgrades, so you can be productive from the start. Once the free period ends, Pitney Bowes Software Inc. offers a broad selection of extended support services for individual, business, and corporate users.

Technical Support is here to help you, and your call is important. This section lists the information you need to provide when you call your local support center. It also explains some of the technical support procedures so that you will know what to expect about the handling and resolution of your particular issue.

Please remember to include your serial number, partner number or contract number when contacting Technical Support.

Contacting Technical Support

Full technical support for MapInfo Pro is provided for the currently shipping version plus the two previous versions.

To use Technical Support, you must register your product. This can be done very easily during installation or anytime during normal business hours by contacting Customer Service directly.

Technical Support Contact Information

Extended support options are available at each of our technical support centers in the Americas, Europe/Middle East/Africa, and Asia-Pacific regions.

To contact the office nearest you, on the Support menu point to Contact Support, or go to our website at www.mapinfo.com/support.

Technical Support Online Case Management System

The Technical Support Online Case Management system is another way to log and manage cases with our Technical Support center. You must register yourself the first time you access this site if you do not already have a user ID.

http://go.pbinsight.com/online-case-management

Tell Us What You Think!

Want to give MapInfo Pro Engineers feedback? We have an option in the Help menu for you to provide direct product feedback to Pitney Bowes Software Inc. If you have a need for a new feature, or you need our product to do something it does not currently do, use this feature to write to us.
Whether you want to complain or complement, let us know so we can meet your MapInfo Pro needs better.

To send us feedback:

• On the Help menu, point to Send Product Improvement Suggestions to open the customer feedback form.

Our team of Product Managers and Engineers will collect your feedback and consider your request in a future release of MapInfo Pro. You will be able to track the activity on your suggestions through different statuses and maintain a list of your ideas or suggestions. Your suggestions will be grouped with other similar ideas to help us build a list of new features and workflows for the application. You may be invited to give your feedback on the scoping and implementation of these suggestions and participate in surveys that help us narrow down the priority of the features we are working on.

Our goal is to ensure that MapInfo Pro stays on the forefront of your needs and product requirements. Help us do that important work for you!
Thank you for upgrading to the most advanced computer mapping product in the Pitney Bowes Software Inc. software family! As the field of computer mapping continues to expand, Pitney Bowes Software Inc. leads the way with new products that are designed to fulfill your computer mapping needs from the most basic to the most specialized.

For more information about the bug fixes and corrections we have made to MapInfo Pro in this release, review the release notes at:

http://www.mapinfo.com/publications

In this section

New and Changed Features in MapInfo Pro 20
Sample Data Enhancements 23
New and Changed Features in MapInfo Pro

Export All Active License Information

You can now export all active license information on your server into a text or CSV (comma separated value) format. For details and instructions, refer to the Using the License Server Utility topic in the License Server User Guide that installs with the License Server software.

Multi-Touch Support

MapInfo Pro now supports multi-touch gestures which allows two-finger pinching and panning gestures on a touchscreen device to perform zoom in, zoom out and pan on the map. The multi-touch also works on a 3D map, Prism map and the map in the New Layout Designer window.

For details on using this feature, see Multi-touch.

Improvements in Layout Frame Alignment

Alignment of layout frames have been improved and you can now:

- Align layout objects with each other.
- Align layout objects with either the page margins or the page center lines, both horizontal and vertical.

For more details, see Aligning Objects.

New Coordinate Systems and Projections

There are coordinate system additions or enhancements in this version

For a detailed list of new EPSG codes, see Coordinate System Enhancements by Version in the Help System.

New EPSG codes have been added in this version.

For a detailed list of new EPSG codes, see Coordinate System Enhancements by Version in the Help System.

There are new PRJ codes in this version:

Portuguese Coordinate Systems

- "PT TM06 ETRS891\p3763", 8, 115, 7, -8.13310833334, 39.668258333333, 1, 0, 0
Colombian Coordinate Systems

- "Colombia East", 8, 16, 7, -68.08091666666667, 4.599047222222222, 1, 1000000, 1000000
- "Colombia East Central zone", 8, 16, 7, -71.08091666666667, 4.599047222222222, 1, 1000000, 1000000
- "Colombia West zone", 8, 16, 7, -77.08091666666667, 4.599047222222222, 1, 1000000, 1000000
- "MAGNA-SIRGAS / Colombia East", 8, 165, 7, -68.07750791666666, 4.596200416666666, 1, 1000000, 1000000
- "MAGNA-SIRGAS / Colombia East Central", 8, 165, 7, -71.07750791666666, 4.596200416666666, 1, 1000000, 1000000
- "MAGNA-SIRGAS / Colombia Bogota", 8, 165, 7, -74.07750791666666, 4.596200416666666, 1, 1000000, 1000000
- "MAGNA-SIRGAS / Colombia West", 8, 165, 7, -77.07750791666666, 4.596200416666666, 1, 1000000, 1000000
- "MAGNA-SIRGAS / Colombia Far West", 8, 165, 7, -80.07750791666666, 4.596200416666666, 1, 1000000, 1000000

For a detailed list of enhancements, see *Coordinate System Enhancements by Version* in the Help System.

There are new datums in this version:

- The number used to identify the datum in the MAPINFO.PPJ file.
- The datum's name
- The maps for which the datum is typically used
- The datum's reference ellipsoid

<table>
<thead>
<tr>
<th>Number</th>
<th>Datum Name</th>
<th>Area of Coverage</th>
<th>Ellipsoid</th>
</tr>
</thead>
<tbody>
<tr>
<td>166</td>
<td>Aratu</td>
<td>Brazil</td>
<td>4</td>
</tr>
<tr>
<td>167</td>
<td>Barbados</td>
<td>Barbados</td>
<td>6</td>
</tr>
<tr>
<td>168</td>
<td>Beduaram</td>
<td>Guinea</td>
<td>30</td>
</tr>
<tr>
<td>170</td>
<td>Dealul Piscului 1930</td>
<td>Romania</td>
<td>4</td>
</tr>
<tr>
<td>171</td>
<td>Douala</td>
<td>Cameroon</td>
<td>4</td>
</tr>
<tr>
<td>172</td>
<td>FinalDatum_1958</td>
<td>Iran</td>
<td>6</td>
</tr>
<tr>
<td>Number</td>
<td>Datum Name</td>
<td>Area of Coverage</td>
<td>Ellipsoid</td>
</tr>
<tr>
<td>--------</td>
<td>--------------</td>
<td>------------------------</td>
<td>-----------</td>
</tr>
<tr>
<td>173</td>
<td>Makassar</td>
<td>Indonesia</td>
<td>10</td>
</tr>
<tr>
<td>174</td>
<td>Manoca</td>
<td>Cameroon</td>
<td>30</td>
</tr>
<tr>
<td>1026</td>
<td>NGO_1948</td>
<td>Norway</td>
<td>1026</td>
</tr>
<tr>
<td>1927</td>
<td>Palestine_1923</td>
<td>Asia / Middle East</td>
<td>1027</td>
</tr>
</tbody>
</table>

For datum details, see *Seven or Eight Parameter Datums* in the *Help System*.

**New Option to Rename a Layer**

You can now assign a friendly name to a selected layer. Right-click on a layer in the Layer Control window and click **Rename**. For more details, see *Layer Control Menu Options*.

You can also assign a default friendly name to a layer by using the **Description** field (part of **Definition** section) in a TAB file. For details, see *Layer Control Options*.

**Enhancements to the Change View Dialog**

The **Catrographic Scale** field in the **Change View** Dialog is now an editable list-box showing a list of available common scales. You can also type in a custom scale factor.

For more details, see *Change View Dialog Box*.

**New Option to Set Grid Sizes in Paper Units**

You can set the units in which you want to resize a grid. On the **Options** menu, click **Preferences** and then click **System Settings** to open the **System Settings Preferences** dialog box. Select the desired unit from the **Paper and Layout Units** drop-down list.

For more details, see *Aligning Layout Frames Using Grid Lines*.

**Change Text Frame Orientation in Layout Designer**

You can now change the orientation of a text frame in Layout Designer:

1. Using **Changes orientation of selected frames** button on the Layout Designer window.
2. Dragging and dropping the text frame bottom-right corner.

For more details, see *Changing the Text Frame Orientation*. 
Sample Data Enhancements

See the *MapInfo Pro Data Directory* document on the MapInfo Pro DVD for a description of the sample data supplied with this product.
3 - The Basics of MapInfo Pro

Now that you have installed MapInfo Pro, you are probably anxious to get mapping. But, if you are new to MapInfo Pro, take a few minutes to read this chapter to familiarize yourself with the concepts, components, and tools for successful computer mapping.

In this section

Starting and Leaving MapInfo Pro 25
A Tour of the MapInfo Pro Desktop 26
Data - Where MapInfo Pro Begins 33
Understanding Your Data in MapInfo Pro 48
Using Workspaces 49
Reviewing the Windows in MapInfo Pro 51
Working with Tables in the Table List 62
Working with Layers in the Layer Control 66
Working with Thematic Layers 78
Working with Seamless Layers 81
Working with MapInfo Manager Library Services 86
Saving, Closing, and Exporting Your Work 87
Using the Tools in the Tool Manager 93
Multi-touch 94
Starting and Leaving MapInfo Pro

In this section we cover the very basics of starting MapInfo Pro, using the STARTUP.WOR, and exiting the program. Since opening a table is basic to getting started in using MapInfo Pro, we cover that topic here, as well.

Starting MapInfo Pro

The Quick Start dialog box opens every time you start MapInfo Pro, so that you can return to the previous mapping session or start a new mapping session with different data.

To start MapInfo Pro:
1. Launch MapInfo Pro by doing one of the following:
   • Double-click the MapInfo Pro icon on your desktop.
   • On the Start menu, point to MapInfoPro.

2. In the Quick Start dialog box, choose how you want to start your mapping session.
   • If you are returning to MapInfo Pro, you can return to the previous mapping session by choosing Restore Previous Session or Open Last Used Workspace.
   • If this is your first look at MapInfo Pro, choose Open a Table to begin. This will open the Open dialog box, where you can select a data table to open within a Map window or a data Browser window in MapInfo Pro.

3. Click OK to proceed.

Note: The Quick Start dialog box displays every time you start MapInfo Pro, but you can change this behavior in the Startup preferences. On the Options menu, point to Preferences and click Startup to open the Startup Preferences dialog box and clear the Display the Quick Start Dialog check box. For details, see Setting the Startup Preferences in the MapInfo Pro Help System.
Exiting MapInfo Pro

To leave MapInfo Pro, on the File menu, click Exit. There is no confirmation message.

Note: If you made changes to a table and did not save them a prompt appears asking you if you want to save the changes. Unless you choose Save, the changes are lost.

• For more information, see Leaving MapInfo Pro using the MAPINFO.WOR Workspace in the Help System.

A Tour of the MapInfo Pro Desktop

This section details the tools and commands that are available to you in the MapInfo Pro product. You may refer to these frequently as you familiarize yourself with MapInfo Pro.

If your copy of MapInfo Pro includes introductory data, you may want to install it now, as described in the MapInfo Pro Install Guide. You can then view the sample data in MapInfo Pro as a map while getting familiar with the features of this product.

• For more information, see Opening MapInfo Pro Introductory Data in the Help System.

Working with Toolbars

MapInfo Pro provides toolbars of tool buttons and commands to give you tremendous mapping creativity at the click of a button.

To reshape the toolbars, click and drag on their borders. Drag the title bar to move them. To dock a toolbar, drag it to one of the edges of the application window. The toolbar changes shape and positions as it docks itself. You can easily change it back to the floating view by clicking the background area of the toolbar and dragging it away from its position. The toolbar retains the same shape as it had before you docked it.

Displaying or Hiding Toolbars

To show or hide toolbars:
1. On the Options menu, point to Toolbars.
2. Show a toolbar by checking its check box or clear its check box to hide a toolbar.
3. Click Close. The toolbars display or disappear from your screen.
An Overview of the Toolbars

Reviewing the Standard Toolbar

The Standard toolbar contains tools for commonly performed menu functions from the File, Edit, and Window menus. It also contains tools for quick access to a Redistricting window and Help System. Many of these tools are familiar to you from working with Microsoft Windows.

- New Table
- New Mapper
- Open Workspace
- New Layout Window
- Bing Aerial
- Open
- Bing Hybrid
- Save Table
- Bing Roads
- Close All
- Move Map To
- Print Window
- Save Workspace
- Cut
- Save Window As
- Paste
- Print To PDF
- New Browser
- Copy
- New Grapher Window
**Reviewing the Main Toolbar**

The Main toolbar contains buttons for selecting objects, changing the view of the Map window, getting information about an object, and showing distances between objects. It also contains buttons that allow you to change attributes and open the floating thematic legend or Statistics windows.

<table>
<thead>
<tr>
<th>Button</th>
<th>Function Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select</td>
<td>Accesses the <strong>Select</strong> tool to select objects/records in a Map, Layout, or Browser window. Also acts as the default pointer/cursor tool.</td>
</tr>
<tr>
<td>Marquee Select</td>
<td>Accesses the <strong>Marquee Select</strong> tool so you can select and search for map objects within a given rectangle (marquee box).</td>
</tr>
<tr>
<td>Radius Select</td>
<td>Accesses the <strong>Radius Select</strong> tool so you can select and search for map objects within a circular region.</td>
</tr>
<tr>
<td>Polygon Select</td>
<td>Accesses the <strong>Polygon Select</strong> tool so you can select objects within a polygon.</td>
</tr>
<tr>
<td>Boundary Select</td>
<td>Accesses the <strong>Boundary Select</strong> tool so you can select and searches for map objects within a given region.</td>
</tr>
<tr>
<td>Unselect All</td>
<td>Accesses the <strong>Unselect All</strong> tool so you can clear all of your object and record selections. Performs the same operation as Unselect All.</td>
</tr>
<tr>
<td>Invert Selection</td>
<td>Selects all objects or records not included in the current selection, and cancels the current selection.</td>
</tr>
<tr>
<td>Graph Select</td>
<td>Accesses the <strong>Graph Select</strong> tool. As you click graph objects, such as a riser bar, pie slice, column, etc., this tool selects the corresponding records from the table.</td>
</tr>
<tr>
<td>Zoom-in *</td>
<td>Accesses the <strong>Zoom-in</strong> tool to get a closer area view of a map or layout.</td>
</tr>
<tr>
<td>Tool</td>
<td>Accesses the <strong>Tool</strong> so you can <strong>Task</strong>.</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>------------------------------------------</td>
</tr>
<tr>
<td><strong>Zoom-out</strong> *</td>
<td>Accesses the <strong>Zoom-out</strong> tool so you can get a wider area view of a map or layout.</td>
</tr>
<tr>
<td><strong>Change View</strong> *</td>
<td>Accesses the <strong>Change View</strong> dialog box so you can specify settings for Map window width, map scale, resizing, and centering.</td>
</tr>
<tr>
<td><strong>Grabber</strong> *</td>
<td>Accesses the <strong>Grabber</strong> tool so you can reposition a map or layout within its window.</td>
</tr>
<tr>
<td><strong>Info tool</strong> *</td>
<td>Accesses the <strong>Info</strong> tool so you can view the tabular data that is associated with a map object.</td>
</tr>
<tr>
<td><strong>HotLink</strong></td>
<td>Accesses the <strong>HotLink</strong> tool, so you can launch active objects such as files or URLs from your Map window.</td>
</tr>
<tr>
<td><strong>Label</strong></td>
<td>Accesses the <strong>Label</strong> tool so you can label objects with information from the related database.</td>
</tr>
<tr>
<td><strong>Drag Map Window</strong> *</td>
<td>Accesses the <strong>Drag Map Window</strong> button to drag a MapInfo Pro map into an OLE container application.</td>
</tr>
<tr>
<td><strong>Layer Control</strong></td>
<td>Accesses the <strong>Layer Control</strong> window so you can specify how the various tables in a Map window are layered and displayed.</td>
</tr>
<tr>
<td><strong>Ruler</strong></td>
<td>Accesses the <strong>Ruler</strong> tool to determine the distance between two points and the length of some path.</td>
</tr>
<tr>
<td><strong>Show/Hide Legend</strong></td>
<td>Accesses the floating Thematic Legend window.</td>
</tr>
<tr>
<td><strong>Show/Hide Statistics</strong></td>
<td>Accesses the Statistics window to tally the sum and average of all numeric fields for the currently chosen objects or records.</td>
</tr>
<tr>
<td><strong>Set Target District from Map</strong></td>
<td>Sets the target district from the map during a Redistricting session.</td>
</tr>
</tbody>
</table>
Assign Selected Objects | Assigns selected objects to the target district during a Redistricting session.
---|---
Clip Region On/Off | Redisplays the entire map.
Set Clip Region | Isolates a map region for display.
Create a Scale Bar | Access the **Create Scale Bar** dialog box, so that you can add a scale bar to the mapper window.
Table List | Accesses the Table List so that you can view a list of open tables, perform operations on them, and organize or sort them into groups.
Add to Library | Access the Add to Library to create a metadata record for the table in MapInfo Manager Library.

* These tools are also available when you access your MapInfo .TAB map within a container application such as MS Word, PowerPoint, etc.

**Reviewing the Drawing Toolbar**

The Drawing toolbar contains tools and commands that are used to create and edit map objects. For more about how to use these buttons, see **Using the Drawing and Editing Commands**.

Symbol | Accesses the **Symbol** tool, which allows you to place point symbols on your map like "push pins."
---|---
Line | Accesses the **Line** tool, which allows you to draw straight lines.
Polyline | Accesses the **Polyline** tool, which allows you to draw polylines (an open, connected sequence of lines).
Arc | Accesses the **Arc** tool, which allows you to draw an arc the size and shape of one quarter of an ellipse.
<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Polygon</td>
<td>Accesses the <strong>Polygon</strong> tool, which allows you to draw polygons (a closed, connected sequence of lines).</td>
</tr>
<tr>
<td>Ellipse</td>
<td>Accesses the <strong>Ellipse</strong> tool, which allows you to create elliptical and circular objects.</td>
</tr>
<tr>
<td>Rectangle</td>
<td>Accesses the <strong>Rectangle</strong> tool, which allows you to draw rectangles and squares.</td>
</tr>
<tr>
<td>Rounded Rectangle</td>
<td>Accesses the <strong>Rounded Rectangle</strong> tool, which allows you to draw rounded rectangles and squares.</td>
</tr>
<tr>
<td>Text</td>
<td>Accesses the <strong>Text</strong> tool, which allows you to add titles, labels, and annotation to maps and layouts.</td>
</tr>
<tr>
<td>Frame</td>
<td>Accesses the <strong>Frame</strong> tool, which allows you to create frames in the Layout window to display maps, graphs, browsers, and legends.</td>
</tr>
<tr>
<td>Reshape</td>
<td>Toggles in and out of <strong>Reshape</strong> mode. Reshape allows you to edit regions, polylines, lines, arcs, and points by moving, adding, and deleting nodes that define them.</td>
</tr>
<tr>
<td>Add Node</td>
<td>Accesses the <strong>Add Node</strong> tool, which allows you to add a node to regions, lines, or polylines when you are in Reshape mode.</td>
</tr>
<tr>
<td>Symbol Style</td>
<td>Accesses the <strong>Symbol Style</strong> dialog box where you can change the style, color, and size of a symbol object.</td>
</tr>
<tr>
<td>Line Style</td>
<td>Accesses the <strong>Line Style</strong> dialog box where you can change the style, color, and width of line objects.</td>
</tr>
<tr>
<td>Region Style</td>
<td>Accesses the <strong>Region Style</strong> dialog box where you can change the fill pattern, color, and background, plus the border style, color, and width of region objects.</td>
</tr>
<tr>
<td>Text Style</td>
<td>Accesses the <strong>Text Style</strong> dialog box where you can change the font typeface, size, style, color, and background of text objects.</td>
</tr>
</tbody>
</table>
**Reviewing the DBMS Toolbar**

The DBMS Toolbar contains buttons and commands that are used to access tables residing on a remote database. These options are only available if you have installed a relational database manager. For more about how to use these buttons, see *Working with Data in a DBMS*.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open DBMS Table</td>
<td>Accesses the Open dialog box, which allows you to access a remote database. If a connection has not been established, you are prompted to open one. This button is also found in the Open dialog box if DBMS is installed.</td>
</tr>
<tr>
<td>Refresh DBMS Table</td>
<td>Accesses the Refresh DBMS Table dialog box, which allows you to refresh a MapInfo Pro linked or live table with the most recent data residing on the remote database for that linked or live table.</td>
</tr>
<tr>
<td>Unlink DBMS Table</td>
<td>Accesses the Unlink DBMS Table dialog box, which allows you to unlink a downloaded table from its remote database.</td>
</tr>
<tr>
<td>Make DBMS Table Mappable</td>
<td>Accesses the Make DBMS Table Mappable dialog box, which allows you make a table linked to a remote database mappable in MapInfo Pro.</td>
</tr>
<tr>
<td>Change Symbol for a Mappable DBMS Table</td>
<td>Accesses the Change Symbol for a Mappable DBMS Table dialog box, and allows you to change the symbol style of a mappable DBMS table.</td>
</tr>
<tr>
<td>Disconnect DBMS</td>
<td>Accesses the Close DBMS Disconnection dialog box, where you can close a connection to a remote database.</td>
</tr>
</tbody>
</table>

**Reviewing the Web Services Toolbar**

The Web Services Toolbar contains buttons and commands that are used to access web services. For more about accessing web services, see *Working with Data from a Web Service*.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open WMS Table</td>
<td>Opens a Web Map Service table into the current map or into a new map. The Open WMS Table button is available whenever your computer is connected to the intranet or the Internet.</td>
</tr>
<tr>
<td>Open WFS Table</td>
<td>Opens a Web Feature Service table into the current map or into a new Map window. The Open WFS Table button is available whenever your computer is connected to the intranet or the Internet.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command</td>
</tr>
<tr>
<td>------</td>
<td>---------</td>
</tr>
<tr>
<td>📍</td>
<td>Find Address</td>
</tr>
<tr>
<td>📍</td>
<td>Geocode Using Server</td>
</tr>
<tr>
<td>🚗</td>
<td>Create Drive Regions</td>
</tr>
<tr>
<td>🌍</td>
<td>Web Services Preferences</td>
</tr>
<tr>
<td>🗺️</td>
<td>Search CSW Catalogs</td>
</tr>
</tbody>
</table>

**Data - Where MapInfo Pro Begins**

To use MapInfo Pro, you need to match the files that contain your information (data) and maps that come from MapInfo Pro or that you create yourself. MapInfo Pro organizes all its information, whether textual or graphic, in the form of tables; each table is a group of MapInfo Pro files that constitute either a map file or a database file.

MapInfo Pro begins when you open tables, whether they are maps or data from a database.

**What is a Database and Other Basic Terminology**

A database is a collection of information organized so that it can be readily accessed using a computer. Databases in MapInfo Pro are often referred to as tables. MapInfo Pro creates a visual display of the data in tables in the form of a map.
Emergency medical calls thematically shaded by type of call and time of call, with response zones shaded by number of calls.

To understand MapInfo Pro, you need a basic understanding of database organization, in particular, three fundamental concepts: record, field, index, and query.

<table>
<thead>
<tr>
<th>LastName</th>
<th>FirstName</th>
<th>Address</th>
<th>ZIPCode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fraser</td>
<td>Mark</td>
<td>212 Hudson St</td>
<td>12205</td>
</tr>
<tr>
<td>Donaldson</td>
<td>Eva</td>
<td>459 Yates St</td>
<td>12208</td>
</tr>
<tr>
<td>Espinosa</td>
<td>Kim</td>
<td>200 Broadway</td>
<td>12180</td>
</tr>
<tr>
<td>Smith</td>
<td>Charles</td>
<td>1 Redbird Ln</td>
<td>12065</td>
</tr>
<tr>
<td>Chang</td>
<td>Elizabeth</td>
<td>53 Crescent Rd</td>
<td>12077</td>
</tr>
</tbody>
</table>

To understand the database concepts we are about to discuss, consider the table above.

Each row in the list contains information about one person. In database terms, each row is a record. Each different box of information (Last Name, First Name, etc.) within a record is called a field. Fields correspond to the columns so that the table shown above contains four different fields.
Database fields are ordered (first, second, third, fourth, etc.), and the basic convention is that the first field displays as the first column in the database. The second field is in the column to the right of the first, and so on to the last field, which is displayed in the right most column.

Since the data in a database is not usually in alphabetical order or postal code order or any other pattern which would make it easy for the computer to find the information, the computer needs a way to organize the information. A database uses an index to keep track of what information is where and what record it is tied to. Without indices it would be tedious to find anything in a database with hundreds of records, not to mention databases with thousands and tens of thousands of records.

A database index works on the same principle as a book index. A book index is an alphabetical list of topics that appear in the book and the page number or address of the information. Database indices work in a similar way, except that they generally work behind the scenes. You do not ever see them. But the computer constructs them and allows you to use them in your work. An index allows the computer to work with the records according to the order of items in the key field.

MapInfo Pro requires fields to be indexed in order to use the Find command. Indices are also used to improve performance in SQL Select and joins.

A query is just another word for a question. You query data to collect a particular type of information from your database. For example, if you wanted to know how many customers live within a certain number of miles of your store, (and you had that kind of information in your database), you could query the database to find out that information. The result of the query is query data. You can think of query data as a subset of your data as in the example - a list of all the customers within 5 miles and none of the customers who live further away. MapInfo Pro has tools to help you query your data and display it on a map. For more about querying your data, see Selecting and Querying Data.

What Data Can I Use in MapInfo Pro?

MapInfo Pro allows you to use data that was created in other file formats. When you bring data into MapInfo Pro for the first time, you need to specify its format. For example, if your data is in delimited ASCII format, choose Delimited ASCII from the File Format drop-down list.

Data file choices include:

- Microsoft Access
- Microsoft Excel
- dBASE DBF
- ESRI shapefiles
- Raster Images
- Grid Images
- ASCII Delimited Text
- Lotus 1-2-3
- Remote Databases (Oracle, SQL Server, PostGIS)
- Workspace
- Comma Delimited CSV files
For database versions that MapInfo Pro supports, see the *MapInfo Pro Install Guide*.

When you choose a particular file format, the File Name box will only list files that have the appropriate extension. For example, if you choose **dBASE DBF** from the File Format drop-down list, MapInfo Pro will only list files that are in dBASE format.

When you choose a file other than a MapInfo-formatted file type, MapInfo Pro creates a table structure for that data based on the type of file that it is.

**Note:** During the .TAB file creation process, the original file is in no way altered. The file retains its original properties.

When you open that table in future work sessions, MapInfo Pro will treat these files as if they were in MapInfo Pro's native format. The next time you want to open the table, you should choose the .TAB format for the table. If you accidentally attempt to open the file again with its original file format, MapInfo Pro prompts you with the message:

![Table definition already exists. Overwrite it?](image)

This message displays because MapInfo Pro has already created a table for that file. To use the file you have already created, click **Cancel** and open the associated .TAB file.

Also keep in mind that MapInfo Pro supports long filenames and UNC paths. The UNC paths allow you to access your data without having to remember your drive mappings from one session to another.

To display your table in the Map window, your data must contain X and Y coordinates. If it does not already, you can add them using MapInfo Pro. Assigning these coordinates is called geocoding. More about geocoding follows later in this chapter and in *Putting Your Data on the Map*.

The *Help System* contains these related topics:

- Displaying your Excel (.XLS or .XLSX) Data
- Displaying your Access (.MDB or .ACCDB) Data
- Displaying your Comma Delimited Data
- Displaying your dBase Data
- Displaying your Lotus 1-2-3 Data
- Displaying your ESRI Shapefile Data
- Registering and Displaying your ASCII Data
- Importing and Displaying GML File Data
- Working with Data in a DBMS
- Working with Data from a Web Service

**Support for Raster Images**

MapInfo Pro supports raster image display. Raster images are computerized pictures. These graphic images can be used as backgrounds for maps you create in MapInfo Pro and can serve as a reference for your displayed data.
When you bring in a raster image to MapInfo Pro, you may need to register it (specify its map coordinates) so MapInfo Pro can display it properly. Choosing the Raster Image file format from the Open dialog box will bring you to the Image Registration dialog box where you can specify the appropriate map coordinates. Once you register the image, a process that creates a .TAB file for the image, you can open it as you would open any table in a Map window. Images that you purchase from MapInfo Pro will already be registered.

If a raster image is georeferenced it will be automatically opened. If a raster image has an associated world file, you will be prompted to choose the projection. If you open a raster image that does not have any georeferencing data, you will be prompted to display or register the image.

For a full discussion of raster image display, see Registering SPOT Images in the Help System.

The MapInfo Pro raster handlers support:

- LeadTools to version 15
- MrSID SDK (3.2), to provide support for MG3 files
- Multi-threading; specifically for ECW and the Government handlers (ADRG, ASRP, CADRG, CIB, NITF)

AirPhotoUSA provides raster images at different elevations for particular areas in the United States. The AirPhotoUSA map handler allows MapInfo Pro users to open and display the imagery contained in AirPhotoUSA Map files as a layer. These files are treated just like any other raster file in MapInfo Pro. The MAPINFOW.PRJ file contains AirPhotoUSA information.

You can use the AirPhotoUSA Conterminous U.S. coordinate system without making any changes. However, if you want MapInfo Pro to recognize and give a name to that coordinate system, or to use it for other purposes, you must add it to the MAPINFOW.PRJ.

Understanding the Files Associated with MapInfo Pro Tables

When you open your data file, MapInfo Pro creates a table. This table consists of at least two separate files. The first file contains the structure of the data. The second file contains the raw data. All MapInfo Pro tables have the following two files:

- `<SOMEFILE>.tab`: This file describes the structure of your table. It is a small text file describing the format of the file containing your data.
- `<SOMEFILE>.DAT` or `<SOMEFILE>.WKS`, `.DBF`, `.XLS`, `.XLSX`: These files contain your tabular data. If you are working with a dBASE/FoxBASE, delimited ASCII, Lotus 1-2-3, Microsoft Excel, or Microsoft Access file, your MapInfo Pro table will consist of a .TAB file and your data or spreadsheet file. For raster tables, the equivalent extension might be BMP, TIF, or GIF.

Your data may also contain graphic objects. Once you assign X and Y coordinates to your data records, your table will also contain graphic objects. In Geocoding - Assigning Coordinates to Records, you will learn how to assign X and Y coordinates to your data records so you can display them on a map. If you already have graphic objects in your table, there are two more files associated with the table:

- `<SOMEFILE>.MAP`: This file describes the graphic objects.
• <SOMEFILE>.ID: This file is a cross reference file that links the data with the objects.

For a Microsoft Access table, there will be a file SOMEFILE.AID associated with the table instead of SOMEFILE.ID. This file is a cross reference file that links the data with the objects for a Microsoft Access table.

Your table may also include an index file. The index file allows you to search for map objects using the Find command. If you want to locate an address, city, or state using the Find command, those fields must be indexed in your table. The index is located in:

• <SOMEFILE>.IND

Note: There is a two Giga Byte (2 GB) file limit on these files after which MapInfo Pro displays an error message: "Cannot write database row. Possibly out of disk space. Out of disk space while saving table [tableAlias] ..." If you see this message, check the file sizes and consider reducing the amount of data you are saving.

Opening Your Data in MapInfo Pro

Using Local Data (Located on your Machine)

You can open your Excel (.XLS or .XLSX), dBase (.DBF), Microsoft Access (.MDB or .ACCDB), and ASCII (.TXT) in MapInfo Pro and display that data on a map. There are three steps to accomplishing this:

1. Creating a copy of your data in MapInfo format.
2. Creating points on a map using either coordinates in your data or by matching your data to a search file (see When Do I Geocode vs. Create Points? for this process).
3. Display your data on the map (see How Do I Get My Data on the Map? to complete this process).

Using Remotely Located Data

If you are accessing your data remotely or use an ODBC supported database product, see Getting Started for additional support.

For information about opening remotely located data, see Opening Data in Remote Tables. For information about converting, displaying, and printing your data, see Understanding Your Data.

Using Introductory Data

If your copy of MapInfo Pro includes introductory data, you may want to install it now, as described in the MapInfo Pro Install Guide. You can then view the sample data in MapInfo Pro as a map while getting familiar with the features of this product.

• For more information, see Opening MapInfo Pro Introductory Data in the Help System.

MapInfo Pro Data File Support

You can open the following file types in MapInfo Pro on the File menu by pointing to Open:
**Importing File Formats**

You can import the following file formats into MapInfo Pro using the Universal Translator (on the File menu point to **Universal Translator**):

- Autodesk AutoCAD DWG/DXF (.dxf, .dwg) — up to AutoCAD rel 2013
- Bentley MicroStation Design 7 (.dgn)
- Bentley MicroStation Design 8 (.pos, .fc1, .dgn)
- ESRI ArcInfo Export (.e00)
- ESRI ArcSDE
- ESRI Geodatabase (Personal Geodatabase) (.mdb)
- ESRI Shapefile (.shp)
- Google Earth KML (.kmz, kml)
- Spatial Data Transfer Standard, such as TR01CATD.DDF (*.CATD.DDF)
- Vector Product Format (VPF) Coverage, such as POAREA.AFT, POLINE.LFT, POPOINT.PFT, POPOINT.*ft

You can import the following file formats into MapInfo Pro on the **Table** menu by pointing to **Import**:

- **DXF** – The graphic/data interchange format (DXF) for AutoCAD and other CAD packages
- **GML** – OS MasterMap format
- **GML, XML** – Geographic Markup Language (GML) 2.1
- **IMG** – A file format for MapInfo Pro for DOS image files
- **MBI** – MapInfo Pro Boundary Interchange format (MBI) An ASCII file for MapInfo DOS boundary files.
- **MIF** – MapInfo Pro Interchange Format (MIF) MapInfo Pro’s data interchange format (ASCII file format).
- **MMI** – MapInfo DOS MMI

**Note:** You can download raster handlers for NIMA formats such as ADRG, CADRG, ASRP, CIB, USRP, and NITF formats from the Pitney Bowes Software Inc. website or get them from the Installation DVD.

MapInfo Pro imports graphics and textual information from MapInfo Pro Interchange Format, DXF, MBI, and MMI files. MapInfo Pro imports only graphics from IMG.

**Supported Raster Image File Formats**

The following are the Raster image file formats that MapInfo Pro supports:

- **ADF** – ArcInfo coverage Data File (ADF)
- **ASC** – ASCII text file
- **BIL** – Satellite Pour l’Observation de la Terre (SPOT) satellite images Spot Image Formats 1.5 and 4.0: 8 Bit Gray, Format 1.5, 8 Bit Gray, Format 4.0, 24 Bit Color, Format 1.5, 24 Bit Color, Format 4.0
- **BMP** – Windows bitmap (BMP) Monochrome: 8 Bit Color, 24 Bit Color
- **filename.*** – Compressed ARC Digitized Raster Graphic (CADRG) format
- **filename.*** – Controlled Image Base (CIB) format
- **ECW** – Enhanced Compression Wavlet (ECW) format handler by ER Mapper
- **EMF** – Enhanced Metafile Format
- **FLT** – Image Filter (FLT)
- **GEN** – ARC Digitized Raster Graphic (ADRG) format
- **GEN** – ARC Standard Raster Product to 1.2 (ASRP) 1.2 format
- **GIF** – Graphics Interchange Format (GIF)
- **GIF** – Graphics Interchange Format (GIF89a) non-interlaced only Monochrome: 8 Bit Color
- **GRC** – MapInfo Vertical Mapper
- **GRD** – MapInfo Vertical Mapper MapInfo Pro treats GRD files as either a grid or raster image. If the associated .TAB file contains a RasterStyle 6 entry, then MapInfo Pro treats the file as a grid.
- **JFIF** – JPEG File Interchange Format (JFIF) 8 Bit Gray, 24 Bit Color, No Subsampling, 24 Bit Color, YUV422 Subsampling, 24 Bit Color, YUV411 Subsampling
- **JPX** – Joint Photographic Experts Group (JPG)
- **NTF** – National Imagery Transmission Format (NITF) version 2.x format
- **PCX** – ZSoft Paintbrush
• **PCX** – Format Version 5 (Paintbrush Version 3.0) Monochrome, 8 Bit Gray, 8 Bit Color, 24 Bit Color
• **PNG** – Portable Network Graphics (PNG) format
• **PSD** – Photoshop 3.0
• **SID** – MrSID format The MrSID raster handler allows you to open and display raster images compressed in the MrSID format
• **TIF** – Geographic Tagged Image File Format (GeoTIFF)
• **TIF** – Tagged Image File Format (TIFF) TIFF Revision 5.0, Monochrome (Class B), Uncompressed, Monochrome (Class B), PackBits Compression, 8 Bit Gray (Class G), Uncompressed, 8 Bit Color (Class P), Uncompressed, 24 Bit Color (Class R), Uncompressed
• **TIF** – Tagged Image File Format (TIFF) CMYK
• **TIF** – Tagged Information File Format (TIFF) CCITT Group 4
• **TIF** – Tagged Information File Format (TIFF) LZW
• **TXT** – Text
• **TGA** – Targa TGA Truevision File Format Specification 2.0. 8 Bit Gray, 8 Bit Color, 24 Bit Color
• **WMF** – Windows Metafile Format(WMF). The raster handler will load a rasterized version of the WMF file.

**File Limitations for MapInfo Pro Supported Formats**

Keep the following notes in mind when working with these MapInfo formats:

• MapInfo Pro only supports the DXF file import to release 13 through **Table > Import**. This has been superseded by the Universal Translator and Open Universal Data feature.
• The Open Universal Data feature supports all DWG and DXF formats up to the current AutoCAD release 2013. While it is our company’s intention to keep pace with the new releases of FME, if you extend the application to import AutoCAD DWG and DXF files using a newer version of FME before we have upgraded our product, errors may occur.
• You can have maximum 500 files open at a time in MapInfo Pro if you remove the HKEY_LOCAL_MACHINE\SOFTWARE\MapInfo\MapInfo\Common Max Files registry key.
• You can have up to 125 files open at a time for editing in MapInfo Pro.

**Feature Manipulation Engine (FME) Format Support**

MapInfo Pro installs with the Feature Manipulation Engine (FME) 2015, which lets you open data directly to avoid having to translate it separately and work with copies of the data in .tab format. This FME opens a variety of Universal Data formats including:

• Autodesk AutoCAD DWG/DXF – Supports AutoCAD file versions up to and including 2010
• Bentley MicroStation Design (V7) – Supports Intergraph Standard File Format (ISFF) Version 7
• Bentley MicroStation Design (V8) – Supports Intergraph Standard File Format (ISFF) Version 8
• ESRI ArcInfo Export (.e00) – Supports ArcGIS 10.x
• ESRI ArcSDE – Supports ArcSDE 10.x
• ESRI Geodatabase (MDB) – Supports ArcGIS 10.x
• Google Earth KML – Supports KML 2.2
• MapInfo TAB (MFAL) – Support MapInfo File Access (MFAL) version 2.4.0.3
• Geography Markup Language (GML) - Reader supports GML versions 2.1.2, 3.1.1, and 3.2.1 and Writer supports GML versions 3.1.1 and 3.2.1
• Esri Geodatabase (File Geodatabase API) Reader/Writer (GDB) - Supports 10.0 File Geodatabases or higher

To open these data formats in MapInfo Pro, on the File menu point to Open Universal Data.

To translate TAB files using FME in MapInfo Pro, on the Tools menu point to Universal Translator.

For details about all of the FME supported formats, see FME Readers and Writers (formats supported by FME 2013) in the FME Desktop Help.

To see what is new in FME 2013, see http://fmepedia.safe.com/articles/FAQ/Whats-Great-2013.

Opening MapInfo Tables

Just about everything in MapInfo Pro starts with opening a table. You can display the information in your tables in a number of ways in MapInfo Pro, as a table, in a browser, and on a map.

To open a local table (which is a data file on your machine):

1. On the File menu, click Open. The Open dialog box displays.

   Note: If you are at the Quick Start dialog box (the first dialog box you see after starting MapInfo Pro), choose the Open button. The Open dialog box displays.

2. Navigate to the data file you want to open. From the Files of type drop-down list, select the type of data you will open.

3. From the Preferred View drop-down list, select the view you want of this data.

   • Automatic - MapInfo Pro chooses the most appropriate view. If the data is mappable (for example, graphic objects are attached to the data), for example, MapInfo Pro opens the table in a Map window. If you have a Map window displayed and the table you want to open is mappable, MapInfo Pro will automatically open the table in the current Map window. If the data is not mappable, MapInfo Pro will attempt to open the table in a Browser window. If the table cannot be mapped or browsed, MapInfo Pro opens the table using the No View option (no data is displayed).

   • Browser - MapInfo Pro attempts to open the table in a Browser window.

   • Current Mapper - MapInfo Pro attempts to add your data to the current Map window.

   • New Mapper - MapInfo Pro attempts to open the table in a new Map window.

   • No View - MapInfo Pro opens the table making the data available for other uses, but no data is displayed.

   Note: When you open a table and select an option in the Preferred View drop-down list, MapInfo Pro remembers what you selected and uses the same option the next time you open a table.
4. Select the **Create copy in MapInfo format for read/write** to open it in native (.tab) format.

   **Note:** If you do not select the **Create copy** check box, the file opens read-only.

5. To open the file, do one of the following:
   - Double click the file you want to open
   - Click the file you want to open to highlight it in the list and click **Open**.

   Using either method, MapInfo Pro opens the data file.

When opening multiple tables, use `Shift`-click to select adjacent tables and `Ctrl`-click to select non-adjacent tables.

Note that although a MapInfo Pro table consists of two or more component files (STATES.TAB, STATES.DAT, STATES.MAP, etc.), only the .TAB file appears in the **File Name** box of the **Open** dialog box. It is the only component file you must open. For more about these other MapInfo file types, see **Understanding the Files Associated with MapInfo Pro Tables**.

In MapInfo Pro you can work with a variety of table types. Some data tables are like the example table we just discussed. Further subdividing this class of tables are data tables that contain graphic objects (map objects) and data tables that do not (such as spreadsheets or external database tables). Raster tables are graphic images that you can display in a Map window. These computerized pictures do not have the same table structure of record, field, and index as data tables do, and therefore, will not be discussed in this chapter. For more on raster images, see **Working with Raster Images** in the MapInfo Pro Help System.

You can see what windows are currently open by reviewing the list at the bottom of the **Window** menu. If one of these "More Windows" windows is the active window, the check box displays beside the More Windows entry. To make another window active, click the entry in the Window list. The window you selected comes to the forefront of the MapInfo Pro screen. When you select the More Windows entry, the **Select Window** dialog box displays. To activate a window from this list, either double-click the entry in the **Select Window** list, or click the entry and click **OK**.

**A Note about the Preferred View Options**

Of the five Preferred View options, **Automatic** and **No View** will work on all tables, regardless of what kind of data they contain.
MapInfo Pro attempts to open the table as specified for Browser, Current Mapper, and New Mapper. If it cannot, it will open the table according to the following rules:

- If **Current Mapper** is selected, and there is no Map window displayed, MapInfo Pro will attempt to open the table in a new Map window.
- If **Current Mapper** or **New Mapper** is selected and the data is not mappable, MapInfo Pro will try to open the table in a Browser window.
- If the table cannot be mapped or browsed, MapInfo Pro will open the table using the **No View** option (no data is displayed).

For more information, see *Renaming a Table* and *Deleting a Table* in the Help System.
Opening Data in Remote Tables

MapInfo Pro also enables you to access remote database data through its ODBC connectivity support and the Oracle Spatial Object support. The MapInfo Pro ODBC connectivity support supplies many ODBC drivers that you can easily install.

Oracle spatial databases enable you to store spatial objects with your conventional data in the same database. This enables you to read and write geographies in Oracle Spatial without the need for a middleware product such as MapInfo Pro's SpatialWare, or SDE. You also gain better performance through the Oracle Call Interface (OCI). In addition, Oracle applications can use this same spatial or non-spatial data through other interfaces (ODBC, OCI, JDBC, PL/SQL, HTTP, IIOP, etc.) or use other spatial or non-spatial tools (MapInfo Pro, ArcView, Intergraph, Excel, Forte, Formida, etc.).

For more about accessing remote data using ODBC connectivity, see Setting your Database Connection Preferences in the Help System.

Using the MapInfo Places on Open Dialog Box

The Open dialog box provides a quick way to look for maps you have created.
**The Places box.** Select the **Workspaces Directory** option in the **Places** box, to display the **Workspace (.wor)** type in the **Files of Type** list. If you select any other entry in the **Places** box, **MapInfo (.tab)** displays in the **Files of type** list.

The **Open** dialog box provides many ways to quickly find the maps that you have created in a variety of locations in your system and network.

**Note:** The **Places** box on the left side of the **Open** dialog box allows you to select a directory in which you may have your map and other MapInfo Pro tables and workspaces.

When you select the **Workspaces Directory** option in the **Places** box, the Files of type drop-down list changes to Workspace (.wor) type. If you select any other entry in the **Places** box, **MapInfo (.tab)** displays in the **Files of type** list.

- For more information, see *Opening MapInfo Pro Introductory Data* in the **Help System**.
Opening Special File Types

There are additional file types that MapInfo Pro can read including rasters, grids, and shape files. For details about working with raster images, see Displaying a Raster Image and Registering the Coordinates of a Raster Image in the Help System.

Opening a Grid Layer

A grid layer is a type of thematic map that displays data as continuous color gradations across the map. To produce this type of thematic map, you interpolate point data from the source table. In MapInfo Pro, a grid file from the data interpolation is generated and displays as a raster image in a Map window.

• For more information, see Selecting Point Objects in Grid Files in the Help System.

To open a grid layer:

1. On the File menu, click Open to display the Open dialog box.
2. Select Grid Image in the Files of type drop-down list.
3. Navigate to the directory in which your grid image is located and click the file you want to open.
4. Click Open to display the grid image.
Understanding Your Data in MapInfo Pro

Computer maps are organized into layers. Think of the layers as transparencies that are stacked on top of one another. Each layer contains different aspects of the whole map.

What is a Layer?

In MapInfo Pro you begin by opening your table of data and displaying it in a Map window. Each table displays as a separate layer. Each layer contains the table plus any map objects, such as regions, points, lines, and text. Additionally, the layer contains style overrides and zoom layering characteristics that you can add to give the layer more or less prominence in the Map window.

Figure: Map Layers Example

Map layers form the building blocks of maps in MapInfo Pro. Once you have created your layers, you can customize them in a variety of ways, add and delete layers, or reorder them.

For example, one layer may contain state boundaries, a second layer may have symbols that represent capitals, and a third layer might consist of text labels. By stacking these layers one on top of the other, you begin to build a complete map. You can display one, two, or many tables at a time.

Map Objects as Part of Layers

We mentioned earlier that maps in MapInfo Pro are made up of layers of map objects. There are five basic types of objects:

- **Regions**: closed objects that cover a given area. These include polygons, ellipses, and rectangles.
  For example, country boundaries, postal code boundaries, sales territories.
• **Point objects**: represent single locations of data. For example, customer locations, restaurants, parking meters. Points can also be combined into multipoint objects.

• **Line objects**: open objects that cover a given distance. These include lines, polylines, and arcs. Examples are streets, rivers, power lines.

• **Text objects**: text that describes a map or another object, such as labels and titles.

• **Collection objects**: combination of region, line, and multipoint objects.

You can have each type of object in a separate layer (most common), or you can combine objects in the same layer. MapInfo Pro lets you create, edit, customize, and display these objects to make maps that meet your needs.

For information about drawing and editing map objects, see [Drawing and Editing Objects](#) and see [Moving Map Objects](#) in the Help System.

### Managing a Map's Layers

The key to controlling your map layers is the Layer Control window. The window shows all the layers that make up a Map window and the status of the layer attributes. These attributes are: Visible On/Off, Style Override, Editable, Selectable, and Automatic Labels. ToolTips display over the attribute when you move your cursor over them to help familiarize yourself with each one. It is easy to change a layer's, or multiple layers', attributes.

You also have options available to change the display and label settings; modify any thematic maps you have displayed; and reorder, add, or remove layers.

• For instructions on accessing the Layer Control window, see [Accessing Layer Control](#) in the Help System.

• For instructions on changing layer order in the Layer Control window, see [Changing the Order of Contiguous Layers](#) or [Changing the Order of Random Layers](#) topics in the Help System.

### Using Workspaces

A workspace is a list of all the tables, windows, and settings you are using, stored in a file with the extension .WOR or .MWS. Workspaces are a convenient way to return to a previously created map without having to open each table file individually. The workspace keeps track of the following elements:

• Map, Browser, Graph, 3DMap, Layout, and Layout Designer windows, including their size and position

• Query tables created from base tables using either the Select or SQL Select statements (queries on queries will not be saved)

• Graphs

• Thematic maps
• Legend Designer windows
• Cosmetic objects
• Labels
• Styles for fonts, symbols, lines, and fill patterns used to display objects

A .WOR file is MapInfo Pro workspace file containing un-compiled MapBasic code that MapInfo Pro interprets to open a session with tables, windows, and settings the way a user left it. It is MapInfo Pro version specific depending on features used in it.

A .MWS workspace file originates from the MapXtreme product line and is comprised of XML code to do things similar to a MapInfo Workspace *.wor with some limitations.

To view the contents in the workspace file, open the .WOR or .MWS file in MapInfo Pro, a text editor or word processor.

**Note:** When you save a workspace, you cannot save any references to selections or queries made by the Selection tools or the Query options.

### Opening a Workspace

Any previously opened tables and windows will be left untouched when you open a workspace. However, to avoid cluttering up your screen with unnecessary windows, use the Close All command from the File menu before adding the workspace.

There are two MapInfo workspace formats, WOR and MWS. A .wor file is written using MapBasic and a .mws file is written using XML. The MWS format contains more information about the data sources than the WOR format does. MapInfo Pro works with both workspace formats, but other MapInfo products may work with only one of the two formats.

To open either a .wor or a .mws workspace:

1. From the **File** menu, select **Open**.
2. In the **Open** dialog box, from the **Files of type** list, select **Workspace (*.wor, *.mws)**.
3. From the **Look in** list, navigate to and select the workspace (.wor or .mws) file to open.
4. Click **Open**.

**Note:** When you exit MapInfo Pro, the MapInfo Pro workspace (MAPINFOW.WOR) stores the last session (unless you have set your preferences so that the workspace will not be written). If there are files you do not want added to your workspace, close them before exiting.

The **Help System** contains these related topics:

- **Opening Multiple Workspaces**
- **Reading Labels from a MapInfo Workspace File (MWS)**
- **Limitations opening a MWS Format Workspace**
- **About Writing Label Overrides to a MapInfo Workspace File (MWS)**
- **About Reading/Writing Translucency Settings for a Workspace File (MWS)**

**How Renaming Tables Affects Workspaces**
When you change the name of a table listed in a workspace, you invalidate the workspace. Table names are stored in the workspace file, so if change it, the workspace cannot find it.

For example, if you create a workspace called CUSTOMER.WOR that contains the STATES table. If you later rename the STATES table to AMERICA, MapInfo Pro will not be able to open the CUSTOMER.WOR workspace. It will try to open the STATES table and not be able to locate it.

There are three ways to avoid this problem:

• Make any table name changes before you start to build workspaces.
• Open the workspace file in any text editor and manually change the table names.
• Open a workspace. Rename the table(s) using the Rename Table dialog box and immediately save the workspace.

Saving Printer Information to a Workspace

MapInfo Pro enables you to save your printer information to a workspace, and restore printer information from a workspace. These settings are located in the Startup preferences (on the Options menu, point to Preferences, and click Startup). To save printer information to a workspace, check the Save Printer Information to Workspaces check box. Subsequently, when you save your workspace, the printer name, paper orientation, paper size, and the number of copies are saved. When this preference is on, the printer settings are saved in a workspace file.

Note: We recommend that you leave this preference on.

To restore printer information from a workspace, check the Restore Printer Information to Workspaces box. When you open the workspace, the printer name, paper orientation, paper size, and the number of copies are restored. This is useful if you are sharing workspaces with other MapInfo Pro 6.0 or later users who are also using the same printers. You may want to leave it off if you want to send the workspace to someone who is using a different printer. If this preference is turned off, MapInfo Pro uses the default printer selected in the Printer preferences.

Note: You can get additional printer advice in the MapInfo Pro Printing Guide, which is located in the Documentation subfolder of your installation directory.

Reviewing the Windows in MapInfo Pro

MapInfo Pro allows you to display your data in many different windows and with different views at the same time. For instance, you can display the WORLD table of country boundaries in a Map window to view the geographic boundaries. At the same time you can display the tabular data of the WORLD table in a Browser window to see the country names, population, and other data in the file. If you make a change in either window, it is reflected in the other.

Only one view can be active at a time. To make a different window active, click its title bar. Notice that the menu bar changes depending on which window is active. For instance, when you are working
in a Map window when you also have a Browser open, only the **Map** menu is available on the menu bar. Make the Browser active. The **Browse** menu replaces the **Map** menu.

There are many different types of windows you can display your data in, depending upon what you need your data to communicate. This section covers the many ways you can display your data using MapInfo Pro. Each of these display methods: map, list, graph, and presentation give your information a different impact. How you display the information you have should depend upon what effect you want.

Consider these options carefully before you select a display type.

- **Map windows** present information arranged as conventional maps, allowing you to visualize the geographic patterns of your data (for details, see Displaying Data in a Map Window). In addition, Legend Designer windows present information arranged as map legends, so that you can understand the symbols and themes used in the map (for details, see Creating a Legend for your Map).

- **Browser windows** present information as tabular lists (just as conventional databases do), allowing you to fully examine tabular data (for details, see Displaying Data in a Browser Window).

- **Graph windows** present information arranged as graphs, allowing you to visualize and make comparisons of the purely numerical patterns (for details, see Displaying Data in a Graph Window).

- **Layout windows** present information in a polished and attractive way and can be embedded in other applications such as Microsoft Word or PowerPoint (for details, see Displaying Data in a Layout Window).

**Note:** To switch between windows to change which is active, press the **Ctrl+Tab** keys.

### Displaying Data in a Map Window

You use Map windows to display the geographic objects from your table on a map. Map windows can display information from many tables at once, with each table a separate layer.

**Opening a Table in a Map Window**

You can create your maps or edit existing maps. You can open a Map window directly on the **File** menu, by pointing to **Open** or by pointing to **New Map Window** on the **Window** menu.
Getting Around in the Map Window

There are a wide variety of tools that allow you to zoom, pan, and move objects around the Map window. Zooming allows you to look more closely or more widely at a particular geography. Panning allows you to move around a map left, right, up, and down. Moving selected objects in an editable layer is useful when you want to get your map right.

You can zoom using the mouse wheel or using the keyboard. In addition to the usual zoom keys on your Main Toolbar (zoom in, zoom out, and fit to map), you can use the + and - keys on the keyboard, to zoom in and out more precisely.

• When you press +, you zoom in by a factor of 2.
• When you press -, you zoom out by a factor of .5.

You can pan in your Map window using the scroll bars or the Arrow keys Up, Down, Left, and Right.

Further, you can move an object in an editable layer more precisely by selecting it and using the following key combinations.

• Ctrl+Arrow - moves the editable, selected objects 1 pixel at a time
• Ctrl+Shift+Arrow - moves the editable, selected objects 10 pixels at a time

Note: These tools also apply to the classic Layout window and maps embedded in a Layout Designer window.

Changing a Map's Zoom Level

You change a map's zoom level by specifying certain parameters in the Change View dialog box.
To change a map's zoom level do one of the following:

- Choose **Map > Change View**. The **Change View** dialog box displays.
- Click the **Change View** button on the **Main** toolbar. The **Change View** dialog box displays.

The **Change View** dialog box allows you to set various parameters of the map including:

- Display the current zoom, scale or cursor position in the status bar (the default unit of distance is miles which is specified in **Map > Options**).
- Change the zoom, scale, and the center point of the current map view.
- Behavior of the map when you resize the window.
- Resize the map to fit the new window, keeping the view the same.
- Set the map to preserve the current scale, so that resizing the window has the effect of letting you see more or less of the map.

The **Help System** contains the following related topics:

- Opening MapInfo Pro Introductory Data
- Setting Margins for a Map Window when Printing
- Editing Text in a Map

**Displaying Data in a Browser Window**

You use **Browser** windows to view and manipulate your data records in traditional row and column form, typically used in spreadsheets and databases. Each column contains information about that particular field, such as name, address, phone number, cable ID number, or order amount. Each row contains all information relating to a single record.

- For more information, see **Displaying Data in a Browser Window** in the Help System.

**About the Browser Format**

If you have ever worked with spreadsheets or databases, you are probably familiar with the Browser format. Each row of the table contains one record, and each column in the record contains information about a particular field (for example, last name, street address, order number, price, and so forth). The name of the table appears in the **Browser** window title bar. Column titles appear directly below the **Browser** window title bar, appearing as headings. You select a row by single clicking the empty box appearing to the left of that row.

The Status Bar appears at the bottom left of the MapInfo Pro window. This bar displays the range of records currently displayed within the **Browser** window out of the total number of records in the table.

**Opening a Table in a Browser Window**

You can edit records in your table, copy records, add new ones, or delete existing records.
To open a Browser directly:

1. On the Window menu, point to New Browser Window.
2. If the Browse Table dialog box opens, then select a table from the list and click OK.

Your data displays within the Browser window.
The table must be editable to make changes to it—it cannot be read-only.

- For more information, see *Opening Multiple Browsers, Scrolling through a Table*, and *Using the Select Tool to Edit Browser Entries* in the Help System.

### About Browser Window Tools and Menus

#### Browser Window Toolbar

The **Browser** window includes a toolbar of options that apply to the data in the **Browser** window.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sort/Filter menu</td>
<td>Displays a pop-up menu with the options to <strong>Sort Multi-Column</strong>, <strong>Reapply Sort &amp; Filter</strong>, <strong>Toggle Sort &amp; Filter Off/On</strong>, <strong>Clear All Sort &amp; Filters</strong>, <strong>Clear Filters</strong>, <strong>Clear Sort</strong>, and <strong>Create a Query from the Browser Contents</strong>. Unavailable options are shown in grey.</td>
</tr>
<tr>
<td>Reapply</td>
<td>Re-applies your sort and/or filter conditions, so that any recent table edits are applied.</td>
</tr>
<tr>
<td>Selection menu</td>
<td>Displays a pop-up menu with the option to <strong>Select All</strong> or <strong>Unselect All</strong>.</td>
</tr>
<tr>
<td>Text Style</td>
<td>Opens the <strong>Text Style</strong> dialog box.</td>
</tr>
<tr>
<td>New Row</td>
<td>Adds a new row to the end of the table and changes the view to display the new, empty, row.</td>
</tr>
<tr>
<td>Pick Fields</td>
<td>Opens the <strong>Pick Fields</strong> dialog box.</td>
</tr>
</tbody>
</table>

#### Browse Menu Options

When the **Browser** window is active, then you will see a **Browse** menu option in MapInfo Pro’s main menu. Selecting this menu displays the following options:

<p>| Text Style | Opens the <strong>Text Style</strong> Dialog Box where you select how to display the text in the <strong>Browser</strong> window. This option is the same as choosing the <strong>Text Style</strong> button from the <strong>Browser</strong> window toolbar menu. |</p>
<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pick Fields</td>
<td>Use Pick Fields to choose which fields display in the active <strong>Browser</strong> window. You can also use Pick Fields to temporarily rename a column, creates a new column that will display in the <strong>Browser</strong> window, or edit the expression that defines an existing column.</td>
</tr>
<tr>
<td>Sort Multi-Column</td>
<td>Opens the <strong>Sort</strong> dialog box where you would make selections to perform a multi-column sort in the <strong>Browser</strong> window. This option is also available from the <strong>Browser</strong> window <strong>Sort/Filter menu</strong> button.</td>
</tr>
<tr>
<td>Reapply Sort &amp; Filter</td>
<td>Reapplies your last sort/filter to the data in a <strong>Browser</strong> window. Re-applying a sort and/or filter is useful after making changes to the data or after selecting to turn the sort/filter off. This option is also available from the <strong>Browser</strong> window <strong>Sort/Filter menu</strong> button.</td>
</tr>
<tr>
<td>Toggle Sort &amp; Filter Off/On</td>
<td>Turns off a sort, so that you can view data as it appears in the table. After turning a sort off, you can turn it back on to view the sort result. This option is also available from the <strong>Browser</strong> window <strong>Sort/Filter menu</strong> button.</td>
</tr>
<tr>
<td>Clear All Sort &amp; Filters</td>
<td>The <strong>Clear All Sort &amp; Filters</strong> command removes all sort and filters that were applied to the data in the <strong>Browser</strong> window. This removes the sort and filters from memory, so you cannot reapply them again after making this selection. This option is also available from the <strong>Browser</strong> window <strong>Sort/Filter menu</strong> button.</td>
</tr>
<tr>
<td>Clear Filters</td>
<td>Clears the filter conditions from this column, and refreshes the <strong>Browser</strong> window. The <strong>Clear Filter</strong> button is enabled after you have applied a filter condition to the currently-selected column. This option is also available from the <strong>Browser</strong> window <strong>Sort/Filter menu</strong> button.</td>
</tr>
<tr>
<td>Clear Sort</td>
<td>Removes the sort that was applied to the data in the <strong>Browser</strong> window. This removes the sort from memory, so you cannot reapply the sort after making this selection. This option is also available from the <strong>Browser</strong> window <strong>Sort/Filter menu</strong> button.</td>
</tr>
<tr>
<td>Create a Query from the Browser Contents</td>
<td>Opens the <strong>Create Query</strong> dialog box where you can select to open a new query in a new <strong>Browser</strong> window, and add the query as a layer to an existing map or to a new <strong>Map</strong> window. This option is also available from the <strong>Browser</strong> window <strong>Sort/Filter menu</strong> button.</td>
</tr>
<tr>
<td>Select All</td>
<td>Selects and highlights all of the rows in the table that is the <strong>Browser</strong> window.</td>
</tr>
<tr>
<td>Unselect All</td>
<td>Unselects the currently selected objects in a <strong>Browser</strong> window.</td>
</tr>
</tbody>
</table>
The Hide/Show Toolbar command removes the toolbar buttons from view in the Browser window. After hiding the Browser window tools, the Browse menu displays the Show Toolbar command.

| Options                  | Displays or hide the grid pattern in the Browser window. |

**Right-Click Context Menu Options**

Right-clicking on a column in the Browser window displays a pop-up menu with the following options:

**Sort A to Z**

- Sorts the column containing text alphabetically starting from A to Z.

**Sort Z to A**

- Sorts the column containing text alphabetically starting from Z to A.

**Sort Smallest to Largest**

- Sorts the column containing numbers from the lowest (smallest) value to the highest (largest) value.

**Sort Largest to Smallest**

- Sorts the column containing numbers from the highest (largest) value to the lowest (smallest) value.

**Filter**

- Opens the Filter dialog box where you can set filter conditions for the column. A filter may consist of up to two conditions where each condition is built from a simple set of operations (such as equals, greater than, and so on) and some set of values. After applying a filter to a column, an icon displays in the column header to let you know that the column has a filter. You can apply as many column filters as the number of columns in the table up to a limit of 100. Each new column filter is appended to the previous filters to produce fewer records in the current view.

**Clear Filter**

- Clears the filter conditions from the column and refreshes the Browser window. This only clears the filter on the right-clicked column, filters and sort on other columns are preserved. The Clear Filter button enables after you apply a filter condition to the column.

**How a Browser Displays in a Layout**

A Browser window displays with the column headings at the very top of the frame. Immediately below, it displays the contents of the table, starting with the row and column at the upper-left corner of the table. It displays as many columns and rows as it can fit in the frame, regardless of how many are displayed in the table. When you resize the frame, the number of rows and columns displayed...
are adjusted accordingly. However, fields removed from the table with the **Pick Fields** command (right-click on the **Browser** window and select **Pick Fields** from the pop-up menu) are not displayed in a table frame.

The number of rows and columns that can be displayed in a frame depends on font size and column width. The frame displays Table text using the font style and size for that **Browser** window. When you want a different type style in the frame, you would select the **Text Style** button. When you use smaller type, you can get more rows and columns in a frame.

You can also manually adjust column width in a **Browser** window without affecting the underlying field size for the base table. You do this by clicking and dragging the short vertical bars separating the column names in the **Browser** window.

The **Browser** window always has a current cell, which is never in a deleted row. The **Browser** window scrolls as necessary to keep the current cell in view. When not in edit mode, the current cell displays with a black border. When in edit mode, the current cell has a gold outline. You can use keyboard gestures to move the current cell.

The **Help System** contains related topics:

- Showing or Hiding a Browser's Grid
- Adding and Editing Text in a Browser
- Entering Multi-Line Text
- Selecting and Deleting Rows in a Browser Window
- Undoing or Redoing an Action
- Adding Fields to a Browser
- Removing Fields from a Browser
- Adding a New Row to a Browser
- Resizing a Browser's Columns
- Printing a Browser View
- Setting Margins for a Browser Window when Printing
- Sorting Data in a Browser Window
- Toggle Sort and Filter Off or On
- Filtering a Column in a Browser Window
- Clearing a Sort and/or Filter
- Re-Applying a Sort and/or Filter
- Adding a Filtered View to a Map
- Creating a Default Browser View
- Choosing a Font for Your Browser Window
- Preserving Column and Expression Settings in a Browser Window
- Using the HotLink Tool in a Browser Window

For information about setting the background color for **Browser** window rows and other preferences, see **Setting your Browser Window Preferences**.
Changing a Record's Data, Font, and Style

The **Info** tool allows you to choose an object or row and see a window displaying information from the table about that object. Click another object with the **Info** tool button and its information appears in the same window. Click the **Ctrl**-menu box (**Close** box) of the **Info** window to make it disappear.

**Mouse Wheel Support for Browser Window**

When you are working in the **Browser** window, you can use the mouse wheel to scroll through the records. Roll the mouse button down to scroll down the list, and roll the mouse button up to scroll up the list. You can use the **Tab** key to scroll right and the **Shift+Tab** keys to scroll left in the **Browser** window.

Displaying Data in a Graph Window

The **Graph** window allows you to visualize statistical relationships in graph format. You can create many different kinds of graphs: 3D, area, bar, bubble, column, histogram, line, pie, scatter, and surface graphs. You can also choose from a number of different graph templates.

To display a table as a graph:

1. From the **File** menu, click **Open** and select the table that you want to display as a graph.
2. On the **Window** menu, point to **New Graph Window**.

After the graph displays you can invoke one of several editing dialog boxes from the **Graph** menu to modify an extensive array of attributes. You can also move and resize objects within the graph window until the desired graph is achieved.

For details about using the graph features, see **Graph Help System available by selecting** (on the **Help** menu, point to **MapInfo Graphing Help Topics**).

Displaying Data in a Layout Designer Window

The **Layout Designer** window lets you stylize your map for presentation and publishing. You can design a map layout for print or to export to an image file for distribution.

To open the **Layout Designer** window, either:

1. On the **Standard** toolbar, click the **Layout Designer** tool.
2. On the **Window** menu, point to **New Layout Designer Window**.

After the **Layout Designer** window opens, you can add **Map** and **Browser** windows to your layout, add images and shapes, and create a legend for the map layout. How you stylize the map and browser in your layout does not affect the styles in your open **Map** and **Browser** windows.

You can save your map layout to a workspace to work on it in later sessions. Besides printing a layout you can also export it to an image to include within a presentation or for distribution.
For details about the Layout Designer window, see Working with Layouts (on the Help menu, point to Working with Layouts).

Displaying Data in a Layout Window

The Layout window allows you to combine Browser windows, Map windows, Graph windows, and other graphic objects into one layout which can then be sent to a printer or plotter. You use this type of window to create presentation graphics. Layout windows have scroll bars at the right and at the bottom like Map windows and Browser windows.

You can display rulers at the top and to the left to help you in positioning, sizing and aligning objects.

The Zoom displayed in the status bar indicates the magnification factor that is currently applied to the layout. When the zoom is 37.46%, then the layout is being displayed 37.46% of its actual size. When the zoom is at 123%, then the layout is being displayed at 123% of its actual size.

Opening a Map in a Layout Window

To use a Layout window, on the Window menu, click New Layout Window.

Note: MapInfo Pro has some excellent tools to assist you in moving around the Layout window. See Getting Around in the Map Window for these details.

The Help System contains these related topics:

- Sending Objects to the Back of a Layout
- Sending Objects to the Front of the Layout
- Printing a Layout
- Setting Printing Margins for a Layout
- How a Map Legend Displays in a Layout
- Printing a Legend in a Layout
- Changing a Map Scale in a Layout
- Moving a Map or a Layout

For instructions for sending objects to the back of a layout, see Displaying Data in the Layout in the Help System.

For instructions for sending objects to the front of a layout, see Displaying Data in the Layout in the Help System.

Other Windows for Displaying Data

There are two other ways of displaying data that are used less often or can be used in conjunction with display options we have already reviewed.

- Legend Designer Windows display legends, or keys, to the cartographic data on your map. (Map legends are the key boxes at the bottom of a map that explain what the map symbols mean.) The Legend Designer window displays information for any map layer including thematic map layers.
The legend frames can all be in one Legend Designer window, or can be split among several Legend Designer windows for the same map. Therefore, each map can have one or more Legend Designer windows containing the frames of your choice. Additionally, you can customize the text and style of the information presented. Modifications to the legend can be made through shortcut menus you access by right-clicking in the Legend Designer window or through the Legend Designer menu. You can learn more about legends in Working with a Thematic Map Legend.

- Redistricting Windows allow you to create groupings of spatial information. This is a little more complex than these other options. For more information about redistricting windows, see Redistricting in the MapInfo Pro Help System.

Working with Tables in the Table List

The Table List window lets you perform operations for open tables in MapInfo Pro using fewer clicks. You can organize tables into groups and sort them alphabetically and recently opened first. The Table List window is accessible on the Table menu by pointing to Table List.

The Table List has the following features:

- Modeless, so that you can open it and leave it open for the duration of your session. (Modeless windows do not have OK or Cancel buttons.)
- Dockable to any of the four sides of the MapInfo Pro window: top, left, bottom, and right. The Layer Control window and Table List window can also share the same space.
- Drag and drop enabled, so that you can select tables and drag and drop them to a blank area to open them in a new Map window. When dropping tables on to an existing Map window, MapInfo Pro adds them to the Map window as new layers.
- Sorting enabled, to sort tables based on ascending order of table alias (name), descending order of table alias, and recently opened. Sorting criteria persist across different MapInfo Pro sessions.
- Multi-Selection enabled, to select multiple tables using the Ctrl or Shift keys.
- Context Menu enabled, so that when you right-click on table aliases (names) a pop-up menu displays and you can perform the desired operations.
- Searching enabled, you can search for a table name in the Table List window by typing characters in a Search text box. The Table List window list refreshes itself to show only those tables that contain the search characters.

Accessing the Table List

To access the Table List, do one of the following:

- Click the Table List tool on the Main toolbar.
- On the Table menu, point to Table List.
The Table List lets you manage open tables and their attributes. It is resizable. It supports two modes of display:

- **ListView** - tables display as a list.
- **TreeView** - tables group according to the type they belong to.

### About the Table List Window

To see the table names of the open tables, expand or collapse the groups using + and -. Hovering over an entry in the Table List will display the path of the open table as a tool tip.

### About the Table List Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Group By Type" /></td>
<td>Click to switch to tree view mode.</td>
</tr>
<tr>
<td><img src="image" alt="Ungroup by Type" /></td>
<td>Click to switch to list view mode.</td>
</tr>
<tr>
<td><img src="image" alt="Ascending order" /></td>
<td>Click to sort tables in ascending order.</td>
</tr>
<tr>
<td><img src="image" alt="Descending order" /></td>
<td>Click to sort tables in descending order.</td>
</tr>
<tr>
<td><img src="image" alt="Recently Opened First" /></td>
<td>Click to sort tables based on the order they were opened. The most recently opened table displays first. In tree view mode, the table type nodes always display in ascending order. The sorting criteria persist across different MapInfo Pro sessions.</td>
</tr>
</tbody>
</table>

### About the Table List Menu Options

Right-click on a table in the Table List to view a pop-up menu with the following options:

- **Select All from** - Select this option to select all the rows in the table together. If a table is selectable, this menu item includes the table name. For unsupported tables, this menu option is unavailable.
- **Browse** - Select this option to open a table in a Browser window and edit records, copy records, add new records, or delete existing records.
- **Open in new Map Window** - Select this option to open the table in a new Map window.

For more information, see Opening MapInfo Tables in the Help System.
• **Export** - Select this option to open the *Export Table to File* dialog box to export the table. You can export graphics and tabular data to MapInfo Pro format (MIF). Only tabular data can be exported to Delimited ASCII (*.txt), dBASE DBF (*.dbf), and Command delimited CSV (*.csv).

• **Refresh** - Select this option to refresh WFS, Universal Data, and DBMS tables. It is enabled for single selection only.

**WFS table** - It refreshes the WFS layer based on the WFS server settings and the filter options set for WFS Refresh in the Web Services Preferences. It is enabled for a WFS table when connection to the Internet or intranet is established.

**Universal Data table** - It refreshes the Universal Data table, such as AutoCAD®, Microstation Design®, and ESRI ArcSDE datasets.

**DBMS table** - It refreshes a MapInfo Pro linked table with the most recent data residing on the remote database for that linked table. It is enabled when there are no pending edits against the table.

• **Table Structure** - Select this option to specify the field name, field type, number of characters (width), and whether the field is to be indexed for each field in your new database. You also indicate whether or not the table is mappable by associating graphic objects with records and, if so, whether the map is to be an earth or a non-earth map. Collectively, this information is the structure of your database.

For more information, see *Modify Table Structure Dialog Box* in the Help System.

• **Create Points** - Select this option to create point objects for a database that has X and Y coordinates or longitude/latitude coordinate information. These points can be displayed on a map. If you do not have coordinates in your table, then use Geocode to match some other geographic information (such as street address) against a table that already has graphic objects.

For more information, see *Create Points Dialog Box* in the Help System.

• **Update Column** - Select this option to change a column's value by updating a table based on its own data values or by updating a table based on data from another table. This dialog box remembers the column that was updated the last time update was run and the expression that was used for updating a column the last time an update was run.

For more information, see *Update Column Dialog Box* in the Help System.

• **View/Edit Metadata** - Select this option to view the metadata of a managed table.

• **Add to Library** - Select this option to create a metadata record for the layer in the MapInfo Manager Library. You can perform this operation only after selecting the Catalogs and Library Mode preference for library services and while at least one unmanaged native table is open.

For more information, see the Catalog Browser Help System.

To set preferences for library services: on the Options menu point to Preferences, select Web Services, and click the Library Services tab.

• **Close** - Closing a table removes it from active use in your current session. When you close a table, you automatically close all views of that table. When closing a table that displays in a Map
window with other tables, MapInfo Pro removes that table from the window and keeps the Map window open.

For more information, see *Closing a Table* in the Help System.

**Moving the Table List to Customize your Work Area**

The Table List is a floating window, so that you can leave the Table List open throughout your session.

To move the Table List to another location in the application window:

- **Dock it** to any of the four sides of the MapInfo Pro window: top, left, bottom, and right. The Layer Control window and Table List window can also share the same space. You can dock it also using the docking guides if you enable it from System Preferences. Look for System Preferences dialog box.
- **Undock it** by double-clicking the Table List window title bar, so that it floats. You can then move it to another location in the application window.

**Note:** If your computer has two monitors, try dragging the Table List window on to the second monitor. This arrangement allows more room for Map windows on the first monitor.

**Selecting Multiple Tables in the Table List**

Multiple tables can be selected with Ctrl, Shift keys, or arrow keys. Only Browse, Open in new Map Window and Close options are enabled in the context menu for multi-selected tables.

**Note:** In tree view mode, only tables can be selected. Table type nodes are not selectable.

**Dragging and Dropping in the Table List**

To open multiple tables in a new Map window, select them (using the Ctrl and Shift keys) and then drag and drop them on to a blank area. When dropping tables on to an existing Map window, MapInfo Pro adds them to the Map window as new layers.

**Note:** Tables can be dropped only on a Map window or an empty area in the MapInfo Pro.

**Sorting in the Table List**

You can sort tables based on ascending order of table alias (name), descending order of table alias, and recently opened. Sorting criteria persist across different MapInfo Pro sessions.

The following buttons sort the Table List view:
Click to sort tables in ascending order. Ascending order

Click to sort tables in descending order. Descending order

Click to sort tables based on the order they were opened. The most recently opened table displays first. In tree view mode, the table type nodes always display in ascending order. Recently Opened First

**Note:** The sorting criteria persist across different MapInfo Pro sessions.

### Searching the Table List

**Searching Tables**

You can search for a table name in the Table List by typing characters in the Search text box. The Table List view refreshes itself to show only those tables that contain the search characters.

**Clear Search**

Typing in the Search text box causes the Search button to change to a Clear Search button. To clear the contents of the Search text box, click the Clear Search button.

### Working with Layers in the Layer Control

The Layer Control window lets you control the layers on display for all maps open in MapInfo Pro.

**Select and Modify Many Layers at Once**

Select multiple layers at once in the Layer list by using the Shift and Ctrl keys. Selecting a check box for one of these layers then selects the check boxes for all selected layers. This is useful when turning several layers off, because the map redraws only once instead of redrawing for each layer selection.

Modify multiple layers at once instead of having to modify layer properties one layer at a time. Use the Shift and Ctrl keys to select multiple layers in the Layer list, and then click the Layer Properties button to launch the Layer Properties dialog box. Changes apply to all selected layers making it easier to ensure consistency in your layer settings. You can also set the style override for all selected layers by clicking the style swatch for one of the layers, or set the labeling font for all the selected layers by right-clicking on one of the layers and then choosing Label Font.
You can only modify a selection of similar layers; if you select different types of layers, such as a raster layer and a pie theme, then the dialog box is not enabled.

**Preview Style Changes before committing them**

Style dialog boxes that are launched by clicking a style swatch for a layer in the Layer Control list include a Preview button. Use this Preview button to see what the map will look like with your style changes before committing the change. You can cancel the preview if you do not like what you see by clicking the Cancel button in the style dialog box.

**Apply Display and Label Overrides for when zooming the Map**

At different zoom levels information on the map may be difficult to view. Changing (overriding) the display style for specific zoom levels can help. As an example, to make the map easier to read, you may want roadways to display using a thick line when zoomed in to the map, but a very thin line when zoomed out of the map.

Right-clicking on a layer in the Layer Control list and clicking the Add a Display Override option creates a display override for that layer. Right-clicking and clicking the Add a Label Override option creates an override for labels for a layer. The first display override defaults to the zoom range of the layer. Adding subsequent display overrides splits the zoom range of the first display override. You can then customize the display style for the layer at each specific zoom level.

**Reorder Layers**

The Layer list has multi-select capabilities. To change the order of one or more contiguous layers, hold down the **Shift** key, select the layers, and drag them up or down. To change the order of one or more layers that are out of sequence, hold down the **Ctrl** key, select the layers, and drag them up or down.

When you begin to drag the layers, the cursor will change shape to represent the number of layers being dragged. If you are dragging one layer, the cursor becomes an arrow icon with a single layer icon attached to the top. If you are dragging multiple layers, the arrow icon will display multiple layer icons at the top. If you select layers that cannot be dragged or if you are attempting to insert layers where they cannot be inserted, the cursor becomes a circle with a line through it.

**Note:** A selection of layers that is out of sequence will become contiguous upon insertion.

Use the **Move Layers Up** or **Move Layers Down** buttons to move one or more layers. You cannot reorder or remove the Cosmetic layer. It will always be the top layer.

**Group Layers**

Group layers to organize them, so that you can show or hide the entire group with a single click.

**Note:** Group Layers are not preserved when you do a Save Workspace As to a .MWS file.

**Quick View an Entire Layer**

Right-click on a layer name and choose **View Entire Layer** to see the layer as a whole without going through a dialog box.

**Rename Maps**
You can give a descriptive title for your map by right-clicking on the Map name (at the top of the layer list) and choosing **Rename Map**.

**Suspend or Resume Map Drawing**

For those times when you want to make many quick changes, and you do not want the map to redraw after each change, you can toggle the Automatic Map Drawing button to temporarily turn off map display.

- For more information, see *Grouping Layers* and *Suspend or Resume Map Drawing*, in the Help System.

**Accessing Layer Control**

To access the Layer Control window, do one of the following:

- Click the **Layer Control** tool in the **Main** toolbar.
- On the **Map** menu, point to **Layer Control**.

**About the Layer Control Window**

Use **Layer Control** to manipulate the layers and their attributes to determine the map display.

![Layer Control Window](image)

Each row represents a layer on the map. You can select the following for each layer:

- Selecting the **Visible** check box displays a layer on the map.
- Clicking the **Layer Type** icon lets you edit style properties for the items in the layer, such as:
  - points
• Clicking the **Editable** icon makes the layer editable.

• Clicking the **Selectable** icon makes a layer selectable in the **Map** window.

• Clicking the **Automatic Labels** icon labels a layer automatically.

The buttons in the **Layer Control** window are described under **About the Layer Control Buttons**.

Visual indicators in the Layer list provide more information about a layer:

• When a layer is outside of its zoom range, the layer name is dimmed and there is an asterisk (*) beside the Visible On/Off check box.

• Selecting an object, such as a point or line, in the **Map** window causes the layer name to appear in **bold**.

• When you select a layer, it is highlighted in the list. You can select multiple layers by using the **Ctrl** and **Shift** keys when making your selections.

**See also:**

• **Map Layers**

• **Reordering Map Layers**

• **Grouping Layers**

• **Suspend or Resume Map Drawing**

**Layer Types**

The **Layer Type** indicate the types of items in the layer, such as points, lines, regions, theme range, or raster images. If the layer has a style override, then the icon indicates the style. You can show or hide layer type icons by clicking the **Layer Control Options** button in the **Layer Control** window. **Layer Type** icons include:

• For points, lines, and regions, click the icon to open the corresponding style dialog box and edit style properties for the layer.

  ![points](https://via.placeholder.com/15)

  ![lines](https://via.placeholder.com/15)

  ![regions](https://via.placeholder.com/15)

• A layer with a theme shows a thematic icon. For more about thematic layers, see **Working with Thematic Layers**.

  ![Range Theme](https://via.placeholder.com/15)

  ![Bar Chart Theme](https://via.placeholder.com/15)
Pie Chart Theme

Graduated Symbol Theme

Dot Density Theme

Individual Theme

Grid Theme

- A map tile server layer or a raster layer displays the following icon:
  Raster Layer or Tile Server Layer

- A group layer icon indicates a group of layers. You can drag to move layers in to or out of the group.
  Group Layer

Note: Group layers are not preserved when you do a **Save Workspace As** to a .MWS file.

### About the Layer Control Buttons

The following buttons in the **Layer Control** window help you to control how the map displays layers:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="https://via.placeholder.com/15" alt="Add Layers" /></td>
<td>Click to open the <strong>Add Layer</strong> dialog box and add one or more layers to the map. Select from the list of open tables. Your additions display in the Layer list. The <strong>Add Layers</strong> button enables when there is an active <strong>Map</strong> window; the layers you add are for the active <strong>Map</strong> window. Before clicking the <strong>Add Layers</strong> button, make a map active (bring it to the front) by clicking on the map title in the layer list.</td>
</tr>
<tr>
<td><img src="https://via.placeholder.com/15" alt="Remove Layers" /></td>
<td>Click to remove selected layers from the Layer list. To select multiple layers, press the <strong>Shift</strong> or <strong>Ctrl</strong> key while selecting layers. Note: The <strong>Remove Layers</strong> button displays a confirmation dialog box. If you would rather not see these confirmation prompts, click the <strong>Layer Control Options</strong> button and un-check <strong>Confirm Removal of Layers</strong> in the <strong>Layer Control Options</strong> dialog box.</td>
</tr>
<tr>
<td><img src="https://via.placeholder.com/15" alt="Move Layers Up" /></td>
<td>Click to reorganize one or more layers in the list. To select multiple layers, press the <strong>Shift</strong> or <strong>Ctrl</strong> key while selecting layers.</td>
</tr>
<tr>
<td>Button</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>Move Layers Down</td>
<td>Click to reorganize one or more layers in the list. To select multiple layers, press the <strong>Shift</strong> or <strong>Ctrl</strong> key while selecting layers. The order determines which layers obscure the contents of the other layers; the bottom layer in the list is the most obscured.</td>
</tr>
<tr>
<td>Layer Properties</td>
<td>Click to open the <strong>Layer Properties</strong> dialog box and set display attributes, including label display and labeling rules, for selected layers. The <strong>Layer Properties</strong> button enables after selecting a single layer or multiple layers of the same type. If you select two different layer types, such as the cosmetic layer and a raster layer, then this button does not enable.</td>
</tr>
<tr>
<td>Modify Theme</td>
<td>Click to open the <strong>Modify Thematic Map</strong> dialog box and set display attributes for a thematic layer. This button is only active after selecting a thematic layer.</td>
</tr>
<tr>
<td>Hotlink Options</td>
<td>Click to open the <strong>Hotlink Options</strong> dialog box where you can specify filename expression, file locations, what activates HotLink, and saving options to table metadata. See <strong>Creating Active Objects</strong> in the Help System. The Hotlink Options button enables only after selecting a single layer.</td>
</tr>
<tr>
<td>Adjust Labeling Priorities</td>
<td>Click to open the <strong>Adjust Labeling Priorities</strong> dialog box where you can move layers up and down in the list to adjust layer priority when <strong>Automatic Labeling</strong> is turned on for layers. The Adjust Labeling Priorities button is enabled when the active map has at least two layers that can be labeled (this does not include raster, theme, or cosmetic layers).</td>
</tr>
<tr>
<td>Selectable Labels</td>
<td>Click to control whether you can select labels when you click on the map. By default, labels are selectable. You might make labels unselectable if you find that you are accidentally selecting labels on the map when you were trying to select points or lines. This is a per map setting, so each <strong>Map</strong> window has its own setting. Each map’s <strong>Selectable Labels</strong> setting is preserved when you save a workspace.</td>
</tr>
<tr>
<td>Automatic Map Drawing</td>
<td>Click to allow map redraw or to turn off map display as changes are made to layers. Select to suspend automatic redraw when there are many layers that slow the redraw process.</td>
</tr>
<tr>
<td>Layer Control Options</td>
<td>Click to open the <strong>Layer Control Options</strong> dialog box and set which maps show in the Layer list, enable confirmation when removing a layer, disable tooltips in the <strong>Layer Control</strong> window, and show or hide icons in the <strong>Layer Control</strong> window.</td>
</tr>
</tbody>
</table>
**Moving the Layer Control Window to Customize Your Work Area**

The Layer Control is a floating window, so that you can leave the Layer Control window open throughout your session. It also docks to the side of the application window, so that you can customize your work area.

To move the Layer Control to another location in the application window:

- **Undock it** - Double-click the Layer Control window title bar, so that it floats. You can then move it to another location in the application window.
- **Dock it** - Drag the Layer Control window by the title bar, toward the left or right side of the screen, so that the Layer Control window snaps in to place.

**Note:** If your computer has two monitors, try dragging the Layer Control window on to the second monitor. This arrangement allows more room for Map windows on the first monitor.

**Adding Layers to the Map**

You can add one layer to the current Map window at a time or use the multi-select functionality to add layers simultaneously.

**Note:** You can only add layers from tables that are open. If you want to add a layer and you do not see it in the list, make sure the table that contains that layer is open.

- For more information, see the Help System.

**Reordering Map Layers**

Map layers display in the order that they are listed in the Layer Control window, with the bottom layer drawn first and the top layer (which is always the Cosmetic Layer) drawn last. It is important to order your layers correctly.

For example, you have a layer of customer points and a layer of census tracts. If the layers are incorrectly ordered in the Map window, MapInfo Pro might draw the customer points first and then display the census tract layer second. Your points would be obscured by the census tract layer. You can reorder how layers are displayed in a Map window two ways.

- For more about layers, see Reordering Layers, Changing the Order of Contiguous Layers and Changing the Order of Random Layers topics in the Help System.

Layer order is also important when you use the Select button. The Select tool selects objects from the topmost Selectable layer. If you have several objects at the same location, it is difficult to select the exact one you want. You can reorder your layers in Layer Control so that the layer you want to select from is the new topmost layer.

MapInfo Pro does not allow you to control the front-to-back ordering of objects within a single map layer. If you are editing a table, and you draw a line on top of a circle, the line might appear in front
of or behind the circle; you cannot control whether it is in the front or the back. You can, however, control the front-to-back ordering of objects in a Layout window.

**Note:** If you need to control the ordering of objects (for example, you need to make sure that your lines display on top of your regions), put the different object types in separate layers. Put your line objects in one table, and put your region objects in another table. Then use the Layer Control window to order the layers.

- For more information, see *Removing a Layer from the Map* and *Changing how a Layer Displays on the Map* in the Help System.

### Setting the Zoom Layering

Sometimes you want a map layer to display only at certain zoom levels. *Zoom Layering* controls the display of a map layer so that it displays only when the map's zoom level falls within a preset distance.

For example, you have a layer of streets and a layer of postal code boundaries. When you zoom out past 10 or so miles, the streets look like a black smudge in the window. This is because the zoom (window width) is too wide to show detailed street maps. Use Zoom Layering to tell MapInfo Pro to display the street layer only when the zoom is set to a distance that allows you to see the street detail properly, for instance, less than 5 miles.

The first map does not have zoom layering set for its street layer. At a zoom of 15 miles across, notice how difficult it is to see any detail. The second map has zoom layering set to display the streets when the zoom is less than five miles. Therefore, the streets layer does not display when the window is set at 15 miles.

For more information, see *Setting the Zoom Layering* in the Help System.

You can display different layers in the same Map window at different zoom levels. For example, you have a layer of streets, a layer of county boundaries, and a layer of state boundaries. You want the streets layer to be visible only when the zoom level is less than eight miles. You want the county
boundary layer to display when the zoom level falls between 20 miles and 200 miles. You want the states boundary layer to be visible only when the zoom level is greater than 100 miles. You can set a different zoom level for every layer in your Map window.

**Note:** When you add an object, a region, a line, or a polyline in the Map window and zoom out beyond where the zoom layer would permit you to see that feature, MapInfo Pro turns off zoom layering so you can continue to see what you are working on. When you complete the add process, a message displays asking you if you want to leave zoom layering off (so you will still be able to see the feature). If you click **Cancel**, MapInfo Pro cancels the zoom layering. If you click **OK**, you need to adjust your zoom settings to see this feature again.

For more information, see *Changing a Map's Zoom Level* in the Help System.

### Positioning and Sizing Labels

To label a map object using the Label button:

1. Make sure that the layer containing the objects you want to label is selectable. Choose **Map > Layer Control** and click the **Selectable** icon to make the layer selectable.

2. Click the **Label** button in the **Main** toolbar.

3. Click on an object with the Label button to display a label for that object.

MapInfo Pro labels the object with the values (from the column that you specified for that layer in the **Layer Properties** dialog box on the Label Display tab).

### Changing Label Options

Two features in the **Layer Properties** dialog box help you with label placement: Label Position and Offset.

To change label options:

1. Choose **Map > Layer Control**. The Layer Control window opens.

2. In the Layer list, double-click the layer name. The **Layer Properties** dialog box opens.

3. Select the **Label Display** tab and specify the desired label options, such as label style.

4. Select the **Labeling Rules** tab and specify the desired label placement and label adjustments, such as allow or discard overlapping text, try other positions when overlapping occurs, allow duplicate text, and label partial objects.

**Label Position** (also called the anchor point) is the label's position relative to the map object. Click on one of the buttons to select an anchor point. You have nine choices.

The anchor point is an ongoing attribute of the label. For example, if you anchor a point object's label at Center Left and you increase the label's font size, the text will grow to the left. This way, the text can never overwrite the point.

The default anchor point varies with the type of map object you are labeling:

- Regions default to Center.
• Lines default to Below Center.
• Points default to Right.

**Label Offset** is how far away a label is from its anchor point. Specify the number of half spaces you want the label to be from the anchor point in the **Label Offset** box.

5. Click **OK**.

The map redraws with your changes.

**Label Size**

Label size does not change with zoom or scale changes. Labels display at the size you specify at all zoom levels as well as on printed output. Labels are never hidden behind other geographic objects because they are always the last objects drawn on the map.

### Displaying the Lines, Nodes, and Centroids

The **Layer Properties** dialog box allows you to display line directions, nodes, and object centroids. Select the **Show Line Direction** check box when you want to show the direction in which line objects are drawn. Check the **Show Nodes** check box to display the nodes in a layer.

The **Show Centroids** box displays the centroids of each object in a layer. In MapInfo Pro, a region's centroid does not represent its center of mass. Instead, the centroid represents the location used for automatic labeling, geocoding, and placement of thematic pie and bar charts. If you edit a map in Reshape mode, you can reposition region centroids by dragging them.

See the **Help System** for these related topics:

• **Changing a Layer's Labeling Options**
• **Changing a Region's Centroid**
• **Changing a Label's Style**
• **Drawing Autolabels**

For instructions on inserting table-based style in the Layer Control window, see *Inserting Styles into Tables* in the **Help System**.

### Understanding the Cosmetic Layer

Every Map window in MapInfo Pro has a Cosmetic Layer. Think of the Cosmetic Layer as the blank transparency that lies on top of the other map layers (transparencies). It can store map titles and other graphic objects you create during a work session. The Cosmetic Layer is always the top layer of the map. You cannot remove or reorder the Cosmetic Layer.
You can only make the Cosmetic Layer editable or selectable. Other Layer Control options (labeling, zoom layering, display mode) are not available for the Cosmetic Layer. To select fill patterns, line types, symbols, and text font for the Cosmetic Layer, use the Line Style, Region Style, Symbol Style and Text Style commands from the Options menu. When the Cosmetic Layer is editable, you can access the style options from the Drawing Toolbar.

The contents of the Cosmetic Layer are linked proportionally to the map. Map objects (except for symbols) and text in the Cosmetic Layer are proportionally linked to the zoom level of the map. If you draw objects in the Cosmetic Layer and then change the map's zoom from 30 to 100 miles, the size of the objects will appear smaller.

The Help System contains these related topics:

• Using the Cosmetic Layer
• Saving Cosmetic Layer Objects
• Saving Objects on the Cosmetic Layer
• Removing Cosmetic Objects
• Disabling the Save Cosmetic Objects Warning Dialog Box

Making the Layers "Editable"

To make changes to the graphic objects in a layer, you must make the layer editable. You can draw objects on that layer, add text, combine, or delete objects. You can only make one layer editable at a time.

• For specific instructions, see Making Layers Editable in the Help System.

Making a Read-Only Table "Editable"

If you are working with tables that were opened from Excel, Lotus, or ASCII files, you may have noticed that they come in as read-only tables. Because the files are not in native MapInfo Pro formats or standard DBF format, MapInfo Pro is unable to edit the tabular information contained in these tables.
If you wish to modify the table information, you must save a copy of the table. You can do this when you open the table in MapInfo Pro by selecting the Create copy in MapInfo format for read/write check box before selecting Open in the Open dialog box.

• For instructions on making read-only map layers editable, see Making Layers Editable in the Help System.

Getting Layer Information

You can use the Info tool button to get information pertaining to the map layer.

To get information about an object in a particular layer:

1. Make sure the layer you want information about is the selectable layer.
2. Click Info in the Main toolbar and click the object you want information about.

   Note: If the information that displays is not what you were looking for, check to see that the layer you are interested in getting data for is selected.

Using either method, the Info Tool box displays.

![Sample World Map](image)

**Note:** Use the Ctrl key with the Info button to toggle through all selectable layers and access overlapping objects.

When you click a map location using the Info button where two or more selectable map objects overlap, the data tied to the objects on each layer display in the Info tool window. If you do not want the information for all layers to display, turn off Selectable for those layers in the Layer Control window.
You can also view an object's label expression in an InfoTip when you use the Select, Info, or Label buttons. InfoTips work very much like ToolTips. Using one of these tools, place your cursor over an object. An InfoTip displays the label expression for the object in the topmost selectable layer. To set InfoTips for a particular layer, adjust the Selectable attribute in the Layer Control window so that the Tips display for the layer you want. InfoTips are active by default, but you can turn them off in the Map window preferences (on the Options menu, point to Preferences and click Map window).

Selecting Objects in a Layer

If you only want to select objects for further analysis rather than edit the objects, make the layer selectable. More than one layer can be selectable at a time. If a layer is editable, it is also selectable.

Many MapInfo Pro functions require that map objects be selected before performing the particular operation. To use the Select button, Label button or Info button you must first make the layer selectable. Unlike the editable feature, more than one layer may be selectable at the same time. You may, however, only select from one layer at a time.

The Select button selects objects from the topmost Selectable layer. To select an object that is not in the top Selectable layer, you can turn off the Selectable option in Layer Control for every layer above the layer you want to select from by selecting a layer's Selectable icon to deactivate it. Alternately, you can leave all layers Selectable and use the Ctrl key in combination with the Select button to cycle through each Selectable layer.

Note: The instructions for making a layer editable are the same, except that you select Editable On/Off instead.

• For instructions on making objects in a layer selectable, see Selecting Objects in a Layer in the Help System.

For example, if you want to find all customers who live within a fifty kilometers radius of Paris, make the Street layer selectable. If the map also includes a layer of hospitals (which you do not want to include in the radius search), turn off the Selectable option for the hospital layer.

The Editable or Selectable options only apply to the Map window itself. You can always select objects using the Select or SQL Select commands regardless of whether a layer is selectable.

Working with Thematic Layers

When you create a thematic map in MapInfo Pro, the thematic shading is added to your map as a separate layer. It is drawn on top of the layer, from which it gets the raw data. Separating a thematic layer from its base layer provides you with several important options:
Graduated symbol thematic maps do not require that your base layer contain point objects. Instead, graduated symbol objects are built regardless of the map object type. Therefore, even if your base layer contains region or line objects, you will still be able to create a graduated symbols map.

- You can have multiple thematic layers per base layer. In some cases, you do not have to add another base layer to the map to create another thematic layer. You can display more than one thematic layer at a time, as well as perform bivariate thematic mapping.
- You can use Layer Control to turn the display on or off for a given thematic layer. The layer it is based on can continue to display. You can also set individual zoom layers on thematic maps.

Ordering Thematic Layers

To display thematic layers properly, they must be in a specific order. This is especially important when you want to display more than one thematic layer at a time. For example, you would want pie or bar charts for an area map to display on top of regions that are shaded in order to see them.

The following lists the order of map layers from top to bottom (note that map layers are drawn from the bottom up):

1. Pies, Bars, or Graduated Symbol thematic layer.
2. Dot Density thematic layer.
3. Ranged thematic layer - where Color or Size Attributes are applied.
4. Ranged (or Individual Value) thematic layer - where All Attributes are applied.
5. Major layer or base layer.
6. Grid thematic layer.

When you create a new thematic layer, MapInfo Pro automatically inserts it into its proper place.

- For more information, see Reordering Thematic Layers in the Help System.

Displaying Thematic Layers

You can turn the display on and off for thematic layers the same way you can for other map layers. All the display settings in Layer Control are also applicable to thematic layers, enabling you to set a zoom level for each thematic layer. You can also access the Modify Thematic Map dialog box through Layer Control by double-clicking a Thematic layer.

Thematic layers are always drawn after their base layer. Therefore, they appear above their base layer in the Layer Control list, and are indented to distinguish them from other map layers.

Thematic layers are displayed in the list with this naming convention:

- `<Thematic type> with/by <variable-list>`

The type of thematic map is noted first, followed by the list of variables used to create the map. For example, a pie thematic layer that uses commuting data is listed this way:

- Pies with ComAlone, ComCarpool...
The variable list is truncated if there is not enough room to display each variable used in your thematic analysis. For more information about thematic mapping, see Using Thematic Mapping to Analyze Information.

Converting Objects into Region Objects

When you convert a circle or ellipse into a region, the region contains 101 nodes. When you convert an arc into a region, the number of nodes depends on the starting and ending angle of the arc. If the arc spans 180 degrees (for example, the starting angle is zero and the ending angle is 180), a region based on the arc will contain 52 nodes; if the arc spans 90 degrees, a region based on the arc will contain 27 nodes; etc.

If you perform extensive map editing, you may need to convert polylines to regions. If you cut or copy a group of selected nodes, MapInfo Pro treats the set of nodes as a polyline object, and places the polyline on the clipboard. If you then paste the object, MapInfo Pro places the polyline on your map. At this point, you may want to perform Convert to Regions, depending on whether you want the finished object to be a region.

Convert to Regions also allows you to perform node-editing operations (for example, adding and moving nodes) on objects that ordinarily do not allow node editing. For example, MapInfo Pro does not allow you to add nodes to rectangle objects; however, if you convert a rectangle object to a region, you can then add nodes to the region.

To convert objects into region objects:

1. Make the Map window active.
2. Choose the layer containing the objects and make it editable.
3. Select one or more objects from the editable layer.
4. Choose Objects > Convert to Regions.

When you choose Convert to Regions, MapInfo Pro converts each of the selected objects into a region object. Each object is converted into a separate region; MapInfo Pro does not combine all selected objects into one region. To combine objects, use the Combine command.

MapInfo Pro automatically assigns the current region style to each of the region objects. To specify a region style, choose Options > Region Style.

Line, polyline, arc, ellipse, rectangle, and rounded rectangle objects may all be converted to regions. The Convert to Regions command does not affect point objects, text objects and region objects.

5. For more information, see the Creating Regions from Polygonal Areas Enclosed by Polylines topic in the Help System.

Working with Raster and Grid Layers in Layer Control

A raster image is a type of computerized image that consists of row after row of tiny dots (pixels). If you have a scanner and scanner software, you can create a raster image by scanning a paper
map. After you scan a map image and store the image in a file, you can display the file using MapInfo Pro.

In contrast, vector images contain coordinate-based data structures represented by x and y coordinates (most of MapInfo Pro's data is in vector format).

The Help System contains these related topics:

- Displaying a Raster Image
- Registering the Coordinates of a Raster Image
- Working with Raster Images
- Changing the Display of a Raster Image

Converting Grid Files to MapInfo Pro Grids (*.mig)

The Grid Tools (Create MapInfo Grid from Table of Objects and Create MapInfo Grid from Other Grid Files) In MapInfo Pro allow you to convert Grid Files to MapInfo Pro Grids (*.mig). These tools convert any grid file for which there is a grid handler present with the output being in MapInfo Pro (*.mig) format. You can apply relief shading from a user-specifiable virtual light source and control the color inflection values. The color files are simple text files that you can edit to specify the color inflection values by specific value or as a percentage of the range of data values. You can open and display the new grid after the conversion.

- For specific instructions, see Converting Grid Files to MapInfo Pro Grids and Specifying Inflection Values with the MapInfo Pro Grid Converter in the Help System.

Adjusting the Translucency of a Grid Thematic Map

The Translucency slider control in the Modify Thematic Map dialog box allows you to control the percentage that layers show through raster images. A translucent image allows you to partially see through the image. Translucent images can be layered on top of other layers so that the lower layers are partially visible through the image.

Note: The Grid Appearance dialog box allows you to specify color inflection distribution options for grid maps.

- For specific instructions, see Adjusting the Translucency of a Grid Thematic Map in the Help System.

Working with Seamless Layers

Use or create a seamless map layer to treat a group of base tables as if they were one. A seamless layer allows you to change display attributes, apply or change labeling or use the Layer Control window for an entire group of tables at once. You can also retrieve information using the Info tool,
and select or browse any one of the layer's base tables. A base table can be any regular MapInfo Pro table. Grid layers cannot be made seamless.

This feature is especially useful when you want to display a vector or raster backdrop for your maps such as joining street or boundary maps. For example, you may have a seamless layer of county boundaries made up of several individual county tables.

When zooming in on a seamless layer, MapInfo Pro only opens data for displaying the map at the specific zoom level-only those component tables on display open. If you change the zoom level, then MapInfo Pro analyzes which tiles to open and which tiles to close, and does not cache the data. Specific raster handlers open raster images, which are usually slower than vector tables.

Features Available with Seamless Layers

Since a seamless layer is actually made up of several base tables, MapInfo Pro does treat it a little differently than a regular MapInfo Pro table. You can use the following MapInfo Pro features with a seamless map layer:

- **Layer Control** - Use any of the functions except Thematic Mapping from the Layer Control window on your seamless layer. Add, remove, or reorder layers or set display, zoom layering or label options for the seamless layer (all base tables) at one time. However, you cannot make a seamless layer editable.

- **Info Tool** - Retrieve information about a particular object in a base table.

- **Select Tools** - Select objects from the seamless layer. You can only select a group of objects if they reside in the same base table. Press the Shift key while clicking the Select Tool to do so. If you attempt to select several objects that reside in different base tables, MapInfo Pro will only select objects in one base table. If you use the Marquee or Radius select tools and the selected area spreads across two different base tables, MapInfo Pro selects the table in either the center of the circle or polygon.

- **Browse Table** - Display a Browser window of a particular seamless table. You are prompted to select a base table.

**Turning Seamless Layers On and Off**

If you need to edit the structure of your seamless layer, you will need to turn your seamless layer off.

To turn your seamless layer off:

1. Choose Options > Show MapBasic Window. The MapBasic Window displays.
2. Type set table "tablename" seamless off. MapInfo Pro turns off the seamless layer.
3. Display the table in a Browser to view or edit its table structure. If you edit the table structure, you will need to recompile the seamless layer.

MapInfo Pro turns off the seamless layer. Display the table in a Browser to view or edit its table structure. Use the Seamless Table Manager to add or create seamless tables.

To turn the seamless layer on:
1. Choose **Options > Show MapBasic Window**. The MapBasic Window displays.
2. Type set table "tablename" seamless on. MapInfo Pro turns the seamless layer on again.

**Opening a Seamless Map Layer**

MapInfo Pro includes sample seamless maps or you can create your own. Some of these data files are available on the Pitney Bowes Software Inc. web site in the MapInfo Pro Tutorial data. We recommend you download this data for use with these examples.

From the `mapinfo\tutorial\tut-usa\usa\dc\seamless` directory, choose `dcmetrow`. A seamless map layer of water areas in Washington DC displays. Notice at first glance that the seamless layer looks like any other MapInfo Pro table. However, the **Dcmetrow** seamless map layer is made up of the following base tables:

- **VAARLIW.TAB** (Arlington Virginia water areas)
- **VAALEXW.TAB** (Alexandria Virginia water areas)
- **DCWASHW.TAB** (Washington DC water areas)

To display a sample seamless map:

1. On the **File** menu, point to **Open**.
2. From the data directory, choose a seamless layer.

The following is an example of a map layer of water areas in Washington DC.
The structure of each seamless layer includes the path name of each base table plus a description that defaults to the table name (alias). To view the table structure, turn the seamless layer off and display the seamless table in a Browser. Refer to Turning Seamless Layers On and Off.

Characteristics of a Seamless Layer

Since a seamless layer is actually made up of several base tables, MapInfo Pro does treat it a little differently than a regular MapInfo Pro table. You can use the following MapInfo Pro features with a seamless map layer:

• **Layer Control.** Use any of the functions except Thematic Mapping from the Layer Control window on your seamless layer. Add, remove, or reorder layers or set display, zoom layering or label options for the seamless layer (all base tables) at one time. However, you cannot make a seamless layer editable.

• **Info Tool.** Retrieve information about a particular object in a base table.

• **Select Tools.** Select objects from the seamless layer. You can only select a group of objects if they reside in the same base table. Press the **Shift** key while clicking the Select button to do so. If you attempt to select several objects that reside in different base tables, MapInfo Pro will only select objects in one base table. If you use the Marquee or Radius select buttons and the selected area spreads across two different base tables, MapInfo Pro selects the objects in the center of the circle or polygon.

• **Browser Table.** Display a Browser window of a particular seamless table. You will be prompted to select a base table.

• For more information, see Creating/Compiling a Seamless Layer in the Help System.

• For more about Seamless Layers in general, see the MapInfo Pro Help System.

The Help System contains these related topics:

• SExperimenting with a Seamless Layer
• SSpecifying Search Paths for Component Tables of a Seamless Layer
• STurning Seamless Layers On and Off

**Experimenting with a Seamless Layer**

Open a seamless layer, click **Layer Control** to display the **Layer Control** window.
In the Layer Control window, you can add, remove, or reorder seamless layers as if they were conventional MapInfo Pro layers. You can also set Label and Display options for all the tables in the seamless layer as if they were one table. Notice the editable option for a seamless layer is grayed.

Choose your seamless layer and experiment with order, display, and labeling options.

To retrieve information from a seamless layer:

1. From the Main Toolbar, click the Info button.
2. Click the object for which you want information to open the Info Tool window. It contains the information about the object you selected including the name of the base table in which it is stored.

To browse the seamless layer:

1. On the Window menu, click New Browser Window to open the Browse Table dialog box.
2. Select a layer (table) from the list and click OK to open the Select Base Table dialog box.
3. Type the name of the base table you want to browse. We typed XX to indicate an unknown table. A Browser window with the base table you selected displays. If a base table matching your description is not found, a list of possibilities displays.

Keep in mind, base tables are treated like any other MapInfo Pro tables. Once a base table from a seamless table is browsed, it will be opened as any other regular MapInfo Pro table.

4. To select a base table from the list, highlight it and click OK.

Specifying Search Paths for Component Tables of Seamless Layers

You can set search paths to look for the component tables of a seamless layer.

To set the search path for the component tables of a seamless layer:
1. On the **Options** menu, click **Preferences** and click the **Directories** button. The **Directory Preferences** dialog box displays.

2. In the **Search Directories for Tables** group, click **Add**.

3. Specify a drive and directory in the **Choose Directory** dialog box and click **OK**.

   You can set up to four paths. Use the Up and Down keys to change the search order and use the **Add** and **Remove** buttons to add or remove paths from the list.

4. Click **OK** to close the **Preferences** dialog box.

**See Also:**

- Map Layers
- Turning Seamless Layers On and Off
- Using the Tools in the Tool Manager

---

### Working with MapInfo Manager Library Services

The Library Service lets you access the metadata records published in MapInfo Manager. You can access Library Services by selecting **Options > Preferences > Web Services > Library Services**. For enabling the Library Services, refer to [Setting the Library Services Preferences](#).

After setting the Library Services preferences to **Catalogs and Library**, the Table List window shows the status of the tables and if they are managed or not by the MapInfo Manager library.

- If the table list shows 📦 against a particular table, it means the table is managed by the MapInfo Manager.
- If the table list shows 🗑️ against a particular table, it means the table is not managed by the MapInfo Manager.
- If the table list shows no icon against a particular table, it means that the table is not manageable, such as a selection table, query table, or seamless table.

To manage a table you can use the following:

- **Add to Library** 📦 icon on the **Main** toolbar
- **Add to Library** from the **Table** menu.

### Add to Library

To create a metadata record for a table in MapInfo Manager Library:

1. From the **Table** menu, select **Add to Library**.
Note: You can also select the Add to Library icon on the Main toolbar.

2. In the Select Table for Adding to Library dialog box, select the table you want to add to the library. This operation can be performed only if the Catalogs and Library Mode is selected from Library Service Preferences and at least one unmanaged native table is open.

3. In the Select Library Folder dialog box, select the folder where you want to add the selected table.

This dialog displays the folders published by a Library Service in a hierarchical structure. You can select the appropriate checkboxes from the After upload is complete section to get the preferred operations after the table uploads. If the table is added successfully, its metadata window is displayed.

- View Metadata of Managed Table - If this option is enabled, MapInfo Pro displays metadata for the uploaded table. This option will persist across different sessions of MapInfo Pro.
- Open Managed Table - If this option is enabled, MapInfo Pro opens a managed table in a separate mapper window. This option will persist across different sessions of MapInfo Pro.

Saving, Closing, and Exporting Your Work

Preserving your work is an important part of being productive. MapInfo Pro has a wide variety of ways you can save what you are working on, depending upon what needs to be saved and how you need to retrieve it.

Saving a MapInfo Workspace

If you work with the same tables repeatedly, you know that opening each one individually every time you use it can be tedious. With MapInfo Pro’s workspace feature, you can automate this process so you can get back to the business of creating maps and analyzing data sooner.

When you work with MapInfo Pro you generally use many different tables and windows. A Map window, for instance, is likely to be built of several layers. MapInfo Pro uses workspaces to save your work setup from session to session. Workspaces prevent you from having to reassemble all the pieces of your earlier setup from scratch. So, you do not have to reopen tables, re-create maps or layouts, resize windows, or do anything else just to duplicate what was on your desktop the last time you were using MapInfo Pro.

Caution: Saving a workspace will not save edits you have made to tables in the workspace.

If you close a window or table and you have thematic maps, graphs, label settings or label edits, or cosmetic objects pending, MapInfo Pro will prompt you to save the session to a workspace.
• For more information, see Saving a Workspace and Saving a Map Window as a .TAB File in the Help System.
• For instructions on saving a Map window as a .TAB file, see the Help System.

Saving Your Workspace as an XML-Based MWS File

You can save the maps in your workspace out to an XML format for use with MapXtreme (2004 or later) applications. When saving a workspace to MWS format, only the map windows and legends are saved. All other windows are discarded as MapXtreme applications cannot read that information. Once your workspace is saved in this format, it can be opened with the Workspace Manager utility that is included in the MapXtreme installation or with an application developed using MapXtreme. The file is valid XML you can view it using any XML viewer or editor.

You can set the visibility of a modifier theme without regard to its reference feature layer, so you can turn the visibility of the main reference layer off but still display the theme. In MapXtreme, the modifier themes (Dot Density, Ranges, Individual Value) are only drawn if the reference feature layer is visible. To ensure that modifiers marked as visible in MapInfo Pro display in tools like Workspace Manager, we force the visibility of the reference feature layer so that its modifier themes display.

• For specific instructions, see Saving your Workspace as an XML-Based MWS File in the Help System.
• For more information, see Caveats for Saving Label Expressions to MWS and Caveats for Saving Thematic Expressions to MWS in the Help System.

Exporting to GeoTIFF (*.tif) Format

MapInfo Pro includes the capability of exporting Map windows to GeoTIFF (*.tif) export format. GeoTIFF files are designed to connect a raster image to its location on the earth. Georeferencing information is written directly to the *.tif file so that it can be used in other applications. This section explains the requirements for exporting maps to GeoTIFF format. Using GeoTIFF format has the following requirements:

• The window you are exporting is a Map window.
• The Map window’s projection contains an EPSG code. Projections that do not have an EPSG code are not supported.
• The Map window must not be rotated, or contain a raster image that causes a rotation.

GeoTIFF Export Procedure

To export a Map window to a GeoTIFF format file, do the following:

1. Open the desired layers in a Map window, if you do not have your map open already.
2. Make the Map window active.
3. Choose File > Save Window As. The Save Window As dialog box displays on the screen.
4. In the Save in box, select the destination folder of the exported file.
5. In the Save as type drop-down list, click the arrow to see the file format choices. Select GeoTIFF (*.tif).
6. In the **File name** box, enter a name for the exported file.

Click **Save** and continue with the normal Save Window As process.

- For more information about the conditions of GeoTIFF exporting, see *Exporting to GeoTIFF Format* in the Help System.

## Saving a Table or a Copy of a Table

To save changes to map objects or data, you must save the table. (On the **File** menu, click **Save Table**.) A dialog box displays asking you to choose which table you want to save.

You can also save a copy of the table under a new name, using **Save Copy As**. This, in essence, creates a new table. This is helpful in several instances, as when you want to:

- Retain any changes while preserving the original table.
- Save a table with a temporary column (from Update Column).
- Create a new table before you make editing changes to the original table.
- Save spreadsheet files that you wish to modify in MapInfo Pro.
- Save a table in a different projection.

To save a copy of the table:

1. On the **File** menu, click **Save Copy As**. The **Save Copy of Table** dialog box displays.
2. Choose the file to save and click **OK**.
3. Give the file a new name.

The original table remains unchanged and open for all further changes. The new table does not open immediately after its creation, but can be opened for use at any time. When choosing a name for your new table that begins with a number, MapInfo Pro adds an underscore to the beginning of the table name. For instance, your table 1STREETS.TAB will become _1STREETS.TAB.

Saving a copy of a raster table only saves a copy of the *.tab file, not the image. You cannot change the projection of a raster or grid table using **Save Copy As**. To do this go to the **Table** menu, point to **Raster** and click **Modify Image Registration** and click the **Projection** button. Then save the file from there.

Since MapInfo Pro supports long filenames, it is easier to give the new table a name that is descriptive and at the same time distinguishes it from the original file.

The *Help System* contains these related topics:

- **Saving a Copy of your Table as a New Table**
- **Saving a Copy of Your Table in a Different Projection**
- **Tables you Cannot Update**
- **Choosing Ascending vs. Descending Sorts**
- **Column Name Syntax in the Order By Columns Field**
- **Rearranging a Table’s Column Order**
- **Saving Changes Made to a DBMS Table**
• *Saving a Copy of a Table to a DBMS Server*

**Closing a Table**

Closing a table removes it from active use in your current session. Choose the **Close** command from the **File** menu to close tables. When you close a table, you automatically close all views of that table. If you close a table that is displayed in a Map window with other tables, MapInfo Pro removes that table from the window, but the Map window remains open.

In addition, any subset tables of the original table (known as query tables) also close. You can use the Close command for any table, whether or not it is displayed in a window. Opening and closing *tables* is different from opening and closing *windows* in which you view your tables. You can open a table without opening any views of the data. Similarly, closing a window does not close the table (or tables) you are viewing in the window. They are still open and available for use. To close a window, click the **Ctrl**-menu box in the upper-left corner of any window and select **Close**.

If you have made changes to a table but have not yet saved those changes, MapInfo Pro will ask you if you want to save them before closing the table. To save your changes, choose **Save Table** from the **File** menu.

• For more information, see *Closing a Table, Closing All Open Tables, and Closing Multiple Tables* in the *Help System*.

**Opening vs. Importing**

You must open a table before you can use it. The Open command activates a dialog box for opening tables, (opening a table is described below). Choose the appropriate table by double-clicking on it in the dialog box.

Most programs require you to import files created in some other programs. MapInfo Pro allows you to work directly with files created in other programs. When you have a file in one of the following non-MapInfo Pro formats, you do not have to import it:

• dBase DBF
• Delimited ASCII
• Lotus 1-2-3
• Microsoft Access Database
• Microsoft Excel

By not importing data you save time; opening a file is quicker than importing it. You also save disk space. When you import a file, you make a copy of it. Since MapInfo Pro works directly with files from other programs, it does not have to make a copy.

When MapInfo Pro opens a file from some other program, it creates a file with a .TAB extension. This file describes the format of the file that actually contains the data. When you have opened a non-MapInfo Pro file, such as a Lotus file, in a previous session and attempt to open it again, the following prompt appears:
The table definition already exists. Overwrite it?

The table definition referred to is the .TAB file. It does not hurt anything if you continue. MapInfo Pro overwrites the .TAB file and opens the file.

Exporting Your Data to a New Format

You can export your Map window to other file formats with the Save Window As command (on the File menu, click **Save Window As**). This enables you to use your map in another application, such as word processing, presentation, or computer publishing packages.

**Supported Export Formats**

You can save data in a number of formats in MapInfo Pro. Windows .bmp is the initial default. The **Save Window to File** dialog box sets the last-used format as the default. Formats include:

- Windows Bitmap (*.BMP)
- Windows Metafile (*.WMF)
- Windows Enhanced Metafile (*.EMF)
- EMF + Metafile (*.EMF)
- EMF + Dual Metafile (*.EMF)
- JPEG File Interchange Format (*.JPG)
- JPEG 2000 (*.JP2)
- Portable Network Graphics Format (*.PNG)
- Tagged Image File Format (*.TIF)
- TIFF CMYK (*.TIF)
- TIFF CCITT Group 4 (*.TIF)
- TIFF LZW (*.TIF)
- Graphic Interchange Format (*.GIF)
- Photoshop 3.0 (*.PSD)

- See *Understanding the Advanced Exporting Options* in the MapInfo Pro Help System.
- For more information, see *Understanding the Advanced Exporting Options* and *Setting your Output Setting Preferences* in the Help System.

Importing and Exporting Data in AutoCAD Format

Because CAD packages represent drawings in non-earth coordinates, all drawings imported or exported between MapInfo Pro and CAD suffer some distortion. This comes from trying to display non-earth information on a spherical coordinate system (like the globe). Coordinate conversions are used to assign longitude/latitude coordinates to CAD drawings that were created using non-earth coordinates. Conversions near the equator are more exact than conversions at the extremes of the hemispheres. To minimize distortion, import and export with no coordinate conversions and avoid translating maps that cover large areas.
For more information, see *Importing DXF Attributes into MapInfo Pro* and *Importing Attributes with Nested Blocks* in the *Help System*.

**Cropping Images**

When MapInfo Pro exports a window, it does not clip objects that extend beyond the edges of the windows, but it does export information about where the clipping is.

Other programs always honor the clipping of bitmap files. As for other formats, the behavior varies depending on the program that is used to display and print the file. Many programs, such as drawing programs, "explode" the file into individual objects. A file containing several country boundaries would explode into several polygon objects, one for each country. Programs like these usually ignore the clipping information that MapInfo Pro stores in the file.

Other programs, such as word processing programs and spreadsheets, typically open files as one compound object, without trying to explode them into component objects. These programs usually honor the clipping information and clip the contents appropriately.

For example, if you are exporting a Map window that displays part of Germany, but not all of it, the exported file contains the entire image of Germany. It also contains information about where MapInfo Pro clipped that image in its Map window. But when you open the exported window in your target application, a drawing package for example, the image of Germany may not be clipped.

**Exporting to ASCII Format**

MapInfo Pro also allows you to export your tabular data to a delimited ASCII file. This file can later be edited with a text editor or imported into another package. When you export to ASCII, MapInfo Pro displays the *Delimited ASCII Information* dialog box, where you choose your delimiter character. You can also choose to have the first row of the ASCII file become column titles.

MapInfo Pro also displays a dialog box that you use to indicate the character set for the exported ASCII file. Different platforms use different character sets. MapInfo Pro must know the platform where you are going to use the exported file in order to provide the appropriate character set. No graphical data is exported to ASCII.

**Exporting to dBase (*.DBF) Format**

MapInfo Pro can export tabular data into dBASE DBF format. Exporting to DBF creates only the .DBF file. No graphical data is exported to dBASE. When you save your table in DBF format, you create a .DBF file, as well as some other files. These other files contain graphic information (for example, MapInfo Pro indices and other information that MapInfo Pro uses).

MapInfo Pro also displays the *dBASE DBF Information* dialog box that you use to indicate the character set for the exported DBF file. Different platforms use different character sets. MapInfo Pro must know the platform where you are going to use the exported file in order to provide the appropriate character set.
Smoothing Map Images during Export

You can anti-alias a table during the export process to give you more control over your map images. This is particularly important when you are saving maps created in MapInfo Pro for use in other Windows-based applications, in particular in slide presentations or for web pages.

Anti-aliasing allows you to smooth images in all types of windows such as Map windows, layouts, legends, and graphs.

**Note:** You cannot anti-alias images you are exporting to .EMF or .WMF format, because these are not true raster formats.

There are three smoothing options you can use to customize your raster image:

1. *Smooth using a Filter value.* You can set a flag that selects one of six filters that allow you to choose the direction the filter is applied to the image from.

2. *Smooth using a Mask value.* You can select a value that indicates the size of the area you want to smooth. For example, to create a 3x3 pixel mask value, you would enter a 3 in this field. This would limit the amount of change in the color of the pixels. Typically mask sizes would be 2-3 pixels when exporting at screen resolution. If you are exporting at a higher resolution, a larger mask might be appropriate.

3. *Smooth using a Threshold value.* You can select a threshold value to indicate which pixels to smooth. Each pixel in an image has a value based on its color. The smaller the pixel value, the darker the color. Select this option to smooth all of the pixels above the threshold you enter in this field. When you set this value to 0, MapInfo Pro will smooth all of the pixels.

You must either set a global preference for these anti-aliasing options or set them locally during the export process (using the Advanced button).

* For specific instructions, see *Smoothing Map Images during Export* in the Help System.

Using the Tools in the Tool Manager

MapInfo Pro contains many additional tools that simplify mapping tasks, convert MapInfo Pro files to different file formats and vice versa, automate tasks for working with DBMS tables, and more. The Tool Manager helps you run and manage these many utilities easily.

Use the Tool Manager to run, add, edit, or remove tools from the currently registered list of tools in the Tools menu. You can also configure a tool to run automatically upon startup. If you performed a Custom installation, you may have elected to not install the tools. In this case when you open the Tool Manager dialog box, the list box will be empty (on the Tools menu, click Tool Manager).

For a list of available tools and for information about using the tools in MapInfo Pro, see the MapInfo Pro Help System.
Multi-touch

MapInfo Pro supports multi-touch gestures which allows two-finger pinching and panning gestures on a touchscreen device to perform zoom in, zoom out and pan on the map. The multi-touch also works on a 3D map, Prism map and the map in the New Layout Designer window.

When you pinch the touchscreen display or drag your fingers on it, the system detects the gestures and creates the zoom or pan effect on the map.

**Turn multi-touch on or off**

In MapInfo Pro 15.0 the multi-touch support is enabled by default. To turn it off:

1. From the **Options** menu, choose **Preferences**, the **Preferences** window displays.
2. Click **System Settings**, the **System Settings Preferences** dialog box displays.
3. In the **System Settings Preferences** dialog box, deselect the **Enable Multi-touch** checkbox.

**Pan**

1. Open a map on your touchscreen device.
2. Place two fingers on your touchscreen display and drag both fingers together in any direction.

**Zoom In**

1. Open a map on your touchscreen device.
2. Place two fingers on your touchscreen display and spread them apart without lifting them from the screen.

**Zoom Out**

1. Open a map on your touchscreen device.
2. Place two fingers on your touchscreen display and pinch them in together without lifting the fingers from the screen.

**Multi-touch on a 3D or Prism map**

You can move the 3D or Prism map around to determine the most effective angle for displaying your information on a touchscreen device.

**Pan a 3D or Prism map**

1. Open a 3D or Prism map on your touchscreen device.
2. Place two fingers on your touchscreen display and drag both fingers together in any direction.

**Zoom In on a 3D or Prism map**

1. Open a 3D or Prism map on your touchscreen device.
2. Place two fingers on your touchscreen display and spread them apart without lifting them from the screen.

**Zoom Out on a 3D or Prism map**

1. Open a 3D or Prism map on your touchscreen device.
2. Place two fingers on your touchscreen display and pinch them in together without lifting the fingers from the screen.
Preferences allow you to change a number of default settings, enabling you to customize certain aspects of the program's behavior. Preference files are stored on a per-user basis.

In this section

Summary of Preferences 97
Setting Your Preferences 98
Setting Your System Preferences 99
Setting Your Startup Preferences 104
Setting Your Directory Preferences 107
Setting the Web Services Preferences 109
Setting up a Geocoding Server 116
Setting up a Routing Server 119
Setting Your Performance Preferences 120
Setting Your Style Preferences 120
Setting Your Address Matching Preferences 122
Setting Your Image Processing Preferences 123
Setting Your Notification Preferences 124
Setting Your Map Window Preferences 125
Setting Your Layout Window Preferences 131
Setting Your Browser Window Preferences 132
Setting Your Legend Designer Window Preferences 132
Setting Your Printer Preferences 134
Setting Your Output Setting Preferences 137
Summary of Preferences

Here is a brief description of the preference categories.

System

- **System Settings** - Controls what information is copied to the clipboard, color defaults, touch screen settings, paper and layout units, the number of Undo objects permitted, how symbol types used prior to version 4.0 are drawn, and how MapInfo Pro handles 2-digit years.

- **Startup** - Controls whether the program saves the `MAPINFOW.WOR` upon exiting and loads it upon start up; whether queries are saved in workspaces; and the display of the Quick Start dialog box upon startup.

- **Directories** - Specifies default directories for opening and saving tables, workspaces, MapBasic programs, import files, ODBC SQL queries, theme templates, graph support files, saved queries, new grids, and Crystal Report files. Also specifies the directories MapInfo Pro searches for tables without fully qualified paths referenced in workspaces or MapBasic programs.

- **Web Services** - Sets refresh, timeout values, server options and other default settings for Proxy Servers, WMS, WFS, Geocode server, Drivetime server, and Map Tile server web services.

- **Performance** - Sets how much of the operation to perform in parallel using more than one CPU or processor core when processing objects; when buffering an object in a table or selection, and with overlay operations.

- **Styles** - Sets the default object styles for region, line, symbol, and text objects.

- **Address Matching** - Controls the house number placement when specifying street addresses.

- **Image Processing** - Sets the rules for raster reprojection allowing you to choose whether reprojection is allowed, when, and allows you to select resampling options.

- **Notifications** - Sets the frequency of notifications and product updates when a new session of MapInfo Pro is initiated. A notification, typically, is a pop-up that will appear showing links to product updates or information. Clicking a link will redirect you to the hyperlink address on your web browser.

Windows

- **Map Window** - Sets the default Map window options; moving duplicate nodes; snap tolerance; units for distance and area; display of scroll bars in the Map window; display of degrees in either decimal or degrees, minutes, seconds form; and the display of InfoTips.

- **Layout Window** - Sets the Layout window preferences to display Rulers, Page Breaks, and to determine the display options of frame contents.

- **Browser Window** - Select the color to use for the background on alternating rows in the Browser window.

- **Legend Designer Window** - Sets the legend frame default settings as well as swatch size and view preferences.

Output
Setting Your Preferences

To set a preference:

1. On the **Options** menu, point to **Preferences** to open the **Preferences** dialog box.

2. Click one of the buttons to open the dialog box of preferences.

3. Set your preferences and click **OK** to save them and return to the **Preferences** dialog box.

4. Click **OK** to close the **Preferences** dialog box.

What follows in this section are details to assist you in setting your preferences.
Setting Your System Preferences

Use the **System Settings Preferences** dialog box to control the default settings that affect how MapInfo Pro interacts with your system.

To set your system settings preferences:

1. On the **Options** menu, point to **Preferences** and click **System Settings** to open the **System Settings Preferences** dialog box.

2. Select your system preferences for MapInfo Pro.

3. Click **OK** to close the dialogs and save your settings.

**Setting Your Default Units**

You can set the default paper and layout units, distance units, and area units as a software preference.

To set your default units:

1. On the **Options** menu, point to **Preferences**, and then click **System Settings** to open the **System Settings Preferences** dialog box.

2. In the **Units** panel, select from the following drop-down lists:
• **Paper and Layout Units** - Specifies the units when you measure the size of objects in a layout and the size of paper in the **Print** dialog boxes. Choose a unit of measurement from the drop-down list. The default is set to **inches**. You can choose: inches, picas, points, millimeters, and centimeters.

• **Distance Units** - Specifies the default distance units you want to use for all subsequently created maps. Options include: US Survey feet, yards, rods, chains, miles, nautical miles, millimeters, centimeters, meters, and kilometers.

• **Area Units** - Specifies the default area units you want to use for all subsequently created maps. Options include: square inches, square links, square feet, square yards, square rods, perches, square chains, roods, acres, square miles, square nautical miles, square millimeters, square centimeters, square meters, hectares, and square kilometers.

3. Click **OK** to close the dialogs and save your settings.

### Setting Your Undo Options

To set your undo options in MapInfo Pro:

1. On the **Options** menu, point to **Preferences** and click **System Settings** to display the **System Settings Preferences** dialog box.

2. • **Number of Undo Objects** - Enter the number of objects (0 to 800) that can be undone. For example, if you specify the number 50, and then you perform a single editing operation that affects more than 50 objects, you will not be able to undo the operation. The number of undo objects can also affect the performance of MapInfo Pro.

   The default is 10 objects. You can set it from 0 to 800. Setting the number of objects to 0 deactivates the system. After you use the **Undo** option, the system toggles to **Redo**.

   **Note:** You cannot use the **Undo** capability for the following operations: Revert, Save, Save As, or Modify Table, or any operations whose effects are primarily cosmetic.

• **Memory Size for Undo** - Indicates the memory size in bytes for **Undo** operations. Maximum is 10,000,000 bytes. The default is 1,000,000 bytes; increasing this entry may result in slower response time.

   For **Undo** to be available on the **Edit** menu, the selected object(s) must be smaller in size than this setting.

3. Click **OK** to close the dialogs and save your settings.

### Setting Your Color Defaults

When creating a thematic map, you need to distinguish between objects in different thematic layers. When you create a new thematic layer, MapInfo Pro chooses the initial colors and patterns based on this setting. Either a range of solid colors or a range of black and white patterns is used. Changing the color default settings does not affect existing maps or graphs.
1. On the **Options** menu, point to **Preferences** and click **System Settings** to open the **System Settings Preferences** dialog box.

2. In the **Color Defaults** panel, choose one of the following:
   - **Monitor Setting** - Determines if your monitor is color or black and white and then uses either color or gray scale fill patterns. This is the default setting.
   - **Black & White** - Use this setting to view and print your thematic map in gray scale when working on a color monitor.
   - **Color** - Use this setting to work on a black and white monitor but print in color on a color printer.

3. Click **OK** to close the dialogs and save your settings.

### Setting Show Guides when Docking Windows

You can dock windows, such as the **Layer Control** and **Table List**, and some tools, such as **Named Views** and **Catalog Browser**, to the sides (top, bottom, left, and right) of MapInfo Pro. The windows are in a fixed position when they are docked and can share the same space—you may dock multiple windows to the same side of the screen. When the windows are not docked, they are floating and can be moved anywhere in the window.

There are visual guides that look like arrows that display by default to help you when docking a window or a tool. You can drag the window or tool to one of the arrows to dock it at that location. These visual guides display by default. You can show or hide them in MapInfo Pro using a software preference.

To show or hide visual guides when docking a window in MapInfo Pro:

1. On the **Options** menu, point to **Preferences** and click **System Settings** to open the **System Settings Preferences** dialog box.

2. Select the **Show Guides when Docking Windows** check box to display visual guides, in the form of up, down, left, and right arrows, to help you when docking windows in MapInfo Pro. Clearing this checkbox hides these guides.

3. Click **OK** to close the dialogs and save your settings.

### Setting Your Date Window for Two-Digit Years

MapInfo Pro converts two-digit input into four digit years using the current century for the dates (so that 14 becomes 2014). If your data includes dates in the 1900s, then you can turn on date windowing to select a pivot year below which to use the previous century. If you specify the number 50 as the pivot year for your data, then the years entered as 00-49 become 2000-2049 and years entered as 50-99 become 1950-1999.

To turn on date windowing:

1. On the **Options** menu, point to **Preferences** and click **System Settings** to open the **System Settings Preferences** dialog box.
2. Select **Set date window to** and enter a number from 0-99 that will be the pivot year below which to use the previous century.

   The number you enter is shown in the example, which illustrates how the date will display with the prefix 19 or 20. If you enter the number 14, then the example display as:

   **Years entered as 00-13 become 2000-2013**
   **Years entered as 14-99 become 1914-1999**

3. Click **OK** to close the dialogs and save your settings.

   If you select the **Turn date windowing off** option, then MapInfo Pro uses the current century for two-digit dates.

---

### Setting Your Copy to Clipboard Preferences

By default, MapInfo Pro copies text, bitmaps, metafile items, and Map objects to the Clipboard. You can choose which of these objects copy to the Clipboard as a software preference.

To set how you would like to copy objects to the Clipboard:

1. On the **Options** menu, point to **Preferences** and click **System Settings** to open the **System Settings Preferences** dialog box.
2. Select the check boxes for those objects you want to copy to the Clipboard, or clear check boxes for those objects that you do not.
   - **Copy Text to Clipboard** - Check to specify that you want text copied to the Clipboard.
   - **Copy Bitmap to Clipboard** - Check to specify that you want Bitmaps copied to the Clipboard.
   - **Copy Windows Metafile (WMF) to Clipboard** - Check to specify that you want metafiles copied to the Clipboard.
   - **Copy MapInfo Map Object to Clipboard** - Check to specify that you want map objects copied to the Clipboard.
3. Click **OK** to close the dialogs and save your settings.

---

### Setting Your Clipboard to Copy Maps in to Word, Excel, or PowerPoint

To copy a map to the Clipboard and then past it in to a Microsoft Office document, such as Word, Excel or PowerPoint, you must first customize the Clipboard behavior so that only specific types of metafiles copy to the Clipboard.

1. On the **Options** menu, point to **Preferences** and click **System Settings** to open the **System Settings Preferences** dialog box.
2. In the **Copy to Clipboard** group, check the **Copy Enhanced Metafile (EMF) to Clipboard** check box.
3. Choose one of the following:
• **Copy EMF to Clipboard** - Choose this if you expect to bring your maps into an application that supports only EMF, such as Microsoft's Office 2003.

• **Copy EMF+ to Clipboard** - Choose this if you expect to bring your maps into an application that supports EMF+, such as Microsoft Office 2007 or 2010.

• **Copy EMF+ Dual to Clipboard** - Choose this (a combination of EMF and EMF+) to use your maps in applications that may or may not support EMF+, such as when you have Microsoft's Office 2003 and Office 2007 on the same machine.

  **Note:** EMF+Dual format will produce a larger file than EMF+. But it provides better compatibility with older application that do not support EMF+.

4. Click **OK** to close the dialogs and save your settings.

### Setting Your Image Resolution for Exporting

You can control the resolution of a window when exporting it using a software preference. MapInfo Pro uses this preference whenever you copy windows to the Clipboard, export your work to metafile and raster formats, and use the **Save Window As** export process. If you do not set this resolution manually, the product assumes 96 dpi. The maximum setting for this field is 1200 dpi.

To set your image resolution preference:

1. On the **Options** menu, point to **Preferences** and click **System Settings** to open the **System Settings Preferences** dialog box.

2. In the **Window Export and Clipboard Resolution** box, type a new dpi value between 96 and 1200. The default is 96 dpi, which is the screen resolution.

3. Click **OK** to close the dialogs and save your settings.

### Setting how to Draw Symbols for MapInfo Pro 4.0 or Earlier

You can indicate how you want to draw symbols from early versions of MapInfo Pro (before 4.0). By default, MapInfo Pro draws these vector symbols using the True Type font. You can change the default to use characters from the MapInfo Symbols font.

To draw vector symbols with characters from the MapInfo Symbols font:

1. On the **Options** menu, point to **Preferences** and click **System Settings** to open the **System Settings Preferences** dialog box.

2. Select the **Display Pre-Version 4 Symbols using the True Type font** check box.

  Check this to draw vector symbols with characters from the MapInfo Symbols font. Clear this check box to draw vector symbols (default).

3. Click **OK** to close the dialogs and save your settings.
Setting Your Vertical Mapper Grid File Display Preferences

To set the display preferences for Vertical Mapper grid files:

1. On the Options menu, point to Preferences and click System Settings to display the System Settings Preferences dialog box.

2. Select the Display Vertical Mapper grd files as option to determine how to display Vertical Mapper GRD files within MapInfo Pro. These options allow you to display your Vertical Mapper GRD maps as grid files and not as raster files. Vertical Mapper creates GRD\TAB files that display using the raster handler. This preference contains a Grid option, so that Vertical Mapper grid files use the Info tool and displays file information in 3D windows.
   - **Grids** - Select this option to display your Vertical Mapper GRD files as grid files when you open them. Get the added support of the MapInfo Pro toolbar features
   - **Raster** - Select this option to treat your Vertical Mapper GRD files as raster layers when you open them.
   - **Default** - Select this option to treat your Vertical Mapper GRD files as Raster or Grid files depending on the existence of the Rasterstyle 6 1 code in the TAB file: if the code does not exist then the file opens as a raster file, if the code does exist then the file opens as a grid file.

3. Click OK to close the dialogs and save your settings.

Setting Your Startup Preferences

You can set preferences for how MapInfo Pro behaves when you start the software for:

- Showing or hiding the Quick Start dialog box.
- Using a default DBMS connection.
- Your MAPINFOW.WOR workspace properties such as whether printer information and queries are saved to workspaces.

To set default DBMS Connections, see Setting up your Database Connection Preferences in the Help System.

To set your startup preferences for MapInfo Pro:

1. On the Options menu, point to Preferences and click Startup to open the Startup Preferences dialog box.

2. Select from the following preferences:
   - **Save MAPINFOW.WOR when Exiting MapInfo** - Select this check box to save your setup to the MAPINFOW.WOR workspace when you exit MapInfo Pro. When you clear this check box, MapInfo Pro does not save the MAPINFOW.WOR unless you save it explicitly.
• **Load MAPINFO.WOR when Starting MapInfo** - Select this check box to display MAPINFO.WOR when you enter MapInfo Pro.

  **Note:** To enable this check box, you must clear the **Display Quick Start Dialog** check box.

• **Save Queries in Workspaces** - Select this check box to save the queries you create during a mapping session in the workspace. If you do not select this check box and the selected map has only one layer based on a query, the query is not saved and the application writes a map definition with an empty layer list. MapInfo Pro cannot support subselects in queries.

  **Note:** The operators **Any** and **All** are not supported in the MapXtreme 2004 or later versions of MapInfo SQL and, therefore, subselects are not supported either. MapInfo Pro cannot map selections with **Group By**, so **Group By** clauses are ignored. MapInfo Pro only translates the **Order By** clause.

• **Save Printer Information into Workspaces** - Select this check box to save the printer name, paper orientation, paper size, and the number of copies from your printer settings into the workspace. This also includes any overrides you might have made to the default printer settings in the Printer preferences. We recommend that you leave this preference on.

  **Note:** If this preference is turned off, or if the printer indicated is not available, the printer settings for the workspace revert back to the default printer set in the Printer preferences.

• **Restore Printer Information to Workspaces** - Select this check box to restore the printer name, paper orientation, paper size, and the number of copies when you open the workspace. This is useful if you are sharing workspaces with other MapInfo Pro users who are also using the same printers.

  **Note:** If this preference is turned off, or if the printer indicated is not available, the printer settings for the workspace revert back to the default printer set in the Printer preferences.

• **Default DBMS Connection** - Select this check box to set a DBMS connection that will open each time you begin a MapInfo Pro session. Click **Set** to select the connection.

• **Display Quick Start Dialog** - Select this check box to display the **Quick Start** dialog box automatically when you start MapInfo Pro. This check box is selected by default. Clear the **Display Quick Start Dialog** check box to prevent it from displaying when you start subsequent MapInfo sessions.

3. Click **OK** to close the dialogs and save your settings.

### Creating a Startup Workspace

**STARTUP.WOR** is the name you give to a workspace from which MapInfo Pro is run. You can create it so that MapInfo Pro automatically opens various tables and windows on startup. When you use **STARTUP.WOR**, MapInfo Pro performs the startup actions regardless of what you did in your previous MapInfo Pro session or how you have set preferences for **MAPINFO.WOR**.

To create a workspace:

1. Open the tables and windows you want in your workspace. Size and position them as you please.
2. On the **File** menu, point to **Save Workspace**.
3. Name your workspace "Startup" and save the workspace into your "home" directory. By "home" directory we mean your private Windows directory.

When you run MapInfo Pro, the following occurs in the order shown:

1. If there is a STARTUP.WOR in the MapInfo Pro program directory, it is run.
2. Then, if there is a STARTUP.WOR in your home directory it is run. (When there is a STARTUP.WOR in both the MapInfo Pro program directory and your home directory, both will run.)
3. Then, if any file names are given on the command line-or if you double-click a document, MapInfo Pro loads those files. MapInfo Pro support adding workspaces (.WOR), running applications (.APP), and opening databases (.TAB) on the command line.
4. Only if MapInfo Pro did not add a workspace or run a program from the command line does it then check the AutoLoad preference and load MAPINFOW.WOR from the user's home directory. When the preference is set, and the file is found, it is loaded. Note that if we had a workspace or application on the command line, we skip the AutoLoad.
5. Finally, if MapInfo Pro did not load a workspace or run an application from the command line, and it did not AutoLoad MAPINFOW.WOR, then MapInfo Pro shows the Tool palette.

Setting Your Database Connection Preferences

If you have a favorite database connection setting, we have established a startup preference setting to create that connection automatically at the beginning of your session.

To set your database connection startup preference:

1. In the Options menu, click Preferences and then Startup to open the Startup Preferences dialog box.
2. Click Set to open the Select DBMS Connection list.
3. Select an existing entry in the list. Click OK to accept the preference.

To establish a new database connection. Click New and select the connection type you want to search for.

- If you select ODBC, the Select Data Source dialog box displays and you can search for the database from this dialog box. Select the database connection and click OK to return to the Startup Preferences dialog box.
- If you select Oracle Spatial, the MapInfo Oracle Connect dialog box displays and you must enter the user name, password, and server name of the database you are adding. Click OK to save your entries and return to the Startup Preferences dialog box.

After selecting a DBMS connection, it displays in the Default DBMS Connection field and is set to connect each time you open MapInfo Pro.

4. Click OK to close the dialogs and save your settings.

You can also make a DBMS connection from any of these three dialog boxes: Open, Create New Table, and Save Copy As.

Note: For database versions that MapInfo Pro supports, see the MapInfo Pro Install Guide.
Setting Your Directory Preferences

You can specify the default directories in which MapInfo Pro looks for files as a software preference. You can specify directories for:

- Tables
- Remote tables
- Workspaces
- MapBasic programs
- Import files
- DBMS SQL queries
- Theme templates
- Saved queries
- New grids
- Crystal Report files
- Graph support files
- Shapefile tables

The default directories that you set display in the File menu dialog boxes when you open or save files. This includes the four locations that are part of the Open dialog box. When you open a file, you can select an icon from the MapInfo Places Bar for what you set, such as a Workspace Directory icon to display the workspace directory that you set as a preference.

To set your directory preferences:

1. On the Options menu, point to Preferences and click Directories to open the Directory Preferences dialog box.
2. In the **Initial Directories for File Dialogs** list, select a preference and then click **Modify**. The **Choose Directory** dialog box opens.

3. Enter a new directory location and click **OK**.

4. Repeat this process until you have set all of the preferences that you need to.

5. If you are accessing your application data files and other configuration files (Mapinfo.prj, templates, and custom symbols) remotely, select the **Use when searching for application data files** check box and enter the path to the remote location in the field below. This field is usually pre-filled for you.

6. Click **OK** to close the dialogs and save your settings.

You can use this preference to search for raster and grid tables. If you open a *.tab file for a raster or grid image and the image file cannot be found an attempt is made to find the image in the same location as the .TAB. If the image file is not found, it will then use the search directories.
Using Search Directories

Use the Search Directories for Tables and Workspaces to specify search paths that MapInfo will use to look for tables referenced in workspaces or MapBasic programs that do not have fully qualified paths.

To search directories for tables and workspaces:

1. On the Options menu, point to Preferences and click Directories to open the Directory Preferences dialog box.
2. To specify a search path, in the Search Directories for Tables group, click Add.
3. Specify a drive and directory in the Choose Directory dialog box and click OK.
   
   You can set up to four paths. Use the Up and Down keys to change the search order.

   Use the Add and Remove buttons to add or remove paths from the list.

4. Click OK to close the dialogs and save your settings.

For more information see Choosing the Directories in the Place Bar in the Help System.

Setting the Web Services Preferences

The Web Services Preferences dialog box provides access to settings for the Web Feature Service and Web Map Service timeout values, GetMap pixel limits, and Proxy Server settings in MapInfo Pro. Additionally, you can set geocoding server and routing server options. These options allow you to control the web services preferences.

Note: You can set per-server defaults based on particular WFS and WMS servers in the Override Timeout Values section of the Server Information dialog box.

To access the Web Services Preferences dialog box:

1. On the Options menu, point to Preferences and click Web Services to open the Web Services Preferences dialog box.
2. Select the tab you want to set the options for and change the default settings.
3. Click OK to close the dialogs and save your settings.

Setting the Proxy Server Preferences

To set your proxy server preferences:

1. On the Options menu, point to Preferences and click Web Services to open the Web Services Preferences dialog box.
2. On the Proxy tab, set your preferences for the server:
• **Use System Settings** - Click to use the LAN settings in the system registry. This is the default preference.

You can review the current LAN settings in the Control Panel. On the Start menu, point to Control Panel and type Internet Options in the Search box. In the search results, click Internet Options. On the Connections tab, click LAN Settings.

• **Use Direct Connection** - Click to override the system LAN settings and try to connect directly to the Internet (not through a proxy server).

• **Use Proxy Server** - Click to set and use the proxy server settings to connect to the Internet. Ask your system administrator for the settings to use.

If you use a proxy server to connect to the Internet, the proxy server may require authentication in the form of a user name and password. Your system administrator should tell you what these are. If a user name and password are required, you are prompted for them via a dialog when MapInfo Pro attempts to connect to the Internet, such as when drawing a tile server layer. Within a session you only need to specify the username and password once.

• **Settings** - Click to set the proxy server options. See Setting the Custom Proxy Server Preferences for instructions on completing these settings.

3. Click **OK** to close the dialogs and save your settings.

### Setting the WFS Server Preferences

MapInfo Pro has software preferences that let you:

• Use a WFS Refresh option to retrieve updated GML information from the web feature service pertaining to the current layers.

• Set the default WFS timeout values (in seconds) for the WFS servers you use. You can set per-server defaults based on particular WFS servers in the Override Timeout Values section of the WFS Services Preferences dialog box.

• Add, edit, and delete WFS servers.

To set your WFS Server preferences:

1. On the Options menu, point to Preferences and click Web Services to open the Web Services Preferences dialog box.

2. On the WFS tab, set your WFS refresh, timeout, and server options.

• **Update Mapper Filters with Current Mapper** - Select this check box to use the current filter settings to refresh the Map window. If you select this check box and the table has already been refreshed, the current bounds of the front-most map window are used. If the check box is cleared and the table is refreshed, the bounds of the map window (at the initial WFS request) are used.

**Note:** The original map bounds are used, regardless of the current map window bounds.
• **Connect Timeout** - Use this setting to indicate the amount of time to establish an Internet connection to the service. If the request takes longer than this value, a timeout occurs. The default connect time out is 60 seconds.

• **Send Timeout** - Use this setting to indicate the amount of time to send an Internet request to the service. If the request takes longer than this value, a timeout occurs. The default send time out is 60 seconds.

• **Receive Timeout** - Use this setting to indicate the amount of time begin to receive a response from a request to the service. The download can take longer than the time out, but the response has to occur within the timeout setting. The default receive time out is 300 seconds.

• Click the **Servers** button to display the **WFS Servers List** dialog box, where you can add, edit, and delete WFS servers.

3. Click **OK** to close the dialogs and save your settings.

### Setting the WMS Server Preferences

MapInfo Pro has software preferences that let you:

• Set the default WMS timeout values (in seconds) for the WMS servers you use.

• Set the maximum number of pixels (in width/height) that a map request is limited to.

You can set default values for a specific WMS server in the **Override Timeout Values** and **GetMap Pixel Limits** sections of the **WMS Server Information** dialog box.

To set your WMS Server preferences:

1. On the **Options** menu, point to **Preferences** and click **Web Services** to open the **Web Services Preferences** dialog box.

2. On the **WMS** tab, set your WMS timeout values:

   • **Connect Timeout** - Use this setting to indicate the amount of time to establish an Internet connection to the service. If the request takes longer than this value, a timeout occurs. The default connect time out is 60 seconds.

   • **Send Timeout** - Use this setting to indicate the amount of time to send an Internet request to the service. If the request takes longer than this value, a timeout occurs. The default send time out is 60 seconds.

   • **Receive Timeout** - Use this setting to indicate the amount of time begin to receive a response from a request to the service. The download can take longer than the time out, but the response has to occur within the timeout setting. The default receive time out is 300 seconds.

3. Set your GetMap pixel limits:

   • **Max Width** - Max Width specifies the maximum number of pixels for a GetMap request in the X direction.

   • **Max Height** - Max Height specifies the maximum number of pixels for a GetMap request in the Y direction.
The GetMap request is designed to retrieve the highest resolution map image as is necessary to render the image on the screen, for a printer, or for an export file. This option prevents the request from going higher than the specified values. Different servers have different limits, so you can set the limit that works best for your environment.

**Note:** You can also use this option to shorten the WMS map retrieval time, but remember that the resulting image will display at a lower resolution.

4. Click **Servers** to open the **WMS Servers List** dialog box, where you can add, edit, and delete WMS servers.

5. Click **OK** to close the dialogs and save your settings.

Unfortunately, servers do not report their limits to us, so if the GetMap request fails, it means that you have entered a value that is too large. There are large GetMap requests when you are printing or exporting windows containing WMS images. This happens because printing and exporting occurs at larger sizes and/or higher resolutions than on-screen display requires.

### Setting the Geocoding Server Preferences

You can get more information about setting up a geocoding server in *Setting up a Geocoding Server*. A table must be open to enable the Geocode using Server menu item.

To set the geocoding server preferences:

1. On the **Options** menu, point to **Preferences** and click **Web Services** to open the **Web Services Preferences** dialog box.

2. Click the **Geocode** tab to display the Geocoding server options.

   This tab sets the geocoding server timeout and maintenance options.

3. Set any of the following preferences for your server:

   - **Offset From Road** - Use this field to indicate the default distance the geocoded point should be from the road, if applicable.
   - **Offset From Corner** - Use this field to indicate the default distance the geocoded point should be from the corner, if applicable.
   - **Units** - Use this field to indicate the units for the previous entries.
   - **Dictionary** - Use this drop-down list to choose the dictionary option that you want the geocoder to use (Address or User). These libraries exist on the service. Not all dictionary types may exist on all services. There are a maximum of five (5) options:
     - **Select All Dictionaries** - Select this option to use both the user and address dictionaries.
     - **Address Dictionary Only** - Select this option to use only the service's address dictionary and not the user's dictionary.
     - **User Dictionary Only** - Select this option to use only the user's address dictionary and not the service's address dictionary.
     - **Prefer Address over User** - Select this option to use the service's address dictionary before the user's address dictionary. This option is the default.
• **Prefer User over Address** - Select this option to use the user's address dictionary before the service’s address dictionary.

• **Number of Addresses to Batch** - Use this option to specify how many addresses you want to send to the geocoding service at a time. The number of addresses you send at a time can affect performance.

• **Default Timeout Values** - Use these timeout values to set the communication parameters for the geocoding service. You can override these defaults on a per-service basis locally by editing the service in the Services list and specifying the override.

  **Note:** When you set the timeout values locally, you may want to keep in mind the size of your request. The more complicated your request, the more time may be required for connection/sending/receiving.

• **Connect Timeout** - Use this setting to indicate the amount of time to establish an Internet connection to the service. If the request takes longer than this value, a timeout occurs. The default connect time out is 60 seconds.

• **Send Timeout** - Use this setting to indicate the amount of time to send an Internet request to the service. If the request takes longer than this value, a timeout occurs. The default send time out is 60 seconds.

• **Receive Timeout** - Use this setting to indicate the amount of time to begin to receive a response from a request to the service. The download can take longer than the time out, but the response has to occur within the timeout setting. The default receive time out is 300 seconds.

• **Mark Multiple Match when Automatic Geocoding** - Select this option to display a result code of M when you are performing automatic geocoding and there are multiple matches for an address. If you do not select this option, and there are close matches, the system displays an S for street only. See *Understanding the Geocoding Result Codes* in the *Help System*.

• **Symbol Style** - Use this setting to set the default symbol style for the points you are creating for geocoding. You can override it during a geocoding operation using **Symbol Style** in the **Common Options** tab.

• **Servers** - Click **Servers** to display the **Geocoding Servers List**, where you can add, edit, and delete MapMarker and Envinsa geocoding servers. This list is the same as you would see when you select the **Servers** button in the **Geocode Using Servers** and the **Find Address** dialog box.

4. Click **OK** to close the dialogs and save your settings.

**Setting the Routing Server Preferences**

This section describes how to set the Routing Server preferences, which sets the driving region server maintenance options.

For instructions on how to set up MapInfo Pro to work with a routing server, see **Setting up a Routing Server**

To set the routing server preferences:
1. On the **Options** menu, point to **Preferences** and click **Web Services** to open the **System Settings Preferences** dialog box.

2. On the **Routing** tab, click **Servers** to open the **Routing Servers List** dialog box.

3. Add, edit, and remove Envinsa Drivetime servers.

   Set the server that you will use the most as your default, by highlighting it in the list and clicking **Set Default**. A check mark displays beside the server to indicate it will open by default.

4. Click **OK** to close the dialogs and save your settings.

### Setting the Tile Server Preferences

You can configure MapInfo Pro default preferences for the time-outs that are used when requesting tiles from a tile server.

To set up your time-out preferences for when requesting tiles:

1. On the **Options** menu, point to **Preferences** and click **Web Services** to open the **Web Services Preferences** dialog box.

2. On the **Tile Server** tab, set the following:

   - **Read Timeout** - Set the default value for attempting to read a specific tile from a tile server. The value should be between 1 and 3600 seconds.
   - **Request Timeout** - Set the default value for attempting to request a specific tile from a tile server. The value should be between 1 and 3600 seconds.

3. Click **OK** to close the dialogs and save your settings.

### Setting the Library Services Preferences

To set your preferences for working with Library Services:

1. On the **Options** menu, point to **Preferences** and click **Printer** to open the **Web Services Preferences** dialog box.

2. Click the **Library Services** tab.

3. Click **Server**.

4. In the **Library Service Preferences** dialog box, set a new Server URL (and timeout values) to work with, or change the timeout values for the server that you are currently working with.

   - **Server URL** - The internet address for a Library Service server. Enter a valid library service URL and click **Test URL** to validate the URL. MapInfo Pro becomes Library aware, accesses the list of Catalogs the user can view, and populates their list automatically through MapInfo Manager. Supports any MapInfo Manager Library Service URL that requires authentication
   - **Server Status** - This displays the availability of the Server and shows Available, Not Available, or Unknown.
   - **Authentication Timeout** - Use this setting to indicate the amount of time to establish and authenticate the connection with the Library Service. If the request takes longer than this value,
a timeout occurs. The default authentication timeout is 30 seconds. The value should be between 1 and 3600 seconds.

- **Get Capabilities Timeout** - Use this setting to indicate the amount of time to send a request to the Library Service. If the request takes longer than this value, a timeout occurs. The default Get Capabilities timeout is 60 seconds. The value should be between 1 and 3600 seconds.

- **Request Timeout** - Set the default value for attempting to request a specific result from the Library Service. The value should be between 1 and 3600 seconds.

Click **OK** to apply your settings.

5. In the **Web Services Preferences** dialog box, choose one of the following:

   - **Catalogs** - Automatically populates the **Catalog Browser** with MapInfo Manager Catalogs. (For MapInfo Pro users who do not use MapInfo Manager.)
   
   - **Catalogs and Library** - Finds catalogs and allows you to work with MapInfo Manager Library directly from MapInfo Pro. (For MapInfo Pro users who also use MapInfo Manager.)

6. Click **OK** to close the dialogs and save your settings.

If your Library Service mode is set to anything other than Disabled, then the **Catalog Servers** dialog box opens the catalog URLs exposed by the MapInfo Manager.

![Catalog Servers Dialog Box](image)

These catalog URLs cannot be edited or deleted. Clicking **View** in the **Catalog Servers** dialog box opens the **Catalog Server Definition** dialog box. You cannot make edits in this dialog box.

**MapInfo Manager Authentication Handling within MapInfo Pro**

For setting up security and expected MapInfo Manager behavior, consult with your MapInfo Manager administrator and refer to the MapInfo Manager version 1.2 documentation at:

### Setting the Custom Proxy Server Preferences

You can configure MapInfo Pro for proxy server use. By default, MapInfo Pro uses your system LAN settings as the default proxy server settings. To set the Web Services Preferences to use a different proxy server, you must know the IP address and port number of the alternate proxy server to properly complete these entries.

To set up your web service preferences to use a different proxy server than those provided in your system LAN settings:

1. On the **Options** menu, point to **Preferences** and click **Web Services** to open the **Web Services Preferences** dialog box.
2. On the **Proxy** tab, choose **Use Proxy Server** and click **Settings**.

   The **Web Services Proxy Settings** dialog box opens. Use these options to configure the proxy server for your internet and intranet use.

3. Enter the IP address of your computer and the port number in the fields provided. If you do not know this information, check the IP Config settings or consult your system administrator.
4. To access local addresses without going through the proxy server, select the **Bypass proxy server for local addresses** check box.
5. To exclude some non-local IP addresses from the proxy server, enter the IP addresses in the text area provided, using a semicolon to separate the addresses.
6. Click **OK** to close the dialogs and save your settings.

As a result of these settings, you are prompted for a user name and password when you are attempting to access the Internet to use the Web Map Service or the Web Feature Service features.

### Setting up a Geocoding Server

To use MapInfo Pro with a geocoding server, you need MapMarker Java Server 4.0 or later or Envinsa Server 4.0 or later. MapInfo Pro supports any geography that is supported by Envinsa currently. Envinsa supports MapMarker Java Server version 2, 3, and 4. Keep in mind that any Envinsa server only supports the data that is installed.

Before you can access a MapMarker or Envinsa geocoding service, you need to connect MapInfo Pro to its server. This process gives MapInfo Pro all the information it needs to access the geocoding service. You need to enter this information only once per service.

To set up a geocoding server:

1. On the **Table** menu, point to **Geocode Using Server** to open the **Geocode using Server** dialog box.
After you add geocoding servers to MapInfo Pro, this dialog box shows your default server.

2. Click **Servers** to open the **Geocoding Servers List** dialog box.

3. Click **Add** to open the **Geocoding Server Information** dialog box to add a new server.

*Note:* Set the server that you will use the most as your default, by highlighting it in the list and clicking **Set Default**. A check mark displays beside the server to indicate it will open by default.
4. Type the service URL and description in the fields provided. You can connect to either a MapMarker or Envinsa geocoding service by making a selection in the Type of Service drop-down list.

When you select an Envinsa service, enter a user ID and password in the fields provided. Select the Remember Password check box to save the password in encrypted format in the server list. This option is selected by default. If you prefer to enter the password each time you access this server, clear this check box.

Caution: Anyone knowing this password will be able to use the Envinsa geocoding service.

5. Consider whether the default timeout values are appropriate for the service you are adding. The default values that display in each field are set in the geocoding web services preferences. You can change these global defaults using the instructions in Setting the Geocoding Server Preferences.

To reset these entries for the current server, select the Override Default Values check box and enter new timeout values using these definitions:

- **Connect Timeout** - Use this setting to indicate the amount of time to establish an Internet connection to the service. If the request takes longer than this value, a timeout occurs. The default connect time out is 60 seconds.
- **Send Timeout** - Use this setting to indicate the amount of time to send an Internet request to the service. If the request takes longer than this value, a timeout occurs. The default send time out is 60 seconds.
- **Receive Timeout** - Use this setting to indicate the amount of time begin to receive a response from a request to the service. The download can take longer than the time out, but the response has to occur within the timeout setting. The default receive time out is 300 seconds.

6. When you have completed these entries, click Test URL to ensure that the connection is made. When you click Test URL and MapInfo Pro can connect to the service, the Geocoding Server Details dialog box opens.

If the URL is valid, the Engine Info list displays the service’s available, country data, the supported geocoding types (Street, Postcode, Geographic), and the version information.
Click the column headings to sort the entries alphabetically. Click Close to return to the Geocoding Server Information dialog box.

**Note:** If you select Test URL and no service connection is found, an error message displays.

7. Click OK to save the new geocoding server.

### Setting up a Routing Server

Before you can access an Envinsa Drivetime service, you need to show MapInfo Pro where to find the Routing server it is housed on. This process gives MapInfo Pro all the information it needs to access the server. You need to enter this information only once per server. To set the routing server preferences, see [Setting the Routing Server Preferences](#).

To add a Routing server:

1. On the **Options** menu, point to **Preferences** and click **Web Services** to open the Web Services Preferences dialog box.
2. On the **Routing** tab, click **Servers** to open the Routing Servers List dialog box.
3. Click **Add** to open the Routing Server Information dialog box.
4. Type the server URL, the server description, the default user name and password in the fields provided.
   
   Select the **Remember Password** check box to remember the password when you enter the correct user name.

5. Review the default timeout values for the server you are adding. To change these entries, select the **Override Default Values** check box and enter new timeout values.
6. Click **Test URL** to ensure that the connection is available. The Routing Server Details dialog box opens.
   
   If the URL is valid, the **Countries** list displays the server's available country data. Click **Close** to return to the Routing Server Information dialog box.
   
   **Note:** If you select Test URL and no server connection is found, an error message displays.

7. Click **OK** to return to the Routing Servers List dialog box
   
   Set the server that you will use the most as your default, by highlighting it in the list and clicking **Set Default**. A check mark displays beside the server to indicate it will open by default.

8. Click **OK** to close the dialogs and save your settings.

MapInfo Pro supports server-side and proxy server authentication. If you use a proxy server for Internet access and your routing server also requires user/password authentication, you authenticate
with the proxy server first. As a result, the **Connection** dialog box displays twice—once for the proxy server and once for the routing server.

### Setting Your Performance Preferences

MapInfo Pro runs some operations in parallel, using more than one CPU or processor core at the same time. This improves the processing time when buffering an object in a table or selection, and with overlay operations (such as **Split**, **Erase**, **Erase Outside**, **Polyline Split**, and **Overlay Nodes**). You can turn this off, or specify that a percentage of the processors on your system run concurrent operations.

By default, MapInfo Pro has full concurrency turned on, but you can select the level of concurrency as a software preference:

- **None** – a single processor performs the operation. This option provides the least amount of processing speed.
- **Moderate** – 25% of the processors on your system perform the operation.
- **Intermediate** – 50% of the processors on your system perform the operation.
- **Aggressive** – 75% of the processors on your system perform the operation.
- **Full** – all processors on your system perform the operation. This is the default setting MapInfo Pro installs with.

To change the default concurrency setting:

1. On the **Options** menu, point to **Preferences** and click **Performance** to open the **Performance Settings** dialog box.
2. Select a concurrency setting from the **Concurrency Level** list.
3. Click **OK** to close the dialogs and save your settings.

When concurrency is set, MapInfo Pro divides the processing to multiple cores that simultaneously perform the operation.

### Setting Your Style Preferences

The Style preferences allow you to preset the look of your objects regions, text, and lines.

To set the default style preferences:

1. In the **Options** menu, click **Preferences** and then **Styles** to open the **Styles Preferences** dialog box.
When you set the text styles you are also setting the label styles.

2. set your preferences style preferences for:

- Default Object Styles
  Click the Region, Symbol, Line, and Text buttons to set these style options. These selections will serve to create the default settings for these style elements.

- Enhanced Rendering Defaults for New Windows
  Click this check box to apply anti-aliasing and object translucency options.

  **Smooth Text & Labels** - Use this drop-down list to select Anti-Aliasing to smooth your labels and text.
**Smooth Images** - Use this drop-down list to select High Quality, Low Quality, or None for smoothing all images.

**Smooth Lines & Borders** - Use this drop-down list to select Anti-Aliasing to smooth your lines and borders.

- **Highlight Control**
  Click this button to specify the Line, Region, and Multipoint styles of selected and target objects, as well as highlighting specifications in the Map window. Additionally, specify the style of selected and target multipoint objects. The default settings are shown in the Style boxes of the Highlight Control group. Click one of the boxes to display the corresponding style dialog box and change its settings.

**Translucency** - Use this slider to set the translucency for your objects.

- **Default Find Style**
  **Symbol** - Click this button to set the default symbol style for tasks when selecting Find on the Query menu. In the Symbol Style dialog box, select the new symbol style and click OK to save them.

- **Show reference grid for style pickers** - Click this check box to display reference grids on the style picker dialog boxes. This option allows you to refer to a particular style based on the intersection of the column letters and row numbers. Clear this check box to stop the reference grids from displaying.

3. Click OK to close the dialogs and save your settings.

For more information, see *Changing the Find Symbol Style Locally* and *Inserting Styles into Tables* in the Help System.

---

### Setting Your Address Matching Preferences

Use the Address Matching preferences to specify the placement of the house number in addresses. The default setting is for house numbers to come before the street name.

To set your address matching preferences:

1. On the **Options** menu, point to **Preferences** and click **Address Matching** to open the **Address Matching Preferences** dialog box.
2. Click OK to save this preference and return to the Preferences dialog box.
3. Click OK to close the Preferences dialog box.
Setting Your Image Processing Preferences

You can control the reprojection options of your vector and raster maps using the Image Processing Preference. Reprojection, particularly when reprojecting seamless tables or other large raster map layers, can take a long time. This is particularly true if your reprojection is dramatic, as when you are transforming world-wide rasters from Long/Lat to Mercator, for example.

To see the results of this setting, refer to Reprojecting a Raster based on a Vector Map in the Help System.

To set the raster reprojection options for all registered raster files:

1. On the Options menu, point to Preferences and click Image Processing to open the Image Processing dialog box.
   
   You can also open the Image Processing dialog box by clicking Image Processing in the Map Options dialog box.

2. Choose a reprojection:
   
   - **Never** - Prevents raster reprojection. This is the default setting which preserves the pre-version 8.5 MapInfo Pro behavior.
   
   - **Always** - Ensures that reprojection is always performed, that is, MapInfo Pro calculates the image’s coordinates based on a precise formula and then the pixels are resampled using Cubic Convolution or Nearest Neighbor options.
   
   - **Optimized** - Determines the reprojection of a raster image based on the look of the destination rectangle (a selection of the image) after transformation into the source image space. If it looks as a rigorous rectangle (two sides are parallel to x-axis and two sides parallel to y-axis), then the standard Windows functions stretch the source image in both directions, as it was in pre-version 8.5 MapInfo Pro. If the image fails the rigorous rectangle test, the reprojection is performed using the resampling options.

   The Resampling Method options enable when you select Always or Optimized. Never is the default reprojection option and reflects the vector reprojection only behavior.

3. If you chose Always or Optimized, then you can decide how best to resample the image by choosing:

   - **Cubic Convolution** provides the best restoration of pixel values because of their separateness. Using this option, a pixel in the destination image is calculated based on the pixel values in a 4x4 pixel window centered at the original pixel in the source image. The coordinates of the original pixel are calculated for every pixel of the destination image based on a special optimized procedure. Pixels are then weighted based on the basic pixel coordinates. In general, we recommend you use the Cubic Convolution resampling method for aerial images and satellite raster images to get a better image quality. The Cubic Convolution algorithm used in MapInfo

• **Nearest Neighbor** replaces the pixel value in the reprojected image with the original pixel value from the source image. This resampling method takes less time to render than the Cubic Convolution method, but may be less precise. In general we recommend you use **Nearest Neighbor** resampling for raster maps, grids, and scanned maps to get faster results.

**Note:** When you are reprojecting 8-bit palette raster images, such as color .TIFF or .BMP images, MapInfo Pro uses the **Nearest Neighbor** resampling option without regard to the resampling method you choose.

4. Click **OK** to close the dialogs and save your settings.

When you choose the **Always** or **Optimized** reprojection, the reprojection process runs in the background and there is nothing to see. However, you can see the differences that **Cubic Convolution** or **Nearest Neighbor** resampling make in the way that the raster displays.

### Setting Your Notification Preferences

MapInfo Pro updates you when there is a new maintenance patch available for download and news about the product. You can set the frequency of these updates, or turn them off, as a software preference.

**Note:** On the Help menu, point to **Check for News Feed** to link to the MapInfo Pro product notifications site where you can see the latest product news and information.

To set the frequency of product updates and notifications from MapInfo Pro:

1. On the **Options** menu, point to **Preferences** and click **Notifications** to open the **Notifications** dialog box.
2. Select from the following options:
   - **Check for new maintenance patch once in** – Select this check box and type a number (in days) to enable MapInfo Pro to check for maintenance patches and other updates. Clear this check box to disable checking for any new patches.
   - **Update me of news from PB once in** – Select this check box and type a number (in days) to receive product updates from Pitney Bowes. Clear this check box to disable all checking for updates.
   - **Update Server Request Timeout** – Type a number (in seconds) to determine the server timeout in case MapInfo Pro is unable to communicate with the notifications server.
3. Click **OK** to close the dialogs and save your settings.
Setting Your Map Window Preferences

The Map window preferences control the default settings for any new Map window created in MapInfo Pro. You can override some of these preference settings for the current Map window in the Map Options dialog box (on the Map menu, click Options). These include the settings for resizing Map windows, specifying distance and area calculations, and displaying coordinates in degrees, minutes, and seconds.

To set the Map window preferences: On the Options menu, point to Preferences and click Map Window to open the Map Preferences dialog box.

There are several tabs of preferences:

- **Display tab** - preferences for when resizing a Map window, applying clip region use, and various display settings.
• **Editing tab** - a warning message before loss of map information, how to move duplicate nodes in layers, digitizing options, and find selection options.

• **Projection tab** - default projections, display coordinates, and whether to calculate distances and areas using a Spherical or Cartesian calculation.

• **Adornments tab** - default location and style for scale bars.

**Display tab (Map window dialog box)**

The **Display** tab on the **Map Preferences** dialog box has preferences for controlling the default behavior of Map windows and for how to clip regions.

The **When Resizing Map Window** options controls the default behavior of Map windows when you resize them.

- Click the **Fit Map to New Window** to draw the map to fit the resized window. You see the same view of the map that you saw before you resized the window. This is the default setting.
- Click the **Preserve Current Scale** button to change the view of the map when the Map window is resized. As you shrink or enlarge the window, you will see a smaller or larger area of the map.

This setting does not affect Map windows that are already open. To override the preference settings for the currently open Map window, make different selections in the **Map Options** dialog box.

The **Apply Clip Region Using** choices sets how you want MapInfo Pro to clip regions.

- **Windows Device Clipping (all objects)** - The clipping is controlled by the Windows Device Display. All objects (including points, labels, text, and raster and grid images) will be clipped at the Clip Region boundary. This is the default setting.
- **Windows Device Clipping (no points, text)** - Use this method to emulate the Erase Outside clipping method. All objects are clipped using Erase Outside except points and labels. Points and labels will be completely displayed only if the point or label point lies inside the Clip Region object. Text objects, raster files, and grid files always display and are never clipped.
- **Erase Outside (no points, text)** - This method uses the Erase Outside functionality. The Clip Region object is the Cutter object, and all other objects are Target objects for this operation. All objects are clipped using Erase Outside, except points and labels. In addition, points and labels will be completely displayed only if the point or label point is inside the Clip Region object. Text objects always display and are never clipped.

Other display options are:

- **Scrollbars** - To display scrollbars, select the **Scroll Bars** check box. By default, MapInfo Pro does not display scrollbars in Map windows.
- **Autoscroll** - To scroll the layout automatically, select the **Autoscroll** check box.
- **Show InfoTips** - To display one or two word tips when you cursor over a button, select the **InfoTips** check box. By default, MapInfo Pro displays InfoTips. Clear the **Show InfoTips** check box to deactivate their display.
- **Automatic Raster Zoom Layering** - To choose the default mode for automatic zoom layering for raster layers, select this check box. Raster zoom layering is turned on by default.
• **Automatic Grid Zoom Layering** - To choose the default mode for automatic grid zoom layering when adding a grid layer to the map, select this check box. Automatic Grid Zoom Layering is turned off by default.

• **Draw Layers Under Themes** - This option sets the default behavior for the **Replace Layer Style** check box in both the Ranges and Individual Value Theme dialog boxes. Select this check box to clear the **Replace Layer Style** check box by default. Clear this check box to select the **Replace Layer Style** check box by default.

• **Automatically Open Default Theme** - This option saves the theme to the table's metadata so that the theme displays each time you open the table. This check box is cleared by default.

• **Enable Hardware Acceleration for 3DMap Windows** - Select this check box to use your video card acceleration capability to display 3DMaps. Clear the box to display the 3DMap without using your video card acceleration capability. Turning the acceleration off reduces performance, but it avoids failure with certain graphic adapters and drivers.

• **Mouse Wheel Zoom Based on a Cursor Location** - Select this check box, so that when zooming a map using a the mouse wheel, the zoom will center where the cursor is located on the map. When this option is not set, the zoom is centered at the center of the map.

• **Handler for New Grids** - Select the output grid file format. By default, MapInfo Pro uses the MapInfo Pro handler (*.MIG). The available formats depend on which grid handlers are installed. When you change the grid file format, the file extension on the grid file name changes to reflect the selected format.

*Editing tab (Map window dialog box)*

The **Editing** tab on the **Map Preferences** dialog box has preferences for controlling the display of warning messages, how to move duplicate nodes, digitizing tolerances, and how to apply **Find Selection** features.

The **Warn Prior to Loss** group of check boxes set warning messages before you leave the currently open **Map** window and lose cosmetic objects, map labels, and thematic layers you have created. After the warning, you can save these objects, labels and layers as part of a table or workspace. These check boxes are selected by default. Clear the **Cosmetic Objects**, **Map Labels**, and **Thematic Layers** check boxes to turn off these warnings.

The **Move Duplicate Nodes in** group of choices specifies whether MapInfo Pro will move duplicate nodes when you use the **Reshape** command (on the **Edit** menu, click **Reshape**) to edit objects that are adjacent to each other, such as regions.

• Choose **None of the Layers** to prohibit the product from moving duplicate nodes. This is the default setting

• Choose **Same Layer** to move duplicate nodes that are in the same layer when one of the connected nodes is moved.

The **Digitizing Options** group includes a **Display Snap Radius** check box to make the snap radius larger or smaller. If you clear this check box, then the radius does not display when the snap mode is turned on.

Type a new value in to the **Snap Tolerance** and **Auto Node Tolerance** boxes to specify the default tolerance in pixels within which snap to node and Auto Node features operate. You use these settings
when you draw objects. (Click the $ key to turn **Snap to node** on.) The default is five (5) pixels. Enter a smaller value to obtain a tighter tolerance, and avoid snapping to the nodes of other objects as you draw. Enter a larger value to obtain a looser tolerance, when you want to snap to a node even though you are relatively far away from it.

For more information about the snap tolerance, see *Using "Snap To" to Select Nodes and Centroids* in the *Help System*.

The **Find Selection Options** include:

- **Zoom on Find Selection** - Select this option to zoom to the selection each time you perform a Find Selection for single and multiple objects. Clear this check box to prevent zooming when performing a Find Selection.
- **Find Selection after Paste** - Select this option to turn on the Find Selection feature in the **Map** window only after you Paste an object. If you have an active Browser, and the selection is in that **Browser** window, the browser still scrolls to the selection. Clear this check box to prevent zooming after pasting an object.

*Projection tab (Map window dialog box)*

The **Projection** tab on the **Map Preferences** dialog box has preferences for controlling the projection of tables and a MapBasic session, and the format in which coordinates display.

Specify the default for:

- **Table Projection** - To set the default projections for the current map, designate a default table projection for creating new tables, importing GML 2.1, MIF, MBI, and IMG files, and for **Choose Projection** options in dialog boxes.

  **Note:** You can override the table projection defaults by clicking the **Choose Projection** button throughout MapInfo Pro except when you use the Universal Translator, ArcLink, or when you import DXF files.

- **Session Projection** - To set the option to designate a default MapBasic projection for returning coordinate values using a **MapBasic** window or **Update Column**. Compiled MapBasic applications are not affected by this preference.

The **Display Coordinates** list has options for changing the format in which coordinates display. You can select:

- **Decimal Degrees** - By default, MapInfo Pro displays coordinates in decimal degrees. MapInfo Pro displays coordinates of objects in the **Object Info** dialog box, and of the cursor location in the status bar if that display option is selected.
- **Degrees, minutes, seconds** - Choose this option to display your Map using the degree, minute, seconds format.
- **Military Grid Reference System** - Choose this option to display your Map using the Military Grid Reference System format. Coordinates are converted to the Military Grid Reference System format using the World Geodetic System (WGS) of 1984 Ellipsoid.
- **US National Grid Reference (NAD 83/WGS 84)** - Choose this option to display your map using the United States National Grid (USNG) reference system format. Coordinates are converted to

- **US National Grid Reference (NAD 27)** - Choose this option to display your map using the United States National Grid (USNG) reference system format. Coordinates are converted to the North American Datum of 1927 Ellipsoid.

  **Note:** To override a grid references system preference in individual maps, use the **Map Options** dialog box (on the **Map** menu, click **Options**). Overrides to the default coordinate setting will be saved to your workspace.

  **Note:** Selected in either the **Map** window preferences or the **Map Options** dialog boxes, the format will display in the status bar, but not in the **Object Info** dialog boxes. If you display any **Object Info** dialog box for an object on a map that uses the Military Grid Reference System or United States National Grid, the coordinates will be displayed in decimal degrees.

Choose a **Distance/Area using** setting to specify the default type of distance and area calculation that MapInfo Pro uses for new **Map** windows.

- **Spherical** - The Spherical calculations measure distance according to the curved surface of the Earth. Spherical is the default. The data is first converted to Latitude/Longitude and then a calculation is produced. Lat/Long data will always use spherical calculations.
- **Cartesian** - The Cartesian method performs calculations on data projected onto a flat plane. Cartesian coordinates (x,y) define the position of a point in two-dimensional space by its perpendicular projection onto two axes which are at right angles to each other. Long/Lat projections cannot use Cartesian calculations.

  **Note:** To specify a calculation method for the currently active **Map** window, use the **Map Options** dialog box (on the **Map** menu, click **Options**).

For more information about map preferences, see **Setting your Map Window Preferences** in the **Help System**.

**Adornments tab (Map window dialog box)**

The **Adornments** tab on the **Map Preferences** dialog box has preferences for controlling how to position a new scale bar.

The **Adornment** group of options set the defaults for how to locate a new scale bar on the map.

- **Select a default position** - Select to place adornment in a preset location in the **Layout** window: upper left corner, upper right corner, lower left corner, or lower right corner.
- (Optional) Enter measurement values in to the **X offset** and **Y offset** fields. Use positive numbers.
- **Specify a custom position (from top left)** - Select to place adornment in a specific location in the **Layout** window. Enter measurement values in to the **Move right** and **Move down** fields. Use positive numbers.
- **Background** - Click these buttons to set the background fill style and background border style.

The **Scale Bar Adornment** group of options set the default style for a scale bar.
• **Bar Length** - The two values are proportional: the first value is the distance on the paper map, the second value is what the first value represents as a distance on the Earth's surface. Specify the length of the scale bar to a maximum of 34 inches or 86.3 cm on the printed map.

• **Bar Height** - Set the height of the adornment to a maximum of 44 inches or 111.76 cm on the printed map.

• **Bar Type** - Select a preset scale bar: Check Bar, Solid Bar, Line Bar, or Tick Bar.

• **Add Cartographic Scale** - Check this check box to include a representative fraction (RF) with the scale bar. In MapInfo Pro, a map scale that does not include distance units, such as 1:63,360 or 1:1,000,000, is called a cartographic scale.

• **Use Automatic Sizing** - Check this check box to set a preference if automatic sizing should be "on" or "off" for new scale bars.

• **Bar Style** - Set from the following:

  - Click to display the **Region Style** dialog box and select fill color for customizing the scale bar.
  - Click to display the **Line Style** dialog box and select line options for customizing the scale bar.
  - Click to display the **Text Style** dialog box and set the font style, such as type, size, and color, for customizing scale bar values.

For more information, see the following topics in the *Help System*:

- *Scrolling through a Map*
- *Specifying Options in a Map*
- *Changing the Default or Preference Setting for Calculations*
- *Centering a Map Using Military Grid Reference System (MGRS) Coordinates*
- *Centering a Map Using United States National Grid (USNG) Coordinates*
- *Setting Default Clip Region Options*
Setting Your Layout Window Preferences

The classic Layout window has preferences that you can set to unify the look and feel of the layouts produced through this window.

*Note:* The Layout Designer window does not have preferences.

To set the global default preferences for Layout windows:

1. On the Options menu, point to Preferences and click Layout Window to open the Layout Window Preferences dialog box.
2. Select the Show Rulers checkbox to display rulers in your Layout window. Rulers can be useful to help you line up elements of your layout on the page. This option is selected by default.
3. Select the Show Page Breaks to display the page breaks in your Layout window. Showing the page breaks ensures that the elements of your layout are consistent from page to page. This option is selected by default.
4. Choose when the contents of frames display:
   - *Always* - Have the contents of a frame display all the time even when it is not active. Select this option when you are changing the contents of a Map window that is also in the Layout. You can then see the effect of the layout as you make your changes. This option is selected by default.
   - *Only when Layout window is active* - Display the contents of a frame only when the Layout is the active window.
   - *Never* - Display only the file name and frame type even when the Layout is the active window. Choose this option when you are resizing and repositioning frames, so that the contents of the frames do not redraw when you make a change.
5. Select the Prompt to Save Workspace Prior to Close checkbox to have MapInfo Pro prompt you to save before you close windows with layout changes. Clear this check box if you do not want to be prompted to save your changes. This option is selected by default to prevent accidental loss of information.
   *Note:* The prompt only displays if there are changes to the open Layout and Legend Designer windows or when the Layout and Legend Designer windows are new.
6. Click OK to close the dialogs and save your settings.

After saving your changes, MapInfo Pro uses these settings automatically whenever you create a new Layout window.

You can reset these options for a specific layer: On the Layout menu, point to Options to display the Layout Display Options dialog box where you can set height and width restrictions and an autoscroll option.
Setting Your Browser Window Preferences

Any changes made to the Browser window preferences are applied between sessions.

Changing the Browser Window Background Color

You can choose the color to use for the background on alternating rows in the Browser window. This setting makes it easier to distinguish between rows. MapInfo Pro applies this setting to all Browser window instances (in a layout, printout, and in all Browser windows).

To change the background color for rows in the Browser window:
1. On the Options menu, point to Preferences and click Browser Window to open the Browser window.
2. From the Alternating Row Color list, select a background color to use.
3. Click OK to close the dialogs and apply the color to your Browser windows.

MapInfo Pro saves this setting between sessions.

Setting Your Legend Designer Window Preferences

Using software preferences, you can control the default title settings for legend frames in the Legend Designer window and the default text style attributes, such as font and size. MapInfo Pro uses your preferences when there are no metadata keys in the table on which the legend frame is based. If metadata keys are present, then the metadata defaults override your preferences.

To set the Legend Designer window preferences:
1. On the Options menu, point to Preferences and click Legend Window to display the Legend Window Preferences dialog box.
2. In the Legend Frame Defaults group, set default titles and list names for Legend frames:
   • To set the Title Pattern, type the text that you want to display at the top of each legend frame in this box.

   By default, the Title Pattern is "# Legend", where `#` is the name of the layer on which the frame is based. So, if the frame is based on the States layer, the default pattern title would be "States Legend." You can change this pattern to "Legend of #" or simply "." To have no default pattern, leave the box blank.

   Note: When the # symbol is in the Title, Subtitle, or Style Name pattern, it is replaced with the layer name. When the % symbol is in the Style Name pattern, it is only replaced with
the object type. If you want to use the pound (#) symbol and not have it replaced, then put a backslash (\) character before it (\#). If you want to use the percent (%) symbol in the Style Name pattern and not have it replaced, then put a backslash (\) character before it (\%).

- To set the **Subtitle Pattern**, type the subtitle text you want in this box. The entry in this box is blank by default, but you can set your own default title pattern for subtitles.
- To set the **Style Name Pattern**, type the text you want to display beside each symbol in this box. The default pattern is the `%' character. The Style Name is the text that describes each symbol in a legend frame. The % character is used as a placeholder for the type of object the legend symbol corresponds to: point, line, or region.

You can type in your own default Style Name Pattern, either using the % character or not. For example, in a legend frame based on the States layer, a Style Name Pattern that reads "% of #" will display as "Region of States" next to the symbol in the legend. The % character can only be used in the Style Name Pattern box.

Clicking **Restore Default Title and Labels** clears what you entered in the Title and Subtitle fields and restores the default settings.

3. In the **Legend Frame Sample Sizes** group, set the default sample sizes for legend frames:

- **Paper Units** - Specifies the units when you measure the size of objects in a Legend Designer window. Choose a unit of measurement from the drop-down list. The default unit is points (pt), because it more accurately matches sample sizes to font sizes for legend text.
  
  - 1 inch (in) = 2.54 centimeters , 254 millimeters, 6 picas, 72 points
  - 1 point (pt) = 0.01389 inches, 0.03528 centimeters, 0.35278 millimeters, 0.08333 picas
  - 1pica = 0.16667 inches, 0.42333 centimeters, 4.23333 millimeters, 12 points
  - 1 centimeter (cm) = 0.39370 inches, 10 millimeters, 2.36220 picas, 28.34646 points
  - 1 millimeter (mm) = 0.1 centimeters, 0.03937 inches, 0.23622 picas, 2.83465 points

- **Region Sample Width** - Sets the width of a region sample in legend lists. You can specify 8 to 144 points, 0.666667 to 12 picas, 0.111111 to 2 inches, 0.282222 to 5.08 millimeters, or 0.282222 to 5.08 centimeters. The default value is 32pt (points).

- **Region Sample Height** - Sets the height of a region sample in legend lists. You can specify 8 to 144 points, 0.666667 to 12 picas, 0.111111 to 2 inches, 0.282222 to 5.08 millimeters, or 0.282222 to 5.08 centimeters. The default value is 14pt (points).

- **Line Sample Width** - Sets the length of a line sample in legend lists. You can specify 12 to 144 points, 1 to 12 picas, 0.666667 to 2 inches, 4.23333 to 50.8 millimeters, or 4.23333 to 50.8 centimeters. The default value is 36pt (points).

These options apply when creating a map legend using the **Create Legend** wizard. The resulting legend displays in the **Legend Designer** window.

4. In the **grid and Guidelines** group, set the grid and guidelines display defaults:
The Legend Designer window provides controls, in the form of a grid and guidelines, to accurately set the alignment of the contents of the legend. You can change the display and color defaults for these, which take effect the next time you open a Legend Designer window.

- **Display Grid by Default** - Select to show an equally spaced grid of lightly marked lines to align legend frames to.
- **Snap to Grid Enabled by Default** - Select enable snapping to the grid of lightly marked lines within the Legend Designer canvas.
- **Grid Color** - Select a color to display the grid of lightly marked lines within the Legend Designer canvas (the grid is for aligning legend frames). The default color is Light Slate Gray (RGB = 119, 136, 153).
- **Guideline Color** - Select a color to display the guidelines within the Legend Designer canvas (guidelines are for aligning legend frames to a position of your choosing). The default color is Blue (RGB = 0, 0, 255).

5. Automatically save legends to workspaces, by checking the **Prompt Save Workspace Prior to Close** check box. Selecting this always saves legends to a workspace along with the rest of your work when closing MapInfo Pro.

6. Automatically work with the pre-version 11.5 **Cartographic Legend** window by selecting the **Create Version 11.0 Legends** checkbox.

Selecting this creates map legends that display in the **Cartographic Legend** window, which predates the **Legend Designer** window that was introduced in version 11.5. This option is for users who have created maps and legends in pre-version 11.5 MapInfo Pro and who want to maintain the look and feel of those legends. When unselected new map legends display in the Legend Designer window. For new projects, we strongly recommend using the Legend Designer to ensure that your map legends are forwards compatible with future releases of MapInfo Pro.

After making this selection, you may want to select from the **Version 11.0 Legend Properties** group. The options in this group are only available for legend created before version 11.5.

- **Small/Large Sample Size** - Select the size of the style sample for maps by clicking the **Small** or **Large** button.
- **Border Style** - Check to place a border around the selected Legend Frame. If you want to change the pen style for the border, click the box displaying the X (the Style button) to display the **Line Style** dialog box.

7. Click **OK** to close the dialogs and save your settings.

### Setting Your Printer Preferences

You can use the printer preferences to select a printer for MapInfo Pro output, which can be separate from your default Windows printer.
Note: You can get additional printer advice in the *MapInfo Pro Printing Guide*, which is located in the Documentation subfolder of your installation directory.

To set your printer preferences:

1. On the Options menu, point to Preferences and click Web Services to open the Printer Preferences dialog box.

2. Choose either:
   - **Windows Default** - This displays the path to the default printer specified for your operating system. This is the default setting.
   - **MapInfo Preferred** - This lets you set a different default printer when printing while using MapInfo Pro. This can be a printer or a plotter.

3. If you chose **MapInfo Preferred**:
   - Select the name of the printer, from the Size drop-down list, to use as the default printer.
   - Select a paper size from the Size drop-down list, which prefills with the paper sizes available for the printer.
   - Specify the direction that the paper faces (the orientation). **Portrait** indicates that the paper is taller than it is wide (as shown in the previous figure); **Landscape** indicates that the paper is wider than it is tall.

4. Click **OK** to close the dialogs and save your settings.
Note: If you selected **Save Printer Information to Workspaces** in the startup preferences, then MapInfo Pro saves the printer information and settings to the workspace. To set this preference, on the **Options** menu, point to **Preferences** and click **Startup**.

**Printing Caveats**

*About Working with a Windows Default Printer*

If you select the Windows Default printer, MapInfo will always use the printer that is currently set as the default in Windows. The settings for that printer will display in the **MapInfo Preferred Printer Setup** group. You will not, however, be able to change them in the **Printer Preferences** dialog box. To change the Windows default printer, go back to the **Windows Control Panel**.

To use a printer other than the one indicated in the Printer preferences, choose either:

- On the **File** menu, point to **Print**. You can change the printer you are using in the **Print** dialog box, overriding the default printer settings.
- On the **File** menu, point to **Page Setup**. In the **Page Setup** dialog box, click the printer to display the **Preferences** dialog box for the default printer. Select a different printer in the Name drop-down list. This will override the default printer set in the Printer preferences.

**Note:** The printer override applies only to the window you are currently printing. To change the default settings, go back to the printer preferences and specify a new default printer.

- For more information, see **Selecting a Printer** and **Error Message Displays when Print Output is Too Large** topics in the **Help System**.

**Enabling or Disabling the Subdivided Printing Option**

To allow print jobs to be broken into multiple, smaller print requests set the **Subdivide Printing** preference. This preference is initialized using a registry setting if it exists.

To enable the Subdivide Print option using registration files, see **Enabling the Subdivide Print Option Using Registration Files**.

1. On the **Options** menu, point to **Preferences** and click **Output Settings** to open the **Output Preferences** dialog box.
2. On the **Printing** tab, select the **Subdivide Printing** check box to break a print job into multiple, smaller print request. Clear the check box to print as a single request.
3. Click **OK** to close the dialogs and save your settings.

**Note:** Subdivide Printing is especially useful if printing large raster and/or translucent maps to large paper sizes.
Setting Your Output Setting Preferences

MapInfo Pro has output preferences that control raster and grid file color settings for on-screen display, printed output, and file export settings. You can also specify how you want to handle transparency in vector and raster files in both your printed output and exported files. Other printer settings enable you to specify an output method, map scaling, and whether to print a border around a Map window.

These output preferences become the default settings in MapInfo Pro. These preferences are the default settings in the Advanced Printing dialog box for example. You can override the default settings by changing them, in the Advanced Printing dialog box for example, and then saving your map in a workspace.

**Note:** You can get additional printer advice in the *MapInfo Pro Printing Guide*, which is located in the Documentation subfolder of your installation directory.

To set output preferences: On the Options menu, point to Preferences and click Output Settings to open the Output Preferences dialog box.

There are several tabs of preferences:

- **Display tab** - set the on-screen display options for raster or grid files.
- **Printing tab** - set the printing options for Map windows, classic Layout windows, Layout Designer windows, and all other output file types. (You can reset these preferences by overriding them for your map.)
- **Exporting tab** - set the export options for Map windows, classic Layout windows, Layout Designer windows, and all other output file types. (You can reset these preferences by overriding them for your map.)

The following sections explain the display settings, the printing options, and window export options in Output Preferences dialog box. Some of the options appear in more than one dialog so we have grouped all of the same explanations together.

**Display tab (Output Preferences)**

The Display tab sets the on-screen display options for raster or grid files.

- **Polygon Mode** - Select this check box to display the rendering that draws the object as a single request with all nodes. Polygon Mode has three preferences based on three types of drawing: on-screen, printing, and exporting. You can select Polygon Mode separately for display, printing, and export on the Display, Printing, and Exporting tabs. When Polygon Mode is off, MapInfo Pro renders with special processing.

  **Note:** Printing to PDF files may produce extra hairlines in the output when Polygon Mode is off.
• **Display Raster in True Color When Possible** - Select this check box to display your 24-bit raster or grid file images in true color (make sure your display settings are set to greater than 256 colors). Clear this check box to display images using 256 colors. This box is checked by default.

• **Dither Method** - Select this check box when it is necessary to convert a 24 image to 256 colors, use either halftone or error diffusion. This option is used when printing raster and grid images. Dithering occurs when **Print Raster In True Color When Possible** is off or when the printer color depth is 256 colors or less. Select a dither method from the drop-down list:

  - **Halftone** dithering calculates a series of half tone differences in color between high-contrast elements in your image to create a smooth transition of color. This option is selected by default for display, print, and export options.

  - **Error diffusion** dithering calculates an interim color between contrasting colors and shades the surrounding pixels to blend evenly toward that interim color.

  **Note:** You can select dithering separately for display, printing, and exporting on the **Display**, **Printing**, and **Exporting** tabs.

---

**Printing tab (Output Preferences dialog box)**

Click the **Printing** tab to set the printing options for **Map** windows, classic **Layout** windows, **Layout Designer** windows, and all other output file types. Select the appropriate printing settings based on your output requirements. Remember that resetting these printer options locally overrides these preferences.

• **Print Directly to Device** - Select this option to print your image file directly from MapInfo Pro. This check box is checked by default.

• **Print Using Enhanced Metafile (EMF)** - Select this option to generate an enhanced metafile of your MapInfo Pro image before sending it to the printer. This setting takes advantage of current printer technology to shrink the spool size and print your file quicker without sacrificing quality. When printing to PDF, selecting this option generates a flat, non-layered, PDF file.

  **Note:** You must use this setting if you are printing a map containing a translucent raster or grid layer. If you do not use this setting, the image will not print translucently.

• **Output Method/Print Using Offscreen Bitmap (OSBM)** - Select this option to generate an Offscreen bitmap of your MapInfo Pro image before sending it to the printer. Offscreen bitmap is invoked depending upon the type of translucent content in the map and enhanced rendering state of the window. However, setting OSBM from this window means that while printing Offscreen bitmaps (OSBM) will be selected regardless of the translucency and anti-alias settings.

• **Print Border for Map Window** - Select this check box to print a black border around the image you are printing. Clear this check box to leave the image without a border. This check box is checked by default.

• **Internal Handling for Printing Transparent Vector Fills and Symbols** - Select this check box to have MapInfo Pro handle transparent fill patterns and bitmaps for vector images when printing or exporting. This check box is checked by default. Clear this check box to let the printer or Windows export functions handle this.
• **Scale Patterns** - Select this check box to match the non-transparent fill patterns in your print output to more closely match what you see on your screen. This check box is checked by default. Clear this check box to let the printer driver have exclusive control over rendering the pattern fills.

  **Note**: The **Scale Patterns** check box does not affect transparent fill patterns because transparent fill patterns are always scaled.

• **Subdivide Printing** - Select this check box to break print jobs into multiple, smaller, print requests for better print quality. This is useful when printing large raster/translucent maps to large paper sizes. If unchecked, the print is done in a single request.

• **Polygon Mode** - Select this check box to display the rendering that draws the object as a single request with all nodes. **Polygon Mode** has three preferences based on three types of drawing: on-screen, printing, and exporting. You can select **Polygon Mode** separately for display, printing, and export on the **Display**, **Printing**, and **Exporting** tabs. When **Polygon Mode** is off, MapInfo Pro renders with special processing.

  **Note**: Printing to PDF files may produce extra hairlines in the output when **Polygon Mode** is off.

• **Use ROP Method to Display Transparent Raster** - Select this check box to allow the internal ROP (Raster Overlay by Pixel) to manage the transparent pixel display and printing in raster images. Since the ROP Method is largely a display method, not all printers, plotters, and export programs can use it. We recommend that you either check with the printer manufacturer before using this setting or try a few test prints or exports to get the results you want. This check box is cleared by default.

  Using the ROP method may not produce problems unless you print the metafile.

• **Print Raster in True Color When Possible** - Select this check box to print and export your 24-bit raster or grid file images in true color (make sure your printer settings are set to greater than 256 colors). Clear this check box if you are not working with a color printer. This check box is checked by default.

  **Note**: See the Dithering Method setting above for details about this option.

---

*Exporting tab (Output Preferences dialog box)*

Click the **Exporting** tab settings to set the export options for Map windows, Layout windows and all other output file types. Select the appropriate window export settings based on your output requirements. Remember that resetting these options locally overrides these preferences.

• **Export Border** - Select this check box to include a black border on images you are exporting. This check box is checked by default. Clear this check box to export the image without a border.

  **Note**: The preference setting definitions for **Internal Handling for Transparent Vector Fills and Symbols**, **Use ROP Method to Display Transparent Raster**, **Print Raster in True Color When Possible**, and **Dithering Methods** are the same for export as for printing.
• **Internal Handling for Transparent Vector Fills and Symbols** - Select this check box to have MapInfo Pro handle transparent fill patterns and bitmaps for vector images when printing or exporting. This check box is checked by default. Clear this check box to let the printer or Windows export functions handle this.

• **Polygon Mode** - Select this check box to display the rendering that draws the object as a single request with all nodes. **Polygon Mode** has three preferences based on three types of drawing: on-screen, printing, and exporting. You can select **Polygon Mode** separately for display, printing, and export on the **Display**, **Printing**, and **Exporting** tabs. When **Polygon Mode** is off, MapInfo Pro renders with special processing.

**Note:** Printing to PDF files may produce extra hairlines in the output when **Polygon Mode** is off.

• **Use ROP Method to Display Transparent Raster** - When the ROP method is selected, the transparent image is rendered using a raster operation (ROP) to handle the transparent pixels. This method is used to draw transparent (non-translucent) images on-screen.

• **Export Raster In True Color When Possible** - Select this check box to display your 24-bit raster or grid file images in true color (make sure your display settings are set to greater than 256 colors). Clear this check box to display images using 256 colors. This box is checked by default.

• **Use Anti-Aliasing** - Select this check box to apply the anti-aliasing options available in MapInfo Pro. For a description of the anti-alias preferences, see Understanding the Anti-Aliasing Export Preferences.

---

**Understanding the Anti-Aliasing Export Preferences**

To give you more control over map images when exporting MapInfo Pro maps, you can use anti-aliasing methods. This is particularly important when you are saving maps created in MapInfo Pro for use in other Windows-based applications, in particular in slide presentations or for web pages.

The benefits of anti-aliasing can include:

- Make your fonts look smoother
- Make jagged edges in maps look rounder
- Can make text be easier to read (for some) because it looks more like printed type
- Make maps look more visually attractive

You can choose to smooth images and text during the export process. You can use this capability with all types of windows such as Map windows, layouts, legends, and graphs.

**Note:** You cannot anti-alias images you are exporting to .EMF or .WMF format, because these are not true raster formats.

There are three smoothing options you can use to customize your raster image:

1. **Smooth using a Filter value**. You can set a flag that selects one of six filters that allow you to choose the direction the filter is applied to the image from.
2. *Smooth using a Mask value.* You can select a value that indicates the size of the area you want to smooth. For example, to create a 3x3 pixel mask value, you would enter a 3 in this field. This would limit the amount of change in the color of the pixels. Typically mask sizes would be 2-3 pixels when exporting at screen resolution. If you are exporting at a higher resolution, a larger mask might be appropriate.

3. *Smooth using a Threshold value.* You can select a threshold value to indicate which pixels to smooth. Each pixel in an image has a value based on its color. The smaller the pixel value, the darker the color. Select this option to smooth all of the pixels above the threshold you enter in this field. When you set this value to 0, MapInfo Pro will smooth all of the pixels.

You must either set a global preference for these anti-aliasing options or set them locally during the export process (using the **Advanced** button).

For more information, see *Recommendations for Effective Pattern Scaling* in the *Help System.*
5 - Understanding Your Data

You cannot work for long in MapInfo Pro without wanting to add more or enhance your own data in some way. This chapter teaches you how to get the most from your MapInfo tables and how to create reports with your data.

In this section

Working with MapInfo Tables 143
Creating a Report of your Data 156
Opening an Existing Report 157
Saving a Report 157
Working with MapInfo Tables

After you have brought your data into MapInfo and created .tab files, you can manage them within MapInfo Pro. You can view any database table in MapInfo Pro, once you have converted it to MapInfo format. Additionally you can add or remove fields, change the order, name, type, width, or index of any field. You can also specify or determine the projection of the table from this dialog box. You can also check if the table is mappable (contains map objects). To make these types of changes, see Editing a Table's Structure.

Keep in mind that you can only view the structure of a spreadsheet or database file that you convert into MapInfo Pro’s table structure. See How Do I Get My Data on the Map? for these instructions.

To view the structure of a table, on the Table menu, point to Maintenance and click Table Structure. The View/Modify Table Structure dialog box displays.

For more information, see Accessing StreetPro Data in the Help System.

Adding to a Table

One important operation in maintaining tables is the ability to update the data contained in the table. MapInfo Pro's Update Column feature allows you to:

• Add a temporary column or update an existing column with data from another table
• Update a table
• Place graphic information into visible columns

Updating Information in a Subset of a Table

Use Update Column to update information in a subset of a table. For example, you could marquee the southeast of the United States, then use Update Column to set the "sales rep" field to the name of your sales representative for the Selection table.

You can update all the rows in a table or a selection of rows. To update a selection of rows you need to select the rows using Select, SQL Select, the Select tool, the Boundary Select tool, or the Radius Select tool, and then update the selection.

Adding a Temporary Column using Update Column

If you need to bring data from one table into another, you can use the Update Column command in MapInfo Pro. In fact to bring this data into the table, you can either add a temporary column or you can update an existing column. In both cases, use the Table menu to click Update Column to bring over the information.

You have tremendous flexibility with how information is imported and what information is transferred. You can perform aggregate functions to transfer averages, minima, maxima, sums, weighted
averages, and proportional sums. You can also create expressions to derive additional information from the data.

• For specific instructions and an example, see *Adding a Temporary Column using Update Column* in the Help System.

**Geographic and Descriptive Joins**

A join allows you to join two tables. To do this, MapInfo Pro must know how to associate records in the two tables.

For example, assume you are shading STATES by the values in SALES. Obviously, you want all Pennsylvania sales to be associated with Pennsylvania, all Maryland sales to be associated with Maryland, etc. MapInfo Pro has two ways of doing this:

1. From a common descriptive field.
2. Geographically/graphically.

In this case, the most likely descriptive field contains the state name or an abbreviation for the state name. Thus the STATES table might have a field called Abbr, containing the abbreviation of the state name, and SALES might have a field called State, that contains the state abbreviation. MapInfo Pro matches the entries in these two fields so that information in the SALES State field is matched to the record having the same entry in the Abbr field of STATE, thus matching NY (sales) to NY (state), PA (sales) to PA (state), etc.

However, if both tables contain graphic information, MapInfo Pro can also make a graphic match.

For example, if you are a conservation official and you want to shade a map of COUNTIES according to the number of FIRES that occurred in the last year. Your FIRES database has been geocoded. In this case MapInfo Pro could examine the coordinates of each fire location and determine the county where the fire had occurred. That would allow MapInfo Pro to associate each fire record with the appropriate county.

• For more information, see *Specifying a Join Based on Descriptive Criteria* and *Specifying a Join Based on Geographic Criteria* in the Help System.

**Updating a Table**

For a quick visual way to update your table, select the objects in the Map window and use Update Column to update the table with the new value. This would be useful when you want to update a number of objects with the same value.

To include the District column in the USA table:

1. Create the District column (on the Table menu, point to Maintenance and click Table Structure) in the USA table.
2. Add a field for Districts.
3. Redisplay the USA table in a Map window.
4. Select the appropriate states with the Marquee tool (or other selection method).
5. On the **Table** menu, click **Update Column** and fill in the dialog box as illustrated in the next figure. Be sure to put the value in quotes so MapInfo Pro does not treat it as a new column name.

![Update Column dialog box](image)

6. Click **OK**. MapInfo Pro creates a query table of the southeastern states with the District column containing the value Southeast.

7. Save the table to preserve the new information.

### Appending Rows to a Table

Use the Append Rows to Table command to attach the records from one table to another. The two tables should have the same set of columns in the same order.

To append data to another table:

1. On the **Table** menu, click **Append Rows to Table**. The dialog box displays.
2. Specify the table containing the records you want appended.
3. Specify the table to which the records will be appended and click **OK**.

If the corresponding columns do not have the same data type, a best fit is done to convert the data to the appropriate type. If the order of the columns is not the same between the two tables, use the Table Structure command to reorder the columns before using **Append Rows to Table**.

**Note:** If tables are mappable, the bounds of the map in one table must be large enough to allow objects from the other table to fit within it. Otherwise, the objects will be distorted to the bounds of the Map window. Use the Check/Set CoordSys Bounds tool to alter the map.
Appending One Table to Another

To append one table to another:

1. Choose **Table > Append Rows to Table**. The **Append Table** dialog box displays.
2. Choose the table you want to append from. Select a table in the Append Table drop-down list.
3. Choose the table you are appending to. Select a table in the To Table drop-down list.
4. Click **OK**. The status of the append operation displays.
5. Click **Stop** to halt the append process.

When the columns of the two tables are not ordered properly, so that columns with corresponding positions do not have corresponding data, use Modify Structure to change the order of the columns in one of the tables.

You can use **SQL Select** to reorder the columns of one of the tables and then append the results.

Parsing Data from One Column to Multiple Columns

If you have imported data into MapInfo Pro from another format, there is always the chance that the data will not come in exactly the way you want it. In some instances, items that should appear in separate columns may be put together in one column. The following is a series of column updates that parses one column of full names (first, middle, and last) into three parts. It works even if there is no middle name, or if there is only a last name.

To parse data from one column to multiple columns:

1. On the **File** menu, click **Open** and open the table to be modified.
2. Add three new columns to your table. On the **Table** menu, point to **Maintenance** and click **Table Structure**. Add two character columns of size 15. Call them **FIRST** and **MIDDLE**. Then add a character column called **LAST** of size 30.
3. Put the full name into the column called **LAST** by choosing the **Table** menu, and clicking **Update Column**. Fill in the **Update Column** dialog box.
The column to update is LAST, and we get the Value from the column that has the full name in it. Remember we are only working with one table, so the **Table to Update** and **Get Value From Table** should be the same table. In the following example, the table is TABLE1 and the full name column is your_full_name_column. You should fill in your own values for these two items.

4. To parse the first name out of the full name column, choose the **Table** menu and click **Update Column**. Fill in the **Update Column** dialog box.

```
The Column to Update is: FIRST
The Value is: left$(LAST, instr(1,LAST," "))
```
5. To parse the last name out of the full name column, on the Table menu, click Update Column. Fill in the Update Column dialog box.

![Update Column dialog box]

The Column to update is: LAST
The Value is: Right$(LAST, Len(LAST)-Instr(1,LAST," "))

6. To parse the middle name out of the full name column, on the Table menu, click Update Column. Fill in the Update Column dialog box.

![Update Column dialog box]

Update the MIDDLE column with the Value: Left$(LAST, Instr(1,LAST," "))
7. Then update the LAST column again by returning to the Table menu, clicking Update Column, and filling in the dialog box.

![Update Column dialog box]

The Value is: Right$(LAST, Len(LAST)-Instr(1,LAST," "))

8. Click OK to update the column.

Placing Graphic Information in Visible Columns

Update Column is also useful to put graphic information into columns so that it is visible. Tables that contain map objects store the graphic information about these objects invisibly. Using Update Column, you can bring some of that information into a column so it can be viewed in a Browser. Update Column with CentroidX(Obj), CentroidY(Obj) uses the Session Projection Preferences (if set), otherwise it defaults to Longitude/Latitude. For example, you want to display the longitude and latitude coordinates of a table of radio station point locations in a Browser. In this example, you are only working with one table, RADIOLOC, but you still use Update Column as in the Add Temporary Column example.

- For more information, see Placing Geographic Information in Visible Columns in the Help System.

Mouse Wheel Support for Browser Window

When you are working in the Browser window, you can use the mouse wheel to scroll through the records. Roll the mouse button down to scroll down the list, and roll the mouse button up to scroll up the list. You can still use the Tab key to scroll right and the <Shift+Tab> keys to scroll left in the Browser window.

For a list of keystrokes to help you navigate in a Browser window, see Shortcuts for the Browser Window.
Adding a Row to a Table

You can add a temporary row to an editable MapInfo table.

To add a new row:

1. On the Window menu, click New Browser window.
2. Choose an editable table from the drop-down list.
3. Click OK to display the table in a Browser window.
4. Choose Edit > New Row (or press Ctrl+E), a new row is added to the bottom of the table.
5. Enter data in the new row.

When you are finished adding rows, choose File > Save Table to save new data.

Creating a New Table

You can bring in data tables from several outside sources: dBASE, Excel, Access, Lotus 1-2-3, shapefiles, Grid, comma delimited, and delimited ASCII. You can also create your own database directly in MapInfo Pro. These databases can be opened and displayed as maps (providing they contain graphic objects), Browsers, or graphs.

To create a table in MapInfo Pro:

1. On the File menu, click New Table. The New Table dialog box displays.
2. Choose one or more from the following:
   • Open New Browser - Click this check box to display the new buffer in a new Browser window only.
   • Open New Mapper - Click this check box to display the new buffer in a new Map window.
   • Add to Current Mapper - Click this check box to display the new buffer in the current Map window.
3. Do one of the following and click OK:
   • To create a new table and new table structure, click Create New.
   • To create a new table based on the structure of an existing table, click Using Table and select from the list of open tables.
4. Choose OK. The New Table Structure dialog box displays.
If you selected Create New, this dialog is empty. You can remove a field by highlighting it and clicking the Remove Field button.

5. Choose Add Field to begin adding new fields to the database's structure. Give the field a name, type, width, and specify whether the field will be indexed.

6. Continue to add fields until you have the structure you want.

7. Use the Up and Down buttons to reorder the fields. Keep in mind that the order of fields in this dialog box (top to bottom) will actually display as columns (left to right) in the Browser window.

8. Choose Create. The Create New Table dialog box displays.

9. Specify a location for the new table in the Save in box.

10. Enter a name for the table in the File Name box.

11. Specify the file type in the Save as type drop-down list in one of these formats:

   - MapInfo (*.tab)
   - dBASE DBF (*.tab)
   - Microsoft Access (*.tab)

12. Click Save. One of these things occur:

   - If you chose the MapInfo Pro format, MapInfo Pro creates your table.
   - If you chose dBASE DBF, proceed to step 13.
• If you chose dBASE DBF, the **dBASE DBF Information** dialog box displays, asking you to specify a file character set. Choose the one appropriate for your language and click **OK**.

13. Click **Save** in the **Create New Table** dialog box. MapInfo Pro creates the new table.

**Note:** Do not use "Districts" as a name for your base tables. MapInfo Pro uses "Districts" internally as a system table when beginning a redistricting session.

14. For more information, see **Naming a File** and **Opening Multiple Tables** in the **Help System**.

### Creating a New Table by Combining Objects Using Column

If you want to make a new map of the U.S. based on areas such as Midwest, Pacific Coast, Northeast, etc., you could combine all of the state data and create new objects where some common data value is the key to which the new map object states will belong.

To do this, you could draw a rectangle somewhere on the States map. Select some states around the rectangle and specify them as the target. Select the rectangle and do a split operation. The new objects will be created and each split object will have its same state initials. Then, use **Combine Objects Using Column** and specify the state initials fields as the grouping value. The states will be re-created.

The Combine Objects Using Column feature gives you the option of creating a new table for the newly combined objects:

1. Choose **Table > Combine Objects using Column** to display the **Combine Objects using Column** dialog box.
2. Choose the objects from the table you want to combine.
3. Choose the column you want the objects to be grouped by.
4. Choose **New** in the Store results in table drop-down list.
5. Click the **Next** button to display the **New Table** dialog box.
6. Click the **Create** button to display the **New/Modify Table Structure** dialog box.
7. Click the **Create** button to display the **Create New Table** dialog box.
8. Click **Save** and a new table is created.

### Editing a Table's Structure

You can make changes to the structure of your table directly in MapInfo Pro. You can add or remove fields, change the order, name, type, width, or index of any field. You can also specify or determine the projection of the table from this dialog box. You can also check if the table is mappable (contains map objects).

The **Table is Mappable** option in the **Modify Table Structure** dialog box allows you to modify a table so you can map it or, when left cleared, it will ungeocode your table.

To change the structure of the table:

1. Choose **Table > Maintenance > Table Structure**. The **View/Modify Table Structure** dialog box displays.
2. Click the View/Modify Table drop-down list, a list of available tables displays.
3. Choose the table you want to modify.
4. Click OK.

The Modify Table Structure dialog box displays for editable tables and allows you to change the structure of a table. The View Table Structure dialog box displays for read-only tables and is only for viewing the table's structure.

**Note:** Keep in mind that you can only view the structure of a file that you bring into MapInfo Pro.

To move a column in the Modify Table Structure dialog box, select the column you want to move and drag it to the new position in the list. A small blue arrow shows the position of the column you are dragging.

**Copying and Renaming a Table**

Because a MapInfo Pro table consists of two or more component files (STATES.TAB, STATES.DAT, STATES.MAP, etc.), all of these files for a particular table must be in the same directory. If you move any of the component files to a different directory, you must move all of them. When you want to back up a table to diskette, you must back up all of the component files.

Because each table has at least two files associated with it, you cannot change one file name without changing all the other associated file names. Otherwise, MapInfo Pro would not know where to find all the files that constitute the table.

- For more specific instructions, see *Copying and Renaming a Table* in the Help System.

**Deleting a Table**

Deleting a table allows you to remove the .tab file and all component files associated with the table.

To delete a table:

1. On the Table menu, point to Maintenance and click Delete Table.
2. Choose the table to delete and click OK. A message displays to inform you that the table will be permanently deleted and the operation cannot be undone.
3. Click OK and MapInfo Pro deletes the table.

Deleting a raster table only deletes the *.tab file. Deleting a grid file removes both the *.tab and grid file.

**Packing a Table**

Packing a table allows you to compress tables to take up less disk space. You can choose to pack only tabular data or graphic objects or both. Packing tabular data removes deleted records. When you pack a table, MapInfo Pro requires that you have twice as much free space as the table takes up to handle a copy of the database as a scratch file.
To pack a table:

1. On the **Table** menu, point to **Maintenance** and click **Pack Table**. The **Pack Table** dialog box displays.
2. Choose a table from the Pack Table drop-down list.
3. Click the appropriate radio button to specify the type(s) of data.
   - **Pack Tabular Data**
     This option removes deleted records, making the table smaller, and increasing processing speed.
   - **Pack Graphic Data**
     This option packs only graphic information.
   - **Pack Both Types Of Data**
     Both graphic and textual information are packed.
4. Click **OK**.

**Note:** Packing a table can corrupt customized labels saved to a workspace. If you are going to be working with customized labels, pack the table before you create the labels.

**Collecting Data into the Table using Update Column**

MapInfo Pro provides a number of powerful aggregating functions that allow you to derive new information. These features are available in Update Column when you specify two tables in the **Update Column** dialog box. The aggregate expressions include **Average**, **Count**, **Minimum**, **Maximum**, **Sum**, **Weighted Average**, **Proportion Sum**, **Proportion Average**, and **Proportion Weighted Average**. Each is defined in the next table.

<table>
<thead>
<tr>
<th>Aggregate Expressions</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average</td>
<td>Calculates the average of the values for all records in a group.</td>
</tr>
<tr>
<td>Count</td>
<td>Counts the number of records in a group.</td>
</tr>
<tr>
<td>Minimum</td>
<td>Finds the lowest value for all records in a group.</td>
</tr>
<tr>
<td>Maximum</td>
<td>Finds the highest value for all records in a group.</td>
</tr>
<tr>
<td><strong>Aggregate Expressions</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>--------------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>Sum</td>
<td>Calculates the sum of the values for all records in a group.</td>
</tr>
<tr>
<td>Weighted Average</td>
<td>Gives more weight to one value over another when averaging.</td>
</tr>
<tr>
<td>Proportion Sum</td>
<td>A sum calculation that is adjusted based on how much of one object is within another object.</td>
</tr>
<tr>
<td>Proportion Average</td>
<td>An average calculation that is adjusted based on how much of one object is within another object.</td>
</tr>
<tr>
<td>Proportion Weighted Average</td>
<td>A weighted average calculation that is adjusted based on how much of one object is within another object.</td>
</tr>
</tbody>
</table>

Note that average, count, min, max, sum, and weighted average operate on data values only. The proportion functions take geographic relationships into account.

For faster performance for proportional calculations, use the Proportional Overlap Tool; see Using the Tools in the Tool Manager. For information about this tool, see Proportional Overlap Tool in the Help System.

**Note:** To find instructions for using the Update Column feature, see Adding a Temporary Column using Update Column.

- For more examples, see Collecting Data into the Table using Update Column in the Help System.

**Browsing a Table**

There are times when viewing the tabular data in a table is necessary. In MapInfo Pro, this is called browsing the table.

To browse a table:

1. On the **Window** menu, click **New Browser Window**.
2. Choose the table you wish to browse and click **OK**.

The Browser shows the fields of the data table (column headings) and the records of data (rows).

A Browse menu item gives you further functionality. On the **Browse** menu, click **Pick Fields** to display only the columns of data you want to see. If you wish to show information that is only implicit
in the base table, in the **Pick Fields** dialog box choose Expression from the Fields in Table list. For more on expressions see **Deriving Columns**, or **Creating Query Expressions**.

To show or hide the Browser window grid, on the **Browse** menu, click **Options**.

To add new records to the Browser:

1. On the **Edit** menu, click **New Row** to add a row (or use **Ctrl-E**).
2. Enter text directly into each field. As you type, press **Tab** or **Shift+Tab** to move from field to field.
3. You must remember to save the new information to the base table before exiting the program.

Click the row header, to the left of each row in the Browser window, to select a row. If the Map window for the table is open, the record is selected as well. To add records to the selection, **Shift** and drag to select consecutive records, or **CTRL-click** non-consecutive records.

Selecting records creates a subset of the table that you can browse, map, or graph, just like the full table. More on selecting is found later in **Selecting and Querying Data**. You can also create a report of your tabular data using the Crystal Reports functionality included with MapInfo Pro. The Crystal Reports *User Guide*, which is located in the Documentation subfolder of your installation directory to help you get the most out of this powerful report writing program.

### Creating a Report of your Data

MapInfo Pro includes the full report-writing functionality of Crystal Reports. Crystal Reports enables you to create reports of your tabular data. The Crystal Reports *User Guide* is included online so that you can get the most from this program.

To create a report and print it:

1. On the **Tools** menu, point to **Crystal Reports** and click **New Report**. The **New Report** dialog box displays. It lists all the open tables.
2. Click the table you want to create a report for, and click **Report**. The Crystal Reports user interface displays.
3. In Crystal Reports, **Choose Report** > **Report Expert** to display the **Create Report Expert** dialog box. The Report Expert walks you through the selection of data, fields, fields to sort by, fields to total, and styles for your report. Click **Preview Sample** to see a sample of your report on the screen.
4. On the **File** menu, click **Print** to print your report.

**Note:** Tables with columns containing underscores, temporary column, do not display in the default Crystal Report. Use the Expert Wizard to access columns containing these elements.
Opening an Existing Report

To open an existing report:

2. Select the report from the dialog box.

Saving a Report

When you save a report, an .rpt extension is assigned to the report. The report is assigned the default name: (tablename) report.rpt. You may rename the report using the Crystal Reports Save As feature.

All .rpt files are saved in the directory specified in Options > Preferences > Directories > Crystal Report files.
The graphing feature in MapInfo Pro lets you create a myriad of different graphs from three-dimensional bar graphs to exploded pie graphs. Each type of graph has its own set of features that you can customize to emphasize a particular piece of information, or create the aesthetic look you want for your graph. These features, plus additional formatting options, give you full control over the look and content of the graph.

In this section

- Selecting the Right Type of Graph 159
- Graphing Your Data 163
- Working with Multi-Table and Multi-Variable Graphs 170
- Saving a Graph 177
- Using Graph Templates 177
Selecting the Right Type of Graph

What do you need your graph to tell your audience? The answer to this question determines the type of graph you should select. In MapInfo Pro, you can choose from 10 different graph types. Each type of graph includes at least one graph template that you can use to create your graph. Each graph type, with a brief description of each template, is explained in the next section.

Graphing Terms

**Axis (Axes)**
An axis refers to a graduated line bordering the plot area of a graph. Coordinates are measured relative to the axes. By convention, the X-axis is horizontal and the Y-axis is vertical.

1. Y Axis, 2. X Axis

**Data Series**
A data series is the information your graph is based on.

**Graph Object**
A graph object is any selectable element in your graph. This can be a line, an area, text, or title.

**Graph Series**
A graph series is the row of objects you are graphing.

**Label Axis**
The label axis is the axis that has the labels of the data values being graphed. For example, in a typical financial graph, the label axis might have 1st Qtr, 2nd Qtr, and 3rd Qtr while the value axis
might have dollar amounts. For a graph in normal orientation (not rotated), the label axis is the X, or horizontal axis.

3D Graphs

Three-dimensional (3D) graphs give your information impact and depth. Most 3D templates are variations of a bar graph. You can customize a graph to fine-tune its appearance, such as applying a 3D Viewing Angle feature to set the angle at which a 3D graph displays.

- **3D Bar** - A conventional bar graph in three dimensions.
- **3D Floating Cube** - Each value being measured, such as population, is displayed as a cube. The value is indicated by the placement of the cube in the graph. Cubes that have higher values appear to float within the graph.
- **3D Floating Sphere** - This graph is the same as the 3D Floating Cube, except that each value being measured is displayed as a sphere.
- **3D Line** - The values being measured for a category, such as a country or a city, are displayed as a continuous line across the axis. The line will dip and spike according to the values.
- **3D Pyramid** - Each value being measured is displayed as a 3-dimensional pyramid. This graph is based on a bar graph—the higher the value, the taller the pyramid.
- **3D Round** - This graph is the same as the 3D Bar graph, except that the values are displayed as cylinders instead of bars.

Area Graphs

Area graphs display cumulated totals as numbers or percentages over time. You view your graph series as an area, where the area from the X axis to the plot line of the data series is filled in with a pattern or color. You can choose from the following templates:

- **Clustered** - A clustered area graph draws area risers overlapping each other to show the absolute relationship between data series.
- **Percent** - The percent area graph is an area version of a pie graph whose parts total 100%. Each group calculates the percent of the total required for each series. The axis goes from 0 to 100%.
- **Stacked** - The area risers are stacked on top of each other. The axis is the cumulative total of all the groups.

Bar Graphs

Bar graphs display proportional relationships over time by using horizontal or vertical bars, whose lengths are proportional to quantities.

- **Clustered** - The clustered bar graph is a side-by-side group of bars. This is the standard type of two-dimensional graph.
- **Percent** - The percent bar graph is a bar-graph representation of a pie graph. Each group calculates the percent of the total required for each series. The axis goes from 0 to 100%.
• **Stacked** - The stacked bar graph displays stacked groups of bars. Each stack is made up of all series in this group, added up to obtain a total. The axis is the total value of the cumulative points.

Bar charts are more accurate than pie charts, because distances are more accurately estimated than areas. Do not use bar graphs for:

• Comparisons. Instead use one-dimensional scatterplots.
• Larger data sets. Instead, use line charts.

### Bubble Graphs

Bubble graphs plot values on an X-Y axis and compare a third value, Z, by the size of the markers in the graph. The bubble graph requires three values per marker, X, Y, and Z, in that order. Another way to think of it is that the graph is an X-Y plot where the marker size depends on a third value, Z.

### Column Graphs

Column graphs display observations over time or under different conditions. This type of graph is effective with smaller data sets.

• **Clustered** - Each group of columns for a category are clustered together.
• **Percent** - The percent column graph is a column-graph representation of a pie graph. Each group calculates the percent of the total required for each series. The axis goes from 0 to 100%.
• **Stacked** - The stacked column graph shows stacked groups of columns. Each stack is made up of all series in this group, added up to obtain a total. The axis is the total value of the cumulative points.

Column charts are more accurate than pie charts, because distances are more accurately estimated than areas. Do not use column graphs for:

• Comparisons. Instead use one-dimensional scatterplots.
• Larger data sets. Instead, use line charts.

### Histogram Graphs

Histograms show frequency distribution by grouping values into value ranges—it measures the number of data values that fall within each range. The ranges display as bars without gaps.

• **Horizontal** - The orientation of the bars is horizontal.
• **Vertical** - The orientation of the bars is vertical.

### Line Graphs

Line graphs display trends and relationships by connecting data points by lines or curves.
• **Clustered** - In a clustered line graph, lines draw on top of each other to show the absolute relationships between data series.

• **Percent** - The percent line graph is a line-graph representation of a pie graph. Each group calculates the percent of the total required for each series. The axis goes from 0 to 100%.

• **Stacked** - In a stacked line graph, lines stack on top of each other. The axis is the cumulative total of the all the groups.

Do not use line graphs if the X axis has non-numeric values.

---

## Pie Graphs

Pie graphs display proportional relationships at a given time. Segments of the pie chart may be pulled out of the pie for emphasis, as an exploded pie chart.

- **Pie** - The pie graph displays percentages of a total as pie wedges.
- **Ring Pie** - The ring pie graph is a variation of the standard pie graph. It looks like a ring or donut. The total value of all the pie slices displays in the center.

Pie charts do not represent values beyond 100% and do not show change over time. Do not use pie charts:

- For exact comparisons of values. The pie shapes can be hard for people to interpret.
- For rank data. Instead, use column or bar charts.
- When proportions vary greatly.

---

## Scatter Graphs

Scatter graphs display measurements over time (one-dimensional scatterplot) or an impression of the relation between two variables (two-dimensional scatterplot). It distributes data points along one or two dimensions using a standard X-Y plot requiring two values per marker, X and Y, in that order.

Do not use a scatter graph for:

- Trends, interpolation, extrapolation, recognition, and comparison of change rates.
- More than one independent variable.

---

## Surface Graphs

Surface graphs display three dimensional data sets, where X and Y values determine the reference coordinates for Z values.

- **Surface** - The surface graph displays all data points as a surface, like a rolling wave.
- **Surface with Sides** - A variation of the surface graph, where the surfaces in the graph have solid sides.
- **Surface, Honeycombed** - A variation of the surface graph, where the surfaces in the graph have a honeycombed look.
Graphing Your Data

To create a graph, use the **New Graph Window** menu command in the **Window** menu.

Creating a Graph using the Graph Wizard

Graphing in MapInfo Pro is done through a two-step graph wizard, similar to the **Create Thematic Map** wizard. You must first open in a table MapInfo Pro before graphing its data.

To access the wizard and create a graph:

1. On the **Window** menu, click **New Graph Window**. The **Create Graph - Step 1 of 2** dialog box displays. Select the graph type and the graph template to use.

2. Click one of the graph types shown in the Graph group in the left pane. When you select a graph type, the templates for that graph type display in the Template group.

3. Choose a template from the right pane. Some graph types have several templates to choose from. Others, such as the bubble and scatter graph types, have only one template.
4. Click **Next** when you have selected a template. The **Create Graph - Step 2 of 2** dialog box displays. Select the table and the fields from the table to graph. Optionally, choose what column you want to use for your labels.

![Create Graph - Step 2 of 2 dialog box](image)

**Note:** This dialog box is the same for all graph types.

5. Choose the table you want to graph from the **Table** drop-down list. The list displays the currently open tables.

6. Choose the fields from the table you want to graph. Select a field from the Fields from Table list, and either double-click it, or highlight it (single click) and click the **Add** button. Both methods will move the field to the Fields for Graph list. Use the **Remove** button in the same way to move fields back to the **Fields from Table** list.

7. Arrange the fields in the desired order by selecting a field and using the **Up** and **Down** buttons to place it in the position you want.

   Some graph types use the first field for axis labels (bar, 3D, column), and other graph types use the order of the fields to determine X and Y values. In the case of bubble graphs, the field order also determines the Z value.

8. If applicable, select whether you want to graph your series by row or by column (this is not available for bubble, histogram, or scatter graphs).

9. Click **OK**. Your graph displays in a Graph window.
Editing a Graph

Once you create the basic graph, your ability to customize it is unlimited and depends only upon the message your graph needs to convey. You have complete control over virtually every aspect of your graph and every item in the Graph window. The customizing options available depend on the graph type you have selected.

Selecting Graph Objects

To format a graph object, select it by clicking it. When you make a graph selection, you can also select related graph objects. For example, if you click a series bar in a column graph, then all the series bars and the corresponding legend marker are selected. If you select an axis label, all the labels on that axis are selected. All selected items are altered.

If you choose an axis label, then all of the labels on that axis are selected. If you change an attribute from the Formatting dialog box, then all the selected items are affected.

Shift-click and Ctrl-click have no special meaning when selecting for formatting. When the Graph Select tool is active, Shift-click does have a special meaning.

Moving and Resizing Graph Objects

To move a graph object, click it in the Graph window and drag it to the desired location. You can move the titles, data labels, and the legend. When you click on a movable object, the cursor changes to a crosshair and you can drag the object to a new location. You cannot drag an object past the edge of the Graph window.

Note: If you move the main graph frame, then some of the other objects, like axis title labels, will move along as well.

You can resize some objects in the Graph window. If it is resizable, then handles display along the outer edge of the object you select. When you move the mouse over one of the resize handles the cursor changes shape to indicate the direction in which the object can be resized (east-west, north-south, northwest-southeast or northeast-southwest). You cannot resize an object past the edge of the graph window.

Note: When you resize the main graph frame, then some of the other objects, like axis title labels, move as the frame is resized.

To resize the legend, select it to display legend handles. Click and drag on one of the edit handles to make the legend larger or smaller.

Using the Graph Menu

The Graph menu contains all the editing options to customize your graph. When you create a graph, the Graph menu displays in the MapInfo Pro menu bar. You can also access the Graph menu options by right-clicking in the Graph window to display a shortcut menu.

Formatting Graph Objects
On the **Graph** menu, click **Formatting** to access the formatting options, which allow you to customize the line and fill patterns of your graph objects and graph titles. You can also add color gradients, different textures, and pictures to your graph. You can quickly access the **Formatting** dialog box by selecting a graph object and double-clicking in the Graph window. The formatting will apply to whatever object is selected in the Graph window. It could be the background, the titles, the axes, the graph series, graph markers, etc. The formatting options that display in the dialog box depend on what element in the Graph window is selected.

![Formatting dialog box](image)

**Layout and Display**

Go to the General Options command (on the **Graph** menu, point to **General Options**) to change the general options for the type of graph you are creating, as well as customize its display. The General tab displays options that enable you to customize the markers for the type of graph you selected. For 3D graphs, you can change the shape of the risers, and the gap between the risers. For pie graphs, you can create an exploded pie graph, as well as specify the pie’s rotation, tilt, and depth. For bubble graphs, you can customize the size and shape of the marker. In column graphs, you can customize the columns.
Modifying Axis Attributes

The Numeric Axis Grids & Scales dialog box (on the Graph menu, click Grids and Scales) is used to format graph axes, gridlines, and perform scaling. The tabs on the left of the dialog box indicate the available axes in the graph: Category Axis, Y1 Axis, Y2 Axis (for dual-axes graphs), X Axis (for bubble and scatter graphs), and Series Axis (for 3D graphs).
When you select an axis tab, the tabs at the top of the dialog box will change to reflect the available formatting options for that axis. Each axis is described in this section:

- **Category Axis** - All graph types, except bubble, histogram, and scatter graphs, have a category axis. The category axis defines the groups of items that are being graphed. When category axis labels are displayed, the labels are taken from the first row in your table.

- **Y1 Axis** - All graph types except pie graphs have a Y1 axis, or primary numeric axis. This axis plots the values from the rows and columns in your table.

- **Y2 Axis** - Area, bar, bubble, column, line, and scatter charts can be drawn on two numeric axes, Y1 and Y2. When a dual-axes graph is selected, MapInfo Pro automatically divides the number of series in half and assigns half of the series to one axis and the other half to the second axis. The two axes can be drawn up or out from the same plane/base line or physically split into two separate sections on the graph.

- **X-Axis** - Bubble, histogram, and scatter graphs include an X-axis. These graphs have two numeric axes-a Y1 axis that is drawn on the left side of the graph and an X axis that is drawn on the bottom of the graph frame.

- **Series Axis** - A series axis is included only in 3D riser and 3D surface graphs. The series axis is also called a secondary ordinal or O2 axis. In two-dimensional graphs, the series or rows of objects being graphed are shown in the legend area of the chart. In 3D graphs, these objects are shown on the series axis, which is on the lower left side of the 3D graph.

**Specifying Titles for Your Graph**

On the **Graph** menu, click **Titles** to specify titles for your graph. In the **Titles** dialog box, check the boxes next to the titles that you want to display in the graph.

![Titles dialog box](image)

The text boxes next to those titles become available. You can use the default titles or create your own. Choose from these titles:

- **Title** - Displays the main title of the graph centered over the top of the graph.
- **Subtitle** - Displays the subtitle of the graph directly underneath the main title.
• **Footnote** - Displays a note at the bottom right hand corner of the graph.

• **Category title** - Displays a title for the category axis of the graph above, below, or next to the category axis labels.

• **Value title (Y1)** - Displays a title for the primary numeric (Y1) axis of your graph. Use the title to explain what is being plotted on this axis.

• **Value title (Y2)** - Displays a title for the secondary numeric (Y2) axis of your graph. In dual-axes graphs, the primary (Y1) axis shows some of the groups in the data, and the secondary numeric (Y2) axis plots other groups of data. Use the title to explain what is being plotted on this axis.

• **X-Axis title** - Displays a title for the X-axis, where applicable. Histogram, bubble, and scatter graphs include a numeric X-axis.

• **Series Axis** - Displays series labels along the lower left side of a 3D graph. Series titles can further describe the information that is being graphed on this series axis. These titles normally correspond to the series labels displayed in the legend.

All graphs can include a title, subtitle, and footnote. Most graphs can also include a Category Axis title and a numeric Y1-Axis title. Other axis titles may be available depending on the graph type. Titles can be moved from their default positions by clicking and dragging them to the desired position. To change other elements in the title, such as the font or the text color, select the title directly in the Graph window and choose the **Formatting** command in the **Graph** menu.

**Editing a Graph Series**

You can apply formatting changes to an individual series in your graph and to the whole graph. The **Series Options** command in the **Graph** menu is available whenever a series is selected in your graph. If no series is selected, the message "No series is selected" displays.

To format an individual series:
1. Click a riser (area, bar, line, marker, pie slice, etc.) or a legend marker to select a series.
2. On the **Graph** menu, click **Series Options**. The **Series Options** dialog box displays.
3. Make changes in each of the dialog box tabs and click **OK**. You can also apply changes as you go by clicking the **Apply** button. Apply saves your changes to the graph without closing the dialog box. This enables you to see your changes in the Graph window, continue working, and experiment with options without having to close and reopen the dialog box.
4. Click **OK** when you are finished.

The options available in the **Series Options** dialog box depend on the graph type you have selected. Each of the dialog box tabs is explained briefly in this section:

- **General** - Contains general formatting options for a series for each type of graph. For instance, in 3D column graphs, you can change the riser shape; in bubble graphs and other graph types that may use markers such as line graphs, you can change the shape of the markers. In pie graphs, you can manipulate the individual pie slices. You can detach a slice from the pie, delete a slice, or restore the pie back to its original state. In many graph types, you can also display the selected series as another graph type. For example, if you create a bar graph, you can change a selected series to display as a line or an area, contrasting that series to the rest of the series in the graph.
- **Data Labels** - Specify whether you want to display data labels for the selected series and where you want to place the labels. Data labels show the actual values from your table.
- **Number** - Specify how you want to display data label numbers. You can choose from a number of categories: general, number, currency, date, time, percentage, fraction, scientific, special, and custom. This tab is available when the Data Labels box is checked in the Data Labels tab.
- **Trendlines** - Contains formatting and display options for trend lines. This tab is unavailable for 3D and pie graphs. You can display a trend line according to different types of regression: Linear, Logarithmic, Polynomial, or Exponential. You also have several other display options. You can display the equation used to create the trend line, show the coefficient values, or specify that the trend line display in the same color as the series.

**Working with Multi-Table and Multi-Variable Graphs**

This section of the chapter provides some examples of ways you can customize your graphs. The first example illustrates some of the ways you can customize a pie graph. The second example demonstrates how you can customize a 3D graph using the 3D viewing angle feature.

**Exploding a Pie Graph**

Creating a basic pie graph is easy using the **Graph** wizard. Simply select the table and the fields you want to graph. You can also graph a subset of a table, as shown in the next figure, by browsing the selection, and using the Save Copy As command to save the selection as a permanent .tab file.
The General Options for pie graphs let you manipulate the look and rotation of the pie slices easily. The left side of the dialog box shows a preview of what the finished pie graph will look like. You can change the tilt, or the angle at which you view the pie. You can give the pie a 3D look by using the Pie Depth setting.

Some of the files described in this example may refer to MapInfo Pro Tutorial data, which is available on the MapInfo web site, [http://goto.pbinsight.com/webtutorials](http://goto.pbinsight.com/webtutorials).

You can also rotate the pie or explode the pie. When you explode the pie, you detach all the slices away from the center. You can also detach an individual slice away from the pie center using the Series Options (on the Graph menu, click Series).

The following graph shows the same pie graph, based on the General Options settings.
3D Graphs - Using the 3D Viewing Angle

The 3D Viewing Angle feature displays your 3D graph at different angles, as well as customize other aspects of the graph's position, such as its rotation and position in the Graph window. The following 3D graph shows the same selection from the table that was used in the pie graph, but graphs different columns from the table. This example rotates the angle of the 3D graph and the changes the thickness of the walls of the 3D cube.
When you choose the 3D Viewing Angle option, preset angles for your graph display. You can choose one of these, or use the Advanced options to create your own angle, position, and rotation. The Advanced portion of the dialog box displays additional controls that allow you to scroll through the presets more quickly, and manipulate the angle and position of the graph manually.

Use the controls along the bottom of the graph preview to scroll through the preset viewing angles. You can also select one from the drop-down list.

**Rotating Your 3D Graph**

Use the options Rotate, Pan, Walls, and Move at the lower right of the dialog box to manipulate the graph. In the Rotate tab, you can click directly on the arrows to rotate your graph in the direction indicated by the arrow. A preview of the graph in its new position displays above. You can also rotate the graph one click at a time using the X, Y, and Z buttons.

1. Click an arrow to rotate the graph.
2. Click the X, Y, and Z arrows to rotate the graph one click.
Panning Your 3D Graph

Use the Pan tab options to move the graph across the window. Again, click directly on the arrows to move the graph in the direction indicated by the arrow, or use the X and Y buttons to move the graph one click at a time. Use the Zoom buttons to zoom the graph in and out.

Customizing Cube Walls

The Walls tab helps you change the dimensions of the 3D graph walls. You can alter the length and thickness of the walls directly using the arrow keys on the wall image on the left side of the tab, or use the X, Y, and Z buttons.

Moving Your 3D Graph at an Angle

The Move tab options are used to move the graph diagonally across the window. Click the arrows on the diagram in the Move tab to move the graph in the direction indicated by the arrow, or use the X, Y, and Z buttons. The X button moves your graph from the top left to the bottom right of the window. The Y button moves your graph from top to bottom. The Z button moves your graph from the bottom left to the top right of the window.
Above, the same graph that was shown earlier is displayed here using a different preset angle. The walls of the cube have also been removed, as well as the values for the Value Axis, in the **Display Status tab of the General Options** dialog box.

All of the **3D Viewing Angle** options have been used in this graph. The graph has been rotated about 90 degrees from the earlier example. The **Pan** and **Move** options have also been used to position the graph. And the **Walls** option has been used to increase the thickness of the floor of the cube.

**Choosing a 3D Graph Viewing Angle**

To choose a different Viewing Angle for a 3D graph:

1. Select **Graph > 3D Viewing Angle** to display the **Choose a Viewing Angle** dialog box:
   
   This dialog box shows a picture of all defined viewing angles. It may contain more or fewer viewing angle pictures depending on previous selections in the **Advanced Options** dialog box. To select one of the defined viewing angles:

2. Select a viewing angle picture.
3. Select the **Apply** button to apply the Viewing Angle to your 3D graph.
4. Select the **OK** button to exit the **Choose a Viewing Angle** dialog box.
5. Select the **Advanced Options** button to display additional viewing angle selections.
Selections in Graphs and Their Tables

Selections you make in your graphed table will also be highlighted in your Graph window. Conversely, using the new Graph Select tool, selections in the Graph window change the current selection in the graphed table.

Table Selections

In a graphed table, any selections you make in the table with the Select tool will be reflected in the corresponding Graph window as long as the selected table row or map object corresponds to an object in the graph. For example, in a bar graph, one or more of the bars will be highlighted. In a pie graph, one or more of the pie wedges will be highlighted.

The selection in the Graph window uses the same pen and brush styles that are used to highlight selected objects in the Map window.

Using the Graph Select Tool

When you select objects in a Graph window using the Graph Select tool, you also change the current selection in the graphed table. Your Graph window selection must correspond to a row in the table. Your Graph window selection will be reflected in the Map or Browser window.

To select rows in the table being graphed:

1. Click on the Graph Select tool from the Main toolbar.
2. Click on a part of the graph that corresponds to a row in the table (riser bar, pie wedge). MapInfo Pro updates the current selection.

This change is reflected in Map and Browser windows displaying the same table. If you click on an area of the graph that does not correspond to a table row, the selection is cancelled (like Query > Unselect All).

Pressing Shift in the Graph window adds or removes the target item to the selection list.

Note: For some graph types there is no relationship between the graph objects and rows in the table (for example, histogram). For these graph types the Graph Select tool is not available and the current selection will not be highlighted in the Graph window.

If you select an object in the Graph window that does not correspond to a row in the table, any other selections in the Graph window are cleared. As in other types of windows, selecting multiple objects by Shift-clicking works the same way in Graph windows-either adding the target object to, or removing it from, the selection.

Selecting graph objects with the Graph Select tool is not the same process as selecting objects in the Graph window to edit the graph object. The default mode is to select graph objects with the Select tool in order to edit them. To select graph objects for the purpose of changing the selections in the table, you must use the Graph Select tool. In some graph types, there is no relationship between the graph objects and the rows in the table, for example, histograms. The Graph Select tool is unavailable for these graph types. Selections in the Graph window will not highlight any records or map objects in the table.
Saving a Graph

Graphs are saved to workspaces. For each Graph window in the workspace, MapInfo Pro saves a uniquely named .3TF file in the same directory as the workspace. The name of the graph is:

<WORKSPACE NAME>, <WINDOW TITLE>.3TF

The <WORKSPACE NAME> is the root name of the workspace being saved and <WINDOW TITLE> is the title of the Graph window being saved. For example, if you save a workspace named "MY WS.WOR" and it contains a Graph window with the title, "Scatter Graph," MapInfo Pro creates the graph file "MY WS, SCATTER GRAPH.3TF" in the same directory as the original workspace, "MY WS.WOR."

Using Graph Templates

MapInfo Pro stores the various graph template files in folders in the GraphSupport directory. The GraphSupport directory is located in the MapInfo Pro directory by default in versions 6.0 and earlier. In MapInfo Pro 7.5 files are stored on a per-user basis. Other support files containing numerous kinds of fill patterns, as well as the 3D viewing angle files, that help you format your graph are also located in this directory.

Each type of support file stored in the GraphSupport directory is listed in the next table, according to the name of the folder in which the files are stored:

<table>
<thead>
<tr>
<th>Folder Name</th>
<th>File Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D Viewing Angles</td>
<td>Files correspond to the preset viewing angles available in the 3D Viewing Angle dialog box (on the Graph menu, click 3D Viewing Angle).</td>
</tr>
<tr>
<td>Gradients</td>
<td>Files correspond to the preset gradients available in the Choose Gradient dialog box (on the Graph menu, point to Formatting and click Fill tab).</td>
</tr>
<tr>
<td>Pictures</td>
<td>Files correspond to the pictures available in the Choose Picture dialog box (on the Graph menu, point to Formatting and click Fill tab).</td>
</tr>
<tr>
<td>Folder Name</td>
<td>File Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>Templates</td>
<td>Contains the available graphing templates listed in the Graph wizard (Create Graph - step 1 of 2 dialog box).</td>
</tr>
<tr>
<td>Textures</td>
<td>Files correspond to the textures available in the Choose Gradient dialog box (on the Graph menu, point to Formatting and click Fill tab).</td>
</tr>
</tbody>
</table>

**Location Preferences**

Using the Directory preferences, you can change the location where MapInfo Pro looks for all the support files. To do so:

1. On the Options menu, point to Preferences and click Directories. The Directory Preferences dialog box displays.
2. In the Initial Directories for File dialog boxes group, select Graph Support Files.
3. Click Modify. The Choose Directory dialog box displays. It shows the current location of the Graph Support files. Navigate to the directory where you want to store the files, and click OK. The new location of the files displays in the Initial Directories list.
4. Click OK to close the Directory Preferences dialog box.

Although the location of the GraphSupport directory can be changed, the names and locations of the support file folders inside the GraphSupport directory cannot. MapInfo Pro looks in the GraphSupport directory specifically for the appropriate support folders and files as listed above.

**Saving a Graph Template**

You can easily add to the available set of templates when you create a graph by saving an existing Graph window as a template file. For example, you prefer the legend to display on the left side of the Graph window instead of on the right (the default position). You can make this modification in the Graph window and then on the Graph menu, click Save As Template.

To save a graph as a template:

1. Make the modifications in the Graph window that you would like to save as a template.
2. On the Graph menu, click Save As Template. The Save Graph Template dialog box displays. It shows the template folder that corresponds to the type of graph you are saving as a template.
3. Name your graph template and click Save.

The next time you create a Graph window, the saved template file will be available in the Graph wizard for that graph type.

**Note:** You can save a template file to a location other than the GraphSupport\Templates directory; however, it will not be available unless you save it to a folder in the Templates directory.
MapInfo Pro lets you access data where it lives, on your machine or on the network, in flat files, such as Microsoft Excel files or MapInfo Pro native (.tab) files, in a Database Management System (DBMS), or from a web service.

This section addresses the special circumstances that surround accessing data from a SQL Server, Oracle Spatial, or PostgreSQL with PostGIS database for use with MapInfo Pro, which requires setting up a database connection.

This section also discusses how to set up your connection to Microsoft Access.

For database versions that MapInfo Pro supports, see the *MapInfo Pro Install Guide*.

**In this section**

- Getting Started 180
- Creating a Data Source Connection 182
- Reconnecting to your Data Source after Startup 190
- About Supported DBMS Data Types 193
- Creating a Map Catalog in the DBMS to Work with Data 197
- Adding a Spatial Primary Key to a DBMS Table 199
- Making a DBMS Table Mappable to Display it on a Map 201
- Deciding to work with Linked or Live Access Tables 204
- Opening a DBMS Table in MapInfo Pro 206
- Working with Remote Tables from Specific Databases 216
Getting Started

To access data from a DBMS, you need to set up a connection to it. In addition, any DBMS tables that contain spatial data that you want to see on a map must have a record created for them in a special table called the MapInfo Map Catalog. This record contains information about the spatial data. The process of creating this record is called "making the table mappable". An overview of the setup process is provided under Overview of the DBMS Access Setup Process.

You can access the following types of spatial database servers. To locate the version numbers that MapInfo Pro supports, see the MapInfo Pro Install Guide.

- Microsoft SQL Server (also called SQL Server Spatial)
- Microsoft SQL Server with SpatialWare
- Oracle Spatial
- PostgreSQL with PostGIS

You can work with point and textual data from:

- Microsoft Access
- Any Open Database Connectivity (ODBC) database

This document refers to accessing data from a DBMS or a web service as "remote data access".

**Note:** You can access ESRI SDE and Geo databases in read-only mode through Open Universal Data, see Displaying your ESRI Shapefile Data.

Overview of the DBMS Access Setup Process

**Install a Database Driver**

Access to a database server is through a DBMS driver, which you install on to your machine and is specific to the DBMS you want to connect to. A driver allows MapInfo Pro to connect to the database. Each type of database supplies its own driver. You may need to obtain the driver from your database administrator and have your database administrator help you set up properties for the driver after installing it.

For the version numbers that MapInfo Pro supports, see the MapInfo Pro Install Guide.

**Prepare your Connection and Database**

To work with your DBMS data in MapInfo Pro, you need to set up your database connection by following the steps in the sections:

1. **Creating a Data Source Connection**

   There may be prerequisites, in addition to installing a driver, that you need to connect and work with a database. Each of the following sections provides details:
Creating a Data Source Connection to SQL Server
Creating a Data Source Connection to PostGIS
Creating a Data Source Connection to Oracle

When you connect to a data server, you will have two choices: to use windows authentication or to provide a username and password unique to the data server. Windows authentication is the username and password you use to log in to your network. Depending on how your database server is set up, you may only require your windows authentication to log in. Otherwise, you would provide a username and password that is unique to the server. Your database administrator will tell you whether or not you can use your windows authentication or a username and password specific to the server.

2. Creating a Map Catalog in the DBMS to Work with Data

Your database administrator may need to grant you specific access privileges to the database to work with the data. The following section gives details:

• Before you Begin Creating a Map Catalog Table.

3. Adding a Spatial Primary Key to a DBMS Table

To view your data on a map in MapInfo Pro it must contain geometry data (polygon regions) or X and Y data (coordinates, such as Latitude and Longitude values). This is what displays on the map as regions or points. The geometry column or X and Y columns must have specific names for MapInfo Pro to recognize them, and the table requires a unique spatial primary key for MapInfo Pro to reference the data on a map.

4. Making a DBMS Table Mappable to Display it on a Map

Access your Data

After setting up your database connection, you are ready to work with your data in MapInfo Pro, see Opening a DBMS Table in MapInfo Pro.

For details, see:

• Working with SQL Server Tables
• Working with PostGIS Tables
• Working with Oracle Spatial Tables

If your data includes spatial data, which can be columns holding X and Y values, such as Latitude/Longitude, or a column holding spatial data in the format specified by the database system. With no spatial information, you can work with your data in a table browser (a Browser window) in MapInfo Pro.

If your data does not include coordinate information, then consider geocoding, adding the coordinate information, using a Pitney Bowes Software product, such as MapMarker or Spectrum.
Requirements

When accessing remote data sources:

• The table you access must have a spatial column or two numeric columns to hold X and Y coordinate values.
• The view must have a key column named MI_PRINX to make the view mappable.

PostGIS users: MapInfo Pro treats all views in a PostGIS database as read only, because there is no way to determine if the view can be used for update.

Creating a Data Source Connection

The first step to working with data in a DBMS is setting up a data source connection on your machine to the DBMS. This is necessary for a DBMS installed on to your machine or on the network. SQL Server and PostGIS require an Open Database Connectivity (ODBC) connection and Oracle Spatial requires an Oracle Call Interface (OCI) connection.

Note: Use an OCI connection to Oracle for spatial data. You can use an ODBC connection to any ODBC compatible database and to older versions of Oracle with non-spatial data.

You must have the ODBC driver or OCI installed on your machine before creating a data source connection. MapInfo Pro installs or updates Windows ODBC drivers if they are older than the version that MapInfo Pro supports. For non-Windows databases, such as Oracle and PostgreSQL with PostGIS, consult with your database administrator for information on how to obtain and install the driver provided with your database.

You can create a data source connection:

• Through MapInfo Pro's interface.
• Through EasyLoader's interface, see the EasyLoader User Guide.
• From your Microsoft Start menu, by selecting Start > Control Panel > Administrative Tools > Data Sources (ODBC).

You must set up a data source connection for each DBMS that you plan to work with.

Creating a Data Source Connection to SQL Server

Before you begin, you need a SQL Server driver installed on your machine. Check with your database administrator to install the driver for your database.

You need to know the SQL Server name, and the login ID and password if required.

To create a new SQL Server data source connection:
1. From the File menu, select Open DBMS Connection.
2. If the Open DBMS Connection dialog box displays, select ODBC from the list and then click New.

3. In the Select Data Source dialog box, select either the File Data Source or the Machine Data Source tab and then click New.

You can share the connection information for a file data source with other users on the network if they have the necessary drivers, because it is stored in a file. You cannot share the connection information for a machine data source, because it is stored in the registry on the local computer.

4. In the Create New Data Source wizard:
a. Select the type of data source to create: **User Data Source** or **System Data Source**. Make a selection to display the description for it in the wizard. Click **Next** to continue.

b. From the driver name list, select the **SQL Server** driver you have installed for the database and then click **Next**.

c. Click **Finish**.

5. In the **Create a New Data Source to SQL Server** wizard set the following. If you are unsure of the settings to use for your database, consult with your database administrator.

a. In the first screen provide the following information:

   **Description** - Optionally, type a description if you plan on connecting to more than one database and would like a description for this connection.

   From the **Server** list either select from the list or type the name of the SQL Server to connect to.

   Click **Next**.

b. In the next screen, select how SQL Server will verify the authenticity of the login ID.

   Optionally select to connect to SQL Server to obtain default settings for more configuration options.

   Click **Next**.

c. Keep the default settings (check with your database administrator) and click **Next**.

d. Keep the default settings (check with your database administrator) and click **Finish**.
6. In the ODBC Microsoft SQL Server Setup dialog box, click Test Data Source.
7. In the SQL Server ODBC Data Source Test dialog box, click OK.
   If there were errors, click OK to return to the ODBC Microsoft SQL Server Setup dialog box. Click Cancel to return to the Create a New Data Source to SQL Server wizard and use the Back button to view your settings and make changes. Return to step 5.

8. In the ODBC Microsoft SQL Server Setup dialog box, click OK.
9. In the Select Data Source dialog box, under the Machine Data Source tab, your new SQL Server connection displays in the list of available data source connections. Click OK.
10. In the SQL Server Login dialog box, type your login ID and password if required and click OK.

You must now create a map catalog for the database, continue to Creating a Map Catalog Table Using EasyLoader.

Creating a Data Source Connection to PostGIS

Before you begin, you need a PostgreSQL ANSI ODBC driver (psqlODBC) installed on your machine. Check with your database administrator to install the driver for your database. Ensure that your database administrator adds your machine IP address to the pg_hba.conf file for the database you want to connect to.

You need to know the database name, server name, username and password to the database, and whether or not you need a specific SSL Mode or Port number.

To create a new PostgreSQL PostGIS data source connection:

1. From the File menu, select Open DBMS Connection.
2. If the Open DBMS Connection dialog box displays, select ODBC from the list and then click New.
3. In the **Select Data Source** dialog box, select either the **File Data Source** or the **Machine Data Source** tab and then click **New**.

You can share the connection information for a file data source with other users on the network if they have the necessary drivers, because it is stored in a file. You cannot share the connection information for a machine data source, because it is stored in the registry on the local computer.

4. In the **Create New Data Source** wizard:
   a. Select the type of data source to create: **User Data Source** or **System Data Source**. Make a selection to display the description for it in the wizard. Click **Next** to continue.
   b. From the driver name list, select the **PostgreSQL ANSI** driver and then click **Next**.
   c. Click **Finish**.
5. In the PostgreSQL ANSI ODBC Driver (psqlODBC) Setup dialog box, set the following. If you are unsure of the settings to use for your database, consult with your database administrator.

- **Data Source** - Provide a name for this data source. This is the name you will see after setting up this connection in the Select Data Source dialog box.
- **Database** - The name of the PostGIS database that you want to connect to.
- **Server** - The name of the machine where PostGIS is installed.
- **User Name** - The username for accessing the database.
- **Password** - The password for accessing the database.
- **Description** - Optionally, type a description if you plan on connecting to more than one database and would like a description for this connection.
- **SSL Mode** - Use the default value.
- **Port** - Use the default value.

Click **Test** to ensure that your connection works.

Click **Datasource** (or **Connection** depending on the PostGIS driver).

6. In the Advanced Options dialog box, select the **Use Declare/Fetch** check box and then click **OK**.

Selecting this option improves the processing time when connecting to larger databases.

7. In the PostgreSQL ANSI ODBC Driver (psqlODBC) Setup dialog box, click **Save** to set your connection.

8. In the Select Data Source dialog box, under the Machine Data Source tab, your new PostGIS connection displays in the list of available data source connections. Click **OK**.

You must now create a map catalog for the database, continue to **Creating a Map Catalog Table Using EasyLoader**.
Creating a Data Source Connection to Oracle

Before you begin, you will need the following installed on your machine:

• Oracle Client - connects to an Oracle database.
• TCP/IP - a communications protocol required by Oracle Client to communicate on the network
• Oracle SQL*Net - for performing SQL queries to the database (optional).

Have your database administrator check that the:

• tnsnames.ora file is correctly configured on your machine for the server you want to connect to.
• Service to the database is configured-they may need to run the Net Configuration Assistant utility that Oracle provides to configure the service.
• TCP/IP working properly (using ping.exe).
• Environment variable TNS_ADMIN is correctly set to your client_1 path (the Oracle Client installation directory).

To create a new Oracle Spatial data source connection, set up your Oracle Driver:

1. On the Start menu, point to All Programs, click Oracle..., click Configuration and Migration Tools, and then click Microsoft ODBC Administrator.
2. In the ODBC Data Source Administrator, under the User DSN tab, click Add.
3. In the Create New Data Source wizard:
   a. From the driver name list, select the Oracle in OraClient driver and then click Next.
   b. Click Finish to install the driver.
4. In the ODBC Text Setup dialog box, set the following:
   • Data Source Name - Provide a name for this data source. This is the name you will see after setting up this connection in the Select Data Source dialog box.
   • Description - Optionally, type a description if you plan on connecting to more than one database and would like a description for this connection.

   Click OK.

To set up your Oracle Spatial connection in MapInfo Pro:

1. From the File menu, select Open DBMS Connection.
2. In the Open DBMS Connection dialog box, select Oracle Spatial from the list and then click New.
3. In the MapInfo Oracle Connect dialog box enter the following information:
   • User Name - The username for accessing the database.
   • Password - The password for accessing the database.
   • Server Name - The name of the Oracle database that you want to connect to.

   Optionally, check the Use Operating System Authentication check box to use your Windows authentication when accessing this Oracle database.
You have an active connection to your Oracle database. You must now create a map catalog for the database, continue to Creating a Map Catalog Table Using EasyLoader.

In the MapInfo Oracle Connect dialog box, you have the option to check the Use Operating System Authentication check box. With OS authentication, your database relies on the underlying operating system to restrict access to database accounts. A database password is not used for this type of login. For additional information, refer to Oracle Operating System Authentication and Configuration.

Creating a Data Source Connection to Microsoft Access

You can work with your Microsoft Access database from MapInfo Pro through an ODBC connection. Microsoft Access does not allow spatial data, but you can display in MapInfo Pro data that has X and Y coordinate values associated with it.

Before you Begin

Before you begin, you must have the Microsoft Access Driver installed on your machine-the driver is installed by default with your Microsoft Access. The driver is necessary for establishing an ODBC connection to the data source.

To check that the driver is installed on your machine, run the ODBC Administrator:

1. Open the Control Panel; from the Start menu select Control Panel.
2. In the Control Panel, in the Classic View, select Administrative Tools and then Data Sources ODBC (ODBC).
3. In the Data Sources ODBC Administrator dialog box, select the User DSN tab.
4. In the list, locate and select the MS Access Database. Or, if you do not see this name, then under the Driver list look for Microsoft Access Driver (.mdb or .accdb).
5. Click Configure to ensure that it is properly set up.

If the driver is not there, then click Add to check if the Access driver is installed. You may need to install the Microsoft Access drivers. These are included with Microsoft Access, Microsoft Office Professional, ODBC SDK, Visual C++, MapInfo Pro, or purchased separately.

To verify if this is the required version of this driver, select the Drivers tab in the ODBC Administrator. Locate the MS Access Driver (.MDB or .ACCDB) and check that it is the latest version.

To add a new Microsoft Access Data Source:

1. Run the ODBC Administrator.
2. Under the User DSN tab, click Add.
3. In the Create New Data Source wizard, select MS Access Driver (.MDB or .ACCDB) from the list and click Finish.
4. In the **ODBC Microsoft Access Setup** dialog box, in the **Data Source Name** box, type in a name for the data source. (This is the name that appears in the list when you connect from MapInfo Pro.) Click **Select**.

5. In the **Select Database** dialog box, select the Microsoft Access database you wish to use and then click **OK**.

   If you do not select a database for this data source, a prompt displays during the connection to do so. MapInfo Pro provides a sample Microsoft Access database.

**Limitation**

in Microsoft Access, if the key is set to character, then it does not display rows when the key value is less than the full column width: for example, if the key is set to char(5), then the value `aaaa` looks like a deleted row.

---

### Reconnecting to your Data Source after Startup

Each time you start MapInfo Pro, you must set the connection to your database before you can work with tables. The connection remains active while MapInfo Pro is open. The connection closes when you exit MapInfo Pro.

The following instructions are applicable to SQL Server and PostGIS users. **Oracle** users, see [Connecting to Oracle after Re-Starting MapInfo Pro](#).

To open a connection to your database:

1. From the **File** menu, select **Open DBMS Connection**.
2. If the **Open DBMS Connection** dialog box displays, select **ODBC** from the list and then click **New**.
3. In the **Select Data Source** dialog box:
   a. Select the **Machine Data Source** tab.
   b. From the Data Source name list, select your connection name.
   c. Click **OK**.

   You may see a login dialog box for your database connection. If you see this dialog, then provide the information required, such as user name and password for the database. For example, SQL Server users may see the following:
You are now ready to open a table. To do this, select File > Open and then from the Files of type list, select your data source name from the list to display the table in your database.

Connecting and Opening a Table at the Same Time

To open a connection to your database and then open a table in the database:

1. From the File menu, select Open.
2. In the Open dialog box, select the Open DBMS Connection button.
3. If the Open DBMS Connection dialog box displays, select ODBC from the list and then click New.
4. In the Select Data Source dialog box:
   a. Select the Machine Data Source tab.
   b. From the Data Source name list, select your connection name.
   c. Click OK.

You may see a login dialog box for your database connection. If you see this dialog, then provide the information required, such as user name and password for the database. For example, SQL Server users may see the following:
5. In the Open dialog box schema and tables in your database display. If you do not see this, then from the Files of type list, select your data source name.
   
   Select the table to open from the list and click Open.
   
   You are now ready to work with your table.

Connecting to Oracle after Re-Starting MapInfo Pro

To open a connection to your Oracle database:

1. From the File menu, select Open DBMS Connection.
2. In the Open DBMS Connection dialog box, select Oracle Spatial from the list and then click New.
3. In the MapInfo Oracle Connect dialog box enter the following information:
   
   - **User Name** - The username for accessing the database.
   - **Password** - The password for accessing the database.
   - **Server Name** - The name of the Oracle database that you want to connect to.

   Click OK.
   
   You are now ready to open a table. To do this, select File > Open and then from the Files of type list, select Oracle to display the table in your Oracle database.

Connecting to Oracle and Opening a Table at the Same Time

To open a connection to your Oracle database and then open a table in the database:

1. From the File menu, select Open.
2. In the Open dialog box, select the Open DBMS Connection button.
3. In the Open DBMS Connection dialog box, select Oracle Spatial from the list and then click New.
4. In the MapInfo Oracle Connect dialog box:
   
   - **User Name** - The username for accessing the database.
   - **Password** - The password for accessing the database.
   - **Server Name** - The name of the Oracle database that you want to connect to.

   Click OK.
   
   5. In the Open dialog box schema and tables in your Oracle database display. If you do not see this, then from the Files of type list, select Oracle or your data source name.

   Select the table to open from the list and click Open.
   
   You are now ready to work with your Oracle table.
About Supported DBMS Data Types

This section provides a list of supported data types and any data restrictions for SQL Server, PostGIS, and Oracle.

SQL Server Data Support

**Read-Only Support for Spatial Objects in SQL Server with Z and M Values**

Spatial data that is stored in SQL Server Spatial Geometry and Geography field types may have Z and M values. MapInfo Pro cannot edit this type of spatial data and ignores the Z and M values, so you must view these tables as read-only in MapInfo Pro. If you edit this type of spatial data in MapInfo Pro, saving the table back to the original SQL Server Spatial table does not preserve the original Z and M values.

The MapInfo_MapCatalog has the following spatial types for tables with Z and M values:

- 20 - Geometry read-only support of objects with Z/M values.
- 21 - Geography read-only support of objects with Z/M values

**Supported SQL Server ODBC Data Types**

These are the ODBC data types that MapInfo Pro supports:

- SQL_BIT
- SQL_TINYINT
- SQL_SMALLINT
- SQL_INTEGER
- SQL_REAL
- SQL_BIGINT
- SQL_DECIMAL
- SQL_DOUBLE
- SQL_FLOAT
- SQL_NUMERIC
- SQL_BINARY
- SQL_LONGVARBINARY
- SQL_VARBINARY
- SQL_LONGVARCHAR
- SQL_DATE
- SQL_TYPE_DATE
- SQL_TIMESTAMP
- SQL_TYPE_TIMESTAMP
PostGIS Data Support

Supported PostGIS Column Types
MapInfo Pro supports all data types. Please note that PostGIS is case sensitive.

Oracle Data Support

Working with Oracle Spatial Data
MapInfo Pro uses Oracle Spatial for Oracle tables (XY is supported via OCI). MapInfo Pro does not support HH_CODE (and the old version of SDO index types).

Supported Oracle Data Types
The following lists non-spatial data types from Oracle Spatial and what they are treated as in MapInfo Pro:

<table>
<thead>
<tr>
<th>From Oracle</th>
<th>to MapInfo Pro</th>
</tr>
</thead>
<tbody>
<tr>
<td>RAW, LONG RAW</td>
<td>BinaryString up to 127 bytes shown as Hex characters</td>
</tr>
<tr>
<td>Named type</td>
<td>MIObject</td>
</tr>
<tr>
<td>Named Object type (SDO_GEOM)</td>
<td>MIObject</td>
</tr>
<tr>
<td>BLOB, CLOB</td>
<td>Not Supported</td>
</tr>
<tr>
<td>CHAR, VARCHAR, LONG, LONG VARCHAR</td>
<td>Character</td>
</tr>
<tr>
<td>Number, Decimal</td>
<td>if no scale or precision: Float else Decimal</td>
</tr>
<tr>
<td>INTEGER</td>
<td>Integer</td>
</tr>
</tbody>
</table>
MapInfo Pro captures many Oracle data types and translates them into MapInfo native types. When the column is updated, Oracle data makes sure that the data being bound is translated into the column format (for example, MapInfo Pro can bind a character as a long and send it through to Oracle and on the other end it will be translated into a long number in the table).

**Spatial Object Types from Oracle Spatial to MapInfo Pro**

<table>
<thead>
<tr>
<th>From Oracle: GTYPES</th>
<th>to MapInfo Pro</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 UNKNOWN_GEOMETRY (Spatial ignores this geometry.)</td>
<td>NULL</td>
</tr>
<tr>
<td>1 POINT Geometry contains one point.</td>
<td>Point</td>
</tr>
<tr>
<td>2 LINestring Geometry contains one line string.</td>
<td>Line (if only 2 pts) or Polyline if &gt; 2 pts</td>
</tr>
<tr>
<td>3 POLYGON Geometry contains one polygon.</td>
<td>Region</td>
</tr>
<tr>
<td>4 Collection Geometry is a heterogeneous collection of elements.</td>
<td>Collection</td>
</tr>
<tr>
<td>5 MULTIPOINT Geometry has multiple points.</td>
<td>MultiPoint</td>
</tr>
<tr>
<td>6 MULTILINESTRING Geometry has multiple line strings. Poly-line</td>
<td>Region</td>
</tr>
<tr>
<td>7 MULTIPOLYGON Geometry has multiple polygons (more than one exterior boundary).</td>
<td>Region</td>
</tr>
</tbody>
</table>
**Geometry Conversions from Oracle Spatial to MapInfo Pro**

The following lists Oracle Spatial geometry types and what they convert to in MapInfo Pro.

<table>
<thead>
<tr>
<th>Geometry Type</th>
<th>Converted to MapInfo Type</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Circular Arc</td>
<td>Polyline</td>
<td>Circular Arcs are made up of three coordinates, starting point, any point on the arc, and ending point. MapInfo Pro will use these three points to form a polyline representing the arc.</td>
</tr>
<tr>
<td>Circle</td>
<td>Region</td>
<td>Circles are made up of three coordinates on the circumference of the circle. MapInfo Pro will use these three points to form a circular region.</td>
</tr>
<tr>
<td>Rectangle</td>
<td>Region</td>
<td></td>
</tr>
<tr>
<td>MULTIPOINT</td>
<td>Multipoint</td>
<td></td>
</tr>
<tr>
<td>COLLECTION {Point (cluster), Line String, Multiple Line String, Polygon, Multiple Polygon}</td>
<td>Collection {Multipoint, Polyline, Region}</td>
<td></td>
</tr>
<tr>
<td>Unknown or invalid geometries or user defined.</td>
<td>Null Object</td>
<td>Oracle currently does not have a mechanism to check the validity of objects. MapInfo Pro will perform some geometry checks. If MapInfo Pro detects an invalid or an unknown geometry, it will return a null object to prevent errors. No error message will display to notify users of the null geometries.</td>
</tr>
</tbody>
</table>

MapInfo Pro can download some or all of an Oracle Spatial table through either a spatial query or attribute query.

**Note:** To select a Multipoint object within a region (for example, Select Object within Selection), the first point of the Multipoint object must be within the region. Otherwise, the Select statement fails. The same rule applies to Collections containing Multipoint objects. Lines and Polygons in Collections should work correctly.
Creating a Map Catalog in the DBMS to Work with Data

MapInfo Pro stores information about spatial tables and views in the database. It stores this information in a file called MAPINFO.MAPINFO_MAPCATALOG (the Map Catalog) as a special table on the DBMS you are accessing.

The MAPINFO_MAPCATALOG is a registry table for databases that stores metadata about spatial tables and views in the database. Using the tablenname and ownername as the key, the MAPINFO_MAPCATALOG identifies the spatial type, spatial columns (if there is more than one), projection, data bounds, and rendition information. The MAPINFO_MAPCATALOG is used by a number of MapInfo products, including MapInfo Pro, that access map data from databases.

There must be one catalog per database, which is required before mapping any tables on that database in MapInfo Pro.

Before you Begin Creating a Map Catalog Table

You will use EasyLoader to create a Map Catalog table in the database you wish to work with. EasyLoader installs with MapInfo Pro.

Note: EasyLoader is also available as a free download from the Pitney Bowes Software website. If you download a copy of EasyLoader, then you must ensure that you have the same version of EasyLoader as MapInfo Pro to use them together.

Before you begin, you must alert your database administrator to the following:

• You require administrator privileges to read and write to the database server. Even if you only read tables on the server, you still require write access to have EasyLoader create and then have MapInfo Pro write to the Map Catalog table.
• EasyLoader creates a MAPINFO schema at the server level while creating the Map Catalog table.
• EasyLoader creates a MAPINFO user for the database.

Your database administrator may want to manually set up your database access, thus bypassing the need to use EasyLoader. If your database administrator wants to create the Map Catalog table manually.

Instructions are available in the MapInfo Pro Help System under Manually Creating a MapInfo_MapCatalog.

Creating a Map Catalog Table Using EasyLoader

EasyLoader installs with MapInfo Pro as a tool, but you can run it separately from MapInfo Pro. It lets you create a data source connection and create a map catalog in the database.
To create a Map Catalog table using EasyLoader:

1. Load EasyLoader as a tool in MapInfo Pro:
   a. On the **Tools** menu, click **Tool Manager**.
   b. In the **Tool Manager** dialog box, select the **Loaded** check box next to the EasyLoader tool.
      To have the tool load automatically every time you start MapInfo Pro, select the **Autoload** check box next to the tool.
   c. Click **OK**.

2. Run EasyLoader from the **Tools** menu, select **Tools > EasyLoader > EasyLoader**.
   EasyLoader opens, proceed to the following section that applies to you.

**SQL Server and PostGIS users:**

1. Click **ODBC**. In the **Select Data Source** dialog box, select the **Machine Data Source** tab. From the Data Source name list, select your connection name, and click **OK**.
   You may see a login dialog box for your database connection. If you see this dialog, then provide the information required, such as user name and password for the database.

2. Click **Map Catalog** to add a new Map Catalog. One of two things happens:
   • If there is no Map Catalog available for the current database, EasyLoader creates a MAPINFO user if one does not already exist and then creates the Map Catalog. This concludes the Map Catalog creation process.
   • If there is a Map Catalog, the **Unregister tables from Map Catalog** dialog box displays. Close this dialog box. There is already a map catalog in this database.
      **Note:** If the Map Catalog is present and there are no entries in it, then the **Map Catalog** button does not enable.

3. Click **Close** to close EasyLoader.

**Oracle users:**

1. Click **Oracle Spatial**. In the MapInfo Oracle Connect dialog box set the following and then click **OK**:
   • **UserName** - The username for accessing the database.
   • **Password** - The password for accessing the database.
   • **Server Name** - The name of the Oracle database that you want to connect to.

2. Click **Map Catalog** to add a new Map Catalog. One of two things happens:
   • If there is no Map Catalog available for the current database, EasyLoader creates a MAPINFO user if one does not already exist and then creates the Map Catalog. This concludes the Map Catalog creation process.
   • If there is a Map Catalog, the **Unregister tables from Map Catalog** dialog box displays. Close this dialog box. There is already a map catalog in this database.
Note: If the Map Catalog is present and there are no entries in it, then the Map Catalog button does not enable.

3. Click Close to close EasyLoader.

Adding a Spatial Primary Key to a DBMS Table

After establishing a data source connection to your DBMS you must add a geometry reference to the tables you wish to work with on a map in MapInfo Pro. Each table that you want to work with must contain geometry, such as regions, or X,Y point data, with correctly named columns and a unique primary key column that is indexed and defined with a specific name.

If you attempt to work with a DBMS table that does not contain a spatial primary key column and does not have geometry and X,Y columns correctly labeled, then you may see the following error:

Unable to download only the OBJECT from a DBMS table. Select an additional attribute column.

To have MapInfo Pro prepare a table for you:

1. Open the table in MapInfo Pro, select File > Open and then locate and select the table from the Open dialog box.
2. Select File > Save Copy As and save a copy back to the DBMS.

This saves a copy of the table with a unique primary key column that is indexed and in the correct format. This process also asks you for your spatial geometry column or your X,Y columns in the table and then renames these columns, so that MapInfo Pro can work with them.

You are now ready to begin working with the data in MapInfo Pro in tabular form (in a Browser window). For details on what changes are made to column names, see Adding a Spatial Primary Key Manually.

If you want to convert your table to the MapInfo Pro native .TAB format to work with it, then use EasyLoader, which will also rename your geometry or point columns and add a spatial primary key column to the table.

Adding a Spatial Primary Key Manually

To have full control over renaming geometry or point columns and add a spatial primary key column to one or more tables, you can do this manually. If you choose to update your tables yourself, then you must make the following changes:

Geometry Data Tables
If you are working with a spatial table containing geometry (such as regions), the geometry column must be named SP_GEOMETRY. The following table is a summary of what is required for geometry data tables (note that Microsoft Access does not support geometry data, only point data):

<table>
<thead>
<tr>
<th>DBMS or Data Source</th>
<th>Primary Key Column</th>
<th>Geometry Column Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Oracle, PostGIS, SQL Server Spatial</td>
<td>MI_PRINX</td>
<td>SP_GEOMETRY</td>
</tr>
</tbody>
</table>

- If working with a database table, then MapInfo Pro finds the correct primary index column (this column must be a numeric type).
- If working with a database view, then it must have a column named MI_PRINX that is unique and numeric.

**X,Y Point Data Tables**

If you are working with a spatial table containing X,Y data (such as Latitude and Longitude), the X and Y columns must be named MI_SQL_X and MI_SQL_Y. The table must also have a unique primary key column that is indexed and named MI_SQL_REC_NUM.

<table>
<thead>
<tr>
<th>DBMS or Data Source</th>
<th>Primary Key Column</th>
<th>X Column Name</th>
<th>Y Column Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access, Oracle, PostGIS, SQL Server Spatial, SQL Server with SpatialWare</td>
<td>MI_SQL_REC_NUM</td>
<td>MI_SQL_X</td>
<td>MI_SQL_Y</td>
</tr>
</tbody>
</table>

To use different names for these columns, specify the name of the X, Y and spatial object columns in the MapCatalog.

**SQL Server with SpatialWare Tables**

If you are working with SQL Server with SpatialWare installed, the column naming convention is different from other spatial DBMS tables. You must use SW_MEMBER for the unique primary key column that is indexed, and SW_GEOMETRY for the geometry column.

<table>
<thead>
<tr>
<th>DBMS or Data Source</th>
<th>Primary Key Column</th>
<th>Geometry Column Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL Server with SpatialWare</td>
<td>SW_MEMBER</td>
<td>SW_GEOMETRY</td>
</tr>
</tbody>
</table>

If your table contains X,Y data, then the column names must be MI_SQL_X and MI_SQL_Y.
Making a DBMS Table Mappable to Display it on a Map

After establishing a data source connection to your DBMS and adding a geometry reference to the tables you wish to work with, you can begin working with the data in MapInfo Pro in tabular form (in a Browser window). To view the data on a map in MapInfo Pro, you must correctly name the spatial data geometry or X,Y columns and then make the table mappable.

Before making a table mappable, review the instructions under Creating a Map Catalog in the DBMS to Work with Data and Adding a Spatial Primary Key to a DBMS Table.

MapInfo Pro’s Make Table Mappable menu option makes a database table (DBMS table) viewable on a Map window in MapInfo Pro. Any table may display in a Browser window, but only mappable tables can display in a Map window.

Making a table mappable provides MapInfo Pro with information about the table:

- The column containing the spatial data (not applicable to relational Oracle SDO)
- The projection system of the table
- The symbol to use for all objects without a per row style
- The column in the table to use for per row styles
- The object type
- The table bounds, which informs MapInfo Pro of the entire extent of the data (used by View and Entire Layer for example)

MapInfo Pro takes this information and stores it in a table called the MapInfo_MapCatalog. Every time you use a DBMS table MapInfo Pro checks the catalog to see if the table is mappable. As a result, you only have to make a DBMS table mappable once. It will always remain mappable.

Making a Table Mappable

Use the Make Table Mappable menu option only for tables that you did not previously upload with EasyLoader, or save to the database through MapInfo Pro.

Before you begin, you must have a data source connect to the database containing the table to map. For instructions, see Creating a Data Source Connection.

To make a table mappable:

1. From the Table menu, select Maintenance > Make DBMS Table Mappable.
2. In the Select DBMS Table dialog box, select the DBMS table you want to make mappable and click Open.
3. In the Make Table Mappable dialog box, select from the options and then click OK to make the table mappable. For option descriptions, see Make Table Mappable dialog box Options.
4. A message dialog displays to tell you that the table has been made mappable. Click OK.
5. The Select DBMS Table dialog displays. Select the table to make mappable and click **Open**. Click **Cancel** if you do not want to make tables mappable.

After making a table mappable, you are ready to begin working with it in MapInfo Pro. Continue to:

- **Working with SQL Server Tables**
- **Working with PostGIS Tables**
- **Working with Oracle Spatial Tables**

**Make Table Mappable dialog box Options**

**Index Type**

Select the spatial index type of the column that has the spatial information in the DBMS table. The spatial index provides a fast way for MapInfo Pro to access the spatial data in the table. The seven index types to choose from are SpatialWare, Oracle Spatial, Oracle Annotation Text, SQL Server Spatial, PostGIS Spatial, MapInfo Pro, and XY Coordinates. (You use the XY Coordinates option when there is no index.)

**Index Column**

Required for all index types except **XY Coordinates**. Choose the name of the spatial column, or in the case of a MapInfo Pro index type, choose the name of the MICODE column.

**X Coordinate, Y Coordinate**

Required only if you chose the XY Coordinate or MapInfo Pro index type. Choose the X and Y columns that contain the point data you wish to map.

**Object Type**

For spatial databases, select point, linear, or region object types. (Defaults to point object type for MapInfo Pro and XY Coordinates index types.)

- **Point**: indicates the table only can contain point objects
- **Linear**: indicates the table can only contain lines and polylines
- **Region**: indicates the table can only contain region objects

**Per Row Styles**

Activates per row styles for the table, which enables you to use different object styles on the remote table. You can modify the styles of individual objects or groups of objects and save them to the DBMS table.

This option is only available when the MapInfo_MapCatalog has the structure to support styles; it contains the columns RENDITIONTYPE, RENDITIONCOLUMN, and RENDITIONTABLE, and when the table has a minimum of one Char (character) column.

**Style Column**

When the "Per Row Style" check box has been selected, you must also pick a **Style Column** from the drop-down list of candidate columns. Any column that is a character column is a candidate.
Since this column will be overwritten with the style when tables are modified within MapInfo Pro, do not select a column that contains information.

Once this is done, the table is enabled for per row styles. If none were previously loaded into the tables column, the default style stored in the MapInfo_MapCatalog SYMBOL column will be used. You may set new styles simply by modifying the style in the Map window and saving the table.

**Note:** If the chosen column is read-only (it holds more than 254 characters for example), then your map data is read-only.

**Object Style**

Depends on the object types that the mappable table can contain. You can set the default style that the objects will use for display when they are downloaded.

**Symbol:** Displays the **Symbol Style** dialog box where you can select a default symbol for the point data.

**Line:** Displays the **Line Style** dialog box where you can select a default symbol for the line data.

**Region:** Displays the **Region Style** dialog box where you can select a default symbol for the region data.

**Projection**

Opens the **Choose Projection** dialog box. Specify the projection for the DBMS table. The projection must match the projection used by the corresponding remote database table.

If the Projection button is disabled, the application has read the projection information from the Oracle metadata and will use that projection to display the file.

**Table Bounds**

Opens the **Set Table Bounds** dialog box, which lets you choose the options that determine how your default view and your entire view table bounds are calculated. The bounds options you specify in this dialog box define both views. Select one of these options and click **OK** to implement those bounds options.

**Use Data Bound:** By default MapInfo Pro calculates the bounds as the minimum bounding rectangle of all the data in the layer. This requires scanning the table and calculating this value. This process can take some time, so a progress bar displays showing you the progress of this operation. You can cancel it, if necessary.

**Use CoordSys Bounds:** You can use the coordinate system bounds, but usually we do not recommend it. The coordinate system bounds are usually much larger than the actual data bounds, which may make finding your displayed data difficult. You are usually zoomed out too far to be able to locate your data easily.

**Use Custom Bounds:** Set your own custom bounds based on the size and location of your data. Click this option to modify or set the bounds of your data.
About Updating Data Bounds in the MapInfo_MapCatalog

The MapInfo_MapCatalog contains the bounds of the data within the table. This determines the map view when opening the table as the first map in a window. The bounds are set either by EasyLoader when loading the data, or from MapInfo Pro's Set Minimum Bounding Rectangle tool.

The bounds automatically adjust when inserting or updating spatial objects. If the object is outside the Minimum Bounding Rectangle (MBR), MapInfo Pro expands the MBR and updates the MapInfo_MapCatalog. Deleting objects from the table does not alter the bounds.

Deciding to work with Linked or Live Access Tables

There are two ways in which you can work with your data tables: live (or live with caching) and linked. If you are not working with very much data, a small data table size, then it does not matter if you choose to work with live or linked access.

About Live Access Tables

You can access remote data as a live access table using MapInfo Pro. It is called a live access because there is no local copy of the data, that is, all operations against the data go directly to the server. This differs from linked tables, which download a snapshot from the remote database into a native MapInfo Pro table.

You can perform most operations on a live access table that you do for a regular MapInfo Pro table. For example, you can view, edit, copy, and save a live access layer just as you can a regular MapInfo Pro table. However, you cannot pack or modify a live access table's structure.

Live with cache is the preferred way to access live tables. MapInfo Pro provides smart caching to improve performance of live data access from remote databases. During a pan operation, MapInfo Pro retrieves map data from a cache rather than retrieve it from the server every time. Only when the pan requires map data not already contained in the cache, does it go to the server. Closing or refreshing the table clears the cache.

When the live access table is creating a new Map window, the initial view is determined by the entry in the MapInfo_MapCatalog table. The values in the VIEW_* columns, if they exist, describe a rectangular area that is the initial map display. If the live access table is being added as a layer to an existing Map window, the layer will be fit to that Map window.

MapInfo Pro stores information about a live access table in a TAB file. This information is known as metadata. MapInfo Pro uses metadata to store information about the live access table that is needed to manage transactions between MapInfo Pro and the server database. Two of the most important kinds of information stored in the metadata include the connection string and the query you build from the DBMS Table Wizard, or Expert dialog box.

About Linked Tables
A linked table is a MapInfo Pro table that is a replica of a table downloaded from a remote database and retains links to its remote database table. (The remote database table is known as a DBMS table.) When MapInfo Pro downloads a table, it copies the entire contents of the table to the local machine. Any changes you make to the copy can be committed to the server table at any time.

Linked tables can be used stand-alone or remain linked to the original server database. You can refresh linked tables to rerun queries on a regular basis using the Refresh tool or from the Table > Maintenance > Refresh DBMS Table menu. After editing data in a linked table, MapInfo Pro saves it to the RDBS in a manner that resolves any multi-editing conflicts. Saving the edits made to a linked table commits them to the server database as well as to the linked table.

Comparing and Contrasting Live and Linked Access to a Table

Use the following information to decide whether to work with your remote data tables live or linked.

<table>
<thead>
<tr>
<th>Linked Table</th>
<th>Live Table</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Definition</strong></td>
<td>Data is read from the DBMS Server as required. When the data is locally cached, the life of the cache is limited to the current session.</td>
</tr>
<tr>
<td><strong>Suitability</strong></td>
<td>Linked tables are suitable for backdrop display data, or data that does not change much. Linked tables are editable, as long as the base tables they are based on are editable.</td>
</tr>
<tr>
<td><strong>Suitability</strong></td>
<td>Live tables are suitable for reading and editing dynamically changing data; or data sets that do not fit within the limits of 2 GB per data file. Live tables are recommended if you want to maintain data security (the data must remain only in a single secure location).</td>
</tr>
<tr>
<td><strong>Performance Factors</strong></td>
<td>As the data is entirely local, there is a one-time cost of downloading the data, but subsequent access is fast, comparable to native table access, since the user does not incur the cost of network traffic every time the data needs to be accessed for mapping, or for analysis.</td>
</tr>
<tr>
<td><strong>Performance Factors</strong></td>
<td>The cost of data transfer is incurred a little bit at a time. Live tables are accessed real time from the database, as required. Optionally, records from the live table can be locally cached for the length of the MapInfo Pro session. Caching enhances performance, because the data is not fetched multiple times as the user, zooms, pans, or browses around the data.</td>
</tr>
<tr>
<td><strong>Limitations</strong></td>
<td>Linked tables are limited to 2 GB per data file; Linked tables are not refreshed unless the user explicitly refreshes the table. You cannot pack a linked table. You cannot modify the table structure of a linked table.</td>
</tr>
<tr>
<td><strong>Limitations</strong></td>
<td>This is a network intensive option.</td>
</tr>
</tbody>
</table>
Opening a DBMS Table in MapInfo Pro

After completing the instructions in the following sections:

- Creating a Data Source Connection
- Creating a Map Catalog in the DBMS to Work with Data
- Making a DBMS Table Mappable to Display it on a Map

you are ready to connect to your data sources and the database tables you want to work with. If you are not familiar with the details of your remote database type, discuss your requirements with your database administrator to find out the basic information necessary to connect to your database.

Options for Opening Tables

When opening DBMS tables, there are a number of options for:

- Which tables in the database to open or select to open all of the available tables.
- Whether to open the tables live or linked. If selecting linked, you can open them with caching. You can set this option individually for a table to override what is set for all the tables you will open.
- How you want the data to display on the map by selecting point, line, and region style options. You can change: symbol type, color, and size, as well as the label font; line color and pattern; region fill color and pattern, and border color and pattern.
- Column and row filters on tables. Filters let you reduce the amount of information that you will work with and reduce the time it takes to fetch and save the data.
- A directory where the MapInfo TAB file (with the same name as the table) will be saved.

You can apply these selections to all of the tables you will open and also select overrides for individual tables.

Performing Queries on Tables

When performing a query on a table the query executes when:

- Linked tables: Opening the table for the first time, and when refreshing the table.
- Live with cache: Adding the table to the map, and zooming or panning in the map.
- Live without cache: Adding the table to the map, zooming or panning in the map, and clicking in the map with the Select or Info tools.

You can specify which records to retrieve from the database by attribute or by geography. The query syntax is specific to the database that you are accessing. MapInfo Pro translates some expressions when passing a query to the database, such as Object, Within, Selection, and Current_Mapper. You may save your queries, so that you can reuse them.

Tables and Metadata
MapInfo Pro stores information about a table in the .tab file's metadata, which is not displayed on the map. MapInfo Pro uses metadata to manage transactions between MapInfo Pro and the server database. Two of the most important kinds of information stored in the metadata include the connection string and the query you build from the DBMS Table Wizard, or Expert dialog box.

Opening a DBMS Table

This section describes how to open a DBMS table.

The connection to your DBMS must be open before you can open a table. If you have not yet opened a connection or if you have restarted MapInfo Pro (and must re-open a connection), see Reconnecting to your Data Source after Startup.

To open a database table:

1. Select File > Open.
2. In the Open dialog box, from the Files of type list, select the DBMS connection to work with. The DBMS connections that you created previously (as described under Creating a Data Source Connection) are at the bottom of the Files of type drop-down list. If you have more than one connection, then the connection name contains a sequential number indicating the order in which the connection was added.

   The Select One or More Tables to Open dialog box opens.

3. In the Database Tables list, select a table to open by adding a check mark beside the table name. You can select one or more tables. Only the tables that have a check mark beside them will open.

4. Optionally, select how you want the data to display on the map by selecting (highlighting) the table name and clicking Style. This opens the Change Table Object Style dialog box where you can specify the display style for geometry (spatial object types), such as symbols, lines, and regions in the table. The custom styles that you set only apply to the table that you highlighted (whether it has a check mark beside it or not).

   To select more than one table, press Ctrl while selecting table names. Your style choices are made to all of the tables that you select (that are highlighted in the Database Tables list).

5. From the Preferred View drop-down list, select the view you want of this data.

   - **Automatic** - MapInfo Pro chooses the most appropriate view. If the data is mappable (for example, graphic objects are attached to the data), for example, MapInfo Pro opens the table in a Map window. If you have a Map window displayed and the table you want to open is mappable, MapInfo Pro will automatically open the table in the current Map window. If the data is not mappable, MapInfo Pro will attempt to open the table in a Browser window. If the table cannot be mapped or browsed, MapInfo Pro opens the table using the No View option (no data is displayed).
   
   - **Browser** - MapInfo Pro attempts to open the table in a Browser window.
• **Current Mapper** - MapInfo Pro attempts to add your data to the current Map window.
• **New Mapper** - MapInfo Pro attempts to open the table in a new Map window.
• **No View** - MapInfo Pro opens the table making the data available for other uses, but no data is displayed.

When you open a table and select an option in the **Preferred View** drop-down list, MapInfo Pro remembers what you selected and uses the same option the next time you open a table.

6. Click **OK**.

If a MapInfo message dialog displays asking if you want to overwrite the existing file, click **OK**. You have previously opened this file and there is a temporary copy of the file on your machine. MapInfo Pro will overwrite this temporary copy.

The table, or tables, from your selection open in a Map window (or in a Table browser if the data is not mappable).
Creating a New DBMS Table

To create a new DBMS table:

1. Choose File > New Table.
2. In the New Table dialog box:
   a. Specify how you want the table opened: Browser, Mapper, or Current Mapper.
   b. Specify whether you want the table structure to be based on an existing table or you want MapInfo Pro to create a new table structure.
   c. Click Create.
3. In the New Table Structure dialog box specify the field name, field type, number of characters (width), and whether or not to index for each field in your new database. Click Create.

If you are using the structure from another mappable table, then MapInfo Pro sets the new table projection to the projection of the source table. Collectively, this information is the structure of your database.

Note: You indicate whether the table is mappable by associating graphic objects with records and, if so, whether the map is to be an earth or a non-earth map.

4. In the Create New Table dialog box, from the Save as type drop-down list, select a DBMS type. The dialog box displays DBMS connection controls.
   In the File name box, type a file name and click Save.

Depending on the database type that you selected, the new table opens in MapInfo Pro or the New DBMS Table Options dialog box opens. If you see the New DBMS Table Options dialog box then continue to the next section.

Setting New DBMS Table Options
To set new DBMS table options, follow the instructions under Creating a New DBMS Table. Depending on the database type that you select, the New DBMS Table Options dialog box opens. This dialog box has three tabs, General, Spatial, and Styles. Refer to the following sections for information about each tab of options.

If you cleared the Make Table Mappable check box in Create New Table dialog box, then the DBMS Table Options dialog box shows only the General tab.

**General Tab**

Under the General tab complete the appropriate selections:

- **TAB file location** - Displays the name and path of the .tab file that will be created. You can manually type a filename or use the Save As dialog box (via Browse button) to choose a filename. MapInfo Pro uses the last directory where you saved a DBMS .tab when constructing the default filename full path. If this directory does not exist, then the Remote Tables preference directory is used. The filename part of the default path is based on the name of the specified DBMS table name.

- **Browse (...) button** - Displays the Save As dialog box so the user can choose a .tab filename. Initialized with the text in the .tab filename edit box.

- **PrimaryKeyColumn** - Lets you specify a key column for the new table. Without a key column a DBMS table cannot be open as live access and can only be opened read only as Linked. If the Primary Key Column check box is selected, then the corresponding combo box is enabled. You can either choose a column that was specified in the New Table Structure dialog box or specify a new column by typing into the combo box's edit control. By default the Primary Key Column check box is selected and a new column is specified. The default name of the new column depends on the DBMS connection: MI_PRINX for Oracle Spatial, SW_MEMBER for all others.

- **Download Data (Linked Table)** - Select to establish a linked connection to this table.

- **Live Access** - Select to access this table with a live connection.

- **Cache** - Select to save the table to the local buffer and then read the table data from the buffer. Access time to data is faster but you are not working with the most current version. Refresh occurs when you zoom, pan, or select. Unselect to read the table directly from the data source, which is the current version.

  The Cache check box enables after selecting the Live Access option.

**Spatial Tab**

Click the Spatial tab and specify the index type and coordinate column selections:

- **Index Type** - This setting determines the type of spatial indexing used on the table. Types MapInfo (MICODE) and XY are always available. Server specific types may also be listed. The index type selection affects the state of the other three controls in this tab.

- **Index Column** - Specify the primary spatial index column from the list. This option is always available, except when the index type is XY.
• **X Coordinate** - Specify the X or longitude column in the database from the list. This is only available for MapInfo (MICODE) or XY types. You can either choose a float column that was specified in the **New Table Structure** dialog box or specify a new column by typing into the combo box's edit control.

• **Y Coordinate** - Specify the Y or latitude column in the database from the list. This is only available for MapInfo (MICODE) or XY types. You can either choose a float column that was specified in the **New Table Structure** dialog box or specify a new column by typing into the combo box's edit control.

**Styles Tab**

Click the **Styles** tab and complete the appropriate selections:

• **Per Row Style** - Check the **Per Row Style** check box to enable per row symbology. The style information for each object is maintained in a character column of the table. If unchecked, then the style of all objects in the table is determined by the default object styles maintained in the Map Catalog.

  If **Per Row Style** is checked, then the **Style Column** combo box is enabled. By default **Per Row Style** is checked and a new column named **MI_STYLE** is specified.

• **Style Column** - Select from the list a character column that was specified in the **New Table Structure** dialog box or a new column by typing into the combo box's edit control.

• **Default Object Styles** - The default object styles are used when **Per Row Style** is not turned on for a table, or the style info for a particular object does not exist (the style column for that row is empty). The default style information specified here is entered into the map catalog. The default symbol, line, and region settings within MapInfo Pro are used to initialize these controls.

**Refreshing Live and Linked Remote Tables**

If the table you are working with is linked, then refresh it to update your data with changes from the remote database. If the table is live, MapInfo Pro reads the latest data from the table.

When you open a remote table, MapInfo Pro enables the **Refresh DBMS Table** tool so you can refresh the data in that table. Refreshing a table:

• Checks the database for changes.
• Reapplies any query conditions (these are static).
• If filtering using the current map or selection, then the filter always applies to the table. To set a different map extent, reopen the table from the database.

To refresh a linked or live table:

1. Do one of the following:

   • Click the **Refresh DBMS Table** tool on the DBMS toolbar
   • From the **Table** menu, select **Maintenance > Refresh DBMS Table**
   • Press **Ctrl+D** in an active Browser window (clicking on a Browser window makes it active)

2. In the **Refresh Table** dialog box, select the table to refresh and then click **OK**.
Unlinking a Table from a Remote Database

You can unlink a table from its remote database using the Unlink DBMS Table menu option. Unlinking a table removes the link to the remote database. This does not work if edits are pending on the linked table, you must first update any pending edits with the Save Table menu option. The end product is a normal MapInfo Pro base table without table linkages and non-editable fields made editable.

To unlink a table:

1. On the Table menu, select Maintenance and then Unlink DBMS Table.
2. In the Unlink Table dialog box, select the name of the table to unlink and then click OK.

The specified table unlinks.

Saving a DBMS Table

You save changes to a MapInfo Pro linked or live table the same way you save a regular MapInfo Pro table, with the Save Table menu option.

Saving a linked or live table saves the records on the remote database. Before MapInfo Pro updates records from a linked or live table, it evaluates the records in a process called conflict resolution.

If MapInfo Pro finds conflicts between the data on the remote database and records in the linked table, since the time of its download, the Resolve Conflicts dialog box displays. Use this dialog box to resolve conflicts.

• For more information, see Saving Changes Made to a DBMS Table in the Help System.

Conflict Resolution when Multiple Users Access a Remote Table

Other users may change or delete records in a table on the remote database after it was downloaded into MapInfo Pro. As a result, conflicts may exist between the data residing on the remote database and the new data that you want to upload to the remote database.

If there are changes to records in the original data source when saving a table back to a remote database, a Resolve Conflicts dialog box displays. A conflict exists when the original state of the record does not match the server state. This implies that another user has updated this database since it was extracted by MapInfo Pro.

In the Resolve Conflicts dialog box, you can choose the fields to use from the conflicting records to update the database with. There are three considerations when updating a record:

• The original server state of the record (the record as it appeared when initially extracted from the database).
- The current local state of the record (the record as it appears in the session of MapInfo Pro making the update, possibly after editing by the user).
- The current server state of the record (the record as it appears in the database at the time of the update).

The Resolve Conflicts dialog box displays once for each conflicting record. At any point in this process, you may choose to leave this interactive mode and have the rest of the conflicts resolved automatically. In that case, you can use all local values or all server values to resolve the conflicts in the records.

For each conflict found during a commit, a modal dialog box displays. This box displays enough information for you to decide which data values to use to update the row in question.

<table>
<thead>
<tr>
<th>Type of conflict</th>
<th>Default resolution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value changed on server, local value unchanged</td>
<td>Use server value</td>
</tr>
<tr>
<td>Value changed on server, local value changed</td>
<td>Use local value</td>
</tr>
</tbody>
</table>

The dialog box provides you with the following options:

**Column**

Shows the name of the column in the record that has data which is in conflict and needs to be resolved. If the column name is too long and does not fit into the list box, a truncated representation will be shown instead. Its full value displays in the Column field.

**Original DBMS**

Shows the original data as it appeared when extracted from the database. If the original data is too long and does not fit into the list box, a truncated representation will be shown instead. Its full value can be displayed in the Original field.

**Current MapInfo Pro**

Shows the data as it appears in the MapInfo Pro linked table you are trying to save. The MapInfo Pro field will be blank if the record has been deleted from the MapInfo Pro database. If the data from the MapInfo Pro linked table is too long and does not fit into the list box, a truncated representation will be shown instead. Its full value can be displayed in the MapInfo Pro field.

**Current DBMS**

Shows data as it appears in the remote database at the time of the update. (This data might have been changed by another user since it was downloaded into an MapInfo Pro linked table.) The Current field will be blank if the record has been deleted on the remote database, after being downloaded into an MapInfo Pro linked table. If the current data from the remote database is too long and does not fit into the list box, a truncated representation will be shown instead. Its full value can be displayed in the Current field.
**Current MapInfo Pro**

Select this check box to update the remote database with the value from the MapInfo Pro linked table.

If the current record on the database or the MapInfo Pro record was deleted, then this check box is not available. Instead, you must use the MapInfo Pro or Current button.

**Current DBMS**

Select to retain the current value on the remote database. If the current record on the database or the MapInfo Pro record was deleted, then this check box is not available. Instead, you must use the MapInfo Pro or Current button.

**MapInfo button**

This button selects all the MapInfo Pro values. If the record you are trying to resolve was deleted from the MapInfo Pro database, selecting the MapInfo button will delete the record from the remote database. If the record you are trying to resolve was deleted from the remote database, selecting the MapInfo button will insert the new record into the remote database.

**Current button**

This button selects all the current DBMS values. If the record you are trying to resolve was deleted from the MapInfo Pro database, selecting the Current button will ignore the deletion and retain the current record in the remote database. If the record you are trying to resolve was deleted from the remote database, selecting the MapInfo button will insert the new record into the remote database.

**Column**

Shows the full name of the column highlighted in the list box.

**Original DBMS**

Shows the full value of the original data highlighted in the list box.

**Current MapInfo**

Shows the full value of the MapInfo Pro data highlighted in the list box.

**Current DBMS**

Shows the full value of the current remote database data highlighted in the list box.

**Stop Commit**

The Stop Commit button terminates the entire update. A second dialog box confirms that this is what you really want.

**Automatic**

The Automatic button causes the interactive conflict resolution to end. A dialog box displays to allow you to select the automatic conflict-resolution modes you want to use for the remainder of this update. You can select one two automatic modes from the dialog box. You can accept MapInfo Pro values, or the values currently residing on the remote database.
Disconnecting from a Remote Database

Disconnecting from a remote database server is a simple operation.

To disconnect from a remote database server:

1. From the DBMS Toolbar, do one of the following:
   • Click the **Disconnect DBMS** tool.
   • On the **File** menu, click **Close DBMS Connection**.

2. In the **Close DBMS Connection** dialog box, the **Connection** list displays all the open connections. Select the connection(s) you want to close and click **OK**.

The selected connection(s) close.

**Note:** You cannot disconnect if you have a live table open using the connection you are trying to close.

Working with Styles in DBMS Tables

A table may use one style for all objects within a table, or contain different styles for each row, called per row styles (per row style is optional). There are two requirements for setting up per row styles:

• A row must exist in the DBMS table
• You must set up a map catalog entry to activate the row style.

**Using Per Row Styles for DBMS Table Layers**

Per Row Styles allows the use of different object styles on a remote database. You can modify the styles of individual objects or groups of objects and save them to a DBMS table. To use Per Row Styles, the DBMS table must be set up correctly, and your MapInfo_MapCatalog must have the appropriate structure:

• The MapInfo_MapCatalog must contain columns that support the use of styles. They are: RENDITIONTYPE, RENDITIONCOLUMN, and RENDITIONTABLE.
• The map table itself must have a character column wide enough to store the complete style string. Style strings vary in width. We recommend a minimum of 50 characters be provided. If you plan to use custom symbols, which use much longer strings, allow 200 characters.
• The entry for the table in the MapInfo_MapCatalog must be set correctly. This means that the RENDITIONTYPE is 1, and the RENDITIONCOLUMN contains the name of the column that will contain the style string. This entry is set by EasyLoader if the MapInfo_MapCatalog contains the new columns, or it may be set using the Make Table Mappable function.

**Changing the Symbol Style in a Mappable DBMS Table**

The Change DBMS Table Symbol menu option allows you to change the symbol attributes for the point objects in a mappable DBMS table.
1. On the Table menu, point to Maintenance and click Change DBMS Table Symbol. Or, select the Change Symbol tool.
2. In the Select DBMS Table dialog box, select a table. Only mappable DBMS tables display.
3. In the Change Table Object Style dialog box, specify new style attributes for the objects in the selected table.
4. Refresh the linked table for the style change to take effect.

Working with Remote Tables from Specific Databases

You can specify whether to load and work on an entire table or only specific columns or rows from a table.

Working with SQL Server Tables

Converting Unsupported Geometries in SQL Server and SQL Server SpatialWare

Some times when you are creating a Map in MapInfo Pro and you are storing the results in SQL Server you create maps which use geometries that are not supported:

- **SQL Server Spatial** does not support arcs, and lines that do not have distinct points.
- **SQL Server SpatialWare** does not support arcs, ellipses, and rounded rectangles.

**Note:** If you have created a map you do not want to lose but cannot save to the DBMS of your choice due to unsupported geometries, then use the Save As menu option and save the map without the unsupported geometries.

If you try to save a map with unsupported spatial geometry types in SQL Server Spatial or SQL Server SpatialWare, these are the results:

- **Spatial Geometry Types with All Unsupported Objects**: If you have created a map that might contain all of the unsupported objects and you are trying to save to SQL Server Spatial or SQL Server SpatialWare, this message displays:

  Table has unsupported objects (rounded rectangles, ellipses or arcs). Convert to regions and/or polylines?

  Click Yes to convert the unsupported objects to regions or polylines; you would select No to decline to convert the unsupported objects. If you decline, you cannot save the map you have created to the SQL Server Spatial or SQL Server SpatialWare database.
• **Spatial Geometry types with Region Objects Only**: If you have created a map that contains region objects only and you are trying to save to SQL Server Spatial or SQL Server SpatialWare, this message displays:

| Table has unsupported objects (rounded rectangles or ellipses). Convert to regions? |

Click **Yes** to convert the unsupported objects to regions; you would select **No** to decline to convert the unsupported objects. If you decline, you cannot save the map you have created to the SQL Server Spatial or SQL Server SpatialWare database.

• **For Spatial Geometry types with Line Objects Only**: If you have created a map that contains line objects only and you are trying to save to SQL Server Spatial or SQL Server SpatialWare, this message displays:

| Arc is an unsupported object. Convert to polylines? |

Click **Yes** to convert the unsupported objects to polylines; you would select **No** to decline to convert the unsupported objects. If you decline, you cannot save the map you have created to the SQL Server Spatial or SQL Server SpatialWare database.

### Working with SQL Server with SpatialWare Tables

SpatialWare is a Pitney Bowes Software Inc. Corporation product that helps users store, access, manage, and manipulate spatial data as a standard part of their business data. You can query both spatial and non-spatial data within a single SQL Server query using SpatialWare. All of the strengths of SQL Server as a relational database are extended to spatial data using SpatialWare. Spatial data may for example be directly managed and edited by many different users simultaneously.

**Cannot Upload Object**

If you edit a mappable SpatialWare table and try to insert MapInfo Ellipse, Rounded Rectangle, or Arc objects into it, the following message displays:

"Cannot Upload. Object format is not supported in SpatialWare (Ellipse, Rounded Rectangle, or Arc)"

This is because you are trying to insert objects that are not supported. To fix the problem, delete these objects from the table or transform them to polylines or regions. To determine which objects have to be deleted or transformed, run a query in the MapInfo SQL Select dialog box and specify "obj" in the Select Column clause. The resulting query will tell you the types of objects in the table. Select the objects you wish to delete or transform and display the selection in an editable layer in a Map window. To delete the objects, use the Clear Map Objects Only option in the Edit menu. To transform the objects, use the Convert to Regions or Convert to Polylines option in the Objects menu. For best results, transform Ellipse and Rounded Rectangles into regions, and transform Arcs into polylines.
If you make a SpatialWare table mappable with the Object Type default of Point and try to insert a Line or Region object into it, the same message "Cannot Upload Object format is not supported in SpatialWare (Ellipse, Rounded Rectangle, or Arc)" displays. This is because you are trying to insert objects other than a point. You need to make the table mappable with the Object type specified as ALL. To fix the problem, delete the table from the Map Catalog using EasyLoader. Then re-add the table to the Map Catalog with an Object type of ALL using the Make Table Mappable option.

**Working with PostGIS Tables**

Some times when you are creating a map in MapInfo Pro and you are storing the results in PostGIS you create maps which use geometries that are not supported: PostGIS does not support arcs, ellipses, rectangles, and rounded rectangles.

**Note:** If you have created a map you do not want to lose but cannot save to the DBMS of your choice due to unsupported geometries, then use the Save As menu option and save the map without the unsupported geometries.

If you try to save a map with unsupported spatial geometry types in PostGIS, these are the results:

- **Spatial Geometry Types with All Unsupported Objects:** If you have created a map that might contain all of the unsupported objects and you are trying to save to PostGIS, this message displays:

  Table has unsupported objects (rounded rectangles, ellipses or arcs). Convert to regions and/or polylines?

  Click **Yes** to convert the unsupported objects to regions or polylines; you would select **No** to decline to convert the unsupported objects. If you decline, you cannot save the map you have created to the PostGIS database.

- **Spatial Geometry types with Region Objects Only:** If you have created a map that contains region objects only and you are trying to save to PostGIS, this message displays:

  Table has unsupported objects (rounded rectangles or ellipses). Convert to regions?

  Click **Yes** to convert the unsupported objects to regions; you would select **No** to decline to convert the unsupported objects. If you decline, you cannot save the map you have created to the PostGIS database.

- **For Spatial Geometry types with Line Objects Only:** If you have created a map that contains line objects only and you are trying to save to PostGIS, this message displays:

  Arc is an unsupported object. Convert to polylines?

  Click **Yes** to convert the unsupported objects to polylines; you would select **No** to decline to convert the unsupported objects. If you decline, you cannot save the map you have created to the SQL Server Spatial database.
• For Spatial Geometry of type Rectangle: If you have created a map that contains rectangle objects and you are trying to save to PostGIS, this message displays:

```
Cannot upload Object - Rectangle object type is not supported in this table. Operation canceled.
```

Click OK. You cannot save the map you have created to the PostGIS database.

---

**Working with Oracle Spatial Tables**

Oracle Spatial is an implementation of a spatial database from Oracle Corporation. You can install it in addition to the MapInfo Pro ODBC Connectivity component. Although it has some similarities to the previous Oracle SDO relational implementation, it is significantly different. Oracle Spatial maintains the Oracle SDO implementation via a relational schema. However, MapInfo Pro does not support the Oracle SDO relational schema via the Oracle Call Interface (OCI). MapInfo Pro does support simultaneous connections to Oracle Spatial through the OCI and to other databases through ODBC.

**Supported Object Types**

The Multipoint and Collection object types are translated into the Spatial Objects Oracle MULTIPOINT and COLLECTION, respectively, via Oracle OCI and vice versa. However, Oracle’s COLLECTION object is broader in scope than MapInfo Pro’s Collection, which only allows one REGION, one polyline and one multipoint. Therefore, conversion from MapInfo Pro object to Oracle objects and the conversion from Oracle objects to MapInfo Pro objects may not be a one-to-one translation.

The following table shows the relationship between MapInfo Pro objects and Oracle objects.

<table>
<thead>
<tr>
<th>Oracle Spatial Objects</th>
<th>MapInfo Pro Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>MULTIPOINT</td>
<td>Multipoint</td>
</tr>
<tr>
<td>COLLECTION</td>
<td>Collection</td>
</tr>
<tr>
<td>Point (cluster)</td>
<td>Multipoint</td>
</tr>
<tr>
<td>Line String</td>
<td>Polyline</td>
</tr>
<tr>
<td>Multiple Line String</td>
<td></td>
</tr>
</tbody>
</table>
### Oracle Spatial Objects vs MapInfo Pro Objects

<table>
<thead>
<tr>
<th>Oracle Spatial Objects</th>
<th>MapInfo Pro Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Polygon</td>
<td>REGION</td>
</tr>
<tr>
<td>Multiple Polygons</td>
<td></td>
</tr>
</tbody>
</table>

The table indicates how Oracle Spatial objects are translated into MapInfo Pro objects. All point elements in an Oracle COLLECTION will be translated into one multipoint in a MapInfo Pro Collection; all Oracle Line objects (including single and multiple) will be translated into one MapInfo Pro polyline; and all Oracle Polygons (including single and multiple) will be translated into one MapInfo Pro REGION. Therefore, when an Oracle COLLECTION is modified and then saved back into Oracle Server by using MapInfo Pro, the original structure of the Oracle COLLECTION object may be changed if it is more complicated than the MapInfo Pro Collection.

If you are connecting to an Oracle Spatial database, Oracle Spatial is a new spatial schema number 13. It provides support for points, lines, and polygon spatial types.

### Oracle Spatial Requirements

To connect to Oracle Spatial within MapInfo Pro, you must have the Oracle Spatial or Oracle 9i and 9i release 2, or 10G client installed. See your Oracle documentation for detailed information.

#### Primary Key used for New Table Creation or When Saving a Remote Copy

An Unique key ensures that an entry does not match any other entry from a different record. If a record does not contain any value, no error is reported. A Primary key requires that every record contains a unique value in that field. By making these values Primary keys, we enforce that every record has a value in this field.

#### Primary Key Auto-Increment for Oracle Databases

The Primary auto-increment feature manages the Primary key value for you. When you add a new record to a remote Oracle table, MapInfo Pro locks the table, checks for the highest value of the Primary key of the table, increments it by one (1), and then puts that value in the Primary key field. SQL Server Spatial users do not require this feature as the server-side software manages the Primary key automatically.

Use the Auto Key check box in the **Open DBMS Table Option** dialog box to enable this feature. When you select the Auto Key check box, the Primary key field is not editable and the Unique key is automatically incremented. If you do not select this check box, the Primary key field remains editable.

To access this feature:

1. From the **File** menu, click **Open** and select an Oracle database from the Files of Type drop-down list. Click **OK** to display the **Open DBMS Table Options** dialog box.
2. Select the **Auto Key** option to increment the Primary key of the selected table automatically for any new records.
3. Click **OK** to continue.

**Oracle Object Map Verification Supporting Object/Map Validation**

The Check Regions menu option enables you to remove region line segments that intersect each other. You can also think of this as nodes within a single polygon of a region where the polygon intersects itself, as when a node has more than 2 line segments emanating from it.

These cases can be broken down into two other instances:

- If a polygon has 2 looped sections, and the path traced by the nodes of the polygon follow a cursive figure 8 pattern, then we call this a *Figure 8 polygon*.
- If the same 2 looped polygon can trace its path as a cursive capital letter B, then we call this a *Bow Tie polygon*.

We think of Figure 8 as worse than Bow Tie because the area of a Figure 8 is always incorrect, while the area of a Bow Tie can be correct and accurate. Both Figure 8's and Bow Ties are detected.

**Creating Legends from/for a Live Table**

You can retrieve unique styles from the table using the **Create Legend** wizard. You can retrieve styles from the map catalog, if performance is your primary concern, but if you prefer a more visually descriptive and appealing spatial representation of the unique map styles in your live table, you can create legends from a live table instead.

**When are unique map styles available for a live table?**

In general, remote databases have no consistent way of storing styles for geographic data. MapInfo Pro gives you two different ways of associating styles with geographic data for remote databases. The first way is to specify a common style for a database table in the map catalog, which is used for all records in that database table. The second way is to have an additional column for the database table that specifies a style for each record in that table. (MapInfo Pro uses the map catalog to keep track of the style column for a database table.) Unique map styles are available for a database table when it has this designated style column.

To see this functionality:

1. Open a remote DBMS connection and select a live table for display.
2. From the **Map** menu, click **Create Legend** to display the **Create Legend - Choose Layers** dialog box.
3. Select a layer to create a legend from and click **Next** to display the **Create Legend - Legend Default Properties** dialog box.
4. Click **Next** to display the **Create Legend - Frame Properties** dialog box.
5. In the **Styles from** box, there are three options. The first option, **map catalog**, provides the existing support and is still the default for live tables.
   - Select **map catalog** to retrieve the default styles for the selected legend frame from the map catalog. Use this option when you are concerned with performance. Retrieving map styles from live tables on a remote database can take a long time, but retrieving a default style from the map catalog can be significantly faster. Remember that styles in the map catalog may not be
as visually descriptive as the other options. This is the default option for live tables, but is disabled for other types of tables.

- Select **unique map styles** to retrieve all unique object styles for the live access table for a visually appealing legend. For extremely large tables, this option can take longer than the first option. This option is selected by default when the legend frame is not a live access table.

- Select **unique values in a column** to retrieve the styles associated with the values saved in a particular column in the database table for a visually appealing legend. For extremely large tables, this option can take longer than the first option.

6. Click **Save frame setting to Metadata** to preserve the choice you made in this dialog box. When you re-open this dialog box the settings from the metadata are used as default values instead of the system set default values.

7. Click **Finish**.

See *Troubleshooting DBMS Table Issues* in the **Help System**.

**MapInfo Pro does not Maintain the Curve Type in Oracle Data**

When reading Oracle tables, MapInfo Pro changes records containing geometries that do not directly translate to MapInfo Pro geometry types. This happens when working with lines and polygon boundaries containing segments that are curve types or circles. MapInfo Pro does not support the curve type, so it converts these to polylines. MapInfo Pro also converts circles into regions. When saving these records back to the database, you may lose some topological information as a result. This is something to be aware of when sharing your Oracle data with other applications, such as Autodesk's Map3D.

MapInfo Pro shows a message before saving data back to the Oracle database when that data contains curved geometries. The message is as follows:

The Oracle table you are updating contains one or more geometry types that MapInfo Pro does not support, so the geometry type has been converted to a supported type. Saving these geometries may introduce topological errors into your database. Click Yes to continue, or No to discard changes that were made to unsupported geometries. Edits to attribute data save in either case.

**Note:** When executing the MapBasic Commit statement, the prompt displays only when it contains the Interactive keyword.

**Converting Unsupported Geometries in Oracle**

Some times when you are creating a Map in MapInfo Pro and you are storing the results in Oracle you create maps which use geometries that are not supported: Oracle does not support arcs, ellipses, rectangles, and rounded rectangles.

**Note:** If you have created a map you do not want to lose but cannot save to the DBMS of your choice due to unsupported geometries, then use the Save As menu option and save the map without the unsupported geometries.

**Oracle Geometry Conversion Behavior**

If you try to save a map with unsupported spatial geometry types in Oracle, these are the results:
**Spatial Geometry Types with All Unsupported Objects**: If you have created a map that might contain all of the unsupported objects and you are trying to save to Oracle, this message displays:

Table has unsupported objects (rounded rectangles, rectangles, ellipses or arcs). Convert to regions and/or polylines?

Click **Yes** to convert the unsupported objects to regions or polylines; you would select **No** to decline to convert the unsupported objects. If you decline, you cannot save the map you have created to the Oracle database. A confirmation message explains that the operation is canceled.

**Spatial Geometry types with Region Objects Only**: If you have created a map that contains region objects only and you are trying to save to Oracle, this message displays:

Table has unsupported objects (rounded rectangles, rectangles, or ellipses). Convert to regions?

Click **Yes** to convert the unsupported objects to regions; you would select **No** to decline to convert the unsupported objects. If you decline, you cannot save the map you have created to the Oracle database.

**For Spatial Geometry types with Line Objects Only**: If you have created a map that contains line objects only and you are trying to save to Oracle, this message displays:

Arc is an unsupported object. Convert to polylines?

Click **Yes** to convert the unsupported objects to polylines; you would select **No** to decline to convert the unsupported objects. If you decline, you cannot save the map you have created to the Oracle database.

**Oracle Operating System Authentication and Configuration**

When you choose OS authentication for a user, the user account is maintained by the Oracle database, but password administration and user authentication is performed by the Operating System (OS). With OS authentication, your database relies on the underlying operating system to restrict access to database accounts. A database password is not used for this type of login.

By default, Oracle allows operating-system-authenticated logins only over secure connections, which precludes using Oracle .NET and a shared server configuration. This default restriction prevents a remote user from impersonating another operating system user over a network connection.

Setting `REMOTE_OS_AUTHENT` to `TRUE` in the database initialization parameter file forces the RDBMS to accept the client operating system user name received over a non-secure connection and use it for account access.

Any change to this parameter takes effect the next time you start the instance and mount the database. Generally, user authentication through the host operating system offers faster and more
convenient connection to Oracle without specifying a separate database user name or password. Also, user entries correspond in the database and operating system audit trails.

**Setting Prefix for OS Authenticated User**

Set the initialization parameter `OS_AUTHENT_PREFIX`, and use this prefix in the Oracle database user names. The `OS_AUTHENT_PREFIX` parameter defines a prefix that the Oracle database adds to the beginning of every user's operating system account name. When a user attempts to connect, Oracle compares the prefixed user name with the Oracle user names in the database.

For example, assume that `OS_AUTHENT_PREFIX` is set as follows:

`OS_AUTHENT_PREFIX=OPS$`

**Note:** The initialization parameter `OS_AUTHENT_PREFIX` is case-sensitive in some operating systems. Refer to your operating system specific Oracle documentation for more information about this initialization parameter.

If a user named tsmith is to connect to an Oracle database installation and be authenticated by the Operating System, then the Oracle database checks whether a corresponding database user `OPS$tsmith` exists. If so, the user will connect. All references to a user authenticated by the Operating System must include the prefix, `OPS$`, as seen in the example `OPS$tsmith`.

The default value of this parameter is `OPS$` for backward compatibility with previous versions of Oracle databases. However, you might prefer to set the prefix value to some other string or a null string (an empty set of double quotes: " "). Using a null string eliminates the addition of any prefix to operating system account names, so that Oracle user names exactly match operating system user names.

After you set `OS_AUTHENT_PREFIX`, it should remain the same for the life of a database. If you change the prefix, then any database user name that includes the old prefix cannot be used to establish a connection, unless you alter the user name to have it use password authentication.

**Creating a User who is Authenticated by the Operating System**

The following statement creates a user who is identified by Oracle and authenticated by the operating system or a network service. This example assumes that `OS_AUTHENT_PREFIX = ""`.

```
CREATE USER scott IDENTIFIED EXTERNALLY;
```

Using `CREATE USER <user name> IDENTIFIED EXTERNALLY`, you create database accounts that must be authenticated by the operating system or network service. Oracle will then rely on this external login authentication when it provides that specific operating system user with access to the database resources of a specific user.

See the *Oracle Database Advanced Security Administrator's Guide* ([http://docs.oracle.com/cd/B19306_01/network.102/b14268/toc.htm](http://docs.oracle.com/cd/B19306_01/network.102/b14268/toc.htm)) for more information about external authentication.
The drawing and editing capabilities in MapInfo Pro allow you to create and customize an unlimited variety of objects for your maps. Easy-to-use drawing tools and commands are accessible from the Drawing Toolbar. You can also display nodes, line directions and centroids to give you better control when editing objects.

In this section

- Understanding the Drawing and Editing Tools 226
- Drawing Objects 228
- Drawing Polygons and Polylines 230
- Drawing Symbols 233
- Working with Text on the Map 236
Understanding the Drawing and Editing Tools

MapInfo Pro has a complete set of drawing tools and editing commands. These tools allow you to draw and modify objects on your map. You can also use these tools to customize the colors, fill patterns, line types, symbols, and text on your map.

However, these tools and commands give you more than the ability to modify your map. You can draw a variety of objects that you can use to perform powerful geographic analyses. For example, you can draw circles, polygons, and other bounded objects. You can then search for records within those boundaries.

**Note:** You can only draw and edit objects on a map when the layer the object is on is editable.

We have covered making a layer editable in depth elsewhere in this *User Guide*. See *Making the Layers "Editable"*.

**Note:** We have increased the size of the allowed objects in MapInfo Pro. That is, we have increased the number of nodes permitted per object for regions, polylines, and multipoints and we have increased the number of polygons allowed in a multipolygon region and increase the number of polylines in a multiple segment polyline.

• For more general information, see *Understanding the Drawing and Editing Tools* in the *Help System*.

Using the Drawing and Editing Commands

There are nine drawing tools, each located in the Drawing toolbar, which you can review in *Reviewing the Drawing Toolbar*. The Drawing toolbar contains six additional buttons to aid you in drawing and editing.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Tool Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Reshape" /></td>
<td>Reshape</td>
<td>Toggle in and out of Reshape mode with this button when you want to add, delete, or move nodes in an editable layer (also available on the Edit menu).</td>
</tr>
<tr>
<td><img src="image" alt="Add Node" /></td>
<td>Add Node</td>
<td>The Add Node button allows you to put additional nodes on an object for more precise editing.</td>
</tr>
<tr>
<td><img src="image" alt="Line Style" /></td>
<td>Line Style</td>
<td>Displays the Line Style dialog box where you can change the color, width, and type of selected line objects or set new defaults for future objects.</td>
</tr>
</tbody>
</table>
Adding a Node

Nodes can be added only to lines, polylines, and regions.

The maximum number of nodes for regions and polylines is 1,048,572 nodes for a single polygon region or polyline. The limit drops by seven nodes for every two additional polygons.

To add a node:

1. On the **Drawing Toolbar**, click the **Add Node** button.
2. Move the cursor to the point on the segment where you want to add a node.
3. Click to add the node. Press the **Backspace** key to delete the last node added.
4. On the **Edit** menu, point to **New Row**. A new row is added to the bottom of the table.

Adding Nodes to an Object (Overlay Nodes Command)

To add nodes to an existing object:

1. Select one or more objects in the editable map layer of the active Map window. These are the objects to which you want to add nodes.
2. Choose **Objects > Set Target**. The objects you selected in Step 1 appear in a different style to indicate that they are the editing targets.
3. Select one or more objects from any layer of the active Map window. Presumably, these are objects that intersect your target object(s).
4. Choose **Objects > Overlay Nodes**.

MapInfo Pro adds nodes, if appropriate, to the target object(s).

When you choose **Overlay Nodes**, MapInfo Pro adds nodes to the current target objects. MapInfo Pro calculates all points where the target objects intersect the currently selected objects; MapInfo Pro then adds nodes to the target objects at the points of intersection unless the target objects already have nodes at those locations. If the target objects do not intersect the selected objects, MapInfo Pro does not add any nodes.
If you use **Overlay Nodes** to add nodes to a line, MapInfo Pro converts the line to a polyline. If you use **Overlay Nodes** to add nodes to an ellipse, rectangle or rounded rectangle object, MapInfo Pro converts the object to a region. **Overlay Nodes** does not affect text or point objects, and you may not use point or text objects to add nodes to other objects.

### Drawing Objects

Drawing objects in MapInfo Pro is easy. Once you have made the layer editable, choose the appropriate tool. Using the shape tools, you can draw arcs, ellipses, circles, lines, rectangles, and rounded rectangles on your map. You can either draw the object directly on the Cosmetic Layer (and save it to another or new layer later) or make a map layer editable and draw the objects there.

Once you have drawn the object, you can move the object, delete it, copy it to the Clipboard, or paste it to another Map window.

Also, you can delete the last node of the object by pressing the **Backspace** key. If there is only one node left in the object, it will not be deleted.

### Specifying an Object's Spatial Attributes

If the selected object is editable (resides in an editable layer) then you can specify attributes for the object by accessing that **Objects Attributes** dialog box.

**Note:** If the object is not editable then you can only access a read-only dialog box.

To specify an object's spatial attributes:

1. Make the layer containing the map object editable. Choose **Map > Layer Control** and click the **Editable** 📝 icon to make the layer editable.
2. Select the map object.
3. Do one of the following:
   - Choose **Edit > Get Info**.
   - Double-click the map object with the **Select** tool.

   The **Object Attributes** dialog box displays.

4. Type in attributes as appropriate.
5. Click **OK**.

Use the **Help** search option to locate information for a specific map object (for example, Arcs, Points, Polygons etc.).
Reverting to a Previous Version

Use Revert Table in the File menu to access a previous version of a table when you have made changes that you do not want to make permanent and have not saved yet. Revert Table replaces the selected table currently in memory with the last version saved.

To revert to a previous version:

1. Choose File > Revert Table to display the Revert Table dialog box. Here you can choose the table to revert to (that is, return to its previous state).
2. Once you have chosen a table to revert, MapInfo Pro prompts you on whether you wish to discard the changes you have made in the table.
3. Click Discard. MapInfo Pro discards the changes you have made to the table. However, if you have second thoughts, click Cancel.
4. For instructions on drawing specific objects such as lines, polylines, squares, etc., see Drawing Objects in the Help System.

Using the Ruler Window as You Draw

The Ruler window will show the distance of line segments as you draw, as well as the cumulative distance of the drawn object. If necessary, a rubber-banding line displays to show what points are being used to compute the distance. The Ruler window also displays what type of calculation is used to compute the distance: Spherical or Cartesian. The type of calculation depends on the projection of the map.

The following drawing tools will display a rubber-banding line:

- Arc
- Ellipse
- Rectangle
- Rounded Rectangle

You can also use the Ruler window with the Marquee Select and Radius Select tools. Just click the Ruler tool to display the Ruler window.

If the Ruler window is not active, the drawing and selection tools noted above do not display distance. The rubber-banding line does not display.

- For more instructions, see the Measuring the Distance between Two Points topic in the Help System.

Object Styles

MapInfo Pro draws objects using the default color, fill pattern, line type, symbol, and text settings for the layer you are drawing on. The default style can be set in the Styles Preferences dialog box.

To change the style of an existing object:
1. Choose Map > Layer Control and click the Editable icon to make the layer editable.

2. Select the object and choose the appropriate style command from the Options menu.

   The style commands are also available on the Drawing Toolbar. These commands also set the styles for any subsequent objects to be drawn on the layer.

3. Save your changes.

   For closed shapes such as circles and squares, you can change the fill pattern and color, the style and color of the border, and the line width of the border. For arcs and lines, you can change the type of line, its color, and the width of the line. In addition, you can use interleaved line styles to create the appearance of intersections for overlapping intersections and lines within a single layer. Interleaved line styles are available for use with lines of the same style and color (they can be different widths). Interleaved line styles are not available for solid lines or borders.

   Any edits to an object’s default settings will be applied during the entire work session until you make new changes. To save the settings, you must save the table where the object resides.

   You can also change the display of an object in Layer Control. In the Layer Control window, select the layer and then click the Layer Properties button. In the Layer Properties dialog box, under the Layer Display tab, check the Style Override check box. Click the Style button to bring up the appropriate style dialog box.

   Note: The settings you specify are temporary unless you save the table to a workspace.

   • For more information, see Using Interleaved Line Styles in the Help System.

Printing Fill Patterns

When it comes to printing objects, some fill patterns print faster than others. In general, the fill patterns on the top row of the pattern list in the Pattern drop-down list print the fastest. The difference in printing speed varies from printer to printer. The fill patterns on the top row are also the ones most likely to plot correctly on pen plotters, although results depend on which plotter driver you use. For more coaching on printing fill patterns, review the MapInfo Pro Printer Guide, which is located in the Documentation subfolder of your installation directory.

Drawing Polygons and Polylines

Drawing polygons is different than drawing other shapes because you are creating a region on which you can perform other editing and analysis.

For instance, you want to create school districts for your map. You have a street map of your town to guide you in defining the school district boundaries.

To create a polygon:
1. Choose the **Polygon** tool. The tool becomes a cross hair.
2. Click a starting point for the polygon.
3. Continue to click to add segments to the polygon.
4. When you are ready to complete the object, double-click the last end point.

   You can delete the last node by pressing the **Backspace** key.

**Note:** If there is only one node left in the object it will not be deleted.

You can then use the Combine command to combine this region with another, reshape the region, etc.

Polylines are made up of multiple line segments that are treated as one object. Unlike lines created with the Line tool, you can smooth polylines into a continuous curve using the Smooth command. Again, you can delete the last node by pressing the **Backspace** key.

**Note:** If there is only one node left in the object it will not be deleted.

**Drawing Orthogonal Polygons**

You can draw orthogonal (right angle) polygon line segments when you press the **Ctrl** key. Using this key you can draw the polygon at 45 degree increments relative to the slope of the last line segment. This functionality works for Add Line, Add Polyline, the Ruler Tool, Custom Polyline and Custom Polygon tools, and the Add Polygon operations.

This functionality is useful when you want to draw perpendicular lines at an angle rather than horizontal to the map.

**Note:** Snap and Autotrace functionality must be turned off to use this feature, because when these features are activated, the **Ctrl** and **Shift** keys have other purposes. The **Shift** and **Ctrl** keys also do not operate when you are using the **Polygon Select** tool.

To see this functionality:

1. From the **File** menu, click **Open** and select a map to display.
2. Choose **Map > Layer Control** and click the **Editable** icon to make the layer editable.
3. Select the **Polygon** tool from the **Drawing** toolbar.

**Note:** This works with any of the Line, Polyline, the Ruler Tool, Custom Polyline and Custom Polygon tools as well, we are just using the Polygon tool as an example.

1. Click and draw a single line in any direction other than horizontal following these directions:
   - To draw the next segment perpendicular to the last segment, press **Ctrl** while dragging the cursor.
   - To draw the next segment perpendicular to horizontal, press **Shift** while dragging the cursor.

**Tracing Polylines and Polygons**
When you are drawing a new polyline or polygon, you can use **Autotrace** to trace nodes from existing polylines or polygons. The Autotrace tool is only in effect when you are using a polygeometric tool (Add Polyline, Add Polygon, or Select Polygon) and Snap is on.

Use Autotrace to trace a boundary of an existing object and avoid creating splinter polygons trying to trace a difficult line.

To trace the nodes of an existing polyline or polygon:

1. Press the **S** key to activate Snap Mode.
2. Press the **T** key to activate Autotrace (for information about autotrace, see **Autotracing Objects**).
3. Click on the first node of the polyline/polygon you want to trace.
4. Move the mouse to another node of the same object. Follow the procedure below for the type of object you are tracing:
   - **Polyline**: Hold down the **Shift** key or the **Ctrl** key and click.
   - **Polygon**: Hold down the **Shift** key for the shorter set of nodes or the **Ctrl** key for the longer set of nodes and click.

   Pressing the **Shift** or **Ctrl** keys highlights the trace path. Click to automatically trace the segments between the nodes and add them to the polyline/polygon you are drawing.

5. Continue until you have traced the entire polygon/polyline and right-click to end.

**Note:** Autotrace only one object at a time; clicking nodes in different objects will produce a straight line between the two nodes.

### Converting a Polyline to a Region

To convert a polyline into a region:

1. Make the Map window active.
2. Choose **Map > Layer Control** and click the **Editable** icon to make the layer editable.
3. Select the polylines you want to convert to a region.
4. On the **Objects** menu, click **Enclose**. The **Create Region Objects From Enclosed Areas** dialog box displays.
5. Click **OK** to convert the polyline you selected to a region.

You can also convert regions to polylines. For these instructions, see **Converting Regions to Polylines**.

### Splitting Polylines at Nodes

A single-section polyline can be split into two polylines at a selected node.

To split a single-section polyline:

1. From an editable layer, select a single-section polyline
2. Click the **Reshape** button from the Drawing tools.
3. Select one node (other than the first or last node).
4. Select the **Objects** menu, then **Polyline Split at Node**
5. If a layer is not a cosmetic layer or if the polyline is in the classic **Layout** window, the **Data Disaggregation** dialog box will appear. Here the user can specify how data is disaggregated.
6. After selecting the data disaggregation method, click **OK**. The selected polyline will be split at the node into two polylines.

Error messages display under the following conditions:

- You did not select a node of the polyline.
- You selected a beginning or ending node of the polyline.
- You selected more than one node of the polyline.
- The object that you selected is not a polyline object.
- You attempted to split a multi-segmented polyline (only single-section polylines can be split).

### Converting Objects into Polyline Objects

If a region contains lakes or islands, and you convert that region to a polyline, the polyline has multiple sections. Each lake or island comprises one section of the polyline. When you convert a circle or ellipse into a polyline, the polyline contains 102 nodes. When you convert an arc into an ellipse, the number of nodes depends on the starting and ending angle of the arc. If the arc spans 180 degrees (for example, the starting angle is zero and the ending angle is 180), a polyline based on the arc will contain 52 nodes; if the arc spans 90 degrees, a polyline based on the arc will contain 26 nodes; etc.

The **Help System** contains these related topics:

- **Displaying Distance while Drawing Objects**
- **Displaying Distance, Length, Perimeter, and Area Calculations**
- **Specifying Distance, Length, Perimeter, and Area Calculations for a Particular Map**

### Drawing Symbols

Symbols on your maps make your map more expressive and easier to understand. This section explains how to change a style currently used by MapInfo Pro and create your own custom symbols. We also discuss in detail the rules governing symbols.

To draw symbols, make the layer you want to draw the symbols to editable and choose the **Symbol** tool. Place the cursor where you want the symbol to be and click. The symbol displays using the default symbol style settings.

The **Help System** contains these related topics:

- **Adding Point Symbols to your Map**
• Specifying Symbol Styles of Point Objects
• Changing the Location of Point Symbols

Changing a Symbol Style on a Map

To change a symbol's style on a map:

1. Select the symbol with an appropriate selection tool.
2. Do one of the following:
   • Click the Symbol Style button
   • On the Options menu, click Symbol Style

   Using either method, the Symbol Style dialog box displays.

   **Note:** The options in the Symbol Style dialog box may be different depending upon the size and complexity of the image.

   Here you can change the symbol, font, color, and size, as well as create background effects and bold face for symbols.

   Select the Display at Actual Size check box to see the symbol you selected at the size it was originally created.

   Click the Reload button to refresh the list of custom symbols stored in the Application Data CUSTSYMB directory. Select this button if you added a new custom symbol and do not see the symbol(s) in the list.

   Click the Full View button to display the entire view of custom symbols in a separate window. This button displays only when you select the Custom Symbols font type. You use this button when the preview is too large to display completely in the sample area.

3. Make the desired changes, and click OK.

   The symbol displays with the style changes you specified. These settings also apply to any subsequent symbols you draw until you change the settings.

Supported Fonts for Symbols

You have many options when drawing symbols. We support a number of TrueType fonts that carry their own symbol sets. We have also organized a number of symbol fonts around different industries, such as real estate and transportation, making it easy for you to find the symbols you need. MapInfo Pro supports the following fonts:

• MapInfo Cartographic
• MapInfo Transportation
• MapInfo Real Estate
• MapInfo Miscellaneous
• MapInfo 3.0 Compatible Symbols (vector symbols, available as a True Type font in MapInfo Pro):
  the 36 shapes from the MapInfo symbol set
• MapInfo Oil & Gas
• MapInfo Weather
• MapInfo Arrows
• Installed font symbols: symbols available from the installed fonts that offer a symbol set
• ERS Fonts (For more about these fonts, see Homeland Security Symbols in the Help System.)
• Custom symbols: from here you can access user-created bitmap symbols which you have saved
to the CUSTSYM directory. This directory is created during MapInfo Pro installation. See Working
with Custom Symbols for more about this process.

The MapInfo Symbols font is a TrueType font. When you use these symbols, the Background and
Effects options in the Symbol Style dialog box are unavailable.

Working with Custom Symbols

You can create and use your own custom bitmaps as symbols in MapInfo Pro. To access these
custom symbols, place them in the CUSTSYM directory and select them from the Custom Symbols
option in the Font list of the Symbol Style dialog box (Options > Symbol Style). All of the custom
symbols in MapInfo Pro are stored in the CUSTSYM directory. If you cannot find this directory,
there are a couple of places you could check. The location of this file depends largely on the
administration of your computer, the version of MapInfo Pro you use, and the location of your
installation directory.

Usually, this directory is located in Program Files\MapInfo\Professional\ (or one of its subdirectories)
or in \Documents and Settings\user’s login directory\Applications Data\MapInfo\MapInfo\version
number\. If you cannot find this directory, click Start and Search and search for \CUSTSYM on
your system.

Note: If you add custom symbols while you are working in MapInfo Pro, open the Symbol Style
dialog box and click the Reload button to ensure that the new symbol(s) you have added
display. Otherwise, you have to exit MapInfo Pro and re-enter it to get the new symbols to
display in the Custom Symbols list.

When you change the style of a custom symbol, the Effects options in the Symbol Style dialog box change. You can either show a background or apply a color.

• Show Background displays the custom symbol with the background color with which it was
  created.
• Apply Color replaces all non-white pixels with a color you choose from the color palette.
• Display at Actual Size shows the symbol at its actual size.

When you are creating extended custom symbols we recommend you check the Show Background
check box if you do not require transparency. This setting improves performance significantly during
exporting and Drag and Drop operations.

MapInfo Pro ships with custom symbols that you can use to enhance your maps.
The Help System contains these related topics:

- Understanding the Custom Symbol Types
- Understanding the Custom Symbol Sizes, Shape, and Color Rules
- Adding User-Defined Custom Symbols

Displaying Overlapping Symbols

When point objects display at the same coordinate, you can miss the significance of their proximity because the data overlaps each other, preventing you from making the connection.

The Dispersed Groups symbol font gives you a way to display symbols that represent different organizations, events, or services that occupy the same coordinate location without overlapping each other. When you zoom out from the coordinate point, these symbols display around the coordinate point side by side. This font is installed when you install MapInfo Pro.

This symbol style is useful in several industries:

- Crime mapping: See multiple incidents at the same address and for traffic incident analysis
- Insurance: See multiple policy holders, policies, claims, or inspection requirements at the same address
- Wireless telecom: See multiple assets on the same mast/tower
- Health care: See multiple incidents at the same address
- Retail: See multiple attributes of a retail store, for example what internal franchised departments it contains or specific services that it offers.

For specific instructions, see Displaying Overlapping Symbols in the Help System.

Working with Text on the Map

Although the labeling feature takes care of most of your text needs, you will still need to create text objects with the Text tool to annotate your map or a classic layout (for example, map titles and subtitles). Unlike labels, text objects have no connection to data.

To create text, make sure the layer you want to draw the text to is editable and choose the Text tool. The cursor changes to an I-beam. Place the cursor where you want the text to be and type in the text you want.

To enter text onto a map:

1. Click the Text button in the Drawing toolbar. The cursor turns into an I-beam when moved over the active window.
2. Click the cursor at the place on the map, classic layout, or data displayed in the Browser window where you want to enter the text. A blinking cursor appears. In a Browser, press Tab to move to the next cell.
3. Type the desired text. The text will appear at the blinking cursor as you type.
4. When you want to move to a new line of text press **Enter**.

5. When you are finished entering text, press **Esc** or click the **Select** button in the **Main** toolbar and click the mouse somewhere else on the map or classic layout.

**Note**: The font used is the current font, as indicated in **Options > Text Style**.

To change the style of the text:

1. Select the text with the **Select** tool.
2. Do one of the following:
   - Click the **Text Style** button in the **Drawing** toolbar
   - Choose **Options > Text Style**

   Using either method, the **Text Style** dialog box displays where you can change the font, the size, color and create various effects such as haloing or drop shadows.

   These settings will remain in effect for any text you subsequently draw on the map until you change them.

3. To save changes, on the **File** menu, click **Save**. To save objects drawn to the Cosmetic Layer, on the **Map** menu, click **Save Cosmetic Objects**.

### Editing Objects

1. In all likelihood, you will need to change or edit some of the objects you have drawn or mapped. To begin this process, you need to make the layer that you want to change editable (on the **Map** menu, click **Layer Control**, and then click the **Editable** icon for the layer).

To edit an object:

1. Select the object with the **Select** tool.

   - If the object is a line, edit handles appear at either endpoint.
   - If the object is a boundary or region, edit handles appear at the outer corners of the object.

2. Drag the object to a new position or change its line style, fill pattern, or symbol.

3. On the **File** menu, click **Save** to save your changes.

To delete an object:

1. Click the object with the **Select** tool.

2. Do one of the following:
   - On the **Edit** menu, click **Clear** or on the **Edit** menu, click **Cut**.
   - Press the **Delete** key.

   Using either method, MapInfo Pro deletes the object. To view an object's nodes, centroids, and line direction when editing and drawing, set the conditions in the (**Layer Control**) **Layer Properties** dialog box.
Positioning and Sizing your Map Objects

To move an object to a new location, make the object's layer editable and click the object to select it. Hold down the mouse button for at least one second until the cursor turns into a four-headed arrow. Drag the object to its new location and release the button. The object maintains its shape.

To move an object (in an editable layer) one pixel at a time, click it and press and hold the Ctrl key and press the Arrow button corresponding to the direction you want the object to move. To move the object 10 pixels at a time, press and hold the Ctrl and Shift keys and press the Arrow button corresponding to the direction you want the object to move.

Also, if you click the on the fifth edit handle (rotate handle) and hold down the mouse button, you can rotate the highlighted box to the desired angle. A rubber banding box is drawn representing the bounds of the rotated object. If you press and hold the Shift key while the rubber banding box is being drawn, the rotation will be limited to 45 degree increments.

Moving Objects on the Map

You can move selected objects within its editable map layer easily.

To move an object on the map:

1. Click your map to make it active.
2. Make the layer where the object is located editable. Choose Map > Layer Control and click the Editable icon to make the layer editable.
3. Select the object(s) using the Select tool.

If you select more than one object at a time to move, the objects move in the same way. Take care to ensure that you do not move an object off the map or off land by mistake.

**Note:** When you move the objects, you move them all at once, maintaining their positions relative to one another.

4. Do one or all of the following:
   - To move the selected object(s) using the mouse, hold down the mouse button and drag the object to its new location
   - To move the selected object(s) one screen pixel at a time, press and hold the Ctrl key and press the Arrow key in the direction you want the object(s) to move
   - To move the selected object(s) 10 screen pixels at a time, press and hold the Ctrl and Shift keys and press the Arrow key in the direction you want the object(s) to move

   **Note:** Since the moves are made in screen pixels, the zoom level affects how far the object is moved.

Offsetting Objects on the Map

The Offset feature makes a copy of the object(s) you select from the original source object(s) and saves them in the original data file.
You can both move and offset the objects you select using this process. The difference between these two operations is whether MapInfo Pro makes a copy of the data (as in the case of copy) or simply moves the objects and stores the new value in the original table.

To move/offset selected objects on the map:

1. Click your map to make it active.
2. Make sure a layer is editable. Choose **Map > Layer Control** and click the **Editable** icon to make the layer editable.

   The offset/move functionality is available when any layer is editable, not just when the objects you want to move or offset are in the editable layer. However, you can only move an object within its editable layer. Copy is always permitted as long as a layer is editable.

3. Select the object(s) using the Select tool.
4. On the **Objects** menu, click **Offset**.
5. In the **Offset Objects** dialog box, to move your selected objects, enter or select from the following options and click **OK** to apply the changes. To copy your selected objects to offset them, enter or select from the following options and click **Next**. Then go to **step 6**.

   - **Angle** - To offset your selected object at an angle, type the angle (in degrees) in this field. The new object is created based on the original object and is offset in the direction of the angle you specified, measured from the positive X-axis. If you enter a positive angle, the object is offset counterclockwise; if you enter a negative angle, the object is offset clockwise.
   - **Distance/Units** - To set the offset distance and units, type the distance and select the units in the **Distance** box. The list of units is as follows: inches, links, feet, U.S. Survey feet, yards, rods, chains, miles, nautical miles, millimeters, centimeters, meters, and kilometers.

   **Note:** MapInfo Pro takes the default units from the map window in which you've selected the object.

   - **Create Copy** - Click this option to create a copy of the selected object(s) in the data. When you complete this process, MapInfo Pro saves the copy to the editable layer.
   - **Move Objects** - Click this option to move the object without creating a copy in the data. You can only move an object within its own editable layer. When you move objects, the **Data Aggregation** dialog box does not display, since you are only moving the data within the layer.
   - **Copy or Move Distance Using** - The option you select in this box depends largely upon the projection of your source map. If your map has a latitude/longitude projection, MapInfo Pro enables the **Spherical** type only. If you are working with a non-Earth projection, MapInfo Pro enables the **Cartesian** type only.

   When you click **Spherical**, MapInfo Pro calculates the copy/move distance by mapping the data into a Latitude/Longitude On Earth projection.

   When you click **Cartesian**, MapInfo Pro calculates the copy/move distance by considering the data to be projected to a flat surface and distances are measured using Cartesian distance calculations.
6. The **Data Aggregation** dialog box displays if one of these conditions are true:

- You clicked the **Create Copy** option
- You selected objects in a different table from the table associated with the editable layer
- The editable layer is not the cosmetic layer and has no text associated with the spatial objects in it

You may notice that the only controls available to you in this dialog box are **Blank**, **Value**, and **No Data**.

Type a value you will remember in the **Value** field of this dialog box. For more information about data aggregation, see *Aggregating and Disaggregating Data*.

7. Click **OK** to copy the data and offset the objects you selected.

**Rotating Objects on the Map**

To rotate an object or objects by a specific angle, use the Rotate Objects tool, which is available whenever you have selected an object(s) in an editable layer in a **Map** or classic **Layout** window.

To rotate an object or objects in a **Map** or **Layout** window:

1. On your editable layer, select the object(s) you want to rotate.
2. On the **Objects** menu, click **Rotate** to display the **Rotate Objects** dialog box.

![Rotate Objects dialog box](image)

3. In this dialog box, you specify the angle and the anchor point of the rotation. Type the rotation angle in the **Rotation** field.

**Note:** The rotation angle can be positive (counter clockwise) or negative (clockwise).

1. Determine the anchor point by doing one of the following:
   - Accept the default anchor point of the selected object(s) by leaving the X and Y coordinates that display in these field as they are
Note: The default anchor point varies depending upon how many objects you have selected and the kind of objects they are. See Understanding an Object's Default Anchor Point for more about default anchor points.

- Type new entries in the X and Y coordinate fields to select a new anchor point.
- Click the Pick from Map button and click the anchor point you want on the Map or Layout window. Click the mouse button only once to establish this point.

Note: When the Pick from Map button is disabled, you can select locations directly from the open map. If a map is not open, you can select another tool (like the Select tool) and use that tool instead of the Pick from Map functionality.

To return to the default anchor point, click the Reset Anchor button.

2. Decide whether or not you want to lock the anchor point. Click the Lock Anchor Point Position check box to lock the anchor point.

When you lock the anchor point, you ensure that the anchor point will not be recalculated when you return to the Map or Layout window. If you do not lock the anchor point, MapInfo Pro recalculates the anchor point based on the rotated selection. Once the objects are rotated, they may have a different anchor point.

Note: You cannot maintain an anchor point lock when you change the selection from the Map window to the Layout window or from the Layout to the Map window.

3. When you have completed these entries or selections, click OK to rotate your object(s).

Understanding an Object's Default Anchor Point

When rotating objects in an editable layer, the default anchor varies depending upon how many objects you are rotating and the kind of objects you select. If you select:

- A single object (not a polyline), the default anchor point is the object's centroid
- A single polyline or several objects, the default anchor point is the center of the polyline's or the selected objects minimum bounding rectangle (MBR)
- Multiple objects, the default anchor point is the center of the MBR of the selected objects

Changing your Map Object Attributes

When you double-click a region, line, point or text object with the Select tool, MapInfo Pro displays an Object Attribute dialog box. This dialog box gives you the object's size, its position, and other information specific to the object.

For example, if you double-click a region, MapInfo Pro displays the perimeter, centroid, and area. It also shows the type of distance calculation that was used to obtain these values.
If the layer is Selectable but not editable, you can only view these attributes. If the layer is also editable, then you can change these attributes by typing new values into the text boxes of the dialog box. The illustration above shows the **Object Attribute** dialog box for a region object in an editable layer. You can also access this dialog box on the **Edit** menu (click **Get Info**).

Changing an object’s size and position with the **Object Attribute** dialog box gives you much greater control over its exact size and position than you have through drawing it on the screen. For example, you have a list of ten radio towers and their X and Y coordinates. You could geocode these points using the Create Points command. However, if you bring up the **Points Object Attribute** dialog box and type the new X and Y coordinates, you can create ten points with the Symbol tool and then individually place them in the correct location.

You can also use the **Text Object Attribute** dialog box to change the point’s actual text. For example, you have typed the title "World Population" on a Map window. You want to fix your typographical error. Bring up the **Object Attribute** dialog box for the text object. You can correct your error in the box that displays the text.

• For more information, see *Changing Attributes for Multiple Layers* in the Help System.

### Reshaping Map Objects

You can reshape regions, polylines, lines, arcs and points. A region is an object created with the Polygon tool. You cannot reshape objects created with the Rectangle tool, the Rounded Rectangle tool, or the Ellipse tool.

To reshape an object:

1. Select an object with the Select tool.
2. Do one of the following:
   • **On the Edit menu, click Reshape**
   • Use the **Reshape** button on the **Drawing** toolbar.
You are now in Reshape mode. MapInfo Pro draws nodes at every juncture where two polyline or polygon line segments meet.

3. To reshape the object, move the nodes, add nodes, or delete nodes from the object.

   To move a node, click it and, while holding down the mouse button, drag the node to the desired location. The line segments connected to the node are moved to a new position.

   To add a node, click the Add Node tool from the Drawing Toolbar, position the cursor where you want to add the node, and click the mouse button. MapInfo Pro adds a node. You can move this node or delete it, just as you would any node.

   To delete a node, position the cursor over the node, click it, and press the Delete key. To delete the last node when creating a polyline or polygon, click the Backspace key.

The Reshape command is very useful when you are creating sales territories or other merged boundaries. For example, you are merging postal code boundaries together to create school districts. Some postal code boundaries fall into more than one school district. Use the Reshape command to reshape the school district to incorporate a section of a postal code boundary.

Selecting Multiple Nodes

Reshape mode allows you to easily select nodes of an existing object and copy and paste them, drag them to reshape the object, delete them, etc. To trace an existing object, we recommend that you use the autotrace feature, which is explained in the next section, Snap to Nodes. The following illustrations show how to copy the border between Kentucky and Indiana.

1 Select the object. Click Reshape mode to display the nodes.
2 Select the nodes you want to copy.
3 Choose Copy and Paste to display the new objects with edit handles (small squares).
4 Click and drag the object to move to another location.

To reshape an object (such as the state of Kentucky):

1. Select Kentucky to enable Reshape mode.
2. Select the first node with the Select tool. Shift-click the last node to be copied. MapInfo Pro selects all nodes between following the shortest route. (To select all nodes except those between the shortest distance, use Ctrl-click with the Select tool.)
3. On the Edit menu, click Copy to copy the nodes to the clipboard.
4. Paste the duplicate nodes onto the map. On the File menu, click Paste. The object you copied is drawn on top of the original object as a polyline.
5. To move the polyline click it and drag the polyline to a new location.

Using "Snap To" to Select Nodes and Centroids

You can use nodes to reshape an object and align objects with each another. MapInfo Pro refers to this process as snapping to a node. In the Map window, regions, polylines, lines, arcs and rectangles all have nodes that can be attached (or snapped) to each other. When the Snap mode is enabled, MapInfo Pro searches for nodes and centroids as you move around a window. MapInfo Pro automatically snaps the cursor to a node or centroid when the cursor comes within the snap tolerance of the node. The crosshairs display when the node is "snapped to".

Note: You can also use the snap to capability to snap to visible centroids in region objects.

To toggle Snap to Nodes, press the S key. The Status Bar displays with the word "SNAP" when Snap mode is activated. When you activate the Snap mode, a circle displays around your cursor showing the size of the tolerance of the Snap mode in pixels. The S key acts like a toggle on/off switch. You can set the snap tolerance in pixels in the MapWindowPreferences dialog box. The Snap Tolerance field allows you to specify a tolerance. If you set the snap tolerance to 3 pixels, whenever you move the cursor within 3 pixels of a node, the cursor will snap to the node.

Snap mode works in the Map window, classic Layout window, and a map in a Layout Designer window (but not raster layers). It works with all MapInfo Pro tools in the Main and Drawing toolbars except Pan, Drag Map, and Text tool. Additionally, snap mode works on object types, including regions, points, multipoints, collection objects, lines and polylines, rectangles, and arcs. It is not available for text objects, ellipses, and rounded rectangles. You set the Snap in one window at a time and can save it with your workspace.

Snap to Nodes applies to all selectable layers—this is useful if you are drawing an object in one layer and want to attach it to an object in another layer. If you do not want to snap to objects in certain layers, make those layers unselectable.

Snap and Thin Settings Saved in Metadata

The Snap and Thin settings remove self-intersections and overlaps in your data based on values you establish. When you complete your selections and entries in the Set Values for Node Snap & Thinning dialog box, MapInfo Pro saves these values to the table's metadata. This allows the Snap and Thin changes to be retrieved after the table is saved or you have left MapInfo Pro.
Setting Snap Preferences for a Visible Snap Area

The Map Window Preferences dialog box has a Display Snap Radius check box that controls whether or not the snap radius displays when Snap mode is on. The snap tolerance (in pixels) can also be selected.

- From the Options menu, select Preferences, then Map Window to display the Map Preferences dialog box.

On the Editing tab, under the Digitizing Options section, you can change the snap tolerance to make the snap radius larger or smaller (measured in pixels).

If you clear Display Snap Radius check box, then the radius does not display when snap mode is turned on. Remember to click OK to save your preferences.

Move Duplicate Nodes

In most maps, nodes of various objects are usually connected, especially for adjoining streets and boundaries that share a common border. Using the Move Duplicate Nodes Option under Map Window Preferences, you can specify where MapInfo Pro looks for connected nodes in order to move them in unison. Choose the None of the Layers button to turn the option off. Choose the
**Same Layer** button so that connected nodes in the same layer are moved when one of them is moved.

**Autotracing Objects**

You can trace the nodes of an object, for example, the Yucatan in Mexico using the Polyline or Polygon tools. This makes it easier to digitize objects that share a border because you do not have to re-digitize the shared border. You can also use this feature to trace an existing polygon/polyline network, for example, a street, a county, or some other polyline or boundary. A Status Bar entry displays showing that this mode is enabled.

To trace a border:

1. Open a Map layer you want to trace a polygon or polyline on.
2. Make the layer editable.
3. Press the $S$ key to turn on the Snap process and the $T$ key to turn on the Autotrace functionality.
4. Select the **Polygon** or **Polyline** tool from the Drawing toolbar and select the first node you want to trace.
5. Drag the mouse along the nodes of the line or object you want to trace.

The rules that apply to AutoTrace are:

- To enable the AutoTrace mode, you must use the **Polygon** or **Polyline** tool.
- You must press $S$ to enable the Snap feature to use the AutoTrace feature.

You can use the **Shift** or **Ctrl** key functionality for this mode. When you AutoTrace a polygon, the path contains the least number of nodes necessary to complete the AutoTrace, which is similar to...
the **Shift** key behavior. If you want to trace the longer path, press the **Ctrl** key to override default AutoTrace direction. When you are autotracing a closed polyline, the trace line never crosses the start and end points of the polyline (so the **Ctrl** key has no effect).

*AutoTrace entry in Status Bar.*

### Smoothing and Unsmoothing Lines

You can use the Smooth command to convert polyline angles into polyline curves.

To smooth a polyline angle into a polyline curve:

- Click a polyline with the Select tool and on the **Objects** menu, click **Smooth**. MapInfo Pro smoothes the line so that it appears to be one continuous line with curves instead of angles.
- To undo the process choose either the **Undo Smooth** command or on the **Objects** menu, click **Unsmooth**.

Both the Smooth and Unsmooth commands can be used only on polylines. A polyline is a line drawn with the Polyline tool. Smooth and Unsmooth do not work with objects drawn with the Line tool. If you attempt to smooth or unsmooth any object besides a polyline, MapInfo Pro displays a warning message.

### Converting Regions to Polylines

You may find it necessary, on occasion, to change an object into a polyline or a polyline into a region during an editing session. You can do so simply by selecting the object and on the **Objects** menu, click **Convert to Region** or **Convert to Polyline**.

For instance, you select a group of nodes that you want to copy and paste elsewhere on your map. MapInfo Pro treats the group as a polyline and copies it to the clipboard. After you paste the polyline on your map, you can convert it to a region on the **Objects** menu, click **Convert to Region**.

If you want to create a buffer zone within one mile of a boundary, meaning you want a zone that extends one mile from the boundary to the outside and to the inside, you must first convert the region to a polyline and then create the buffer. If you first create the buffer on the region, you will include too much territory in the buffer (the entire region in the buffer plus the one mile buffer that extends outside of the region).

Converting objects to polylines and regions allows you to perform node-editing operations on objects that ordinarily do not allow node editing. For example, you cannot add nodes to a rectangle object. If, however, you first convert the rectangle into a polyline or region, you can then add nodes to the object.

The **Help System** contains these related topics:

- **Editing Street Maps (StreetPro)**
Merging One Map into Another

There are two ways to merge layers from one Map window to another:

1. You can use the Drag Map Window functionality to drag the layers of an existing Map window onto the another Map window.
   
   To see this method, see *Merging Maps using the Drag Map Window Tool* in the Help System.

2. You can copy the map layers you want from one map to the other in the Layer Control window.
   
   To see this method, see *Merging Maps from Layer Control* in the Help System.

When you merge the layers from the source map on top of the destination map, the destination map settings take precedence. This means that the clip regions and coordinate systems, for example, are based on the settings in the destination map. If the destination map does not allow raster reprojection and the source map has a raster layer, the coordinate system of destination map could change.

Consider this example of a vector map and a raster map. Many times you want to add detail to a map by merging it with another open map. You can think of the map you are dragging or copying layers from as the source map.

**Figure: Alaska Raster Map (Source Map)**
You can think of the map that you are dragging or copying the layers to as the destination map.

**Figure: Alaska Vector Map (Destination Map)**

**Note:** MapInfo Pro does not copy the Cosmetic layer objects or thematic layers from a source map to the new window, so any symbols or features you have created there do not merge.

- For more information, see *Merging Maps using the Drag Map Window Tool* and *Merging Maps from Layer Control* in the Help System.
9 - Selecting and Querying Data

This chapter presents the ins and outs of selecting records from tables. As you use MapInfo Pro you will find yourself selecting records quite often. This chapter covers an overview of selecting and querying methods using tools from the Main toolbar.

In this section

- Selecting Your Data in MapInfo Pro 251
- Querying Your Data in MapInfo Pro 259
Selecting Your Data in MapInfo Pro

While MapInfo Pro allows you to attach data to objects on a map, its true analytical power is its ability to group and organize data. Once your data is broken down into logical groups, you can analyze it based on one or more variables.

For example, you have a basket of fruit. You want to organize the fruit into different categories, based on one or more variables:

- Put all the apples into one group
- Put all the citrus fruit into one group (oranges, lemons, grapefruit)
- Put all the fruit that begins with a vowel into one group (oranges, apples, apricots)

There are many different ways that you could group the fruit. Some fruit would fall into more than one category (oranges are citrus fruit and also begin with a vowel). You could also use more than one variable to group your fruit - put all the citrus fruit that begins with a vowel into one group.

MapInfo Pro can retrieve information or even individual records from within your data. We refer to the record or records that are retrieved this way as selections. A selection is a subset of data that has been collected based on one or more variables.

For example, you have a table of customer records. You could create a subset of all customers who live within a 50 mile radius of Prague. Or, you could create a subset of all customers who purchased over $1000 of merchandise. Or, you could create a subset of all customers whose last name begins with the letter "B". 
The statements above used to create these subsets are known as *queries*. A query is just another word for a question - which of my customers spent more than $1,000? Which of my customers lives within 50 miles of Prague?

As with the fruit example, there are many different ways to group your data. Some data records will obviously fall into more than one category. You could also use more than one variable to group your data. Which of my customers lives within 50 miles of Prague and purchased over $1000 of merchandise? This section gives you some examples and some practical applications of "selecting" in MapInfo Pro.

**Characteristics of Selections**

Selections are temporary tables. When you make a selection, MapInfo Pro creates this temporary table (called a selection) to store the records you have selected.

You can perform many of the tasks with a selection table that you can perform with a permanent (base) table such as:

- View it in a Browser, a Map (if it has graphic objects), a Graph, classic Layout window, or a Layout Designer window.
- Cut and copy it into the clipboard and paste it into another table, or even into another application.
• Use it to edit a table. If you want to edit only certain records in a table, you can get those records into a selection and then edit that selection.
• Make a further selection from it.

To convert selections into permanent tables, on the File menu, click Save Copy As. Once you have saved the temporary selection table as a permanent table, you can treat the new table like any other table. Selection tables are totally dependent on the table from which they were created. If you close a base table, all associated selection tables are deleted.

Selection Commands and Tool Descriptions
MapInfo Pro gives you a number of commands and tools for making selections. They fall into two categories:

• Selecting from the screen: Select tool, Radius Select tool, Boundary Select tool, Polygon Select tool, Marquee Select tool, Invert Selection tool, Select All command. To select records with the tools, click or encircle the associated graphic objects. To select records from a layer at the same time, on the Query menu, click Select All. Or, select a layer on the map, right-click to display the context pop-up menu, and select Select All from Selected Layer.
• Selecting with queries: Select, SQL Select. When you select records with either of these methods, you create a logical expression that MapInfo Pro uses to select the records. For example, the expression SALES > 20000 means that MapInfo Pro will select only those records with sales higher than $20,000. We discuss Select and SQL Select in more detail in Using Select to Create Queries and Using SQL Select to Query Data).

To import a GML file:

1. Choose Table > Import to display the Import File dialog box. Choose OS MasterMap (*.GML) from the Files of type drop-down list and navigate to its location.
2. Select a GML file to import. Click Open. The GML Import dialog box displays.

Selecting from the Screen
To select objects from the screen, the layer that contains the objects must be Selectable. To make a layer selectable, on the Map menu, click Layer Control. In the Layer Control widow, click the Selectable icon to make the layer selectable.

When you select map objects in a Selectable layer, MapInfo Pro highlights the objects using the settings defined in the Highlight Control section of the Preferences dialog box (Options menu). When you select map objects in an Editable layer, MapInfo Pro places edit handles (small squares) around the extents of the object you selected.

If you have more than one Selectable layer in a Map window, MapInfo Pro selects objects from the topmost Selectable layer.

For example, you have a Selectable layer of county boundaries and a Selectable layer of state boundaries. If the county boundaries are in the topmost layer in the Map window, MapInfo Pro selects objects from the county layer. If the state boundaries are in the topmost layer in the Map window, MapInfo Pro selects objects from the states layer. When you use the Select tool, MapInfo
Pro also displays InfoTips for the topmost Selectable layer. As you move your cursor over the objects, InfoTips display the object's label expression. You can turn off the InfoTips in the Map window Preferences (on the Options menu, point to Preferences and click Map window).

Likewise, if you perform a boundary search, the boundary object that you want to search should be in the topmost layer.

For example, you have a layer of postal code boundaries and a layer of state boundaries. If you want to select all objects that fall within a postal code boundary, the postal code layer should be the topmost boundary layer. If you want to select all objects that fall within a given state, the state layer should be the topmost boundary layer. You can reorder the layers by selecting the Map menu, and clicking Layer Control.

You can select objects from tables other than the topmost table, by holding down the Ctrl key when you are selecting an object. For example, say you have three selectable layers, such as STATES, COUNTIES, and CITIES. If you want to select objects in the STATES table, but it is the bottom layer in the Map window, do the following:

1. Hold down the Ctrl key and click the map with the Select tool. You are now in the second layer.
2. Hold down the Ctrl key and click the map again with the Select tool. You are now selecting objects from the third layer, the STATES layer.

Selecting a Single Object from a Map or Layout

Making selections is a basic MapInfo Pro operation, using the Select tool is only one way of making selections.

The tool must be active before you can use it; activate the tool by clicking on it. The tool's icon is highlighted in the Main toolbar and the cursor becomes a pointer. If you are editing records in a browser, the cursor becomes an I-beam.

To select a single object from a map or an active map in a layout:

1. Click the Select button in the Main toolbar.
2. Click the object.

The layer where the object is located has to be selectable in the Map window. When an object is selected it is highlighted according to the settings you specified in Options > Preferences.

• When the layer is editable, the selected object is surrounded by edit handles and is colored and patterned as it was originally defined.
• When you select another object, the first object is unselected.
• To select a number of objects from a map or an active map in a layout, hold the Shift key down and click the desired objects with the Select tool.

Selecting Tools

MapInfo Pro includes several tools on the Main toolbar to allow you to choose records for further viewing and analysis, including the Select tool, Radius Select tool, Marquee Select tool, Polygon Select tool, Boundary Select tool, and Invert Selection tool. Each tool is discussed in the next section.
Using the Select Tool

Use the Select tool to select objects one at a time or to select all objects that are generally in the same area of the Map window. You select an object by clicking it using the mouse.

To select an object using the Select tool:

1. Make the layer that you want to select objects from selectable. On the Map menu, click Layer Control and click the Selectable icon for the layer.
2. Choose the Select button from the Main toolbar.
3. Click an object in the Map window. If that object's layer is selectable, MapInfo Pro highlights the object. If the layer is editable, MapInfo Pro puts edit handles around the extents of the object. If the layer is neither editable nor selectable, MapInfo Pro does not allow you to select the object.
4. On the Window menu, click New Browser Window to display selected records in a Browser. Choose Selection from the list of tables. MapInfo Pro creates a Browser of the new temporary table. To select records from the Browser, simply click each record with the Select tool.

To select multiple objects individually in a Map window:

1. Click the first object to select it.
2. Hold down the Shift key and click another object. MapInfo Pro selects that object, too. If you select a second object without holding down the Shift key, MapInfo Pro unselects the first object and selects the second object.
3. For additional instructions, see Selecting the Next Selectable Object Beneath the Current Object in the Help System.

Using the Unselect All Tool

Use the Unselect All tool to deselect all of the selected objects. You use this most often when you have selected too many objects and want to start over.

To select an object using the Select tool:

Choose the Unselect All button from the Main toolbar.

Deselecting Objects and Removing Objects from the Selection

To deselect:

- An object or remove it from the selection in a Map window, press the Shift key while clicking on the object. When you click, the object is removed from the selection set.
- All objects, on the Query menu point to Unselect All, or click on the map where there are no objects.

For additional information, see Moving Selected Objects and Rotating Selected Objects in the Help System.
Using the Radius Select Tool

The Radius Select tool selects all objects that fall within a given radius. For example, you have a table of blood donors and a table of blood donation sites. Using the Radius Select tool, you could create a temporary list of blood donors that live within a one-half-mile radius of each blood donation site.

The Radius Select tool selects all objects whose centroid falls within the circle. The object does not have to be completely bounded by the circle.

To select objects within a radius:

1. Make the layer you want to select objects from selectable. On the Map menu, click Layer Control and click the Selectable icon for the layer. Make sure the layer is either at the top of the list, or that the layers above they layer you want are not selectable.

2. Choose the Radius Select tool from the Main toolbar. The cursor becomes a hand when moved over the Map window.

3. Click a place on the map that you would like to use as the center point of your radius search. For example, if you want to select all the homes of all of the children that live within three blocks of the school, click the school icon and use that as the center point.

4. Hold down the mouse button and drag the mouse away from the center point. MapInfo Pro draws a circle around the point and reports the radius of the circle in the Status Bar (lower left corner of the screen).
5. When you have the desired radius release the mouse button. MapInfo Pro highlights all map objects that fall within that circle.

6. To see a list of all the records that fall within that circle, choose **New Browser Window** from the **Window** menu. Choose **Selection** from the list of tables. MapInfo Pro creates a Browser of the new selection table.

![Query1 Browser](image)

**Using the Marquee Select Tool**

The **Marquee Select** selects objects within a rectangle. By clicking and dragging using the Marquee tool, you create a dotted rectangle, or marquee box around objects you want to select. All Selectable objects in the topmost Selectable layer will be included in the marquee box.

**Note:** To select objects from another layer, you must turn off selectable in Layer Control for the upper layers. Only objects from one layer at a time are selected.

To select objects within a rectangle:

1. Make the layer that you want to select objects from selectable. On the **Map** menu, click **Layer Control** and click the **Selectable** icon for the layer.

2. Choose the **Marquee Select** tool from the Main toolbar. The cursor becomes a hand when moved over the Map window.

3. Click a place on the map outside of the area you want to include in the marquee box.

4. Hold down the mouse button and drag the mouse to form a dotted rectangle around the points you want to select.

5. When you have reached the desired rectangle size, release the mouse button. MapInfo Pro highlights all map objects that fall within that rectangle.
6. To see a list of all the selected records, on the **Window** menu, click **New Browser Window**. Choose **Selection** from the list of tables. MapInfo Pro creates a Browser of the new selection table.

**Adding Objects to the Selection Set**

Use the **Shift** key with the **Marquee Select** tool when you wish to add newly selected objects to the previous selection.

**Using the Polygon Select Tool**

The **Polygon Select** tool selects map objects within a polygon that you draw on a map.

To select objects with the Polygon Select tool:
1. Make the layer that you want to select from selectable. On the **Map** menu, click **Layer Control** and click the **Selectable** icon for the layer.
2. Choose the **Polygon Select** tool from the **Main** toolbar. The cursor becomes a pointing hand when moved over the **Map** window.
3. Click the map location at which you want to place the first end point of the polygon. Move the cursor over your map in any direction. MapInfo Pro draws a line from the point where you clicked to the cursor.
4. Click to create another endpoint. Continue to move the cursor and click until you have the desired number of sides to your polygon.
5. To close the polygon, make your last click as close as possible to the first click. MapInfo Pro closes the polygon and selects the objects that are within it.

**Note:** Press **Shift** while using the **Polygon Select** tool to add newly selected objects to the previous selection.

**Using the Boundary Select Tool**

The **Boundary Select** tool selects objects that fall within a given region or boundary. When you use this tool, MapInfo Pro selects all objects within any boundary on the map, such as state or county boundaries, police precincts, or sales territories.

For example, you have a layer of states and a layer of retailers. Using the Boundary Select tool, you could click a state and create a temporary list of all the retailers in that state.

To select objects within a region:
1. Make the layer that you want to select objects from selectable. On the **Map** menu, click **Layer Control** and click the **Selectable** icon for the layer.
2. Choose the **Boundary Select** tool from the **Main** toolbar. The cursor becomes a cross hair when moved over the **Map** window.
3. Click within a boundary object. MapInfo Pro selects all objects that fall within that boundary.
4. To see a list of all the records that fall within that boundary, on the Window menu point to New Browser Window. Choose Selection from the list of tables. MapInfo Pro creates a Browser window with the new selection table.

Using the Invert Selection Tool

The Invert Selection tool is a convenient way to select many objects at once. You simply select the few objects that you do not want, and then invert the selection to select all the objects you do want.

1. Make the map layer that you want to select from selectable. On the Map menu, click Layer Control and click the Selectable icon for the layer.
2. Make the Select tool active, and click one or two map objects.
3. Click the Invert Selection tool. MapInfo Pro selects all the objects that are not part of the current selection, and cancels the current selection. You can also find Invert Selection in the Query menu.

Unselecting Objects or Records

You may choose to:

• Unselect one object or record from a group of selected objects or records.
• Unselect a group of selected objects or records.
• Unselect all selected objects.

To cancel the selection of a record from a group of selected records in a Browser window, press the Ctrl key while selecting records.

To cancel the selection of all selected objects, you can either click the Map window where there are no objects or choose the Unselect All command from the Query menu.

Querying Your Data in MapInfo Pro

A query is a mathematical question that you pose to your database to collect information. In MapInfo Pro, there are two query builders available under the Query menu, Select and SQL Select.

Figure: SQL Query to Determine Homes Affected by Airport Noise Pollution
In the case of Select, you can pose a question of a single table. For example,

- Which of my customers spent more than $20,000?
- Which of my customers live in Vermont?

In the case of SQL Select, you can ask your question from one or several table(s) of information and perform these tasks:

- Derive new columns - columns that calculate new values based on the contents of your existing columns.
- Aggregate your data so that you see only a listing of subtotals instead of seeing your entire table.
- Combine two or more tables into one results table.
- Show only the columns and rows that interest you.

### Selecting and Using Queries

Select allows you to query a table. It allows you to select records and objects from a table according to their attributes. You can use it to highlight objects in a Map or Browser window that meet certain criteria. You can also create a results table that you can browse, map, or graph like any other table.

For instance, by formulating queries with Select, you can ask MapInfo Pro to:

- Show only postal code regions where the average household income is above $65,000.
- Show only postal code regions where the median age is 42.
• Show only the postal code regions where the household income is above $65,000 and the median age is 42.
• Show only records for all orders received in July or September.
• Show cities of over 100,000 people in Texas, California and Florida.

When you are working in a Browser, MapInfo Pro highlights the records meeting the criteria of the query. When you are working in a Map window, the graphic objects of the chosen records are highlighted. When you are working in both windows, the objects in both are highlighted. In all cases, MapInfo Pro automatically creates a working table called Selection that contains the results of the query. You can browse, map, or graph this table like any other table. The table can also be saved as a separate table with Save Copy As.

Finding an Object or Street Address

To find an object or street address:

Your tables must be mappable and indexed. If you need to set up these components, on the File menu point to New Table (Import) or on the Table menu point to Maintenance and select Table Structure.

1. On the Query menu, point to Find to open the Find dialog box.
2. Click the Search table drop-down list and choose a table from which to search.
3. Click the for objects in column drop-down list and choose the column containing the location information of the objects you are looking for.

You now have the option of refining the search. Use this option when you are trying to find an object or address whose name is not unique and is used for other objects or locations.

For example, when you are searching for the town of Ipswich in Great Britain, do you want Ipswich in Suffolk county or Ipswich in Essex county. Refining the search by county allows you to specify the county for each town, rather than just the town name.

• Optional - Click the Refine search with table drop-down list and choose a refining table (the table must contain regions, such as states, counties, census tracts etc.).
• Optional - Click the using boundary name column drop-down list and choose your refining column, the column containing the name of the boundary.

4. Check the Find in Front Window Only check box when you want the Find operation executed only in the Front Window. When this check box is unchecked, the Find operation is executed in all windows. When checked, if features are found, they will be marked with a symbol in a Map Window. If the Browser window is the active window, it will be scrolled so the record appears in the Browser view.

When you have finished defining where to look for your search data and selecting between the front most map and all maps then specify what data to look for.

5. Click OK to open the Find dialog box. This dialog box allows you to specify what data to look for.

The name of the column that you specified in the first Find dialog box is listed to the left of the list box (for example, Street). When locating a street address, type in "# Name", such as "30 Elm
St" or "1045 Templar Blvd." What you type in depends on geocoding preferences specified on the Options menu when you point to Preferences and select Address Matching.

**Note:** MapInfo Pro comes with a text file called MAPINFO.ABB [MapInfo Pro Abbreviations], that contains a list of common street abbreviations, such as "St" for "Street" and "Blvd." for "Boulevard," and so forth. These help MapInfo Pro to obtain exact matches. To familiarize yourself with the MAPINFO.ABB file, you can take a look at its contents in the Notepad Text Editor.

6. Type the name of the object or address you are searching for in this box. If you have used the Refine option in the first dialog box, a second column name is listed (for example, ZIP).
7. Type the name of the refining boundary in this box. If MapInfo Pro cannot find an exact match for the object you specified, it lists possible matches.
8. Click **Up** or **Down** to move to other pages and choose a specific entry from the list.
9. Click **OK** and the find is initiated.

You can also use the Find command to locate street intersections. When you type in the name of the object to be found in the second Find dialog box (enter object name to find), separate the two items by a double ampersand (&&). For example, to find the intersection of Congress Street and Christie Street, type "Congress Street && Christie Street."

**Finding and Displaying a Selected Object**

When you create a query or a SQL query, you may want to see the results of that query visually on the map.

To find and display a selected object:

1. Do one of the following:
   - On the Query menu, point to Select to open the Select dialog box
   - On the Query menu, point to SQL Select to open the SQL Select dialog box

   The **Find Results in Current Map Window** check box displays in both dialog boxes.
2. Create your query and verify that it is correct, selecting the open table that you want to query.
3. Select the **Find Results in Current Map Window** check box to display the results upon completion.
4. Click **OK** to display the results.
5. For more information, see *Selecting All Objects from a Table* in the *Help System*.

**Figure: Query Results of Urban Population > Rural Population**

---

### Making Queries using the Select Command

*MapInfo Pro has two commands for selecting objects through querying: Select and SQL Select. Select is simpler and SQL Select is more powerful.*

**To make a query:**

1. Choose **Query > Select**. The **Select** dialog box displays.
2. Click on the **Select** records from table drop-down list and choose the table from which to select the records.
3. Type your query expression in the **that satisfy** box, or click the **Assist** button to display the **Expression** dialog box which helps you write an expression.
4. Type a name in the **Store Results** in table box for the temporary table that stores the results of your query or choose selection (the default). If Selection is chosen, MapInfo Pro automatically names the table Query 1, Query 2 etc.
5. To sort the query by the value in some column (optional) click the Sort results by column drop-down list and choose the column containing the value you want to sort with.
6. Click OK. A Browser window of your query results displays if the Browse Results box is checked.

You can use Select to highlight objects in a map or a table that meet certain criteria and create a results table that you can browse, map, or graph like any other table.

• When you are working in a Browser window, the records meeting the criteria of the query are highlighted.
• When you are working in a map, the graphic objects of the chosen records are highlighted.
• When you are working with both a Map window and a Browser window, the objects and the records are highlighted.

In all cases, a working table is automatically created called Query 3. This table contains the results of the query. You can map, or graph this table like any other table. The table can also be saved as a separate table with Save Copy As.

• For more information, see Saving Queries and Loading Templates in the Help System.

Making Queries using the SQL Select Command

To create a query using SQL Select:

1. Open the table you wish to query, if you have not already done so. The table that you query is known as the base table. If you use SQL Select to perform a query on the World table, the World table is your base table.

2. Choose Query > SQL Select. Fill in the portions of the SQL Select dialog box that meet your needs. When you click OK, MapInfo Pro performs the query.

MapInfo Pro extracts data from your base table, stores the query results in a special, temporary table, known as the results table. The results table contains only the rows and columns that meet your criteria. The default name of the results table is Selection (although you can specify a different results table name in the Into Table Named field in the SQL Select dialog box).

3. Open a Map window and/or a Browser window if you want to see the query results. By default, MapInfo Pro displays the results table in a Browser window automatically (unless you clear the Browse Results check box in the SQL Select dialog box).

If your results table is called Selection (the default name), the Browser window shows a different table name, such as Query1 or Query2. This is because the moment you Browse the Selection table, MapInfo Pro takes a "snapshot" of the table, and names the snapshot Queryn (where n is a number, one or greater). MapInfo Pro takes the snapshot because "Selection" is a special table name; Selection dynamically changes every time you select or de-select rows.

In the SQL Select dialog box, you can enter a different name for your results table (e.g. you can name your results table My_Query). This prevents MapInfo Pro from renaming your results table Queryn.

4. MapInfo Pro automatically selects all rows in the results table. Thus, after you perform SQL Select, you can perform operations on the entire set of selected rows. For example, you could
apply a different fill color to all selected rows (by choosing **Options > Region Style**), or you could cut or copy all selected rows.

5. Usually, any alterations you make to the results table are automatically applied to your original (base) table. For example, if you use SQL Select to select some of the rows from the Orders table, and then you delete some of the rows from your results table, MapInfo Pro deletes the corresponding rows from your base table (Orders). However, if your query produces subtotals, you can alter the results table without affecting the base table.

6. Choose **File > Save As** if you want to make a permanent copy of the results table. If you do not perform Save As, the results table will be deleted when you exit MapInfo Pro.

For more information, see *Using the SQL Select Dialog Box's Where Condition Field, Updating a SQL Select Query Table* and *Using the SQL Select Dialog Box's Select Columns Field Templates* in the Help System.

### Displaying Query Results Quickly

When you create a query or a SQL query, you can display the results visually on the map. To find and display the results of a query automatically:

1. Do one of the following:
   - From the **Query** menu, select **Select** to display the **Select** dialog box
   - From the **Query** menu, select **SQL Select** to display the **SQL Select** dialog box

   ![Select dialog box](image)

   The **Find Results in Current Map Window** check box displays in both dialog boxes. If there are no open Map windows, this check box is disabled. You cannot save this check box setting to a template. This option is cleared by default.

2. Create your query and verify that it is correct, selecting the open table that you want to query.

3. Select the **Find Results in Current Map Window** check box to display the results. Click **OK**.
Creating Query Expressions

To perform a Select query, you must create an expression. An expression is a logical statement that is used to ask your question. For example, you have a table of apartments for rent. If you want to create a temporary table of all apartments that cost less than $800 a month, you could use the expression:

- RENT < 800

where RENT is the name of a numeric column that contains the per month rent rate.

MapInfo Pro searches the apartment table for all records that satisfy this condition and puts those records in a temporary table that you can map, browse, graph or carry out additional queries.

You can also perform mathematical operations on your data. For example, you want to create a temporary table of all apartments that have a total cost of less than $800. Total cost is equal to the sum of the rent and the monthly utilities.

You could use the expression:

- RENT + UTILITIES < 800

You are telling MapInfo Pro to add the number in the RENT column and the number in the UTILITIES column and then compare that number to 800.

For more information, see Creating Expressions for details in creating a variety of expressions.

Specifying an Expression

There are two ways of creating an expression. The first method is to type in the expression directly. When you are creating very simple expressions, this method is usually faster. The second method is to click the Assist button in the Select dialog box and build your expression using the pop ups in the Expression dialog box. This method is particularly useful when you are just learning how to build expressions or when you are building very complex expressions.

To specify an expression:

1. Choose Query > Select.
2. In the Select dialog box, click the Assist button.
3. In the Expression dialog box, type your expression directly into this box, or choose from the drop-down list selections to create an expression.
4. Click Verify to verify that your expression is valid.
5. Click OK to return to the Select dialog box.
6. Click OK to run the expression.

The Expression dialog box gives you three drop-down lists that you can use to build your expression: columns, operators, and functions.

Columns
This pop up lists every column in the table from which you are selecting. If the table contains derived columns from previous queries, those columns will also be listed.

**Operators**

This pop up contains mathematical and logical operation symbols. The mathematical operators in this pop up include addition, subtraction, multiplication, division, greater than, less than, and equal signs. You can use these symbols to create mathematical formulas. For example, from your table of sales representatives you want to select those sales representatives who, on the average, gross more than $2000 per month. Gross sales is computed by adding together sales and commission.

You have two columns in your table: TOTAL_SALES, which is total sales for the year for each representative and COMMISSION, which is total commission for the year for each representative. You could build the following expression:

\[
\frac{(\text{TOTAL\_SALES} + \text{COMMISSION})}{12} < 2000
\]

This expression tells MapInfo Pro to add the number in the TOTAL_SALES column with the number in the COMMISSION column. However, this gives you gross sales for the year. We want average gross sales for the month. Therefore, we divide the sum by 12, which will give us a monthly average. We then compare that figure with 2000.

The Operators pop up also includes logical operators conjunctions AND, NOT, OR and LIKE. The LIKE operator can be used with two wildcard characters: `%' and `_'. The `%' character matches zero or more characters. The `_` character matches only one character.

**Functions**

This pop up contains mathematical functions that take one or more parameters and return a value. You use functions to perform basic mathematical functions on the data in that column. For example:

\[
\text{abs(<number>)}
\]

takes the absolute value of the numbers in the specified column.

For example, a meteorologist wants to select all days where the temperature in her city was more than 10 degrees warmer or cooler than the national average. She has a column in her table, AVG_DIFF, that contains the difference between the national average and city average.

She could create the following expression:

\[
\text{AVG\_DIFF} < -10 \text{ Or } \text{AVG\_DIFF} > 10
\]

This expression tells MapInfo Pro to select all records that have an average difference less than -10 or greater than +10. However, she could also create the following expression:

\[
\text{abs(AVG\_DIFF)} > 10
\]

This expression tells MapInfo Pro to select all records where the absolute value of the average difference is greater than ten.

The Functions pop up contains many other functions, including area, perimeter, sin, cos, and date-related functions. For a complete list of functions, see Creating Expressions.

**Verify**
This button reviews the expression you have created and verifies that it is valid. This is particularly helpful if you are new to writing expressions.

Using Select to Create Queries

In general the process for selecting objects using Select is:

1. On the Query menu, click Select to display the Select dialog box.

   - **Select Records from Table** - Select the table from which to select records.
   - **that Satisfy** - Create the expression to select records.
   - **Store Results in Table** - Choose a storage place for results.
   - **Store Results in Column** - Choose column for sorting.

2. To see a list of the records you have selected, select the Browse Results check box. MapInfo Pro creates a Browser of the new selection table.

3. To display the query results in the currently active Map window, select Find Results in Current Map Window. If there are no open Map windows, this check box is disabled. You cannot save this check box setting to a template. This option is cleared by default.

4. Click OK to begin the query.

MapInfo Pro names the table Query1. It will name the next temporary selection table Query2. You can override MapInfo Pro's default name and give the selection a descriptive name. Type the new name into the Store Results in Table box. The table can also be saved as a separate table with Save Copy As.

Example: Selecting

MapInfo Pro makes finding information and locations easy. You can use the Select feature to create subset databases. As an example, we use the WORLD table to select countries with a literacy rate greater than 90%.

1. Open the WORLD.TAB table.
2. On the Query menu, click Select to display the Select dialog box.
3. Complete the Select dialog box:
• **Select Records from Table** - From the Select records from table drop-down list, choose **World**.
• **Assist** - Click the **Assist** button to display the **Expression** dialog box.

4. Complete the **Expression** dialog box as shown in the figure:

   From the Columns drop-down list, choose **Literacy**.
   
   From the Operators drop-down list, choose > (the greater than sign).
   
   Type **90**.
   
   Click **Verify** to confirm the syntax of your expression. Click **OK** to close the **Verify** dialog box.

5. Click **OK** to close the **Expression** dialog box. The **Select** dialog box redisplays.

6. Select the **Browse Results** check box.

7. Click **OK**. MapInfo Pro creates a Browser that contains the selections. Notice that the selections display in both the World map and Browser.

Making a New Table Using a Subset of a File

Many of the data sets that are used with MapInfo Pro include more objects and information than necessary for some projects. In many cases it is easier to work with a subset of the complete data product. For example, if you were tracking crime statistics for a county by census tract, you would not need the census tracts for the entire state.

There are two ways to create a new table that will contain a subset of the records from an existing file. You can interactively select the objects representing the records you would like to put in the new table using one of the select tools. Or, you can use the SQL Select command to choose a subset of objects based on an SQL function. For an example using the SQL Select command, see **Example 1 - Computing Population Density Using Area**. Saving the resulting table is the same procedure, whether you choose the objects interactively or use an SQL Select statement.
Note: Many of the queries on the following pages can be done either by using the SQL Select command or through the simpler Select command. Because SQL Select is more versatile and more commonly used, the SQL Select dialog box is used in the following examples.

Interactively Selecting Objects

1. On the File menu, click Open and open the table in a Map window.
2. Select the objects that will make up the subset with the Select tool, Radius Search Selector tool, or Polygon Search Selector tool. Shift-click to select multiple objects.
3. On the File menu, click Save Copy As and save the Selection table. The table can be saved with any filename.

Using SQL Select to Query Data

A selection is a subset of data rows in a table, chosen based on the contents of one or more columns from the table. You create selections by formulating questions, or queries, about your data. How many customers live in the state of Idaho? Which police precinct has the highest rate of violent crime? MapInfo Pro stores the results of these questions in temporary tables called query tables.
In the first part of this chapter, we discussed selections and query tables as a result of using Query Select command. We now turn our attention to an extremely powerful and useful feature in MapInfo Pro, querying by SQL Select.

While MapInfo Pro's Select command lets you formulate sophisticated queries, SQL Select goes even further. The records in the query table generated by the Select command do not have any information in them that is not contained in the records of the base table. They are, in fact, the same records. They have been arranged so that they can be viewed together.

With SQL Select you can create query tables containing information that was only implicit in the base table(s).

The SQL Select dialog box is one of the most elaborate ones in MapInfo Pro. But do not be intimidated. Once you learn what each box is used for, it is fairly simple to create powerful selection statements. You can type directly into the boxes or you can use the pop up menus on the right to enter items into the boxes.

The easiest way to describe the dialog box is to walk you through an example, step-by-step. This example uses data from the WORLD table included in MapInfo Pro, so you can try out this SQL Select exercise yourself. We have included a brief description of the parts of the dialog box with each step. A complete description of each box is given after the example.

Note: Expanding the text controls is no guarantee that the resulting query can be handled by MapInfo Pro. You can still receive the Query too complex error when adding larger queries.

Example 1 - Computing Population Density Using Area

In this example, we will use the world map to create a table of all the countries that have a population density of over 500 people per square mile.

The following formula computes population density:

- \[ \text{POPULATION} / \text{AREA} \]

While the WORLD table has a population column (pop_1994), it does not include a column for country area. However, since the WORLD table has graphic objects associated with the records, MapInfo Pro can compute the total area for each country.

Open the WORLD.TAB table, and maximize its display by clicking the window's maximize button. On the Query menu, click SQL Select to display the SQL Select dialog box.

To complete the SQL Select dialog box:

1. In the From Tables box, choose WORLD from the Tables drop-down list.

   You can specify more than one table in an SQL statement. This example uses only one table, WORLD.

   You should fill in the From Tables box before you fill in the Select Columns box. MapInfo Pro uses the tables in the From Tables box to generate the list of columns in the Columns drop-down list.
2. Place your cursor in the **Select Columns** box and delete the asterisk (*). In this example, we will specify a list of columns to be included in the resulting query table, instead of including all columns.

   **Note:** An asterisk (*) in the **Select Columns** box means by default that all columns would be queried.

   Remember, the query table is the temporary table that MapInfo Pro creates to store the results of the query.

3. Select **Country** from the Columns drop-down list.
4. Select **pop_1994** from the Columns drop-down list.

   Now, we need to compute population density. Remember, population density is computed by dividing population by area. There is no Area column in the table. However, there is a function, Area, which will compute the area of any mappable object. Since the WORLD table is mappable, MapInfo Pro can compute the area of each country and, therefore, the population density of each country.

5. Select the division sign (/) from the Operators list.
6. Select **Area** from the Functions popup.

   This creates a *derived* column. A derived column is a column that contains the results of calculations performed on another column or columns. When MapInfo Pro creates the query table, it will include two columns: the **Country** column and the **pop_1994/Area(obj, "sq mi")** column, which is our population density column. MapInfo Pro includes a units statement with all geographic functions. If you wanted MapInfo Pro to return the area in square kilometers, you would change "sq mi" to "sq km."

   Now, we need to build an expression that selects only those countries whose population density is over 500 people per square mile.

7. Tab to the Where Condition box and select **pop_1994** from the Columns drop-down list.
8. Select the division sign (/) from the Operators drop-down list.
9. Select **Area** from the Functions pop up.
10. Select the greater than sign (>) from the Operators drop-down list.
11. Type the number **500**.

   We have now built the expression "Select all countries whose population density (pop_1994/Area(obj, "sq mi")) is more than (>) 500 people per square mile."

12. Leave the **Group by Columns** box blank.
13. Tab to the **Order by Columns** box and select **Country** from the Columns list.

   The **Order by Columns** box allows you to specify the order the records in the query table will display. By selecting Country, MapInfo Pro will list the records in alphabetical order, according to country name.

14. Tab to the **Into Table Named** box and type **DENSITY**.
By default, MapInfo Pro names the query table Query1. Subsequent query tables will be named Query2, Query3, and so on. You can change the name of the query table by typing in a new table name in the Into Table Named box. MapInfo Pro will name the query table DENSITY.

15. Click **Verify**. MapInfo Pro checks the syntax of your SQL statement. If there are any errors in your statement, MapInfo Pro gives you an error message telling you what the error is and which box contains the error.

16. Select the **Browse Results** check box to create a Browser of the query table. If you do not select Browse Results, MapInfo Pro still creates the temporary query table but does not display it. If you wanted to display the table after the fact, choose the **Browse** option in the **Window** menu and select **DENSITY** from the drop-down list.

17. To display the query results in the currently active Map window, select **Find Results in Current Map Window**. If there are no open Map windows, this check box is disabled. You cannot save this check box setting to a template. This option is cleared by default.

18. Click **OK** to create the following table.
The first column contains the country name. The second column contains the population density. Note that the countries are listed in alphabetical order (Order By: Country) and the population density for each country listed is over 500 people per square mile (pop_1994/Area(obj, “sq mi”) > 500).

**Example 2 - Computing Population Density with SQL**

To set up an SQL Select statement that selects only those states with a high population density, do the following:

1. On the **File** menu, click **Open Table** and open the STATES table in a Map window.
2. On the **Query** menu, click **SQL Select** and fill in the **SQL Select** dialog box.
   - **Select Columns**: *
   - **from Tables**: States
   - **where Condition**: (Pop_1990 / Total_Area) > 500
   - **into Table Named**: HIDENSITY

   This creates a new table, HIDENSTY, that contains only those states with a relatively high population density (population divided by total area). The asterisk (*) in the Select Columns box transfers all of the columns in the STATES table to the HIDENSTY table.

3. On the **File** menu, click **Save Copy As** and save the Selection table. The table can be saved with any filename.

The **Help System** contains these related topics:

- **Examples of Group by Columns**
- **Example - Using the Group by Columns Field to Subtotal the Results Table**
- **Example - Using the Order by Columns Field to Sort the Results Table**

**Saving Queries**

Any query created using the Select or SQL Select commands can be saved as a MapInfo Pro query table. Query tables consist of a .tab file and a .QRY file. After you have executed a Select or SQL Select statement, on the **File** menu, click **Save Query** to save the query as a table. When you open this table, the tables on which the query is based are re-opened and the query is re-executed.

**Note**: Queries made against other queries cannot be saved as a table or in a workspace.

**Saving Queries to Workspaces**

You can also save queries in workspaces. When you open a workspace that contains a query, the query will execute and any windows created by the query will redisplay. Unlike saving a query as a table, a separate .tab file is not created when you save a query to a workspace.

**Note**: To save queries to a workspace, the **Save Queries in Workspaces** check box must be selected in the Startup preferences. MapInfo Pro selects this check box by default.
Activating Save Query when Using a Workspace

To activate the **Save Query** option when using a workspace, you must activate the **Save Queries in Workspaces** option in the **Startup Preferences** dialog box.

1. Choose **Options > Preferences > Startup**. The **Startup Preferences** dialog box displays.
2. Check the **Save Queries in Workspaces** option (default setting).
3. Click **OK**.

If you selected this option and open a workspace, the associated queries are regenerated. A separate MapInfo Pro table (.tab) file for the queries is not created.

**Note:** Only queries created using the **SQL Select** or **Select** commands are saved in a workspace.

Using Date- and Time-Based Data in Maps and Queries

If you maintain time- or date/time-specific data, you may be interested in querying that information and displaying it visually in your maps. Time and DateTime data types let you display that data thematically and as part of a query analysis. You could use this data type for many types of projects, such as to display crime information based on Date and Time or to post schedules based on resource availability on a particular date. Also, you can use use the date and time data from Access, Excel, dBase, and remote databases.

Time and DateTime data types options are made available in the lists of your Query dialog boxes.

Using **Time and Time/Date Data Types**

You can convert existing fields with time or time/date information into Time and Time/Date formats, so you can use them for querying and thematic maps.

To convert your data:

1. Open the data you want to convert in MapInfo Pro.
2. Chose **Table > Maintenance > Table Structure** and select the table for which you want to change the data type. The **Modify Table Structure** dialog box displays.
3. To change the **ArrivalTime** field from a character field to a Time field, click the Type drop-down arrow and select the Time type.

4. Click **OK** to save your change.

**Adding Time or DateTime Data Types to Existing Data**

If you have existing data and want to add Time or DateTime content to it, check the following table to ensure that the data is in a format that MapInfo Pro can recognize as Time or DateTime.

**Table 1: Time and DateTime Data Formats**

<table>
<thead>
<tr>
<th>Enter</th>
<th>To Format for Time</th>
<th>To Format for DateTime</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date</td>
<td>Not Applicable.</td>
<td><code>yyyyMMdd</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Sets value to the specified Date at midnight.</td>
</tr>
<tr>
<td>Enter</td>
<td>To Format for Time</td>
<td>To Format for DateTime</td>
</tr>
<tr>
<td>--------</td>
<td>-------------------------------</td>
<td>--------------------------------------</td>
</tr>
<tr>
<td>Time</td>
<td>HHmmssfff. Can also use the locale settings for a Time string.</td>
<td>HHmmssfff Sets value to current date at specified Time. Can also use the locale settings for Date and Time strings separated by a space.</td>
</tr>
<tr>
<td>DateTime</td>
<td>yyyyMMddHHmmssfff Sets value to Time portion of DateTime value.</td>
<td>yyyyMMddHHmmssfff</td>
</tr>
</tbody>
</table>

where:

HH refers to hours, mm refers to minutes, ss refers to seconds, ff refers to fractions of seconds, yyyy refers to years, MM refers to month, dd refers to date

Converting Existing Data to Time or DateTime Data Types

If you have Time or DateTime data in your tables already, check to see if it is in the format you want by checking the Time and DateTime Data Formats. If you have a lot of data and it is not in the format you require for your tasks, you can use one of the MapBasic conversion functions to assist you with this process.

<table>
<thead>
<tr>
<th>Converting</th>
<th>Date</th>
<th>Time</th>
<th>DateTime</th>
</tr>
</thead>
<tbody>
<tr>
<td>String</td>
<td>Assumes the form yyyyMMdd or locale settings for a date string if Date format is &quot;local&quot; or the U.S. form if Date format is &quot;US&quot;.</td>
<td>String can be in the form HHmmssfff or can use the locale settings for a Time string. **</td>
<td>String can be in the form yyyyMMddHHmmssfff or can use the locale settings for Date and Time strings separated by a space. ***</td>
</tr>
<tr>
<td>Number</td>
<td>Assumes the form yyyyMMdd. If any portion of the Date is invalid the value is set to null. May display this error: &quot;Could not convert data.&quot;</td>
<td>Assumes the form HHmmssfff. If any portion of the Time is invalid the value is set to null and display this error: &quot;Could not convert data.&quot;</td>
<td>Assumes the form yyyyMMddHHmmssfff. If any portion of the DateTime is invalid the value is set to null and display this error: &quot;Could not convert data.&quot;</td>
</tr>
<tr>
<td>Date</td>
<td>No conversion</td>
<td>Sets value to null and display this error: &quot;Could not convert data.&quot;</td>
<td>Sets value to the specified Date at midnight.</td>
</tr>
</tbody>
</table>
### Converting Strings to Dates, Times, and Datetimes

<table>
<thead>
<tr>
<th>Converting</th>
<th>Date</th>
<th>Time</th>
<th>DateTime</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>Sets value to null. May display this error: &quot;Could not convert data.&quot;</td>
<td>No conversion</td>
<td>Sets value to current date at specified Time.</td>
</tr>
<tr>
<td>DateTime</td>
<td>Sets value to Date portion of DateTime value.</td>
<td>Sets value to Time portion of DateTime value.</td>
<td>No conversion</td>
</tr>
</tbody>
</table>

#### Additional Notes for Converting a String

* **to a Date**

  If the year is last in the current Date format, you can omit it and MapInfo Pro will assume the current year. If the data specifies a two-digit year, MapInfo Pro assigns the century based on the current Date Window. If the Date is invalid the value is set to null and MapInfo Pro may display the error, "Could not convert data."

** ** ** to a Time

  MapInfo Pro accepts both military and AM/PM forms. The data can specify the entire locale in AM or PM strings or use just the first character of each. The data may omit the milliseconds, seconds, and minutes if the lower-order portions are also omitted. If the Time is invalid the value is set to null and MapInfo Pro may display the error, "Could not convert data."

*** ** ** ** ** to a DateTime

  The conversion rules for Date and Time apply for the respective portions of the string. If the data omits the Time portion, MapInfo Pro assumes midnight. If the DateTime is invalid the value is set to null and MapInfo Pro may display the error, "Could not convert data."

#### Additional Notes for Converting a Number to a String

# **The conversion rules for Date and Time apply for the respective portions of the string. If the data omits the Time portion MapInfo Pro assumes the Time is midnight. If the DateTime is invalid the value is set to null and MapInfo Pro may display the error, "Could not convert data."**

If you have a lot of data and it is not in the format you require for your tasks, you can use one of the MapBasic conversion functions to assist you with this process.

#### Creating a DateTime Column from Two Separate Columns

To create a DateTime column from a Date column and a Time column:

1. Open your data in MapInfo Pro Browser window. We use CrimeActivity.TAB from the Introductory Data on your DVD.
2. Choose **Table > Maintenance > Table Structure** to display the **Modify Table Structure** dialog box.
3. Click **Add Field** and type a Date_Time label in the **Name** field.

---

**MapInfo Pro 15.0**  **MapInfo Pro User Guide**

278
4. Select Date/Time in the Type drop-down list and click OK.
5. Select Table > Update Column to display the Update Column dialog box.
6. Select the table name in the Table to Update drop-down list.
7. Select the name of the new column you just created in the Column to Update drop-down list.
8. Select the table name again in the Get Value from Table drop-down list.
9. Click the Assist button to display the Expressions dialog box.
10. Use the Column drop-down list to create the following expression and click OK:

\[ \text{DateColumn} + \text{TimeColumn} \]

For more about using math expressions with Time and Date information, see Using Arithmetic Operators with Time and Time/Date Data Types.

1. Click OK to update the new column with the Date and Time information.

Creating Thematic Maps using Time and Time/Date Data Types

For ranged thematic maps, Time values will be able to be rounded by seconds, minutes, and hours. The default is seconds. When you select None, MapInfo Pro does not round the selecting the seconds and displays a granularity of milliseconds.

Note: If your data is on a remote database, you may be interested in the Time and DateTime Data Type Support for Remote Databases in the Help System.

To create a thematic map using DateTime information:

1. Open your data in MapInfo Pro Browser window. Use the appropriate background map to give your data perspective. Here we use the Great Britain data in the Introductory Data on the MapInfo Pro DVD.
2. Choose Query > SQL Select to display the SQL Select dialog box.
3. Place your cursor in the **from Tables** field and select the table name that contains the DateTime data in the **from Tables** drop-down list. For our example we used the **CrimeActivity** table.

4. To find out the location of crimes between April 10, 2003 and April 10, 2004 and between the hours of 12 and 8 p.m., we entered this text in the **where Condition** box:

   Crime_Date between "04/10/2003" and "04/10/2004" And Crime_Time between "12:00:00 PM" and "08:00:00 PM"

1. Select the **Browse Results** and **Find Results in Current Map Window** check boxes to display the results.

2. Click **OK** to create the query and display the results.

---

### Using Arithmetic Operators with Time and Time/Date Data Types

You can use the addition and subtraction operators with the Time and Time/Date data types as follows:

<table>
<thead>
<tr>
<th>Data type</th>
<th>Operator</th>
<th>Data type</th>
<th>Result</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>minus (-)</td>
<td>Time</td>
<td>Number</td>
<td>The number represents the number of seconds between two times as a</td>
</tr>
<tr>
<td>Data type</td>
<td>Operator</td>
<td>Data type</td>
<td>Result</td>
<td>Notes</td>
</tr>
<tr>
<td>------------</td>
<td>----------</td>
<td>-----------</td>
<td>--------</td>
<td>-------</td>
</tr>
<tr>
<td>Time</td>
<td>+ or -</td>
<td>Number</td>
<td>Time</td>
<td>The number represents the seconds to add to the first Time. The Time wraps around midnight so that 11:59 PM + 120 seconds equals 12:01 AM.</td>
</tr>
<tr>
<td>DateTime</td>
<td>minus (-)</td>
<td>DateTime</td>
<td>Number</td>
<td>The number represents the number of days between two DateTimes as a floating point number. The fractional part of the result is the fractional portion of a day, as in today at noon minus today at midnight equals one half day.</td>
</tr>
<tr>
<td>DateTime</td>
<td>+ or -</td>
<td>Number</td>
<td>DateTime</td>
<td>The number represents the number of days to add to the first Time.</td>
</tr>
</tbody>
</table>

Using Comparison Operators with Time and Time/_Date Data Types

The comparison operators are =, <>, <, >, <=, >= and should all work as expected for the Time and DateTime values. For Time values, the smallest Time is "12:00:00.000 AM" while the largest Time is "11:59:59.999 PM".

The "Between" operator works as expected for DateTime values. For Time values, we support wrap-around comparisons. For example:

TimeValue Between "2:00 AM" And "10:00 PM" is true if the TimeValue is greater than or equal to "2:00 AM" and less than or equal to "10:00 PM"

TimeValue Between "10:00 PM" And "2:00 AM" is true if the TimeValue is greater than or equal to "10:00 PM" and less than or equal to "11:59:59.999" or greater than or equal to "12:00 AM" and less than or equal to "2:00 AM"

Using Logical Operators with Time and Time/Date Data Types

A Time or DateTime field with a value is true, while the same field with a null value indicates false. The behavior of the logical operators And, Or, and Not should follow logically from this.

Interpreting Excel Data

Using Excel you can format numeric cells as Dates and/or Times. Excel determines the meaning of the 'm' format code as either 'month' or 'minute' based on the rest of the format code.
The Date fields in older MapInfo Pro files are treated as Date fields until you re-register them to use the DateTime data type. Older versions of MapInfo Pro supported Date fields with the format 'y' (year), 'm' (month), or 'd' (day). Time fields within the format 'h' (hour) or 's' (second) were treated as Float fields. Fields with Date and Time format codes were treated as a Date field and the Time information was ignored.

The Help System contains these related topics:

- Ensuring that Dates Display Correctly for Excel for Macintosh Tables
- Controlling how MapInfo Pro Handles Mixed Data Type Columns

Interpreting Microsoft Access Data

Access data uses a DateTime type, but not separate Date or Time types. MapInfo Pro registers the Access DateTime type fields as DateTime fields.

The Date fields in older MapInfo Pro files are treated as Date fields until you re-register them to use the DateTime data type.

When you save a MapInfo table to Access format, MapInfo Pro writes Date, Time, and DateTime fields as Access DateTime fields. The .tab file itself maintains the Date, Time, and DateTime types so when you reopen the file, the Date, Time, or DateTime data displays. If you attempt to open these .tab files using a non-MapInfo application, these fields display as DateTime.

Interpreting dBase Data

The dBase format supports Date fields but does not explicitly support Time or DateTime fields. Therefore, when you register an existing dBase file, there will be no Time or DateTime fields. When you save or export a MapInfo table with Time or DateTime fields to a dBase file, Time and DateTime fields are written out as character fields of length 9 and 17, respectively so that the data is written out in numeric formats.

When you save a MapInfo table to dBase format, the .tab file maintains the Time and DateTime types so that when you reopen it the data displays as either Time or DateTime. If you attempt to open these .tab files using a non-MapInfo application, these fields display as character fields.

The Help System contains these related topics:

- Time and DateTime Data Type Support for Remote Databases
Using Templates for Queries

Query templates enable you to save Select or SQL Select statements as templates and reload them. This saves you the trouble of having to rebuild a query each time you want to use it. Both the Select and SQL Select dialog boxes have Load Template and Save Template options to enable you to do this easily. Query templates are useful for re-creating a query with an updated version of the table used in the original query, or for executing a query on a table that has the same fields as the table on which the query statement was created.

Loading a Template

You can load any saved query template.

To load a query template:

1. In the Select or SQL Select dialog boxes, lick the Load Template button. The Load Dialog From Query File dialog box displays. It lists the .QRY files.
2. Select the .QRY file you want to use, and click Open. The Select or SQL Select dialog box displays with the values from the template already filled in. Simply execute your query to create the query browser.

Renaming a Template

Rename a template by selecting and clicking the template name; enter a new name up to 64 characters.

Saving a Template

After you have finished writing your Select or SQL Select query, you can save the query as a template.

To save a query as a template:

1. In the Select or SQL Select dialog boxes, click the Save Template button to save the query to a template, or query file. The Save Dialog to Query File dialog box displays.
2. Give the query file a name, select a folder, and click Save. Query files are saved with a .QRY extension and are saved in the directory specified in the Directories preferences.

Note: The query does not need to be complete or syntactically correct to save it to a template.

Deleting a Template

To delete a template:

• Select the template name and press the Delete key. A dialog box displays prompting you to confirm or cancel the operation. If no templates of the given type exist, a button to restore a default template displays.
**Deriving Columns**

A derived column is a column in a query table whose contents are created by applying an expression to the values of columns already existing in some base table. In the example above, population density was a derived column. By default, the **Select Columns** box contains an asterisk (*), indicating that all of the columns in the base table are to be included in the query table. If you do not want all of those columns, you should delete the asterisk and list only those columns that you want to use. You are not limited to creating one derived column. You can create as many derived columns as you want. Note that the more derived columns you create, the longer it will take MapInfo Pro to execute the query.

You can also create derived columns based on the aggregate functions `count`, `sum`, `avg`, `wtavg`, `max`, and `min`. For example:

- `sum(Population)`
  would give you the population for the entire world.
- `sum(Area(obj), "sq mi")`
  would give you the area for the entire world.

**Creating Column Aliases**

When MapInfo Pro creates a derived column, it uses the expression itself as the name for that derived column, which can be awkward. You can, however, specify an alias for the column. For example, the population density column in our DENSITY Browser was titled:

- `Population / Area(obj, "sq mi")`

To rename the column, add the new name to the Select Columns box when listing the columns. The alias must follow the expression. It must also be separated from the expression by a blank space and enclosed in quotes. For example:

- `Country, Population / Area(obj, "sq mi") "POP_DENSITY"

When MapInfo Pro creates the temporary query table, the population density column will now be named POP_DENSITY.

You can use aliases to rename any column in a table, not just derived columns. For example, if each country in your table is a separate sales territory for your corporation, you might want to rename the Country column "TERRITORY". The procedure is identical:

- `Country "TERRITORY", Population / Area(obj, "sq mi") "POP_DENSITY"

For another example, see Example - Computing Total World Population Density in the Help System.
Aggregating Data

When you aggregate data, you perform a mathematical operation on all of a column's values in all of the records in your table. Unlike the Select command, which only allows you to perform mathematical functions on individual records, SQL allows you to aggregate (or summarize) data across records.

MapInfo Pro looks for each *unique* set of data values in the specified column or columns and creates one row for each such unique set. When you aggregate data, you need to specify:

- How the records will be grouped.
- How the data will be aggregated (summarized).

For example, you have a table of sales representatives and their sales figures for the past three months:

<table>
<thead>
<tr>
<th>SALES_REP</th>
<th>MONTH</th>
<th>SALES</th>
</tr>
</thead>
<tbody>
<tr>
<td>John</td>
<td>May</td>
<td>1200</td>
</tr>
<tr>
<td>Cathy</td>
<td>May</td>
<td>900</td>
</tr>
<tr>
<td>Julie</td>
<td>May</td>
<td>1100</td>
</tr>
<tr>
<td>John</td>
<td>June</td>
<td>900</td>
</tr>
<tr>
<td>Cathy</td>
<td>June</td>
<td>1400</td>
</tr>
<tr>
<td>Julie</td>
<td>June</td>
<td>600</td>
</tr>
<tr>
<td>John</td>
<td>July</td>
<td>1200</td>
</tr>
<tr>
<td>Cathy</td>
<td>July</td>
<td>700</td>
</tr>
<tr>
<td>Julie</td>
<td>July</td>
<td>1000</td>
</tr>
</tbody>
</table>
MapInfo Pro could also compute the total sales for each representative by specifying in the **SQL Select** dialog box:

- Select Columns: SALES_REP, sum(SALES)
- Group by Columns: SALES_REP

<table>
<thead>
<tr>
<th>SALES_REP</th>
<th>sum(SALES)</th>
</tr>
</thead>
<tbody>
<tr>
<td>John</td>
<td>3300</td>
</tr>
<tr>
<td>Cathy</td>
<td>3000</td>
</tr>
<tr>
<td>Julie</td>
<td>2700</td>
</tr>
</tbody>
</table>

or MapInfo Pro could compute the average sales for each representative:

- Select Columns: SALES_REP, avg(SALES)
- Group by Columns: SALES_REP

<table>
<thead>
<tr>
<th>SALES_REP</th>
<th>avg(SALES)</th>
</tr>
</thead>
<tbody>
<tr>
<td>John</td>
<td>1100</td>
</tr>
<tr>
<td>Cathy</td>
<td>1000</td>
</tr>
<tr>
<td>Julie</td>
<td>900</td>
</tr>
</tbody>
</table>

or MapInfo Pro could compute the total sales for each month:

- Select Columns: MONTH, sum(SALES)
- Group by Columns: MONTH

<table>
<thead>
<tr>
<th>MONTH</th>
<th>sum(SALES)</th>
</tr>
</thead>
<tbody>
<tr>
<td>May</td>
<td>3200</td>
</tr>
</tbody>
</table>
MapInfo Pro has six aggregate functions:

- **Count**: counts the number of records in a group. It takes * as its argument because it applies to the record as a whole, and not to any particular field in the record.
- **Sum** (expression): calculates the sum of the values in <expression> for all group records.
- **Average** (expression): calculates the average of the values in <expression> for all the records in a group.
- **WtAvg** (expression): calculates the weighted average of the values in <expression> for all the records in a group.
- **Max** (expression): finds the highest value in <expression> for all records in a group.
- **Min** (expression): finds the lowest value in <expression> for all records in a group.

For more about grouping and ordering your data, see the *Help System*.

**Joining Tables Using SQL Select**

When performing an SQL Select operation with multiple tables, MapInfo Pro needs to join information from the records in the various tables. You may have a map table containing only graphic objects and their names and a table of statistical data for some geographic region. You want to display the statistical data on the map table. You could use SQL Select to create a query table in which your statistical data and map data are joined in one table.

Whenever you are working with multiple tables, you must put a statement in the Where Condition telling MapInfo Pro how to match up the rows in the different tables. For example, you have the WORLD table that contains countries and a table of economic statistics (Eco_Stats), also broken down by country.

You want to create a query table that contains both sets of data:

- **Select Columns**: * (an asterisk indicates include all columns in the query table)
- **From Tables**: World, Eco_Stats

The two columns that you want to match do not have to have the same name. For example, you have a table of international customers (Int_Cust) that contains a sales territory column (TERRITORY). This column contains continent names, since your company breaks up its sales territories according to continent. If you wanted to temporarily join the two tables:

- **Select Columns**: *
• **from Tables:** World, Int_Cust
• **where Condition:** World.Continent = Int_Cust.TERRITORY
• **into Table Named:** WORLD_DENSITY
• Select the Browse Results checkbox.

For an example, see *Example - Total Population and Area by Continent* in the Help System.

**Using the Where Condition**

The order of fields used in the Join does not matter. Either of the following syntaxes is acceptable:

```sql
Select * from A,B where A.field1 = B.field1
Select * from A,B where B.field1 = A.field1
```

However, keep in mind that when you switch the order of geographic operands, the geographic operator must also change. The following statements will produce identical results:

```sql
Select * from states, cities where states.obj contains cities.obj
Select * from states, cities where cities.obj within states.obj
```

**Order of Clauses**

The order in which Join clauses are performed does not matter. For example, each of the following are valid clauses:

```sql
Select * from Us_custg,States,City_125
where States.state = City_125.state and States.state = Us_custg.state
and
Us_custg.order_amt > 10000
Select * from Us_custg,States,City_125
where States.state = City_125.state and States.state = US.custg.state
and
Us_custg.order_amt > 10000
Select * from Us_custg,States,City_125
where Us_custg.state = States.state and Us_custg.order_amt > 10000 and
States.state = City_125.state
```

**Note:** Some of the data used in this example is from the MapInfo Pro Tutorial, which is only available from the Pitney Bowes Software Inc. web site, [http://go.pbinsight.com/webtutorials](http://go.pbinsight.com/webtutorials).

**Error Handling**

If an invalid Where condition that uses an OR as a logical operator is detected, MapInfo Pro will indicate an error has occurred. Usually this error will display whenever MapInfo Pro cannot find a join between two tables. For example, if you have specified the following incorrect condition:

```sql
Select * from A,B where A.field1 = B.field1 or A.field1 = B.field2
```
Joining Tables Geographically (Using Geographic Operators)

When two tables have graphic objects, MapInfo Pro can join the tables based on the spatial relationship between those objects. Thus, even if your tables do not share a common column, you may be able to join the tables.

Geographic operators allow you to select objects on the basis of their spatial relationship to some other object. MapInfo Pro has a special column name you use with geographical operators: "obj" or "object". This column name refers to the graphic objects that are attached to your table.

The geographic operators go between the objects being specified. Select the geographic operators from the Operators drop-down list.

The following table lists the geographic operators:

<table>
<thead>
<tr>
<th>Geographic Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contains</td>
<td>Object A Contains Object B if B's centroid is anywhere within A's boundary.</td>
</tr>
<tr>
<td>Contains Entire</td>
<td>Object A Contains Entire Object B if B's boundary is entirely within A's boundary.</td>
</tr>
<tr>
<td>Within</td>
<td>Object A is Within Object B if its centroid is inside B's boundary.</td>
</tr>
<tr>
<td>Entirely Within</td>
<td>Object A is Entirely Within Object B if A's boundary is entirely within B's boundary.</td>
</tr>
<tr>
<td>Intersects</td>
<td>Object A Intersects Object B if they have at least one point in common or if one of them is entirely within the other.</td>
</tr>
</tbody>
</table>

The difference between Contains and Within on the one hand, and Contains Entire and Entirely Within on the other, hinges on how the geographic comparison is made. For Contains and Within, the comparison is based on object centroids. For Contains Entirely and Entirely Within, the comparisons are based on the whole object.

The following graphic illustrates this point:
In each case, object A contains object B because the centroid of object B is inside the boundary of object A. However, in the cases at the left and in the middle, part of object B is outside the boundary of object A. Only in the case to the right is all of object B inside object A. Only in this case could we assert "object A Contains Entire Object B" or "Object B Entirely Within Object A." Further, if A contains entire B, then A contains B, and if A is entirely within B then A is within B.

MapInfo Pro can perform a simple Contains or Within comparison more rapidly than a **Contains Entire** or **Entirely Within**. Therefore, unless you are absolutely sure that objects are completely inside other objects, you should use **Contains** and **Within** rather than **Contains Entire** or **Entirely Within**.

Geographic operators provide a way of joining tables. When there are no columns in the tables on which you can base your join, you can use a geographical operator to specify the join (in the Where Condition field). If you want to perform a query that involves both a Cities table and a States table, you can join the tables using either of the following expressions:

1. Cities.obj within States.obj
2. States.obj contains Cities.obj

In either case, MapInfo Pro finds the cities within each state and then associates a row for a city with the row for the state that contains it. In the same SQL Select query, you could also use aggregate functions to count the number of cities per state or to summarize city-based data on a statewide basis.

When you have a table of counties and one of customers, where counties are polygons and customers are points, you could specify a geographic join using either of the following geographic expressions:

1. Customer.obj within County.obj
2. County.obj contains Customer.obj

Geographic operators are particularly useful in conjunction with subselects.

The *Help System* contains this related topic:
Performing Subselects

Joining Two or More Tables

Typically, you store your information in several different tables. You have your own data files, and you may also have various databases of statistical information that you purchased from MapInfo Pro. SQL Select allows you to create relational joins so that you can bring information from these various tables together into a single results table.

When you want to join two tables, you must determine whether one of the columns in the first table contains values that match one of the columns in the second table. Imagine that you have a table of counties that has demographic information—the population of people in various age ranges, ethnic groups, and occupational categories in each county. You may also have a database containing information about customer orders. You want to examine these two tables and see if certain kinds of orders come from counties having certain demographic characteristics. Perhaps you want to select counties according to combinations of orders and demographic characteristics. To do this you have to be able to join the two tables.

Suppose the counties table contains the name of the county. Similarly, one of the columns in the order table contains the name of the county in which the order originated. Thus, these two tables have one field in common, the county name. MapInfo Pro can use that common field to join the two tables.

### Counties Table Orders Table

Within the SQL Select dialog box, you use the Where Condition field to tell MapInfo Pro how to join the two tables. The SQL Select dialog box might look like this:

```
Select Columns:  *
From Tables:  Counties, Orders
Where Condition:  Counties.CountyName = Orders.County
```

The order of the table names (in the From Tables field) is important. If both tables contain map objects, the results table will only retain the map objects from the first table listed in the From Tables field. Furthermore, when the query is complete, MapInfo Pro automatically selects some or all of the rows from whichever table is listed first in the From Tables field. Thus, in the preceding example,
MapInfo Pro will select some or all of the rows from the Counties table. The results table will also include data copied from the Orders table, but the Orders table will not be selected per se.

When you join two tables, the number of rows in the results table depends on how well the two tables match up. Suppose you have an Orders table with 10,000 rows, and you join the Orders table to the States table, which has fifty rows. The results table may contain as many as 10,000 rows. However, if some of the rows in the Orders table fail to match any of the rows in the States table, the results table will contain fewer than 10,000 rows. Thus, if 400 of the rows in the Orders table do not have a state name (perhaps due to data-entry errors), and if the relational join relies on the state name, the results table may only contain 9,600 rows.

You can use Update Column to modify the results of an SQL Select multi-table join. When you want to update a column in one table with information from another table, you can:

1. Join the tables with SQL Select.
2. Use Update Column on Selection. The update automatically takes effect in the appropriate base table.
3. For more information, see Performing Outer Joins and Using the Instr Function to Find Data in the Help System.

**Finding Duplicate Values in a Column**

Often data is entered into tables by many different users. Sometimes data is repeated, or there is common information in several different records. This section explains how to find all rows in a table that, for a given column, share a value with another row. This is accomplished by performing two SQL Select statements.

The first SQL Select statement produces a query table with two columns. The first column is a list of all unique values in the data column and the second column lists the number of times that each unique value occurs. The second SQL statement compares each data column value with all rows in the Query table where the count is greater than one.

In the next example, there is a table EMPLOYEE that has two columns Id_Num and Name.

To find the duplicate values, perform the two SQL Selects, modifying them where indicated.

1. On the Query menu, click SQL Select and fill in the SQL Select dialog box.

   - Select Columns: ID_Num, Count(*)
   - from Tables: EMPLOYEE
   - Group by Columns: 1
   - Order by Columns: 2 desc
   - into Table Named: Selection

   Substitute the name of your data column for ID_Num and the name of your table for EMPLOYEE. The number 1 in the Group By Columns box will group the row by ID_Num (the first column). The 2 Desc in the Order by Columns box will arrange the records in descending order based on the values in the count(*) field (the second column).
This SQL Select statement returns a query table with two columns. The first column contains every identification number possessed by at least one employee. The second column contains the number of employees that have that identification number. The rows are sorted by the number of employees that have each id number (for example, the count).

2. On the Query menu, click SQL Select and fill in the dialog box.

Also, change EMPLOYEE to the name of your table and ID_Num to the name of your data column.

In the example, the SQL statement returns a query table containing all of the rows from EMPLOYEE with duplicated data column values. The where condition selects all rows from EMPLOYEE that have an identification number that is the same as one of the ID numbers in the Count_By_ID query table. This sub-select finds all identification numbers that occur more than once.

Calculating the Distance to a Fixed Point

In MapInfo Pro it is possible to calculate the distance from one point to another. This example shows how to calculate the distance from a fixed point to every point in a geocoded table and store the result in another table.

1. Determine the location of the fixed point. To find the position of a symbol on the map, double-click the symbol with the Select tool. In this example, the X value is -101.697209 and the Y value is 35.550036.

2. On the Query menu, click SQL Select and fill in the SQL Select dialog box, substituting your X and Y values for the values mentioned above

As in the previous SQL query, replace EMPLOYEE with the name of your table, and LName and FName with the name of the relevant column from your table.

- Select Columns: LName, FName, Distance(-101.679209, 35.550036, CentroidX(obj), CentroidY(obj), "mi") "Dist"
- from Tables: EMPLOYEE
- into Table Named: CUSTDIST

3. Click OK. The resulting query table contains last names and first names plus a new column called DISTANCE which records the distance between the fixed location (-101.697209, 36.550036) and the point associated with each row of the table.

4. To save the results in a permanent table, on the File menu, click Save Copy As, and save the CUSTDIST table.

5. For instructions on entering SQL queries using the Expert button, see the Help System.
10 - Creating Thematic and Other Themed Maps

Thematic mapping is a powerful way to analyze and visualize your data. You give graphic form to your data so that you can see it on a map. Patterns and trends that are almost impossible to detect in lists of data reveal themselves clearly when you use thematic shading to display the data on a map.

You can create thematic maps with MapInfo Pro using the following methods: ranges of values, graduated symbols, dot density, individual values, bar and pie charts and continuous grid. There are also several variations on and options within these methods, such as bivariate thematic mapping and inflection point, that give you even more ways to analyze your data.

For clarification of the uses of thematic maps in MapInfo Pro, see MapInfo Pro in Action in the Help System.

The Help System also contains these related topics:

• Bivariate Thematic Mapping
• Working with 3D and Prism Maps

In this section

MapInfo Pro in Action 295
Using Thematic Mapping to Analyze Information 296
Creating a Thematic Map 312
Changing the Display Parameters of a Map 318
Updating Columns using Thematic Mapping 321
Working with Grid Surface Maps 327
MapInfo Pro in Action

Since you have all the tools you need to make effective and useful maps, it is time to talk about what makes a map effective and useful. Whatever you need your map to say, whether it is to convey information, calculate distances between health care providers and their patients, or get a count of the number of customers that live within a given radius of an outlet location, MapInfo Pro can help you do that. By making selections from your table, you can extract information from sets and subsets of your data or see patterns and distributions, getting answers to such questions as: Which of my customers bought more than $5000 of equipment? Which of my customers is located within a 200 mile radius of my warehouse? Which of my customers bought more than $5000 of equipment and is located within a 200 mile radius of my warehouse? For more on selecting, see Selecting Your Data in MapInfo Pro, and Querying Your Data in MapInfo Pro.

MapInfo Pro refers to this grouping of like information as thematic mapping.

• For an example, see Can You Give Me an Example in the Help System.
Using Thematic Mapping to Analyze Information

*Thematic mapping* is the process of enhancing your map according to a particular theme. At the cornerstone of the theme is the data in your table. Themes represent your data with shades of color, fill patterns, symbols, bar and pie charts, and grids.

With MapInfo Pro, you create different thematic maps by assigning these colors, patterns, or symbols to map objects according to specific *values* in your table. MapInfo Pro’s bar and pie charts allow you to make data comparisons for each record. Grids allow you to see continuous change of your data across an area.

The thematic map feature uses a wizard made up of a series of three dialog boxes to help you choose the type of thematic map you want, the table(s) and fields that will be used to construct the map, and a variety of options to customize your map.

MapInfo Pro’s thematic templates make it easy to start constructing a theme. Just choose a template that represents the type of thematic map you want. The templates are fully customizable and can be saved as new templates for future thematic mapping needs. More than 40 templates ship with MapInfo Pro.

**Figure: Comparison of Senior Population to Total U.S. Population**

Planning Your Thematic Map

Before you create a thematic map, it is important to know about the elements that make up a thematic map and how to put them together. This section will discuss thematic variables, where you can obtain your data, using data from the same table or another table, and the arrangement and display of thematic layers.

**What is a Thematic Variable**
The data that you display on your thematic map is called the thematic variable. Depending on the type of thematic analysis you are performing, your map can show one or more thematic variables. Ranges of values, grid shading, graduated symbols, dot density, and individual values maps all examine one variable. With bar or pie charts, you can display more than one thematic variable at a time.

A thematic variable can also be an expression. Choose Expression from the field list in place of a data field to construct a statement that derives information from the data in your table(s). Although an expression can be made up of more than one variable (for example, POP_1990 - POP_1980), for purposes of thematic mapping, a complete expression is equivalent to one thematic variable. See Querying Your Data in MapInfo Pro, and Creating Expressions in the MapInfo Pro User Guide, which is located in the Documentation subfolder of your installation directory, for more detailed information.

You can also create bivariate thematic maps, where one map object, such as a symbol, represents two different pieces of data. The symbol color, for example, can represent one thematic variable, and the symbol size can represent another.

Where to Obtain the Data

Before you begin your thematic map, you need to decide what information you want to display and locate where that information resides. It can either be in the table on which you are basing the map, or it can be in another table.

If the data is in the same table on which you are basing the map, choose the desired field directly in the Field list box in the Create Thematic Map - Step 2 of 3 wizard panel.

If the data is in another table, you must first bring the data into the table on which you are basing the thematic map. This requires creating a temporary column using Update Column.

Each situation is described in the next few sections.

Using Data from the Same Table

If you are using data from the same table, choose the table and field on which you want to base your thematic map in the Create Thematic Map - Step 2 of 3 wizard panel.

For example, you have a table of parking meters that contains the location of the parking meter and the last time the parking meter was emptied. Using Individual Values you want to shade the parking meter symbols according to the last time each meter was emptied. MapInfo Pro will assign a color to each time. In the Create Thematic Map - Step 2 of 3 wizard panel, choose the parking meter table as your table, and choose the field that contains the time each meter was emptied.

Using Data from a Different Table

The Join feature within the Create Thematic Map - Step 2 of 3 wizard panel enables you to use data from other open tables to create a thematic map. Choose Join in the Field list box to display the Update Column dialog box where you can create a temporary column in the base table.

The temporary column can contain data taken directly from the other table, or you can aggregate the data to create derived information for the temporary column.
For example, you have two tables: a table of county boundaries and a table of police stations. You want to shade the table of county boundaries according to the number of police stations in each county.

To do this, all the information you want to use must be in the county table. Therefore, you must add police station data to this table.

Using Update Column, you create a temporary column in the county boundaries table that will store the police station information. To create this column, the two tables must have a link so that MapInfo Pro can access the data that goes into the temporary column. The link can either be a matching field (like county name), or you can make the link geographically (police stations contained within counties).

An example later in this chapter explains more about Update Column.

**Methods of Thematic Mapping**

When you create a thematic map in MapInfo Pro, the thematic shading is added to your map as a separate layer. It is drawn on top of the base map layer.

*Separating Thematic Layers*

Separating thematic layers from the base map layer provides you with several important options:

- Graduated symbol thematic maps do not require that your base map contain point objects. Instead, graduated symbol objects are built regardless of the map object type. Therefore, even if your base map contains region or line objects, you will still be able to create a graduated symbols map.
- You can have multiple thematic layers per base map layer. In some cases, you do not have to add another base layer to the map to create another thematic layer. You can display more than one thematic layer at a time, as well as perform bivariate thematic mapping.
- You can use Layer Control to turn the display on or off for a given thematic layer. The layer it is based on can continue to display. You can also set individual zoom layers on thematic maps.

*Ordering of Thematic Layers*

To display thematic layers properly, they must be in a specific order. This is especially important when you want to display more than one thematic layer at a time. For example, you would want pie or bar charts for an area map to display on top of regions that are shaded in order to see them.

The following lists the order of map layers from top to bottom (note that map layers are drawn from the bottom up):

1. Pies, Bars, or Graduated Symbol thematic layer.
2. Dot Density thematic layer.
3. Ranged thematic layer - where Color or Size Attributes are applied.
4. Ranged (or Individual Value) thematic layer - where All Attributes are applied.
5. Major layer or base layer.
6. Grid thematic layer.
When you create a new thematic layer, MapInfo Pro automatically inserts it into its proper place.

**Displaying Thematic Layers**

You can turn the display on and off for thematic layers the same way you can for other map layers. All the display settings in Layer Control are also applicable to thematic layers, enabling you to set a zoom level for each thematic layer. You can also access the Modify Thematic Map dialog box through Layer Control by double-click the thematic layer.

**Figure: Layer Control (Showing Thematic Layer above Base Map)**

Thematic layers are displayed in the list with this naming convention:

```
<Thematic type> with/by <variable-list>
```

The type of thematic map is noted first, followed by the list of variables used to create the map. For example, a pie thematic layer that uses commuting data is listed this way:

Pies with ComAlone, ComCarpool...

The variable list is truncated if there is not enough room to display each variable in your analysis.

**Types of Thematic Maps**

With MapInfo Pro you can create seven types of thematic maps:

- Ranges
- Bar Charts
- Pie Charts
- Graduated Symbol
- Dot Density
- Individual
- Grid
Each has its own purpose and unique attributes. For example, using Ranges of Values, you could thematically shade a map of the world according to population density. You could shade the countries with graduated shades of red, the darkest red representing the most densely populated countries, and the palest red representing the least densely populated countries. At a glance you can see the distribution of the world's population.

You are not limited to representing numeric values with thematic mapping. Nominal values also may be shaded thematically. For example, you have a table of underground cables. Those cables that have not been serviced in the past six months are labeled priority status. Using Individual Values, you can shade the cables according to their repair status. All records with the same value will be shaded the same. See the individual sections later in this chapter for more information on each type of thematic map. They offer general information on the methods available for creating thematic maps. For more information on any of these methods and options, see *Thematic Mapping* in the Help System.

**Ranged Maps**

When you create a ranged thematic map, MapInfo Pro groups all records into ranges and assigns each record's object the color, symbol, or line for its corresponding range. For example, if you wanted to visualize the population of the world by growth rate, you would shade countries according to their reported growth rate amounts.

With the Ranged map feature, MapInfo Pro groups the growth rate amounts into ranges. For example, in the next table, all countries that had growth rates between zero and one percent are grouped into one range. Countries that had growth rates between one and 2.2 are grouped in a separate range. Countries that have rates between 2.2 and 3.1 are in a third range, and those countries reporting greater than 3.1 are in a fourth range.

**Figure: Ranged Map**
All records are assigned to a range and then assigned a color based on that range. For example, the countries with the higher growth rates are shaded in red. The other ranges are shaded in lighter shades of red to light green and finally darker green. When you display the map, the colors make it readily apparent which locations have the highest growth rate in relation to their neighbors.

Ranges are also useful when the size of the region is not directly related to the magnitude of the data values. In our population density example in this section, we see that countries that are small in size can be very densely populated, and countries that are large in size may not be densely populated. Differences like these are more readily apparent when the regions are shaded in this manner.

**Types of Ranged Values**

MapInfo Pro can create ranges automatically using five methods: Equal Count, Equal Ranges, Natural Break (Standard Deviation), Quantile, and Custom. To set ranges manually, use Custom.

**Equal Count** has the same number of records in each range. If you want MapInfo Pro to group 100 records into 4 ranges using Equal Count, MapInfo Pro computes the ranges so that approximately 25 records fall into each range, depending on the rounding factor you set.

When using Equal Count (or any other range method), it's important to watch out for any extreme data values that might affect your thematic map (in statistics, these values are referred to as outliers). For example, if you tell MapInfo Pro to shade according to Equal Count with this database:

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>John</td>
<td>5000</td>
<td>Andrea</td>
</tr>
<tr>
<td>Penny</td>
<td>6000</td>
<td>Kyle</td>
</tr>
<tr>
<td>Miguel</td>
<td>4500</td>
<td>Angela</td>
</tr>
<tr>
<td>Linda</td>
<td>5000</td>
<td>Elroy</td>
</tr>
<tr>
<td>Ben</td>
<td>100</td>
<td>Mark</td>
</tr>
</tbody>
</table>

Ben and Miguel are grouped in the same range (since they have the two lowest values). This may not produce the results you want since the value for Ben is so much lower than any of the other values.

**Equal Ranges** divides records across ranges of equal size. For example, you have a field in your table with data values ranging from 1 to 100. You want to create a thematic map with four equal size ranges. MapInfo Pro produces ranges 1-25, 25-50, 50-75, and 75-100. (Since ranges use "=>" and "=<", they need to overlap.)
Keep in mind that MapInfo Pro may create ranges with no data records, depending on the distribution of your data. For example, if you tell MapInfo Pro to shade the following database according to Equal Ranges:

<p>| | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>John</td>
<td>100</td>
<td>Andrea</td>
<td>90</td>
</tr>
<tr>
<td>Penny</td>
<td>6</td>
<td>Kyle</td>
<td>1</td>
</tr>
<tr>
<td>Miguel</td>
<td>4</td>
<td>Angela</td>
<td>92</td>
</tr>
<tr>
<td>Linda</td>
<td>95</td>
<td>Elroy</td>
<td>89</td>
</tr>
<tr>
<td>Ben</td>
<td>10</td>
<td>Mark</td>
<td>10</td>
</tr>
</tbody>
</table>

MapInfo Pro creates four ranges (1-25, 25-50, 50-75, and 75-100). Notice, however, that only two of those ranges (1-25 and 75-100) actually contain records.

Natural Break and Quantile are two ways to show data that is not evenly distributed.

**Natural Break** creates ranges according to an algorithm that uses the average of each range to distribute the data more evenly across the ranges. It distributes the values so that the average of each range is as close as possible to each of the range values in that range. This ensures that the ranges are well-represented by their averages, and that data values within each of the ranges are fairly close together. MapInfo Pro bases its Natural Break algorithm on the procedure described by Jenks and Caspall in their article "Error on Choroplethic Maps: Definition, Measurement, Reduction" from the Annals of American Geographers, June, 1971.

**Quantiling** enables you to build ranges that determine the distribution of a thematic variable across a segment of your data. For example, you can quantile state population by urban population to illustrate how urban population is distributed across the United States. Your map legend will not indicate that you have used Quantile to build your ranges. You can customize the map legend so that it shows which field you used to quantile the table.

When you create ranges using **Standard Deviation**, the middle range breaks at the mean of your values, and the ranges above and below the middle range are one standard deviation above or below the mean. You can also define your own ranges using Custom.

The **Help System** contains these related topics:

- **Creating a Map by a Range of Values**
- **Customizing a Range Map**
- **Customizing Range Styles and Inflection Points**
Bar Chart Maps

Unlike thematic maps for single variables such as ranges of values or graduated symbols, a thematic bar chart map allows you to examine more than one variable per record at a time. A bar chart is built for every map object at the centroid of the object, enabling you to analyze the thematic variables in a particular chart by comparing the height of the bars. You can also examine the same variable across all the charts in your map.

You can customize the color of each bar, create a frame around each chart, and fill the empty space inside the frame with a pattern or color. In addition, you can change the bar chart's orientation, such as displaying horizontal bars instead of vertical (the default). You can also control where to display the chart: over the object's centroid (the default) or any of eight other locations.

You can also change the type of bar chart. In our example, you can create a multi-bar chart, where each thematic variable has its own bar, or a stacked bar chart with each thematic variable on top of one another, or a graduated bar chart, where the bars are graduated in size based on some value. You can also scale the bars in a multi-bar chart independently from one another. To show negative values in a bar chart map, the bars extend in the opposite direction to the chart's orientation. Note that negative values do not display in stacked bar charts.
Bar Chart Map

The Help System contains the following related topics:

- Creating a Bar Chart Map
- Customizing Bar Chart Styles on your Map
- Customizing the Map Legend of a Bar Chart
- Modifying a Thematic Map

Pie Chart Maps

Thematic maps using pie charts enables you to examine more than one variable per record at a time. Like comparing the height of the bars in bar charts, in pie charts you compare the wedges in a single pie, or examine a particular wedge across all pies. Pie charts enable you to compare parts of a whole.

Both pie and bar charts are particularly useful for analyzing demographic data. For example, you have a table of demographic information for the United States. Your table shows the populations of several major demographic groups. Using pie charts, you can show the population of each demographic group, and see what fraction of the pie it makes up in each pie. This enables you to see the distribution of demographic groups on a per state basis, or across the entire United States. You can also look at one demographic group and see how the population of the group varies in different states. For best results, use no more than four to six pie wedges per pie chart in your analysis.
You can customize the color of each pie wedge as well as the borders of the wedges and the whole pie. You can also specify the angle at which you want to place the first pie wedge, and whether the variables go in a clockwise or counterclockwise direction. Like bar charts, you can also change the pie's orientation. The default is to place the pie over the centroid of the object.

You can choose from graduated pies or half pies. Graduated pies graduate the size of the pies according to the sum of their components. Half pies distribute your data across half a pie instead.

The Help System contains the following related topics:

• Creating a Pie Chart
• Customizing a Pie Chart
• Customizing the Map Legend of a Pie Chart
• Modifying a Thematic Map

Graduated Symbol Maps

Graduated symbol maps use symbols to represent different values. You can use graduated symbols regardless of the type of map object with which you are working.

For instance, use graduated symbols to show the number of housing units by city. When you select the graduated symbols option, MapInfo Pro varies the size of each symbol according to the value in the sales order field.

You can also represent how much interest each customer has expressed in a given product by assigning a symbol whose size is proportional to the customer's interest.

Graduated symbols maps work best when you use numeric data. If you are working with a layer of restaurants, it makes no sense to create graduated symbols based on the type of cuisine each
restaurant serves. However, graduated symbols are appropriate when you want to show the relative number of housing units by city as in the next figure.

![Housing Units by City](image)

**Graduated Symbol Map**

There are three attributes you can customize on a graduated symbols map: the color, type, and size of the symbol. To change the symbol's attributes in Create Thematic Map - Step 3 of 3, choose **Customize Settings** and click the symbol icon in the **Customize Graduated Symbols** dialog box to access the **Symbol Style** dialog box. The default symbol is a red circle.
In the **Customize Graduated Symbols** dialog box, the size of the symbol in the **Symbol** box is the size for the value listed in the at **Value** box. All values between the high value and zero have interpolated point sizes. If you want the symbols at the low end to be larger, increase the point size.

You can also display symbols for negative data values. To change it, click **Options** in the **Customize Graduated Symbols** dialog box. There is a separate symbol picker so that you can make this symbol as distinct from the symbol for positive values as you want. When you click the icon a different **Symbol Style** dialog box displays, enabling you to choose a different symbol type, change the color or the size, or change any combination of the three attributes. The default symbol for negative values is a blue circle, and all values between zero and the low value (a negative number) also have interpolated point sizes.

The **Help System** contains these related topics:

- Creating a Graduated Symbols Map
- Customizing a Graduated Symbols Map
- Modifying a Thematic Map

**Dot Density Maps**

Dot density maps use dots to represent the data value associated with a boundary or region. The total number of dots in a region represents that region's data value. If you have 10,000 senior citizens in a county, and each dot represents 100 senior citizens, there would be 100 dots in the county boundary.

Dot density is particularly useful for showing raw data where one dot represents a large number of something: population, number of fast food restaurants, number of distributors who carry a brand of soda, etc.

For example, if you have a table of age demographics broken down into postal codes, you could use the dot density option to show the concentration of small children in each postal code boundary.
There are three customizing options for dot density maps. You can specify the value of one dot. For example, you have a table of population statistics, broken down by county. There are 10,000 pre-school students in Rensselaer County, New York. If you display Rensselaer County according to the number of pre-school students using the dot density method, each dot could represent 200 students. In that case, there would be 50 dots in Rensselaer County. You can specify the number of units each dot represents using the Customize Dot Density Settings dialog box.

When you increase the value each dot represents, you decrease the number of dots that display on the map. You could modify your dot density map so that one dot represents 400 students. In that case, there would only be 25 dots in Rensselaer County.

A second option is to change the size of the dots according to your needs, either large or small. If you are working with large populations, or large counts of something, make the dot size smaller so that the distribution of dots is easier to see.

Conversely, if your working with a small data set, making the dot size larger might illustrate your analysis more clearly.

Note: Distribution of dots is random within the region. If you shade states according to population, the dots for New York are spread out throughout the state; they are not concentrated in New York City, where the majority of the state’s population lives.

Thirdly, in the Customize Dot Density Settings dialog box, change the color of the dot to either red or black to add more variety to the final map. In this dialog box, you can select Circle or Square dot thematics and specify the dot density width (in pixels) of the square or circle. In general, squares
look clearer at small sizes. At larger sizes, it may be more appropriate to use circles. You can create multiple dot density maps on the same layer by varying these options.

In the Create Thematic Map - Step 3 of 3 wizard panel, click Customize Settings. This opens the Customize Dot Density Setting dialog box. Here you can change the number of units that each dot represents, and also select the dot shape (square or circle) size, and color. You can specify a circle size from 2 to 25 pixels in width. For a square, the size can range from 1 to 25 pixels.

The Help System contains these related topics:

- Creating a Dot Density Map
- Customizing a Dot Density Map
- Modifying a Thematic Map

Individual Value Maps

Individual Value maps show points, lines, or boundaries that are shaded by individual values contained in a particular field. You can use both numerical and nominal values in individual values maps. MapInfo Pro gives each unique value its own color or symbol. When an individual values map uses symbol types, the symbols are taken from the base table.

For example, a soft drink distributor maintains a table of the supermarkets that buy soft drinks from him. Each supermarket sells the distributor's brand of soft drink for a different price. If the distributor shades the supermarket points by price, using individual values, all stores that sell the soft drink for 49 cents are shaded one color, all stores that sell the soft drink for 51 cents are shaded another color, and so on. Each unique value is assigned its own color. The distributor is able to see the price distribution among the supermarkets and can determine where he should increase his sales volume, based on the price.
If you are shading your points, lines or boundaries using nominal data, you can shade only by individual values. Nominal data is either non-numerical data (name, type of cuisine served, or brand of automobile sold) or numeric data where the numbers represent non-numeric data like an ID number. Dates are considered numeric data and can be used in both ranged and individual values maps.

For example, you have the results from a consumer survey. One question on the survey reads "What is your favorite Sunday afternoon activity?" The possible responses are:

1. Sleeping
2. Watching TV
3. Taking a drive
4. Reading
5. Playing or watching sports
6. Visiting museums or art galleries
7. Going to the movies

You want to shade each consumer point with the response for the favorite Sunday activity. The SUNDAY column of your table contains the number that corresponds to the consumer's favorite activity. However, the numbers in this column do not represent quantitative values. Going to the movies is not greater than Playing or watching sports even though 7 > 5. When numbers are used as names instead of values, you must shade your objects by individual values. The numbers are only used to reference the pastimes so color can be assigned to them.

The Help System contains these related topics:
• Creating an Individual Values Map
• Customizing an Individual Values Map
• Customizing the Styles of an Individual Values Map
• Customizing the Map Legend of an Individual Values Map
• Custom Sort Order for Individual Value Thematic Map Legends
• Modifying a Thematic Map

Important Notes:

When you are creating and merging theme templates:

• MapInfo Pro saves the custom label order only when the option to **Save Individual Value categories** is selected in the **Save Theme to a Template** dialog box. This implies that when you create a theme based on a template, MapInfo Pro applies the custom label order only when the thematic expression creates the same categories as those in the template.

• When you are merging theme templates, the custom label order from the source template is applied to the current theme only when the option to **Merge Individual categories** is selected in the **Merge a Template to a Theme** dialog box and the template and current theme have the same number of categories.

• Saving a Template - The entry for theme templates in the **Options > Preferences Directories** dialog box allows you to designate the directory where theme templates reside.

• For more information, see **Saving Individual Categories in a Theme Template for an Existing Thematic Map** and **Saving Individual Categories in a Theme Template when Creating a Thematic Map** in the Help System.

Grid Surface Maps

A grid surface theme is a continuous raster grid produced by an interpolation of point data. MapInfo Pro takes a data column or expression from a table and passes those centroids and their data values to an interpolator. The interpolator produces a raster grid file, which appears as a raster table in a Map window.

Grid mapping displays data as continuous color gradations across the map. This type of thematic map is produced by an interpolation of point data from the source table. A grid file is generated from the data interpolation and displayed as a raster image in a Map window.

The Help System contains these related topics:

• **Working with Grid Thematic Layers**
• **Spreading Inflections by Equal Cell Count**
• **Modifying a Thematic Map**
Creating a Thematic Map

There are many kinds of thematic maps, but the process for creating each type of map is the same. In this section, we cover the creation of thematic maps in general terms.

You can find more specific instructions for creating specific types of thematic maps in the Help System.

Step 1 - Choosing a Type of Thematic Template

Templates allow you to make a thematic map based on values and settings. In our default types, you can alter these settings and/or save them as a new template you can use again. When you first create a thematic map, you select a template that you can modify to suit your requirements. You cannot create a theme without using an existing theme template.

- **Template Sort by Name** - Displays available templates in alphabetical order according to their name.
- **Template Sort by Time** - Displays available templates according to the time they were created or last modified.
- **Preview Legend Sample** (Template Type) - Displays a sample legend for the template type.
- **Use Customized Legend Text** - Displays customized text for the legend. If enabled, the template has custom titles or range labels. Check to use the custom text.
- **Cancel** Button - Cancels the options dialog box and returns to the map.
- **Next** Button - Continue to next step.
- **Range Template** - Displays your data according to the ranges you set. Ranges are shaded with colors and/or patterns. Choose from templates displayed as shaded lines, points or regions. Ranged thematic maps allow you to illustrate data values across points, lines and regions. They are used to show a relationship between the data values and geographical area (e.g. sales figures, household income) or to present ratio information such as population density (population divided by area). Ratio information can be shown in other types of thematic maps when you choose Expression in Step 2.
- **Bar Chart Template** - Displays a bar chart of your thematic variables for each record in your table. Use bar charts to analyze multiple variables per record on the map. Make comparisons between the size of the bars in each chart to obtain information about a record in the table set, or compare one bar in all the bar charts to draw conclusions about a variable across all of the records, or compare the height of the bar charts to obtain information about the entire table. To indicate a negative value in a bar chart, bars extend in the direction opposite to the charts orientation. Negative values do not display in stacked bar charts.
- **Pie Chart Template** - Displays a pie chart of your thematic variables for each record in your table. Pie charts are multi-variable. Use pie charts on the map to analyze more than one variable at a time. You can compare the size of the pie wedges in each chart to obtain information about a record in the table, or compare one pie wedge in all of the pie charts to draw conclusions about...
a variable across all the records, or compare the diameter of the pie charts to obtain information about the entire data set.

- **Graduated Template** - Displays a symbol for each record in your table, the size of which is directly proportional to your data values. A graduated symbol map shows data points with specific numerical values. It is useful for illustrating quantitative information, such as high-to-low rankings. The size of the symbols is proportional to the data values of the points. Points that have larger data values appear larger, and points that have smaller data values appear smaller.

  For instructions on creating a Graduated Symbols thematic map, see *Creating a Graduated Symbols Map* in the Help System.

- **Dot Density Template** - Displays the data values as dots on your map, where each dot is equal to a number, and the total number of dots in a region is proportional to the data value for that region. A dot density map allows you to examine raw counts of data (e.g. population). Each dot represents a number of units. That number, multiplied by the total number of dots in the region, equals the data value for that region.

  For instructions on creating a Dot Density thematic map, see *Creating a Dot Density Map* in the Help System.

- **Individual Values Template** - Shades records according to individual data values. Individual value templates are multi-variable. Choose from shaded lines, points or regions. A thematic map that draws map objects according to individual values is useful when you want to emphasize categorical differences in the data rather than show quantitative information (e.g. types of stores in a given area, zoning classifications in a given area etc.).

  For instructions on creating a Individual Values thematic map, see *Creating an Individual Values Map* in the Help System.

- **Grid Template** - Grid mapping displays data as continuous color gradations across the map. This type of thematic is produced by an interpolation of point data from the source table. A grid file is generated from the data interpolation and displayed as a raster image in a Map window.

**Step 2 - Choosing Thematic Values**

Choose the map layer on which you want to base the map, and the field or expression from which you want to obtain the data values (thematic variable).

A thematic variable can be the data value that is associated with the graphic objects (regions, lines, and points) displayed in your map, such as the values in a column like Pop_1990, Buy_Power, or Median Age.

You can also obtain your thematic variable from another table using **Table > Update Column**. Update Column creates a temporary column in your base table where you can aggregate or calculate information about your data.
You can also use an expression for your thematic variable. For example, you could use the following expression to display population density:

\[
\text{Pop}_1990/\text{Area}(\text{obj}, "\text{sq mi"})
\]

You can access the **Expression** dialog box in Step 2 of creating a thematic map. See the Help topics, *Using Expressions in a Thematic Map* and *Creating Expressions* for more information.

Your map may have more than one variable, depending on the thematic method you choose. Pie and Bar chart maps contain more than one variable; the other five types of thematic maps contain one variable. Depending on your choice of a one-variable or multi-variable thematic map, one of two **Create Thematic Map - Step 2 of 3** wizard panel displays.

### One-Variable Thematic Maps

Ranged, graduated symbol, dot density, individual value, and grid thematic maps examine one variable. The **Create Thematic Map - Step 2 of 3** wizard panel that displays for these kinds of maps asks you to choose only a table and one field or expression.

1. Choose a table from the **Table** drop-down list. The drop-down list displays the tables that are mapped in the active Map window.
2. Choose the table on which you want to base the map.
   - If you have objects selected in the Map window, the Selection from TABLE item also displays in the list. This enables you to create a thematic map based on the selected items without having to map the selection. You can also base your thematic map on a mapped query table.
3. Choose a field from the **Field** drop-down list.
   - The drop-down list displays all the numeric fields in the table you selected from the **Table** list. Choose the field or expression that contains the data values.
4. Select the **Ignore Zeroes or Blanks** check box to ignore zero values and blank values in the table.
   - Because you are creating a thematic map based on one field in a table, any zero or blank values in that field will cause the whole record to be ignored. If you are creating a grid map, you can choose a table of regions to clip the grid against.
5. Click **Next** to go on to **Step 3 - Customizing Your Thematic Map**.

### Multi-Variable Thematic Maps

Pie and Bar Chart thematic maps allow you to analyze more than one variable at a time. In the **Create Thematic Map - Step 2 of 3** wizard panel, you choose the fields or expressions you want to use as the variables, and list them in an order that best suits your analysis.

To create a multi-variable thematic map in the **Create Thematic Map - Step 2 of 3** wizard panel:

1. Choose the table on which you want to base the map from the **Table** drop-down list.
   - The drop-down list displays the tables that are mapped in the active Map window.
If you have objects selected in the Map window, the Selection from TABLE item also displays in the list. This enables you to create a thematic map based on the selected items without having to map the selection.

Fields from TABLE displays all the numeric fields in the table you selected from the Table list.

2. Choose the field, or create an expression that contains the data values.

**Fields for Pie/Bar Chart** indicates the fields or expressions you have chosen for your pie or bar chart thematic map. The order of the variables in the **Field for the Pie/Bar Chart** list is the order in which the variables appear in the legend.

- For bar chart thematic maps, the order in which the variables display in the legend is the order in which the bars display from left to right on the map.
- For pie chart maps, the first variable in the legend corresponds to the pie wedge that begins at the angle specified in the **Customize Pie Style** dialog box.

3. Click **Styles** in the **Create Thematic Map - Step 3 of 3** wizard panel.

The **Customize Pie Style** dialog box opens:

- Click **Up** to move the selected field or expression up one place in the **Fields for Pie/Bar Chart** list. **Up** is unavailable when the selected item is the first item in the list.
- Click **Down** to move the selected field or expression down one place in the **Fields for Pie/Bar Chart** list. **Down** is unavailable when the selected item is the last item in the list.
- Click the **Right Arrow** button to move the selected field in the **Fields from TABLE** list to the **Fields for Pie/Bar Chart** list.
- Click the **Left Arrow** button to move the selected field in the **Fields for Pie/Bar Chart** list to the **Fields from TABLE** list.

4. Click **Next** to go on to Step 3.

**Step 3 - Customizing Your Thematic Map**

The last step allows you to customize your thematic map, or create the map based on the default settings. You can also preview the map's legend before you display the map, and change the legend's label order. Use these features:

- **Preview** (Thematic Map) - Displays a sample legend of the thematic map you are creating.
- **Customize** - The buttons in the Customize group enable you to change the default settings of particular aspects of your thematic map. For more information, see the Help topic, **Modifying A Thematic Map**.

- **Ranges** - Allows you to customize settings on a ranged map. This option is available for ranged and grid maps.
- **Styles** - Enables you to customize style attributes such as color and size. This option is available for ranged, pie, bar, and individual value maps.
- **Legend** - Enables you to customize your map legend. This option is available for all types of thematic maps.
• **Number of Columns** - Use this field to indicate the number of columns in which you want the map legend entries to display.

• **Legend Label Order** - Determines the order in which range and value labels (for ranged and individual values maps) and field labels (for all other thematic maps) appear in the map legend. If you are creating a ranged map, the order you specify is also shown in the **Customize Range Styles** dialog box. Use these entries to indicate whether the map legend entries should display in **Ascending** or **Descending** or alphabetical order. Click **Custom** to select a custom label order and to enable the **Order** button.

• **Order** - Use this button to display the **Customize Legend Label Order** dialog box. Here you can click an entry in the list and use the **Move Up** and **Move Down** buttons to properly position the label entries until they are in the order you want. Click **OK** to save the custom order.

• **Associate Theme with Table** - The options you select in this group determine the default theme display for the current map.

• **Save As Default Theme View** - Use this check box to save this theme to the map's metadata so that the theme you have chosen displays each time you open the map.

  **Note:** To ensure that this feature works, you must set the **Automatically Open Default Theme** option in the **Map Window Preferences** dialog box.

• **Remove Default Theme View** - Use this check box to remove the saved default theme from the map's metadata.

• **Template** - The buttons in the Templates group enable you to specify a name for a template, save the thematic map as a template, and when modifying an existing theme merge the thematic map with another template.

• **Save As** - Displays the **Save Theme to a Template** dialog box. Type a unique name or select an existing name and overwrite it. If you overwrite an existing template, you are prompted to confirm this action.

• **Merge** - The **Merge** button is enabled only when you are modifying an existing theme, not when you are creating a thematic map.

When you click **OK** a thematic map is created based on either the default or customized settings.

**Customizing the Legend of a Thematic Map**

To customize the legend for a thematic map, choose the **Legend** button in the **Create Thematic Map - Step 3 of 3** wizard panel. It displays the **Customize Legend** dialog box where you can customize the map legend's title, subtitle, fonts, or range labels. You can also specify if you want to display a legend for this thematic layer. To customize a legend after creating a thematic map, double-click on the legend frame in the Legend Designer window.

The **Help System** contains these related topics:

• **Working with a Thematic Map Legend**

• **Customizing a Thematic Map Legend**

• **Customizing the Contents of a Legend Frame**
Saving a Theme to a Map Window

To save a thematic map to a Map window's table, you must select the **Automatically Open Default Theme** check box in the **Map Window Preferences** dialog box.

- For more information, see *Saving a Theme to a Map Window* in the Help System.

Working with a Thematic Map Legend

Theme legends are created automatically when you create a thematic map. They provide a key of the colors, symbols, and styles used in the map. MapInfo Pro offers many types of themes for creating a thematic map, such as range, bar chart, pie chart, graduated, dot density, individual values, and grid themes. For a description of the various theme templates and how to create a thematic map, see *Creating a Thematic Map*.

By default, a theme legend displays in an existing Legend Designer window if one exists. Otherwise, it displays in a new Legend Designer window. You have the option of working with this Legend Designer window or you can add the map legend to an existing or new Legend Designer window.

- To add the thematic map legend to an existing Legend Designer window, see *Adding Frames to a Legend* in the Help System.
- To create a new Legend Designer window that includes the thematic legend as well as legends for other layers on the map, follow the instructions under *Creating a Legend for your Map* and make sure to include the thematic layer in the Create Legend Choose Layers screen (all map layers, including thematic layers, are included by default).

To display a simple Legend window with a thematic legend, use the **Show/Hide Theme Legend Window** command in the Options menu after having created a thematic map.

For more information, see *Customizing a Thematic Map Legend* in the Help System.

Thematic Maps as Layers

If you have created a thematic map, it will be listed in **Map > Layer Control** as a separate layer. Thematic layer names are indented and display above their corresponding data layers in the layer list. You can modify the attributes of the thematic map through Layer Control.

**Note:** A Grid thematic layer will not be indented in the Layer Control window; a grid thematic layer is a read-only layer.

To modify the attributes of a thematic Map:

1. Choose **Map > Layer Control**.
   
   The Layer Control window displays.

2. Double-click the thematic layer.
   
   The **Modify Thematic Layer** dialog box displays.
3. Change the thematic settings, style, or map legends from this dialog box.
4. Click OK. The map redraws with your changes.

Note: The availability of certain dialog boxes depends on the type of thematic map you are altering.

For a full discussion of altering thematic maps, see Modifying a Thematic Map.

Changing the Display Parameters of a Map

Modifying a Thematic Map

Once you create your theme, it is likely that you will want to change something about it. MapInfo Pro provides two ways to reach the Modify Thematic Map dialog box where you can customize a variety of settings, styles, and map legend components.

To modify a thematic map, do one of the following:

• On the Map menu, choose Modify Thematic Map.
• In the Legend Designer window, double-click the thematic map’s legend.

When you are modifying a map, a quick way to change a number of settings at once is to change the template of the current theme.

To merge a template into your current map:

1. On the Map menu, choose Modify Thematic Map.
2. In the Modify Thematic Map dialog box, click Merge in the Templates group.
   The Merge a Template into the Current Theme dialog box displays with a list of the same type templates as your theme (all range of values templates, for example.)
3. Choose the new template.
4. Click OK to return to the Modify Thematic Map dialog box.
5. Click OK to display the map with the new thematic template.
   The settings in this template will be applied to your theme.

The Merge feature is only available once you have created the thematic map.

Using the Theme Templates

You can use the theme templates for region ranges, region individual values, point ranges, and grid elevations. Some of the new region range templates are sequential (variations on a particular color
to show intensity), and some are color diverging (starting with one color and moving to other complementary colors) and each has its purpose. Sequential templates are helpful when you are showing a progression of data, that is, when the data is straightforward. An example might be population.

**Figure: Sequential Template Example**

![Sequential Template Example](image)

*Figure: Sequential Template Example*

*Diverging* templates are useful when showing data that diverges more dramatically. An example might be world literacy rates:

**Figure: Divergent Theme Example**

![Divergent Theme Example](image)

*Figure: Divergent Theme Example*

The areas in green are areas we do not have data for.
Saving Your Thematic Settings

MapInfo Pro provides a way to save your themes and the templates from which you created them.

**Saving Thematic Map Layers**

To save your thematic maps, on the **File** menu, click **Save Workspace**. A workspace is a listing of all the tables and settings used in a map. When you open the workspace, MapInfo Pro opens the tables and re-creates the thematic map. If you close a table or Map window without saving your session to a workspace, MapInfo Pro displays the **Save Map Objects** dialog box and prompts you to do so. The dialog box indicates what types of objects will be lost (for example, thematic layers, label layers) if you do not save your session to a workspace. You can turn off the warning prompt in Map Window preferences.

**Saving Thematic Templates**

Every thematic map begins with a template from which you can then customize for your particular needs. These settings can be saved for future use. In the **Create Thematic Map - Step 3 of 3** wizard panel, choose **Save As** in the **Template** group box. The **Save Theme to a Template** dialog box displays. To save your new settings to the existing template, choose **OK**. To retain both the new and the original template, type a different name into the Name field. To recover any template that ships with MapInfo Pro, copy it from the \THMTMPLT directory on the product DVD. Templates have the extension .THM. In MapInfo Pro files are stored on a per-user basis.

For individual value themes you can also save the actual categories in a theme template. For example, if you choose to build an individual value theme on a table to show land usage, you can assign a different region style to each type of land usage (commercial, forest, residential, farm land etc.). You may then want to take those same assignments and apply them to another table. You can do this by storing the category in a template, it will be associated appropriately when the template is applied to the second table.

To save individual categories in a theme template when creating a new thematic map or for an existing thematic map, from the **Modify Thematic Map** dialog box choose **Save As** and specify a template Name. Select the **Save Individual Value Categories** check box and choose **OK**. A template is saved that can be used to apply the stored individual categories to a second table. When you choose **Map > Create Thematic Map**, the template’s name will appear in the Template Name field of the **Create Thematic Map - Step 1 of 3** wizard panel.

**Important Notes for Creating and Merging Theme Templates:**

When you are creating and merging theme templates:

- MapInfo Pro saves the custom label order only when the option to **Save Individual Value categories** is selected in the **Save Theme to a Template** dialog box. This implies that when you create a theme based on a template, MapInfo Pro applies the custom label order only when the thematic expression creates the same categories as those in the template.
- When you are merging theme templates, the custom label order from the source template is applied to the current theme only when the option to **Merge Individual categories** is selected in the **Merge**
a Template to a Theme dialog box and the template and current theme have the same number of categories.

Updating Columns using Thematic Mapping

As explained earlier in this chapter, you can use data from another table to construct your thematic map using Update Column. Update Column creates a temporary column in your base table and automatically inserts data into it for your map. This data can be a field taken directly from another table, or aggregated from other data.

For example, you have a table of U.S. state boundaries and a table of U.S. city point locations. Using ranges of values you want to shade the STATES table according to the percentage of each state’s population living in urban areas. For MapInfo Pro to calculate this percentage, the population for the cities must be in the STATES table.

Note: Some of the files used in this example may be from the MapInfo Pro Tutorial data and is only available from the Pitney Bowes Software Inc. web site, http://go.pbinsight.com/webtutorials.

To create a temporary column using Update Column:

1. Open the base table (USA.TAB) and the city table (USCTY153.TAB).
2. On the Map menu, choose Create Thematic Map.
   The Create Thematic Map - Step 1 of 3 wizard panel opens.
3. Click **Ranges** and select a template name from the list. This is the style of the thematic map you are creating.

4. Click **Next**.
   
   The **Create Thematic Map - Step 2 of 3** wizard panel opens.

5. Click **USA**, this is the table you want to shade.

6. In the **Field** drop-down list, select **Join**.
   
   The **Update Column for Thematic** dialog box opens.
Table to Update is already set to STATES and Column to Update is automatically set to **Add new temporary column**.

7. In the **GetValue From Table** box, select **CITY_125**.

   If that is the only other table open, MapInfo Pro automatically displays its title in the list box.

   **Note**: When you create a temporary column for a thematic map, the field must be a numeric field. This is true for all thematic maps except individual values.

   Since in our example, we are looking for the percentage of the population living in urban areas in the United States, we need to calculate the total of the CITY_125 population; that is, we must calculate the total of the population of each city in each state. We need to put that sum into the temporary column.

8. In the **Calculate** box, choose **Sum**.

9. In the **of** box, choose **Tot_pop**.

   To put the data from the CITY_125 table into the temporary column of the STATES table, there must be a link between the two tables that MapInfo Pro can use to access the data. MapInfo Pro can often make this link automatically. In this example, both our tables have a **State** field.

10. Click **Join**.

    The **Specify Join** dialog box opens.
When you choose **Join** in the **Update Column for Thematic** dialog box, you can see that MapInfo Pro has already set up the **Specify Join** dialog box with the STATE fields from both tables. If the join were not calculated automatically it would be necessary to specify the matching fields or geographic join.

11. Choose **OK**.

MapInfo Pro calculates the sum and returns you to the **Thematic - Step 2 of 3** dialog box. The **Field** list box displays the temporary column you created: SumOfTot_pop.

However, before we create the map, we still need to calculate the percentage of the total population of each state that is urban. That information does not exist as a field in the table, so you must build an expression to generate it.

12. In the Field drop-down list, select **Expression**.

   The **Expression** dialog box displays.

   ```plaintext
   SumOfTotPop / Pop_1990 * 100
   ```

The expression `SumOfTot_pop/Pop_1990 * 100` will give you the answer as a percent.
13. In the expression box, type:

\[ \frac{\text{SumOfTot_pop}}{\text{Pop_1990}} \times 100 \]

14. Click Verify to ensure that your syntax is correct, and then choose OK. The Create Thematic - Step 2 of 3 dialog box shows the expression you created.

15. Click Next.

The Create Thematic Map - Step 3 of 3 wizard panel opens.

16. Click Ranges and choose either Equal Count or Equal Ranges to customize the ranges, whichever gives you the best representation of your data.
Use Round By to round to a decimal place or whole number. Customize the styles to best illustrate your analysis by clicking the Styles button. Customize your map legend by clicking the Legend button.

17. Click OK

The Map window redraws with your thematic.

For details about using point or line objects to represent thematic variables, see *Bivariate Thematic Mapping* in the MapInfo Pro Help System.

**Adding Temporary Columns**

Use Update Column to add temporary columns to a table by using data from another table.

To add a temporary column:

1. Open at least two tables.
2. Choose Table > Update Column.

   The Update Column dialog box opens.

3. In the Table to Update list, choose the table to add the temporary column to.
4. In the Get Value from Table list, choose the table that MapInfo Pro will retrieve the update information from.
5. To add a temporary column, select the Add new temporary column option from the Column to Update list.

   If necessary, specify the information MapInfo Pro will need to associate the data (join) in the two tables by using their common tabular or graphic data.
6. Choose how to produce the column data by specifying how to calculate the information based on columns and expressions from the Calculate and of lists.

7. Select the Browse Results check box to display the table with its new temporary column in browser format.

8. Click OK.

The temporary column is added based on the specified information.

When you make changes to the data table, the new temporary column is automatically updated.

To save the table with its new temporary columns, use File > Save As. If the temporary columns are added to a table in a workspace, the changes are automatically saved when you save the workspace.

The Help System contains the following topics about Bivariate Thematic Mapping:

- Types of Bivariate Maps
- Creating a Transparent Bivariate Layer (Ranged Theme)
- Creating a Transparent Bivariate Layer (Individual Value Theme)
- Setting the Default Behavior of the Replace Layer Style Check Box
- Example of Bivariate Thematic Mapping
- Using an Inflection Point to Show Distinction
- Example of an Inflection Point Map
- Controlling the Number of Inflection Values
- Applying Rounding Factors to Inflection Values
- Spreading Inflections by Equal Cell Count

Working with Grid Surface Maps

The thematic maps we have discussed are based on vector layers. MapInfo Pro takes thematic mapping to a new level with a method that displays data as continuous color gradations across the map. This type of thematic mapping, known as grid mapping or surface theme mapping, is produced by an interpolating point data from the source table. MapInfo Pro generates a grid file from the data interpolation and displays it as a raster image in a Map window.

Grid theme maps are appropriate analytical tools in traditional GIS environments and other industries where the data points have measured values that reflect those locations. For example, use grid shading to illustrate temperature changes, snowfall amounts, or change in elevation.

The next figure shows the light to dark gradual transition across the United States, which represents low to high average annual temperatures. The continuous shading allows you to derive measurements at places other than where measurements were taken.

Figure: Grid Surface Thematic Map
Grid Image Files

Grid mapping produces a file type called a grid image. When you create a grid thematic map using MapInfo Pro’s grid handler, MapInfo Pro generates a default file name of `tablename_fieldname` with the extension .MIG (for example, USELEV_ELEVFEET.MIG). In the **Create Thematic Map - Step 2 of 3** dialog box MapInfo Pro displays the path and the root file name, where you can change it as necessary.

MapInfo Pro contains one read/write grid handler and a Grid Engine tool kit that shows you how to create your own. Once you have written a grid engine, you place this file in your MapInfo Pro application directory and set the preference in the **Map Window** dialog box. Specifically, to set the default grid writeable handler, go to the Map window preferences and specify your grid handler file. The available handler formats depend on what grid handlers have been installed. Changing the default grid handler will change the default file extension of the grid file name.

Grid files are stored by default in the data directory specified as a preference. Grid files can be opened from the **File** menu, click **Open** command like other MapInfo Pro supported file types.

When you open a table that has a grid filename associated with it, MapInfo Pro searches for the file if it cannot find it immediately. For example, the search capability can simplify opening tables if your .tab file refers to an image that resides on a DVD drive, and different letters are used to designate the DVD drive on different systems.

MapInfo Pro uses the following search order:

1. Search for the file where specified by the **FILE** tag in the .tab file.
2. Search for the file in the same directory as the .tab file.
3. Search for the file in the **Table Search** path specified in the **Directories** preferences.

MapInfo Pro either opens the table as though it found the file in the specified location, or it will report an error because the file could not be found in any location.
Working with Grid Handlers

In addition to the MapInfo Pro read/write grid handler (*.MIG) we also supply READ-ONLY grid handlers to support the direct opening of the following grid file formats:

- DEM-USGS ASCII(*.DEM)
- DTED-levels 1, 2, and 3 (*.DT0, *.DT1, *.DT2)
- GTOPO30 (*.DEM)
- MapInfo Vertical Mapper (*.GRD, *.GRC)

You can open these grid file types directly from the Open dialog box. You will see the file extensions listed next to the Grid Image file type in the Files of Type drop-down list in the bottom of the dialog box. Because the handlers are read-only, they cannot be used to create grid files during the thematic mapping process.

If the relief shading option is enabled (in the Create Thematic Map - Step 3 of 3 wizard panel, click Styles and then Grid Appearance), a separate file will be created to store the hill shade information. The hillshade file is stored in the same location as the grid file and has the same base name as the grid but with the extension "*.MIH". If the grid file is read-only, for example, it's located on a DVD, the .MIH files will be created in the same location as the .tab file. The .tab file will contain a new metadata key, for example:

"\Grid\Hillshade File" = "d: \tmp \AntiochSouth.MIH"

Vertical Mapper Grid Handler

MapInfo Pro also includes the Vertical Mapper Grid handler to enable users who have not purchased the full Vertical Mapper add-on product to open, view, and print Vertical Mapper Grid (*.GRD, *.GRC) format files.

The Vertical Mapper Grid files can also be opened directly in MapInfo Pro. The *.GRD or *.GRC extension is listed with the other Grid Image formats in the Files of Type drop-down list.

Currently, grids using the Vertical Mapper handler cannot be modified in the Modify Thematic Map dialog box. They are read-only. They must be created or modified in the Vertical Mapper source application, which is available from Pitney Bowes Software Inc.. In addition, you cannot create .GRD or .GRC files in MapInfo Pro, however, you can convert *.GRD files to *.MIG files with GRIDTOOLS.MBX.

The Help System contains these related topics:

- Creating Custom Read/Write Grid Handlers
- IDW Interpolator
- TIN Interpolator
- Grid Appearance
- Inflection Methods
- Relief Shading
- Grid Translucency
• Final Adjustments
• Zoom Layering
11 - Buffering and Working with Objects

Two of the most important features in MapInfo Pro are buffers and the tools we provide to work with objects. Buffers allow you to create grouping areas around objects, lines and regions, which is important for providing a visual analysis. You can edit and manipulate objects in a wide variety of ways. The Set Target editing model allows you to apply a wide range of editing operations to an object or a series of objects. Using MapInfo Pro you can also create territories and create objects. This chapter covers these topics and discusses the advanced topics of enclosing, checking, and cleaning objects.

In this section

- Buffering Your Data 332
- Editing Objects using the Set Target Model 339
- Creating Territories by Combining Objects 346
- Creating and Manipulating Objects 350
Buffering Your Data

If you would like to search for all underground cable wires that are buried within 440 yards of Interstate 490 or you would like to contact all families with pre-school age children who live within five miles of a proposed school district, buffering is the tool for you.

Understanding Buffers

A buffer is a region that surrounds a line object, another region, symbol, or any other object in a Map window. For example, you can create a buffer region that surrounds Interstate 90 by 440 yards on either side. You can create a buffer region that surrounds the proposed school district by five miles on all borders. Both the 440 yards and five miles are their respective regions’ buffer radii. The buffer table is then joined to data associated with the original buffered objects.

Note: The maximum buffer resolution is 500 segments per circle. This affects the entry you can make in the Smoothness field of the Buffer Objects dialog box.

Creating a Buffer

To buffer objects:

1. Select the objects that you want to buffer. Make sure there is an editable layer in the Map window. The output buffered objects will be placed in that layer.

   Note: There are certain table variables that you need to be aware of that will determine the aggregation method used in joining the table of buffers to data associated with the original objects. See Table Variables for this information.

2. On the Objects menu, click Buffer. The Buffer Objects dialog box displays.
3. Select appropriate buffer radius, segments per circle, distance type calculation to use, and buffer method as described.

   • Radius - The radius is the width of the buffer you want to create around the object you selected. The Value and the From Column radio buttons give you different ways to specify that width.
   • Value - Type a value into this field if the radius of the buffer you want to create is a specific distance. Examples might include 10 feet, 20 kilometers, 50 chains.
   • From Column - Select this radio button if the buffer you want to create is specified in a particular column or is to be calculated by an expression. Then select the column or choose Expression from the drop-down list.
   • If you select Expression, the Expression dialog box displays. Specify the expression you want MapInfo Pro to use to calculate the buffer radius and click OK to return to the Buffer Objects dialog box.
• **Units** - Select the units for the buffer from this drop-down list. Options include: inches, links, feet, US Survey feet, yards, rods, chains, miles, nautical miles, millimeters, centimeters, meters, kilometers.

• **Smoothness** - Type the number of segments per circle that determines the resolution of the curves in the buffer polygon. You can enter a number between 3 and 100. The default value is 12 segments per circle. If making adjustments, a value of 24 yields good results.

• The more segments you enter, the smoother the curve. The fewer segments, the more jagged the curve. More segments produce a smoother curve; fewer segments make a more jagged curve.

**Note:** Creating a buffer is time consuming. The higher the smoothness (more segments), the longer it takes to create a buffer.

• **One buffer of all objects** - Select this option to create one buffer for all of the objects you have selected. For example, if you are buffering Pennsylvania, New York and New Hampshire, one buffer will be created for all three of these objects.

• **One buffer for each object** - Select this option to create one buffer for each object you have selected. For example, if you are buffering Pennsylvania, New York and New Hampshire, each object will have a separate buffer.

• **Buffer Width Distance using Spherical** - Select this option if you want the buffer to take into account the curvature of the Earth. Using this method, MapInfo Pro converts the data to Latitude/Longitude and then creates a mathematical calculation of the buffer. You cannot use this method for non-Earth projections.

• **Buffer Width Distance using Cartesian** - Select this option if you want the buffer to be calculated as if the map is on a flat plane. Cartesian coordinates are a pair of numbers, (x, y), defining the position of a point in a two-dimensional space by its perpendicular projection onto two axes which are at right angles to each other. If you are using a Latitude/Longitude projection, this option is disabled.

4. When you have completed your entries and selections in this dialog box, click the **Next** button. The standard **Data Aggregation** dialog box displays.

**Note:** If the editable layer is the Cosmetic layer, the **Data Aggregation** dialog box will not display because there is no data in the layer to aggregate. The **OK** button displays in place of the **Next** button. Click **OK** to begin the buffer operation.

5. Highlight each of the columns to complete the fields in this dialog box.

• **No Change** - Select this option to keep the value for the selected column in the target row unchanged. This option only displays when you combine objects into a target object.

• **Blank** - Select this option to store blank values in the selected column(s). To store blank values in all displayed columns, select the **No Data** check box. Only choose the **Blank** option to blank out individual columns.

• **Value** - Select this option to store the value that displays in the edit field in the new row. When you select this option, enter an appropriate value in the field.

• **No Data** - Check this check box if you want no data aggregated to any column.
6. After setting the appropriate data aggregation parameters, click OK. MapInfo Pro calculates the buffer according to the parameters you set and creates the new objects in the editable layer. The original objects remain unchanged. Once MapInfo Pro has created the buffer region, it puts it in the editable layer.

Table Variables

If the table containing the selected table and the editable table are either the same table, or contain the exact same table structure (same number of columns with each column in both tables having the same name and data type), then the Sum and Average radio buttons do not display. The data is taken from the current selection, and the results are placed in the editable layer.

If the table containing the selection objects and the editable table are different, and the table structures are different, then the Sum and Average radio buttons are displayed. In this case, the data aggregation for the editable destination table column is initially blank, and you need to select the column from the input selection table to derive the data from.

Saving your Buffer as a New Layer

You can create a buffer and save it as a new table (layer) or as part of another layer in your map. See Saving your Voronoi Polygon as a New Layer in the Help System. This process is also similar to the Combine Using Column process, except that there is no "Group By" functionality for buffers.

**Note:** The table must be mappable to use this feature.

To create the buffer as a distinct layer:

1. To create a selection to buffer, select the object in the map. This step is not required if you want to buffer all objects in a particular table.
2. On the Table menu, click Buffer. The Table Buffer dialog box displays.
3. Do one of the following:
   • To buffer the selected object, leave the **Selection** object selected in the Buffer objects in table drop-down list box.
   • To buffer objects from a particular table, select the table in the Buffer objects in table drop-down list box.

4. Select the type of table you want to place the buffer into from the Store results in Table drop-down list box. Select one of the following:
   • **New table** - allows you to save the buffer in a new table
   • `<tablenames>` - allows you to save the buffer in one of the currently open tables

   After you make this selection, click **Next** to continue.

   **Note:** You cannot save a buffer to the Cosmetic Layer.

5. Do one of the following:
   • If you chose the **New table** option, go to Saving a Buffer to a New Table in the Help System.
   • If you chose `<tablenames>`, go to Saving a Buffer to an Existing Table in the Help System.

**Buffer Radius**

The buffer radius determines the dimensions of the buffer region. For example, if you want to create a region that covers an area one mile on either side of a freeway, set your buffer radius to 1 mile. If you choose to use a field from the table or an expression, MapInfo Pro will calculate the radius of the buffer based on that value.

You can set the radius to be a constant value or you can choose a data value from the table to be used as the radius. For example, to create buffers around major cities that reflect the size of their population, choose the population field as the value.

You can go even further to calculate the buffer radius using an expression. For instance, you want to create buffers around cities showing the population density. Since you do not have a field containing population density, you will need to write an expression that can calculate density from population and area. This is no different than writing an expression for thematic mapping or query selection.

**Buffering - Setting the Number of Segments per Circle**

The number of segments per circle determines the level of detail in the buffer region. The more segments per circle, the higher the level of detail. The default level is 12 segments per circle.

**Buffer Width Distance**

MapInfo Pro's buffering feature calculates the buffer width to create a buffer that is some measured distance from the outline of the object. This distance is calculated using either the Spherical or Cartesian method.

Spherical calculations measure distance according to the curved surface of the Earth. This means that the distance from the boundary of the original object to the boundary of the new buffered object may vary from node to node.
Cartesian calculations measure distance on data that has been projected onto a flat, X-Y plane. This produces buffers that are exact in width, as long as the data is not in a Latitude/Longitude projection.

The availability of the Spherical and Cartesian buttons depends on the type of calculation that is appropriate to the table's projection. The Cartesian button will not be available if the table is in a Latitude/Longitude projection. Conversely, the Spherical button will not be available if the table is in a Non-Earth projection.

Buffer Methods

You can create a single buffer to include all selected objects, or create individual buffers for each object. There are two ways you can buffer multiple objects at the same time. The first method is to create one buffer for all objects. Buffers are produced around each input object, and the resulting buffer objects are combined into a single output object.

The more powerful method is to create one buffer for each object. For example, you have a layer of satellite offices. You would like to create a five-mile radius buffer around every satellite office symbol. You select all office symbols (with either the Select All command or Select tool), on the Objects menu, click Buffer, and select the option to create one buffer for each object. MapInfo Pro creates five mile buffer polygons around each point. With this method, MapInfo Pro considers the resulting buffers as individual region objects and does not combine them into one. Once you create a buffer region, you can search for objects within it, as with any other boundary.

About Buffer Calculations

Buffer functionality uses a Width setting to create a Buffer that is some measured distance from the outline of the object. Using Latitude/Longitude data, the perfect buffer width, as defined in native Latitude/Longitude decimal degrees, may change on different portions of an object. This is because the width is provided in some flat measurement unit, (for example, miles, meters), and the decimal degree to measurement transformation will vary depending on the location on the earth. For example, a mile spans a larger number of latitude degrees as you move toward the poles of the earth and away from the equator.

MapInfo Pro calculates a native decimal degree width (converting from the input measurement unit) for one location in the object, typically the center of the bounding box. Thus, the measured On Earth (Spherical) distance from the boundary of the original input object to the boundary of the new buffered object may vary slightly from node to node. On small objects the distance may be negligible. On objects that span a large distance, such as the United States, the distance variation may be measurable.

In MapInfo Pro, you can produce Cartesian calculated buffers. Using this option, the data is considered to be in a flat-projected coordinate system, and the measured buffer widths are calculated using Cartesian distances. This produces exact buffers (as measured by the Cartesian Distance functions) as long as the data in not in a Latitude/Longitude projection.
Types of Buffers

There are two basic types of buffers that we support in MapInfo Pro.

- **Concentric ring buffers** allow you to create circles around map object(s) or point(s) and compute aggregated values for underlying data that occur within each ring. You would use concentric ring buffers to determine the number of customers within a certain radius of a store or other location.

- **Convex hull buffers** create a region object that represents a polygon based on the nodes from the input object. You can think of the convex hull polygon as an operator which places a rubber band around all of the points. It will consist of the minimum number of points so that all points lie on or inside the polygon. With convex hull buffers, no inside angle is greater than 180 degrees.

For specific instructions, see *Specifying Buffer Calculations in the Help System*.

Concentric Ring Buffers

In the Creating a Buffer, you learned how to create a buffer around one or more objects. Concentric ring buffers allow you to create multiple buffers of different width (radii) around an object or a set of selected objects. The Concentric Ring Buffer tool can assist you in creating this type of buffer.

- For specific access instructions, see *Concentric Ring Buffer Tool in the Help System*.

To create concentric ring buffers:

1. In the Map window, select the object(s) you want to place buffers around.
2. On the Tools menu, point to Concentric Ring Buffers and click Create Concentric Ring Buffers. The Concentric Ring Buffers dialog box displays.
3. To add a ring, specify the radius in the **Radius** field and click **Add Ring**. Continue this until you have added all of the rings you want from the smallest to largest.

4. Select the units of each radius in the **Units** drop-down list.

5. To set the smoothness of the ring buffer, type a number between 3 and 500 in the **Smoothness** field. The larger the number, the smoother and less jagged the curves of the ring.

6. Type the table name and select the path in which you want to store this buffer information. MapInfo Pro stores the concentric ring buffer information into this table including the columns containing the ring number, radius value, radius units, area, and area units for each ring.

7. When you have finished the buffer settings, click **OK**.

Use the Modify Ring and Delete Ring buttons to change the ring settings, or click Clear All to start all over and create new concentric rings. To change the style of a buffer ring, select it in the Buffer Radii list, and use the style buttons to change the fill pattern and line style for the buffer. You can also collect data within each buffer ring using the Calculate Ring Statistics button.

**Convex Hull Buffers**

The Convex Hull command provides another means of creating a polygon around a selected object or objects. Convex Hull is similar to creating a buffer in several ways. Like a buffer, the Convex Hull command always creates an object from the input objects, and it will place the result objects into the editable layer. In addition, you have a choice to create one convex hull object from all of the input objects, or to create one convex hull object for each input object.

The resulting region object(s) are based on the nodes from the input object. The Convex Hull operation can be thought of as an operator that places a rubber band around all of the points. It consists of a minimal set of points such that all other points lie on or inside the polygon. Since the polygon is convex, no interior angles are greater than 180 degrees. No attribute data is aggregated in this operation. To use Convex Hull, a Map window must be active, it must have an editable layer, and objects in the editable layer must be selected.

To create convex hull objects:

1. On the **Objects** menu, click **Convex Hull**. The **Create Convex Hull** dialog box displays.
2. Select the type of convex hull objects you want to create. You have two options:
   - **One output object for all input objects** button is the default setting. It creates one convex hull object around all of the selected objects.
   - **One output object for each input object** button creates a convex hull object around each selected object.
3. Click **OK**. Your map redisplay. The convex hull object(s) is displayed over the input objects. If you want to save this data, save the editable table. The convex hull object is selected when it displays.
4. To change the fill of the convex hull object, do one of the following:
   - Double-click it to display the **Region Object** dialog box. Click the **Style** icon at the bottom of the dialog box to display the **Region Style** dialog box. Make any changes you like and click **OK**.
• Select the convex hull object, if it is not already, and on the Options menu, click Region Style. The Region Style dialog box displays. Make the changes you want and click OK.

Editing Objects using the Set Target Model

With MapInfo Pro's advanced set target editing functionality, you can combine, split, erase map objects, and overlay nodes using a "Set Target - Apply Action" editing model. This model allows you to use objects from the same table or another table to create new objects. Sophisticated data aggregation methods allow you to calculate new data values that match the new objects.

The Set Target editing model in MapInfo Pro allows you to set a map object as the target for editing, then create a modifying object that will act as the cookie cutter that overlays the target and performs the editing action on the target. Set Target is located under the Objects menu.

Figure: Buffered retail locations showing market penetration

The Set Target model for editing map objects can be broadly described as a three-step process:

1. Set the object you want to edit as the target.
2. Choose and select another object or objects to act as the modifying object for the editing operation. You can also create a new object.
3. Perform the edit operation (combine, split, erase, erase outside, or overlay nodes).

A new object (or objects) is created in place of the target object.

The following table describes valid cutter/target objects for supported object processing operations:
You are not limited to working with map objects in the same layer. While the target objects must be in the Editable layer, you can choose the modifying objects from another layer.

The set target process is essentially the same whether you want to combine objects or create new objects by splitting objects or erasing portions of objects. Each operation is discussed individually in this chapter.

In addition to creating new map objects, the Set Target model allows you to control how the data associated with the target object will be transferred to the new object or objects. The next section discusses a number of data aggregation and disaggregation methods that give you tremendous flexibility with editing map objects.

- For specific instructions, see Setting a Map Object as a Target in the Help System.

**Understanding Object Size**

Many customers use the contouring process to create signal coverage maps, which requires large object sizes to create highly detailed coverage areas. To accommodate this need, we have increased the limit on number of nodes and the number of polygons or polylines that can be stored in objects.

Theoretically, the size of an object is only limited by the amount of memory in the system, but for practical reasons, a limit is imposed to work within limits of file size and most system memory limits. Currently, the object size limit is 1,073,741,823 bytes in memory. This limit is imposed so that an object of this size can be saved into a MAP file. All MapInfo Pro files have a theoretical limit of 2GB,
but due to header size and other required Map file contents, the actual size limit has to be somewhat less.

The node limit is 134,217,724 nodes in any object. This is the actual number of nodes that can fit into this 2GB memory size limit. It will be difficult to reach this node limit because memory allocation may prohibit it. It may not be possible to create a Map this size on a computer being used to accommodate an object this size; the program may throw an error when you try it.

Keep these notes in mind:

- For regions, the theoretical maximum number of polygons in a multi-polygon region or collection is 20,648,881 polygons that can fit into the size limit for all objects given above.
- For polyline objects, the theoretical maximum number of segments in a multi-segment polyline is 24,403,223 that can fit into the size limit for all objects given above.
- For multipoint objects, the theoretical maximum number of nodes is 134,217,724 that can fit into the size limit for all objects given above.

### Aggregating and Disaggregating Data

If you have data attached to map objects that will be edited, you can proportion the data for each field to match the new object(s). This is called data aggregation or disaggregation, depending on whether you are combining or splitting objects. MapInfo Pro calculates new data values for the object depending on how you specify the aggregation or disaggregation.

When combining objects, you can choose from several methods of data aggregation, including:

- **Sum** - adds the field values from the original objects to create a total for the field in the new object.
- **Average** - averages the field values from the original objects.
- **Weighted average** - gives more weight to one value over another when averaging. You can choose a numeric field in your table as the weighting factor or choose area (where the weighted average is based on the relative geographic area of the regions to be combined).
- **Value** - stores a specific value in the field of the new object.
- **No Change** - maintains the value of the target object in the new object.

When splitting or erasing portions of a map object, you can choose from:

- **Blank** - removes the original value of the target object.
- **Value** - maintains the original value of the target object.
- **Area proportion** - removes a portion of the original value based on the size of the new object.

With any of the editing operations under Set Target, you can elect not to bring over any data at all by choosing the **No Data** check box. You might do this, for instance, if you are only editing map objects for presentation purposes and do not need any data associated with the objects.

The **Data Aggregation** (or Disaggregation) dialog box displays after you have set the target, chosen the modifying object, and chosen an editing operation. In these dialog boxes, you must specify how you want the data calculated for each field. Once you are satisfied with the aggregation method, you can carry out the editing operation.
Clipping a Region of a Map

You can use Map > Set Clip Region to isolate a region of a map for display and/or printing. The clipped region may be a pre-defined map region, such as a state, or you can use a drawing tool to define a region. Use the Select tool to select a pre-defined region or a region that you defined. Thematic maps and seamless layers, labels, and points displayed on the map will be included in the clipped region.

• For specific instructions, see Clipping a Region of a Map and Setting Clip Region Options on the Fly in the Help System.

To toggle between the map and the clipped region, you may find it useful to use the Clip Region On/Off command.

Note: To clip a raster image, use an object created in the cosmetic layer, or an object from an existing vector layer.

• For specific instructions, see Saving a Clipped Region of a Map in the Help System.

Overview of Combining Map Objects

When you choose Combine, MapInfo Pro performs two operations:

1. MapInfo Pro geographically combines the selected objects. The new object represents the geographic union of the original objects. Therefore, if you select two adjacent region objects and choose Combine, MapInfo Pro combines the regions into a single object, and the border between the regions disappears.

2. MapInfo Pro performs data aggregation. Data aggregation is a process where MapInfo Pro calculates what the column values for the new object should be, based on sums or averages of the values of the original objects.

Perhaps you have a table of sales territories, and the table contains demographic information about the number of households per territory. Using the Combine command, you can combine two of the sales territories into one, large territory. In the same operation, MapInfo Pro also can calculate the number of households in the new territory by adding the values from each of the original territories.

Combining Objects with Set Target

The Combine operation can work in conjunction with the target feature of MapInfo Pro's Edit menu. Before you choose Combine, you can select one map object, and designate that object as the editing target. You can then select additional map objects and choose Combine to combine the selected objects with the target. If you set a target before you choose Combine, the Combine operation is more flexible, allowing you to combine objects from different tables.

You should assign a target object if one of the objects you are combining is more important than any of the other objects. For example, if you want to add small, unnamed islands to an existing "mainland" region, you should make the mainland region the target object. If you designate the
mainland region as the target, MapInfo Pro is able to retain the mainland region's name after the objects are combined.

Using Combine with Set Target allows the mainland region to retain its name after the objects are combined. You can only set one object as the target at a time when using Combine with Set Target. The modifying object can consist of more than one object.

Keep in mind that the Objects Combine command works with selected map objects. To apply the combine operation to an entire table, use Select All in the Query menu. To combine into groups rather than objects, or output to a separate table, use Combine Objects Using Column in the Table menu.

To combine map objects using Set Target:

1. Select one object in an editable layer to be the target object.
2. On the Objects menu, click Set Target. The object displays in a different style to indicate that it is the target object.
3. Select (or create and select) one or more map objects from any layer in the Map window. This is the modifying object.
4. On the Objects menu, click Combine. The Data Aggregation dialog box displays.
5. Choose the appropriate aggregation method (or No Data) for each field in the Destination list. See the definitions for these methods in Aggregating and Disaggregating Data.

   Note: To select more than one field in the Data Aggregation dialog box at a time, use these keystrokes:

   • Shift-click to apply the same method to consecutive fields
   • Ctrl-click for non-consecutive fields.

   When you have chosen the aggregation methods for each field, click OK.
6. Select one or more columns by clicking in the list at the top of the Data Aggregation dialog box.

7. Choose a data aggregation method: Blank, No Change, Value, Sum, Average, or Weighted Average. (Depending on whether you specified an editing target, some of these aggregation methods may not be available.) MapInfo Pro updates the column list in the upper half of the dialog box to show the chosen method.

   • For example, if you choose Average, you are telling MapInfo Pro to calculate the average of the column values of all the selected objects. This average is stored in the column of the new row.
   • Aggregation methods are described below.

8. Repeat steps 6 and 7 for all columns in your table and click OK.

   • To simplify this process, select multiple columns at one time by Shift-clicking and/or Ctrl-clicking in the list of columns. If you select multiple columns, and then choose an aggregation method, MapInfo Pro applies that method to all selected columns.

If your table contains a large number of columns, it can be time-consuming to specify aggregation methods for all columns. However, MapInfo Pro remembers your aggregation methods for the remainder of your session; thus, the next time you choose Combine, you do not need to respecify all aggregation options.

MapInfo Pro computes the new object and displays it as a single object. Use the Info tool to view the aggregated data (if any) associated with the object.

   • For more information, see Combining Points, Linear, and Closed Objects into a Single Object and Specifying Collection Object Attributes in the Help System.

Default Data Aggregation Methods

When the Data Aggregation dialog box first appears, MapInfo Pro automatically assigns a default aggregation method to every column in the table. For numeric columns (Integer, Small Integer, Float, or Decimal), MapInfo Pro assigns Sum as the default aggregation method. For all other types of columns, MapInfo Pro assigns Value as the default method.

You could simply choose OK, without changing any of the default aggregation methods. However, there is no guarantee that the default aggregation methods will produce meaningful results. By default, MapInfo Pro uses the Sum method for all numeric columns; however, depending on your data, it may not make sense to total all of your columns.

For example, perhaps your table contains demographic information, such as median income statistics. If two adjacent regions have different median income values ($30,000 and $35,000), and you combine the two regions, it does not make sense to total the two values; instead, you should choose Average or Weighted Average as the aggregation method.

Clearing a Target

If you do not want to edit an object after it has been set as the target, use Clear Target. The object will no longer be highlighted or marked for editing. An object will also be cleared as a target
automatically if it has been deleted or modified by Combine, Erase, Erase Outside, Split, Overlay Nodes, or if you have chosen a new target.

To clear a target, choose **Objects > Clear Target**.

### Combining Objects with Different Table Structures

If the tables you are combining have the same table structure, the process we have discussed in **Combining Objects with Set Target** works perfectly. When you are working with two tables with different table structures, the Data Disaggregation options are slightly different. When the input table has a different table structure from the output table, the **Data Aggregation** dialog box displays a **Column Name** field to accommodate the table structure.

![Data Aggregation Dialog Box](image)

**Column Name field**

The **Area Proportion** radio button is active if the selected field is numeric. Also the **Value** entry field is enabled when you select the **Value** radio button and the drop-down list contains "none".

### Splitting Objects

Splitting Objects allows you to divide the target object into smaller objects, using another object as a cutter. You can also combine objects into territories using redistricting. For more about the redistricting process, see **Redistricting-Grouping Map Objects into Districts** in the MapInfo Pro Help System. For example, you might use Split to separate a large territory into smaller units.

You can split either closed objects (regions, ellipses, rectangles, or rounded rectangles) or open objects (polylines, lines and arcs) using the Split command. You cannot use Split on points or text objects or to cut objects that are not in editable layers.
• For specific instructions, see Splitting Objects in the Help System.

Proportioning Associated Data after Using Split

After using Objects > Split, you may want to proportion (disaggregate) the associated data. Data disaggregation splits the data associated with a map object into smaller parts to match the new map objects. For instance, you may want to split a state into regions and have the data previously associated with the entire state proportioned for each new region. When you initiate the Split command, a Data Disaggregation dialog box appears that allows you to specify how the data will be proportioned.

Splitting Map Objects Using a Polyline

You can split multipoints and collections, as well as closed objects (regions, ellipses, rectangles, and rounded rectangles), and linear objects (polylines, lines and arcs) using the Polyline Split command.

As mentioned previously, splitting objects requires that the cutter be a closed object. With Split Using Polyline, the polyline cutter will first be transformed into a region suitable for the cutter operation. The region created will be displayed for acceptance. The polyline(s) used as the cutter must be contiguous and non-branching. In general, if the cutter polylines were to be combined, the result would be a one single section polyline. If the cutters are not polylines, and are not contiguous and non-branching, then an error will occur, and the operation will be cancelled.

Note: You cannot use Polyline Split on text objects or to cut objects that are not in editable layers.

• For specific instructions, see Splitting Map Objects Using a Polyline in the Help System.

Creating Territories by Combining Objects

Creating territories is one of the most common tasks performed with MapInfo Pro. Most people create territories by combining two or more smaller regions to create a larger one. Police departments combine postal code boundaries to create precinct boundaries. Sales managers combine county boundaries or state boundaries to create sales territories. Political analysts combine census tract boundaries to create voting districts.

Remember, when you are combining regions, you are also combining the data associated with the regions. If you combine regions without somehow aggregating the data associated with the regions, that data will be lost. For some applications, you might not want to save your data. For example, you are merging census tract boundaries to create school districts. The census tract data is of no interest to you; you merely want the boundaries. There is no reason to aggregate the data, but you would want to apportion the demographic data. For most tasks, you'll want to save the data associated with the regions.

MapInfo Pro gives you three methods for combining regions.

1. The first method, Combine, works with objects that are selected.
2. The second method, Combine Objects Using Column, is used to combine objects into groups based on a specified column.
3. The third method, Redistricting, is covered in Redistricting-Grouping Map Objects into Districts. Most frequently, the Combine Regions options are your easiest and quickest options for combining regions and creating territories.

Combining Selected Objects

When you choose to combine objects, MapInfo Pro performs two operations:

- MapInfo Pro geographically combines the selected objects. The new object represents the geographical union of the original objects and the border between the regions disappears.
- MapInfo Pro performs data aggregation. As described earlier in this chapter, data aggregation is a process where MapInfo Pro calculates what the column values for the new object should be, based on sums or averages of the original objects.

Your setup of the Layer Control window depends on whether you want to copy the result object to another layer (and, thus, save the original objects) or combine the objects in the original layer (and, thus, lose the original objects).

If you want to copy the result object, make the region's layer Selectable and another layer Editable. Specify a target object, then select the objects using any selection method and on the Objects menu, click Combine. This will display the Data Aggregation dialog box where you tell MapInfo Pro how to combine the data. Fill in this dialog box and click OK to combine the objects to combine the objects' data. This method was discussed earlier in this chapter.

If you want to combine objects in the original layer, make sure that the layer is editable, select the objects in the layer, and on the Objects menu, click Combine. Do not set a target. The Data Aggregation dialog box displays. After the operation is complete, a new object will be added to the layer, and the original objects will be deleted.

Combining Objects Using Column

Combine Objects Using Column allows you to modify geographic data to create new map objects that contain data about the group. This feature is similar to redistricting in that it groups objects together, but goes beyond redistricting to combine a copy of the relevant objects while leaving the original objects untouched.

To access Combine Objects Using Column:

1. On the Table menu, click Combine Objects Using Column. For example, you have a layer of states. You want to combine the state boundaries to create sales territories. The data record associated with each state looks like this:
<table>
<thead>
<tr>
<th>SALES_REP</th>
<th>STATE</th>
<th>CUSTOMERS</th>
<th>AVG_SALES</th>
</tr>
</thead>
<tbody>
<tr>
<td>Benita</td>
<td>West Virginia</td>
<td>1782</td>
<td>24231.4</td>
</tr>
<tr>
<td>Benita</td>
<td>Ohio</td>
<td>121</td>
<td>33265.0</td>
</tr>
</tbody>
</table>

- **SALES_REP**: Sales representative assigned to that state
- **CUSTOMERS**: Number of customers per state
- **AVG_SALES**: Average spent per customer

You would like to aggregate the data in the following manner:

- **SALES_REP**: Combine all records that list Benita as the sales representative
- **CUSTOMERS**: Sum up the number of customers in the sales territory
- **AVG_SALES**: Average the amount spent per customer in the sales territory

When performing a Combine Objects Using Column operation, you must specify which column contains the grouping information. In the preceding example, the grouping information is located in the SALES_REP column. We want to combine all of Benita's individual territories into one large territory.

2. Choose the appropriate column from the Group Objects by Column popup. In our example, you would choose the SALES_REP column from the Group Objects By Column popup. MapInfo Pro combines all records that have common data in the column. In other words, MapInfo Pro combines all records that have the same sales representative.

3. Specify the table and the grouping column.

   - If you chose `<New>` from the Store results in table drop-down list to create a new table for the combined objects, a series of dialog boxes prompt you to create the new table.
   - If you specified an existing table, you need to specify how to combine the data. To aggregate your data, click **Next** to display the **Data Aggregation** dialog box.
4. Once you have completed both dialog boxes, click **OK**. MapInfo Pro combines the records based on the column specified in the **Group Objects By Column** list. MapInfo Pro also aggregates the data and combines any objects associated with the records.

5. For specific instructions, see *Combining Object Using Column* in the **Help System**.

### Creating a Voronoi Polygon

The Voronoi polygon is a partition of space into cells. Voronoi takes points and produces regions (cells) as output where each cell contains exactly one point. Each cell is an area in which the contained points are closer to the enclosed site than to any others. Use Voronoi to generate these polygons from a designated set of points. It is useful for dividing areas of responsibilities for field offices or possibly postal zones. It ultimately gives you the areas that are closest to your point of interest. You can create a Voronoi polygon within the same layer, or select points from one layer and place the Voronoi polygon in another layer.

- For specific instructions and additional related topics, see *Creating a Voronoi Polygon* in the **Help System**.

### Grouping Objects using Multipoint and Collection Object Types

The Multipoint and Collection object types allow you to group multiple objects into a single object. One way to create multipoints and collections is by using the Combine command (on the **Objects** menu, click **Combine**). These object types aid in the translation and live access of other GIS data formats, such as ArcView Shape Files, and are more compatible with GIS standards. This is particularly useful for sharing maps with others using different software.
A Multipoint object consists of a number of points that have been grouped into a single object. The Multipoint object displays in a Browser window as a single record, and all the points within the object have the same symbol. One method you can use to create a multipoint object is to select a group of point objects and combine them.

A Collection object consists of multipoint objects, zero or one polyline objects, and zero or one region objects that have been grouped into a single object.

MapInfo Pro automatically converts homogeneous Collection objects to a more specific type, for example, a Collection object that contains only polylines is automatically converted to a multi-polyline object.

• For specific instructions and additional related topics, see Grouping Objects using Multipoint and Collection Object Types in the Help System.

Creating and Manipulating Objects

The operations in this section do not make use of a target object to perform analysis or data aggregation. These tasks use selections to create new objects so that you can perform further mapping operations on those objects. The results of the operation are placed in the editable layer. The original objects remain unchanged.

See the Help System for related topics including:

• Enclosing Objects
• Checking Regions
• Cleaning Objects
• Snapping Nodes and Thinning Objects
• Disaggregating Objects
• Erasing Objects
• Adding Nodes to an Object
• Displaying and Selecting an Object's Nodes
• Moving an Object's Nodes
• Copying and Pasting an Object's Nodes
• Deleting an Object's Nodes
• Checking Regions/Tables for Incorrect Data
Most of us do not get to make maps solely for our own use. We use the maps we create in MapInfo Pro to create presentations, to publish them on the web, or to include as part of another document. This chapter will help you create presentation quality maps and prepare you for printing and exporting your work.

In this section

- Changing a Map’s Style 352
- Labeling Your Map 357
- Adding an Adornment to the Map 370
- Working with Layouts 371
- Working with the Classic Layout Window 389
- Creating a Legend for your Map 402
- Printing and Exporting Your Results 407
Changing a Map's Style

Changing the look of the map is an important part of making it more effective. In this section, we review how to change the way your map looks one piece at a time. For a more comprehensive change in your map's appearance, see *Create Thematic Maps* in the Help System.

Changing a Region's Style

To change the style of a region:

1. Do one of the following:
   - To change the style of one region, click the region and on the **Options** menu, click **Region Style** from the main menu.
   - To change the style of all regions in the same layer, choose **Map > Layer Control** and click the layer's Style Override swatch.

   Using either method the **Region Style** dialog box displays.

   ![Region Style Dialog Box](image)

   *This dialog box includes a Preview button when launched from the Layer Control.*
2. Make the region changes you want to see in your map window in this dialog box and click OK to save them.

- **Fill** - These are the fill options you have in the *Region Style* dialog box.
- **Pattern** - Choose a palette for patterns. If you do not want to use a pattern, choose the letter \textit{N}, for none; the foreground and background color are disabled. If you choose the solid black pattern, the background color is disabled.
- **Color** - Choose a color for the object(s)' foreground. The Sample box displays the pattern using the foreground color you chose. The foreground color is applied to the part of the pattern that displays as black. Therefore, to make the object a solid color, choose the solid black pattern in the Fill Pattern palette and a color from the Foreground Color palette. The color you chose displays in the Sample box as a solid-colored region.
- **BackgroundColor** - Select the check box to display a background color; clear for a "transparent" background. Choose a color for the object's background. The background color is applied to the part of the pattern that displays as white. Background color is grayed if you chose the solid pattern.
- **Border** - These are the border options you have in the *Region Style* dialog box.
- **Style** - Choose the border line style.
- **Color** - Choose the border line color.
- **Width** - Choose the border line width. In the \textit{Pixels} field, enter a number from 1-7, each number represents a line width in pixels. In the \textit{Points} field, select or enter a point size.
- **Sample** - Displays the sample of the pattern and color selections you have made.
- For more information, see *Creating Custom Colors* in the \textit{Help System}.

### Changing a Line's Style

To change the style of a line:

1. Do one of the following to display the *Line Style* dialog box:
   - To change the style of one line, click the line and on the \textit{Options} menu, click \textit{Line Style} from the \textit{Main} menu.
   - To change the style of all lines in the same layer, choose \textit{Map} > \textit{Layer Control} and click the layer's Style Override swatch.
This dialog box includes a Preview button when launched from the Layer Control.

2. Make the line style changes you want to see in your map window in this dialog box and click OK to save them.
   
   - **Style** - Select the new line style from the drop-down list.
   - **Color** - Choose a color for the line from this drop-down list. The **Sample** box displays the pattern using the color and line style you select.
   - **Width (in Pixels and Points)** - Choose the line width from one of these drop-down lists. In the Pixels field, select a width of the line in pixels. In the Points field, select a point size from the drop-down list, or enter a point size.
   - **Interleaved** - If you select a line style that uses multiple passes to create it, MapInfo Pro enables the **Interleaved** check box. Keep in mind these notes:
     - The Interleaved option is not enabled for solid lines
     - The Interleaved option is not activated for borders
     - The Interleaved option is not appropriate for all multiple pass lines

**Changing a Symbol's Style**

To change the style of a symbol:

1. Do one of the following:
   
   - To change the style of one symbol, click the symbol and on the **Options** menu, click **Symbol Style** from the main menu.
   - To change the style of all symbols in the same layer, choose **Map > Layer Control** and click the layer’s Style Override swatch.

   Using either method the **Symbol Style** dialog box displays.
This dialog box includes a Preview button when launched from the Layer Control.

2. Complete your selections and entries in this dialog box and click **OK**.
   
   • **Font** - Choose a font from the drop-down list. In addition to the symbol sets, the list displays any fonts installed on Windows. The Custom Symbols category lists those bitmaps you have created and saved to the CUSTSYMB directory.
   
   • **Size** - Choose a size or type a different point size. The maximum size is 240 points.
   
   • **Symbol** - Choose a symbol type from the symbol palette.
   
   • **Color** - Choose a color from this list for the symbol.
   
   • **Reload** - Click this button when you have added your own custom symbols to update the list. If you restarted MapInfo Pro since adding the new custom symbols you do not need to select the **Reload** button.
   
   • **Full View** - Click this button to display large images in a separate window.
   
   • **Rotation Angle** - Specify number of degrees the symbol should be rotated; 0-360.
   
   • **Background** - In this box, you can specify a background. Select one of these:
     
     - **None**: Click this option to display no background.
     - **Halo**: Click this option to display the symbol with a white border outline.
     - **Border**: Click this option to display the symbol with a black border outline.
   
   • **Effects** - In this box, you can specify special effects for the symbol. Not all of these options display all the time. You can select one or more of these:
     
     - **Bold**: Click this check box to draw the symbol in boldface.
Drop Shadow: Click this check box to draw a drop shadow under the symbol.

Show Background: Click this check box to display the custom bitmap symbol with the background with which it was created.

Apply Color: Click this check box to replace all non-white bitmap pixels with the color you select from the Color palette.

Display at Actual Size: Click this check box to display the image at the actual size.

• Sample - When you select a symbol style, it displays in this box to show you a sample of the symbol using the designated selections.

Changing the Text Style

To change the style of text:

1. Do one of the following:
   • To change the style of one text entry, click the text and on the Options menu, click Text Style from the main menu.
   • To change the style of all text entries in the same layer, choose Map > Layer Control and double-click the layer. In the Layer Properties dialog box, click the Font button on the Label Display tab.

   The Text Style dialog box opens.

2. Make your selections and entries in this dialog box and click OK.
   • Font - Choose a font from the Font drop-down list.
   • Size - Choose a point size from the Point Size drop-down list.
   • Text Color - Display the color palette; choose a text color.
• **Background** - In this box, you can specify background options for the selected text. You can select only one of these options:
  
  **None** - Set no specific background for the selected text.
  **Halo** - Display the text outlined in a designated color.
  **Box** - Surround the text with a box in a designated color.
  **Color** - Display the color palette; select a color to halo or box the text.

• **Effects** - In this box, you can specify special effects for the selected text. Not all of these options display all the time. You can select one or more of these:
  
  **Bold** - Select this check box to display text in boldface.
  **Italic** - Select this check box to display text in italic.
  **Underline** - Select this check box to display text underlined.
  **All Caps** - Select this check box to display text in all upper case letters.
  **Shadow** - Select this check box to display a grey "drop" shadow under the text.
  **Expanded** - Select this check box to insert double spaces between each letter in the text.

• **Sample** - The results of the options you choose show in this box.

**3. Click Preview to display your settings on the map, and then click OK to apply them.**

**Labeling Your Map**

The labeling features in MapInfo Pro make it easier for you to display, edit, and save labels. You can specify whether to display labels automatically when you display the map or display the map without labels. You can edit automatic labels, use the customizing options to make your labels unique, and create individual labels with the Label tool. Haloing and positioning options enable you to get the precise look you want for your labels.

**About Labeling**

The design of the label feature in MapInfo Pro is important for understanding how to create and manipulate labels on your map. Most important among the design elements are the following:

• Labels are attributes of geographic objects in the map layer. The text is based on data associated with that object.
• Labels are always selectable and editable.
• Labels are saved to a workspace.
A label is a short description of one geographic object from a map layer, so a street label states the name of that street for example. The label's text comes from the same table that the layer is based on.

A label is located at or near its geographic object. You can choose a preset position in the Layer Properties dialog box to place point labels, such as on top of or to the right of points.

As attributes, labels are dynamically connected to their map objects. If the layer is closed or is made invisible, the labels no longer display. If the data or geographic information changes, the labels change. If you create an expression for your labels and change the expression, the current labels are dynamically replaced with new ones.

Labels are always selectable and editable, so you do not have to make the map layer editable or selectable to work with them. And, since labels are not Cosmetic objects, you do not have to remember to make the Cosmetic layer selectable or editable to label your map. They are already part of the map layer.

Saving labels is easy. Because labels are attributes of the map object, you do not have to remember to save them to a separate table. Any label edits you have pending, or changes you have made to the Layer Properties settings, are easily saved to a workspace. Because labels are saved in a workspace, you can always create and edit whatever custom label settings you want, and you can always save those labels—even if the tables you are using are read-only.

You can label your map automatically through Layer Control's Layer Properties dialog box. You customize how labels display from the Layer Control window (make the Map window active and then select Map > Layer Control) or directly on the map:

- To see labels displayed for your entire map layer, click the Automatic Labels icon in Layer Control window.
- To make a change that applies to all the automatic labels in your layer, double-click the layer name in the Layer Control window and make your changes in the Layer Properties dialog box. All automatic labels are updated to use the settings that you choose: for example, if you change the label font so that it is Italic, all automatic labels for that layer refresh to use Italic.
- To customize a single label, double-click that label on the map. For example, you might want most of your labels to draw in 9-point Arial, but you might want one particular label to display in 18-point text to show the importance of that geographic feature. Double-click the label that you want to customize on the map, and in the Label Style dialog box customize the label.
- When you edit a label, the label becomes less dynamic. For example, if you double-click a label to change its font, then that label has its own font setting. If you then assign a different label font to your layer, the new label font will not apply to the label that you edited, because the edited label remembers that it has a custom font. You can reset all edited labels by choosing Map > Clear Custom Labels.
- As an alternative to turning on automatic labels, you can label geographic features by hand one at a time by selecting the Label tool from the toolbar and then clicking the geographic feature that you want to label.

Note: The Label tool only draws labels if the layer that you are clicking on is marked Selectable in Layer Control window.
To control whether you can select labels when you click on the map, click **Selectable Labels** in the Layer Control window. By default, labels are selectable. You might make labels unselectable if you find that you are accidentally selecting labels on the map when you were trying to select points or lines. This is a per map setting, so each Map window has its own setting. Each map’s Selectable Labels setting is preserved when you save a workspace.

**Choosing the Label Content**

When you label your map automatically, or interactively using the Label tool, the content of the labels is determined by the data associated with the geographic object. You can obtain the labels from the columns in your table, or the derived result of an expression using the column information. If the column information or an expression does not suit your needs, you can edit the label content or type in new text. See **Editing Labels** for more information.

Text you create yourself using the Text tool is a text object and behaves like other objects you draw on your map such as squares and circles. Although labels and text objects behave somewhat differently, text objects are still useful for additional map annotation such as titles. For information on text objects, see **Working with Text on the Map**.

The Autolabeler tool, available from the Tool Manager (on the **Tools** menu, click **Tool Manager**), creates labels as text objects in the Cosmetic Layer. This application may be useful if you need to create labels that can be transferred to a permanent table. In addition, you can create text objects and convert labels into text objects using another tool from the Tool Manager set, the Labeler tool, which is explained later in this chapter.

**Labeling with a Column**

The content of labels is controlled in the Label with drop-down list in the **Layer Properties** dialog box. You can label an object with any column from its associated table. For example, you can label the STATES table with the state name, abbreviation, 1990 population, or any other field in the STATES table. Simply choose a column from the list, and the objects in that layer will be labeled with the information contained in that column.

**Note:** The **Layer Properties** dialog box only lets you set a label with expression on one layer at a time. After selecting multiple layers in the **Layer list**, the **Label with list** **Layer Properties** dialog box disables and shows a message that says **Mixed**.

**Labeling with Expressions**

You can also label objects with an expression. Select **Expression** from the drop-down list in the **Label Options** dialog box. Create the expression in the **Expression** dialog box. You can type the expression directly or use the drop-down lists to create it. For example, you want to label the countries of Africa with their name and population density on two lines. Your table contains the country names and population figures for each country. To figure the population density, divide population by each country’s area. You can let MapInfo Pro calculate the area of each country using the Area function in the **Expression** dialog box. To create the expression, double-click the Africa layer in the Layer
Control window and select the **Label Display** tab. Select **Expression** from the **Label with** drop-down list. The **Expression** dialog box displays. Using the drop-down lists, create the following expression:

```
Country + Chr$(13) + POPULATION / Area(Object, "sq mi")
```

The **Chr$(13)** function adds a carriage return to the first line. Using the Label tool, click a country. MapInfo Pro labels it with the result of the expression.

- For instructions and examples of this topic, see *Creating Labels using Expressions* in the **Help System**.

### Saving Labels to a Workspace

Both automatic and interactive labels are saved as part of a workspace.

To save your objects:

1. Choose **File > Save Workspace.** The **Save Workspace** dialog box displays. The **Save Workspace** dialog box allows you to save information about the tables and windows used in your current session.
2. Select the drive, folder, and file where you want the workspace saved.
3. Type a name for your workspace.
4. Click **Save**.

### Packing a Table with Customized Labels

Note that packing a table that contains customized labels can corrupt the labels. For example, you delete one or more rows from your table and save the table. Then you create a map with customized labels and save the labels to a workspace. You pack the table to purge the deleted rows. Since the Pack command closes the Map window, you'll need to reload the workspace. When you do so, your labels are corrupted.

This problem occurs most often when the deleted rows are located near the top of the Browser. To avoid the problem, pack the table before you create the labels.

### Using AutoLabeling

There are two types of labels, automatic labels and labels you place by clicking with the Label tool. Automatic labels are labels that MapInfo Pro generates automatically, without you having to click objects on the map. When you turn on automatic labels for a layer, MapInfo Pro tries to label every object in that map layer. However, depending on your font size, your map window, and your map data, you may find that not all items in the layer label automatically.

There are settings in the **Layer Properties** dialog box that let you set conditions for displaying labels, in what style they will display, and in what position for all the objects in the layer.

### Controlling Label Display

The Auto Label attribute in Layer Control is off by default for all map layers.
To activate labels for a layer:

- Select one or more layers in the Layer Control window and then click the **Automatic Labels** icon. The map redraws with labels for your layer selections.

You can easily turn the display of automatic labels on or off in Layer Control window by clicking **Automatic Labels**. Any settings you have specified in the **Layer Properties** dialog box on the Label Display tab are deactivated. You can also click **Off** in the Visibility group on the Labeling Rules tab. Either way, when you go back to your map, the labels no longer display. These settings also apply to labels you have edited.

**Making Changes to Layer Labels**

To make changes to the labels of a selected layer:

1. Double-click a layer in the Layer Control window. The **Layer Properties** dialog box opens.
2. Click the **Label Display** and **Labeling Rules** tabs to select the appropriate options for your new labels.
   
   For a description of the options available, see *About Customizing Layer Properties*.

3. Click **OK** to save your changes.

**About Customizing Layer Properties**

You can customize display properties for a layer by double-clicking on a layer name in the Layer Control window. This opens the **Layer Properties** dialog box where you can set properties for how to display the layer and its labels.

You can customize properties for multiple layers at the same time by selecting the layers (press **Ctrl** while clicking on layer names) and then right-clicking and selecting **Layer Properties** from the pop-up menu.

You can easily turn automatic labels on or off by clicking the **Automatic Labels** icon on the Layer Control window. Even after you have turned off automatic labels for a layer, the layer may still have some labels if any of that layer's labels have been edited. To turn off all labels for your layer, including edited labels, click the **Off** radio button in the **Labeling Rules** tab of the **Layer Properties** dialog box.

When a check box is filled in (not blank and without a check mark) it means that there are different properties set for that option among the layers you have selected. Selecting the check box applies it to all of the layers in your selection.
Label Display tab

Options on the Label Display tab include:

- **Label with** - Choose the column that you want reflected in the label. You can only set a Label with expression on a single layer. After selecting multiple layers in the Layer list, the Label with list disables and shows a message that says Mixed.

- **Expression** - Click to open the Expression dialog box and create an expression query of your data.

- **Allow abbreviated labels** - Select this check box to use an alternate abbreviation field expression for labels that cannot be drawn, because they overlap other labels or do not fit within a region. From drop-down list, select the table field (column) that contains the abbreviations.

- **Font** - Click this button to display the Text Style dialog box, to set all properties of the labeling font.

- **Size** - Sets the font size of the labeling font.

- **Color** - Sets the foreground color of the labeling font.

- **Translucency** - Use this slider bar to indicate the translucency of the selected object of the labels. Translucency can be set between 0 to 100%. A 0% translucency is completely opaque (or cannot be seen through). A 100% translucency is completely transparent (or completely invisible).

- **Label Lines** - Select a line type, or no line type, to attach the label to the anchor point.

  - **None** - Do not display a line with the label.
  
  - **Simple** - Create a callout by using a simple line that connects the label to the anchor point. Label lines display after you move the label from where it was originally created.
  
  - **Arrow** - Create a callout by using an arrow and line that connects the label to anchor point. Label lines display after you move the label from where it was originally created.
**Labeling Rules tab**

Options on the Labeling Rules tab include:

- **Label Position buttons** - Use the label position (Anchor Point) buttons and the label offset to specify the label's placement. The anchor point is the label's position relative to the map object.

Click one of the buttons to select an anchor point. The default anchor point varies with the type of map object you are labeling: Regions default to Center, Lines default to Above Center, and Points default to Right.

<table>
<thead>
<tr>
<th>Anchor Point Button</th>
<th>Position</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Upper Left</td>
<td>Places the label above and to the left of the anchor point.</td>
</tr>
<tr>
<td></td>
<td>Upper Center</td>
<td>Centers the label directly above the anchor point.</td>
</tr>
<tr>
<td></td>
<td>Upper Right</td>
<td>Places the label above and to the right of the anchor point.</td>
</tr>
<tr>
<td></td>
<td>Left</td>
<td>Places the label directly to the left of the anchor point.</td>
</tr>
<tr>
<td></td>
<td>Center</td>
<td>Centers the label at the anchor point.</td>
</tr>
<tr>
<td></td>
<td>Right</td>
<td>Places the label directly to the right of the anchor point.</td>
</tr>
<tr>
<td></td>
<td>Lower Left</td>
<td>Places the label below and to the left of the anchor point.</td>
</tr>
<tr>
<td></td>
<td>Lower Center</td>
<td>Centers the label directly below the anchor point.</td>
</tr>
</tbody>
</table>
The anchor point is an ongoing attribute of the label. For example, if you anchor a point object's label at Center Left and you increase the label's font size, the text will grow to the left. This way, the text can never overwrite the point.

- **Label offset** - Designate number of points (a measurement of text size) label should be placed from the anchor point.

  **Note:** The label's anchor point and offset move a label with respect to its current location and the current zoom. Whenever you want to make minor adjustments to the label's position, you should use these two options.

Lines: These options display when the layer has line objects.

- **Horizontal** - Select to display all labels horizontally.
- **Rotated** - Select to run the label text parallel to the line segment. Using this option, a horizontal polyline would display parallel horizontal labels and a vertical polyline would display vertical street labels.
- **Curved** - Select to display the label along the curve of the polyline or arc segment.
- **Auto position along line** - Select to find the most suitable location along a polyline, because a polyline bends too sharply at the location where the label is to be placed. MapInfo Pro draws the label at one of the best three positions that it finds.
- **Allow rotated as fallback** - Select to have curved labels that cannot be drawn fall back to being normal labels that are rotated.
- **Overhang** - Use this slider bar to indicate the amount a label may extend beyond the end of a line (such as a street) The default amount is 40%.

Regions: These options display when the layer has region objects.

- **Label at centroid** - Place labels relative to region centroids (center points).
- **Auto position label within region** - If you select this, MapInfo Pro ignores the **Label Position** setting for region labels and instead calculates each region's ideal label position based on the shape of that region. The **Label Position** setting still affects point or line labels in the same layer, and MapInfo Pro places these labels around their centroid.
- **Allow font reduction for better fit** - Lets you specify a percent as the limit to which label font sizes will reduce to make labels fit within region boundaries. Labels will not reduce past this value. You can use the slider or select the value from the drop-down list. The default value is 50%.
- **Maximum # of font sizes** - Limits the number of font sizes to use when resizing labels for a region layer. The default value is four (4).
• **Confine labels to region boundary** - Select to display only the labels that fit within their region boundaries.

• **Place outside if necessary (callout)** - Select to display labels that do not fit within their region boundaries by positioning them outside of their region with a callout (a line connecting the label to its region). This option is only available after selecting the **Confine labels to region boundary** check box.

**Label Fit and Density:**

• **Discard Label** - Select to remove labels that overlap each other.

• **Try other positions** - Select to avoid overlapping labels and display more label options. When labels would overlap, MapInfo Pro tries to place conflicting labels in other positions around the object the label is describing.

• **Allow overlapping text** - Select to allow labels to be drawn on top of each other. Some labels do not display because they overlap labels that are have been given higher priority on the map.

• **Allow duplicate text** - Check to allow duplicate labels for different objects to display, for example, Portland, OR and Portland, ME. This option is also used with street maps to label street segments individually.

• **Label partial objects** - Check to label polylines and objects whose centroids are not visible in the Map window. This feature only applies to autolabels. Also, when you customize a label, the location of the label will not change.

**Label Visibility:**

• **Visibility On** - Check to allow display of labels.

• **Visibility Off** - Check to suppress all labels for this layer including custom and/or edited labels.

• **Within zoom range** - Select to display labels within a specified zoom range, much the same way that you display map layers within a certain zoom range. When labeling a dense table of streets such as a StreetPro Display layer, only a few of the streets will be labeled when the map is zoomed out.

• When a layer is outside of its zoom range, the layer name is dimmed and there is an asterisk (*) beside the Visible On/Off check box. If the zoom range is set to **Within zoom range** and the map's zoom level is out of the label's min/max zoom range, then the Automatic Labels do not display in the map.

• **Min Zoom** - Specify the minimum distance at which this layer's labels are visible.

• **Max Zoom** - Specify the maximum distance at which this layer's labels are visible.

**Creating Callouts**

When you are labeling Region objects, the **Layer Properties** dialog provides you with options for automatically generating callout labels. You can also create callout labels manually, by dragging labels away from their geographic features.

For additional information about using callouts, see **Use Callouts for Labels that do not fit within Region Boundaries** in the MapInfo Pro Help System.

To create callouts:
1. In the Layer Control window, double-click the layer to open the Layer Properties dialog box.
2. On the Label Display tab, set the Label Lines option to Simple (for plain callout lines) or Arrow (for callout lines that have an arrowhead at the end).
3. Click OK.
4. Create labels for your map layer. You can either create automatic labels, by clicking the Automatic Labels icon in the layer list, or place labels by hand by selecting the Label tool and then clicking on objects in your map layer.
5. On the Main toolbar, click the Select tool.
6. In the Map window, select a label and drag it away from its location. A callout line connects the label to the label's original location.

**Note:** Callout lines cannot be created with curved line labels, because curved line labels automatically snap back into position next to their lines.

## Label Styles

The Text Style dialog box gives you a number of choices for label and text object styles. You can also change the styles of multiple selected labels at a time.

To make style changes for all the labels, click the Font button in the Layer Properties dialog box to display the Text Style dialog box.

To change the styles of a selected label or labels, select the label(s) and either on the Options menu, click Text Style, or click the Text Style button in the Drawing toolbar to display the Text Style dialog box. If you change the styles of multiple labels at once, hold down the Shift key as you select each label.

Make the style changes you want. When you return to the map, the selected labels display with the style changes you specified. The available styles are explained in the next table.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bold</td>
<td>Uses bold text to create the label.</td>
</tr>
<tr>
<td>Italic</td>
<td>Uses italic text to create the label.</td>
</tr>
<tr>
<td>Underline</td>
<td>Places a line underneath the text.</td>
</tr>
<tr>
<td>All Caps</td>
<td>TEXT DISPLAYS IN ALL CAPITAL LETTERS.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Shadow</td>
<td>Creates a shadow behind the text. (not shown)</td>
</tr>
<tr>
<td>Expanded</td>
<td>A space is placed between each character in the label or text object.</td>
</tr>
</tbody>
</table>

There are also three background options.

- Click **None** to have no background.
- Choose **Halo** to create a halo effect around the text. This puts the text into relief from whatever it covers (for example, part of a region, or a street, etc.).
- Click **Box** to create a background box behind the text.

When you choose either the **Box** or **Halo** backgrounds, the **Color** list is activated. Click it to display a palette of colors for the halo or the background. The color you choose corresponds to the button that is currently activated. The color displays in the box and in the Sample. Click **OK** to accept a color.

To quickly change the size and color of labels for a layer, double-click on the layer name in the Layer Control window. Under the Label Display tab in the **Layer Properties** dialog box, make your selections from the **Size** and **Color** lists.

**Labeling Interactively**

Although you will probably do most of your labeling automatically, you will need interactive labeling to edit and create individual labels.

**Editing Labels**

It is very easy to edit individual labels, either those you have displayed automatically or those you have created interactively with the Label tool. Using the Select tool, double-click the label. The **Label Style** dialog box displays. The changes you make in **Label Style** dialog box apply only to the selected label. Changes you want to apply to all the labels must be done through Label Display tab and Labeling Rules tab in the **Layer Properties** dialog box (choose Map > **Layer Control** and double-click on a layer in the list).
The **Label Style** dialog box allows you to make changes to the text, position, and angle of the labels. You can also make changes to callouts, add, or delete them.

To change the label content, simply type the new label text into the **Text** box. The other controls in this dialog box work the same way as in the **Layer Properties** dialog box.

Moving a selected label is the same as moving other objects; simply drag them with the mouse. If you move a label that has a callout, the line will reappear automatically after you move the label.

You can also rotate the label manually about its anchor point. When you select the label, use the rotation edit handle that appears to the lower right of the label.

- For more information, see *Moving Labels You Created Manually* in the Help System.

### Using Text Objects as Labels

While labels in MapInfo Pro are attributes of the map layer, text objects look like labels but behave like other annotations you draw on the map. You must make one of your layers editable before you can create Text objects. You can make the Cosmetic layer editable, create text objects in the Cosmetic layer, and then later save those text objects to a permanent table if you need to.

The Labeler tool in the MapInfo Pro Tool Manager helps you use text objects to perform several common labeling tasks:

- Convert labels into text objects, so that they can be saved in a permanent table.
- Create labels for only the currently-selected objects.
- Draw text objects one at a time using the **Text Label** button. This allows you to create multiple annotations for a single map feature, which is something you cannot do using labels.

### Creating Labels with the Labeler Tool
To use the Labeler tool, choose **Tools > Tool Manager**, and then locate **Labeler Tool** in the list of available tools. Select the **Loaded** checkbox and/or the **Autoload** checkbox, and then click **OK**. Options for the Labeler tool now appear on the Tools menu and on the Tools toolbar.

Use the Labeler tool to create individual labels. First, make sure that the layer containing the objects you want to label is selectable. Click the **Labeler** tool to activate it, and click a map object. MapInfo Pro labels the object with the column or expression you specified for that layer in the Layer Control window. Double-click on the layer to display the **Layer Properties** dialog and make changes on the Label Display tab and Labeling Rules tab. Remember that InfoTips are active for the Labeler tool, so you can view the object's label before you actually label the object.

For more information about the Labeler tool, see the **Tools** section of the **Help System**.

### Saving Labels

Whenever you manually edit automatic labels (including deleting using the **Edit** menu, and click **Clear** or press the **Delete** key), change the settings on individual automatic labels, or create labels with the Label tool, you will need to save your map to a workspace to have them display in your next session.

For example, label settings are deactivated by default. Click the **Automatic Labels** icon in Layer Control to display automatic labels on your map and do not save the change when you close the table. The next time you display your map, the labels do not display because the settings go back to the defaults. As with the other Layer Control options, label settings are temporary unless you save a workspace.

Manually edited labels and labels created with the Label tool behave differently. If you close a window or a table and you have label edits pending, MapInfo Pro will specifically prompt you to save the session to a workspace.

This also applies to labels you have deleted using the **Edit** menu, click **Clear** or press the **Delete** key. You may not have any labels visible on your map, but because deleting a label is an editing operation, MapInfo Pro will ask you if you want to save the edits to a workspace.

- Click **Save** to save your edited labels to a Workspace file.
- Click **Discard** if you do not want to save any edited labels. The window-close or table-close operation will proceed.
- Click **Cancel** if you do not want to proceed with the Close operation. The table or window will not close, and your Map window will keep any edited labels.

For more information, see **Removing Labels** in the **Help System**.
Adding an Adornment to the Map

MapInfo Pro provides map adornments, such as scale bar, to place and anchor in a Map or classic Layout window. The scale or geographic position of the map does not affect the position or size of an adornment, so it remains stationary when zooming or panning the map. However, the properties and visual representation of an adornment, such as a map scale, may change as the map projection or scale changes.

Adornments are drawn as the topmost elements on a map, on top of any labels and on top of the cosmetic layer. Adornments may display with a border and a background. You can move adornments anywhere on the map by clicking and dragging them with the mouse cursor.

You can pre-set adornment properties, such as the default position and style, in the Map Preferences dialog box under the Adornments tab (on the Options menu, point to Preferences and then click Map Window).

Adding a Scale Bar to Represent Map Scale

The map scale bar shows the scale of map representation relative to the portion of the Earth’s surface it displays. The scale bar also has the option to show the cartographic scale of the map.

About Map Scale

A map represents a portion of the Earth’s surface, so each map has a scale that indicates the relationship between a distance on the map and the distance on the ground. The scale is a ratio or representative fraction (RF). It can be expressed as 1/100,000 or 1:100,000. In this example, one centimeter on the map equals 100,000 centimeters (1 kilometer) on the earth. It also means that one inch on the map is equal to 100,000 inches on the land (8,333 feet, 4 inches or about 1.6 miles). Or even 1 paperclip on the map is equal to 100,000 paperclips on the ground. Common RFs include 1:63,360 (1 inch to 1 mile) and 1:1,000,000 (1 cm to 10 km).

In MapInfo Pro, a map scale that does not include distance units, such as 1:63,360 or 1:1,000,000, is called a cartographic scale.

Maps are often known as large scale or small scale. A large scale map shows greater detail and has a larger representative fraction (RF) of 1:50,000 or greater (for example, 1:10,000). A small scale map shows more of the earth’s surface and has a small RF, such as 1:250,000 to 1:7,500,000. Maps between 1:50,000 to 1:250,000 are an intermediate scale. Maps of the world that fit on to a normal sheet of paper are very small scale, about 1 to 100 million.

The scale bar adjusts as you zoom and pan the map to accurately reflect the new map view.

The Help System contains these related topics:

• Adding a Scale Bar to the Map
• Adding a Cartographic Scale to the Scale Bar
• Resetting the Scale Bar or Cartographic Scale Value

Working with Layouts

Once you have created the perfect map, you can create and customize a page layout to showcase your work in high-quality presentations or printouts.

MapInfo Pro offers both a classic Layout window for designing map layouts for print or export, and a Layout Designer window that will eventually replace the classic Layout window.

The Layout Designer window contains a live map that you can edit, so that you do not need to toggle between the layout and editing in the Map window. The Layout Designer window shows the map using the printer resolution, so that you know beforehand what your printout will look like (you will know what labels will be on the printed map). In contrast, the Map window shows maps using the screen resolution, which is not an accurate representation of what the printed map would look like (labels in a Map window may not be on the printed map). It also offers more advanced alignment tools for designing your layout and lets you insert image files, such as a company logo, directly to the canvas.

The classic Layout window lets you add complicated geometry to your layouts and lets you work with the Redistrict window, which the Layout Designer window does not. It also offers layout templates, which are not yet available with the Layout Designer window.

To read more about the Layout window, see Working with the Classic Layout Window

Note: You can continue to use the classic Layout window, but there will be no new work or updates made to it in future releases. Instead, future releases of MapInfo Pro will focus on improving and adding to the Layout Designer window.

Opening a Layout Designer Window

To open a Layout Designer window, either:

• On the Standard toolbar, click the Layout Designer tool.
• On the Window menu, point to New Layout Designer Window.
Scrolling the Layout Designer window shows the extents of the paper that the layout will print to.

Adding a Map to the Layout Designer Window

You can add the maps that you have open in MapInfo Pro to your layout in the Layout Designer window.

To add a map to your layout:

1. On the Layout Designer window, click Insert Map Frame.
2. Select a map from the list to open it in a map frame in your layout.

The list includes the Map windows that you have open and any map frames that you already have in your layout.

<table>
<thead>
<tr>
<th>New Map</th>
<th>Opens the New Map dialog box where you can select the map layers that are currently open in MapInfo Pro, to add to a frame in your layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Map Window</td>
<td>Indicates a Map window. Select to copy a Map window in to a new map frame in your layout.</td>
</tr>
<tr>
<td>Map Frame</td>
<td>Indicates a map frame that is already in your layout. Selecting a map frame duplicates the frame in your layout, so that you can show the same map twice in your output. You can edit each map frame separately. This is useful if you want to show before and after scenarios, or wish to compare and contrast data on your map.</td>
</tr>
</tbody>
</table>
You can also drag a map from a Map window into your layout. To do this, select Drag Map Window from the Main toolbar. Click on the map in your Map window and then drag it in to the Layout Designer window. If the Map window has a legend, then the legend copies into a frame in the Layout Designer window as well.

You will see the map frame listed in the Layer Control window with a Map Frame in Layout Designer icon beside it.

**Note:** Closing the open Map windows does not affect your layout.

**Editing the Contents of a Map Frame**

You can activate a map frame in your layout to access the Map window context menu (the right-click pop-up menu). When you activate a map frame, you have access to all of the editing tools that are available for the corresponding Map window. Making changes in a map frame affects only that frame. If the map frame was created by copying a Map window into the layout, the frame and the window are two separate maps. Modifying the map frame has no effect on the original Map window.

The content of an active map frame in the Layout Designer window differs from that of the stand-alone Map window. The display of the map, in particular the display of labels, is based on the printer metrics associated with the Layout Designer window. The labels displayed may differ from those displayed in a stand-alone Map window, which uses screen metrics.

To edit the display of a map frame:

1. Right-click on the map frame and point to Activate in the pop-up menu. This highlights the border of the active frame.
2. Select an object on the map frame and then right-click to open a pop-up menu.
3. Make a selection to change the view of the map, edit the selected object, or get more information about the object.

For a description of the map menu options, search for the options in the Help System. The options are the same as those on the Objects and Map menus for a Map window.

The contents of the frame is fully embedded in the Layout Designer window and not linked to any other window, so editing the contents of the frame in the layout does not affect the display in the corresponding Map window.

Clicking away from the active frame deactivates it.

**Editing the Map Display Style**

Changing the map display styles for a map in a Layout Designer window is similar to changing display styles for a map in a Map window. Both types of maps are in the Layer Control list where you can select map layers to change their display styles.

To edit the map display style in your layout:

1. Right-click on the frame and point to Activate in the pop-up menu. This highlights the border of the active frame.
2. On the **Map** menu, point to **Layer Control** to open the **Layer Control** window.

   You will see the map frame listed in the **Layer Control** window with a **Map Frame in Layout Designer** icon beside it.

3. For the layer that you want to change, either:
   - Double-click on the style swatch to change the display style for the layer. A dialog box opens that is specific to the type of items in the layer and what you clicked on, such as points, lines, or regions. For details about the options that you can set in the dialog, click the dialog’s **Help** button.
   - Double-click on the layer name to change the display style and labels for the layer. This opens the **Layer Properties** dialog box. For more details, click on the dialog’s **Help** button or see **Changing how a Layer Displays on the Map**.

   The changes you make to the map in your layout does not affect the contents of the **Map window** and vica versa.

Adding a Map Legend to the **Layout Designer** window

When a map is embedded in a **Layout Designer** window, any legends you create for the map are also placed in the same **Layout Designer** window.

To add a map legend to your layout:
1. Right-click on the map frame and select **Add Legends** to open the **Add Frames** wizard.

   You can also activate the map (right-click and select **Activate**) and then on the **Map** menu point to **Add Legends**.

2. Select from the options that the wizard presents, or click through the wizard to keep the default settings.

   For a detailed descriptions of the options in the wizard, click **Help** in the wizard.

By default, the legend is beside the map in the **Layout Designer** window. A legend has separate legend frames for each layer on the map. This lets you customize the legend to show only the information for those layers that are important to what the map conveys. By showing some legend frames and not others and by changing the map title and legend text, you can use identical maps to create two very different layouts. This is useful when the same map is used for two different audiences.

You can delete a legend frame from your layout by selecting it and pressing the **Delete** key. To add a layer to your legend, because you deleted the legend frame or did not include the layer when creating the legend, follow the steps in this section and select the layer that you want to add in the **Create Legend** wizard.

You cannot create a second legend in your layout for the same map layer. Removing a layer from a map also deletes the legend for that layer.
Editing a Legend in a Layout Designer Window

A map legend in a Layout Designer window is made up of individual legend frames that are each unique to a layer on the map. To customize your map legend, you would edit the contents of the legend frames to support the design of the final map and to clearly communicate the map contents to the reader.

Each legend frame may have a title and subtitle. You can edit the label text, change the font size and style, and change the sample size. You also have control over how to sort the labels.

To edit the contents and display of a legend frame:

1. Double-click on the legend frame to open the Legend Frame Properties dialog box.
2. Change or remove the title. Optionally add a subtitle, change the display of the labels and the sample size. For a detailed description of the dialog options, click Help.
   
   For some legend themes, you can control the order of the rows in the legend (by ascending, descending, or customizing the order), and show or hide the count beside each row.

   For additional information, see Changing Map Legend Titles and Font Style.

3. Repeat the previous steps for each legend frame that you wish to change in your layout.

To have more than one column in a legend frame, either set the number of columns in the Legend Frame Properties dialog box or resize the legend frame.

To modify how a thematic legend displays, right-click on it and select Modify Legend's Thematic Map to open the Modify Thematic Map dialog box. You can then customize the display properties of the thematic map legend. This option is only available on a thematic map legend frame.

Refreshing the Contents of a Legend Frame

You can edit object styles on the map by adding new styles and removing existing styles, which may affect what the styles look like in the legend. A legend does not update automatically except when overriding, changing, or removing an existing style. For other style changes made to a layer, you must refresh that layer's legend frame.

You cannot refresh a thematic legend frame. Instead, you must recreate it.

To refresh the contents of a legend frame after making style changes to a layer:

   Right-click on the legend frame and click Refresh Legend Styles.

   The legend frame refreshes to show the most current styles in use for the layer.

Adding a Thematic Map to the Layout Designer Window

When creating a layout of a map in the Layout Designer window, you can add a thematic layer to the map.

To add a thematic map to your layout:
1. Right-click on the map frame and point to Activate in the pop-up menu. This highlights the border of the active frame.

2. On the Map menu, point to Create Thematic Map to start the theme wizard.

3. Select from the options that the wizard presents.

For details about the wizard and creating a thematic map, see Creating a Thematic Map.

By default, the thematic legend is positioned beside the map in the Layout Designer window.

If you do not want to create a legend with your thematic map, then in Step 3 of the create theme wizard, click Legend to open the Customize Legend dialog box. From the Into Window drop-down list, select No Legend. MapInfo Pro applies the theme to the map in the Layout Designer window, but does not create a legend.

You can delete a legend frame from your layout by selecting it and pressing the Delete key.

Adding a Table (Browser) to the Layout Designer Window

If a Browser window is open in MapInfo Pro, then you can add it as a table in your layout. Adding a table is useful when you want to show more details about the data that the map displays.

To display a table in your layout:

1. On the LayoutDesigner window, click Insert Browser Frame.

2. Select a Browser window from the list to open it in a frame in your layout. The list includes the Browser windows that are open and any browser frames that are in your layout.

<table>
<thead>
<tr>
<th>New Browser</th>
<th>Opens the Browse Table dialog box where you can select a table that is currently open in MapInfo Pro, to add to your layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browser Window</td>
<td>Indicates a Browser window. Select to copy a Browser window in to a new browser frame in your layout.</td>
</tr>
<tr>
<td>Browser Frame</td>
<td>Indicates a browser frame that is already in your layout. Selecting a browser frame duplicates the frame in your layout, so that you can show the same data twice in your output. You can edit each browser frame separately. This is useful if you want to show before and after scenarios, or wish to compare and contrast data on your map.</td>
</tr>
</tbody>
</table>

The table is in a browser frame in the Layout Designer window.

Note: Closing the open Browser window does not affect your layout. However, closing a table (on the File menu pointing to Close Table) closes it in all windows including the Layout Designer window.
Editing the Contents of a Browser Frame

Activating a browser frame in your layout gives you access to the **Browser** context (right-click) menu. The data is read-only, but you can sort and filter the contents, resize and reorder columns, pick fields, change the font display, and toggle the display of the grid lines. You cannot edit the data in a browser frame; you can only make cosmetic changes.

You cannot select rows in a browser frame in the **Layout Designer** window, and selections to the same base table made in other windows does not affect the browser frame.

To edit the display of a browser frame:

1. Right-click on the browser frame and from the pop-up menu, select **Activate**. This highlights the border of the active frame.
2. Right-click on a column in the browser frame and from the pop-up menu, select to sort the column or apply a filter to it.

For a description of the **Browser** context menu, see **About Browser Window Tools and Menus**. Look at the descriptions under **Right-Click Context Menu Options**.

Clicking away from the active frame deactivates it.

Adding an Image to the Layout Designer Window

You can add an image to your layout, such as a corporate logo, on-location photo, or backdrop for your map. The following are supported image formats that you can work with:

- JPEG Interchange Format (*.jpeg, *.jpg)
- Portable Network Graphics (*.png)
- Windows Bitmap (*.bmp)
- Graphics Interchange Format (*.gif)
- Tag Image File Format (*.tif, *.tiff)
- Icon Format (*.ico)

The image frame maintains a reference to the image file, so the original image file must remain in the same location for it to display. The reference to the image file is also maintained in a workspace.

To add an image to your layout:

1. On the **Layout Designer** window, click **Insert Image** to open the **Insert Image** dialog box.
2. Locate the image file that you want to insert, select it, and then click **Open**. The image displays in your layout.

You can resize an image by selecting it and then dragging a corner to a new size. The image scales to fit within the image frame.
The Layout Designer maintains the image aspect ratio (ratio between width and height) as you resize it, so that the image does not look distorted. When replacing an image, the image frame resizes to match the aspect ratio of the new image.

**Image Not Found**

A message displays in a Layout Designer image frame when the image file that the frame references cannot be found. The message includes the path to the file that is missing. The image frame retains the reference to the image, so restoring the image file restores its display in the image frame.

As an example, you will see a message after deleting or renaming the image or when an image is in a shared location on your network and you lose access to the network. After restoring the image, or restoring your network connection, the image displays in the layout.

The Layout Designer retains the image in the layout during your session, so you may not see a message until after reloading the layout, such as when resizing the image in the layout or after opening a workspace.

**Adding Text to the Layout Designer Window**

You can add text to your layout, such as titles, footnotes, copyright date, and other important information that explains your map. The text that you add is within a text frame that can be moved anywhere in the layout.

Each text frame holds up to 2047 characters.

To add text to your layout:

1. On the Layout Designer window, click Insert Text.
2. Click where you want to add text to your layout.
3. Type your text in the text frame.
4. When you are done typing, click anywhere else in the layout or press the Esc key.

To edit your text, double-click on the text frame to active it and then make your changes.

**Note:** If you are editing text while the layout zoom is not set to 100% and your cursor disappears, pressing the left or right arrow keys redisplay the cursor. This is a known issue with the operating system.
Changing the Text Style in a Text Frame

To change the style of text in a text frame:

1. Either:
   - Right click on the text frame and select Text Style to open the Text Style dialog box.
   - Select the text frame and then click Modify Text Style in the Layout Designer window.

2. Change the font, size, color, and effects applied to the text in the frame.
   Text effects shown in grey are unavailable for modifying the text in a Layout Designer window.

3. Click OK to apply your changes.

To change the style for text in multiple frames, press the Ctrl key while selecting text frames, right-click on one of the frames, and then select Text Style.

Changing Text Alignment and Spacing

You can control the horizontal alignment of the text within a text frame. The alignment determines the appearance and orientation of the edges of the text as left-aligned, right-aligned, or centered. You can also determine how much space occurs between the lines of text.

To control the alignment or spacing of text:

1. Select one or more text frames by clicking or shift-clicking on them.

2. On the Layout Designer window, only one of the following icons displays. Click on it to see a drop-down menu with all of these alignment options and then select one.

   - Align Text Left
     - Left-justifies the text within a text frame.

   - Center Text
     - Centers the text within a text frame.

   - Align Text Right
     - Right-justifies the text within a text frame.

3. Click the following icon to select from a drop-down list of line spacing options.

   - Line Spacing
     - Sets the amount of space that displays between the lines of text within a text frame. You can select Single Line, 1.5 Lines, or Double Lines.
The text refreshes using the new alignment and spacing.

**Changing the Text Frame Orientation**

You can change the orientation of a text frame in two ways.

1. Using **Changes orientation of selected frames** button on the **Layout Designer** window:
   a) Select one or more text frames by clicking or shift-clicking on them.
   b) On the **Layout Designer** window, click the icon to see a drop-down menu with all the orientation options and then select one.

<table>
<thead>
<tr>
<th>Orientation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Horizontal</td>
<td>Horizontally aligns the text frame along the Layout Designer window.</td>
</tr>
<tr>
<td>Rotate 90</td>
<td>Rotates the text frame by 90 degrees.</td>
</tr>
<tr>
<td>Rotate 270</td>
<td>Rotates the text frame by 270 degrees.</td>
</tr>
</tbody>
</table>

2. Dragging and dropping the text frame bottom-right corner:
   a) Select one or more text frames by clicking or shift-clicking on them.
   b) Hover the mouse pointer over the bottom-right corner of the text frame till it turns to .
   c) Drag and drop the mouse pointer for the desired orientation.

**Adding Shapes to the Layout Designer Window**

You can add a shape to your layout, such as an ellipse, rectangle, rounded rectangle, or line by clicking the **Draw Shape** tool on the **Layout Designer** window toolbar. This is useful for adding borders to your layout, design elements (such as shading behind a legend), or calling out and separating text or areas of the layout for review, sign-off, or special attention.

To add a shape to your layout:

1. Set the fill color for the shape. On the **Options** menu point to **Region Style** and select **Foreground Color**.
2. On the **Layout Designer** window, click **Draw Shape**.
3. Select a shape from the list.
4. Click and drag to draw the shape onto the canvas.
5. After drawing the shape, drag it to a different location or resize it by dragging one of its corners.

### Aligning Layout Objects

You can align layout objects in the following ways:

- Align layout objects with respect to either the page margins or the page center lines, both horizontal and vertical.
- Align layout objects with respect to each other.

#### Aligning layout objects to page margins

If an object is selected on the layout designer and the guidelines on the page are disabled, then using any **Snap To** option will align the object with the page margin. Pressing either the **Align Horizontal Center** or **Align Vertical Center** option will move the object such that its center is aligned with the page center.

**Note:** The page center is based on the page width / height minus the page margins.
Aligning layout objects to each other

If more than one objects are selected on the layout designer and the guidelines on the page are disabled, then using any Snap To / Align Center option will align the objects with each other.

<table>
<thead>
<tr>
<th>Snap To Bottom</th>
<th>The bottom edge of the selected object is snapped to the bottom page margin.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align Horizontal Center</td>
<td>The vertical center line of the selected object is snapped to the vertical center line of the page.</td>
</tr>
<tr>
<td>Align Vertical Center</td>
<td>The horizontal center line of the selected object is snapped to the horizontal center line of the page.</td>
</tr>
</tbody>
</table>

If guidelines are enabled on the page

If a guideline (horizontal and/or vertical) is visible on the page, selected layout objects snap to the guideline. For example, if you select an object on the layout designer and the guideline is visible, clicking Snap To Left will make the object snap to the guideline rather than snapping to the left page margin.

Saving a Layout in the Layout Designer Window

You can save a layout in a Layout Designer window by saving to a workspace.

To save your layout to a workspace:

1. On the File menu, point to Save Workspace to open the Save Workspace dialog box.
2. Select a location to save the workspace to, give the file a name, and then click **Save**.

The workspace does not save with image files. If the layout includes images, then the workspace saves the references to the images. If a workspace cannot find an image when it opens, then an image not found message displays with a path to the image file. This could happen when you:

- Copy the workspace file to a different location before opening it, because the references to the images are now broken.
- Rename or move an image file and then open the workspace, because the image reference is now broken.

To use your layout on another machine, save it using the Workspace Packager tool. This tool collects all referenced tables and files, such as images, into a folder with the workspace. You can then save and share this folder with other MapInfo Pro users.

Deleting a Frame from the Layout Designer Window

To delete:

- A single frame from your layout, select it and then press the **Delete** key.
- Multiple frames, press the **Ctrl** key while selecting frames, and then press the **Delete** key to remove them from the layout.

Moving Frames

You can move frames anywhere within the **Layout Designer** window, but not above the top edge or to the left of the canvas.

If you need to view the entire contents of the layout before moving frames, then click the **Fit Layout in Window** tool to the right of the zoom slider. For details, see [Re-Center and Specify a Zoom Level for the Layout Designer Window](#).

To move:

- A single frame, click on the frame and drag to a new location on the canvas. To use precise measurements, right-click on the frame and select **Frame Properties**. In the **Frame Properties** dialog box, enter new horizontal (X) and vertical (Y) values.
- Multiple frames, press the **Ctrl** key while clicking on the frames you wish to select and then drag to a new location.

You may add enough frames to the **Layout Designer** window to cause frames to overlap one another. In the **Layout Designer** window all frames are ordered from front to back. Think of them as being stacked in the **Layout Designer** window. When you place a new frame, it is automatically the front most frame, even if it is not overlapping any other frames in the layout. To display your frames properly, you may need to bring a frame forward in front of other frames.
To change the order of frames, right-click on the front frame. From the pop-up menu, select **Send to Back** to reposition it behind the frame you want to move. Use these right-click options to reposition frames:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bring to Front</td>
<td>Moves the frame to the front, so that it is on top of all of the other frames.</td>
</tr>
<tr>
<td>Send to Back</td>
<td>Moves the frame to the back, so that it is behind all of the other frames.</td>
</tr>
</tbody>
</table>

### Resizing Frames

The contents of a frame scales to fit within the frame.

To resize a frame either:

- Select the frame and then drag an edge or corner to a new size.
- Specify width and height values for the frame. To do this, right-click on the frame and select **Frame Properties**. In the **Frame Properties** dialog box, enter new **Width** and **Height** values.

When resizing image frames, you can only drag a corner. The image scales to fit within the new frame size. For details, see **Adding an Image to the Layout Designer Window**.

The **Width** and **Height** values are in the default units set for the application. This setting is on the **System Settings Preferences** dialog box, which you can open on the **Options** menu, by pointing to **Preferences** and clicking **System Settings**. The **Paper and Layout Units** list sets the units, such as inches, points, or centimeters, for the **Width** and **Height** values. For details, see **Setting Your Default Units**.

For details about changing the size of shapes, see **Editing Shapes in a Layout Designer Window**.

### Aligning Frames in the Layout Designer Window

You can move and position layout frames in the **Layout Designer** window by snapping them to a background grid or guideline. Snapping is an effect where you move a layout frame near a guideline or a grid line and it aligns and attaches (snaps) to the line. This is useful for arranging multiple frames so that their edges line up perfectly.

Grids and guidelines are tools that help you design a layout. They do not display in printouts or exported images.

When working with the grid and guidelines, you may want to zoom into or out of the view in the **Layout Designer** window. For instructions on how to do this, see **Re-Center and Specify a Zoom Level for the Layout Designer Window**.
Aligning Layout Frames Using Grid Lines

To use grid lines to align the position of layout frames in the Layout Designer window:

1. On the Grids & Guidelines menu, point to Show Grid.
   A check mark displays beside this option when it is enabled.

2. On the Grids & Guidelines menu, point to Snap to Grid.
   A check mark displays beside this option when it is enabled.

3. Click on and drag a frame to where you want to position it in the Layout Designer window.
   The upper left corner of the frame snaps to the nearest grid cell corner.

To resize the grid to help position frames, on the Grids & Guidelines menu point to Grid Size and select a grid size from the list. The grid resizes to your selection.

Note: You can set the units in which you want to resize the grid. On the Options menu, click Preferences and then click System Settings to open the System Settings Preferences dialog box. Select the desired unit from the Paper and Layout Units drop-down list.

To stop working with the grid, on the Grids & Guidelines menu point to Show Grid. The grid is hidden when there is no check mark beside this option.

Aligning Layout Frames Using Guidelines

Working with guidelines is similar to working with grid lines, except that you can discretely position a guideline for more control when aligning layout frames.

To add a guideline to the Layout Designer window:

1. On the Grids & Guidelines menu, point to Add Vertical Guideline or Add Horizontal Guideline.

2. Click on the guideline and drag it to where you want to position it in the layout.

3. Select one or more layout frames (frame borders display to indicate your selections).

4. On the Grids & Guidelines menu, point to one of the following options to snap the edge of the frame border to the nearest guideline.

| Snap To Left | Aligns all selected frames to the nearest guideline located to the left of the frame. |
| Snap To Right | Aligns all selected frames to the nearest guideline located to the right of the frame. |
Aligns all selected frames to the nearest guideline located above the frame.

Aligns all selected frames to the nearest guideline located below the frame.

The vertical center line of the selected frame is snapped to the vertical center line of the page.

The horizontal center line of the selected frame is snapped to the horizontal center line of the page.

Selecting **Add Vertical Guideline** or **Add Horizontal Guideline** adds a guideline to the center of the **Layout Designer** window. If you make this selection multiple times, you will have more than one guideline at the center position—it might not look that way until you start dragging them to a new position.

**Hiding and Showing Guidelines in the Layout Designer Window**

To hide or show guidelines:

On the **Grids & Guidelines** menu, point to **Disable Guidelines** or **Enable Guidelines**.

**Removing Guidelines in the Layout Designer Window**

You have two options for removing guidelines:

- To remove one guideline, right-click on it and then select **Remove Guideline**.
- To remove all guidelines, on the **Grids & Guidelines** menu point to **Remove All Guidelines**.

**Editing in the Layout Designer Window**

You can edit the contents of map, legend, browser, or text frames, but not image frames.

When you activate a map frame, you have access to all of the editing tools that are available for the corresponding **Map** window. When you activate a browser frame, you can sort the contents, resize and reorder columns, pick fields, and change the font display.

To activate a frame, so that you can change its contents:

- Right-click on the frame and point to **Activate** in the pop-up menu.
- Double-click on the frame, or press the **Alt** key and click on the frame.
The border of an active frame highlights.

Clicking away from the active frame deactivates it, as does pressing the `Alt` key and clicking in the frame. (Use the `Alt` key as a quick way to toggle between making a frame active and inactive.)

For more information about how to edit maps, tables, and text, see:

- **Editing the Contents of a Map Frame**
- **Editing the Contents of a Legend Frame**
- **Editing the Contents of a Browser Frame**
- **Changing the Text Style in a Text Frame**

### Printing Your Layout

Before printing, ensure that you are happy with how your print settings affect your layout. Changing printer information can change the labels that display in a layout. This includes changing the resolution of the printer, which can be done when printing to the MapInfo PDF Printer.

**Note:** Grids and guidelines in the Layout Designer window do not display in printouts or exported images.

To print your layout:

1. Click **Page Setup** on the Layout Designer toolbar to open the Page setup dialog box.
2. Check the paper size, orientation, and margins. Keep or make changes to these settings and then click **OK**.
3. Check the contents of your layout, particularly the labels, to ensure that you are happy with what you see.
4. Click **Print** on the Layout Designer toolbar.
5. From the **Name** list, select a printer to print to.
6. Click **OK** to print your layout.

**Note:** Saving to a workspace also saves the printer resolution, so that the Layout Designer restores to the exact state the next time you open the workspace.

### Setting Printing Margins for a Layout

Before printing, review your page setup to ensure that the print margins, paper size, source, and orientation are set to what you want.

To review and change the page setup:

1. Click **Page Setup** on the Layout Designer toolbar to open the Page setup dialog box.
2. Check the paper size, orientation, and margins. Keep or make changes to these settings.
3. Click **OK** to save your changes.

You are now ready to print your layout. If you save to a workspace, these settings save with it.
Notes about Printer Settings

A layout is on a single page, not multiple pages.

Each Layout Designer window has a printer associated with it. When you use the Page Setup dialog box (from either the Layout Designer toolbar or from the File menu), you are configuring both your printer and your Layout Designer window. For example, if you want to rotate your layout 90 degrees, to give it a landscape orientation, open the Page Setup dialog box and select Landscape.

The margins that you choose in the Page Setup dialog box display as a blank area in the Layout Designer. The grid in the Layout Designer window begins where the margins end.

Note: When you use Print or Print to PDF, nothing in the margins will print. Layout frames within the margin area do not appear in the printout.

Print settings made on the File menu by pointing to Print are applied to the Layout Designer window and used for subsequent printouts.

Layout Paper Size

The layout paper size is tied to the printer settings. Default printer and paper settings are made on the Options menu, by pointing to Preferences and selecting Printer.

You can override the default setting, by setting paper size, margins, and page orientation (portrait or landscape) for a Layout Designer window. To do this, click Page Setup on the Layout Designer window to open the Page Setup dialog box.

Print OSBM and Subdivide Printing

Off-Screen Bitmap (OSBM) automatically applies when printing a map frame that contains items or options that require OSBM to preserve their appearance in print. Using OSBM processes each print tile as a raster. This is an automatic setting that you cannot control when printing from a Layout Designer window. Using OSBM applies when the Map has enhanced rendering turned on, and one or more visible layers with:

• Translucent vectors.
• Images (such as raster, grid, WMS, or tile server) with transparency, translucency, or image smoothing.

Printing to a layered PDF does not use the Print OSBM method.

You can turn on subdivide printing as a preference (on the Options menu, point to Preferences, Output Settings, Printing, and then click Subdivide Printing). When subdivide printing is turned on and Print OSBM is not being used, then each map in a Layout Designer window divides into smaller tiles while printing. This reduces the amount memory required to process the print job, especially when the map frame is large. When subdivide printing is off, then each map frame prints at once.
If your map contains translucent images (usually raster, grid, WMS, or TileServer images) and Enhanced Rendering is turned off, then it may not print as translucent. To make it print with translucency, on the Map menu, point to Options. In the Map Options dialog box, check the Enable Enhanced Rendering check box.

Exporting Your Layout

MapInfo Pro maintains the printer resolution of the layout regardless of the file format you export to. To accomplish this, MapInfo Pro creates an image at the printer resolution and then converts that image to the resolution of the export format. This ensures that what you see in the Layout Designer window is what you see in the image you export to.

To export your layout:

1. On the Layout Designer toolbar, click Save Window As to open the Save Window to File dialog box.
2. In the File name field, type a name for the export file.
3. From the Save as type list, select BMP, metafile, JPEG, JPEG2000, PNG, TIF, GIF, or PSD.

   Note: You cannot export a metafile (EMF/WMF) file from a LayoutDesigner window.

4. Click Save.

   The output size is the same as the printer page size set in the Page Setup dialog box (click Page Setup on the Layout Designer window).

   The export image includes content that is in the margins of the layout (unlike printing, which clips out items in the margins). However, if the content goes beyond the page limits, then it is not included.

   Normally, what you export looks identical to what is in the Layout Designer window. However, some graphics and text may become blurry when you export a layout. To correct this, on the Options menu point to Preferences and then click Output Settings. On the Output Preferences dialog box, under the Exporting tab, select the Clarify Text check box. This corrects the issue, but may cause some labels on the map to look slightly different in the export from what is in the layout.

Working with the Classic Layout Window

Using the classic Layout window, you can create and customize a page layout that shows off your maps, browsers, and graphs.

The classic Layout window lets you add complicated geometry to your layouts and lets you work with the Redistrict window, which the Layout Designer window does not. It also offers layout templates, which are not yet available with the Layout Designer window.
There will be no new work or updates made to the Layout window in future releases. Instead, future releases of MapInfo Pro will focus on improving and adding to the Layout Designer window.

For more information, see Working with Layouts.

What is a Layout Window?

MapInfo Pro’s classic Layout window is a page layout feature that allows you to combine your Map, Browser and Graph windows on a page and arrange them for output. You can add any currently open window to the layout and move and resize it to find the best look to show off your work. Add text such as titles and labels to pull the entire presentation together.

While you can print individual Map, Browser, and Graph windows directly without the Layout window (on the File menu, point to Print), you can only print a thematic legend by first adding it to a Layout window. You can also print the data contained in the Info tool, statistics and message windows from the Layout window.

The Layout window is available as soon as you open MapInfo Pro. On the Window menu, point to New Layout Window to access it. When the Layout window is active, MapInfo Pro puts a Layout menu on the menu bar, allowing access to a number of layout features.

When you add your windows to the Layout window, MapInfo Pro places them inside layout frames. Using frames to hold your maps and browsers allows you to resize and reposition your windows
with ease. The contents of the frame match the contents of the corresponding Map, Browser or Graph window.

The **Layout** window provides dynamic linking between it and a parent window. For instance, if you change the zoom in a Map window, that map will be updated in the **Layout** window once you make the **Layout** window active again.

The rest of this chapter is devoted to learning how best to create a layout, move around in the **Layout** window, and customize your layout using a variety of options.

### Working in the Layout Window

The **Layout** window functionality includes a number of options to help make it easier to design and create your layouts.

**Adding a Maximized Window to a Layout**

You can put a maximized **Map** window into a frame in a **Layout** window. The frame object's dimensions are created according to the Map window's size instead of the page layout size. MapInfo Pro also allows the map's image to completely fill the frame, preserving the map's center and zoom settings. If you double-click on the frame, you will notice that the **Frame Object** dialog box has a check box: **Fill Frame with Contents**. This allows the map image to fill the entire frame. The box is checked by default for all Map windows in frames.

**Aligning Objects in the Layout Window**

To align one or more objects in the **Layout** window:

1. Do one of the following:
   - Choose one object.
   - Hold down the **Shift** key and click several objects.
   - In the **File** menu, point to **Select All** to select all of the objects in the layout.

2. On the **Layout** menu, point to **Align Objects** to open the **Align Objects** dialog box.
3. From the drop-down lists, select vertical and horizontal settings.
4. Click **OK**. The selected objects align according to the settings you specified.

**Note**: Your alignment settings are saved from one use to the next within a session. Be sure to check both the vertical and horizontal settings before you click **OK**.

**Getting Around in the Layout Window**

The **Layout** window includes a rule along the top and left side of the window to assist you when resizing and positioning frames. To hide the rule, on the **Layout** menu, click **Options**. The **Layout Display Options** dialog box displays. Clear the **Show Rules** check box.

If you are creating a multi-page layout, MapInfo Pro displays the page breaks by default. If you wish to turn off the page breaks, clear the **Show Page Breaks** box in the **Options** dialog box.
Controlling Zoom Level

MapInfo Pro displays the Layout window at a zoom level that is a fraction of the actual size of the printed layout. The zoom level is represented as a percent of actual size in the lower left corner of the status bar.

In order to better position or resize layout objects, you may want to change the zoom level of the Layout window to see more detail. Keep in mind that you are changing the overall zoom of the Layout window, not the zoom of individual windows in frames. (If you want to change the zoom level on a frame containing a Map window, change the zoom for the Map window itself.)

There are four ways to change the zoom level of the Layout window:

- Use the Zoom-in and Zoom-out tools. These tools work exactly as they do in the Map window. You can click the Layout window with the tools or draw a marquee box around the areas of the Layout window.
- On the Layout menu, click Change Zoom to set the zoom. You can set the zoom anywhere between 6.3% and 800%.
- Use the number keys (1-8) on your keyboard to set the zoom level. As the numbers increase, the zoom increases geometrically. For example, press 1 to get a zoom of 6.3%, press 2 to get a zoom of 12.5%, and press 3 to get a zoom of 25%. (Remember to use the number keypad, and make sure Num Lock is on.)
- Use the View commands in the Layout menu: View Actual Size, View Entire Layout, Previous View.

Ordering Overlapping Objects

You may add enough windows to the Layout window to cause objects to overlap one another. In the Layout window all objects are ordered from front to back. Think of them as being stacked in the layout. When you draw a new object, it is automatically the front most object, even if it is not overlapping any other objects in the layout. To display your objects properly, you may need to bring an object forward in front of other objects.

You can use the Bring to Front and Send to Back commands to change the order of objects. Click an object with the Select tool. Choose the Bring to Front option to move the object into the foreground. Choose the Send to Back object to move the object into the background.

When you select an object using the Ctrl key along with the Select tool, MapInfo Pro selects the object one layer down. Selecting again chooses the next layer.

Before You Create a Layout

The first step in generating quality output is creating good Map windows. MapInfo Pro is set up to do a great deal of on-screen data entry, object editing, geocoding, and geographic analysis. There are many windows available to work with that can be easily arranged on the screen. When you prepare any MapInfo Pro window for output using a classic Layout window, you must change the way you think of using MapInfo Pro.
For example, in a MapInfo Pro session, if you want two views of a map, you may simply use the Grabber tool and shift to a different location and then return via Map menu (click Previous View). To get two views of the same map for a layout, you must have two separate Map windows. There are many techniques that can be used to prepare the windows to make output easier.

Creating Multiple Views of the Same Map

One very popular way to display maps is to have a detailed map with an inset of an overview map representing the general area. For example, government planners have a detailed flood plain map thematically shaded for an area around a major city. They want to include an inset map showing the location of that city in relation to the entire region. We can simulate this exercise with the WORLD.TAB table included with MapInfo Pro.

Note: Some of the files described in this example may refer to MapInfo Pro Tutorial data, which is available on the MapInfo web site, www.mapinfo.com.

To create multiple views of the same map:

1. Open the WORLD.tab and WORLDCAP.TAB tables from the MapInfo/Data/World directory. The tables display in a Map window.
2. Choose the area you want to show in detail and zoom in on it. The Map window contains the detailed view.
3. As stated previously, there must be a separate Map window for each view you want to include in a layout. Instead of re-opening the tables to re-create the Map window, on the Map menu, point to Clone View to create a duplicate Map window.
4. A new Map window displays. Zoom out on this map to create the overview map.
The new Map window is independent of the original Map window. You may add or remove layers without changing the original map.

Getting Labels Right for your Layout Window

There are many considerations in getting labels to look good on your maps. As with changing views of the map, there is a significant difference between using labels in a MapInfo Pro session and using them in a layout. Labeling in a MapInfo Pro session is best handled by clicking Automatic Labels for a layer in Layer Control.

When you create a map to place in a Layout window, you usually need to spend more time making your labels look aesthetically pleasing. It is also more likely that you will want to save these labels to a separate layer. With the default labeling, label styles can be changed; however, customized labels are not saved in their own layer for future use or editing. To create labels that can be easily saved, use AUTOLABEL.MBX or LABELER.MBX. These MapBasic applications allow you to create labels that can be saved to a separate layer for future use.

For instructions on using the AutoLabeler tool, see the Tools section of the Help System.

Creating a Layout Window

Creating a layout involves adding your Map, Legend Designer, Graph, and Browser windows to a classic Layout window, positioning these items where you want them, and adding any annotations such as text and titles so that your final layout presents the message you want to send.

You bring your windows into the Layout window by adding them to placeholders, or frames. A frame is a graphic object through which you can view a window. Each frame may contain the contents of one Map, Graph, Browser, or Legend Designer window.

First, decide what you want to put in the Layout window. You can choose whether you want to display all, some, or none of your open windows.
To create a Layout window:

1. On the Window menu, point to New Layout Window.

   When no windows are open, MapInfo Pro creates a blank Layout. When there are windows open, MapInfo Pro displays the New Layout Window dialog box.

2. Choose one of the options:

   • **One Frame for Window** - MapInfo Pro places a single open frame in the center of the layout. You select the contents of this frame through the drop-down menu that lists all open windows.

     If you choose a Map or Graph window from this list and there is an active map legend, MapInfo Pro automatically places the map legend in the layout. You can reposition or delete this map legend from the layout. A legend in the Legend Designer window is positioned in the same way as Map, Browser, and Graph windows. Their relative locations are preserved on the screen.

   • **Frames for all Currently open Windows** - This option tells MapInfo Pro to place all open windows in the layout. Since MapInfo Pro places windows in the approximate location and size as they appear in the MapInfo Pro window, you should arrange and size the windows before you bring them into the layout.

   • **No Frames** - If you prefer, you can create a blank layout by choosing the No Frames option. If you do not have any windows open, choosing New Layout Window automatically creates a blank layout. The New Layout Window dialog box does not display.

   Since a frame is a graphic object, you can:

   • Reposition it using the Select tool.

   • Change its fill, and the line style of its border.

   • Copy or cut the frame and paste it into another Layout window.

   You can also position frames so that they overlap one another or overlap other graphic objects. To change which window is displayed in a frame, double-click the frame with the Select tool. Use the drop-down list in the Frame Object dialog box to change the frame’s contents.

3. Click OK.

MapInfo Pro opens and displays that Layout.

When MapInfo Pro first opens a Layout window, it sets the page size and orientation (portrait or landscape) according to the current setting for your printer. The current setting for your printer is determined by the printer specifications designated on the Options menu by pointing to Preferences and clicking Printer. You can change the printer settings for the active Layout window on the File menu by pointing to Page Setup, or by using the Set Window Printer command in the MapBasic window. When you later open that layout when the printer setup is different, the layout uses the page size and orientation for that printer setup. The sizes and positions of objects in the layout are the same, but the way the layout is broken into pages is different.

After you create a layout, that layout is the currently active window. MapInfo Pro places the Layout menu item on the menu bar. Use the Layout menu to choose your layout options.
Adding a Maximized Map Window to a Layout

You can place a maximized Map window into a frame in a Layout window. The frame object's dimensions are created according to the Map window's size instead of the page layout size. MapInfo Pro also allows the map's image to completely fill the frame, preserving the map's center and zoom settings. If you double-click the frame, you will notice that the Fill Frame with Map check box in the Frame Object dialog box is checked. This allows the map image to fill the entire frame. The box is checked by default for all Map windows in frames.

Adding a Map to a Layout

After you have created a layout, you may decide that you want to add other maps to it. You do not have to create a new layout to do this. You can create frames by hand to contain other windows. Use the Frame tool to draw window frames where you want them. The Frame tool is available whenever the Layout window is active.

To add a window to a layout you are already working with:

1. Click the Frame button in the Drawing toolbar and the cursor becomes a small cross.
2. Move the cursor to where you want to begin drawing.
3. Click and hold the mouse button and drag the cursor diagonally until the dashed box outlines the area where you want the frame.
4. Release the mouse button. When there are no windows open, an empty frame displays with "No Window" inside. When there are one or more open windows, the Frame Object dialog box displays.

Frame Object

Window: Statistics

Bounds X1: 2.4785 in Y1: 0.3097 in
Bounds X2: 2.9333 in Y2: 1.2410 in
Center X: 2.7056 in Y: 1.0750 in
Width: 0.4548 in Height: 0.3313 in

Scale Options
Map Scale: 1 in = Cartographic Scale: 1:
Resize Frame
Change Map Zoom

Fill Frame with Contents

[OK]  [Cancel]  [Help]
This dialog box is slightly different for each type of frame. The Map Scale options are only available when you select a Map window in the frame.

**Note:** The Fill Frame check box does not display for Browser, Legend Designer, and Graph windows.

The Frame Object dialog box allows you to change the width, height, and center of the frame and to set a specific scale for a map. When there are several windows open on the screen, MapInfo Pro displays its choice in the Window drop-down list. This list allows you to choose which window you would like in your frame.

5. In the Window drop-down list, select the window you want to add and review the options for creating this frame.

   • **Bounds X1, Y2 and X2, Y2** - Use these fields to define the x and y boundaries for the new frame. When you change the width of the window (by changing X1 or X2), both the Map Scale and the Cartographic Scale change. Both the scales, however, do not change if you alter the height of the window (by changing Y1 or Y2).

   • **Center X, Y** - Use these fields to define and adjust the center point of your new frame.

   **Note:** When you make a change to the Center X or Y entries, the Width and Height bounds do not change.

   • **Width, Height** - Use these fields to adjust the width and height of the new frame.

   • **Change Map Zoom** - Click this radio button to implement the correct map scale without changing the size of the frame. This option changes the zoom of the actual Map window so that the layout frame is in the correct scale. This option is selected by default. Type the scale you want within this frame in the Scale. The units are set by the Paper Unit setting in the System Preferences dialog box.

   For example:

   \[
   \text{Map Scale} = \text{Scale field entry} \times \left(\frac{\text{Frame width}}{\text{Map window width}}\right)
   \]

   **Note:** Changing the map scale with this option will not change the values in the Bounds fields or the Width and Height fields because there is no change to the size of the frame, only the look of the map within the frame. To undo the change to the map zoom, return to the Map window and click Previous View.

6. Select one of these options:

   • **Resize Frame** - Click this radio button to change the size of the frame based on the data you enter into the Scale field. When you change this entry, the bounds, Center, Width, and Height entries change accordingly.

   • **Fill Frame with Contents** - Click this check box to display as much of the Map window as fits in the frame. When you do not select this button, the frame may be only partially filled but it will have the same contents as the window it contains.

7. Click OK to choose MapInfo Pro's choice and that window is placed into the frame.
8. Choose a window from the dialog box's Window drop-down list.
9. Click OK and the window is placed in the frame.

**Note:** When you click the Change Map Zoom or Resize Frame radio button, you set your selection as the default for the rest of the session. If you change it during the session, the change becomes the default.

Once you have created a frame, you treat it much like any other graphic object. You can change its size and position, its line style and fill pattern, and you can cut, copy, and paste it.

You can access instructions for making a frame transparent in the *Help System*.

**Using Map Legends in a Layout**

You can use map legends in your layout. The Legend Designer window display in the layout at the same size as on the MapInfo Pro desktop.

When you resize a map legend frame to make it smaller, it crops the map legend rather than shrinking it to fit. The text styles (for example, font, size) used in the Legend Designer window are preserved in the layout.

Adding a map legend to the classic Layout window is a different process, depending on the type of map legend. You can add a theme legend to a layout even when no theme legend displays in the MapInfo Pro desktop.

To do this, make sure the Layout window is active and click the Frame button.

1. In the Layout window, click and drag to draw the frame for your theme legend. When you release the mouse, the Frame Object dialog box displays.
2. In the Window drop-down list, select the thematic map legend and click OK. The thematic map legend displays in the layout frame. This is also how you add other types of windows on your desktop to the current layout.

You must create a map legend on your desktop (on the Map menu, point to Create Legend) before you can add it to a Layout window.

**Moving Frames in a Layout Window**

Once you have brought in the windows you wish to include in the layout, you can reposition or resize them to create a professional looking product.

To move a frame:

1. Click the frame with the Select tool and hold down the mouse button.
2. When the cursor becomes a four-headed arrow (after about one second), drag the frame to the new location and release the mouse button.
Aligning Objects in a Layout Window

MapInfo Pro includes a command to help you perfectly align objects in a classic Layout window. You can align objects to each other horizontally and vertically or to the Layout window itself.

Choose the objects you want to align and on the Layout menu, and click Align Objects to open the Align Object dialog box.

Specify the appropriate vertical and horizontal alignment. Choose from the following options:

<table>
<thead>
<tr>
<th>Horizontal Alignment</th>
<th>Vertical Alignment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Don't change alignment</td>
<td>Don't change alignment</td>
</tr>
<tr>
<td>Align left edges of</td>
<td>Align top edges of</td>
</tr>
<tr>
<td>Align center of</td>
<td>Align center of</td>
</tr>
<tr>
<td>Align right edges of</td>
<td>Align bottom edges of</td>
</tr>
<tr>
<td>Distribute</td>
<td>Distribute</td>
</tr>
</tbody>
</table>

Each alignment can be performed with respect to each object or to the entire layout. When you choose the entire layout, the objects are aligned with respect to the top, bottom, left, and right edges or margins of the layout.

If you want to align objects with respect to each other, the objects are aligned with respect to an imaginary rectangle, called the bounding rectangle, that completely encloses the objects. The horizontal and vertical settings you choose position the objects at the top, bottom, left, right, and horizontal or vertical center lines of the bounding rectangle, rather than at the edges of the layout.

The Distribute option tells MapInfo Pro to distribute the vertical and horizontal space between objects evenly. You can perform multiple alignments in one layout.

You can also align objects and frames relative to each other both horizontally and vertically. There are four options - Align Left, Align Right, Align Top, and Align Bottom on the Layout menu. These shortcuts offer simpler options to the previously existing menu options on the Align Objects dialog box.

The alignment operations are equivalent to using this dialog to perform one of the four alignment options, “with respect to each other”. This means that the selected objects (including frames) in the layout align relative to one of the selected objects.
Creating Drop Shadows for Layout Objects

When you move or resize the layout object, the shadow does not resize or move. You may not want to create a drop shadow until you are sure of the position of its source.

To create a drop shadow:

1. Click the object with the Select tool or hold down the Shift key and click on several objects, or choose Select All from the Query menu to select all the objects in the layout.
2. On the Layout menu, point to Create Drop Shadows to open the Create Drop Shadow dialog box.
3. Type the size of the horizontal and vertical offset for the drop shadow.
4. Click OK. The drop shadow appears behind the selected object.
5. Since a drop shadow is just a rectangle object, you can delete it or change its fill pattern and line style.

See Also:

Layouts

Setting the Map Scale for a Layout Window

One of the most difficult tasks in generating good output is setting the scale of the map. There are two ways to set the map scale. The first method is to choose Map menu and click Change View. This scale setting affects the on-screen scale of your map according to your monitor size. This scale setting is not used as often, because generally the scale on screen does not need to be exact. Use the on-screen scale when you are making a presentation that will be viewed directly in MapInfo Pro.

Note: The Map Window Preference setting Use Cartographic Scale affects the entries in the Change View dialog box.

Accurate scale is more important on the printed map. To get the correct scale for output, you must coordinate the Map window with the Layout window. You must also decide on the desired end result. For example, you may want a map that has a 1:25000 scale and fits in a nine inch layout frame. If this is the case, you will have to alter the zoom level of your map to fit these conditions. Or, in the case where you must show a set distance across the map, you may have to allow for a larger page size. The following two formulas will help you set the right map zoom, scale, and frame width.

Limiting Frame Size When Setting the Layout Scale

The following formula calculates the zoom that must be set in your Map window in order to have a map meet set scale and frame width criteria.

\[
\frac{(\text{Frame Width in Inches} \times \text{Scale})}{12} \div 5280 = \text{Map Zoom in Miles}
\]
For example, you need to make a map that will be in a scale of 1:24000 and fit in an eight inch frame. You need to determine the zoom level that will accommodate the map scale and frame width. Calculate the following:

\[
\frac{(8 \times 24000)}{12} / 5280 = 3.03
\]

On the Map menu, point to Change View and enter 3.03 miles as your new zoom level.

**Limiting Map Zoom when Setting the Layout Scale**

The following formula calculates the number of inches to make the frame for a map in order to meet set scale and zoom level criteria.

\[
\frac{\text{Map Zoom in Miles} \times 5280 \times 12}{\text{Scale}} = \text{Necessary Frame Width}
\]

For example, you need to make a map that will be in a scale of 1:100000, and you must view a twenty mile zoom level. You need to determine the frame size that will accommodate the scale and zoom.

Calculate the following:

\[
\frac{20 \times 5280 \times 12}{100000} = 12.67
\]

Your frame needs to be 12.67 inches wide. If your printer is not large enough to handle this, change your layout size to spread over two pages.

- For more information, see Creating a Simple Scale Bar in the Help System.

**Cloning a Map View**

You can create a second view of your map with the Clone View command. Clone View creates a duplicate Map window that you can then alter to create a different view of your map, for example, a street map of a city and a zoomed in view of a major intersection, or use a different kind of thematic analysis for each view. It is particularly useful when you are creating a layout and you want to present side-by-side views of the same location.

**Note:** Cloned windows in a workspace are written as MapBasic commands to the .WOR file. These command statements cannot exceed 32,000 bytes.

Now that you have completed your professional looking layout, printing is a simple matter.
Creating a Legend for your Map

You can create a legend for the map layers in your Map window (with the exception of raster layers). The legend you create displays in a Legend Designer window where you customize the elements of the legend to enhance your map presentation. Also, the Legend Designer window offers alignment tools. To learn about map legends and the Legend Designer window, see What is a Legend? and About the Legend Designer Window.

To quickly get started and create a map legend for your map, see Creating a Map Legend.

If after creating a map legend, you want to customize it by changing a map legend's titles, list text, and font styles, then see the sections under Customizing the Contents of a Legend Frame in the Help System.

What is a Legend?

A legend is the key to understanding what the symbols mean on a map. It takes the form of a list containing color-coded symbols and their descriptions. You will most often find it positioned near the edge of or in a corner of a printed map, and it is sometimes accompanied by a scale bar (see Adding a Scale Bar to Represent Map Scale). A map shows real-world boundaries, artifacts, and features and any data associated with these that you wish to show. It generalizes this information to make it easier to understand the information being shown.

After designing your map presentation, you will want to design a legend to help your readers understand what they are looking at. The following example shows a map with two legends: one for map symbols and one for the ranged theme.

This map layout includes a legend for the map symbols of points and stars, and a legend for the ranged theme of color-coded style swatches.
You can create a legend for an individual layer, giving it particular emphasis, or you can place legends for several layers in one Legend Designer window (see About the Legend Designer Window). You can add map legends to a map layout when you are preparing the presentation of your map for print or electronic distribution.

For instructions, see Creating a Legend in the Help System.

Creating a Map Legend

Creating a map legend is easy. When you select the Create Legend option from the Map menu it launches the Create Legend wizard, which steps you through the process. The wizard has three screens; the second and third screens provide customization options, and are optional. You can select to customize a legend when you are creating it, in the second and third screens of the Create Legend wizard, or afterwards from the Legend Designer window.

There is no size limitation on a map legend. However, there is a size limitation of 1600 rows for a legend frame, which ensures that it does not slow resizing the Legend Designer window. A message displays to warn you when a legend frame list is truncated to 1600 rows.

To create a map legend:

1. Make sure your Map window is active and click Map > Create Legend.
2. in the Create Legend Choose Layers screen, select the map layers to include in the legend.

   All the layers in your Map window are included in the Legend Frames box by default, so that they will be in your legend. Use the Remove button to exclude layers from the legend.

   The legend will have one frame for each layer in the Legend Frames box. The frames display in the order that they appear in the list. Use the Up and Down buttons to change the order.
**Note:** A layer must contain style attributes to appear in the Legend Frames list; therefore, raster layers are not included in the list.

3. Click **Finish** to create the Legend.

The Legend Designer window opens with legend frames for each layer that you chose to include in the legend. Legend frames will display default settings for their titles and symbol style names will be the same as those on the map layer.

**About the Legend Designer Window**

The Legend Designer window displays the legend for each layer in your Map window. You can create an individual Legend Designer window for each layer in your map, or you can have several map legends in one Legend Designer window. When creating a map legend, you get to choose the map layers that you want to include.

Each legend, within the Legend Designer window, is enclosed in a frame. A legend frame is another way to refer to a particular layer’s legend. The properties for each legend frame can be edited individually, such as the legend title and subtitle, row text, and font.

Each Map window can have one or more Legend Designer windows, which are not shared with any other Map window. The Legend Designer window gives you control over the design of the legend for your map: it provides controls, in the form of a grid and guidelines, to accurately set the alignment of the contents of the legend; it offers a zoom feature, so you can see a more detailed view of the contents; it lets you add titles for each legend frame; and you can set the text and font styles in each legend frame.

Legend frames are added in a top down fashion (portrait option when creating a legend) or from left to right (landscape option when creating a legend). This organization is maintained when adding or removing legend frames, so that there are no spaces between the frames. Once you begin moving legend frames in the Legend Designer window, the automatic arrangement is no longer preserved and you must position frames appropriately to remove gaps between them.

**Legend Designer Window Toolbar**
The Legend Designer window includes a toolbar of buttons with options that apply to the legend frames in the window.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Refresh</td>
<td>Click to redraw the contents of the window after changing the sample styles.</td>
</tr>
<tr>
<td>Zoom Designer Area</td>
<td>Select a zoom level (in paper units) from this list to view the contents of the window in, or type a zoom value and press Enter. The zoom value must be between 25 and 800.</td>
</tr>
<tr>
<td>Modify Thematic Map</td>
<td>Opens the Modify Thematic Map dialog box for changing thematic display properties. This button enables after selecting a legend frame in the Legend Designer window.</td>
</tr>
<tr>
<td>Toggle Grid Lines</td>
<td>Shows or hides an equally spaced grid of lightly marked lines to align legend frames to.</td>
</tr>
<tr>
<td>Change Grid Size</td>
<td>A slider bar that changes the size of the grid to make it smaller or larger.</td>
</tr>
<tr>
<td>Snap / Toggle Snap to Grid</td>
<td>Check this box to enable snapping to the grid. Uncheck to disable snapping to grid.</td>
</tr>
<tr>
<td>Add Vertical Guidelines</td>
<td>Adds a guideline to the Legend Designer canvas for aligning legend frames along their left or right sides.</td>
</tr>
<tr>
<td>Add Horizontal Guidelines</td>
<td>Adds a guideline to the Legend Designer canvas to align the tops or bottoms of legend frames.</td>
</tr>
<tr>
<td>Snap to Closest Left Guideline</td>
<td>Aligns all selected legend frames to the nearest guideline located to the left of the legend frame.</td>
</tr>
<tr>
<td>Snap to Closest Right Guideline</td>
<td>Aligns all selected legend frames to the nearest guideline located to the right of the legend frame.</td>
</tr>
<tr>
<td>Snap to Closest Top Guideline</td>
<td>Aligns all selected legend frames to the nearest guideline located above the legend frame.</td>
</tr>
</tbody>
</table>
### Snap to Closest Bottom Guideline

Aligns all selected legend frames to the nearest guideline located below the legend frame.

### Legend Designer Menu Options

Creating a legend places a Legend Designer menu on the menu bar. This menu is only visible when the Legend Designer window is active and includes the following options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Frames</td>
<td>Opens the <strong>Add Frames</strong> wizard where you can select map layers that you want to add to the map legend on display in the Legend Designer window. You can also set unique attributes for the legend frame for each map layer that you add.</td>
</tr>
<tr>
<td>Add Text Frame</td>
<td>Opens the <strong>Text Frame Properties</strong> dialog box where you can add text to display in the legend; this can be text for a title, subtitle, or description of the contents of the legend for example. You can include carriage returns in the text.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Opens the <strong>Refresh Legend</strong> dialog box where you can specify how you would like to redraw the contents of the Legend Designer window: by refreshing styles, or changing a classic layout to be portrait or landscape.</td>
</tr>
<tr>
<td>Remove All Guidelines</td>
<td>If there are guidelines visible or hidden (enabled or disabled) in the Legend Designer window, then selecting this option removes all of them.</td>
</tr>
<tr>
<td>Properties</td>
<td>If there is a legend selected in the Legend Designer window, then this option opens the <strong>Legend Frame Properties</strong> dialog box, which allows you to modify the legend frame. For a theme legend, it launches the <strong>Modify Thematic Map</strong> dialog box. If there is no legend selected in the Legend Designer window, then this option is disabled.</td>
</tr>
</tbody>
</table>

### Legend Designer Right-Click Context Menu Options

Right-clicking in the Legend Designer window displays the previously listed options along with the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable/Enable Guidelines</td>
<td>Hides or shows guidelines in the Legend Designer window and disables or enables the guideline toolbar buttons.</td>
</tr>
</tbody>
</table>

In addition to these buttons there is also a **Snap** checkbox, which turns snapping to grid lines on or off, and a **Zoom** level drop-down list, where you select to zoom in or out of the Legend Designer window view.
About Hidden Legends

Thematic legends may be shown or hidden in the Customize Legend dialog box, which is accessed by selecting Map > Modify Thematic Map.

Hidden legends are not persisted to workspaces. If a Legend Designer window has all its legends hidden it will not be saved to a workspace (WOR).

Printing and Exporting Your Results

This section covers the printing and exporting options in MapInfo Pro.

Printing Your Project

When you need to create presentation materials, you can print out the MapInfo Pro layouts you have created.

Page Setup

First check that your page setup is what you want. Any changes to the page setup will likely affect the layout, so it is a good idea to view the effect of the changes on your layout before printing. On the File menu, point to Page Setup. Here, you can specify the page orientation (portrait or landscape) and margins. You can also specify the paper size and its source.

In addition, you can override your default printer setting and choose a different printer for this print job. Click the Printer button to open the Page Setup dialog box for your printer. The printer that initially displays is the default printer that you set in the Printer preferences (on the Options menu, point to Preferences and click Printer). This will either be the Windows default printer, or the MapInfo Pro preferred printer that you selected. Make any changes you want to the printer and its properties, and click OK. The settings available in the Printer Properties dialog box will vary according to the printer you are using.

Printing Options

Changes you make to these settings override the default settings from the Output Preferences.

When you are ready to print:

1. Make sure the layout window is active. On the File menu, point to Print to open the Print dialog box.
2. Choose the number of copies you want to print and whether you want all pages or a specific range of pages to print. As in the Page Setup dialog box, the Print dialog box also allows you to override the default printer settings.

3. Click the Name drop-down list in the Print dialog box to select a printer. All of the printers available on your system display in the list. You can specify printer properties here as well, plus specify whether to print to a file.

4. To use the advanced print settings to take advantage of additional output options that help you control transparency and color, particularly for raster images, click the Advanced button. The Advanced Printing Options dialog box displays.

![Advanced Printing Options](image)

a. Select from the Output Methods to print your layout to:

   **Print Directly to Device** - Click this option to print your image file directly from MapInfo Pro. This check box is checked by default.

   **Print Using Enhanced Metafile (EMF)** - Use this option to generate an enhanced metafile of your MapInfo Pro image before sending it to the printer. This option takes advantage of current technology to shrink the spool size and print your file quicker without sacrificing quality. When printing to PDF, selecting this option generates a flat, non-layered, PDF file.

   **Output Method/Print Using Offscreen Bitmap (OSBM)** - Click this option to generate an offscreen bitmap of your MapInfo Pro image before sending it to the printer. Offscreen bitmap is invoked depending upon the type of translucent content in the map and enhanced rendering state of the window. However, setting OSBM from this window means that while printing Offscreen bitmaps (OSBM) will be selected regardless of the translucency and anti alias settings.
b. Indicate how you want to handle transparency. If you have transparent vector fill patterns and symbols, check the Internal Handling for Transparent Vector Fills and Symbols box to have MapInfo Pro handle the transparency internally.

If you are using transparency in a raster image, clear the Use ROP Method to Display Transparent Raster box to have MapInfo Pro handle the transparency internally. The image will be broken down into small rectangular regions that do not contain transparency. It is recommended that you check this option because printers do not always handle transparent raster images correctly. This method may produce large plot files.

c. If you are using 24-bit, true color raster images, select the Print Raster in True Color When Possible check box, and select a dither method from the Dither Method list.

Note: The Print Border for Map Window check box is not available for layout windows. You can control the border for each frame by selecting the frame and setting by selecting the Options menu, clicking Region Style.

d. Click OK to return to the Print dialog box.

5. Click OK to print.

More and more often, users want to export their maps electronically to files rather than print them.

Exporting a Layout

The easiest way to make electronic copies of maps and layouts from MapInfo Pro is to use the Save Window As command, which is on the file menu. You can export to a variety of formats.

There are software preferences that give you advanced export options to produce better quality output. These preferences are set on the Options menu by pointing to Preferences and clicking Output Settings. Under the Exporting tab, select your window export settings. The same transparency and raster options are available when you print your layout as when you export the layout.

For more information, see Setting your Output Setting Preferences in the MapInfo Pro Help System and Exporting Your Layout.

Save Window As Supports Raster Formats

You can save your map images as GIF, TIFF LZW, and TIFF CCITT Group 4 images.

To save your data as a raster format:
1. Open a Map, Layout, Layout Designer, Browser, or Graph window that you want to save in the new format.
2. On the File menu, point to Save Window As to open the Save Window to File dialog box.
3. Select the type you want to save it in from the Save as type drop-down list.
   • GIF
• TIFF LZW
• TIFF CCITT Group 4

4. Type the name of the file in the **Filename** field and click **Save** to save your entries.

*Creating an Encapsulated Postscript File*

If the available Save Window As formats are not appropriate for your needs, or you want to use the options in a classic Layout window, then you may want to send your output to an encapsulated postscript (EPS) file. This file type is widely used by service bureaus and print shops. There is not a set export or save command for EPS files. You must set up a postscript printer driver and print the map or layout to a file.

1. From the Windows Control Panel, select **Printers**.
2. In Printer Setup choose **Add Printer**. The Add Printer Wizard displays.
3. Follow the wizard for the setup. Choose a postscript printer from the printer list, and select FILE as the available port. Enable the option to specify EPS.
4. Once the postscript driver is installed on your system, use that printer to print the map or layout to a file from MapInfo Pro.
5. From the **File** menu, select **Print**. The **Print** dialog box displays.
6. Under printer name, select the postscript printer. Click **OK**.
7. The **Print to File** dialog box displays. Give your file a name and choose **Save**.

*Smoothing the Edges of Images during Export*

To give you more control over map images when exporting MapInfo Pro maps, you can use anti-aliasing methods. This is particularly important when you are saving maps created in MapInfo Pro for use in other Windows-based applications, in particular in slide presentations or for web pages.

We have added the ability to smooth or anti-alias images during the export process. You can use this capability with all types of windows such as Map windows, layouts, legends, and graphs.

**Note:** You cannot anti-alias images you are exporting to .EMF or .WMF format, because these are not true raster formats.

There are three smoothing options you can use to customize your raster image:

1. **Smooth using a Filter value.** You can set a flag that selects one of six filters that allow you to choose the direction the filter is applied to the image from.
2. **Smooth using a Mask value.** You can select a value that indicates the size of the area you want to smooth. For example, to create a 3x3 pixel mask value, you would enter a 3 in this field. This would limit the amount of change in the color of the pixels. Typically mask sizes would be 2-3 pixels when exporting at screen resolution. If you are exporting at a higher resolution, a larger mask might be appropriate.
3. **Smooth using a Threshold value.** You can select a threshold value to indicate which pixels to smooth. Each pixel in an image has a value based on its color. The smaller the pixel value, the
To set the anti-aliasing preference for exporting images:

1. From the **Options** menu, select **Preferences** and **Output Settings** to display the **Output Preferences** dialog box.

2. Click the **Exporting** tab to display the anti-aliasing options.

3. To use anti-aliasing automatically, select the **Use Anti-aliasing** check box and select from these options:

   - **Smooth using a Filter value** - Choose a filter for the smoothing you want to use. Select from these filters:
     - Vertically and Horizontally (Smoothes the image vertically and horizontally)
     - All Directions (1) (Smoothes the image in all directions)
     - All Directions (2) (Smoothes the image in all directions using a different algorithm)
     - Diagonally (Smoothes the image diagonally)
     - Horizontally (Smoothes the image horizontally)
     - Vertically (Smoothes the image vertically)

   - **Smooth using a Mask value** - Choose the pixel size of the mask you want MapInfo Pro to use in this field. For example, to create a 3x3 pixel mask value, you would enter a 3 in this field. This would limit the amount of change in the color of the pixels to the three pixels around the basic pixel.

   - **Smooth using a Threshold value** - Select a threshold value to indicate which pixels to smooth. Colors are 0 for black and 255 for white (in an 8 bit image). Entering a low number changes the look of your map by smoothing the darker colors and the lighter colors. Choosing a higher number changes the way the lighter colors display.

To set the anti-aliasing options locally during export:

1. When you have completed your work on a window, select the **File > Save Window As** menu option. The **Save Window to File** dialog box displays.

2. Type the name and indicate the path of the file you are saving in this dialog box. Click **Save** to continue. The **Save Window As** dialog box displays.
If you are exporting an EMF or WMF image, the **Use Anti-Aliasing** check box is disabled.

3. Select the **Use Anti-aliasing** check box and do one of the following:

- Click **Save** to use the anti-aliasing options you selected in the **Output Preferences** dialog box.
- Click **Advanced** and choose new anti-aliasing options for this particular map. Click **OK** to return to the **Save Window As** dialog box. Click **Save** to save these settings and the file.

**Note:** If you do not select the **Use Anti-aliasing** check box, the anti-aliasing options in the **Advanced Exporting Options** dialog box are disabled.
13 - Registering Raster Images

Raster images can provide context to your maps by giving them detail and definition. This chapter reviews the details of registering and working with raster image files.

In this section

Working with Raster Images 414
Opening a Raster Image 417
Printing/Exporting Translucent Raster Images 423
Working with Raster Images

There are a number of ways you can obtain raster image files. If you have a scanner and scanner software, you can use the scanner to create raster image files. MapInfo Pro can read and display the raster image files created with the scanner software.

Some graphics software packages let you save or export images into raster file formats, such as TIFF (Tagged Image File Format). So if you can create a TIFF file with your draw or paint package, you can display it in MapInfo Pro.

You can also purchase raster images from MapInfo Pro or other commercial vendors. Some data vendors also offer scanning services.

Determining Map Coordinates

When registering your raster image, you need to know the map coordinates that correspond to your image. If your raster map image shows a graticule (a grid of longitude/latitude lines), you can determine map coordinates by noting the longitude/latitude labels along the graticule.

If your map does not show a graticule, you may be able to determine map coordinates by locating prominent map features, for example, the Northwest corner of a region, and then using another MapInfo Pro table as a reference to determine the coordinates of those prominent features.

For a discussion of this process, see Choosing Control Points from an Existing Map in the Help System.

An Introduction to Raster Image Registration

What Is a Raster Image?

A raster image is a type of computerized image that consists of row after row of tiny dots (pixels). If you have a scanner and scanner software, you can create a raster image by scanning a paper map. After you scan a map image and store the image in a file, you can display the file using MapInfo Pro.

There are many different raster image file formats. MapInfo Pro can read the following types of raster image files: JPEG, GIF, TIFF, PCX, BMP, TGA (Targa), and BIL (SPOT satellite).

What Does It Mean To Register a Raster Image?

When you register a raster map image, you enter map coordinates (e.g. longitude/latitude degrees), and you indicate which locations on the raster image correspond to those coordinates. You must register each raster image before displaying the image in MapInfo Pro, so that MapInfo Pro can perform geographic calculations, such as distance and area calculations, when displaying the raster map.
The first time you open a raster image file within MapInfo Pro, MapInfo Pro displays the Register Raster Image dialog box. By completing this dialog box, you tell MapInfo Pro how to register the raster image and determine the coordinate system for the image. MapInfo Pro stores the raster image’s registration information in a table file for future re-use. The next time you run MapInfo Pro, you can re-open the raster table without repeating the registration process. Thus, you only need to register each raster image once.

Raster image files provided by MapInfo Pro are already registered. You do not need to perform the registration process when you display the sample raster data included with MapInfo Pro.

Understanding Raster Images in MapInfo Pro

Using raster image files, you can bring paper maps, photographs, and other graphic images into MapInfo Pro. For example, if you work with paper maps, you probably want to use those paper maps as the foundation for the maps you create in MapInfo Pro. Once you scan your paper map into a raster image file, you then can display it in a Map window.

Using Raster Images as a Backdrop for MapInfo Pro Maps

Using a raster image as the base layer of your map gives you a detailed backdrop for your other map layers. You can easily change the size, scale, or center point of the displayed image. For example, if you want to enlarge part of the image, use the Zoom-in tool. Keep in mind, however, that as you increase the image’s size, the display will become grainier if you exceed a 1-1 pixel ratio. Each pixel in the image becomes more distinct, causing the image to look more like a series of blocks instead of the intended picture.

Using Raster Images as a Stand-Alone Image

You may have a satellite image of topography that would be impossible to duplicate as a vector image that you want to use for a presentation. You can display the image in MapInfo Pro and then incorporate it into a page layout.

Map Editing with Raster Images

Once you have superimposed map layers on top of your raster image, you can use the raster image as a reference while you edit your map layers. The process of editing based on a screen image is known as heads-up digitizing. (To minimize image distortion, only digitize from map images with known projections or rectified aerial photographs.)

Placing a Logo on a Page Layout with Raster Images

Most raster images displayed in MapInfo Pro are images of paper maps or aerial photographs, but almost any image can be scanned and made into a raster image. For example, with an image like your company logo, you can open and display the raster file in MapInfo Pro without registering it because control point coordinates are irrelevant. You can then place it in a frame in a layout window and incorporate the logo into your page layout.
Raster Image Format Details

There are many different raster image file formats. MapInfo Pro can read the following types of raster files:

- `filename.ADF` (ArcInfo coverage Data File)
- `filename.ASC` (ASCII text file)
- `filename.BIL` (SPOT satellite images)
- `filename.BMP` (Windows bitmap)
- `filename.*` (CADRG format)
- `filename.*` (CIB format)
- `filename.ECW` (ECW 2.0 format handler)
- `filename.EMF` (Enhanced Metafile format)
- `filename.FLT` (Image Filter)
- `filename.GEN` (ADRG format)
- `filename.GEN` (ASRP 1.2 format)
- `filename.GIF` (Graphics Interchange Format)
- `filename.JP2` (JPEG 2000 format)
- `filename.JPG` (JPEG format)
- `filename.NTF` (NITF format)
- `filename.PCX` (ZSoft Paintbrush)
- `filename.PNG` (Portable Network Graphics format)
- `filename.PSD` (Photoshop 3.0)
- `filename.SID` (MrSID format)
- `filename.TIF` (Tagged Image File Format)
- `filename.TXT` (Text)
- `filename.TGA` (Targa)
- `filename.WMF` (Windows Metafile format)

For a complete list, see the Raster image file formats MapInfo Pro supports at MapInfo Pro Data File Support.

MapInfo Pro also supports:

- Map Tile Server raster images. For more information, see Enhancing Map Data using a Mapping Tile Server.
- AirPhotoUSA raster images taken at different elevations for particular areas in the United States. The AirPhotoUSA map handler allows MapInfo Pro users to open and display the imagery contained in AirPhotoUSA Map files as a layer. MapInfo Pro treats these images like any other raster file. The MAPINFOW.PRJ file has been updated to accommodate the AirPhotoUSA changes.

Note: The maximum supported raster image varies by raster handler.

ARC Grid Format Support
MapInfo Pro uses the Arc Grid Handler to use and display of ESRI grid files. You will see the file extension options in the Open Table dialog box when you choose the Files of Type option Grid Image. This allows you to open both ASCII and Binary Continuous and Classified grid formats but you can only hillshade the Continuous grid files. These types of data files are available from the USGS Seamless Data Distribution System.

**Note:** The Arc Grid Handler does not support the Arc Grid Export format (*.e00 extension) in MapInfo Pro.

- For more information, see Color Options for Raster Images in the Help System.

### Opening a Raster Image

When you open a raster file you need to register it to identify coordinate point references for the image. Using a vector map as a reference, you identify the coordinates of the vector map and match them with equivalent points on the raster image. This coordinate information allows MapInfo Pro to determine the position, scale and rotation of the image so that you can overlay vector data on top of the image. The coordinate information is stored in a TAB file created during the registration process. The TAB file enables you to re-open the raster file in MapInfo Pro format.

You usually register the image the first time you open it. However, you do not need to register the image if you do not plan to use vector data with it, or if it already contains georegistration information.

Raster images usually fall into one of three categories:

- **A fully registered image**, containing control points and a projection (for example, GeoTIFF file).
- **A partially registered image** containing control points, but missing a projection (for example, an image with an associated World file).
- **An unregistered image** missing control points and a projection.

Once the image is registered, opening it again requires a slightly different procedure. Opening both unregistered and registered images is explained in the next section.

For more information, see these related topics in the Help System.

- Opening a Registered Raster Image
- Opening an Unregistered Raster Image
- Opening a Georeferenced Raster Image

### Registering the Coordinates of a Raster Image

Before you can overlay vector data on top of a raster image, you must first register the raster image so that MapInfo Pro can position it properly in a Map window. In the Image Registration dialog box, you can identify control point coordinates and specify the appropriate projection for the raster image.
Control points are the coordinates you identify on the raster image that MapInfo Pro can use later to match up to other layers. It is very important to provide accurate control point information when registering a raster image, so MapInfo Pro can display raster images without distorting or rotating them. Later, when you overlay vector data, MapInfo Pro distorts and rotates the vector data so both layers can line up properly. Identifying significant control points makes this match up process easier. We suggest you use highway/street intersections and prominent landmarks as control points, as they rarely move.

Specifying the correct projection of the raster image is also important for accurate display. Images that do not have known projections, such as unrectified aerial photographs, are less suitable for use with vector data.

There are two ways to register a raster image in MapInfo Pro. Each involves specifying the map coordinates of control points on a reference map and matching them with equivalent points on the raster image. To determine map coordinates, you can:

- Identify a point's coordinates from the paper map.
- Determine a raster images control point coordinates on screen and automatically transfer the information to the Image Registration dialog box.

**Note:** If you scanned in the image from a paper map, the map most likely contains a graticule (latitude and longitude grid). You can choose those coordinates for prominent features and enter them in the Image Registration dialog box.

- For specific instructions, see Registering the Coordinates of a Raster Image and and Choosing Control Points from an Existing Map in the Help System.

### Reprojecting a Raster Map

From time to time, you will need to use a raster map registered in one projection in another map in different projection. You can reproject the raster image, that is, change the coordinate system and the way the raster image displays to accommodate the new vector map. Typically, the open map dictates the projection of the successively displayed images. You can also reproject the raster using the projection of a vector table.

**Reprojecting a Raster based on a Vector Map**

If you are working with registered raster data such as satellite and aerial photo images, scanned maps, grids, seamless tables and WMS data, you might want to reproject that raster data to accommodate a vector map.

MapInfo Pro performs the raster reprojection when you open a registered raster image inside of an existing Map window with a different projection or when you change the projection of a Map window. During the raster reprojection process, MapInfo Pro recalculates the pixel values of the source image to make them display correctly in the destination image. In this resampling process, MapInfo Pro tries to restore every pixel value of the image based on the pixels around it. In MapInfo Pro there are two methods for calculating the pixel values of the destination image: Cubic Convolution and
Nearest Neighbor. These are industry-standard terms used by GIS professionals all over the world. These methods are described later in this section.

Due to this feature, these are the precedence rules for Map window projection.

Both vector and raster layers have "equal rights", that is, every new layer (without regard for type) is reprojected into the current Map window's projection. That is, which ever map is opened first takes precedence for projection.

**Note:** You can change the projection of a Map window containing a mix of raster and vector layers by setting the image processing reprojection preference to Always or Optimized.

MapInfo Pro does not let you change the projection or image processing/reprojection of a map that displays raster images from a tile server, because this would create inaccuracies in your map. The projection system of the data may vary between tile servers. For this reason, we do not recommend displaying tiles from different tile servers in the same map unless the tile servers use the same projection system.

When you are working with palette raster images (like a scanned map), an image might contain all 256 colors. If you display this image in the Adjust Image Styles dialog box and clear the Transparent check box, the color "white" becomes transparent. If you do not want this display behavior, select the Transparent check box and choose another transparent color (using Select Color).

### Transferring Vector Map Coordinates Directly to a Raster Map

To transfer the coordinates automatically from a vector map to a raster image, you need a vector map of the same image. Then, you display the vector map side by side with the Image Registration dialog box, which shows a preview of the raster image. Click a prominent feature in the vector map to determine its coordinates and transfer this control point to the Image Registration dialog box.

To transfer a vector map's coordinates to a raster image:

1. On the File menu, click Open and Raster Image file format.
2. Choose the raster image file and click Open. The Display/Register dialog box displays.
3. Click Register. The Image Registration dialog box displays. A preview of the raster image appears in the lower half of the dialog box.
4. Choose the Projection button to specify the image's projection. If you do not set the projection, MapInfo Pro defaults to Longitude/Latitude or to the default table projection set in the Map Window Preferences.
5. To add control points, click the Add button to add a control point entry to the Control Points list.
6. Click the Pick from Map button and select a location in the Map window that matches a location in your raster image. MapInfo Pro updates the Map X and Map Y fields in the Edit Control Point dialog box with the new coordinates. Click OK to save this entry and close the dialog box.

**Note:** When the Pick from Map button is disabled, you can select locations directly from the open map. If a map is not open, you can select another tool (like the Select tool) and use that tool instead of the Pick from Map functionality.
7. Highlight the entry in the Control Points list and click the matching control point location in the image pane. The Edit Control Point dialog box displays showing the control point’s location in pixels in the Image X and Image Y fields. Click OK to save these entries.

   **Note:** Remember to type a meaningful description of this location in the Label field.

8. Repeat this process until you have identified three or four non-linear points in the preview pane of the Image Registration dialog box.

9. After you have defined all of the control points, click OK in the Image Registration dialog box. The raster image displays in the Map window under the vector layer.

   Use the Layer Control feature to position the raster map appropriately with your vector layers.

10. For details on converting degree/minutes/seconds coordinates to decimal degrees, see the Help System.

**Modifying Control Points for Raster Images**

If you must adjust the coordinates of a control point because the error is unacceptable, highlight the point in the Image Registration dialog box and choose another location for it in the Map window. To delete control points, click the point and choose the Delete button.

**Raster Image Display Options**

You can display more than one raster image in a window at a time. This is limited only by your computer’s memory. However, if you want to digitize from the raster image, it is best to use only one image in a Map window. This is because two raster images will probably have slightly different rotations.

When using two raster images with different projections, keep in mind that MapInfo Pro will use the projection of the image that is opened first. This means that the second image is only positioned approximately.

**Color (Raster Image)**

Once you have displayed a raster image file in a Map window, you can make adjustments to the colors in the image. From the Table menu, select to Raster and click Adjust Image Styles to change the settings for that .tab file. From the Map menu, select Layer Control. Double-click the layer to display the Layer Properties dialog box. On the Layer Display tab, check the Style Override check box and click the Style button to adjust the raster style only in this Map window.

The Adjust Image Styles dialog box lets you set the contrast and brightness of the image, set translucency, display color raster images in shades of gray, and make one color in the image transparent.
Using the **Adjust Image Styles** dialog box does not modify the raster image file; instead, it changes the way MapInfo Pro displays the raster image file. If you change an image's display style, MapInfo Pro records the new display style in the table file (for example PARCELS.TAB) or in the workspace for per layer styles, but MapInfo Pro does not alter the contents of the raster image file (PARCELS.GIF) in any way.

If you change an image's display style and choose **OK**, the new display style is applied immediately. It will also affect all Map windows in which the image is displayed if you select the **Table** menu, and point to **Raster** and click **Adjust Image Styles**. You do not need to choose **Save** to save the changes.

**Style Override for Raster Images**

MapInfo Pro provides the ability to change the display style for raster and grid images on a per-layer basis through the Layer Control window. The **Style Override** option for raster images works the same way as it does for other map layers. Just choose the **Map** menu, and click **Layer Control**, and select a raster layer in the Layer list. Click the **Layer Properties** button. The **Layer Properties** dialog box displays. On the Layer Display tab, select the **Style Override** check box and click the **Style** button. The **Adjust Image Styles** dialog box displays. You can change any of the raster image style settings.

**Zoom Layering for Raster Images**

Zoom layering for raster images controlled from preferences (in the **Options** menu, point to **Preferences** and click **Map Windows** and select **Automatic Raster Zoom Layering**). To change
the zoom layering setting for a raster layer that you are currently working with, go to the **Layer Properties** dialog box (from the *Map* menu, select **Layer Control**, select the layer and click the **Layer Properties** button) and to either activate or turn off zoom layering. The setting is turned on by default.

**Limitations in Using Raster Images**

Many of MapInfo Pro's features cannot be applied to raster image tables. As a general rule, you cannot use MapInfo Pro to modify a raster image file. Specific limitations of raster tables include:

- **No Data Saved with Raster Images**: A raster table does not have columns, therefore, you cannot attach text or numeric data directly to a raster table, and you cannot perform queries, such as *Find*, on a raster table. You can, however, overlay a conventional (vector-based) MapInfo Pro table on top of the raster image, and attach data to the conventional table.

- **Map Projections and Reprojections with Raster Images**: When a raster image file displays in a Map window, the file that is opened first determines the projection of the map. If two raster images in a Map window use different map projections, MapInfo Pro will use the projection of the map that is opened first. The Map window will redraw slowly when you overlay other map layers on top of a raster image. The map redraws slowly because MapInfo Pro is re-calculating map coordinates so that the vector map objects conform to the projection of the raster image.

**Adjusting the Contrast or Brightness of a Raster Image**

The **Adjust Image Styles** dialog box lets you control how a raster image appears but does not modify the raster image file; instead, it changes the way MapInfo Pro *displays* the raster image file.

Every raster image table consists of two files: a raster image file (for example, PHOTO.GIF), and a table file (for example, PHOTO.TAB). When you change the image display styles, MapInfo Pro stores the new style settings by modifying the table file. MapInfo Pro does not modify the raster image file in any way.

If you change the display options and choose **OK**, MapInfo Pro stores the new display styles immediately; you do not need to choose **File > Save**.

- For instructions, see *Adjusting the Contrast or Brightness of a Raster Image* in the Help System.

**Adjusting the Translucency of a Raster Image**

You can adjust the percentage that layers show through raster images. A translucent image allows you to partially see through the image. Translucent images can be layered on top of other layers so that the lower layers are partially visible through the image.

- For specific instructions, see *Adjusting the Translucency of a Raster Image* in the Help System.
Printing/Exporting Translucent Raster Images

When printing or exporting a translucent raster image, take advantage of Advanced options.

To print a translucent raster image:

1. Do one of the following:
   • On the File menu, click Print
   • On the File menu, click Save Window As

2. Click Advanced and choose from the following settings according to your printing and exporting requirements.
   • Print/Export Border - Select to include the black rectangle border when exporting.
   • Internal Handling for Transparent Vector Fills and Symbols - Select to allow MapInfo Pro to perform special handling when exporting transparent fill patterns or transparent bitmap symbols. If unchecked, the process is handled by Windows.
   • Use ROP Method to Display Transparent Raster - Use this option to print the raster image as a metafile (EMF or WMF). Using the ROP method allows any underlying data to be rendered in the original form. Select this check box to allow the internal ROP (Raster Overlay by Pixel) to manage the transparent pixels for the raster.

   Since the ROP Method is largely a display method, not all printers and plotters can use it. We recommend that you experiment with this setting until you get the results you want when printing raster images. This check box is cleared by default.

   • Print/Export Raster in True Color When Possible - Select this check box to print your 24-bit raster images in true color. Make sure your printer settings are greater than 256 colors. This check box is selected by default.

3. When you have completed these selections and returned to the Print dialog box, click OK to begin printing.
14 - Putting Your Data on the Map

As we saw in Data - Where MapInfo Pro Begins, you can convert your existing data to a format that MapInfo Pro can use to display it on a map. Now you are getting somewhere! But how does MapInfo Pro know where to put the information on a map? That is the subject of this section.

In this section

- How Do I Get My Data on the Map? 425
- Displaying your Excel (.XLS or .XLSX) Data 427
- Displaying your Access (.MDB or .ACCDB) Data 428
- Displaying your SQLite Data 429
- Displaying your Comma Delimited CSV Data 431
- Displaying your dBase Data 432
- Displaying your Lotus 1-2-3 Data 433
- Displaying your ESRI Shapefile Data 433
- Registering and Displaying your ASCII Data 435
- Importing and Displaying GML File Data 436
- Using Universal Data Directly 437
- Opening MapInfo Pro Grid Files 441
- Importing Graphic Files 441
- Geocoding - Assigning Coordinates to Records 441
- Putting Latitude/Longitude Coordinates on a Map 453
- Displaying Your Data on the Map 455
- Printing Your Results 458
How Do I Get My Data on the Map?

There are three steps to putting your organization's data on a map:

• Creating a MapInfo .tab file of your data
• Geocoding or creating points for the data
• Displaying your points on a map

Creating a MapInfo .tab File of Your Data

The first step in using your data in MapInfo Pro is to create that .tab file from your data. This process takes the data you have created (either a spreadsheet or database) and extracts the information into a .tab file that MapInfo Pro can use. Your data remains intact as we go through this process. The process that MapInfo Pro uses depends upon the type of format your data is in. You can create a MapInfo table of the following data file format types:

• Microsoft Excel (.XLS or .XLSX)
• Microsoft Access (.MDB or .ACCDB)
• SQLite (.SQLITE)
• d-Base (.DBF)
• Lotus 123 (.WKS, WK1)
• ASCII (.TXT)
• Comma Delimited files (.CSV)
• RDBMS (Oracle, SQL Server, PostgreSQL with PostGIS)
• XML (Web Map Service)

For database versions that MapInfo Pro supports, see the MapInfo Pro Install Guide.

Note: The process for creating a .tab file from ASCII data is called "registering" instead of creating because we are actually making a series of pointers to the ASCII data. The process is different but your resulting files behave the same way.

Once you have a MapInfo .tab file of your data, you need to either geocode or create points for the data. You are then ready to display your data on a map, as described under Displaying Your Data on the Map.

The Help System contains these related topics:

• Displaying your Excel (.XLS or .XLSX) Data
• Displaying your Access (.MDB or .ACCDB) Data
• Displaying your SQLite Data
• Displaying your Comma Delimited Data
• Displaying your dBase Data
When Do I Geocode vs. Create Points?

There are two processes that MapInfo Pro uses to identify and plot your data on a map.

During Geocoding, MapInfo Pro reads data such as street data, postal code data, and other non-coordinate information from your database and matches it against street or postal code information on a MapInfo data table.

During the Create Points process, MapInfo Pro reads X and Y coordinate data (such as longitude and latitude data from a Global Positioning System) and plots data using those coordinates. Use the appropriate process to the type of data you have collected.

For more specific instructions on creating points, see the following topics in the Help System:

• Geocoding - Assigning Coordinates to Records
• Putting Longitude/Latitude Coordinates on a Map

Note: If your data is in non-MapInfo format before you geocode or create points, you must convert it before using either of these processes.

Displaying DBMS and Web Service Data

Displaying Your Remote DBMS Data

The process for displaying spatialized data from Oracle, SQL Server, or PostGIS is different from the tables we have discussed so far. For more information about accessing remote data, see Getting Started.

Note: For database versions that MapInfo Pro supports, see the MapInfo Pro Install Guide.

Displaying and Importing Data from a Web Map Service

A Web Map Service (WMS) is a technology that gives you a source for data over your Intranet or over the Internet. This innovation is based on a specification from the Open GIS Consortium (OGC) and allows you to use raster map images from servers that also comply with the specification. You must specify the coordinate system within your data request to ensure that the images you retrieve "sync up" or register with your other map data.

This specification supports transparent pixel definition for image formats as well. This allows you to use the images you retrieve as overlays and not solely as the bottom layer of your map.
WMS data may not exist for the geography you are looking for. Further, the data that is provided is determined by the WMS server.

**Note:** You must have a working Internet connection to retrieve or use WMS data.

- For instructions on retrieving and displaying data from a Web Map Service, see *Retrieving Map Data from Web Map Services* in the Help System.

### Displaying your Excel (.XLS or .XLSX) Data

You can create a .tab file from an Excel file that is up to 64K in size.

To create a .tab file from your Excel (.XLS or .XLSX) data:

1. In MapInfo Pro on the **File** menu, click **Open** to display the **Open** dialog box.
2. In the **Files of Type** list select (.XLS or .XLSX), navigate to your data, and click **Open**.
3. Select the worksheet you want in your MapInfo data table. Make sure that this data includes either postal codes or longitude/latitude coordinate values.

   The default data range for an Excel file is the entire worksheet.

   - If you select the **Use Row Above Selected Range for Column Titles** check box, the default data range begins at A2 (row 2).
   - If you clear the **Use Row Above Selected Range for Column Titles** check box, both the **Named Range** and **CurrentValue** fields revert to their previous values on the Entire Worksheet.

4. Click **OK** to display the **Set Field Properties** dialog box.

   This dialog box allows you to reset the name, type and properties of any field (column) that you import from the Excel table. The top of the Set Field Properties window shows the Fields (column names) and Type (character, date, etc.) from the Excel spreadsheet. When you select one of these fields, the Field Information box entries at the bottom allow you to specify the field name, data type, number of characters (for character and decimal fields) or number of decimals (for decimal fields only).
If you click **Cancel**, MapInfo Pro cancels the import operation.

5. Click **OK** to convert the data to a MapInfo table (.tab) format. Now that you have converted your data, you can plot your data; see the next section to continue.

The Help System contains these related topics:

- Default Range Options When Importing MS Excel Files and Controlling Treatment of Imported Excel Tables.
- Controlling Treatment of Imported Excel Tables
- Ensuring that Dates Display Correctly for Excel for Macintosh Tables
- Controlling how MapInfo Pro Handles Mixed Data Type Columns
- Putting Longitude/Latitude Coordinates on a Map

### Displaying your Access (.MDB or .ACCDB) Data

To convert your Microsoft Access (.MDB or .ACCDB) data into a MapInfo Pro table:

1. Choose **File > Open**. The Open dialog box displays.
2. Choose Microsoft Access Database from the Files of type menu. The Access databases (.MDB or .ACCDB) for the specified location display.
3. Choose an Access database to open. If security is turned on, you will be prompted to give user and password information to open the database.

4. The **Open Access Table** dialog box displays the tables for the opened database.

5. Choose an Access table or tables to open. The table or tables are opened in MapInfo Pro. (Please note that for a table name with a space such as Order Details can be saved in MapInfo Pro but subsequently will not be visible to MapInfo Pro.)

After you open an Access table in MapInfo Pro for the first time, MapInfo Pro creates a definition for the table and gives it a .TAB extension. This enables you to treat it like any other MapInfo Pro table. For example, to open this file you would now open it like any other MapInfo Pro table.

**Note:** Even though the table has the .TAB extension in MapInfo Pro, your data is still in your original Access database table and is not a duplicate.

The **Help System** contains these related topics:

- **Microsoft Access Table Specifications**
- **Creating an Access Table in MapInfo Pro**
- **Saving a MapInfo Pro Table as an Access Table**
- **Saving an Access Table as Another Access Table**
- **Limitations of Working Directly with Access Tables**

### Displaying your SQLite Data

MapInfo Pro supports SQLite databases through OSGeo FDO Data Access Technology, so that you can work with spatial data stored in SQLite database files. This means that:

- you can display your existing SQLite data on a map in MapInfo Pro;
- you can save your MapInfo tables to your existing SQLite database to take advantage of the capabilities provided by a transactional SQL database engine;
- you can create a new SQLite database from MapInfo Pro;
- you can share spatial data with other applications, such as Autodesk products: AutoCAD Map 3D, Civil 3D, and Autodesk Infrastructure Modeler.

To start working with your data stored in a SQLite database, see **Opening SQLite Tables**.

FDO (Feature Data Objects) is an interface for storing, retrieving, updating, and analyzing spatial data. MapInfo Pro installs an FDO Provider for SQLite (spatial), so that you can work with SQLite database files. The OSGeo FDO Data Access Technology stores geometry data to a SQLite database as FGF (Feature Geometry Format) objects. For more information about FDO, see [http://fdo.osgeo.org](http://fdo.osgeo.org).

MapInfo Pro works with data created in Autodesk products, such as AutoCAD Map 3D, Civil 3D, and Infrastructure Modeler, that has been stored in SQLite database format. You can view this data...
in MapInfo Pro, save changes made to the data, and then continue to work on the data in the Autodesk products.

For background information:

• about SQLite, see http://www.sqlite.org
• about FDO, see http://fdo.osgeo.org

For more information, see the following topics in the MapInfo Pro Help System:

• Mapping FGF Objects in a SQLite Database to MapInfo Objects
• Using a MapInfo Map Catalog with a SQLite Database
• Working with SQLite Tables
• Sharing Data with other Applications

Opening SQLite Tables

MapInfo Pro lets you select which tables in a SQLite database to open, and gives you the option to set display styles, and column and row filters for the tables.

MapInfo Pro works with existing SQLite databases and it lets you create new SQLite databases. You can open a table in a SQLite database and save your edits, and you can save your new or existing MapInfo tables to a SQLite Database (*.sqlite).

To open one or more tables in a SQLite database:

1. On the File menu, point to Open.
2. In the Open dialog box, from the Files of type list, select SQLite Database (*.sqlite).
3. From the Look in list, select the folder location of the database that you want to access.
4. From the files list, select the database to open.
   To select more than one database file in the Open dialog box, press the Ctrl or Shift key while selecting files.
5. Click Open. The Select One or More Tables to Open dialog box opens.
6. In the Database Tables list, select a table to open by adding a check mark beside the table name.
   You can select one or more tables. Only the tables that have a check mark beside them will open.
7. Optionally, select how you want the data to display on the map by selecting (highlighting) the table name and clicking Style.
   This opens the Change Table Object Style dialog box where you can specify the display style for geometry (spatial object types), such as symbols, lines, and regions in the table. The custom styles that you set only apply to the table that you highlighted (whether it has a check mark beside it or not).
   To select more than one table, press Ctrl while selecting table names. Your style choices are made to all of the tables that you select (that are highlighted in the Database Tables list).
8. From the **View** list, select how you want to open the tables.

   Select **New Mapper** or **Current Mapper** to open them in a **Map** window, or **Browser** to open them in a **Browser** window to see the table contents.

9. Click **OK**.

The table, or tables, from your selection open in MapInfo Pro.

If you choose to open more than one SQLite database (.sqlite file) in the **Open** dialog box, then each database opens a **Select One or More Tables to Open** dialog box. Repeat the previous steps for each database.

### Displaying your Comma Delimited CSV Data

You can work with any ASCII file in MapInfo Pro, it must be delimited using a space, tab, comma, or another special character that separates one field from another. Before opening a delimited ASCII file, you must know the delimiter in use and whether or not to use the file's first line as column headings. You can check this by opening the file in any text editor, such as NotePad.

If you are working with a CSV file, it must be comma delimited to open it in MapInfo Pro.

If you want to place the point data in your CSV file on to a map, then follow these instructions to open a CSV file in MapInfo Pro and then proceed to **Putting Latitude/Longitude Coordinates on a Map**.

### Opening Comma Delimited CSV Files in MapInfo Pro

You can open .csv files by selecting the **File > Open** option.

To open a comma delimited file:

1. From the **File** menu, click **Open** to display the **Open** dialog box.
2. In the **Open** dialog box, from the **Files of type** box, select **Comma delimited CSV (.csv)**.
3. Navigate to the folder that contains the file you want to open and click it to select it.
4. If you wish to edit your table in MapInfo Pro, then select the **Create copy in MapInfo format for read/write** check box. This makes a copy of the original file in MapInfo Pro's TAB format and opens the copy to make edits to it.

   If you do not select this check box, then MapInfo Pro opens the original CSV file and you cannot make edits to it.

   **Note:** When modifying the original file, changes are not made to the copy that MapInfo Pro opens. To see changes, you must repeat these steps to open the original file again. If you make changes to the copy, you will not see them in the original file.
5. Click **Open**.

6. In the **Comma Delimited CSV Information** dialog box, select the **File Character Set** for this file from the drop-down list and then select the **Use First Line for Column Titles** check box if applicable.

**Note:** The **Delimiter** option buttons in this dialog box are disabled intentionally because commas are the only expected delimiters in this file format.

7. Click **OK** to open the file.

The file opens in a Browser window. MapInfo Pro creates a .TAB file in the same location and using the same name as the original .csv file.

If you did not select the **Create copy in MapInfo format for read/write** check box, then this .TAB file references the .csv file and its data. If you did select this check box, then the TAB file contains the data from the .csv file and your edits save to the TAB file.

### Exporting to Comma Delimited CSV Format

When you export a table to a comma delimited (CSV) format (select **Table > Export**), a **Comma Delimited CSV Information** dialog box displays. In this dialog box, you can select a new delimiter, choose the file character set, and choose to use the first column in the file for column headings. When you have made your selections, click **OK**.

**Note:** Your column type must be set to **Decimal** with specified precision (number of digits in the number). Other data formats, such as Float, cause your data to truncate and generates an error message that displays after processing the table.

- For more specific instructions on creating points, see *Putting Longitude/Latitude Coordinates on a Map* in the Help System.

### Displaying your dBase Data

When you convert your data to a MapInfo Pro table, you do not in any way change the original data. MapInfo Pro simply creates a conversion table (.tab) of your data.

To open your dBase (.DBF) data into a MapInfo Pro table:

1. On the **File** menu, click **Open** to display the **Open** dialog box.
2. In the **Files of Type** list, select the format (.DBF), navigate to your data, and click **Open**.
3. Select the appropriate character set for your MapInfo data table. Windows U.S. and Western Europe ("ANSI") is the default option.
4. Click **OK** to convert your selected data to a MapInfo table (.tab) format.
5. On the **File** menu, click **Save Copy As** to make an editable copy of your table. Then, on the **File** menu, click **Close Table** and close the original table. Finally open the editable copy.

For more information, see *Saving Data in DBF File Format* in the *Help System*.

### Displaying your Lotus 1-2-3 Data

To open your Lotus (.WKS, WK1) data into a MapInfo Pro:

1. On the **File** menu, click **Open** to display the **Open** dialog box.
2. In the **Files of Type** list, select the format (.WK1,.WKS), navigate to your data, and click **Open**.
3. Choose the worksheet you want to convert to a MapInfo data table.

   **Note:** If there are column headings above each column in this worksheet, select the **Use Row Above Selected Range for Column Titles** check box. Then, select **Other** from the drop-down box and specify the cell range of the data you want to include in the MapInfo Pro table.

4. Click **OK** to convert your data to MapInfo Pro table format.

### Displaying your ESRI Shapefile Data

One of the prominent graphical formats in our industry is the ESRI shapefile.

To open a shapefile in MapInfo Pro:

1. On the **File** menu, click **Open** to display the **Open** dialog box.
2. Select **ESRI shapefile** in the Files of type drop-down list.
3. Navigate to the file's directory and click it to open it.
4. Click **Open** to display the **Please specify a TAB filename** file. This dialog box saves the shapefile into a format that MapInfo Pro can read. The file has the same name as the file you selected but has a .tab extension.
5. Click **Save** to display the **Shapefile Information** dialog box.
6. Select the character set appropriate for this file from the **File Character Set** drop-down list. The default option is Windows U.S. & Western Europe (ANSI), but make your selection based on your local settings.
7. Select the appropriate projection for this file. The Projection field shows the following:

   • If the Shapefile's native projection is found and it matches an entry in the MAPINFOW.PRJ file, the projection's name displays in the Projection field.
• If a native projection is found but it is not in the MAPINFOW.PRJ file, a message displays in this field: **Not found in projection file** and the name of the native projection displays.
• If a native projection is not found, the name of the currently selected table projection preference displays in this field.

Continue with one of the following actions:

• If the application does not detect the Shapefile's native projection, or there is no matching supported projection in the MAPINFOW.PRJ file, click **Projection** to select one and click **OK**.
• If the application detects a supported projection, MapInfo Pro selects the **Use Projection in Source File** radio button and the **Projection** button is disabled. Do one of the following:
  - To use the detected projection, leave **Use Projection in Source file** selected and continue to the next step.
  - To choose a new projection, click **Choose Projection** and click the **Projection** button to select a supported projection. In the **Choose Projection** dialog box, the source projection is highlighted. Select the projection you want and click **OK**.

**Note:** If you substitute the Shapefile's native projection with a new one, the application does not reproject the Shapefile's objects and data using the new projection. Substituting the Shapefile's projection in this way may produce unexpected results.

8. Select the style and cache options for this file.

• **Style** - Select any line or region style overrides that are necessary for this image by clicking the **Style** button. When you select this option, the appropriate style options dialog box displays.
• **Save Object Cache** - Select this check box to save the *.MAP file to hard drive. If you choose not to save the object cache, you will have to recreate the *.MAP file the next time you open the shapefile file. However, if you are going to save the shapefile as a *.tab file, you do not have to select the check box.

9. Click **OK** to create the .tab file and display the Shapefile.

**Note:** If after you open the shapefile in MapInfo Pro, you edit the file in ESRI ArcView and save the file, the contents of the *.MAP and *.DAT files are recreated to retain these edits even if you selected **Save Object Cache** before.
Registering and Displaying your ASCII Data

When you are working with ASCII data in MapInfo Pro, you do not actually create the table as you would in the other file formats we have discussed. MapInfo Pro registers your ASCII table by creating a MapInfo (.tab) file that points to the fields in the original file.

**Note:** Registering your data using MapInfo does not change the original data in any way.

If your delimited ASCII file has an extension other than .TXT (such as .ASC, .CSV, or .DAT, etc.), rename a copy of the file to `<FILENAME>.TXT` before you begin.

To register your ASCII (.TXT) data:

1. Open the data file using Wordpad/Notepad (on the **Start** menu, point to **Programs** and click **Accessories**) or another text editor. See whether you have column headings and what delimiter (character that separates each piece of data from the next) is used in the data file.
2. In MapInfo Pro, open **File** menu and click **Open** to display the **Open** dialog box.
3. In the **Files of Type** list, select the format (.TXT), navigate to your data, and click **Open**.
4. Specify a tab delimiter or type the other delimiter in the field provided.
5. Choose the character set your file is using from the File Character Set drop-down list.

   Select the **Use First Line for Column Titles** check box if you have column headings.

For more information, see *Working with Shapefiles Containing M and Z Values* in the Help System.
6. Click **OK** to register your data in MapInfo Pro.

7. On the **File** menu, click **Save Copy As** to make an editable copy of your table. Then, on the **File** menu, click **Close Table** and close the original table. Finally, open the editable copy. You can only read information from these files.

For more information, see *Working With Spreadsheets* and *Editing Excel and Lotus Spreadsheets* in the *Help System*.

### Importing and Displaying GML File Data

You can import **OSGB MasterMap GML Files** into MapInfo Pro. Each layer in the GML file is imported into a separate .TAB file. We provide support for some of the Topography features (OSGB version 2.0), Topographic Area, Lines and Points, Cartographic Symbols and Boundary Lines. Currently, we maintain support for these features and add support for Cartographic Text and Departed Features.

Currently, we support the OSGB recommended styles by mapping the style definitions to existing MapInfo Pro styles. Where it is not possible to render complicated fill patterns, we use the simple dot screen that the OSGB recommended to us. You cannot change the OSGB style mapping to MapInfo styles.

For more information, see *Importing and Displaying GML File Data* in the *Help System*.

### Importing and Displaying GML 2.1 Files

You can import GML 2.1 files into MapInfo Pro directly. To import successfully, the XML must contain a reference to a valid schema that MapInfo Pro can read. For example, the schema location could be a path relative to the XML file:

```xml
xsi:schemaLocation="http://www.mapinfo.com/wfs_XX .\mi_usa.xsd"
```

Or, it could be a URI:

```xml
xsi:schemaLocation="http://www.lm.se/xml/namespace/abc
http://www2.xxx.se/xml/scheman/abc.xsd"
```

For more specific instructions, see *Importing and Displaying GML 2.1 Files* in the *Help System*. 
Using Universal Data Directly

You can open AutoCAD, Microstation Design, ESRI ArcSDE, Personal Geodatabase and Google Earth KML data directly to avoid having to translate it separately and work with copies of the data in .tab format. This functionality ensures that you will have more flexibility when working with your data.

Pitney Bowes Software Inc. and Safe Software’s, a third-party partner, have worked together to provide this direct way to open and display universal data in MapInfo Pro using a utility called the Feature Manipulation Engine (FME). The FME opens a variety of Universal Data formats including:

- Autodesk AutoCAD (*.DXF, *.DWG)
- Bentley MicroStation Design (V7) (*.POS, *.FC1, *.DGN)
- Bentley MicroStation Design (V8) (*.POS, *.FC1, *.DGN)
- ESRI ArcInfo Export (*.E00)
- ESRI ArcSDE
- ESRI Geodatabase (*.MDB)
- Google Earth (*.KMZ, *.KML)
- Spatial Data Transfer Standard (*.CATD.DDF)
- Vector Product Format (VPF) Coverage NIMA/NGA (*.FT)
- Geography Markup Language (*.GML)
- Esri Geodatabase (File Geodatabase API) Reader/Writer (*.GDB)

Using the Open Universal Data feature of MapInfo Pro, you can open different types of data stored in a variety of locations and:

- Combine data from multiple sources into a single output.
- Run and join data from incompatible systems
- Extend the use of legacy systems
- Exchange data between CAD-based systems and GIS systems
- Perform quality assurance tests on spatial data

Additionally, if you have the FME Suite, which is available from Safe Software, you can use this feature to open almost 150 formats within MapInfo Pro.

**Note:** You cannot open a SQL Server table through Open Universal Data. If you open an existing table or workspace that references a SQL Server database, then an error message displays. If you purchased FME separately from Safe Software and it supports SQL Server, then tables using SQL server open in MapInfo Pro. For more information, see *Working with the FME Suite* in the Help System.
Opening Universal Data Directly

When opening universal data, you can select the data you want to open and specify the name of the dataset you want to display.

The process for opening this data is the same regardless of the format.

To open the universal data directly:

2. In the Specify Data Source dialog box, beside the Format drop-down list, click Browse the gallery.
3. In the Formats Gallery, select the format for the data you wish to open and click OK.

4. In the Specify Data Source dialog box, click Open file browser beside the Dataset field. A dataset is defined as a set of data in the same format.

5. In the Select File dialog box, locate and select the data file. If you do not see your data in the list, then select All Files (.*.*) from the Files of type list. After making your selection, click Open.

The Specify Data Source dialog box refreshes with your selection. If the Dataset field remains blank, then check that you are selecting data that matches the format in the Format field.

6. To open a directory of data in the Specify Data Source dialog box, click Open advanced browser + button beside the Dataset field.
The Select File dialog box opens and you can select:

- Directory-based formats by clicking Add Directories and browsing for a specific directory name. Check the Subdirectories check box to include all subfolders below that directory. Click OK. The new data appends to the original data.

  When adding a directory, MapInfo Pro opens all of the data of the specified format it finds in the directory. If you select the Subdirectories check box, MapInfo Pro opens all of the data with the specified format in the subdirectories. The data is merged together when you open it.

- File-based formats by clicking Add Files and browsing for a specific file name. To select multiple files, press Ctrl while making your selections. Click OK.

  Select the Identical Schemas check box if the files have the same schema.

  Click OK to close the Select File dialog box.

7. Optionally, click Parameters to set how to handle the output format. This is how you set the display settings for your data.

8. If the coordinate system for your data selection is unknown, then click Open the coordinate system gallery beside the field to select the projection. If you do not specify the coordinate system, you will be prompted to do so later.

  Some data contains the coordinate system information in it and others do not, so you may need to specify the coordinate system projection for the data you are opening.

9. Click OK.

10. In the Select Layers dialog box, select which layers you want to include in the output. By default all layers are selected.

    To set display characteristics for one or all of the layers, see Changing Display Settings for Universal Data in the Help System.

11. In the Directory field, type the location to save the output to or browse to select a location.

12. From the Preferred View drop-down list, select whether you want to view the output in a Map window (Current Mapper or New Mapper) or in a table (Browser).

13. Click OK.

    If you did not specify the coordinate system in step 8 and the coordinate system is unknown, the Choose Projection dialog box displays, so that you can select the projection for the data you are opening. The system defaults to your Table Projection setting in the Map Window Preference if you do not select a projection here.

The data opens in MapInfo Pro.
Working with the FME Suite

If you install the FME Suite from Safe Software, you can open even more formats from within MapInfo Pro. To extend MapInfo Pro to use these additional formats, use the FME Integration Console that ships with the FME Suite. There are a couple of caveats to keep in mind:

- Make sure that the version of the FME Suite that you are using is the same version or later than that which has been integrated with MapInfo Pro. This means you must have FME Suite 2013 or later. This works on a build number basis, so even a minor update to MapInfo Pro or FME Suite could result in discrepancies between the products and could prevent you from opening particular formats.
- Pitney Bowes Software Inc. localizes the dialog boxes of the FME product that we use in MapInfo Pro. However, when you extend MapInfo Pro with the FME Suite, this functionality is effectively run from the FME Suite, using the FME Suite dialog boxes.

For example, if you are running the Japanese version of MapInfo Pro and you install the English version of the FME Suite, the dialog boxes that display for this feature will be in English. If you revert to the MapInfo Pro implementation of this feature, the translated dialog boxes will display in Japanese.

Note: Raster/grid formats and MapInfo TAB/MIF formats are not available when you extend MapInfo Pro with the FME Suite.

For more information see Extending MapInfo Pro with FME Suite in the Help System.

Understanding MapInfo Pro's Use of the Topography Layer

OSGB MasterMap's Topographic Layer contains nine themes including roads, tracks and paths, buildings, landforms, water, height, heritage, structures, and administrative boundaries. You can import these themes as TopographicArea, LandformArea, TopographicLine, TopographicPoint, CartographicText, CartographicSymbols, BoundaryLines, and DepartedFeatures. The TopographicArea feature type contains two 'complexes', Topography and Landform, which contain different polygons of information. The Landform polygons overlap the Topography polygons (which represent land features like slopes and cliffs).

We split the TopographicArea feature type output into two layers so it is possible to save them in different tables. The TopographicArea table contains only output whose areas defined in the OSGB user guide as being part of the Topography complex or Structuring Layer. There is a feature type in the GML Import dialog box called LandformArea, which allows the creation of the LandformArea table. See Importing and Displaying GML File Data for a clearer picture of this process in action.
Opening MapInfo Pro Grid Files

To open MapInfo Pro Grid Files:
1. Choose File > Open to display the Open Table dialog box.
2. Choose Grid Image (*.grd, *.mig), from the Files of Type list box.
3. Click the file you want to open and click the Open button.

   **Note:** There are grid files in the introductory data provided on the MapInfo Pro data DVD.

Importing Graphic Files

To import a graphic file:
1. Choose Table > Import to display the Import File dialog box. Specify the location, name, and format of the file you want to import.
2. Click Import to display the Import into Table dialog box.
3. Specify the name and new table format for the table you are creating.
4. Click Save. The file is imported into the file you named with the specified format.

Geocoding - Assigning Coordinates to Records

To display your data on a map, you must first assign X and Y coordinates to each record. One way that MapInfo Pro assigns these coordinates is by matching geographic information in your database table to geographic information in another table (referred to as a search table) that already has X and Y coordinates associated with it.

For example, you want to assign X and Y coordinates to a customer record whose address is 127 Winston Ave. MapInfo Pro reads that address and looks for a matching address in the search table, such as a StreetPro table. (This search table already has X and Y coordinates associated with its records.)

When MapInfo Pro matches 127 Winston Ave in your table to 127 Winston Ave in the search table, it assigns the corresponding X and Y coordinates to your record. The geocoded point becomes part of your database. You can then view these points by displaying your table in a Map window.
What Do I Need to Know Before Geocoding?

It is important to know your data and what you want to use it for before you select a method of geocoding. Ask yourself these questions:

**What kind of geographic information do I have in my database?**

Do you have street addresses, towns, cities, postal codes, states, countries? Do you have potentially ambiguous information? For example, if you have a database of customer street addresses, will you have 125 Main Street in Smithtown and a 125 Main Street in Nassau? If so, you may have to refine your search using town boundaries or postal codes.

**What kind of maps do I have to work with?**

You will need computerized maps that are at the level of detail that match your data. For example, if you want to geocode a database of customers in specific counties by street address, you will need maps of the desired counties that go to street level. A map of the United States that only goes to a county level would not work for you. You can purchase the appropriate maps for your geocoding application from MapInfo Pro or your reseller.

**How geographically accurate does the placement of my data have to be?**

Taking into account the first two questions, you must decide how accurate the geocoding must be. If you are trying to pinpoint the locations of cable wires, crime scenes, or fire hydrants, a high degree of accuracy is needed. In this case, you should geocode your data to street level.

If, however, you are going to use your data to thematically shade postal code boundaries, town boundaries, county boundaries, state boundaries, or country boundaries, you may not need a high degree of accuracy.

In this case, geocoding against boundary files such as USZIPBDY.TAB, which we provide, would be sufficient for your needs. Since this file does not include point postal codes (postal codes assigned to a single building or company), the hit rate may not be as good as when you geocode by street.
Understanding the Geocoding Process

To assign X and Y coordinates to the records in your table, choose Geocode from the Table menu. MapInfo Pro displays the **Geocode** dialog box, where you enter the following information:

- The name of your table for which you want to assign X and Y coordinates.
- The column in *your table* that contains the geographic information that will be used for matching.
- The name of the *search table* containing the geographic information that will be used for matching.
- The search table column containing the geographic information for matching:

The dialog box also offers you the option of geocoding your data in two modes: *automatically* or *interactively*. When you geocode a table automatically, MapInfo Pro geocodes exact matches only and ignores all other records. It is the faster method, since MapInfo Pro requires no user interaction once the geocoding process begins. When you geocode a table interactively, MapInfo Pro pauses when it fails to match a record and lets you select from a list of close matches.

**Note:** We recommend that you geocode your table automatically first and then go back and geocode interactively to match the remaining records.

**Not Getting Geocoding? Try this Example...**

The objective of geocoding is to place data from your database accurately on a map. Let us call your data the *source* table. You can think of the geographical coordinates on a map as a *target* table.

To geocode a record:

- MapInfo has to match an address in the source table with a location on the target table

Most of the problems in geocoding occur in trying to take the address data in the source file and match it to addresses in the target tables.

For more about the automatic and interactive geocoding modes, see **Modes of Geocoding**.

**Modes of Geocoding**

MapInfo Pro has two geocoding modes: automatic and interactive. The process of matching target addresses with source addresses is the same in both modes.

**Automatic mode** matches addresses based on the choices in the **Geocode** dialog box.

When Geocoding is in automatic mode, only exact matches are geocoded. When some of your data fails to match exactly (due, perhaps, to typographical errors), you need to geocode in Interactive mode to match the near misses by hand. It is generally best to do two passes through your table, with the first pass set on Automatic and the second pass set on Interactive. This approach takes less processing time.

For instructions on geocoding in automatic mode, see **Geocoding Automatically** in the Help System.
**Interactive mode** stops at each address that does not meet the geocode parameters and permits you to assist in the matching process. When you geocode interactively, you are not changing the data. You are merely redirecting MapInfo Pro to look for different information.

For more information, see *Geocoding Interactively* in the *Help System*.

In most cases, the best geocoding strategy is to geocode in automatic mode and then geocode in interactive mode to deal with the records MapInfo Pro was unable to handle automatically.

**Manual mode.** Automatic and interactive geocoding work well for databases with "clean" data. Sometimes, however, you know where a point should be on the map, but the location data does not allow for a match. Manual geocoding is the process of placing your data records on the map by clicking its location on the map. This method works best when you have a small table which contains data that you are very familiar with.

For more information, see *Geocoding Manually* in the *Help System*.  

**Methods of Geocoding**

In addition to geocoding automatically and manually, you have choices in how precise you want the geocoded record to be. Let us look at the variety of ways you can geocode your table.

**Geocoding by Address**

Street addresses typically consist of two or three components:

- Street number
- Street name
- Apartment, Suite, Floor, Room number or some other piece of information. Many addresses do not have this component

MapInfo Pro has one procedure for dealing with the street number and another procedure for dealing with the street name. MapInfo Pro deals with the third component, if present, as though it were a part of the street name.

When you geocode your table with street addresses, MapInfo Pro matches the addresses in your table to the street names and address ranges in a street table, such as StreetPro (Pitney Bowes Software Inc.’s premier streets data product) and assigns X and Y coordinates to your records. When you display your records, MapInfo Pro will spot the record at the location of the record's address. MapInfo Pro places the record on the proper side of the street, offsets it from the side of the street to the specified distance, and insets it from the end of the street the specified percentage of the line. The **Options** dialog box controls these parameters. For more about setting the street offset in the **Options** dialog box, see *Street Offset* in the *Help System*.

**Geocoding by Boundary**

In computer mapping, the term boundary is used to designate enclosed regions or areas such as countries, cities, and postal codes. When you geocode your table with boundaries, MapInfo Pro matches the boundary name in your table with the boundary name in the search table. MapInfo Pro
assigns the boundary centroid X and Y coordinates to your data records. The centroid of a boundary is its approximate center point.

For example, you have a table of wholesale outlet stores. You want to assign X and Y coordinates to each record according to county. MapInfo Pro reads the county name from your table, matches it with the county name in the search table, and assigns the county centroid coordinates to each of your records. The outlet locations will display at the county centroid in a Map window.

**Geocoding by US_ZIPS.tab (Postal Code Centroid File)**

US_ZIPS.tab is a point file that is included with the base MapInfo Pro package. The file consists of postal code centroid points for every postal code in the United States. This file can be used to geocode any database that includes postal code information. This file includes postal codes that are assigned to individual buildings or companies.

You can use any of the above methods to geocode your records, or you can use a combination of address and boundary geocoding to increase the potential for a successful match.

**Geocoding by Server**

If you have access to a geocoding server such as MapMarker or Envinsa Server, you can geocode using a more extensive data set.

**Refining Your Geocoding Search**

When geocoding, you might refer to objects whose names are used for other objects that do not interest you (for example, a city name that is common to two or more states). To eliminate this problem, refine your search by selecting another column (from, typically, another table). To further refine the search, specify the state for each city, rather than just the city name.

If your area of interest is not unique enough for MapInfo Pro to automatically determine the position or location, you will need to refine your geocode search by specifying a particular boundary that contains your area of interest. This will provide MapInfo Pro with geographic locations on where to position your points.

**Finding an Exact Street Match**

When MapInfo Pro geocodes, it attempts to find an exact match between source and target street names. That means that the addresses must be the same, character for character. However, matching is not case sensitive; upper and lower case letters are successfully matched with one another. MapInfo Pro does not get an exact match in many cases and uses a file of abbreviation equivalences to improve its "hit rate". Once you understand the various ways in which a match can fail, you are in a better position to understand what you can do to improve things.

The next table illustrates exact matching. The first column contains a street name from a target table and the second column contains the corresponding street name from a source table. The third column says why they do not match. The fourth column indicates whether the particular problem is one which can be corrected through using the abbreviation file. This table assumes that the addresses are the contents of a single column in a table. While the street number would often be in the same
column, we do not indicate street numbers here because they are handled differently than street names.

<table>
<thead>
<tr>
<th>Target Address</th>
<th>Source Address</th>
<th>Comment</th>
<th>Correctable with Abbreviation File?</th>
</tr>
</thead>
<tbody>
<tr>
<td>LaSal St</td>
<td>LaSalle St</td>
<td>&quot;LaSal&quot; is the wrong spelling.</td>
<td>No</td>
</tr>
<tr>
<td>La Salle St</td>
<td>LaSalle St</td>
<td>&quot;La Salle&quot; is the wrong spelling.</td>
<td>No</td>
</tr>
<tr>
<td>LaSalle Ave</td>
<td>LaSalle St</td>
<td>&quot;Ave&quot; does not match &quot;St&quot;.</td>
<td>No</td>
</tr>
<tr>
<td>LaSalle Street</td>
<td>LaSalle St</td>
<td>&quot;Street&quot; does not match &quot;St&quot;.</td>
<td>Yes</td>
</tr>
<tr>
<td>LaSalle Ave</td>
<td>LaSalle Av</td>
<td>&quot;Ave&quot; does not match &quot;Av&quot;.</td>
<td>Yes</td>
</tr>
<tr>
<td>LaSalle St.</td>
<td>LaSalle St</td>
<td>The target address has a period after &quot;St&quot;. That period is not in the source and causes the match to fail.</td>
<td>Yes</td>
</tr>
<tr>
<td>LaSalle</td>
<td>LaSalle St</td>
<td>&quot;St&quot; is missing from target.</td>
<td>No</td>
</tr>
<tr>
<td>LaSalle St</td>
<td>LaSalle</td>
<td>Target has &quot;St&quot; and source does not.</td>
<td>No</td>
</tr>
<tr>
<td>LaSalle St North</td>
<td>LaSalle St</td>
<td>Target has &quot;North,&quot; which is not in source.</td>
<td>No</td>
</tr>
<tr>
<td>LaSalle St North</td>
<td>LaSalle St N</td>
<td>Target has &quot;North&quot; instead of &quot;N&quot;.</td>
<td>Yes</td>
</tr>
<tr>
<td>North LaSalle St</td>
<td>N LaSalle St</td>
<td>Target has &quot;North&quot; instead of &quot;N&quot;.</td>
<td>Yes</td>
</tr>
<tr>
<td>Target Address</td>
<td>Source Address</td>
<td>Comment</td>
<td>Correctable with Abbreviation File?</td>
</tr>
<tr>
<td>---------------------</td>
<td>----------------</td>
<td>--------------------------------------------------------</td>
<td>-------------------------------------</td>
</tr>
<tr>
<td>North LaSalle St</td>
<td>LaSalle St</td>
<td>Target has &quot;North,&quot; which is not in source.</td>
<td>No</td>
</tr>
<tr>
<td>LaSalle St Apt 3</td>
<td>LaSalle St</td>
<td>Target has an apartment number which does not match anything in the source.</td>
<td>Yes</td>
</tr>
<tr>
<td>Tenth St</td>
<td>10th St</td>
<td>&quot;Tenth&quot; and &quot;10th&quot; do not match.</td>
<td>Yes</td>
</tr>
<tr>
<td>10th Av</td>
<td>Tenth Av</td>
<td>&quot;10th&quot; and &quot;Tenth&quot; do not match.</td>
<td>Yes</td>
</tr>
<tr>
<td>Saint John's Lane</td>
<td>St John's Lane</td>
<td>&quot;Saint&quot; and &quot;St&quot; do not match.</td>
<td>Yes</td>
</tr>
</tbody>
</table>

MapInfo Pro's matching process is not case-sensitive; it does not care whether a letter is upper case or lower case. This means that MapInfo Pro treats the following as the same: Main, MAIN, main, maIN.

MapInfo Pro has a file called the Abbreviations File (MAPINFOW.ABB), which you can use to record acceptable alternate spellings for abbreviations. For example Av for Ave. or BL for Blvd. etc. Using this file increases your hit rate because there are more acceptable spellings for the same abbreviations.

For more information, see *Solving Problems with Abbreviations and Substitutions* in the Help System.

### Placing Geocoded Points

When you are geocoding to street level (by address), you can specify certain aspects of the resulting points' position in relationship to the street. You can specify the offset of the point from the side of the street, and the inset of the point from the end of the street.

For more information, see *Street Offset* in the Help System.

### Street Inset

The street inset is the distance a geocoded point is set from the end of the street. You can specify a distance, or an inset can be a percentage of the length of the street. To avoid skewing the position of inset points, MapInfo Pro performs a proportional calculation that insets the points located at
either end of the street the specified percentage or distance, but that decreases the inset as point
locations approach the center. Points located at the center of the street remain in their original
position.

For more information, see Street Inset and Controlling How Much to Inset and Offset a Point when
Geocoding in the Help System.

Matching Street Names

MapInfo Pro begins by comparing the street address in the target table with the street addresses
in the source table. When it finds an exact match, it may be finished or it may have to deal with
region information, such as town, county, or postal code area.

When MapInfo Pro cannot match the street name for a particular row, it applies the abbreviation file
to the target address. This file consists of pairs of items, such as "STREET ST" and "AVE AV". When
MapInfo Pro finds "STREET" in a target address, it changes it into "ST"; similarly it changes
"AVE" to "AV". MapInfo Pro does not actually change your data in the target table. It substitutes
abbreviations only for the purpose of making matches. The substitution is only effective during the
matching process. The address in your table remains the same. It does not write the correct address
form back to your table.

Once MapInfo Pro has made an abbreviation substitution it attempts to match the resulting street
name against the street names in the source table. When it fails to find an exact match at this point it:

• In Automatic mode, it moves to the next row
• In Interactive mode, it presents you with the closest matches and you pick the best match. MapInfo
  Pro then moves on to the next row.

At this point MapInfo Pro will have done the best it can at identifying street names. The next step
is to deal with address numbers for those addresses where it has matched a name.

Matching Address Numbers

Given that MapInfo Pro has identified a street, it has to deal with street numbers. MapInfo Pro stores
address ranges with each street segment. MapInfo Pro takes the street number from the target
address and compares it to the ranges for each segment in the source table. For example, assume
that we are trying to match "343 LaSalle St". MapInfo stores the beginning and ending address for
each segment, differentiating between left and right sides of the street, as follows:

<table>
<thead>
<tr>
<th>Name</th>
<th>FromLeft</th>
<th>ToLeft</th>
<th>FromRight</th>
<th>ToRight</th>
</tr>
</thead>
<tbody>
<tr>
<td>LaSalle St</td>
<td>269</td>
<td>331</td>
<td>268</td>
<td>330</td>
</tr>
</tbody>
</table>
To match "343 LaSalle St" MapInfo Pro would scan the address ranges until it finds the one where "343" goes. Since 343 is between 333 and 375, the application locates this address on that street segment (the middle one in the table). Once MapInfo Pro has matched an address number to a street segment it moves to the next row. When it fails to match a target street number to an address range on the appropriate street it:

- In Automatic mode, it moves to the next row
- In Interactive mode, it presents you with the closest matches and you pick the best match. MapInfo Pro then moves on to the next row.

At this point MapInfo Pro has done the best it can at locating address numbers. Note that one of the options (on the Geocode Options dialog box) is to automatically pick the closest address range in cases where there is no exact match—Use The Closest Address Number. For example, you might have "412" as an address number, but no range which includes that number. However, there is a range which goes from 346 to 400. Since that is the range closest to 412, that is where MapInfo Pro will geocode 412 if you have chosen this particular option. The next step is to deal with addresses which have been located on more than one street.

### Matching to Region

When MapInfo Pro is geocoding it checks to see how many occurrences of the target address exist. If there is more than one, MapInfo Pro must decide which source address to use. If the user’s target table has a column with region data, MapInfo Pro can refine geocoding within a boundary.

For example, assume that you are geocoding a database of records in Cook county, Illinois. The address in the database reads 200 Washington St. Within the county of Cook, there are eight towns. Four of these towns have a Washington St. Three of the four have a 200 Washington St. MapInfo Pro must now place the target address in the appropriate town. MapInfo Pro uses region information to do this. MapInfo Pro now matches a region designation for the target address against the region designator for the source addresses.

When you originally set up your geocoding operation, you had an opportunity to specify a region (boundary) to use in refining your geocoding operation. This dialog box displays when you choose Refine Search with Table and using Boundary Name Column.

If you specified a postal code table you enter the postal code and MapInfo Pro returns possible matches.
You could use any one of several different region types, including county name, town name, and postal code. Since almost all addresses contain postal codes, this is the most reliable way to refine your search. When you set MapInfo Pro to use postal codes to refine its address matching, MapInfo Pro will match the postal code of the target address against the postal code of the various matching source addresses. When it finds the correct match, it is finished with the geocoding process. MapInfo Pro can now get coordinate information from the source table and use it to place a point object into the target table.

However, once MapInfo Pro has completed this process, many addresses may be unmatched. You can match each one of them individually by geocoding in interactive mode. However, if you are working with a large database, you want to do as little of this as possible. There are other ways of improving MapInfo Pro’s geocoding performance.

In the **Geocode Options** dialog box, you can specify that MapInfo Pro automatically pick a different boundary, providing there is only one, from the one you specify (Use A Match Found In A Different Boundary). You might have had MapInfo Pro geocode addresses to Northtown. One particular address, "223 Locust Ct." is not in Northtown, but it is in Westville, and no place else. In this case, MapInfo Pro would geocode "223 Locust Ct." to Westville. However, if MapInfo Pro had found a "223 Locust Ct." in Westville and another one in Center Valley, it would not geocode the address to either town. It would leave "223 Locust Ct." ungeocoded.

For more information, see **After Geocoding** in the *Help System*. This section contains the following topics:

- **Finding and Examining Ungeocoded Records**
Putting Your Data on the Map

• Extracting Longitude and Latitude from a Geocoded Table
• Extracting Longitude and Latitude into a New Table
• Extracting Longitude and Latitude into the Original Table
• Extracting a Table in a Projection Other than Longitude/Latitude

Selecting Records Not Geocoded

Your geocoded table may have records that did not geocode, or you may have added new data to your table that have yet to be geocoded. There is a simple selection that can be performed to get a Browser list of the records not geocoded.

1. Open your table if it is not open already, and on the Query menu, click Select.
2. Fill in the Select dialog box. The expression used is "NOT OBJ." This selects all of the records that are not objects, for example, not geocoded. Click OK.

Locating Newly Geocoded Points

One of the most satisfying results of geocoding is seeing your points displayed correctly on the map. Depending on the settings of your map, newly geocoded points may or may not be visible immediately.

Follow these steps to attempt to locate newly geocoded points on the map.

1. Make sure that the Map window is active by clicking in its title bar.
2. Choose Map > Layer Control. The Layer Control window displays.

   Make sure that the table you geocoded is listed in the Layer list. If it is not, then click the Add Layers button and add that layer.
3. In the Layer Control window move the geocoded table to the top, just below the Cosmetic layer, to ensure that the points are not obscured by any other layer.

4. Make sure that the geocoded layer is set to visible. Check the Visible On/Off check box.
   
   If your points are still not visible, proceed to step 6.

5. On the Map menu, point to View Entire Layer. Select your table and click OK. This should put all of the points from your table in view. You may see that your points are on the map, but are not in the location you expected them to be. If they seem misplaced, see Ungeocoding Selected Records.

6. If your points still do not display, on the Map menu, click Layer Control. Select the layer containing your geocoded points, and click the Layer Properties button. The Layer Properties dialog displays.

7. On the Layer Display tab, select the Style Override check box and choose a symbol style that will stand out on your map. Click OK and then exit Layer Control.

   After following these steps, if you have not found the points that you geocoded, try to select all of the ungeocoded records as described in the section Selecting Points Not Geocoded.

Result Codes

When you are using the result code option (in Geocode Options dialog box) MapInfo Pro will generate a code for each record. These codes indicate the steps MapInfo Pro took to geocode the record, whether or not the geocoding was successful, and whether or not the match was exact. You can use return codes to diagnose MapInfo Pro’s geocoding performance. It will help you spot “false positives” resulting from using various geocoding options and to analyze why some records have not been geocoded.

Ungeocoding a Table

Ungeocoding is the process of removing objects that have been attached to data records. There are times when it will be necessary to ungecode an entire table or selected records in a table. For example, you have geocoded a database of customers using US_ZIPS.tab. Later, you want to geocode the database again, using street addresses instead of postal code centroids since the geocoding will be more precise. MapInfo Pro allows you to delete all graphic objects associated with this table. You can then geocode your database again, using more specific coordinates. Ungeocoding only selected records from your table is useful when the location information changes for a relatively small number of records, such as address changes in a geocoded list of customers.

To ungecode and remove one or more of the objects in a table:

1. Make the table you are working with the editable layer of the active Map window.
2. Select the object or objects.
3. Click the Map window to make it active.
4. Choose Edit > Clear Map Objects Only.
To ungeocode an entire table:

1. On the **Table** menu, point to **Maintenance** and click **Table Structure**. The **Modify Table Structure** dialog box displays.

2. Clear the **Table Is Mappable** check box. Click **OK**.

   **Caution:** This action will remove all graphic objects from your table. This action cannot be undone. If you are unsure of losing your points, save a copy of the table first.

3. A warning dialog box appears. If you are sure about removing all the objects, click **OK**.

   All graphic objects have been removed from your table.

Make sure that you do not ungeocode your source tables. Unless you have created a backup of that table, you will no longer be able to display that table as a map or use it for geocoding.

### Ungeocoding Selected Records

To ungeocode and remove one or more of the objects in a table:

1. Make the table you are working with the editable layer of the active Map window.

2. Select the object or objects.

3. Choose **Edit > Clear Map Objects Only**.

   For more information about trouble shooting your geocoding issues, see *Resolving Geocoding Issues* in the Help System.

---

**Putting Latitude/Longitude Coordinates on a Map**

You may have a file that already contains X and Y coordinates, but not the point objects themselves that you want to display in MapInfo Pro. While the geographic information exists in the table, MapInfo Pro needs to create points to represent these coordinates before displaying them in a Map window. The Create Points command under the Table menu allows you to create points for each record in your database that has X-Y coordinate information.

**Note:** MapInfo Pro uses the coordinate fields in your table to create point objects. Records that already have graphic objects associated with them will be skipped during the Create Points operation.

For example, you have a table showing transmitter tower locations that was created by recording coordinates using a global positioning system. You want to display the locations on a map in MapInfo Pro. The table already has X and Y coordinate information but MapInfo Pro cannot display this information until you create points for that coordinate data that MapInfo Pro can read.

For more information, see the *Putting Latitude/Longitude Coordinates on a Map* in the Help System. This section also contains these topics:
• Creating Points from an Excel or Lotus Table
• Creating Points from a Longitude/Latitude
• Creating Points in a Projection

For more about the Degree Converter tool, see the Tools section of the Help System.

Dispersing Points Located in the Same Place

Depending on how you have geocoded your table, you may have several points that are placed at the same location, making it difficult to tell if you are viewing one point or many. For example, if you geocode a table of students by census tract, and view the results on your map, it appears that there is one dot at the center of each tract when there actually may be several there. To see all of your data, you may want to disperse the points over a small area. There are three methods for dispersing points: the Disperse Points tool (a tool that comes with MapInfo Pro), equal dispersion, and dispersion to the right.

For specific instructions, see the Dispersing Points Located in the Same Place in the Help System.

Creating Points for Intersections

Many people working with street files are often interested in information that is located at intersections. For some, their only concern is the intersections. In MapInfo Pro you can geocode to intersections in your street file with the Geocode command, but it would be easier to work with a table that contained only intersections. For example, a municipality is interested in tracking the types of traffic control devices at each street intersection. It would be beneficial for them to make an entire layer that contains the intersection of every street.

For specific instructions, see Creating Points for Intersections in the Help System.

Geocoding Data using a Server

Using the MapMarker and Envinsa Web Services, you have more choices for geocoding. For example, you can choose to geocode your records by street address or by postal code centroid, or by geographic centroids. If you have geocoded some records and some did not geocode successfully, you can set fallback conditions to locate those records. If you geocode and there are no results, poor results, or multiple equal close results, the geocoding server can present you with interactive options so you can select among possible matches or change your input. Further, these web services allow you to set multiple matching conditions when more than one record matches the records you are geocoding and set offsets for placing points right in the geocode properties.

For companies and organizations that use MapMarker and Envinsa servers as a geocoding engine, you can now take advantage of the geocoding servers available to your whole enterprise. If your organization makes this server available on your intranet or over the Internet, you can use our geocoding web services from within MapInfo Pro to perform more sophisticated and accurate data geocoding.
To use MapInfo Pro with a geocoding server, you need MapMarker Java Server 4.0 or later or Envinsa 4.0 or later. MapInfo Pro supports any geography that is supported by Envinsa currently. Envinsa supports MapMarker Java Server V2, V3, and V4. Keep in mind that any Envinsa server only supports the data that is installed.

Before you can access a MapMarker or Envinsa geocoding service, you need to connect MapInfo Pro to its server. This process gives MapInfo Pro all the information it needs to access the geocoding service. You need to enter this information only once per service.

• To geocode a single address using a geocoding service, see Geocoding a Single Address using a Geocoding Service.
• To set up a geocoding server and its preferences, see Setting up a Geocoding Server and Setting the Geocoding Server Preferences in the Help System.
• To geocode a table of addresses using a geocoding service, see Geocoding a Table using a Geocoding Service in the Help System.

Displaying Your Data on the Map

Once you have converted your data and geocoded or created points for it, you are ready to display the results.

To display your data in a new Map window:

1. On the Window menu, point to New Map Window and select the tables you want in your map. The order in which you select these tables determines the order they display.
2. Click OK to display your data on the map you selected.
3. To change the symbol used to display your data, choose Map > Layer Control. The Layer Control window displays.
4. Click the Style Override swatch for the layer with your data in it and select new display options.

To display your data on an existing Map window:

1. Open the .tab files or .WOR files you want to plot your converted data onto.
2. Open the .tab files or .WOR files you just created and in the Preferred View drop-down box select the Current Mapper option.
3. Click Open.

Now that your data is there to see, make it say something to your audience. The whole world of MapInfo Pro functionality is open to you. For details on analyzing your data, see Creating Thematic and Other Themed Maps or see Drawing and Editing Objects for more about customizing your map.
Finding Data on your Map

The **Find Selection in Current Map Window** command allows you to search and display a selection in the currently active Map window. You can not search for the selection in other types of windows (such as Browser windows) using this command. You can access this option by pressing **Ctrl+G**.

The **Find Selection in All Windows** command allows you to locate the selection in all open windows (including a Browser window) that are currently open.

To access Find Selection in Current Map Window:

1. Perform the **Query > Find** or **Query > Find Selection**.
2. Choose **Query > Find > Selection > In Current Map Window**.

**Note:** Choosing the **In Current Map Window** option shortens the search time.

To access Find Selection in All Windows:

1. Perform the **Query > Find** or **Query > Find Selection**.
2. Choose **Query > Find > Selection > In All Windows**.

For more information, see *Saving and Closing Query Tables* in the Help System.

Viewing a List of Open Tables

You can view a list of open tables and can perform operations on the open tables in the Table List window.

To access the Table List, do one of the following:

- Click the **Table List** tool in the **Main** toolbar.
- On the **Table** menu, click **Table List**.

The Table List window displays. Use the Table List to manage open tables and their attributes.

The Table List has the following features:

- **Modeless**, so that you can open it and leave it open for the duration of your session. (Modeless windows do not have OK or Cancel buttons.)
- **Dockable** to any of the four sides of the MapInfo Pro window: top, left, bottom, and right. The Layer Control window and Table List Window can also share the same space.
- **Drag and drop** enabled, so that you can select tables and drag and drop them to a blank area to open them in a new Mapper window. When dropping tables on to an existing Mapper window, MapInfo Pro adds them to the Mapper window as new layers.
- **Sorting** enabled, to sort tables based on ascending order of table alias (name), descending order of table alias, and recently opened. Sorting criteria persist across different MapInfo Pro sessions.
- **Multi-Selection** enabled, to select multiple tables using the **Ctrl** or **Shift** keys.
- **Context Menu** enabled, so that when you right-click on table aliases (names) a pop-up menu displays and you can perform the desired operations.
• Searching enabled, you can search for a table name in the Table List Window by typing characters in a Search text box. The Table List Window list refreshes itself to show only those tables that contain the search characters.

For information about how to work with the Table List, see Working with Tables in the Table List.

Displaying Data Details using the Statistics Window

The Statistics window displays the details of a selected data record. This information must exist in the .TAB file's metadata to display in the Statistics window. As the selection changes, the data is re-tallied, and the statistics window is updated automatically.

To see the details of a data record:

1. Open a .TAB file with statistical data in it.
2. Select a geographical object in the Map window.
3. Do one of the following:
   • Select Options > Show Statistics Window
   • Click the Statistics tool .

To copy the contents of the Statistics window to the clipboard, press and hold the Ctrl key and press C. Go to the application you want to paste the Statistics data to and do one of the following:

• Right-click to display the shortcut men, click Paste.
• Hold down the Ctrl key and press Insert.

You cannot select particular contents of the Statistics window.

When you want statistics for an entire table, use Query > Select All to select all records in a table.

Figure: Statistics Window
Printing Your Results

Once you have created the perfect map or graph, you can easily print the individual windows. For presentation, use the Layout Designer to bring together all views of your mapping session. Here, you can combine different types of windows to create an attractive and more informative presentation. On the Window menu, point to New Layout Designer Window to open a Layout Designer window that you can use to arrange your maps, browse tables, graphs, legends, titles, logos, and so on. See Working with Layouts, for tips and techniques about working in the Layout Designer window.

Setting up the Page

Before you print your map or layout, you will need to set up your page. In the Page Setup dialog box (on the File menu, click Page Setup), specify the paper size, orientation, and margins.

If printing a layout in a Layout Designer window, see Setting Printing Margins for a Layout for more details.

For detailed printing instructions, see Printing your Map in the Help System. These topics are also in this section:

- Saving or Restoring Printer Information in Workspaces
- Advanced Printing Options
- Graph/Redistrict/3DMap Printing Options
- Overriding the Default Printer
- Printing Maps to PDF Files

Printing Your Map

When you have your page set up the way you want, you are ready to print.

To print your map:

1. On the File menu, click Print.
2. In the Print dialog box, specify printer properties, such as a page range for printing and the number of copies to print.

You can override the default printer setting by selecting another print from the Name drop-down list.

Note: The PDF button is available on the Print dialog box only when the Printer name is MapInfo PDF Printer.
Click **Options**.

3. In the **Map Print Options** dialog box, specify the size of the map, how its contents will display, the scale, and its width and height. When you have completed your selections, click **OK** to continue.

   **Note:** If you are printing a graph or a browser or a 3DMap, your options will be different. For details on the other print options, see *Graph/Redistrict/3DMap Printing Options* in the *Help System*. The Map Window Preference setting *Use Cartographic Scale* affects the entries in this dialog box.

- **Map Size** - Select the size of the map you are producing in this group; the options are Window Size, Fit to Page, and Custom. As you make selections, the Custom Scale, Custom Width and Custom Height entries change.
- **Window Size** - Click this button to print the map as it displays on your computer screen.
- **Fit to Page** - Click this button to fit the current map to the page size you have selected in your preferences.
- **Custom** - Click this button to enter your own custom scale, width, and height entries in the fields provided. Then, type the appropriate entries in the Custom Scale, Custom Width and Height fields.
- **Map Contents** - Select an option in this group to determine the map contents you want to print; the options are Same as Window and Centered on Window.
- **Same as Window** - Click this button to print the map contents as it appears in the Map window, with the same proportions and content as you see.
- **Centered on Window** - Click this button to center as much of the current map that fits on the page. When you select this option, the image may print on more than one page depending upon fit. In general when you select this option, MapInfo Pro assumes you want to select the **Fit to Page** radio button and selects this for you.

4. If your map is particularly complex (a large map, 3D, or one with 10 or more colors) there are more options available using the **Advanced** button. The **Advanced Printing Options** dialog box displays. (See *Advanced Printing Options* in the *Help System*). When you have completed your selections, click **OK** to continue.

5. After you complete your selections, click **OK** on the **Print** dialog box to print your results.

### Viewing and Printing Text

Text size is handled differently in the classic **Layout** window and **Layout Designer** window from what you see in a **Map** window. You should keep these differences in mind when printing maps and layouts containing text objects and when fine tuning text.

**Text Size in classic Layout windows**

In the **Layout** window, the point size of the text is specified relative to the actual size of the page (that is, the size in which it will print), just as it is in word processing and desktop publishing programs. When you zoom in and out on a **Layout** window, the text will be larger or smaller on the screen, but its specified point size (as indicated in its attributes box) remains the same.
The font and size of text objects in the Layout window may not appear as they do on the printed page. There are several possible reasons for this: fonts available for screen display are not available for your printer, screen character width is different than printer character width, and screen resolution is different than printer resolution.

To find out the true size of a text object in the Layout window, use the Select tool and click on the object. The edit handles indicate the object’s true size.

**Text Size in Layout Designer windows**

The Layout Designer window contains a live map that you can edit, so that you do not need to toggle between the layout and editing in the Map window. The Layout Designer window shows the map using the printer resolution, so that you know beforehand what your printout will look like (you will know what labels will be on the printed map).

**Text Size in Map windows**

In maps, text size is specified relative to the screen, which is not an accurate representation of what the printed map would look like (labels in a Map window may not be on the printed map). When you zoom in and out on a map, the size of the text on the screen and the specified point size of the text will change. If you zoom in, text will appear larger, as will all visible elements of the map. The point size of the text (as indicated in its attributes box) will be appropriate to the text being displayed on screen.

**Troubleshooting Print Problems**

Good first steps in troubleshooting a printing problem are to make sure you have downloaded and installed the latest patch for MapInfo Pro and are using the latest printer driver for your printer/operating system. You can get additional printer advice in the MapInfo Pro Printing Guide, which is located in the Documentation subfolder of your installation directory.

When we discuss printer issues, we make the following assumptions about your print environment:

- The printer/plotter has been installed properly
- The printer/plotter drivers have been installed correctly
- The printer/plotter is connected to the computer or to the network properly
- There is sufficient memory (on the print device and on the computer) to print your files

Any of these issues can affect your ability to print/plot your MapInfo Pro output. Our Technical Support professionals may be able to identify these difficulties, but they are not within their control.

**Note:** Whenever we use the terms print or printer we also mean plotter.

**When Printing a MapInfo Pro Object From Another Application**

When you embed a MapInfo map or graph in another application (such as Word or PowerPoint), click outside the map/graph before you use the Print or Print Preview commands. This allows the container application to take over previewing or printing properly. This is particularly true if you have just made changes to the map or graph you are printing.
**Working with Fill Patterns**

Note that fill patterns on the first row of the Region Style dialog box are Windows standard and tend to print faster. The other patterns are bitmaps Pitney Bowes Software Inc. has created for your use. You might want to consider this when you are selecting fill patterns.

See also *Recommendations for Effective Pattern Scaling* in the MapInfo Pro Help System for more information regarding scaling and printing fill patterns.

**Translucent Raster Maps/Grids and Windows 9X Do Not Mix**

You cannot print a translucent raster map or grid on Windows 9X platforms or export them to EMF or WMF file formats. You need to use a non-metafile (for example, .BMP or .GIF) format to export raster images on Windows 9X.

Customers printing large images (such as destination page size D, E, or A0) no longer have the 28,000 pixel limitation. If you experienced printer difficulties in the past due to this limitation, you should notice a significant improvement in your printed images.

**Sometimes the Older Driver is Better**

When in doubt, if an older driver worked and the new one does not, go back to the older driver.

**Make Room for the Metafile**

Make sure you have plenty of temporary disk space, particularly if you are using the Print using the Enhanced Metafile option. The system is trying to create a layered bitmap locally on disk.

**Spool Locally, Print Globally**

Try spooling print jobs locally rather than at the plotter. This allows the computer to rasterize your output rather than the printer, which can be more efficient.

For print spooling instructions, see *Troubleshooting Printing Problems* in the Help System.
15 - Working with Coordinate Systems and Projections

Maps at their base are a visual representation in two dimensions of a section of the three-dimensional Earth. Being able to use maps in an electronic format in many ways frees us from the constrictions of the two-dimensional map because we can use mathematical formulas to compensate for the curvature of the Earth. In this chapter, we cover the coordinate systems and projections that are standard in MapInfo Pro and provide the tools with which you can create a custom projections to meet your organization's needs. Whether you are a local government trying to establish new tax rolls or a large company trying to define your sales territory more precisely, creating a custom projection may be a solution you want to explore.

For more information, see Using Ocean and Grid Tables and Frequently Asked Projection File Questions in the Help System.

In this section

- Working with Coordinate Systems 463
- Building Blocks of a Coordinate System 469
- Adding Projections to the MAPINFO\W.PRJ File 477
- Understanding Precision in MapInfo Pro 480
- Understanding Affine Transformations 480
- Using Earth and Non-Earth Maps 483
Working with Coordinate Systems

The terms "projection" and "coordinate system" are often used interchangeably, however they do not mean the same thing.

**Projection** - An equation or set of equations that contain mathematical parameters for a map. The exact number and nature of the parameters depends upon the type of projection. You can think of a projection as a method of reducing a map's distortion caused by the curvature of the Earth, or more precisely, a projection compensates for the shortcomings of depicting maps in two dimensions when the coordinates exist in three dimensions.

**Coordinate System** - When parameters of a projection are assigned specific values, they become a coordinate system. A coordinate system is a collection of parameters that describe coordinates, one of which is a projection.

Displaying Coordinates

There are two places where coordinates display:

- In the **StatusBar** by cursor location (set in the **Map Options** dialog box or by clicking on the **StatusBar**).
- In dialog boxes that display area measurements, such as a **Point Object**, **Region Object** etc.

**Note:** Coordinates can only be entered in the **Object Info** dialog boxes when a layer is editable.

You can display coordinates in one of the following formats:

- Decimal degrees (for example -97.90052°, 42.85732°)
- Degrees, minutes, seconds (for example -97° 54' 1.908", 42° 51' 26.28")
- Military Grid Reference (WGS 1984 datum) (for example 14TNN8982545555)
- US National Grid Reference (NAD 83/WGS 84) (for example 14TNN8982545555)
- US National Grid Reference (NAD 27) (for example 14TNN8985745342 (NAD 27))

The default is Decimal degrees.

Elements of a Coordinate System

A coordinate system in MapInfo Pro is made up of many elements which need to be specified in advance. Once these elements are in place, you can be sure that your maps are as accurate as possible. These are the projection elements you need to set in the MAPINFOW.PRJ file:

- **Projection Types**
- **Datums**
- **Units**
• Coordinate System Origin
• Standard Parallels (Conic Projections)
• Oblique Azimuth (Hotine Oblique Mercator)
• Scale Factor (Transverse Mercator)
• False Easting and False Northing
• Range (Azimuthal Projections)

Note: For datum and unit tables, see Projection Datums and Units.

Understanding Coordinate Systems

You can make a map out of any globe without distorting the points on the surface by placing the globe into an imaginary cylinder.

Globe with Longitude/Latitude Projection

If you transfer the touch points from the globe surface onto the cylinder and roll out the cylinder onto graph paper, the result is a map as in the figure below. In the map that would be created from this cylinder, the Equator is 0 degrees all the way around the globe and the points on that line are completely accurate.
Longitude/Latitude Projection Map

When you add longitude and latitude lines at 15 degree increments to each side of the Equator and the Prime Meridian you create a reference grid. The lines furthest from the Prime Meridian are +180 degrees toward the right and -180 degrees to the left. This map projection is commonly called the Longitude/Latitude projection.

This is often considered the default projection. It is the most effective map for areas nearest the Equator but measurements further away tend to increase in distortion.

Because many people do not live near the Equator, other projections came into use to create more accurate local maps. Accuracy depends upon how you project the globe onto the cylinder. If you turn the cylinder so that it touches the Prime Meridian instead (or any line of longitude, 90 degrees away from the Equator) you have a Transverse Projection. The closer you are to the place the cylinder touches the globe, the more accurate the measurements are.

*Globe Demonstrating the Transverse Projection*

Transverse projections allow us to make maps that are more North-South line accurate, as long as you compensate for the distance from the new "Equator" which in this case is the Prime Meridian.
A third type of projection attempts to resolve the distortion problem in another way. Conic projections use a cone shape instead of a cylinder to create the "touch points".

This type of projection is much more accurate for large regions or countries that are wider in the East-West direction than in the North-South direction. There is much less distortion regionally because the touch points of a cone are closer to the map surface than those of a cylinder.
Brazilian Polyconic Projection Map

As you can see from the previous figure, the conic maps are best for small regional areas. The smaller-scale map has too much distortion to be useful.

A fourth type of projection, the Azimuthal projection, does not use cones or cylinders but a simple circle that goes all the way around the globe over a particular point. This projection provides a "view from space" over a particular point.

Globe with Azimuthal Projection

This type of projection is most useful when you need to work with a particular hemisphere. A hemisphere need not be North-South or East-West based. The next figure uses the North Pole as the center point for the Azimuthal Projection.
Lambert Azimuthal Projection Map

You can use more than one projection that rotates a cylinder slightly along the Equator. This style is used in the Universal Transverse Mercator (UTM) projection. UTM maps the Earth with a transverse cylinder projection to create standard "UTM Zones". By rotating the cylinder around the globe in six degree increments, the UTM assures that all spots on the Earth are within 3 degrees of the center line. (The Gauss-Kruger system is a European system akin to UTM that also uses a transverse cylinder rotated in six degree steps).
Universal Transverse Mercator Projection Map (UTM Zone 29)

Almost all projections you will use are one of these types. They are either cylindrical (regular or transverse), conic, or azimuthal projections and are customized by slightly different projection parameters. Projection parameters are options that describe how the projection is arranged.

You can further customize projections by specifying different parameters for the projection you want to use. For example, you can specify the longitude and latitude of any point on the Earth to create your own Azimuthal projection of that point. You can customize conic projections by specifying the parallel of latitude at which the cone should be tangent.

Building Blocks of a Coordinate System

In this section, we provide the tables required to create your own coordinate systems using map projections, datums, units, Origins, Standard Parallels, Azimuths, Scale Factors, False Eastings, False Northings, and Ranges. You might want to create your own coordinate system if accuracy is crucial to understanding your data or if your data is specified in relation to a non-standard point, and you would prefer to keep your data in that custom coordinate system.

Coordinate Systems, Projections, and their Parameters

By specifying a projection type and various required parameters, you create a mathematical algorithm for producing equivalent coordinates in degrees for the projected coordinate system. Each projection has specific parameters you can customize to make your maps more geographically accurate. The
following table details each major coordinate system type and the parameters you can use to customize that system. The parameters are listed in the order they appear in the relevant projection entries in the MAPINFO.W.PRJ file. To create your own coordinate system using a particular projection, you must add an entry into the MAPINFO.W.PRJ file.

The parameters of a coordinate system are (in this order):

• Coordinate System Name
• Projection Type
• Datum
• Units
• Original Longitude
• Original Latitude
• Standard Parallel 1
• Standard Parallel 2
• Azimuth
• Scale Factor
• False Easting
• False Northing
• Range

**Note:** Each of these headings is described in detail in the next few pages.

For a complete list of common coordinate systems and their necessary parameters, see *Projections and Their Parameters*

### Projection Types

The projection type is the equation or equations used by a coordinate system. For a list of projections MapInfo Professional uses, see *Projection Types List.*

### Specifying the Bounds for Coordinate Systems

You can specify the bounds for coordinate systems in the MapInfo Professional .PRJ file. To do so, add 2000 to the projection number and list the bounds after the projection parameters. The general form is:

```
name, projectionnum + 2000, projection parameters, x1, y1, x2, y2
```

For example, to define a UTM Zone 10 coordinate system with bounds of (100000, 400000) to (200000, 450000), use this line:

```
"UTM Zone 10", 2008, 74, 7, -123, 0, 0.9996, 500000, 0, 100000, 400000, 200000, 450000
```
To define a Longitude / Latitude coordinate system with bounds of (-50, 30) to (-48, 35), use this line:

"Longitude / Latitude", 2000, 0, -50, 30, -48, 35

You can also define a coordinate system with bounds and an affine transformation. In that case, add 3000 to the projection number, and list the bounds after the affine transformation constants. The general form is:

name, projectionnum + 3000, projection parameters, unitnum, A, B, C, D, E, F, x1, y1, x2, y2

Accounting for Affine Transformations and Explicit Bounds in Projection Types

You can modify projection type entries in the MAPINFOW.PRJ to add a constant value to account for affine transformations and explicit bounds. Valid constant values are listed in the next table:

<table>
<thead>
<tr>
<th>Constant</th>
<th>Coordinate System has:</th>
<th>Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000</td>
<td>Affine transformations</td>
<td>Affine units specifier and coefficients appear after the regular parameters for the system.</td>
</tr>
<tr>
<td>2000</td>
<td>Explicit bounds</td>
<td>Bounds appear after the regular parameters for the system.</td>
</tr>
<tr>
<td>3000</td>
<td>Both affine transformations and bounds</td>
<td>Affine parameters follow system's parameters; bounds follow affine parameters.</td>
</tr>
</tbody>
</table>

Example:

In this example we use the Transverse Mercator coordinate system with the NAD 1983 datum. You might have this line in your MAPINFOW.PRJ file:

"UTM Zone 1 (NAD 83)", 8, 74, 7, -177, 0, 0.9996, 500000, 0

If you want to account for an affine transformation for this system, you would add the constant to the projection type and append the parameters of the affine transformation as listed below:

Units=meters; A=0.5; B=-0.866; C=0; D=0.866; E=0.5; and F=0

Therefore, the new entry to append the parameters of the affine transformation would be:

"UTM Zone 1 (NAD 83) - rotated 60 degrees", 1008, 74, 7, -177, 0, 0.9996, 500000, 0, 7, 0.5, -0.866, 0, 0.866, 0.5, 0
where:

<table>
<thead>
<tr>
<th>Entry</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1008</td>
<td>Achieved by adding the constant (1000) to the projection type (8)</td>
</tr>
<tr>
<td>7</td>
<td>Units for the affine transformation (7 = meters)</td>
</tr>
<tr>
<td>0.5, -0.866, 0, 0.866, 0.5, 0</td>
<td>Affine parameters.</td>
</tr>
</tbody>
</table>

To supply explicit bounds to the coordinate system \((x_1, y_1, x_2, y_2)=(-500000, 0, 500000, 1000000)\), the required line entries would be:

"UTM Zone 1 (NAD 83) - bounded", 2008, 74, 7, -177, 0, 0.9996, 500000, 0, -500000, 0, 500000, 1000000

where:

<table>
<thead>
<tr>
<th>Entry</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2008</td>
<td>Produced by adding the constant (2000) to the projection type (8)</td>
</tr>
<tr>
<td>-500000, 0, 500000, 1000000</td>
<td>Explicit bounds parameters</td>
</tr>
</tbody>
</table>

To customize the coordinate system using both the affine transformation and explicit bounds, the entry in the MAPINFOW.PRJ would be:

"UTM Zone 1 (NAD 83) - rotated and bounded", 3008, 74, 7, -177, 0, 0.9996, 500000, 0, 7, 0.5, -0.866, 0, 0.866, 0.5, 0, -500000, 0, 500000, 1000000

where:
Produced by adding the constant (3000) to the projection type (8)

Units for the affine transformation (7 = meters)

Affine parameters

Explicit bounds parameters (See Accounting for Affine Transformations and Explicit Bounds in Projection Types.)

Datums

A datum is established by tying a reference ellipsoid to a particular point on the earth. The following Datums table lists the details for each datum:

- The number used to identify the datum in the MAPINFOW.PRJ file.
- The datum's name
- The maps for which the datum is typically used
- The datum's reference ellipsoid

For a comprehensive list of supported projection datums, see Projection Datums.

For a list of datum changes by version, see Coordinate System Enhancements by Version in the MapInfo Pro Help.

To create a custom datum, see Defining Custom Datums in the Help System.

Converting Coordinates from One Datum to Another

When converting coordinates from one datum to another, MapInfo Pro has used the Molodensky (3-parameter) and Bursa-Wolfe (7-parameter) methods. These are general-purpose methods that can convert coordinates from any datum to any other datum.

After the NAD 83 datum was introduced, NOAA developed a program called NADCON, which stands for North American Datum CONversion. This is a very specialized program that converts coordinates only from NAD 27 to NAD 83 and vice versa. For this specialized task, it is much more accurate than the Molodensky general-purpose method; NADCON is accurate to about 0.1 meter, and Molodensky is accurate to only 10-30 meters. Most U.S. government agencies, including the Census Bureau, have standardized on NADCON for converting between NAD 27 and NAD 83.

The NADCON algorithm is used to convert coordinates between NAD 27 and NAD 83 if those coordinates lie within the areas covered by NADCON (United States, Puerto Rico, and the Virgin Islands).
Islands). If the coordinates lie outside those areas, or if they use datums other than NAD 27 or NAD 83, MapInfo Pro uses the Molodensky or Bursa-Wolfe conversion methods.

Due to the file access required, the NADCON conversion method can be slightly slower than the Molodensky method. If you want to turn off the NADCON conversion, add a "NADCON" entry to the registry. The registry entry should have this path:

```
HKEY_LOCAL_MACHINE\Software\MapInfo\MapInfo\Common\NADCON
```

If this entry is set to zero, then the Molodensky conversion method will be used instead of NADCON.

```
NADCON=0
```

**Units**

The units indicate the measurement that the projection uses to keep track of space. To find a complete list of units and their corresponding projection entries, see [Units](#).

**Coordinate System Origin**

The coordinate system origin is the point on the Earth (specified as longitude and latitude degrees) from which all coordinate distances are to be measured. X = 0 and Y = 0 at the origin point, unless a false easting and/or false northing is used (see below). It is chosen to optimize the accuracy of a particular coordinate system. As we move north from the origin, Y increases; X increases as we move east. These coordinate values are generally called northings and eastings.

For the Transverse Mercator projection, the origin's longitude defines the central meridian. In constructing the Transverse Mercator projection a cylinder is positioned tangent to the earth. The central meridian is the line of tangency. The scale of the projected map is true along the central meridian.

In creating a Hotine Oblique Mercator projection it is necessary to specify a great circle that is not the equator nor a meridian. MapInfo Pro does this by specifying one point on the ellipsoid and an azimuth from that point. That point is the origin of the coordinate system.

**Standard Parallels (Conic Projections)**

In conic projections a cone is passed through the earth intersecting it along two parallels of latitude. These are the standard parallels. One is to the north and one is to the south of the projection zone. To use a single standard parallel specify that latitude twice. Both are expressed in degrees of latitude.
Oblique Azimuth (Hotine Oblique Mercator)

When specifying a great circle (such as the Hotine Oblique Mercator) using a point and an azimuth (arc), the azimuth is called the Oblique Azimuth and is expressed in degrees.

Scale Factor (Transverse Mercator)

A scale factor is applied to cylindrical coordinates to average scale error over the central area of the map while reducing the error along the east and west boundaries. The scale factor has the effect of recessing the cylinder into the earth so that it has two lines of intersection. Scale is true along these lines of intersection.

You may see the scale factor expressed as a ratio, such as 1:25000. In this case it is generally called the scale reduction. The relationship between scale factor and scale reduction is:

\[
\text{scale factor} = 1 - \text{scale reduction}
\]

In this case the scale factor would be 1-(1/25000) or 0.99996.

False Easting and False Northing

As you can see in the Longitude/Latitude Projection Map, X and Y coordinate parameters are commonly designated in relationship to a single point. Points to the left of that center point are negative and points to the right are positive. Points above that center point are positive and points below that point are negative.

In the days of the tall ships, these calculations and computations were done by hand. Using positive and negative signs made these calculations more complicated. The terms "false easting" and "false northing" were used to remove these signs and refer to the absolute value of the X and Y coordinates. MapInfo Pro handles these computations, but these parameters still have to be accounted for in the projections that use them.

Range (Azimuthal Projections)

The range specifies, in degrees, how much of the Earth is visible. The range can be between 1 and 180. When you specify 90, you see a hemisphere. When you specify 180 you see the whole earth, though much of it is very distorted.

About Polyconic Coordinate Systems

The following description has been copied from "Map Projections - A Working Manual", USGS Professional Paper 1395, by John P. Snyder.

The Polyconic projection, usually called the American Polyconic in Europe, achieved its name because the curvature of the circular arc for each parallel on the map is the same as it would be
following the unrolling of a cone which had been wrapped around the globe tangent to the particular parallel of latitude, with the parallel traced onto the cone. Thus, there are many ("poly-") cones involved, rather than the single cone of each regular conic projection.

The Polyconic projection is neither equal-area nor conformal. Along the central meridian, however, it is both distortion free and true to scale. Each parallel is true to scale, but the meridians are lengthened by various amounts to cross each parallel at the correct position along the parallel, so that no parallel is standard in the sense of having conformality (or correct angles), except at the central meridian. Near the central meridian, distortion is extremely small.

This projection is not intended for mapping large areas. The conversion algorithms used break down when mapping wide longitude ranges. For example, WORLD.TAB, from the sample data shipped with MapInfo Pro, may exhibit anomalies if reprojected using Polyconic.

Examples of Projection Entries in the MAPINFO.W.PRJ File

The MAPINFO.W.PRJ file lists the parameters for each coordinate system on a separate line, as in the following examples:

"Mollweide (Equal Area)", 13, 62, 7, 0

"Albers Equal-Area Conic (Alaska)", 9, 63, 7, -154, 50, 55, 65, 0, 0

"UTM Zone 9 (NAD 27 for Canada)", 8, 66, 7, -129, 0, 0.9996, 500000, 0

This is a basic list of the elements of a coordinate system, for review. There are some projections that do not require all of the elements in the list. Following this list, you can see some entries from the .PRJ file.

1. The first element in each list is the name of the projection in quotes.
2. The second element in each list is the number that identifies the projection number as indicated in Projection Types List.
3. The third element in each list is the datum ID that identifies the appropriate datum for the projection. See Datums for a complete list of supported datums.
4. The fourth element in each list is the units, which indicate the units of the projection. See Units for a current list of the supported units.
5. The next element in some lists is the coordinate system origin. See Coordinate System Origin for a complete description of this entry.
6. The remaining elements are specific to particular types of projections. You can see their descriptions in Standard Parallels (Conic Projections), Oblique Azimuth (Hotine Oblique Mercator), Scale Factor (Transverse Mercator), False Easting and False Northing and Range (Azimuthal Projections).

**Note:** Each element in a projection entry is separated by a comma.

Let us look at some specific coordinate systems to prepare you to create your own projection. It is important to remember that the elements of a projection are different for each projection. Here are some examples we have already seen:
Note: There are additional examples in the Help System.

Adding Projections to the MAPINFO.W.PRJ File

Once you understand the structure of the entries in the MAPINFO.W.PRJ file, you are ready to create a new projection entry for your coordinate system. You may want to make a copy of the MAPINFO.W.PRJ file in case you want to revert back to it later.

To create a new projection entry for the coordinate system in the MAPINFO.W.PRJ file:

1. Open MAPINFO.W.PRJ in a text editor or word processor. In this file, you are going to add the new projection entries.

    "--- Longitude / Latitude ---", 0, 0, 0, 0., 0., 0., 0., 0., 0.,
    0.
    "Longitude / Latitude", 1, 0
    "Longitude / Latitude (Adindan)p4201", 1, 1
    "Longitude / Latitude (Afgooye)p4205", 1, 2
    "Longitude / Latitude (AGD 66)p4202", 1, 12
    "Longitude / Latitude (AGD 84)p4203", 1, 13
    "Longitude / Latitude (Ain el Abd 1970)p4204", 1, 3
    "Longitude / Latitude (Anna 1 Astro 1965)", 1, 4
    "Longitude / Latitude (Arc 1950)p4209", 1, 5
    "Longitude / Latitude (Arc 1960)p4210", 1, 6
    "Longitude / Latitude (Ascension Island 1958)", 1, 7
    "Longitude / Latitude (Astro Beacon E)", 1, 8

MAPINFO.W.PRJ in Notepad

2. Scroll down in this list to find the type of projection you want to base your map on. See Understanding Coordinate Systems for descriptions of the different projection types.

3. Add a new line at the end of the projection list you are modifying.

   For example, to add a new Universal Transverse Mercator projection (Australian Map Grid using AGD66 datum), scroll down to that entry and type the new projection at the end of the list.

    "--- Longitude / Latitude (v 6.0 and later projections) ---"
    "Longitude / Latitude (Hungarian HD 72)", 1, 1004
    "Longitude / Latitude (Hartbeesthoek 94)", 1, 150
    "Longitude / Latitude (Australia GDA94)p4283", 1, 116
    "Longitude / Latitude (Australia-National-AGD84 7-param)", 1, 1006
    "Longitude / Latitude (A.C.T. AGD66 7-param)", 1, 1007
    "Longitude / Latitude (Australia (Tasmania AGD66 7-param)", 1, 1008
    "Longitude / Latitude (Australia (Victoria/NSW AGD66 7-param)", 1, 1009
    "Longitude / Latitude (New Zealand (NZGD49 7-parameter)", 1, 1010
    "Longitude / Latitude (EUREF89)", 1, 115
    "Longitude / Latitude (New Zealand NZGD2000)", 1, 117
    "Longitude / Latitude (American Samoa)", 1, 118

Adding a Line in the MAPINFO.W.PRJ File
4. On a new line, type the new parameter entries based on the required parameters described for that projection type in the table Projections and Their Parameters.
   
   - If the name of your projection does not appear in the Common Map Projections list, consider the kind of projection you are creating (Latitude/Longitude, Conic, Transverse, etc.) and follow the table entries for the type of projection you want.
   
   - Remember to include constant values (Accounting for Affine Transformations and Explicit Bounds in Projection Types) to indicate an affine transformation, specific bounds, or both if appropriate or necessary.

   **Note:** The order of parameters is vitally important. Remember to separate each parameter with a comma.

5. Save your edited MAPINFOW.PRJ file in the directory in your user directory.

   **Note:** In the past the MAPINFOW.PRJ file was saved in your installation directory but this did not allow different users to have different PRJ files. This new file placement permits this.

   Things to keep in mind when editing the MAPINFOW.PRJ file:
   
   - You must record the X and Y coordinates of the origin point in decimal degrees.
   - Remember to include a negative sign for west longitudes and south latitudes.
   - You must list the origin longitude first in the MAPINFOW.PRJ file entry.
   - Carry out decimals to at least five (5) places for greater accuracy.
   - Do not use commas to represent thousands or millions in large numbers. Only use commas to separate parameters from one another.
   - When specifying projection, datum and units, use the number that represents the parameter. These numbers are listed in the table for each parameter earlier in this section. In our example, 6 represents Equidistant Conic projection; 74 represents NAD 83 datum, and 7 represents meters.

Using the New Projection in a Coordinate System

Once you have created this new projection, you can use it in a Map window to replace the coordinate system you are using.

1. Open the map for which you want to change projections.
2. From the Map menu, select Options to display the Map Options dialog box.
3. Click the Projections button to display the Choose Projection dialog box.

   **Note:** To change the projection of a tab file and all of the map objects in it, use the File > Save Copy As command and select the new projection.

   1. Select the new projection from the list and click OK to confirm. The Map Options dialog redisplay.
   2. Click OK to implement the new projection in the Map window.
### Entering a New Coordinate System (Example)

To illustrate this process in another way, create the following coordinate system using these parameters by adding a new entry to the MAPINFO.W.PRJ file:

<table>
<thead>
<tr>
<th>Parameter Type</th>
<th>Entry</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>&quot;Equidistant Conic Plus&quot;</td>
<td>Name of the new coordinate system</td>
</tr>
<tr>
<td>Projection Type</td>
<td>6,</td>
<td>Equidistant Conic</td>
</tr>
<tr>
<td>Datum</td>
<td>74,</td>
<td>(NAD 83)</td>
</tr>
<tr>
<td>Units</td>
<td>7,</td>
<td>meters</td>
</tr>
<tr>
<td>Origin Longitude</td>
<td>-90.5,</td>
<td>90°30′W</td>
</tr>
<tr>
<td>Origin Latitude</td>
<td>30,</td>
<td>30°N,</td>
</tr>
<tr>
<td>Standard Parallel 1</td>
<td>10.33333,</td>
<td>10°20′N</td>
</tr>
<tr>
<td>Standard Parallel 2</td>
<td>50,</td>
<td>50°N</td>
</tr>
<tr>
<td>False Easting</td>
<td>10000000,</td>
<td>10,000,000 m</td>
</tr>
<tr>
<td>False Northing</td>
<td>500000</td>
<td>500,000 m</td>
</tr>
</tbody>
</table>

1. Open MAPINFOW.PRJ in a text editor or word processor.
2. Go to the Equidistant Conic section and add a new line.
3. Type the name of your new coordinate system in quotes, followed by a comma.
4. Enter the following information to represent your coordinate system:
   6, 74, 7, -90.5, 30, 10.33333, 50, 10000000, 500000
5. Save your edited MAPINFOW.PRJ file.

You can use your custom coordinate system just as you would use any of the coordinate systems that come with MapInfo Pro.

There are other ways you can edit this file. To shorten the list, remove coordinate systems from the file. You can also change the names, change group headings and reorder the file to suit your needs.

**Note:** Group headings are distinguished by the hyphen at the beginning of the name. Names of coordinate systems cannot begin with a hyphen or a space.

### Understanding Precision in MapInfo Pro

MapInfo Pro is a very good tool for working at a high precision level. But the onus is on the user to discover the practical limits of the program in various circumstances and how to set the work environment in order to obtain the desired precision level. Millimeter level precision can be easily attained and maintained with projected maps in the metric system.

### What is Precision?

The most basic component of any GIS is the spatial data that defines the map features. This spatial data could not exist without the coordinate systems that are used to specify the location information. Coordinate precision is a measure of storing spatial data as accurately as possible. Of course, this can be no more precise than the original data provided. Precision is a measurement of how accurately you can store and retrieve the spatial data and has nothing to do with the quality of the data. The number of reliable digits in your coordinate is termed significant digits. Precision is measured in terms of these significant digits.

- For topics related to precision and map bounds, see *Understanding Precision in MapInfo Pro* in the Help System.

### Understanding Affine Transformations

An affine transformation allows you to match the points on two vector maps that use different coordinate systems so they can be used together. The base map stays the same while the derived map is transformed mathematically to match up coordinates to the base map.

MapInfo Pro provides the definitions for scale, translation, rotation, reflection, and shearing necessary to support an optional affine transformation for any coordinate system definition. You can also define
a coordinate system with bounds and/or with an affine transformation. This is described in detail in Accounting for Affine Transformations and Explicit Bounds in Projection Types.

Description of an Affine Transformation

There are several basic types of transformation that can be applied to the base map using an affine transformation. These include scaling, translation, rotation, shearing, and reflection.

• For more information, see Understanding Affine Transformations in the Help System.

The scale factor of a transformation indicates the distance between the fixed points of one map versus the fixed points of the second map. If the only difference between two maps is the scale, the affine transformation of the derived map is only the same map zoomed in or out around a fixed point. The orientations of the lines connecting the points, and the angles between these lines, remain the same. The scaling in the case of the figure below is around the 0,0 point.

![Scale Example](A.png)

*The difference between these images is the scale. To create an affine transformation that maps the base image (A) to the derived image (B), change only the scale.*

The translation factor of a transformation is when every point on an image follows a parallel path and no rotation takes place.

![Translation Example](B.png)

*The difference between these two images is the translation.*

The rotation factor of a transformation indicates that the image turns on a particular point. The next figure shows a 25-degree rotation of the map around the 0,0 point.
The difference between these two images is not the scale, because the size of each image is the same. The difference is the rotation of the derived image (B).

The shearing factor of a transformation indicates that one of the coordinates of one image should change proportionally to the other. You can apply a shear transformation either on the x-axis as shown in the next figure or on the y-axis. As you can see the vertical scale of the image has not changed, and the corner of the figure at 0,0 has not moved—but points higher up on the figure are shifted progressively further to the right.

The difference is the shearing of the derived image (B).

The reflection factor of a transformation indicates that the derived image is the mirror image of the base image, that is, all the points in the base image should be reflected across some straight line, such as the x-axis or y-axis. In the figure below, the derived image (B) is the reflection of the base image (A).

The difference between these two images is that the derived image (B) is a reflection of the base image (A) along the x-axis.
Using Earth and Non-Earth Maps

Earth maps and non-earth maps generally require different treatment. The following section on projections apply only to earth maps. An earth map contains objects that have a particular location on the earth's surface. All maps that MapInfo Pro sells are earth maps. Coordinates typically represent an object's location in longitude and latitude, although other coordinate systems (using various projections) may be used instead.

**Sinusoidal (Equal-Area)**

Use earth maps to:

• Overlay your map onto any maps that MapInfo Pro supplies.
• Use or change projections.
• Specify objects on the map in terms of longitude and latitude.

A non-earth map contains objects that have no specific location on the earth's surface. Floor plans are typical examples of non-earth maps. A non-earth map has a coordinate system, but since its map points are not referenced to locations on earth, the coordinate system does not contain a projection. Even though the floor plan describes a building that may be located somewhere on the Earth, the coordinates of objects in the floor plan are generally not referenced to positions on the Earth. Rather, the object's coordinates are referenced to the floor plan itself, generally representing distance from the lower left corner of the floor plan. The next figure depicts a floor plan and is an example of a non-earth map.

Specifying Coordinates for a Non-Earth Map

**Saving a Map to a Non-Earth Coordinate System**

To save a table into a Non-Earth Coordinate system:

1. Ensure that your non-earth map is open and that it is the active window.
2. Choose File > Save Copy As.
3. In the Save Copy of Table As dialog box, click the Projection button.
4. In the Choose Projection dialog box, choose Non-Earth from the Category drop-down list.
5. Choose a unit from the **Category Members** drop-down list to specify the bounds and units for your non-earth coordinate system.

6. Click **OK**. The **Non-Earth Coordinate Bounds** dialog box displays.

The **Non-Earth Coordinate Bounds** dialog box allows you to specify the bounds and units for your non-earth coordinate system. You can use positive or negative numbers to specify the minimum and maximum X and Y values.

**Changing the Map's Coordinate System to Non-Earth**

To only change the Map's Coordinate System:

1. Ensure that your map is open and that it is the active window.
2. From the **Map** menu, select **Options**.
3. In the **Map Options** dialog box, select the **Projection** button.
4. In the **Choose Projection** dialog box, choose **Non-Earth** from the **Category** drop-down list.
5. Choose a Non-Earth unit from the **Category Members** drop-down list.
6. Click **OK**.
A web service is a software system that is accessible using an intranet or Internet connection. MapInfo Pro supports the Web Map Service (WMS) and Web Feature Service (WFS), which allow you to retrieve data that others are sharing internally or world-wide. The power of web services is that you can use them to create more powerful maps or in the case of geocoding services get more accurate and precise results using the same data.

You can also work with Geocoding and Driving Region web services. A Geocoding web service lets you geocode with greater accuracy, because the maps on a service are more precise. A Driving Region web service lets you create time- and distance-based buffers around a site to determine proximity to a location. You might use this service to find the customers closest to a store, or to determine which insured customers are closest to a weather pattern.

A mapping tile server provides cartographic maps of geo-referenced data, in the form of raster images (tiles). In MapInfo Pro, you can add map tiles as a base layer to your map to provide a visual reference for your data. This gives you a real-world reference for viewing your data, such as for viewing store locations or maintenance routes.
Introduction to Web Services

MapInfo Pro web services can add detail and precision to the maps you are creating and analyzing. Currently, you can use the following web services from within MapInfo Pro:

- Web Map Service (WMS)
- Web Feature Service (WFS)
- Geocoding Service
- Routing or Driving Region Service
- Mapping Tile Service

Accessing Web Services in MapInfo Pro

To make it easier to access web services, there is a Web Services toolbar. These toolbar buttons display frequently used web services dialog boxes.

To display the toolbar:

1. From the Options menu, select Toolbars.
2. Check the Web Services check box and click Close.

Web Services Toolbar

<table>
<thead>
<tr>
<th></th>
<th>Open WMS Table</th>
<th>Create Driving Regions</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Open WFS Table</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Find Address</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Geocode Using Server</td>
</tr>
</tbody>
</table>

For more information about these buttons, see the Accessing Web Services in MapInfo Pro topic in the Help System.
Web Service Authentication

A web service, such as a WFS, WMS, geocoding server, routing server, or tile server, may require authentication in the form of a user name and password.

Server-Side Authentication

You can access WFS, WMS, and tile servers that require basic authentication using the built-in standard mechanism for internet servers. To connect to a web service that requires authentication, complete the Connect dialog box that displays.

Enter the appropriate user name and password and select the Remember my password check box to have the site "remember" your password for you. Click OK to enter the site. If you do not have a valid user name and password, you cannot connect to the site.

Accessing Secure Web Sites

SSL is an international standard security protocol for exchanging sensitive information between a web site and your computer. You know SSL-enabled sites by the https: address. When you connect to an SSL-enabled server, your computer and the server exchange digital certificates, which minimize the threat of theft of sensitive data. If you try to connect to a server and you have a valid SSL certificate, you should be able to connect to the web site.

Proxy Server Authentication

Your local LAN may use a proxy server to connect to the internet. Web client applications such as internet browsers provide a mechanism for specifying a proxy server, and MapInfo Pro does as well. By default, MapInfo Pro uses your system settings—the same settings used by Internet Explorer—for a proxy server. Those settings can be accessed via the Connections tab under Internet Options in the Control Panel, or via the same dialog invoked in Internet Explorer via the Tools > Internet Options menu option. Ask your system administrator for the correct settings.

You can override these settings in MapInfo Pro via their Web Services preferences. Select Options > Preferences to display the Preferences dialog box and then click Web Services. The first tab in the Web Services Preferences dialog box displays Proxy Server settings.

There are several options for a proxy server.

• Use System Settings is the default option which uses the system settings for a proxy server, such as the same settings as Internet Explorer.
• Use Direct Connection bypasses any system proxy server settings and connects directly to the Internet. This option will only work if your LAN allows direct connections.
• Use Proxy Server also bypasses the system settings and allows you to specify a proxy server to use for MapInfo Pro. Ask your system administrator for the settings to use.

If you do use a proxy server to connect to the Internet, the proxy server may also require authentication in the form of a user name and password. Your system administrator should tell you what these are. If a user name and password are required, you will be prompted for them via a dialog when MapInfo Pro attempts to connect to the Internet, such as when drawing a tile server layer.
Enter the appropriate user name and password. You may also choose the **Remember my password** check box so the system will remember these values between sessions of MapInfo Pro. Within a session you should only need to specify the username and password once.

You can set automatic authentication for a proxy server when accessing Bing Map, Move Map, and the Web Feature Service (WFS). For details, see **Single Sign-On Credentials for Proxy Servers Accessing Map Services**.

**Single Sign-On Credentials for Proxy Servers Accessing Map Services**

You can set automatic authentication for a proxy server when accessing Bing Map, Move Map, and the Web Feature Service (WFS).

MapInfo Pro supports single sign-on authentication with proxy servers while accessing tile map services, such as Bing Map. MapInfo Pro signs on to the proxy server for you by automatically passing your Windows Authentication credentials (your Windows username and password), so that you do not have to type your proxy username and password.

Support for single sign-on authentication for proxy servers is in addition to our existing support for basic authentication for proxy servers. If you have your proxy server set up with basic authentication, then you still need to enter a username and password. For automatic authentication, you must have NTLM, Kerberos, or Negotiate authentication set up on the proxy server, and your proxy access credentials must be the same as your Windows Authentication credentials.

This single sign on experience does not apply to Tile Server authentication when the Tile Server you are using requires you to sign on before accessing map tiles.

**Note:** Microsoft ISA and TMG Proxy servers use Negotiate authentication when authentication mode is set to **Integrated**.

---

**Enhancing Map Data using a Web Map Service (WMS)**

Web Services can provide more data for you to work with in MapInfo Pro. A Web Map Service (WMS) allows you to access maps and data through your local intranet or the Internet. This innovation is based on a specification from the Open GIS Consortium (OGC) that allows you to use raster map images from servers that also comply with the specification. You must specify the coordinate system within your data request to ensure that the images you retrieve "sync up" or register with your other map data.

**How Does MapInfo Pro Use WMS Servers?**

When you create a .tab file from WMS layer(s), you are actually creating a pointer to an XML file that keeps track of the data you selected, (the server address, the selected layer(s), the styles, the format, and the projection settings). You never actually retrieve the data and save it on your computer. Every time you add a WMS table as a layer to your map or you change the view of the map, the
system generates a map request and retrieves the layer information. To do this, the .tab file points to an XML file which retrieves the information from the WMS Server and displays it on your computer. If you are not connected to the Internet, the server is unavailable, or the WMS layer(s) you are retrieving are not available, you cannot use the WMS .tab file.

**Note:** The WMS sites that we include in this documentation or in the standard installation of MapInfo Pro have been verified as part of the testing process. We cannot guarantee that these sites will remain active, only that they were active as of this writing.

**WMS Maps Display in Current Map Window's Coordinate System by Default**

Many times, when you are retrieving a WMS map, you are adding it to enhance the detail of a Map window that you are already working on. We have changed the default behavior of the Projection drop-down box. Now, this list defaults to the projection that matches the front-most map window, if that projection is available in the list.

**But What if a WMS Definition Already Exists or I am not Working in a Map Window?**

- If you are retrieving a WMS map and there was a previous WMS definition (or you are modifying a WMS map), MapInfo Pro uses the coordinate system that matches the current projection (not necessarily the Map window's coordinate system).
- If there was no previous WMS definition, the current Map window's coordinate system is selected if it can be found in the Projection list.
- If the Map window's coordinate system is not in the Projection list or you are retrieving a WMS map when you are not working in a Map window, MapInfo Pro tries to default to EPSG:4326.
- Finally, if none of these projections are found, the first item in the **Projection** list is selected.

**Supported Image Formats for WMS**

MapInfo Pro supports the following image formats for WMS:

- PNG
- JPEG (JPG)
- TIFF (GeoTIFF AND TIFF)
- GIF.

**Note:** Not every format will be available from every Web Map Service.

The OGC WMS specification supports transparent pixel definition for image formats. This allows you to use the images you retrieve as overlays and not solely as the bottom layer of your map.

To set the background to transparent, click the **Transparent** check box in the **Open WMS Table** or the **WMS Table Properties** dialog boxes. You can also control the transparency and translucency of the image via **Layer Control** (by double-clicking the layer and checking the **Style Override** check box on the Layer Display tab in the **Layer Properties** dialog box).

The **Help System** contains these related topics:

- **Adding a WMS Server**
Understanding WMS Error Messages

Data returned to the WMS client depends on the availability and status of the WMS server and on the characteristics and status of the maps on the WFS server. These conditions are beyond the control of Pitney Bowes Software Inc..

The following table lists and explains WMS-related error messages. Some messages consist of two parts, separated by a colon. The information up to the colon is generated by the MapInfo WMS client. The raw data following the colon comes directly from the WMS server. For clarification on those messages, please contact the service provider of the WFS server.

Table 2: WMS-Related Error Messages

<table>
<thead>
<tr>
<th>Error Message</th>
<th>Description and Explanation of Message</th>
</tr>
</thead>
<tbody>
<tr>
<td>XML Parsing Error: message from XML parser</td>
<td>The most likely cause is badly formed XML from the server. The raw data following the colon is transmitted by the MSXML 4.0 parser.</td>
</tr>
<tr>
<td>The WMS Server issued the following exception: message from server</td>
<td>The raw data following the colon is transmitted by the WMS server. This may help you analyze the problem.</td>
</tr>
<tr>
<td></td>
<td>The WMS server generated an error. For clarification, contact the service provider of the WFS server.</td>
</tr>
<tr>
<td>The following error was issued while attempting to access the WMS server:</td>
<td>There could be a problem with the URL, the server may not be available, or it may have timed out.</td>
</tr>
<tr>
<td>message from server</td>
<td></td>
</tr>
<tr>
<td>The WMS Server returned no data in response to the request.</td>
<td>MapInfo Pro issued a service request, but nothing was received from the server.</td>
</tr>
<tr>
<td>Error Message</td>
<td>Description and Explanation of Message</td>
</tr>
<tr>
<td>------------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Unable to retrieve capabilities from the WMS Server.</td>
<td>The GetCapabilities request from the server failed. This message usually appears paired with another message in the same message window.</td>
</tr>
<tr>
<td>The WMS Server returned HTML data rather than the requested format.</td>
<td>The raw data following the colon is transmitted by the WMS server. This may help you analyze the problem.                                                                                     The server you are accessing may not be a WMS server. You may see this message after accessing a WFS server and seeing a list of WFS layers. This can occur because the Capabilities document provided by the server may contain additional URLs that redirect you to another server (not the one you explicitly selected). That &quot;redirected&quot; server may be down or have another problem.</td>
</tr>
<tr>
<td>The WMS Server returned data which was neither in the requested format nor a recognized WMS service exception.</td>
<td>The raw data following the colon is transmitted by the WMS server. This may help you analyze the problem.                                                                                     The exception message from the server could not be understood. For example, the exception message may not have been in XML format.</td>
</tr>
<tr>
<td>Error accessing temporary file.</td>
<td>It is possible that your disk is full or you might have deleted the temp file while Mapinfo Pro was running.</td>
</tr>
<tr>
<td>The WMS Server does not return GetFeatureInfo data in a format supported by MapInfo Pro.</td>
<td>The server may not support GetFeatureInfo.</td>
</tr>
<tr>
<td>The WMS Server does not support GetFeatureInfo requests.</td>
<td>The server may not provide GetFeatureInfo in a format understood by MapInfo Pro.</td>
</tr>
<tr>
<td>There are no queryable layers in the WMS table for GetFeatureInfo request.</td>
<td>The server may not have a queryable layer. It is possible that a queryable layer changed between the time that you first created the WMS table and subsequently reopened the table.</td>
</tr>
<tr>
<td>The WMS Server returned data in formatA rather than the requested format of formatB.</td>
<td>MapInfo Pro requested data in the format that the server claims it supports, however the server is returning a different format. For clarification, contact the service provider of the WMS server.</td>
</tr>
<tr>
<td>Unable to retrieve feature information from the WMS server.</td>
<td>The GetFeatureInfo request from the server failed. This message usually appears paired with another message in the same message window.</td>
</tr>
</tbody>
</table>
Enhancing Map Data using a Web Feature Service (WFS)

MapInfo Pro provides a Web Feature Service (WFS) client to retrieve geospatial GML (Geography Markup Language) data using HTTP GET and HTTP POST requests over the Internet or through a private intranet. The WFS client was developed in accordance with the 1.0.0 and 1.1.0 OpenGIS Web Feature Service Implementation Specifications, which are available online at: http://www.opengis.org/docs/02-058.pdf

WFS is similar to WMS (Web Map Service), in that both can provide geographic data via the Internet. But while a WMS server provides raster maps, a WFS server provides raw coordinate data that the client uses to produce a map.

Note: The MapInfo WFS client has been developed in accordance with OGC WFS Specification 1.0 and 1.1. Using this client you cannot retrieve data from sites that are compliant with earlier or later versions of the OGC specification.

The WFS client supports GML2 (OGC GML V2.1.1). The OGS WFS Specification states that all servers should support GML2, but may also support other formats. The server provides information on the formats available, and the client makes the request for the data in the format it can use. If the server does not support GML2, it will not be supported by the MapInfo WFS client.

GML2 does not contain any style information. You can provide style information to associate with a particular WFS table.

A WFS request contains a description of query operations that can be applied to one or more features. The client generates the request and posts it to a WFS using HTTP. The web feature server then reads and executes the request.

The `GetCapabilities` operation queries the WFS server for capabilities. Then the MapInfo Pro WFS client can generate a query appropriate for the WFS server and table.

Each table in the WFS server can result in a single MapInfo table. The mapping is always 1-to-1 (unlike WMS, which is many-to-1).

The TAB file retrieved from a WFS server resembles a read-only DBMS linked table. It contains a MAP file and a DAT file, and acts like a read-only native table. Information is stored so that the table can be refreshed from the WFS server.

The sequence of actions can be summarized as follows:

1. After sending a `GetCapabilities` request to a WFS server, the server returns a list of WFS layers (FeatureTypes) that it can provide.
2. The user picks a WFS layer to fetch from the server, MapInfo Pro then sends a `DescribeFeatureType` request to the server. This response is an XML schema that describes the feature.
3. The user can then select which columns and/or rows to fetch.
4. MapInfo Pro sends a **GetFeature** request to the WFS. If the user did not select a subset of columns, all columns will be requested by default.

5. The response is a GML document containing the feature collection. Each feature represents one "record" in the MapInfo table.

There is a list of WFS servers in the client to help you get started in using this functionality.

**Note:** Since the data you retrieve using the WFS is remote, it may change from time to time. You can refetch your WFS data manually using the refresh process. See *Refreshing your WFS Data* in the Help System for more information.

### WFS Server Requirements

You must have a working Internet connection whenever you retrieve WFS data. To display GML2 data correctly in the MapInfo Pro Web Feature Service, the server you are requesting information from must:

- **Support versions 1.0.0 and 1.1.0 of WFS.** The MapInfo Pro WFS client sends the initial GetCapabilities and specifies version 1.1.0 (unless version 1.0.0 is set in MapInfo Pro as a preference). If the server you are requesting information from does not support 1.1.0 (or 1.0.0), MapInfo Pro cannot use that server and no further operations are allowed.

- **Respond to GetCapabilities request using Http GET in XML.**

- **Respond to the GetFeature request by returning GML2 (OGC GML 2.1.1).** The server's GetCapabilities response should include this information. If the server does not claim to use GML2 as the Result Format for GetFeature, then MapInfo Pro cannot use the server and no further operations will be allowed.

- **Conform to the OGC GetCapabilities schema.** If the server GetCapabilities response does not conform to the schema, MapInfo Pro may not be able to read portions of it. This may mean that MapInfo Pro misses items that the server is trying to communicate, such as feature types (tables), or filters. In some cases, MapInfo Pro will not be able to deal with the server, since necessary information cannot be found. In other cases, MapInfo Pro may miss functionality that the server is trying to provide, such as filters.

- **Support HTTP GET and/or HTTP Post for the DescribeFeatureType and GetFeature requests.** The MapInfo Pro client supports both HTTP GET and HTTP POST. The server should advertise what it accepts for each request in its GetCapabilities response. MapInfo Pro prefers HTTP POST for both operations, so if the server advertises that it supports both HTTP POST and HTTP GET methods for these operations, MapInfo Pro uses HTTP POST.

- **Supply the URL for both the DescribeFeatureType and GetFeature in their GetCapabilities response.** The URL provided must be valid for that request. If the server provides an invalid URL, MapInfo Pro's WFS client cannot work and displays a suitable error message.

The DescribeFeatureType response should be:

- **An XML Schema that contains the information for the table specified only.** If the server returns a schema that contains descriptions for multiple tables, MapInfo Pro cannot parse it correctly, and the operation will fail.
• **A Valid XML Schema.** If not, no further operations can be allowed for that feature type. Without a valid schema, MapInfo Pro cannot create or populate the table. In this case you can either select another table, select another server, or cancel the WFS dialog box.

**Note:** MapInfo Pro may not handle schemas that are "well formed" but contain invalid XML.

MapInfo Pro checks that the schema returned for DescribeFeatureType is well formed XML, but does not validate the XML. Our WFS client works correctly with many servers that return schema’s which contain invalid items, and our developers thought that eliminating these servers because they did not contain 100% valid XML was too limiting.

**Note:** MapInfo Pro cannot successfully handle schemas that contain invalid items, such as an invalid character in an element name - for example, "City Type" where the space in the element name is not valid XML.

While MapInfo Pro may be able to process a schema that contains well-formed but invalid XML, this may cause problems elsewhere, such as during the GetFeature processing. This may cause some confusion. If the XML returned during GetFeature does not match the schema, MapInfo Pro may create an empty table without displaying an error.

MapInfo Pro:

• **Does not process xsd:include.** All element types must be defined in the schema returned from the DescribeFeatureType request or derived from GML base types.

• **Supports all row filters that the server advertises in the GetCapabilities response with the following constraints:**
  
  • The filters are OGC-defined filters as specified in the OGC WFS Specification or the OGC Filter Encoding Implementation specification.
  • The filter takes 0 or 1 arguments beyond the column name. This is a user interface constraint. MapInfo Pro's interface is currently not set up to address such filters. This includes the A Between filter, which requires 2 values.

• **Supports MaxFeatures, but not all WFS servers seem to support this option.** While the OGC WFS Specification states that the server should implement this option, our experience has been that some servers ignore MaxFeatures.

• **Treats the Geometry column as mandatory.** While you can filter specific columns, MapInfo Pro always requests the Geometry column from the server. Many servers seem to treat the Geometry column as mandatory and return this column whether it is requested or not.

**Note:** The GML returned during the GetFeature request should validate against the schema returned during the DescribeFeatureType request. If this is not the case, then MapInfo Pro may not be able to create a table.

If a MapInfo WFS table is open, the user interface automatically enables the refresh process. During the refresh process, users can not change the query that is sent to the WFS server. The data will be refetched from the server using the original query. This refreshed information can then be saved to the table.
The Help System contains these related topics:

- Adding a WFS Server
  - Adding WFS Client Support
  - Removing a WFS Server Entry
- Opening a Web Feature Service Table
  - Applying a Coordinate Order Override to Correct how Objects Display on the Map
  - Testing the Coordinate Order of a WFS Table
  - Selecting and Filtering WFS Layers
  - Setting the Number of Records (Features) that a WFS Server Returns
  - Using Spatial Row Filters to Limit the Size of Data from the WFS
  - Changing a WFS Coordinate System
  - Changing WFS Layer Styles
  - Saving Retrieved WFS Data
  - Refreshing Your WFS Data
  - Adding Column Indices to WFS Tables
  - Working with WFS Tables that have Nested Structures
  - Overriding WFS Default Timeout Values Locally
  - WFS-Related Error Messages
- Saving Data Changes to the WFS-T Server
  - Use WFS-T by Setting a Preference to use WFS 1.0
  - How to determine which WFS version you are using?
  - Saving Data Changes to a WFS-T Server
  - Resolving WFS-T Data Conflicts
  - What to Do if You Cannot Complete Transactions using WFS-T
  - Who can Read .tab Files Created using WFS-T

Geocoding using a Geocoding Server

Not everyone in a flood zone loses their homes in a disaster. Accuracy in address matching (geocoding) can mean the difference between an insured being in a flood plain or on dry land. Knowing that information quickly and precisely can mean the difference in thousands of dollars of risk or no risk at all.

For retail customers, an advanced geocoder could be the difference between finding your product in a local store or wasting a trip.
For financial services customers, it could mean locating your best customers quickly when you have an opportunity to share with them.

You can use MapInfo Pro to connect to MapMarker and Envinsa servers to handle advanced geocoding functions.

Geocoding is the process of assigning geographic coordinates to your data, which can be street addresses. Point values assigned to each address turn each record into a geographic object that MapInfo Pro can display on a map. Visualizing your records on a map can make the relationships among your data clearer. You can display your geocoded records against a street map, a postal code centroid map, a county map, or whatever is most appropriate to your needs. You can then use the wide variety of functions available in MapInfo Pro mapping software to perform querying, create thematic maps, create territories, and perform many other types of geographic analysis.

Using the MapMarker and Envinsa Web Services, you have more choices for geocoding. For example, you can choose to geocode your records by street address or by postal code centroid, or by geographic centroids. If you have geocoded some records and some did not geocode successfully, you can set fallback conditions to locate those records. If you geocode and there are no results, poor results, or multiple equal close results, the geocoding server can present you with interactive options so you can select among possible matches or change your input. Further, these web services allow you to set multiple matching conditions when more than one record matches the records you are geocoding and set offsets for placing points right in the geocode properties.

For companies and organizations that use MapMarker and Envinsa servers as a geocoding engine, you can take advantage of the geocoding servers available to your whole enterprise. If your organization makes this server available on your intranet or over the Internet, you can use our geocoding web services from within MapInfo Pro to perform more sophisticated and accurate data geocoding.

**Note:** IMPORTANT: Pitney Bowes Software Inc. may not have a Geocoding Server with data that includes the geography you are interested in. Please check with your local Pitney Bowes Software Inc. sales personnel to ensure that web services exist for your geography.

**What Are MapMarker and Envinsa Geocoding Services?**

MapMarker is a powerful geocoding product that assigns coordinates to an address based on how well it matches entries in an Address Dictionary. The precision of the match can vary. For each address you geocode, you may get back a single perfect, street-level match, a list of street-level match candidates from which you choose the best match, or a less precise postal code centroid match, where the point would be located near the center of the postal code area. In the case of a ZIP + 4 centroid match, the location of the point corresponds to the address which is closest to the mid-address of the ZIP + 4 address range. You must have MapMarker 4.0 core to use this web service.

Envinsa provides a wider range of web services than MapMarker and can even provide access to earlier versions of MapMarker. Envinsa can determine these values from a street address or postal code. Envinsa servers require more security than MapMarker, so you will need a user name and
password to access them. Keep in mind that the services that are available on an Envinsa server depends on what was installed.

There are many reasons why using a geocoding service with MapInfo Pro is a good business solution.

- **Multiple Data Formats OK!** Since MapInfo Pro can import or open data in many different formats, you can geocode almost any kind of geographically enabled file. You can take advantage of MapMarker or Envinsa's advanced geocoding options using Shapefiles, Excel files, ASCII, Access tables, Oracle and SQL Server tables.
- **Data filtering.** You can use the selection and subselection capabilities of MapInfo Pro to create input for the service using any MapInfo Pro "table," including queries created using SQL Select or tools. For example, if you want to geocode your data based on more than one column, you can specify an input address based on a MapBasic expression that could skip irrelevant characters.
- **Geocode a Little or a Lot.** You can geocode individual records or in batch mode.
- Choose your own Symbols. You have the full range of MapInfo Pro symbols to choose from when plotting your points, or you can create your own custom symbols for the points you are geocoding.
- **Undo works!** Because all of the geocoded results are transacted, you can use MapInfo Pro's revert capabilities to undo the transactions. You can save the geocoded results in the source table or into a completely new table.

**Geocoding a Single Address using a Geocoding Service**

The process for geocoding a single address for an Envinsa or MapMarker service. Keep in mind that you must set up a geocoding service before you can use this type of geocoding.

The **Help System** contains these related topics:

- **Geocoding a Single Address using a Geocoding Service**
- **Setting up a Geocoding Server**
- **Setting the Geocoding Server Preferences**

**Understanding the Geocoding Result Codes**

The geocoding service returns a result code for each address it attempts to match. The code indicates whether a match was made, the type of match it was, and conveys information about the quality of the match. The result code is an alphanumeric code of 1-10 characters. There are four categories:

- Single close match to street level (S category)
- Postal Code centroid match (Z category)
- Multiple matches during automatic geocoding (M category)
- Non-matches (N category)

Matches in the M category indicate that there is more than one match candidate for the record and the geocoding service has chosen the best one of those candidates. This category displays when
you select the automatic option and the geocoding service finds more than one strong match candidate.

For S and Z categories, the first two characters represent the positional accuracy of the match, that is, where the point for the record would spot on a street map. For the S category matches there are eight additional characters that indicate the individual components in the input address that matched. If the geocoding service did not match on a particular address component, the code would contain a dash for that element. For example, a single close match to a street address that matched to all address components except house number would look like: S5-PNTSCZA.

<table>
<thead>
<tr>
<th>S Category: Single Close Match to Street Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>S6</td>
</tr>
<tr>
<td>matched to a point located at a Postal Code centroid</td>
</tr>
<tr>
<td>S5</td>
</tr>
<tr>
<td>matched to a street address</td>
</tr>
<tr>
<td>S4</td>
</tr>
<tr>
<td>matched to an interpolated point on the street segment</td>
</tr>
<tr>
<td>S3</td>
</tr>
<tr>
<td>matched to a Secondary Postal Code centroid (centerpoint of the Secondary Postal Code boundary)</td>
</tr>
<tr>
<td>S2</td>
</tr>
<tr>
<td>matched to a Primary Postal Code centroid (centerpoint of the Primary Postal Code boundary)</td>
</tr>
<tr>
<td>S1</td>
</tr>
<tr>
<td>matched to a Postal Code centroid (centerpoint of the Postal Code boundary)</td>
</tr>
<tr>
<td>SX</td>
</tr>
<tr>
<td>matched to a street intersection</td>
</tr>
<tr>
<td>S0</td>
</tr>
<tr>
<td>single close match, no coordinates available</td>
</tr>
<tr>
<td>H</td>
</tr>
<tr>
<td>matched to house number</td>
</tr>
<tr>
<td>P</td>
</tr>
<tr>
<td>matched to street prefix</td>
</tr>
<tr>
<td>N</td>
</tr>
<tr>
<td>matched to street name</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>---</td>
</tr>
<tr>
<td>T</td>
</tr>
<tr>
<td>S</td>
</tr>
<tr>
<td>C</td>
</tr>
<tr>
<td>Z</td>
</tr>
<tr>
<td>A or U</td>
</tr>
</tbody>
</table>

**Z Category: Postal Code Match**

<table>
<thead>
<tr>
<th>Z</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Z6</td>
<td>Postal Code centroid match</td>
</tr>
<tr>
<td>Z3</td>
<td>Secondary Postal Code centroid match</td>
</tr>
<tr>
<td>Z2</td>
<td>Primary Postal Code centroid match</td>
</tr>
<tr>
<td>Z1</td>
<td>Postal Code centroid match</td>
</tr>
<tr>
<td>Z0</td>
<td>Postal Code match, no coordinates available</td>
</tr>
</tbody>
</table>

**M Category: Multiple Automatic Matches**

<table>
<thead>
<tr>
<th>M</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>M1</td>
<td>multiple matches, point located at Postal Code centroid</td>
</tr>
<tr>
<td>M2</td>
<td>multiple matches, point located at Primary Postal Code centroid</td>
</tr>
<tr>
<td>M3</td>
<td>multiple matches, point located at Secondary Postal Code centroid</td>
</tr>
</tbody>
</table>
Creating Routing Distance and Time Buffers

To find out how many customers are within ten minutes drive of your stores to find all of the suppliers within 15 to 30 miles of your warehouse location, use a Driving Regions web service.

The Drivetime web service uses the latest road networks and fast search algorithms to show the buffer boundaries in time (isochrone) or distance (isodistance) from a specified location. These buffers are different from other MapInfo Pro object or table buffers because they are based on road networks and not straight line distances. Driving region time and distance buffers are calculated based on the speed limits of the individual roads and highways in the road network and the distance or time values you request. Isochrones and isodistances are collectively called isograms.

You can only access this Drivetime data and calculation functionality on an Envinsa 4.0 routing server. The Driving Regions web service helps you create isochrone and isodistance buffers using points in your own data.

An isochrone or a time buffer is a region that shows the area that a driver can reach from a starting point in a specific amount of time based on the speeds specified in the routing network. For example, if you wanted to put together an event and invite the customers who live within an hour's drive of...
the event site, you could create a time buffer for known customers within an hour’s drive. The service would then use the average driving speeds defined in the road network to calculate the time buffer from your event. You can then display your data within those buffer regions using a Select or SQL Select statement.

An isodistance or a distance buffer is a region that shows the area that a driver can reach from the starting point in the same distance. For example, if you want to contact all of the customers who live within 50 miles of the event instead of one hour, you could calculate the distance using the Drivetime web service, using similar logic.

Effectively, you are creating buffers from a point or table of points based on the server’s road network for specified times or distances. Using the Driving Region service options, you can control the way this information displays and the number of time and distance buffers you create at a time.

• For more information, see Creating Time or Distance Buffers for a Table and Rules when Adding a Driving Value in the Help System.

How are Time and Distance Buffers Calculated?

This is a raster map of a portion of a major city, but it could just as easily be your community.

You can travel further on a limited access highway than a local road in the same amount of time due to the difference in speed limits.

In it, you can see limited access highways, major roads with buildings on them, and local streets with homes. The speed limits on these streets vary depending upon their size and use. The routing server manages the speeds for each road type and uses those speeds to calculate the distance a
driver could travel in a specific amount of time. For example a driver could get further in an hour on a highway, than on a local road, due to the average speed limits on those roads.

If you think of these speed limits and distances in spatial terms, starting from a particular point, the region the web service could create along a highway would be longer and narrower than the region you would create using a more local road based on the same amount of time or distance request. That is the concept behind the Driving Region functionality.

### Using Driving Region Buffers to Display Data

You can create a driving region buffer (time or distance) to find out how far away your customers are from a particular event or location. We recommend that you add a server as described in the in the Help System in the Setting the Routing Server Preferences instructions before attempting to create time or distance buffers.

Here are some definitions that may be useful for you as you use this feature.

**Holes**

Areas within the larger boundary that cannot be reached within the specified time or distance, based on the road network.

**Island**

Small areas outside the main boundary that can be reached within the specified time or distance.

**Offroad Travel**

Offroad travel refers to streets that are not part of the server's road network, such as driveways, private roads, or access roads.

### Creating Time or Distance Buffers for Objects

You can use a routing server's driving regions network to create time or distance buffers around map objects to see your data in a new way. Keep in mind that these buffers are not like standard straight line circle buffers, but are rather based on the speed that a driver can travel on a particular road network. If you want to create time and distance buffers for an entire table of objects, see Creating Time or Distance Buffers in the Help System.

Before you begin this process, we recommend that you set up your own default routing server using the instructions in Setting the Routing Server Preferences in the Help System.

- For specific instructions and related topics, see creating Time or Distance Buffers for Objects in the Help System.
Enhancing Map Data using a Mapping Tile Server

A tile server is a server that contains a collection of raster tile images. The tiles cover a given place on the earth. Tiles are organized in a row/column grid fashion. There are also multiple levels of tiles. Each level represents a different resolution of data, covering the same place on the earth. The level determines the number of tiles (number of rows and columns). As you zoom in or out, the level of data may change. As you pan around, the specific tiles that are needed may change.

MapInfo Pro lets you use tile server data within the product. If you add a tile server layer to a MapInfo Pro map, then the application takes care of fetching the appropriate tiles from the server and displaying them. You only need to add the tile server layer and then pan/zoom.

For more about using raster images as a backdrop for maps, see Using Raster Images as a Backdrop for MapInfo Pro Maps.

About Tile Server Tables and Map Layers

MapInfo Pro has a table for tile servers that consists of a TAB file and XML file. These files contain the information necessary to communicate with a tile server and retrieve tiles correctly. This information includes server URL, coordinate system and bounds, and other parameters for retrieving the proper tiles.

After opening a tile server table in MapInfo Pro, you can add it as a layer to a map. Tile server layers act as an underlying base map, so they are added to the bottom of the layer list by default. Tile server layers do not have attribute data, so they cannot be edited and labeled. They are meant to be used as backdrop images.

Tile Server Display Properties

Display properties can alter the appearance of the tiles returned from a tile server. Tile server images are rendered using the same display attributes as raster images. This includes:

• Translucency
• Transparency - on/off and transparent color
• Brightness
• Contrast
• Grayscale versus color

Tile Server Coordinate System and Reprojection

Tile server layers do not support raster image reprojection. This means that a map's coordinate system will be set to use the tile server coordinate system if a tile server layer is visible in a map. If the map displays tiles from two different tile servers in different projection systems, then MapInfo Pro uses the projection system of the tile that is most visible on the map.

You cannot change the map coordinate system when a map has an active tile server layer.
Tile Server Authentication

Since the tile server functionality uses internet connectivity to obtain the images to draw, it is possible that the connection may require layers of authentication. If authentication is required, MapInfo Pro prompts you when the tile server table is opened. If the authentication fails, the table does not open.

Adding a Tile Server Layer to your Map

To add a tile server layer to your map (using the same way you add any other TAB file as a layer in a map):

1. Open the tile server table by selecting File > Open. The Open dialog box displays.
2. From the Files of type drop-down list, choose MapInfo (*.tab).
3. From the Look in list, navigate to where the tile server file is, select it from the list, and then click Open. The tile server displays as the bottom-most layer on the map.

If the tile server table is open, and you want to add it to one of several maps that you currently have open, then:

1. Open the Layer Control by selecting Map > Layer Control.
2. In the Layer Control list, select the map name to add the tile server layer to and click the Add Layers button.
3. In the Add Layer dialog box, select the tile server table and click OK.

The tile server displays as the bottom-most layer on the map and as a tile server layer in the Layer Control list.

Adding a Layer to your Map from a Map Tile Server

With a single click, you can add a Microsoft Bing layer to your map. You do not need to open the table prior to adding it to the map. If the current window is a map, MapInfo Pro adds the Bing layer to it. If the current window is not a map or there are no windows open, then MapInfo Pro creates a new map with the Bing layer.

To open and add a Bing Aerial, Bing Hybrid, or Bing Roads layer to a map, select File > Tile Server Maps and then select one of the following:

- Add Bing Aerial to Map
- Add Bing Hybrid to Map
- Add Bing Roads to Map

Or select one of the following on the Standard toolbar:

**Bing Arial**, **Bing Hybrid**, or **Bing Roads**

The menu and toolbar items are always enabled except when the TAB file is missing, then the menu and toolbar item is disabled. MapInfo Pro checks for the presence of the TAB files only once, during program startup.
The map refreshes and displays the tile server layer as a base image (the bottom layer of the map). For more information, see *Setting Timeout Values for the Bing Service* in the Help System.

**Map Tile Server Table Names and Location**

There are three tables for Bing Aerial, Bing Hybrid, and Bing Roads installed in to a subdirectory called TileServer where MapInfo Pro is located. The files are:

<table>
<thead>
<tr>
<th>BingAerial.tab</th>
<th>BingHybrid.tab</th>
<th>BingRoads.tab</th>
</tr>
</thead>
<tbody>
<tr>
<td>BingAerial.xml</td>
<td>BingHybrid.xml</td>
<td>BingRoads.xml</td>
</tr>
</tbody>
</table>

The following files are provided to connect to an OSM-based tile server:

- OSMRoads.tab
- OSMRoads.xml

The following files for connecting to the Cyber Japan tile server. They contain data in the area of Japan, but not other parts of the world.

<table>
<thead>
<tr>
<th>CyberJapanAerial.tab</th>
<th>CyberJapanAerial.xml</th>
<th>Aerial imagery for Japan at levels 15-17.</th>
</tr>
</thead>
<tbody>
<tr>
<td>CyberJapanStandard.tab</td>
<td>CyberJapanStandard.xml</td>
<td>Road-like data for Japan at levels 5-18.</td>
</tr>
</tbody>
</table>

**Performing Distance Calculations on Maps from a Map Tile Server**

Bing Maps uses a slight variation of the Mercator projection. This is a conformal projection that is ideal for navigation, because shapes, directions, and angles on a map are constant. However, distance and scale distortion increases further away from the Equator. As a result, North-South lengths stretch in Northern Latitudes, such as in Finland, and in Southern Latitudes, such as in New Zealand. This is also why some areas, such as Greenland and Antarctica, appear huge on the map.

If you are experiencing inaccurate distance or line length calculations, because you are working in a location that is closer to the North or South pole and further away from the Equator, then use a spherical distance calculation.

**To set the type of distance and area calculation to use:**
1. Select **Options > Preferences > Map Window**.
2. In the **Map Preferences** dialog box, select the **Projection** tab.
3. In the Distance/Area using pane, either of the following:
   - **Spherical** - The Spherical calculations measure distance according to the curved surface of the Earth. Spherical is the default. The data is first converted to Latitude/Longitude and then a calculation is produced. Lat/Long data will always use spherical calculations.
   - **Cartesian** - The Cartesian method performs calculations on data projected onto a flat plane. Cartesian coordinates (x,y) define the position of a point in two-dimensional space by its perpendicular projection onto two axes which are at right angles to each other. Long/Lat projections cannot use Cartesian calculations.
4. Click **OK** to save your setting.

**Note:** To specify a calculation method for the currently active Map window, use the **Map Options** dialog box (on the **Map** menu, click **Options**).

For more information about map preferences, see *Setting your Map Window Preferences* in the *Help System*.

**Bing Licensing**

**Bing Licensing**

If you do not have a valid Bing license key, you would be unable to use Bing Tile Services. In this case, accessing Bing Roads, Hybrid, and Aerial would display the following error:

![Error Message](image.png)

Again, if you have a saved workspace containing a Bing Tile Server layer or a map with objects and vector layers on it, and your Bing key is invalid; you will be unable to open the workspace properly. The workspace would open, but without the tile server layer. The following error message would appear:
To resolve these errors, re-enter a valid Bing license key to the Bing Tile Services.

To enter the valid key credentials:

1. On the Help menu, point to Licensing and click Bing Key to display the Bing Key Credential dialog box.

2. Type a valid value in the Enter valid key field and click Ok.

The Bing Roads tile server also may require that you have a valid license for them. If you see a message that your service has expired, then contact your Pitney Bowes Software representative to learn about renewal options. The Add Bing Roads to Map feature is only available to MapInfo Pro Premium Option holders (this service requires an additional fee and do not come standard with the product). The evaluation version of MapInfo Pro includes a preview of this feature, but after activating your MapInfo Pro license, you require the Premium Option to access it.
Working with Tile Servers

Tile Map Service (TMS) is an Open Source Geospatial Foundation specification to manage cartographic data. TMS is similar to the other LevelRowColumn types of tile server protocols that MapInfo Pro supports, such as Google Enterprise.

MapInfo Pro now supports TMS servers with either North-West or South-West origins.

You can now use a TAB and XML file to view Google tiles within MapInfo Pro. Once the TAB and XML files are properly setup, you can open and use the TAB file just like any other tile server table.

Changing the Map Zoom to the Nearest Tile Server Level

Based on a selected zoom level, a tile server provides various types of information. In MapInfo Pro, you can zoom on a tile server layer to any specified scale. In doing so, the tile server images may stretch making them appear fuzzy and pixilated. To correct for this, you can select to display tile server images at an optimal zoom level based on the tile server and current screen resolution. This is a one-time adjustment to the current display.

To change the zoom to the nearest optimal display for the tile server image:

1. On the Layer Control window, right-click the tile server layer and select Change Zoom to Nearest Tile Server Level from the pop-up menu.

   If there are multiple tile server layers in a map, the Zoom to Nearest Tile Server Level dialog box opens where you can choose a tile server layer.

   The map redraws with a zoom to the nearest tile server layer level.

Setting Tile Server Layer Properties

Tile server layers offer the ability to alter display attributes of the image tiles. These are the same properties that are supported for raster layers and include: translucency, transparency, brightness, contrast and grayscale.

To access layer properties for a tile server layer:

1. Open the Layer Control window by selecting Map > Layer Control.
2. Select a tile server layer in the Layer Control list.
3. Click the Layer Properties button.
4. Check the Style Override check box.
5. Click the style button (below the Style Override check box). The Adjust Image Styles dialog box displays.
6. Change the image properties to suit your needs.

   Tile server layers may be set as translucent.
**Note:** The sample image shown in this dialog is based on the current view in the map. If you wish to see a different sample image in this dialog, you will need to change the map view prior to bringing up this dialog. You may wish to change the view/image if selecting a transparent color because the transparent color picker selects a color from the sample image.
17 - Specialized Topics in MapInfo Pro

The topics in this chapter cover the advanced use of MapInfo Pro.

In this section

- Embedding MapInfo Pro Maps 511
- Internet Connectivity and MapInfo Pro 514
- Redistricting-Grouping Map Objects into Districts 516
- Creating Expressions 520
- Working with the MapBasic Window 533
Embedding MapInfo Pro Maps

MapInfo Pro brings its power of map display, creation and editing right into your favorite application so that you may build a map where you need it. This chapter covers the basics of OLE and the MapInfo Pro features that you may use in other applications to create dynamic maps.

MapInfo Pro's OLE embedding capability turns your applications such as word processors and spreadsheets into "mini-MapInfo" programs where you can create, display and edit a map for presentation, reporting or publishing. OLE is a process known as Object Linking and Embedding whereby a server application (such as MapInfo Pro) provides information that is stored in a client application that can accept OLE information (such as a word processor). MapInfo Pro's OLE embedding functionality allows you to embed a Map window in any application that accepts OLE objects and use some of MapInfo Pro's features to create, display and edit the map directly in that application.

With MapInfo Pro OLE Embedding you can build the map directly in your OLE container application, or you can create it in MapInfo Pro and drag the Map window into your application for additional editing or output. Because the MapInfo Map Object is a live OLE object, you are in fact running MapInfo Pro in the background. When the Map window is active in the container, the menu and toolbar of your application change to reflect the MapInfo Pro features that become available. This subset of features is called MapInfo Map. (Some OLE containers will create a separate window for the object.) With the click of a button or by choosing a menu command, you have MapInfo Pro functionality in your application where you need it.

- For more information about OLE features and requirement in MapInfo Pro, see the MapInfo Pro Help System.

What You Should Know First

Before you get started, it is good to review the system requirements and the registration statement to ensure that you understand where to look for your MapInfo Map Objects.

System Requirements

MapInfo Map is an OLE server application that runs under 32-bit MapInfo Pro. You must install MapInfo Pro 32-bit to engage MapInfo Map. On the client side, only container applications that support OLE embedded objects can run MapInfo Map.

Registering OLE Objects with Containers

Once MapInfo Pro has been installed on your system, the MapInfo Map Object will be registered automatically and listed as a choice in the Object dialog box of any container application that accepts OLE objects.
Menus and Commands Available While Using the MapInfo Map

MapInfo Map replaces all container menus except File and Window with five MapInfo Pro menus: Edit, View, Table, Map and Help. Under each menu, selected MapInfo Pro features have been included, as outlined in this section. This section contains summaries of MapInfo Map’s menu commands and tools. Be sure to refer to other chapters in this Guide and the rest of the MapInfo Pro documentation set for more complete discussions.

- For more about the specific commands available when working with Map windows, see the Help System.

Limitations of OLE

Although MapInfo Map enables you to build a map very easily in your container application, not all of MapInfo Pro's features are available in the context of map embedding. Among them are editing map objects such as regions or polylines, querying a table for further analysis, geocoding to a table in the Map window, or displaying tables in Browser windows.

However, with MapInfo Pro's drag and drop capabilities you can still perform these functions in MapInfo Pro and bring over the Map window to your OLE container application for final viewing, formatting and editing enhancements.

Working with Embedded Maps

Now that you have had an introduction to MapInfo Map Object and what it can do for you as you work in another application, let us get down to the specifics of embedding an OLE object.

**Note:** You need to specify what gets copied to the clipboard. By default, you cannot copy a map until you set this preference. See Setting Your Copy to Clipboard Preferences in the Help System.

Although containers vary in their handling of OLE objects, there are some behaviors that are common to all. There are three ways that containers accept embedded OLE objects such as a Map window:

- On the Insert menu, click Object to choose the object to embed from a list.
- On the Edit menu, click Paste (or Paste Special) to embed an object that was previously copied to the Clipboard.
- Drag and drop from the application to the container using the Drag Map Window tool.

The method you choose depends on which application you are in at the moment (server or client) and how much you want to do to create the final map.

- For more information and related topics, see Creating a New Map Window in your Container and Bringing a Map Window into your Application in the Help System.
Sharing Documents with Embedded Maps

Once you have created a map in your document, you may want to share it with a colleague. Or you might want to use it on another system. When the document is opened on another system, the MapInfo Map Object displays as a metafile, or picture of the map, in the inactive state. The map is like any other graphic image at this point. If no map editing is necessary, the document can be printed, reformatted, reorganized, and saved with no special handling required for the map. The map itself can even be resized or repositioned. You cannot, however, change the content of the map since it is not an active OLE object.

To activate the map for editing on another system, your colleague must have access to 32-bit MapInfo Pro and the data used to create the map. Double-click the map to activate the OLE object. MapInfo Pro will prompt for the location of the data files if it cannot find the original location. If the data is not available, cancel out of the Locate Data dialog box. The metafile image is replaced with the MapInfo Pro world map in the active state. To retrieve the original metafile image, close the document without saving and reopening it.

**Note:** Sharing MapInfo Pro and map data on other systems is limited to the extent of your license agreement(s).

- For more information, see MapInfo Map Objects vs. Data Map Objects in the Help System.

Using MapInfo Tables with Data Map

Data Map uses MapInfo Pro tables. All of the sample maps provided with Data Map are actually MapInfo Pro tables.

If you have created your own MapInfo Pro tables, you can use your tables in Data Map. However, before you can display your table in Data Map, you must set up your table using the Data Map Data Installer. To launch the Data Installer, double-click the file DATAINST.EXE. (To locate this file, click Windows Start, and then click Find.) Once you have launched the Data Installer, complete the dialog boxes that appear on the screen.

Note that some MapInfo Pro tables cannot be used with Data Map. Specifically:

- Data Map cannot display raster image underlay tables.
- Data Map cannot display a table that is actually defined as a relational join of other tables (such as a Pitney Bowes Software Inc. StreetPro table). To use a street table with Data Map, use MapInfo Pro’s Save Copy As command, which saves a street table in a "flat" form that Data Map can use.
- Data Map cannot display point objects that use MapInfo Pro "Custom" symbol styles. (Custom symbols are selected by displaying MapInfo Pro's Symbol Style dialog box, and then selecting "Custom Symbols" from the Font drop-down list.) If your MapInfo Pro table contains points with custom symbol styles, those points will be invisible in Data Map.

For more information about Data Map, see the Data Map Help System. For more information about the Data Installer, see the Data Installer Help System.
Internet Connectivity and MapInfo Pro

MapInfo Pro contains options that allow you to bring the Internet into your mapping sessions, and to bring your maps to the Internet.

Using active objects and the HotLink tool, you can launch files and Internet URLs directly from objects or labels on your map. Active objects provide you with a powerful display tool that allows you to bring information from the Web and other applications together in your map.

These additional sources of information can give your analysis or presentation greater impact. For example, you can link a location on your map to a Web site that gives more information about the location or to an image file that shows certain aspects of the location in more detail.

In addition, you can use the maps you create in MapInfo Pro in your Web pages. The HTML Image Map tool converts a MapInfo Pro map into an HTML image map. Visitors to your Web page will be able to click any region to link to other HTML pages specific to that region.

What Are Active Objects?

Active objects are map objects that are associated with files or URLs. The file can be a bitmap, a MapInfo Pro workspace or table, a MapBasic program, or any type of executable file whose extension is associated with an application installed on your system.
The active object in this map (red triangle) is linked to a webcam web site that displays an erupting volcano.

The Help System contains these and other related topics:

• Adding URL Information to your Table
• Combining a District’s Objects
• Creating Active Objects
• Creating Multiple HotLinks in a Map
• Using the HotLink Tool in a Map Window
• Saving a New District and Exiting the Redistricter

HTML Landing Pages

The Landing Pages option allows you to click any region in the HTML image map and link to an HTML landing page specific to that region. You can put whatever content you want into the landing pages, including column information from your table. The user interface enables you to select the columns you want to use and customize the text.

• For more about selecting columns for landing pages and Tooltips, see the Help System.
Redistricting-Grouping Map Objects into Districts

One popular use of MapInfo Pro is to group map objects with a common field into districts or territories. MapInfo Pro’s Redistricting feature allows you to create new districts, realign existing districts, all the while doing calculations of the attached data on the fly for instant analysis and decision-making.

What is Redistricting and How Can I Use It?

Redistricting is the process of assigning map objects to groups. As you assign map objects to groups, MapInfo Pro automatically calculates totals for each group of objects, and displays the totals in a special Browser window called the Districts Browser. This process is sometimes known as load-balancing.

When you perform redistricting, you create a number of districts. The exact number of districts needed depends on the nature of your work. You can assign a unique name to each district; thus, if you want to work with four districts, you might call the districts Northeast, Southeast, Northwest, and Southwest. Each district appears as one row in the Districts Browser.

The Districts Browser is different from other Browser windows in several respects:

- You only can select one row at a time from the Districts Browser. You cannot Shift-click to select multiple rows.
- The Districts Browser always has one row selected; you cannot cancel the selection of this row by choosing Unselect All.
- When you select a row from the Districts Browser, that row becomes the target district. The target district is the district that will be affected by subsequent redistricting operations.

Once you have selected a target district, you assign map objects to that district by selecting the map objects. You can select objects by pointing and clicking, or by performing queries such as SQL Select.

When you select map objects, MapInfo Pro tentatively assigns the selected objects to the target district. MapInfo Pro then recalculates the totals for each district, and displays the new totals in the Districts Browser. You can then examine the contents of the Districts Browser to decide whether you want to make the district assignments permanent.

To cancel the tentative district assignment, cancel the selection of the map objects.

To make the tentative district assignment permanent, choose Redistrict > Assign Selected Objects. When you choose Assign Selected Objects, MapInfo Pro stores the target district’s name in the rows of the selected objects. Thus, if you assign map objects to a district called Northwest, MapInfo Pro stores Northwest in each object’s row.
Each district has its own set of fill, line, and symbol styles. When you assign a map object to a district, the object subsequently appears in the style of the district. Thus, if you choose a solid blue fill for the Northeast district, objects that you assign to Northeast appear in solid blue.

For example, if you have a layer of states, you might want to combine the state boundaries to create sales territories. Each state record includes a field, TOT_SALES, which contains the total sales for the previous year. You would ultimately like to sum up the TOT_SALES field for each state in a given sales territory. Redistricting gives you the tools for creating the sales territory and combining those TOT_SALES fields from each state’s data into one table.

![Districts Browser](image)

**Note:** The STATES table used in this example is from the MapInfo Pro Tutorial data, which is available from the Pitney Bowes Software Inc. web site, [http://go.pbinsight.com/webtutorials](http://go.pbinsight.com/webtutorials).

But that is only one part of the redistricting process. The real power lies in the Districts Browser where you can see on-the-fly updates of district record counts and data totals when you click a map object and assign it to another district. This allows you to perform visual "what if" analysis to achieve district realignments, a process sometimes referred to as load balancing.

When you are satisfied with the distribution, you can make the district assignments permanent. Later, as the need arises, you can change the assignments and try out new distributions.
Redistricting does not create new map objects or permanently change the style of the map objects. Redistricting is simply a dynamic grouping tool that displays map objects that share the same district information as a group. While the map objects are not permanently affected, you can make the district assignments permanent by saving the table.

You can redistrict any mappable table containing region, line, or point objects. The redistrict map will reflect the appropriate fill, line, or symbol style for the objects. The Redistricter limits the number of districts in a table to 594.

You can use redistricting in a wide variety of applications such as creating and managing sales territories, school or voter districts, emergency service coverage areas, delivery routes, natural resource management areas, etc. Use it wherever there is a high degree of fluctuating data and the need to try out different realignment scenarios.

You can use redistricting whether you need to create districts from scratch or realign existing districts. Before we get into the process, however, there are two key concepts to introduce: the Districts Browser and Target District.

**Using the Districts Browser**

The Districts Browser is the key to the process of creating and changing districts. While looking like other Browsers in MapInfo Pro, the Districts Browser is actually a dynamic window that allows you to make changes to the groups and recalculates total values on the fly. You can immediately see the results of your changes. You then have the option to make the changes permanent or continue to try out new district realignments.

The Browser window lists the districts as specified in your table, the record count for each district, and aggregate expression columns that contain the net total values of your data. You specify these columns in the **New Redistrict Window** dialog box when you begin the redistricting session.

<table>
<thead>
<tr>
<th>District</th>
<th>Count</th>
<th>Fill</th>
<th>Sum(Pop_2010)</th>
<th>Pct(Pop_2010)</th>
</tr>
</thead>
<tbody>
<tr>
<td>****</td>
<td>34</td>
<td>0</td>
<td>216,080,116</td>
<td>69.9865</td>
</tr>
<tr>
<td>Zone 1</td>
<td>9</td>
<td>0</td>
<td>55,317,240</td>
<td>17.9168</td>
</tr>
<tr>
<td>Zone 2</td>
<td>8</td>
<td>0</td>
<td>37,348,182</td>
<td>12.0968</td>
</tr>
<tr>
<td>Zone 3</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

* For more instructions about creating and adding redistricting features and other related topics, see the **Help System**.

For additional topics in **Redistricting**, see **Setting up the Target District** in the **Help System**.
Using Redistricting

When you calculate the percentage of partial columns (such as population columns that cite income, gender, age, ethnic background, or religious affiliation) you have two calculation methods available. One method calculates the percentage by column so that the sum of all of the entries in every column would be 100%. Another method calculates the percentage by row based on your selected row entry (or sum of entries) so that each percentage entry in the row is calculated based on that row (or sum of entries). For example, in the following table:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>2</td>
<td></td>
</tr>
</tbody>
</table>

The Column method determines the percentages of entries in Column A:

\[
\text{Percentage (A1)} = \frac{A1}{A1 + A2} \times 100\%; \quad \text{Percentage (A2)} = \frac{A2}{A1 + A2} \times 100\%
\]

The Row method determines the percentage for entries A1 and B1 based on C1 as a total column:

\[
\text{Percentage (A1)} = \frac{A1}{C1} \times 100\%; \quad \text{Percentage (B1)} = \frac{B1}{C1} \times 100\%
\]

Note: Selecting a valid base entry (or the sum of the entries) is crucial to returning meaningful results. For example, if you choose a value in a population column and a base value from an income column, your results will not be meaningful.

* For more information, see Creating New Districts and Redistricting using the Row Method in the Help System.

Options in Redistricting

To control the order of districts in the Districts Browser, on the Redistrict menu, click Options. The Redistrict Options dialog box displays. Choose your preferred sort order from among: most recently used, alphabetical, or unordered. You can also choose to show the Browser grid lines and save the options as your default.

As mentioned earlier, the Most Recently Used option can greatly aid you if you have more districts than the Districts Browser can display in a window. Whenever you select a map object that belongs to a district that is not currently visible in the Browser, MapInfo Pro will move that record near the top of the Browser window. You can then more easily set the new target district or view the changes in the data fields as you carry out your load-balancing scenario.
Changing the display of your districts is simple. Click the fill pattern, line style, or symbol in the Districts Browser that represents the district. The Region Style, Line Style, or Symbol Style dialog box displays, where you can change the tools used to display the district.

To save the style changes, you must save the redistricting session as a workspace. Save Table will only save the district assignment changes. The styles belong to a thematic layer, not to the table itself. The district changes are applied to the table and, thus, can be saved to the table.

**Records with No Graphic Objects**

Redistricting involves grouping map objects into districts. If you are redistricting a table that contains records that do not have graphic objects associated with them, keep in mind that MapInfo Pro includes them as well in the Districts Browser. You cannot assign these records to new districts. They will affect your data calculations when you move objects into new districts.

If you have numerous records without graphic objects in your table, it may be best to create and save a subset of the table and run the Redistricter on the new table.

### Creating Expressions

Formulating expressions is something like writing sentences. There is a vocabulary of words from which you can draw, and these words have to be combined according to syntactic rules. The syntax of expressions is much simpler than the syntax of English, and the vocabulary is vastly smaller. However, most of us have been using English for years and so it seems easy and natural whereas formulating expressions is, at first, sometimes a bit difficult.

However, just as English has simple sentences and complex sentences, so there are simple expressions and complex ones. Even if you do not get the hang of formulating complex expressions, you can still use all the MapInfo Pro commands that use expressions. That is because formulating simple expressions is very easy and, at the same time, allows you to work with your data in powerful ways.

- Most of the procedural information for Creating Expressions is available in the Help System.

### Where Expressions Can Be Used

Use the Expression dialog box to formulate mathematical and alphanumeric expressions in several MapInfo Pro dialog boxes. See Specifying an Expression in the Help System.

Expressions are used in the following commands: Select, Update Column, Thematic Mapping, and Layer Control (double-click the layer and select from the Label with list on the Label Display tab). The expression serves a different purpose in different commands.

For example:
In the Select command the expression states a condition that a record in a table must meet in order to be included in a query table.

- In Update Column the expression calculates a value that is then entered into a table.
- In Thematic Mapping the expression calculates a value that is then displayed on a map.
- In Label Options, you use expressions containing string functions to fine tune your labels.

The expressions fall into two broad categories:

- Expressions that must evaluate to true or false.
- Expressions that simply calculate some value.

Expressions that must evaluate to true or false always have a comparison operator and may have multiple clauses connected by logical operators. Use these expressions for selecting objects.

Expressions that simply calculate some value never have a comparison operator and generally do not have multiple clauses. Use these expressions to calculate values for Thematic Mapping, Update Column, and Label With Column in Layer Settings.

Constructing Simple Expressions

You formulate expressions using column (field) names and constants (for example, specific data values), on the one hand, and functions and operators, on the other. Think of the column names and constants as nouns, and functions and operators as verbs, prepositions and conjunctions. You always need at least one column name or a constant in an expression. How many operators and functions you need depends on what you want to do with your expression.

The simplest possible expression consists of a column name, for example:

1. POP_1990
2. STATE

You could use such an expression in Thematic Mapping to indicate what data is to be represented on the map. In Update Column such an expression would tell MapInfo Pro what data to use in updating a column in the target table.

Here are some slightly more complex expressions:

1. POP_1990 > 17893
2. POP_1990 <= POP_1980
3. COUNTY <> "Orange"
4. POP_1980 * 1.2
5. POP_1990 / TOTAL_AREA
6. round(POP_1990/TOTAL_AREA,.1)

The first three examples use comparison operators. The first tests to see whether the 1990 population is greater than (>) some constant (17893). The second tests to see whether the value of one column, POP_1990, is less than or equal to (<=) the value of another column, POP_1980. The third tests to see whether or not the county is Orange. When the county does not equal (<> "Orange" the record is selected. You could use any of these expressions in Select or in the Where Condition clause of
SQL Select. These commands allow you to select a subset of the records in a table. The expression defines the characteristics of the subset.

Examples 6 and 7 use arithmetic operators. Example 6 multiplies (*) the value of POP_1980 by a constant (1.2) while example 7 divides one column, POP_1990, by the value of another column, AREA.

Example 8 uses the round function to round the value of the expression "POP_1990/TOTAL_AREA" to the nearest tenth (.1).

Expressions 6, 7 and 8 do not have comparison operators and therefore they would not be suitable for use in Select or in the Where Condition clause of SQL Select. However, you could use them alone in Thematic Mapping, Update Column, or Select columns in SQL Select.

Setting Filter Criteria for Expressions

A filter criterion is a logical expression that usually compares a column value against some other value. For example, the following filter criterion uses the greater-than operator (>) to test whether the Order_Amount column has a value greater than one hundred:

```
Where Condition: Order_Amount > 100
```

If a query includes the preceding Where Condition clause, MapInfo Pro selects only the rows that have an Order_Amount value greater than one hundred.

The Where Condition field can contain two or more logical expressions if the expressions are separated by the word And or by the word Or. If the expressions are joined by the word And, MapInfo Pro only selects the rows that satisfy both criteria. If the expressions are joined by the word Or, MapInfo Pro selects any row that satisfies either criterion.

Filter criteria can use any column in your base table(s), regardless of whether you included the column in the Select Columns field.

Columns can be referred to by name or by number, where the number designates the order the column has in Select Columns. Thus, "col1" and "col6" refer to the first and sixth columns, respectively. The number must be preceded by the letters "col".

• For more instructions and related topics, see the Using Expressions to Create a New Column topic in the Help System.

Constructing Complex Expressions

Now consider examples 9 and 10, that are a bit more complex than 1 through 8:

1. POP_1990 > POP_1980*1.2
2. round((POP_1980*1.2)/TOTAL_AREA,.1)

We created expression 9 by taking expression 3 and replacing the constant "17893" with the whole of expression 6. Similarly, we created expression 10 by taking expression 8 and replacing "POP_1990" with expression 6.
In general, you create complex expressions by combining simple expressions. Perhaps the best way to learn how to do this is look at some of the examples we have provided (above and following) and create your own expressions based on those examples. However, there are two very general techniques for creating complex expressions.

- Replace a column name or a specific value with a simple expression.
- Combine expressions using logical operators (and, not, or).

Example six illustrates the first technique. There are many examples of the second technique throughout this entry. See particularly the discussion following Using Logical Operators in Expressions.

### Entering Specific Values (Constants) into Expressions

Use the Expression dialog box to formulate mathematical and alphanumeric expressions in several MapInfo Pro dialog boxes.

When entering specific character strings, numbers, and dates into expressions, you need to observe the following conventions.

#### Character Strings in Expressions

When typing a particular string into an expression you must enclose it in double quotes. MapInfo Pro then treats it as a string rather than as a column name. For example, strings 1 and 2 shown below are valid string constants, while 3 and 4 are not.

1. "Orange"
2. "New York"
3. Orange
4. New York

#### Numbers in Expressions

When entering specific numerical values, do not use commas, dollar signs, or any characters other than numerals, decimal points, and the minus sign for negative numbers. You can use E to denote numbers in exponentiation.

#### Date Values in Expressions

Dates consist of a month, a day, and an optional year. The year is specified by two or four digits and enclosed in double quotes. The components of a date are separated by hyphens or slashes. If the year is not specified, it defaults to the year set on your computer’s clock. The following are valid data constants:

<table>
<thead>
<tr>
<th>System Order</th>
<th>What MapInfo Pro Expects</th>
</tr>
</thead>
<tbody>
<tr>
<td>M/d/yy</td>
<td>02/28/2005</td>
</tr>
</tbody>
</table>
Using Mathematical Operators in Expressions

Use the Expression dialog box to formulate mathematical and alphanumeric expressions in several MapInfo Pro dialog boxes. Mathematical operators are often used in creating expressions. The following chart shows the operator's symbol, name, example, and how the operators handle different data types.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
<th>Example</th>
<th>Detailed Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>plus</td>
<td>A + B</td>
<td>Date + Number: Date</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>04/01/2007 + 4: 04/05/2007</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>FloatNumber + Date: Date</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>4 + 232: 236</td>
</tr>
<tr>
<td>-</td>
<td>minus</td>
<td>A - B (subtraction)</td>
<td>Date - Number: Date</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Number - Date: Date</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>236 - 4: 232</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>some number - some number: Float</td>
</tr>
<tr>
<td>*</td>
<td>times</td>
<td>A * B</td>
<td>some integer * some integer: Integer</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>some number * some number: Float</td>
</tr>
<tr>
<td>/</td>
<td>divided by</td>
<td>A / B</td>
<td>some number / some number: Float</td>
</tr>
<tr>
<td>^</td>
<td>exponentiation</td>
<td>A ^ B</td>
<td>some number ^ some number: Float</td>
</tr>
</tbody>
</table>
The following calculations are possible:

- Adding numbers to dates to yield another date.
- Subtracting a number from a date to yield another date.
- Subtracting a date from a date to yield a number.

When you add numbers to dates or subtract numbers from dates, MapInfo Pro treats the numbers as specifying a number of days. When you add or subtract a week, you use the number 7.

When you add or subtract a month, you use 30 or 31. When MapInfo Pro subtracts a date from a date, the result indicates a number of days.

### Using String Operators in Expressions

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>&quot;concatenation&quot; - connects strings and string expressions.</td>
</tr>
<tr>
<td>&amp;</td>
<td>(can be used if preceded by a space)</td>
</tr>
</tbody>
</table>

Strings must be enclosed in double quotes. Consider the following example:

```
"Ms." + Last_Name
```

When MapInfo Pro evaluates this as part of an expression it places "Ms." in front of each last name. Note that the string constant ("Ms. ") is in quotes. Similarly,

```
"Hello," + "world"
```

gives you "Hello, world." And

```
"4" + "5"
```

gives you "45."

### Using Comparison Operators in Expressions

Use the Expression dialog box to formulate mathematical and alphanumeric expressions in several MapInfo Pro dialog boxes. Comparison operators are often used in creating expressions. The following chart shows the comparison operator symbols and a description.
<table>
<thead>
<tr>
<th>Operators</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>&quot;equals&quot;</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>&quot;not equals&quot;</td>
</tr>
<tr>
<td>&gt;</td>
<td>&quot;greater than&quot;</td>
</tr>
<tr>
<td>&lt;</td>
<td>&quot;less than&quot;</td>
</tr>
<tr>
<td>&gt;=</td>
<td>&quot;greater than or equal to&quot;</td>
</tr>
<tr>
<td>&lt;=</td>
<td>&quot;less than or equal to&quot;</td>
</tr>
</tbody>
</table>

The Help System contains these related topics:

- **Numerical Comparison**
- **String Comparison**
- **Date Comparison**
- **Logical Comparison**

**Numerical Comparison**

Numerical comparisons are based on the numerical values of the expressions and numerical constants.

**English:** All rows where the household income is above $65,000.

1. HH_INC>65000

Comment: Do not add the dollar sign or comma. MapInfo Pro does not know what to do with it and gives you an error message.

**English:** All rows where the median age is 42.

1. MED_AGE=42

Comment: This expression selects only those records where the median age is exactly 42. When your median age data contains a decimal portion (which is the case for MapInfo Pro-supplied demographic data) then it is unlikely that there are many regions with a median age of exactly 42.

The following expression gives you better results:

1. Round(MED_AGE, 1)=42
Comment: The function "round(somenumber, somenumber)" rounds the first number in the way specified by the second. In this example, the first number is the median age (MED_AGE) and the second is 1, indicating that median age is to be rounded to the nearest whole number.

**English:** All rows where the amount does not equal $23,000.

1. AMOUNT<>23000

Comment: You might want to use the Round function, as in 10, if you are not concerned that the value be exactly 23000.

**String Comparison**

String comparisons are based on the exact character content of the string. In this case ">" means "alphabetically greater than" (for example, comes after in the alphabet) and "<" means "alphabetically less than."

When typing a string into an expression, you should enclose it in quotes so that MapInfo Pro knows to treat it as a string, rather than treating it as a column name.

**English:** All rows where the vendor is Acme.

1. VENDOR="Acme"

Comment: Note that Acme is in quotes so that MapInfo Pro knows to treat it literally (as a character string) rather than to search for a column named Acme.

**English:** All rows where the vendor is not Acme.

1. VENDOR<>"Acme"

**Date Comparison**

**English:** All entries received on October 9, 1991.

1. RECEIVED="10-9-91"

**Note:** Consider these conventions:

- The date is enclosed in quotes
- It is in the form: Month, Day, Year
- The numbers in the data are separated by a hyphen or a slash (/)
- Two characters were used for the year. You can also use four characters (1991)

**English:** All received after October 9, 1991.

1. RECEIVED>"10-9-91"

Comment: This expression does not select those received on October 9, 1991. When you want them as well:

1. RECEIVED>="10-9-91"

**English:** Records for all received before August.

1. Month(RECEIVED)<8
Comment: This expression uses the Month function to extract the month in the date. It does not specify any particular year. When your database has records for several years, this expression does not pay attention to the particular year.

**Logical Comparison**

**English:** All that have shipped.

1. Shipped

Comment: The column "Shipped" is a logical column. It contains "T" for true, or yes, and "F" for false, or no. When an order is shipped, it is marked "T". Otherwise, it is not shipped. For orders that are shipped, expression 28 evaluates to true. For orders not shipped it evaluates to false.

**English:** All that have not shipped.

1. Str$(Shipped)="F"
2. Not Shipped

**Using Geographic Operators in Expressions**

MapInfo Pro has several geographic operators. Use them to select objects on the basis of their spatial relationship to some other object. MapInfo Pro has a special keyword you use with geographical operators: "obj" or "object". This keyword tells MapInfo Pro that it has to get values based on the graphical objects in the table rather than the tabular data.

The geographic operators go between the objects being specified. Select the geographic operators from the Operators menu. Here are the geographic operators:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contains</td>
<td>Object A Contains object B if B's centroid is anywhere within A's boundary.</td>
</tr>
<tr>
<td>Contains Entire</td>
<td>Object A Contains Entire object B if B's boundary is entirely within A's boundary.</td>
</tr>
<tr>
<td>Contains Part</td>
<td>Object A Contains Part object B if B's boundary is partly within A’s boundary.</td>
</tr>
<tr>
<td>Within</td>
<td>Object A is Within object B if its centroid is inside B’s boundary.</td>
</tr>
<tr>
<td>Entirely Within</td>
<td>Object A is Entirely Within object B if A’s boundary is entirely within B’s boundary.</td>
</tr>
<tr>
<td>Partly Within</td>
<td>Object A is Partly Within object B if A’s boundary is partly within B’s boundary.</td>
</tr>
</tbody>
</table>
Object A Intersects object B if they have at least one point in common.

"Contains Part" and "Partly Within" are exactly equivalent to "Intersects"-these are all treated the same way by MapInfo Pro, so the standard syntax "Intersects" is almost universally used. "Contains" and "Within" are concerned only with objects' centroids. "Contains Entire" and "Entirely Within" are concerned with the area covered by a region object; the location of the centroid does not matter. See examples in *Using Geographic Operators in Expressions* in the Help System.

**Using Logical Operators in Expressions**

"And", "or", and "not" are logical operators. You use them to combine expressions in Select and the Where Condition clause of SQL Select. MapInfo Pro treats each such an expression as a test, which it applies to each record in the table. For each test it gets a yes/no (true/false) answer. MapInfo Pro uses the logical operators to tell it how to combine the individual yes/no answers into an overall yes/no answer: Does the current record meet the selection condition?

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>and</td>
<td>is &quot;true&quot; if (and only if) both of its arguments (the expressions it joins together) are true. A record must satisfy both of these conditions if it is to be selected.</td>
</tr>
<tr>
<td>or</td>
<td>is &quot;true&quot; if either one, or both, of its arguments (the expressions it joins together) are true. A record need satisfy only one of these conditions if it is to be selected. It is also selected if both of its conditions are satisfied.</td>
</tr>
<tr>
<td>not</td>
<td>is &quot;true&quot; if its argument (the expression it applies to) is false. A record is selected if it does not meet the stated condition.</td>
</tr>
</tbody>
</table>
Suppose you want to select all properties that are worth $250,000 or more and are in Columbia county. Each record has to meet two criteria, each of which can be formulated as a simple expression:

1. VALUE >= 250000
2. COUNTY = "Columbia"

You could perform one selection for all properties worth $250,000 or more. Then you could perform another selection on that result, looking for all properties in Columbia county. However, it is easier to combine the two operations into one using the logical operator "and".

1. COUNTY = "Columbia" and VALUE >= 250000

When MapInfo Pro examines a record to see whether or not it meets the condition set by this expression, it makes the two tests: Does COUNTY equal Columbia? Is the VALUE equal to or greater than 250000? When the answer to both of these questions is true (or yes), then the record is accepted into the current selection. When the answer to one or both of the questions is no (or false), then the record is not accepted into the current selection.

Now, what if you want all properties worth $250,000 or more and not in Columbia county? You can use "not" to negate the first clause of expression 33, yielding expression 34:

1. not (COUNTY="Columbia") and VALUE>=250000

Only records where the county is not Columbia satisfy the first clause of expression 34. Now consider expression 35:

1. not (COUNTY="Columbia" and VALUE>=250000)

Expression 35 is simply the negation of expression 33. Any record that would satisfy 33 does not satisfy 35. Any record that does not satisfy 33 satisfies 35.

You can use "or" when you want to specify alternative conditions, such as:

1. COUNTY="Columbia" or COUNTY="Greene"

Any record evaluated against this condition is accepted if its county is any one of the two specified counties. One could, of course, use numerical tests as well. For example:

1. TOTAL_AREA>40 or VALUE>250000

This tests to see whether the area is greater than 40 or the value is greater than 250000. When either one is true of a record, then that record is accepted into the selection.

In formulating expressions using logical operators you have to be careful how you use them. The following expression, while it seems OK, does not work:

1. COUNTY="Columbia" or "Greene"

Judging from its English translation-COUNTY equals Columbia or Greene-this expression should operate just like expression 36 and give us any record containing Columbia County or Greene County. But the rules of computational logic and the rules of English are a bit different.

When MapInfo Pro reads expressions it reads them from left to right. One of the things it has to do is to determine how the items in the expression are grouped. Think of this operation as inserting
parentheses into the expression. MapInfo Pro reads expression 35 as though it were grouped like expression 39, which is what we intend.

It reads expression 38 as though it were grouped like 40, which is not at all what we want.

1. (COUNTY="Columbia") or (COUNTY="Greene")
2. (COUNTY="Columbia") or ("Greene")

Both 39 and 40 have the same first clause. But their second clauses (after the "or") are quite different. The second clause of 40 is simply a literal string, "Greene." By convention, MapInfo Pro evaluates a record against a literal string as being true if that record is not blank. When MapInfo Pro evaluates records against expression 40, all non-blank records are evaluated as true and be accepted into the selection. It does not make any difference how a record evaluates on the first clause. Any non-blank record evaluates as true on the second clause, and one "true" is all it takes to evaluate the entire expression as true.

Let us consider one final example, which is the negation of expression 36:

1. not (COUNTY="Greene" or COUNTY="Columbia")

Expression 39 is satisfied if the county is Greene or if it is Columbia, but not if it is Montgomery or Warren. Expression 41 is satisfied by any county other than Greene or Columbia, including Montgomery and Warren.

The Help System contains these related topics:

• Numeric Clauses
• String Clauses
• Date Clauses
• Keyword Clauses

Understanding Operator Precedence

When MapInfo Pro evaluates expressions it needs to know which components of an expression to evaluate first. This is called precedence. By convention, certain operators are assigned different levels of precedence. Those with the highest level are evaluated first. The following table lists MapInfo Pro's operators in the order in which they are evaluated. Exponentiation evaluates from the right. This affects expressions with multiple exponents: $2 ^ { -3 ^ { -4 } } = 2 ^ { ( - ( 3 ^ { -4 } ) ) }$

Operators at the same level of precedence are evaluated from left to right.

<table>
<thead>
<tr>
<th>Highest Priority:</th>
<th>Parenthesis</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Exponentiation</td>
</tr>
<tr>
<td></td>
<td>Negation</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Parenthesis</th>
<th>Exponentiation</th>
<th>Negation</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

MapInfo Pro 15.0   MapInfo Pro User Guide   531
For example, the expression $3 + 4 \times 2$ produces a result of 11. That is because multiplication has a higher precedence than addition and is performed first, in effect:

$$3 + 4 \cdot 2 =$$
$$3 + 8 =$$
$$11$$

We can add parenthesis to force MapInfo Pro to do the addition first:

$$\left(3 + 4\right) \cdot 2 =$$
$$7 \cdot 2 =$$
$$14$$

Now consider expression 60, which is intended to select all records July or September of 1989.

1. $\text{year(RECEIVED)}=89$ and $\text{month(RECEIVED)}=7$ or $\text{month(RECEIVED)}=9$

Because "and" has higher precedence than "or", MapInfo Pro treats this expression as though "$\text{year(RECEIVED)}=89$ and $\text{month(RECEIVED)}=7$" was enclosed in parentheses.

1. $\left(\text{year(RECEIVED)}=89 \text{ and } \text{month(RECEIVED)}=7\right)$ or $\text{month(RECEIVED)}=9$

In this case, any record for July of 89 or for September of any year would be selected. That is probably not what you want. However, by adding parentheses to the second expression, you can get this:

1. $\text{year(RECEIVED)}=89$ and $\left(\text{month(RECEIVED)}=7 \text{ or } \text{month(RECEIVED)}=9\right)$

In this expression, the parentheses tell MapInfo Pro that "$\text{month(RECEIVED)}=7$" and "$\text{month(RECEIVED)}=9$" are alternatives in the second clause of the expression. MapInfo Pro treats this the same as it treats number 53 above.

**Note:** When you are not sure how MapInfo Pro evaluates an expression with several operators, you should use parentheses to group elements as you want them.
Using Functions in Expressions

Functions take data values and perform some operation on them to produce a new value. Functions have the following form:

\[ \text{SomeFunction(parameters)} \]

Most of MapInfo Pro's functions take one or two parameters. A parameter can be a column or another expression. MapInfo Pro uses the keyword "obj" or "object" with the geographic functions: Area, CentroidX, CentroidY, ObjectLen, and Perimeter. This keyword tells MapInfo Pro that it has to get values based on graphical objects in the table rather than tabular data.

- For more information about specific functions, see the Help System.

Working with the MapBasic Window

This section allows advanced MapInfo Pro users to go behind the scenes and take advantage of functions that enhance the use of MapInfo Pro through the MapBasic window. MapBasic is MapInfo Pro's programming language that allows you to customize and automate MapInfo Pro functionality. When MapBasic was created, the MapBasic Window feature was added to MapInfo Pro as a means of testing and debugging code for an application. It became apparent that the MapBasic window is also a useful tool to MapInfo Pro users for doing certain tasks such as complex selections and queries based on object information.

The MapBasic window is limited to selected commands from the MapBasic programming language. The MapBasic window can take commands line by line. It does not include the capability for looping, interapplication communication, and other more complex commands. If you find yourself using the MapBasic window often, you may want to consider transferring your code to a MapBasic application that will automate the process.

Accessing the MapBasic Window

To access the MapBasic window, on the Options menu, click Show MapBasic Window. The MapBasic window displays on your screen. As with any other window, you may resize it or move it to a new location. The window allows you to enter MapBasic code or to view MapBasic code as it is generated by MapInfo Pro.

To see how MapInfo Pro carries out a select statement:

1. Open the MapBasic window and then open the WORLD table.
2. On the Query menu, click Select.
3. Type in the expression \( \text{Pop}_1994 > 1000000 \). Make sure that the Browse Results box is checked.
4. Click OK. The syntax for these commands appears in the MapBasic window as follows:

<table>
<thead>
<tr>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Table &quot;C:\MAPINFO\DATA\WORLD\WORLD.tab&quot; Interactive</td>
</tr>
<tr>
<td>Map From World</td>
</tr>
<tr>
<td>select * from World where Pop_1994 &gt; 1000000 into Selection</td>
</tr>
<tr>
<td>browse * from Selection</td>
</tr>
</tbody>
</table>

The first line is a result of opening the WORLD table. The second line of code is written automatically because the WORLD table displays in a Map window by default. The third line is the syntax for the select statement. The fourth line is the result of checking the Browse results box.

You can also enter MapBasic commands into the MapBasic window. Position your cursor under the `browse from Selection` line. Type the following:

```
Map from Selection
```

Press Enter after the line, and the command executes. You should see your selection displayed in a Map window.

As stated before, the MapBasic window was primarily designed to assist MapBasic programmers. You can statements and functions in the MapBasic window such as Buffer( ) function or Insert statement.

Refer to the MapBasic Reference, which is located in the Documentation subfolder of your installation directory to find the appropriate usage and syntax for these statements and functions. It provides a comprehensive guide to MapBasic programming statements and functions along with examples.

### Running a MapBasic Program

Use Run in the Tools menu to run a MapBasic program. MapBasic is a programming language that you can use to customize or automate MapInfo Pro. To create MapBasic applications, you need the MapBasic compiler, which is a separate product. However, you do not need the MapBasic compiler to run a completed MapBasic application.

MapInfo Pro comes with an assortment of completed MapBasic applications. Some examples include:

- **Symbol application** (`SYMBOL.MBX`). Creates custom symbol shapes.
- **Scale Bar application** (`SCALEBAR.MBX`). Annotates a map with a distance scale.
- **Named Views application** (`NVIEWS.MBX`). Assigns a name to the current map view and use that name to return to that view later.
- **Overview application** (`OVERVIEW.MBX`). Opens a second Map window that displays an overview of the current map (also referred to as an area detail map).

To run a MapBasic application:

1. Choose **Tools > Run MapBasic Program**. The Run MapBasic Program dialog box displays.
2. Choose a directory.
3. Choose an application from the list (MapBasic applications have an .mbx extension).

4. Click **OK**.

MapInfo Pro then runs the MapBasic application.

**Running a MapBasic Program Using a Startup Workspace**

You can use a startup workspace to run a MapBasic application. However, you cannot create this kind of workspace using Save Workspace As. When you want to run a MapBasic application in your startup workspace, you need to create the workspace with a text editor.

1. Place the following into an ASCII file:

   ```
   !workspace
   !version 700
   run application "someprog.mbx"
   ```

2. Replace "Someprog.app" with the name of the MapBasic application you want to launch from the startup workspace.

3. Name this file STARTUP.WOR.

4. Place this file in your MapInfo Pro program directory or in your home directory.

The *Help System* contains these and other related topics:

- Copying the Contents of the *MapBasic Message* window
- Issuing Commands through the *MapBasic* window
- **Examples of MapBasic Programs**
- Creating Circles around Points using the *MapBasic* window

**Note:** There is a comprehensive list of MapBasic functions and statements you can use from the *MapBasic* window in the *Help System*. 
A - Keyboard Shortcuts

This section contains a comprehensive list of the shortcuts available in the MapInfo Pro application. You can create custom shortcuts by editing the MAPINFOW.MNU file using a text editor.

**Caution:** Making changes to the MAPINFOW.MNU file may cause the default shortcuts you change to stop working. Make these changes carefully and record your changes so you can change them back, if necessary.

In this section

- Shortcuts for File Menu Items 537
- Shortcuts for Edit Menu Items 537
- Shortcut to Tools Menu Items 538
- Shortcuts to Objects Menu Items 538
- Shortcuts for Query Menu Items 539
- Shortcuts for Options Menu Items 539
- Shortcuts for Map Menu Items 540
- Shortcuts for Window Menu Items 540
- Shortcuts by Keystroke 541
- Shortcuts for the Map or Layout Window 544
- Shortcuts for the Browser Window 547
- Shortcuts for the Legend Designer Window 553
- Shortcuts for MapInfo Pro 555
## Shortcuts for File Menu Items

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Keystrokes</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; New Table</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>File &gt; Open</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>File &gt; Save Table</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>File &gt; Save Workspace</td>
<td>Ctrl+K</td>
</tr>
<tr>
<td>File &gt; Print</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>File &gt; Exit</td>
<td>Alt+F4</td>
</tr>
</tbody>
</table>

## Shortcuts for Edit Menu Items

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Keystrokes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit &gt; Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Edit &gt; Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Edit &gt; Copy</td>
<td>Ctrl+C</td>
</tr>
</tbody>
</table>
### Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Keystrokes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit &gt; Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Edit &gt; Clear</td>
<td>Del</td>
</tr>
<tr>
<td>Edit &gt; Reshape</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td>Edit &gt; New Row</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Edit &gt; Get Info</td>
<td>F7</td>
</tr>
</tbody>
</table>

#### Shortcut to Tools Menu Items

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Keystrokes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Run MapBasic Program</td>
<td>Ctrl+U</td>
</tr>
</tbody>
</table>

#### Shortcuts to Objects Menu Items

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Keystrokes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Objects &gt; Set Target</td>
<td>Ctrl+T</td>
</tr>
<tr>
<td>Objects &gt; Clear Target</td>
<td>Ctrl+Delete</td>
</tr>
</tbody>
</table>
### Shortcuts for Query Menu Items

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Keystrokes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Query &gt; Unselect All</td>
<td>Ctrl+W</td>
</tr>
<tr>
<td>Query &gt; Find</td>
<td>Ctrl+F</td>
</tr>
<tr>
<td>Query &gt; Find Selection &gt; In Current Map Window</td>
<td>Ctrl+G</td>
</tr>
<tr>
<td>Query &gt; Find Selection &gt; In All Windows</td>
<td>Ctrl+A</td>
</tr>
</tbody>
</table>

### Shortcuts for Options Menu Items

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Keystrokes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Options &gt; Line Style</td>
<td>Shift+F8</td>
</tr>
<tr>
<td>Options &gt; Region Style</td>
<td>Ctrl+F8</td>
</tr>
<tr>
<td>Options &gt; Symbol Style</td>
<td>Alt+F8</td>
</tr>
<tr>
<td>Options &gt; Text Style</td>
<td>F8</td>
</tr>
</tbody>
</table>
# Shortcuts for Map Menu Items

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Keystrokes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Map &gt; Layer Control</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Map &gt; Create 3D Map</td>
<td>F11</td>
</tr>
<tr>
<td>Map &gt; Create Prism Map</td>
<td>F10</td>
</tr>
<tr>
<td>Map &gt; Create Thematic Map</td>
<td>F9</td>
</tr>
<tr>
<td>Map &gt; Modify Thematic Map</td>
<td>Alt+F9</td>
</tr>
<tr>
<td>Map &gt; Previous View</td>
<td>Alt+Left Arrow</td>
</tr>
</tbody>
</table>

# Shortcuts for Window Menu Items

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Keystrokes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Window &gt; New Browser</td>
<td>F2</td>
</tr>
<tr>
<td>Window &gt; New Mapper</td>
<td>F3</td>
</tr>
<tr>
<td>Window &gt; New Grapher</td>
<td>F4</td>
</tr>
</tbody>
</table>
### Shortcuts by Keystroke

<table>
<thead>
<tr>
<th>Menu Items</th>
<th>Keystrokes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Window &gt; New Layout</td>
<td>F5</td>
</tr>
<tr>
<td>Window &gt; Redraw Window</td>
<td>Ctrl+D</td>
</tr>
<tr>
<td>Window &gt; Tile Windows</td>
<td>Shift+F4</td>
</tr>
<tr>
<td>Window &gt; Cascade Windows</td>
<td>Shift+F5</td>
</tr>
<tr>
<td>File &gt; Exit</td>
<td>Alt+F4</td>
</tr>
<tr>
<td>Options &gt; Symbol Style</td>
<td>Alt+F8</td>
</tr>
<tr>
<td>Map &gt; Modify Thematic Map</td>
<td>Alt+F9</td>
</tr>
<tr>
<td>Map &gt; Previous View and Layout &gt; Previous View</td>
<td>Alt+Left Arrow</td>
</tr>
<tr>
<td>Query &gt; Find Selection &gt; In All Windows</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Edit &gt; Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Window &gt; Redraw Window</td>
<td>Ctrl+D</td>
</tr>
<tr>
<td>Menu Items</td>
<td>Keystrokes</td>
</tr>
<tr>
<td>--------------------------------------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Objects &gt; Clear Target</td>
<td>Ctrl+Delete</td>
</tr>
<tr>
<td>Edit &gt; New Row</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Query &gt; Find</td>
<td>Ctrl+F</td>
</tr>
<tr>
<td>Options &gt; Region Style</td>
<td>Ctrl+F8</td>
</tr>
<tr>
<td>Query &gt; Find Selection &gt; In Current Map Window</td>
<td>Ctrl+G</td>
</tr>
<tr>
<td>File &gt; Save Workspace</td>
<td>Ctrl+K</td>
</tr>
<tr>
<td>Map &gt; Layer Control</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>File &gt; New Table</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>File &gt; Open</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>File &gt; Print</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>Edit &gt; Reshape</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td>File &gt; Save Table</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Objects &gt; Set Target</td>
<td>Ctrl+T</td>
</tr>
<tr>
<td>Tools &gt; Run MapBasic Program</td>
<td>Ctrl+U</td>
</tr>
<tr>
<td>Edit &gt; Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Menu Items</td>
<td>Keystrokes</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Query &gt; Unselect All</td>
<td>Ctrl+W</td>
</tr>
<tr>
<td>Edit &gt; Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Edit &gt; Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Edit &gt; Clear</td>
<td>Del</td>
</tr>
<tr>
<td>Cancel a dialog box</td>
<td>Esc</td>
</tr>
<tr>
<td>Window &gt; New Browser</td>
<td>F2</td>
</tr>
<tr>
<td>Window &gt; New Mapper</td>
<td>F3</td>
</tr>
<tr>
<td>Window &gt; New Grapher</td>
<td>F4</td>
</tr>
<tr>
<td>Window &gt; New Layout</td>
<td>F5</td>
</tr>
<tr>
<td>Edit &gt; Get Info</td>
<td>F7</td>
</tr>
<tr>
<td>Options &gt; Text Style</td>
<td>F8</td>
</tr>
<tr>
<td>Map &gt; Create Thematic Map</td>
<td>F9</td>
</tr>
<tr>
<td>Map &gt; Create Prism Map</td>
<td>F10</td>
</tr>
<tr>
<td>Map &gt; Create 3D Map</td>
<td>F11</td>
</tr>
<tr>
<td>Window &gt; Tile Windows</td>
<td>Shift+F4</td>
</tr>
</tbody>
</table>
## Menu Items

<table>
<thead>
<tr>
<th>Menu Items</th>
<th>Keystrokes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Window &gt; Cascade Windows</td>
<td>Shift+F5</td>
</tr>
<tr>
<td>Options &gt; Line Style</td>
<td>Shift+F8</td>
</tr>
</tbody>
</table>

## Shortcuts for the Map or Layout Window

### When the Map or Classic Layout is Active

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layout &gt; Previous View and Map &gt; Previous View</td>
<td>Alt+Left Arrow</td>
</tr>
<tr>
<td>Toggle a Large Crosshair On/Off</td>
<td>C</td>
</tr>
<tr>
<td>This shortcut switches between the standard cursor and the full-window cursor (lines extend to the edge of the window).</td>
<td></td>
</tr>
<tr>
<td>Select Between the Small, Medium, and Large Size Cursor</td>
<td>X</td>
</tr>
<tr>
<td>This shortcut cycles between crosshair cursor sizes (small, medium, and large); this applies to the Info tool, Label tool, and all drawing tools.</td>
<td></td>
</tr>
<tr>
<td>Create Nodes when Drawing a Polyline or Polygon</td>
<td>N</td>
</tr>
<tr>
<td>Move Object by One Pixel</td>
<td>Shift+arrow key</td>
</tr>
<tr>
<td>Move Object by Ten Pixels</td>
<td>Shift+Ctrl+arrow key</td>
</tr>
<tr>
<td>Pan Down</td>
<td>down arrow</td>
</tr>
<tr>
<td>Action</td>
<td>Keystroke</td>
</tr>
<tr>
<td>------------------------------------------------------------</td>
<td>--------------------------</td>
</tr>
<tr>
<td>Pan Left</td>
<td>left arrow</td>
</tr>
<tr>
<td>Pan Right</td>
<td>right arrow</td>
</tr>
<tr>
<td>Pan Up</td>
<td>up arrow</td>
</tr>
<tr>
<td>Switch Between Open Windows</td>
<td>Ctrl+Tab</td>
</tr>
<tr>
<td>Toggle Snap On/Off.</td>
<td>S</td>
</tr>
<tr>
<td>Trace the Short Way Around a Polyline or Region in Terms of the Number of Nodes</td>
<td>Snap mode+Shift</td>
</tr>
<tr>
<td>Trace the Long Way Around a Polyline or Region in Terms of the Number of Nodes</td>
<td>Snap mode+Ctrl</td>
</tr>
<tr>
<td>Toggle Autotrace On/Off.</td>
<td>T</td>
</tr>
<tr>
<td>Zoom In</td>
<td>+</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>-</td>
</tr>
</tbody>
</table>
### While Drawing a Polyline or Polygon

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete previous node</td>
<td><strong>Backspace</strong></td>
</tr>
</tbody>
</table>

### When Selecting One or More Objects from the Editable Layer or Classic Layout

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystrokes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move object down, one screen pixel at a time</td>
<td><strong>Ctrl+Down arrow</strong></td>
</tr>
<tr>
<td>Move object down, ten screen pixel at a time</td>
<td><strong>Ctrl+Shift+Down arrow</strong></td>
</tr>
<tr>
<td>Move object to the left, one screen pixel at a time</td>
<td><strong>Ctrl+Left arrow</strong></td>
</tr>
<tr>
<td>Move object to the left, ten screen pixel at a time</td>
<td><strong>Ctrl+Shift+left arrow</strong></td>
</tr>
<tr>
<td>Move object to the right, one screen pixel at a time</td>
<td><strong>Ctrl+Right arrow</strong></td>
</tr>
<tr>
<td>Move object to the right, ten screen pixel at a time</td>
<td><strong>Ctrl+Shift+Right arrow</strong></td>
</tr>
<tr>
<td>Move object up, one screen pixel at a time</td>
<td><strong>Ctrl+Up arrow</strong></td>
</tr>
</tbody>
</table>
### Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystrokes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move object up, ten screen pixel at a time</td>
<td>Ctrl+Shift+Up arrow</td>
</tr>
</tbody>
</table>

**Shortcuts for the Browser Window**

#### When the Browser is Active

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch between open windows</td>
<td>Ctrl+Tab</td>
</tr>
<tr>
<td></td>
<td>Ctrl+F6</td>
</tr>
<tr>
<td>Switch between open windows in reverse order</td>
<td>Ctrl+Shift+Tab</td>
</tr>
<tr>
<td></td>
<td>Ctrl+Shift+F6</td>
</tr>
</tbody>
</table>

#### When Navigating between Cells in the Browser Window

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move current cell one cell to the left</td>
<td>Left arrow</td>
</tr>
<tr>
<td>Action</td>
<td>Keystroke</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>--------------------</td>
</tr>
<tr>
<td>Move current cell one cell to the right</td>
<td>Right arrow</td>
</tr>
<tr>
<td></td>
<td>Tab</td>
</tr>
<tr>
<td>Move current cell up one line</td>
<td>Up arrow</td>
</tr>
<tr>
<td></td>
<td>Shift+Enter</td>
</tr>
<tr>
<td>Move current cell down one line</td>
<td>Down arrow</td>
</tr>
<tr>
<td></td>
<td>Enter</td>
</tr>
<tr>
<td>Move current cell up one page</td>
<td>Page Up</td>
</tr>
<tr>
<td>Move current cell down one page</td>
<td>Page Down</td>
</tr>
<tr>
<td>Move current cell right one page</td>
<td>Ctrl+Page Down</td>
</tr>
<tr>
<td>Move current cell left one page</td>
<td>Ctrl+Page Up</td>
</tr>
<tr>
<td>Move current cell to top row</td>
<td>Ctrl+Up arrow</td>
</tr>
</tbody>
</table>
### Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move current cell to bottom row</td>
<td>Ctrl+Down arrow</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Move to the first cell in the row</td>
<td>Home</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Move to the last cell in the row</td>
<td>End</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Move to the first cell in the table</td>
<td>Ctrl+Home</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Move to the last cell in the table</td>
<td>Ctrl+End</td>
</tr>
</tbody>
</table>

#### When Editing Text within the Browser Window

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select cell content and place into edit mode</td>
<td>Insert</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Exit edit mode on a cell and cancel any changes made</td>
<td>Esc</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Refresh contents of window with data source</td>
<td>Ctrl+D</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Add a new row to the bottom of the table</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Insert a carriage return in to the text</td>
<td>Ctrl+Enter</td>
</tr>
</tbody>
</table>
## Keyboard Shortcuts

### Keystroke Actions

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete one word to the left of the cursor</td>
<td>Ctrl-Backspace</td>
</tr>
<tr>
<td>Move current cell one cell down and place into edit mode</td>
<td>Enter</td>
</tr>
<tr>
<td>Move current cell one cell up and place into edit mode</td>
<td>Shift+Enter</td>
</tr>
<tr>
<td>Move to the next editable cell and place into edit mode</td>
<td>Tab</td>
</tr>
<tr>
<td>Move to the previous editable cell and place into edit mode</td>
<td>Shift+Tab</td>
</tr>
</tbody>
</table>

Select a range of text: click once at the start of your text selection, then while pressing **Shift**, click at the end of your text selection.

### Moving the Cursor

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move the cursor right to left one character at a time</td>
<td>Left arrow</td>
</tr>
<tr>
<td>Move the cursor left to right one character at a time</td>
<td>Right arrow</td>
</tr>
<tr>
<td>Move the cursor right to left one word or group of characters at a time</td>
<td>Ctrl+Left arrow</td>
</tr>
<tr>
<td>Move the cursor left to right one word or group of characters at a time</td>
<td>Ctrl+Right arrow</td>
</tr>
<tr>
<td>Move the cursor to the left-most position of the current line</td>
<td>Ctrl+Up arrow</td>
</tr>
</tbody>
</table>
### Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>move the cursor to the right-most position of the current line</td>
<td>Ctrl+Down arrow</td>
</tr>
<tr>
<td>Move the cursor to the beginning of the text</td>
<td>Ctrl+Home</td>
</tr>
<tr>
<td>Move the cursor to the end of the text</td>
<td>Ctrl+End</td>
</tr>
</tbody>
</table>

**Selecting Text**

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>select all text in the cell being edited</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>select everything to the left of the cursor</td>
<td>Shift+Up arrow</td>
</tr>
<tr>
<td></td>
<td>Shift+Home</td>
</tr>
<tr>
<td>Action</td>
<td>Keystroke</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>--------------------------------</td>
</tr>
<tr>
<td>Select everything to the right of the cursor</td>
<td>Shift+Page Up</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Select one character at a time from right to left</td>
<td>Shift+Down arrow</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Select one character at a time from left to right</td>
<td>Shift+Left arrow</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Select one character at a time from right to left</td>
<td>Shift+Right arrow</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Select one word or group of characters at a time from right to left</td>
<td>Ctrl+Shift+Left arrow</td>
</tr>
<tr>
<td>(includes the space at the end of a word or group)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Select one word or group of characters at a time from left to right</td>
<td>Ctrl+Shift+Right arrow</td>
</tr>
<tr>
<td>(includes the space at the end of a word or group)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Select everything from the cursor to the start of the line (in</td>
<td>Shift+Home</td>
</tr>
<tr>
<td>multi-line text)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Select everything from the cursor to the end of the line (in</td>
<td>Shift+End</td>
</tr>
<tr>
<td>multi-line text)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Select everything from the cursor to the start of the text</td>
<td>Ctrl+Shift+Home</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Select everything from the cursor to the end of the text</td>
<td>Ctrl+Shift+End</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Shortcuts for the Legend Designer Window

Pressing the Tab key selects and gives the keyboard focus to the first (left-most) button on the Legend Designer toolbar. When a toolbar button or control already has the focus, pressing Tab moves the keyboard focus across the buttons or controls that are enabled in a left to right direction. Use Shift+Tab to reverse the direction. When a Legend Designer toolbar control has the keyboard focus, then pressing the Enter or Space key re-executes the command. When the right-most toolbar control has the keyboard focus, pressing Tab moves the keyboard focus into the canvas area of the Legend Designer window and the canvas has a dotted line drawn around its border. You can use the arrow keys to scroll in the Legend Designer window or move selected frames in the window.

When the Legend Designer Window is Active

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>Closing the active window</td>
<td>Ctrl+F4</td>
</tr>
<tr>
<td>Switch between open windows</td>
<td>Ctrl-Tab</td>
</tr>
<tr>
<td></td>
<td>Ctrl+F6</td>
</tr>
<tr>
<td>Switch between open windows in reverse order</td>
<td>Ctrl+Shift+Tab</td>
</tr>
<tr>
<td></td>
<td>Ctrl+Shift+F6</td>
</tr>
</tbody>
</table>

When Selecting One or More Frames in a Legend Designer Window

To select multiple legend frames in a Legend Designer window, click and drag the mouse over the legend frames.

To add more legend frames to your selection, press Ctrl (or press Shift) while you click and drag the mouse over the legend frames to add to the previous selection.
When Repositioning Legend Frames in the Legend Designer Window

Pressing **Shift** plus an arrow key moves selected legend frames by increments that are based on the grid size, even when the grid is not visible.

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move selected legend frames one pixel to the left</td>
<td>Left arrow</td>
</tr>
<tr>
<td></td>
<td><strong>←</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Ctrl+Left arrow</strong></td>
</tr>
<tr>
<td>Move selected legend frames one pixel to the right</td>
<td>Right arrow</td>
</tr>
<tr>
<td></td>
<td><strong>→</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Ctrl+Right arrow</strong></td>
</tr>
<tr>
<td>Move selected legend frames up one pixel</td>
<td>Up arrow</td>
</tr>
<tr>
<td></td>
<td><strong>↑</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Ctrl+Up arrow</strong></td>
</tr>
<tr>
<td>Move selected legend frames down one pixel</td>
<td>Down arrow</td>
</tr>
<tr>
<td></td>
<td><strong>↓</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Ctrl+Down arrow</strong></td>
</tr>
<tr>
<td>Move selected legend frames one increment to the left on the grid</td>
<td>Shift+Left arrow</td>
</tr>
<tr>
<td></td>
<td><strong>←</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Shift+Ctrl+Left arrow</strong></td>
</tr>
</tbody>
</table>
### Shortcuts for MapInfo Pro

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open the Control Menu (top left corner)</td>
<td>Alt+Space Bar</td>
</tr>
<tr>
<td>Switch Between Windows</td>
<td>Ctrl+Tab</td>
</tr>
<tr>
<td>Interrupt Query Process and Window Redraw</td>
<td>Esc</td>
</tr>
<tr>
<td>Action</td>
<td>Keystroke</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>-----------</td>
</tr>
<tr>
<td>Access the Help Topic for a menu option or a dialog box</td>
<td>F1</td>
</tr>
<tr>
<td>Toggle mouse cursor type for Label, Info, and Drawing tools</td>
<td>X</td>
</tr>
</tbody>
</table>

+ + +
B - Elements of a Coordinate System

In this section

Projections and Their Parameters 558
For More Information on Projections 587
# Projections and Their Parameters

The next tables indicate the parameters applicable to each projection, which are listed in the order they appear in the relevant coordinate system lines in the `MAPINFO.PRF` file (the first table lists the first six parameters and the second table lists the next six parameters). The projection type is the equation or equations used by a coordinate system. The following list names the projections MapInfo uses and gives the number used to identify the projection in the `MAPINFO.PRF` file:

<table>
<thead>
<tr>
<th>Projection Name</th>
<th>Projection Type</th>
<th>Datum</th>
<th>Units</th>
<th>Origin, Longitude</th>
<th>Origin, Latitude</th>
<th>Standard Parallel 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Albers Equal-Area Conic</td>
<td>9</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Azimuthal Equidistant</td>
<td>28</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X *</td>
<td></td>
</tr>
<tr>
<td>Azimuthal Equidistant (polar aspect only)</td>
<td>5</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Cassini-Soldner</td>
<td>30</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Cylindrical Equal Area</td>
<td>2</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Double Stereographic</td>
<td>31</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Eckert IV</td>
<td>14</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Eckert VI</td>
<td>15</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Projection Name</td>
<td>Projection Type</td>
<td>Datum</td>
<td>Units</td>
<td>Origin, Longitude</td>
<td>Origin, Latitude</td>
<td>Standard Parallel 1</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>----------------</td>
<td>------</td>
<td>------</td>
<td>-------------------</td>
<td>------------------</td>
<td>---------------------</td>
</tr>
<tr>
<td>Equidistant Conic</td>
<td>6</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Equidistant Cylindrical</td>
<td>33</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Extended Transverse Mercator</td>
<td>34</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Gall</td>
<td>17</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Hotine Oblique Mercator</td>
<td>7</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Krovak Oblique Conformal Conic (JTSKc)</td>
<td>32</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Lambert Azimuthal Equal-Area</td>
<td>29</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
<td>X†</td>
</tr>
<tr>
<td>Lambert Azimuthal Equal-Area (polar aspect only)</td>
<td>4</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
<td>X†</td>
</tr>
<tr>
<td>Lambert Conformal Conic</td>
<td>3</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Projection Name</td>
<td>Projection Type</td>
<td>Datum</td>
<td>Units</td>
<td>Origin, Longitude</td>
<td>Origin, Latitude</td>
<td>Standard Parallel 1</td>
</tr>
<tr>
<td>---------------------------------------</td>
<td>-----------------</td>
<td>-------</td>
<td>-------</td>
<td>-------------------</td>
<td>------------------</td>
<td>---------------------</td>
</tr>
<tr>
<td>Lambert Conformal Conic (Modified for Belgium 1972)</td>
<td>19</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Longitude-Latitude</td>
<td>1</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mercator</td>
<td>10</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Miller</td>
<td>11</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mollweide</td>
<td>13</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>New Zealand Map Grid</td>
<td>18</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Polyconic</td>
<td>27</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Regional Mercator</td>
<td>26</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Robinson</td>
<td>12</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sinusoidal</td>
<td>16</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Stereographic</td>
<td>20</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Swiss Oblique Mercator</td>
<td>25</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
### Elements of a Coordinate System

<table>
<thead>
<tr>
<th>Projection Name</th>
<th>Projection Type</th>
<th>Datum</th>
<th>Units</th>
<th>Origin, Longitude</th>
<th>Origin, Latitude</th>
<th>Standard Parallel 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transverse Mercator</td>
<td>8</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Tramverse Mercator, (Modified for Danish System 34 Jylland-Fyn)</td>
<td>21</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Tramverse Mercator, (Modified for Danish System 34 Sjaelland)</td>
<td>22</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Tramverse Mercator, (Modified for Danish System 34/45 Bornholm)</td>
<td>23</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Tramverse Mercator, (Modified for Finnish KKJ)</td>
<td>24</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Projection Name</th>
<th>Standard Parallel 2</th>
<th>Azimuth</th>
<th>Scale Factor</th>
<th>False Easting</th>
<th>False Northing</th>
<th>Range</th>
</tr>
</thead>
<tbody>
<tr>
<td>Albers Equal-Area Conic</td>
<td>X</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Projection Name</td>
<td>Standard Parallel 2</td>
<td>Azimuth</td>
<td>Scale Factor</td>
<td>False Easting</td>
<td>False Northing</td>
<td>Range</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>---------------------</td>
<td>---------</td>
<td>--------------</td>
<td>---------------</td>
<td>----------------</td>
<td>-------</td>
</tr>
<tr>
<td>Azimuthal Equidistant</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Azimuthal Equidistant (polar aspect only)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Cassini-Soldner</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Cylindrical Equal Area</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Double Stereographic</td>
<td>X</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Eckert IV</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Eckert VI</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Equidistant Conic</td>
<td>X</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Equidistant Cylindrical</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Extended Transverse Mercator</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Gall</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Projection Name</td>
<td>Standard Parallel 2</td>
<td>Azimuth</td>
<td>Scale Factor</td>
<td>False Easting</td>
<td>False Northing</td>
<td>Range</td>
</tr>
<tr>
<td>--------------------------------------------------------</td>
<td>---------------------</td>
<td>---------</td>
<td>--------------</td>
<td>---------------</td>
<td>----------------</td>
<td>-------</td>
</tr>
<tr>
<td>Hotine Oblique Mercator</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Krovak Oblique Conformal Conic (JTSKc)</td>
<td>X</td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Lambert Azimuthal Equal-Area</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Lambert Azimuthal Equal-Area (polar aspect only)</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Lambert Conformal Conic</td>
<td>X</td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Lambert Conformal Conic (Modified for Belgium 1972)</td>
<td>X</td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Longitude-Latitude</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Mercator</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Miller</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Mollweide</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Projection Name</td>
<td>Standard Parallel 2</td>
<td>Azimuth</td>
<td>Scale Factor</td>
<td>False Easting</td>
<td>False Northing</td>
<td>Range</td>
</tr>
<tr>
<td>-------------------------</td>
<td>---------------------</td>
<td>---------</td>
<td>--------------</td>
<td>---------------</td>
<td>----------------</td>
<td>-------</td>
</tr>
<tr>
<td>New Zealand Map Grid</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Polyconic</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Regional Mercator</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Robinson</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sinusoidal</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Stereographic</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Swiss Oblique Mercator</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Transverse Mercator</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Transverse Mercator,</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>(Modified for Danish</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>System 34 Jylland-Fyn)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Transverse Mercator,</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>(Modified for Danish</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>System 34 Sjaelland)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
The Origin Latitude for the Azimuthal Equidistant projections must be either 90 or -90. An Oblique Azimuthal Equidistant projection supports all Origin Latitudes, including the poles. A Lambert Azimuthal Equal-Area projection has been added that also supports all Origin Latitudes, including the poles.

**Projection Types List**

The projection type is the equation or equations used by a coordinate system. The following list names the projections MapInfo Pro uses and gives the number used to identify the projection in the `MAPINFOW.PRJ` file:

<table>
<thead>
<tr>
<th>Number</th>
<th>Projection Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>9</td>
<td>Albers Equal-Area Conic</td>
</tr>
<tr>
<td>28</td>
<td>Azimuthal Equidistant (all origin latitudes)</td>
</tr>
<tr>
<td>5</td>
<td>Azimuthal Equidistant (polar aspect only)</td>
</tr>
<tr>
<td>30</td>
<td>Cassini-Soldner</td>
</tr>
<tr>
<td>2</td>
<td>Cylindrical Equal-Area</td>
</tr>
<tr>
<td>Number</td>
<td>Projection Type</td>
</tr>
<tr>
<td>--------</td>
<td>-----------------------------------------------------</td>
</tr>
<tr>
<td>31</td>
<td>Double Stereographic</td>
</tr>
<tr>
<td>14</td>
<td>Eckert IV</td>
</tr>
<tr>
<td>15</td>
<td>Eckert VI</td>
</tr>
<tr>
<td>6</td>
<td>Equidistant Conic, also known as Simple Conic</td>
</tr>
<tr>
<td>33</td>
<td>Equidistant Cylindrical</td>
</tr>
<tr>
<td>34</td>
<td>Extended Transverse Mercator</td>
</tr>
<tr>
<td>17</td>
<td>Gall</td>
</tr>
<tr>
<td>7</td>
<td>Hotine Oblique Mercator</td>
</tr>
<tr>
<td>32</td>
<td>Krovak Oblique Conformal Conic (JTSKc)</td>
</tr>
<tr>
<td>4</td>
<td>Lambert Azimuthal Equal-Area (polar aspect only)</td>
</tr>
<tr>
<td>29</td>
<td>Lambert Azimuthal Equal-Area</td>
</tr>
<tr>
<td>3</td>
<td>Lambert Conformal Conic</td>
</tr>
<tr>
<td>19</td>
<td>Lambert Conformal Conic (modified for Belgium 1972)</td>
</tr>
<tr>
<td>1</td>
<td>Longitude/Latitude</td>
</tr>
<tr>
<td>10</td>
<td>Mercator</td>
</tr>
<tr>
<td>Number</td>
<td>Projection Type</td>
</tr>
<tr>
<td>--------</td>
<td>----------------</td>
</tr>
<tr>
<td>11</td>
<td>Miller Cylindrical</td>
</tr>
<tr>
<td>13</td>
<td>Mollweide</td>
</tr>
<tr>
<td>18</td>
<td>New Zealand Map Grid</td>
</tr>
<tr>
<td>27</td>
<td>Polyconic</td>
</tr>
<tr>
<td>26</td>
<td>Regional Mercator</td>
</tr>
<tr>
<td>12</td>
<td>Robinson</td>
</tr>
<tr>
<td>16</td>
<td>Sinusoidal</td>
</tr>
<tr>
<td>20</td>
<td>Stereographic</td>
</tr>
<tr>
<td>25</td>
<td>Swiss Oblique Mercator</td>
</tr>
<tr>
<td>8</td>
<td>Transverse Mercator, (also known as Gauss-Kruger)</td>
</tr>
<tr>
<td>21</td>
<td>Transverse Mercator, (modified for Danish System 34 Jylland-Fyn)</td>
</tr>
<tr>
<td>22</td>
<td>Transverse Mercator, (modified for Danish System 34 Sjaelland)</td>
</tr>
<tr>
<td>23</td>
<td>Transverse Mercator, (modified for Danish System 34/45 Bornholm)</td>
</tr>
<tr>
<td>24</td>
<td>Transverse Mercator, (modified for Finnish KKJ)</td>
</tr>
</tbody>
</table>
Projection numbers in the `MAPINFO.PRG` may be modified by the addition of a constant value to the base number listed in the Projection table, above. Valid values and their meanings are in the next table:

<table>
<thead>
<tr>
<th>Constant</th>
<th>Meaning</th>
<th>Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000</td>
<td>System has affine transformations</td>
<td>Affine units specifier and coefficients appear after the regular parameters for the system.</td>
</tr>
<tr>
<td>2000</td>
<td>System has explicit bounds</td>
<td>Bounds appear after the regular parameters for the system.</td>
</tr>
<tr>
<td>3000</td>
<td>System with both affine and bounds</td>
<td>Affine parameters follow system's parameters; bounds follow affine parameters.</td>
</tr>
</tbody>
</table>

**Example:**

Assume you want to work with a simple system based on the Transverse Mercator projection and using the NAD 1983 datum. You might have a line such as the following in your `MAPINFO.PRG` file:

"UTM Zone 1 (NAD 83)", 8, 74, 7, -177, 0, 0.9996, 500000, 0

Now let us say that you want a system based on this, but with an affine transformation specified by the following parameters (see *Affine Transformations* in the Help System: Units=meters; A=0.5; B=-0.866; C=0; D=0.866; E=0.5; and F=0. The required line in the `MAPINFO.PRG` file is:

"UTM Zone 1 (NAD 83) - rotated 60 degrees", 1008, 74, 7, -177, 0, 0.9996, 500000, 0, 7, 0.5, -0.866, 0, 0.866, 0.5, 0

Alternatively, if you want to bound the system to \((x1, y1, x2, y2)=(-500000, 0, 500000, 1000000)\), the required line is:

"UTM Zone 1 (NAD 83) - bounded", 2008, 74, 7, -177, 0, 0.9996, 500000, 0, -500000, 0, 500000, 1000000

To customize the system using both of these modifications, the line is:

"UTM Zone 1 (NAD 83) - rotated and bounded", 3008, 74, 7, -177, 0, 0.9996, 500000, 0, 7, 0.5, -0.866, 0, 0.866, 0.5, 0, -500000, 0, 500000, 1000000

**Projection Datums**

The datum is established by tying a reference ellipsoid to a particular point on the earth. The following table lists these details for each datum.
- **Number** - The number used to identify the datum in the MAPINFO.PRJ file.
- **Datum Name** - The datum’s name
- **Area of Coverage** - The maps for which the datum is typically used
- **Ellipsoid** - The datum's reference ellipsoid

<table>
<thead>
<tr>
<th>Number</th>
<th>Datum Name</th>
<th>Area of Coverage</th>
<th>Ellipsoid</th>
</tr>
</thead>
<tbody>
<tr>
<td>166</td>
<td>Aratu</td>
<td>Brazil</td>
<td>4</td>
</tr>
<tr>
<td>167</td>
<td>Barbados</td>
<td>Barbados</td>
<td>6</td>
</tr>
<tr>
<td>168</td>
<td>Beduaram</td>
<td>Niger</td>
<td>30</td>
</tr>
<tr>
<td>169</td>
<td>Conakry_1905</td>
<td>Guinea</td>
<td>30</td>
</tr>
<tr>
<td>170</td>
<td>Dealul Piscului 1930</td>
<td>Romania</td>
<td>4</td>
</tr>
<tr>
<td>171</td>
<td>Douala</td>
<td>Cameroon</td>
<td>4</td>
</tr>
<tr>
<td>172</td>
<td>Final_Datum_1958</td>
<td>Iran</td>
<td>6</td>
</tr>
<tr>
<td>173</td>
<td>Makassar</td>
<td>Indonesia</td>
<td>10</td>
</tr>
<tr>
<td>174</td>
<td>Manoca</td>
<td>Cameroon</td>
<td>30</td>
</tr>
<tr>
<td>1026</td>
<td>NGO_1948</td>
<td>Norway</td>
<td>1026</td>
</tr>
<tr>
<td>1927</td>
<td>Palestine_1923</td>
<td>Asia / Middle East</td>
<td>1027</td>
</tr>
<tr>
<td>162</td>
<td>JGD2011</td>
<td>Datum for Japan</td>
<td>16</td>
</tr>
<tr>
<td>163</td>
<td>Timbalai 1948, Everest 1968</td>
<td></td>
<td></td>
</tr>
<tr>
<td>164</td>
<td>GDM2000</td>
<td></td>
<td></td>
</tr>
<tr>
<td>165</td>
<td>MAGNA-SIRGAS</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Adindan</td>
<td>Ethiopia, Mali, Senegal, Sudan</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>Number</td>
<td>Datum Name</td>
<td>Area of Coverage</td>
<td>Ellipsoid</td>
</tr>
<tr>
<td>--------</td>
<td>---------------------------</td>
<td>--------------------------------------------------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>2</td>
<td>Afgooye</td>
<td>Somalia</td>
<td>Krassovsky</td>
</tr>
<tr>
<td>1007</td>
<td>AGD 66, 7 parameter</td>
<td>Australia, A.C.T.</td>
<td>Australian National</td>
</tr>
<tr>
<td>1008</td>
<td>AGD 66, 7 parameter</td>
<td>Australia, Tasmania</td>
<td>Australian National</td>
</tr>
<tr>
<td>1009</td>
<td>AGD 66, 7 parameter</td>
<td>Australia, Victoria/NSW</td>
<td>Australian National</td>
</tr>
<tr>
<td>1006</td>
<td>AGD 84, 7 parameter</td>
<td>Australia</td>
<td>Australian National</td>
</tr>
<tr>
<td>3</td>
<td>Ain el Abd 1970</td>
<td>Bahrain Island</td>
<td>International</td>
</tr>
<tr>
<td>118</td>
<td>American Samoa</td>
<td>American Samoa Islands</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>4</td>
<td>Anna 1 Astro 1965</td>
<td>Cocos Islands</td>
<td>Australian National</td>
</tr>
<tr>
<td>119</td>
<td>Antigua Island Astro 1943</td>
<td>Antigua, Leeward Islands</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>5</td>
<td>Arc 1950</td>
<td>Botswana, Lesotho, Malawi, Swaziland, Zaire, Zambia, Zimbabwe</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>6</td>
<td>Arc 1960</td>
<td>Kenya, Tanzania</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>7</td>
<td>Ascension Island 1958</td>
<td>Ascension Island</td>
<td>International</td>
</tr>
<tr>
<td>9</td>
<td>Astro B4 Sorol Atoll</td>
<td>Tern Island</td>
<td>International</td>
</tr>
<tr>
<td>8</td>
<td>Astro Beacon &quot;E&quot;</td>
<td>Iwo Jima Island</td>
<td>International</td>
</tr>
<tr>
<td>Number</td>
<td>Datum Name</td>
<td>Area of Coverage</td>
<td>Ellipsoid</td>
</tr>
<tr>
<td>--------</td>
<td>------------------------------------------------</td>
<td>-----------------------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>10</td>
<td>Astro DOS 71/4</td>
<td>St. Helena Island</td>
<td>International</td>
</tr>
<tr>
<td>11</td>
<td>Astronomic Station 1952</td>
<td>Marcus Island</td>
<td>International</td>
</tr>
<tr>
<td>12</td>
<td>Australian Geodetic 1966 (AGD 66)</td>
<td>Australia and Tasmania Island</td>
<td>Australian National</td>
</tr>
<tr>
<td>13</td>
<td>Australian Geodetic 1984 (AGD 84)</td>
<td>Australia and Tasmania Island</td>
<td>Australian National</td>
</tr>
<tr>
<td>120</td>
<td>Ayabelle Lighthouse</td>
<td>Djibouti</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>154</td>
<td>Beijing 1954</td>
<td>China</td>
<td>Krassovsky (#3)</td>
</tr>
<tr>
<td>1019</td>
<td>Belgian 1972 (7 parameters)</td>
<td>Belgium</td>
<td>International 1924</td>
</tr>
<tr>
<td>110</td>
<td>Belgium</td>
<td>Belgium</td>
<td>International</td>
</tr>
<tr>
<td>14</td>
<td>Bellevue (IGN)</td>
<td>Efate and Erromango Islands</td>
<td>International</td>
</tr>
<tr>
<td>15</td>
<td>Bermuda 1957</td>
<td>Bermuda Islands</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>16</td>
<td>Bogota Observatory</td>
<td>Colombia</td>
<td>International</td>
</tr>
<tr>
<td>121</td>
<td>Bukit Rimpah</td>
<td>Bangka and Belitung Islands (Indonesia)</td>
<td>Bessel 1841</td>
</tr>
<tr>
<td>17</td>
<td>Campo Inchauspe</td>
<td>Argentina</td>
<td>International</td>
</tr>
<tr>
<td>18</td>
<td>Canton Astro 1966</td>
<td>Phoenix Islands</td>
<td>International</td>
</tr>
<tr>
<td>Number</td>
<td>Datum Name</td>
<td>Area of Coverage</td>
<td>Ellipsoid</td>
</tr>
<tr>
<td>--------</td>
<td>-------------------------------------</td>
<td>-----------------------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>19</td>
<td>Cape</td>
<td>South Africa</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>20</td>
<td>Cape Canaveral</td>
<td>Florida and Bahama Islands</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>1005</td>
<td>Cape, 7 parameter</td>
<td>South Africa</td>
<td>WGS 84</td>
</tr>
<tr>
<td>21</td>
<td>Carthage</td>
<td>Tunisia</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>158</td>
<td>CH1903+ datum for Switzerland</td>
<td>Switzerland</td>
<td>Bessel</td>
</tr>
<tr>
<td>22</td>
<td>Chatham 1971</td>
<td>Chatham Island (New Zealand)</td>
<td>International</td>
</tr>
<tr>
<td>23</td>
<td>Chua Astro</td>
<td>Paraguay</td>
<td>International</td>
</tr>
<tr>
<td>122</td>
<td>Coordinate System 1937 of Estonia</td>
<td>Estonia</td>
<td>Bessel 1841</td>
</tr>
<tr>
<td>24</td>
<td>Corrego Alegre</td>
<td>Brazil</td>
<td>International</td>
</tr>
<tr>
<td>123</td>
<td>Dabola</td>
<td>Guinea</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>156</td>
<td>Dealul Piscului 1970</td>
<td>Romania</td>
<td>Krassovsky</td>
</tr>
<tr>
<td>124</td>
<td>Deception Island</td>
<td>Deception Island, Antarctica</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>1000</td>
<td>Deutsches Hauptdreicksnetz (DHDN) Potsdam/Rauenberg</td>
<td>Germany</td>
<td>Bessel</td>
</tr>
<tr>
<td>25</td>
<td>Djakarta (Batavia)</td>
<td>Sumatra Island (Indonesia)</td>
<td>Bessel 1841</td>
</tr>
<tr>
<td>Number</td>
<td>Datum Name</td>
<td>Area of Coverage</td>
<td>Ellipsoid</td>
</tr>
<tr>
<td>--------</td>
<td>------------</td>
<td>-----------------</td>
<td>-----------</td>
</tr>
<tr>
<td>26</td>
<td>DOS 1968</td>
<td>Gizo Island (New Georgia Islands)</td>
<td>International</td>
</tr>
<tr>
<td>27</td>
<td>Easter Island 1967</td>
<td>Easter Island</td>
<td>International</td>
</tr>
<tr>
<td>115</td>
<td>EUREF 89</td>
<td>Europe</td>
<td>GRS 80</td>
</tr>
<tr>
<td>28</td>
<td>European 1950 (ED 50)</td>
<td>Austria, Belgium, Denmark, Finland, France, Germany, Gibraltar, Greece, Italy, Luxembourg, Netherlands, Norway, Portugal, Spain, Sweden, Switzerland</td>
<td>International</td>
</tr>
<tr>
<td>29</td>
<td>European 1979 (ED 79)</td>
<td>Austria, Finland, Netherlands, Norway, Spain, Sweden, Switzerland</td>
<td>International</td>
</tr>
<tr>
<td>108</td>
<td>European 1987 (ED 87)</td>
<td>Europe</td>
<td>International</td>
</tr>
<tr>
<td>125</td>
<td>Fort Thomas 1955</td>
<td>Nevis, St. Kitts, Leeward Islands</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>30</td>
<td>Gandajika Base</td>
<td>Republic of Maldives</td>
<td>International</td>
</tr>
<tr>
<td>116</td>
<td>GDA 94</td>
<td>Australia</td>
<td>GRS 80</td>
</tr>
<tr>
<td>33</td>
<td>Geodetic Reference System 1980 (GRS 80)</td>
<td>Worldwide</td>
<td>GRS 80</td>
</tr>
<tr>
<td>126</td>
<td>Graciosa Base SW 1948</td>
<td>Faial, Graciosa, Pico, Sao Jorge, and Terceira Islands (Azores)</td>
<td>International 1924</td>
</tr>
<tr>
<td>Number</td>
<td>Datum Name</td>
<td>Area of Coverage</td>
<td>Ellipsoid</td>
</tr>
<tr>
<td>--------</td>
<td>----------------------------------</td>
<td>----------------------------------------</td>
<td>--------------------</td>
</tr>
<tr>
<td>34</td>
<td>Guam 1963</td>
<td>Guam Island</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>35</td>
<td>GUX 1 Astro</td>
<td>Guadalcanal Island</td>
<td>International</td>
</tr>
<tr>
<td>150</td>
<td>Hartbeesthoek 94</td>
<td>South Africa</td>
<td>WGS 84</td>
</tr>
<tr>
<td>127</td>
<td>Herat North</td>
<td>Afghanistan</td>
<td>International 1924</td>
</tr>
<tr>
<td>128</td>
<td>Hermannskogel</td>
<td>Yugoslavia (Prior to 1990), Slovenia, Croatia, Bosnia and Herzegovina, Serbia</td>
<td>Bessel 1841</td>
</tr>
<tr>
<td>153</td>
<td>HGRS87</td>
<td></td>
<td>GRS80 (#0)</td>
</tr>
<tr>
<td>36</td>
<td>Hito XVIII 1963</td>
<td>South Chile (near 53°S)</td>
<td>International</td>
</tr>
<tr>
<td>37</td>
<td>Hjorsey 1955</td>
<td>Iceland</td>
<td>International</td>
</tr>
<tr>
<td>38</td>
<td>Hong Kong 1963</td>
<td>Hong Kong</td>
<td>International</td>
</tr>
<tr>
<td>1004</td>
<td>Hungarian Datum of 1972 (HD 72)</td>
<td>Hungary</td>
<td>GRS 80</td>
</tr>
<tr>
<td>39</td>
<td>Hu-Tzu-Shan</td>
<td>Taiwan</td>
<td>International</td>
</tr>
<tr>
<td>40</td>
<td>Indian</td>
<td>Thailand and Vietnam</td>
<td>Everest (India 1830)</td>
</tr>
<tr>
<td>41</td>
<td>Indian</td>
<td>Bangladesh, India, Nepal</td>
<td>Everest (India 1830)</td>
</tr>
<tr>
<td>129</td>
<td>Indian</td>
<td>Pakistan</td>
<td>Everest (Pakistan)</td>
</tr>
</tbody>
</table>

Elements of a Coordinate System
<table>
<thead>
<tr>
<th>Number</th>
<th>Datum Name</th>
<th>Area of Coverage</th>
<th>Ellipsoid</th>
</tr>
</thead>
<tbody>
<tr>
<td>130</td>
<td>Indian 1954</td>
<td>Thailand</td>
<td>Everest (India 1830)</td>
</tr>
<tr>
<td>131</td>
<td>Indian 1960</td>
<td>Vietnam</td>
<td>Everest (India 1830)</td>
</tr>
<tr>
<td>132</td>
<td>Indian 1975</td>
<td>Thailand</td>
<td>Everest (India 1830)</td>
</tr>
<tr>
<td>133</td>
<td>Indonesian 1974</td>
<td>Indonesia</td>
<td>Indonesian 1974</td>
</tr>
<tr>
<td>42</td>
<td>Ireland 1965</td>
<td>Ireland</td>
<td>Modified Airy</td>
</tr>
<tr>
<td>134</td>
<td>ISTS 061 Astro 1968</td>
<td>South Georgia Island</td>
<td>International 1924</td>
</tr>
<tr>
<td>43</td>
<td>ISTS 073 Astro 1969</td>
<td>Diego Garcia</td>
<td>International</td>
</tr>
<tr>
<td>152</td>
<td>JGD2000</td>
<td>Japan</td>
<td>Bessel 1841</td>
</tr>
<tr>
<td>44</td>
<td>Johnston Island 1961</td>
<td>Johnston Island</td>
<td>International</td>
</tr>
<tr>
<td>45</td>
<td>Kandawala</td>
<td>Sri Lanka</td>
<td>Everest (India 1830)</td>
</tr>
<tr>
<td>46</td>
<td>Kerguelen Island</td>
<td>Kerguelen Island</td>
<td>International</td>
</tr>
<tr>
<td>47</td>
<td>Kertau 1948</td>
<td>West Malaysia and Singapore</td>
<td>Everest (W. Malaysia and Singapore 1948)</td>
</tr>
<tr>
<td>1016</td>
<td>KKJ</td>
<td>Finland</td>
<td>International</td>
</tr>
<tr>
<td>135</td>
<td>Kusaie Astro 1951</td>
<td>Caroline Islands, Federated States of Micronesia</td>
<td>International 1924</td>
</tr>
<tr>
<td>Number</td>
<td>Datum Name</td>
<td>Area of Coverage</td>
<td>Ellipsoid</td>
</tr>
<tr>
<td>--------</td>
<td>--------------------------</td>
<td>-----------------------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>48</td>
<td>L.C. 5 Astro</td>
<td>Cayman Brac Island</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>136</td>
<td>Leigon</td>
<td>Ghana</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>49</td>
<td>Liberia 1964</td>
<td>Liberia</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>155</td>
<td>Libya (LGD 2006)</td>
<td>Libya</td>
<td>International</td>
</tr>
<tr>
<td>113</td>
<td>Lisboa (DLx)</td>
<td>Portugal</td>
<td>International</td>
</tr>
<tr>
<td>1018</td>
<td>Lithuanian Pulkovo 1942</td>
<td>Latvia, Lithuania</td>
<td>Krassovsky (#3)</td>
</tr>
<tr>
<td>50</td>
<td>Luzon</td>
<td>Philippines (excluding Mindanao Island)</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>51</td>
<td>Luzon</td>
<td>Mindanao Island</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>138</td>
<td>M'Poraloko</td>
<td>Gabon</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>52</td>
<td>Mahe 1971</td>
<td>Mahe Island</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>53</td>
<td>Marco Astro</td>
<td>Salvage Islands</td>
<td>International</td>
</tr>
<tr>
<td>54</td>
<td>Massawa</td>
<td>Eritrea (Ethiopia)</td>
<td>Bessel 1841</td>
</tr>
<tr>
<td>114</td>
<td>Melrica 1973 (D73)</td>
<td>Portugal</td>
<td>International</td>
</tr>
<tr>
<td>55</td>
<td>Merchich</td>
<td>Morocco</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>Number</td>
<td>Datum Name</td>
<td>Area of Coverage</td>
<td>Ellipsoid</td>
</tr>
<tr>
<td>--------</td>
<td>-------------------------------------------</td>
<td>-----------------------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>56</td>
<td>Midway Astro 1961</td>
<td>Midway Island</td>
<td>International</td>
</tr>
<tr>
<td>57</td>
<td>Minna</td>
<td>Nigeria</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>137</td>
<td>Montserrat Island Astro 1958</td>
<td>Montserrat, Leeward Islands</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>58</td>
<td>Nahrwan</td>
<td>Masirah Island (Oman)</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>59</td>
<td>Nahrwan</td>
<td>United Arab Emirates</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>60</td>
<td>Nahrwan</td>
<td>Saudi Arabia</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>61</td>
<td>Naparima, BWI</td>
<td>Trinidad and Tobago</td>
<td>International</td>
</tr>
<tr>
<td>109</td>
<td>Netherlands</td>
<td>Netherlands</td>
<td>Bessel</td>
</tr>
<tr>
<td>1010</td>
<td>New Zealand Geodetic Datum 194, 7 parameter</td>
<td>New Zealand</td>
<td>International</td>
</tr>
<tr>
<td>31</td>
<td>New Zealand Geodetic Datum 1949 (NZGD 49)</td>
<td>New Zealand</td>
<td>International</td>
</tr>
<tr>
<td>62</td>
<td>North American 1927 (NAD 27)</td>
<td>Continental U.S.</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>63</td>
<td>North American 1927 (NAD 27)</td>
<td>Alaska</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>64</td>
<td>North American 1927 (NAD 27)</td>
<td>Bahamas (excluding San Salvador Island)</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>65</td>
<td>North American 1927 (NAD 27)</td>
<td>San Salvador Island</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>Number</td>
<td>Datum Name</td>
<td>Area of Coverage</td>
<td>Ellipsoid</td>
</tr>
<tr>
<td>--------</td>
<td>------------------------------------</td>
<td>-------------------------------------------------------</td>
<td>--------------------</td>
</tr>
<tr>
<td>66</td>
<td>North American 1927 (NAD 27)</td>
<td>Canada (including Newfoundland Island)</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>67</td>
<td>North American 1927 (NAD 27)</td>
<td>Canal Zone</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>68</td>
<td>North American 1927 (NAD 27)</td>
<td>Caribbean (Turks and Caicos Islands)</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>69</td>
<td>North American 1927 (NAD 27)</td>
<td>Central America (Belize, Costa Rica, El Salvador, Guatemala, Honduras, Nicaragua)</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>70</td>
<td>North American 1927 (NAD 27)</td>
<td>Cuba</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>71</td>
<td>North American 1927 (NAD 27)</td>
<td>Greenland (Hayes Peninsula)</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>72</td>
<td>North American 1927 (NAD 27)</td>
<td>Mexico</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>73</td>
<td>North American 1927 (NAD 27)</td>
<td>Michigan (used only for State Plane Coordinate System 1927)</td>
<td>Modified Clarke 1866</td>
</tr>
<tr>
<td>74</td>
<td>North American 1983 (NAD 83)</td>
<td>Alaska, Canada, Central America, Continental U.S., Mexico</td>
<td>GRS 80</td>
</tr>
<tr>
<td>139</td>
<td>North Sahara 1959</td>
<td>Algeria</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>1022</td>
<td>North Sahara 7-parameter</td>
<td>Algeria</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>107</td>
<td>Nouvelle Triangulation Francaise (NTF) Greenwich Prime Meridian</td>
<td>France</td>
<td>Modified Clarke 1880</td>
</tr>
<tr>
<td>Number</td>
<td>Datum Name</td>
<td>Area of Coverage</td>
<td>Ellipsoid</td>
</tr>
<tr>
<td>--------</td>
<td>------------------------------------------------</td>
<td>-----------------------------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>1002</td>
<td>Nouvelle Triangulation Francaise (NTF)</td>
<td>France</td>
<td>Modified Clarke 1880</td>
</tr>
<tr>
<td></td>
<td>Paris Prime Meridian</td>
<td></td>
<td></td>
</tr>
<tr>
<td>111</td>
<td>NWGL 10</td>
<td>Worldwide</td>
<td>WGS 72</td>
</tr>
<tr>
<td>117</td>
<td>NZGD 2000</td>
<td>New Zealand</td>
<td>GRS 80</td>
</tr>
<tr>
<td>75</td>
<td>Observatorio 1966</td>
<td>Corvo and Flores Islands (Azores)</td>
<td>International</td>
</tr>
<tr>
<td>140</td>
<td>Observatorio Meteorologico 1939</td>
<td>Corvo and Flores Islands (Azores)</td>
<td>International 1924</td>
</tr>
<tr>
<td>76</td>
<td>Old Egyptian</td>
<td>Egypt</td>
<td>Helmert 1906</td>
</tr>
<tr>
<td>77</td>
<td>Old Hawaiian</td>
<td>Hawaii</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>78</td>
<td>Oman</td>
<td>Oman</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>79</td>
<td>Ordnance Survey of Great Britain 1936</td>
<td>England, Isle of Man, Scotland, Shetland Islands, Wales</td>
<td>Airy</td>
</tr>
<tr>
<td>80</td>
<td>Pico de las Nieves</td>
<td>Canary Islands</td>
<td>International</td>
</tr>
<tr>
<td>81</td>
<td>Pitcaim Astro 1967</td>
<td>Pitcaim Island</td>
<td>International</td>
</tr>
<tr>
<td>141</td>
<td>Point 58</td>
<td>Burkina Faso and Niger</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>142</td>
<td>Pointe Noire 1948</td>
<td>Congo</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>Number</td>
<td>Datum Name</td>
<td>Area of Coverage</td>
<td>Ellipsoid</td>
</tr>
<tr>
<td>--------</td>
<td>-----------------------------------------------</td>
<td>-----------------------------------</td>
<td>----------------------</td>
</tr>
<tr>
<td>157</td>
<td>Popular Visualization CRS / Mercator</td>
<td>Worldwide</td>
<td>WGS 84 Sphere</td>
</tr>
<tr>
<td>143</td>
<td>Porto Santo 1936</td>
<td>Porto Santo and Madeiras Islands</td>
<td>International 1924</td>
</tr>
<tr>
<td>1000</td>
<td>Potsdam</td>
<td>Germany</td>
<td>Bessel</td>
</tr>
<tr>
<td>82</td>
<td>Provisional South American 1956</td>
<td>Bolivia, Chile, Colombia, Ecuador, Guyana, Peru, Venezuela</td>
<td>International</td>
</tr>
<tr>
<td>36</td>
<td>Provisional South Chilean 1963</td>
<td>South Chile (near 53°S)</td>
<td>International</td>
</tr>
<tr>
<td>83</td>
<td>Puerto Rico</td>
<td>Puerto Rico and Virgin Islands</td>
<td>Clarke 1866</td>
</tr>
<tr>
<td>1001</td>
<td>Pulkovo 1942</td>
<td>Germany</td>
<td>Krassovsky</td>
</tr>
<tr>
<td>84</td>
<td>Qatar National</td>
<td>Qatar</td>
<td>International</td>
</tr>
<tr>
<td>85</td>
<td>Qornoq</td>
<td>South Greenland</td>
<td>International</td>
</tr>
<tr>
<td>1000</td>
<td>Rauenberg</td>
<td>Germany</td>
<td>Bessel</td>
</tr>
<tr>
<td>86</td>
<td>Reunion</td>
<td>Mascarene Island</td>
<td>International</td>
</tr>
<tr>
<td>112</td>
<td>Rikets Triangulering 1990 (RT 90)</td>
<td>Sweden</td>
<td>Bessel</td>
</tr>
<tr>
<td>1011</td>
<td>Rikets Triangulering 1990 (RT 90), 7 parameter</td>
<td>Sweden</td>
<td>Bessel</td>
</tr>
<tr>
<td>Number</td>
<td>Datum Name</td>
<td>Area of Coverage</td>
<td>Ellipsoid</td>
</tr>
<tr>
<td>--------</td>
<td>----------------------------</td>
<td>-----------------------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>87</td>
<td>Rome 1940</td>
<td>Sardinia Island</td>
<td>International</td>
</tr>
<tr>
<td>1012</td>
<td>Russia PZ90</td>
<td>Russia</td>
<td>PZ90</td>
</tr>
<tr>
<td>1012</td>
<td>Russia PZ90</td>
<td>Russia</td>
<td>PZ90</td>
</tr>
<tr>
<td>1013</td>
<td>Russia SK42</td>
<td>Russia</td>
<td>SK95</td>
</tr>
<tr>
<td>1014</td>
<td>Russia SK95</td>
<td>Russia</td>
<td>PZ90</td>
</tr>
<tr>
<td>88</td>
<td>Santo (DOS)</td>
<td>Espírito Santo Island</td>
<td>International</td>
</tr>
<tr>
<td>89</td>
<td>São Braz</td>
<td>São Miguel, Santa Maria Islands (Azores)</td>
<td>International</td>
</tr>
<tr>
<td>90</td>
<td>Sapper Hill 1943</td>
<td>East Falkland Island</td>
<td>International</td>
</tr>
<tr>
<td>91</td>
<td>Schwarzeck</td>
<td>Namibia</td>
<td>Modified Bessel 1841</td>
</tr>
<tr>
<td>159</td>
<td>Schwarzeck (updated ) datum for Namibia</td>
<td>Namibia</td>
<td>Modified Bessel</td>
</tr>
<tr>
<td>144</td>
<td>Selvagem Grande 1938</td>
<td>Salvage Islands</td>
<td>International 1924</td>
</tr>
<tr>
<td>1021</td>
<td>Serbia datum MGI 1901</td>
<td>Republic of Serbia</td>
<td>Bessel</td>
</tr>
<tr>
<td>145</td>
<td>Sierra Leone 1960</td>
<td>Sierra Leone</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>146</td>
<td>S-JTSK</td>
<td>Czech Republic</td>
<td>Bessel 1841</td>
</tr>
<tr>
<td>Number</td>
<td>Datum Name</td>
<td>Area of Coverage</td>
<td>Ellipsoid</td>
</tr>
<tr>
<td>--------</td>
<td>----------------------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>--------------------------------</td>
</tr>
<tr>
<td>1020</td>
<td>S-JTSK (Ferro prime meridian)</td>
<td>Czech Republic</td>
<td>Bessel #11</td>
</tr>
<tr>
<td>92</td>
<td>South American 1969</td>
<td>Argentina, Bolivia, Brazil, Chile, Colombia, Ecuador, Guyana, Paraguay, Peru, Venezuela, Trinidad and Tobago</td>
<td>South American 1969</td>
</tr>
<tr>
<td>93</td>
<td>South Asia</td>
<td>Singapore</td>
<td>Modified Fischer 1960</td>
</tr>
<tr>
<td>94</td>
<td>Southeast Base</td>
<td>Porto Santo and Madeira Islands</td>
<td>International</td>
</tr>
<tr>
<td>95</td>
<td>Southwest Base</td>
<td>Faial, Graciosa, Pico, Sao Jorge, Terceira Islands (Azores)</td>
<td>International</td>
</tr>
<tr>
<td>1003</td>
<td>Switzerland (CH 1903)</td>
<td>Switzerland</td>
<td>Bessel</td>
</tr>
<tr>
<td>147</td>
<td>Tananarive Observatory 1925</td>
<td>Madagascar</td>
<td>International 1924</td>
</tr>
<tr>
<td>96</td>
<td>Timbalai 1948</td>
<td>Brunei and East Malaysia (Sarawak and Sabah)</td>
<td>Everest (India 1830)</td>
</tr>
<tr>
<td>97</td>
<td>Tokyo</td>
<td>Japan, Korea, Okinawa</td>
<td>Bessel 1841</td>
</tr>
<tr>
<td>1015</td>
<td>Tokyo97</td>
<td>Japan</td>
<td>Bessel 1841</td>
</tr>
<tr>
<td>98</td>
<td>Tristan Astro 1968</td>
<td>Tristan da Cunha</td>
<td>International</td>
</tr>
<tr>
<td>99</td>
<td>Viti Levu 1916</td>
<td>Viti Levu Island (Fiji Islands)</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>148</td>
<td>Voirol 1874</td>
<td>Tunisia/Algeria</td>
<td>Clarke 1880</td>
</tr>
</tbody>
</table>
### Elements of a Coordinate System

<table>
<thead>
<tr>
<th>Number</th>
<th>Datum Name</th>
<th>Area of Coverage</th>
<th>Ellipsoid</th>
</tr>
</thead>
<tbody>
<tr>
<td>149</td>
<td>Voirol 1960</td>
<td>Algeria</td>
<td>Clarke 1880</td>
</tr>
<tr>
<td>100</td>
<td>Wake-Eniwetok 1960</td>
<td>Marshall Islands</td>
<td>Hough</td>
</tr>
<tr>
<td>101</td>
<td>World Geodetic System 1960 (WGS 60)</td>
<td>Worldwide</td>
<td>WGS 60</td>
</tr>
<tr>
<td>102</td>
<td>World Geodetic System 1966 (WGS 66)</td>
<td>Worldwide</td>
<td>WGS 66</td>
</tr>
<tr>
<td>103</td>
<td>World Geodetic System 1972 (WGS 72)</td>
<td>Worldwide</td>
<td>WGS 72</td>
</tr>
<tr>
<td>104</td>
<td>World Geodetic System 1984 (WGS 84)</td>
<td>Worldwide</td>
<td>WGS 84</td>
</tr>
<tr>
<td>1017</td>
<td>Xian</td>
<td>China</td>
<td>1980</td>
</tr>
<tr>
<td>105</td>
<td>Yacare</td>
<td>Uruguay</td>
<td>International</td>
</tr>
<tr>
<td>106</td>
<td>Zanderij</td>
<td>Surinam</td>
<td>International</td>
</tr>
</tbody>
</table>

### Units

The following table lists the available coordinate units and the number used to identify the unit in the MAPINFO.W.PRJ file:

<table>
<thead>
<tr>
<th>Number</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>Centimeters</td>
</tr>
<tr>
<td>Number</td>
<td>Units</td>
</tr>
<tr>
<td>--------</td>
<td>-------</td>
</tr>
<tr>
<td>31</td>
<td>Chains</td>
</tr>
<tr>
<td>3</td>
<td>Feet (also called International Feet)&lt;sup&gt;1&lt;/sup&gt;</td>
</tr>
<tr>
<td>2</td>
<td>Inches</td>
</tr>
<tr>
<td>1</td>
<td>Kilometers</td>
</tr>
<tr>
<td>30</td>
<td>Links</td>
</tr>
<tr>
<td>7</td>
<td>Meters</td>
</tr>
<tr>
<td>0</td>
<td>Miles</td>
</tr>
<tr>
<td>5</td>
<td>Millimeters</td>
</tr>
<tr>
<td>9</td>
<td>Nautical Miles&lt;sup&gt;2&lt;/sup&gt;</td>
</tr>
<tr>
<td>32</td>
<td>Rods</td>
</tr>
<tr>
<td>8</td>
<td>US Survey Feet (used for 1927 State Plane)&lt;sup&gt;3&lt;/sup&gt;</td>
</tr>
<tr>
<td>4</td>
<td>Yards</td>
</tr>
</tbody>
</table>

<sup>1</sup>One International Foot equals exactly 30.48 cm.

<sup>2</sup>One Nautical Mile equals exactly 1852 meters.

<sup>3</sup>One US Survey Foot equals exactly 12/39.37 meters, or approximately 30.48006 cm.
Coordinate System Origin

The origin is the point specified in longitude and latitude from which all coordinates are referenced. It is chosen to optimize the accuracy of a particular coordinate system. As we move north from the origin, Y increases. X increases as we move east. These coordinate values are generally called northings and eastings.

For the Transverse Mercator projection the origin's longitude defines the central meridian. In constructing the Transverse Mercator projection a cylinder is positioned tangent to the earth. The central meridian is the line of tangency. The scale of the projected map is true along the central meridian.

In creating a Hotine Oblique Mercator projection it is necessary to specify a great circle that is not the equator nor a meridian. MapInfo Pro does this by specifying one point on the ellipsoid and an azimuth from that point. That point is the origin of the coordinate system.

Standard Parallels (Conic Projections)

In conic projections a cone is passed through the earth intersecting it along two parallels of latitude. These are the standard parallels. One is to the north and one is to the south of the projection zone. To use a single standard parallel specify that latitude twice. Both are expressed in degrees of latitude.

Oblique Azimuth (Hotine Oblique Mercator)

When specifying a great circle (Hotine Oblique Mercator) using a point and an azimuth (arc), the azimuth is called the Oblique Azimuth and is expressed in degrees.

Scale Factor (Transverse Mercator)

A scale factor is applied to cylindrical coordinates to average scale error over the central area of the map while reducing the error along the east and west boundaries. The scale factor has the effect of recessing the cylinder into the earth so that it has two lines of intersection. Scale is true along these lines of intersection.

You may see the scale factor expressed as a ratio, such as 1:25000. In this case it is generally called the scale reduction. The relationship between scale factor and scale reduction is:

scale factor = 1-scale reduction

In this case the scale factor would be 1-(1/25000) or 0.99996.

False Northings and False Eastings

Calculating coordinates is easier if negative numbers are not involved. To eliminate this problem in calculating State Plane and Universal Transverse Mercator coordinates, it is common to add
measurement offsets to the northings and eastings. These offsets are called False Northings and False Eastings. They are expressed in coordinate units, not degrees. (The coordinate units are specified by the Units parameter.)

**Range (Azimuthal Projections)**

The range specifies, in degrees, how much of the earth you are seeing. The range can be between 1 and 180. When you specify 90, you see a hemisphere. When you specify 180 you see the whole earth, though much of it is very distorted.

**Polyconic Projection**

The following description is copied from "Map Projections - A Working Manual", USGS Professional Paper 1395, by John P. Snyder.

The Polyconic projection, usually called the American Polyconic in Europe, achieved its name because the curvature of the circular arc for each parallel on the map is the same as it would be following the unrolling of a cone which had been wrapped around the globe tangent to the particular parallel of latitude, with the parallel traced onto the cone. Thus, there are many ("poly-") cones involved, rather than the single cone of each regular conic projection.

The Polyconic projection is neither equal-area nor conformal. Along the central meridian, however, it is both distortion free and true to scale. Each parallel is true to scale, but the meridians are lengthened by various amounts to cross each parallel at the correct position along the parallel, so that no parallel is standard in the sense of having conformality (or correct angles), except at the central meridian. Near the central meridian, distortion is extremely small.

This projection is not intended for mapping large areas. The conversion algorithms used break down when mapping wide longitude ranges. For example, WORLD.TAB, from the sample data shipped with MapInfo Pro, may exhibit anomalies if reprojected using Polyconic.

**Equidistant Cylindrical Projection**

The Equidistant Cylindrical projection (also called the Equirectangular projection, geographic projection, Plate Carrée, or Carte Parallélogrammatique projection or CPP), is a very simple map projection attributed to Marinus of Tyre, who Ptolemy claims invented the projection about 100 AD.

The projection maps meridians to equally spaced vertical straight lines, and circles of latitude to evenly spread horizontal straight lines. The projection is neither equal area nor conformal. Because of the distortions introduced by this projection, it has little use in navigation or cadastral mapping, and finds its main use in thematic mapping. In particular, the Plate Carrée is used often in computer applications that process global maps, because of the particularly simple relationship between the position of an image pixel on the map and its corresponding geographic location on Earth. The Plate Carrée (French, for "flat square"), is the special case where standard parallel is zero.
The following examples are of PRJ entries for Plate Carrée and Equidistant Cylindrical projection centered at 46.5 degree Standard Parallel (used in France):

"Plate Carree WGS84", 33, 104, 7, 0, 0, 0, 0
"Equidistant Cylindrical 46.5 Degree WGS84", 33, 104, 7, 0, 46.5, 0, 0

For More Information on Projections

The first three publications listed are relatively short pamphlets. The last two are substantial books. We have also given addresses and phone numbers for the American Congress of Surveying and Mapping (the pamphlets) and the U.S. Geological Survey (the books).


Contact Information

The Department of Geography at the University of Colorado at Boulder has made available "The Geographer's Craft" project, a website devoted to explanations of map projections, geodetic datums, and coordinate systems. It is particularly valuable because many of the explanations were presented using MapInfo Pro.

The materials may be used for study, research, and education. If you link to or cite the materials below, please credit the author: Peter H. Dana, The Geographer's Craft Project, Department of Geography, The University of Colorado at Boulder.

For geodetic datum information and explanations, go to:

http://www.colorado.edu/geography/gcraft/notes/datum/datum.html

For information on coordinate systems and associated topics, go to:

http://www.colorado.edu/geography/gcraft/notes/coordsys/coordsys.html
For information on map projections, go to:
http://www.colorado.edu/geography/gcraft/notes/mapproj/mapproj.html
C - Manually Creating a MapInfo_MapCatalog

These instructions are for manually creating a MapInfo Map Catalog and making a remote table mappable, two procedures that are necessary for geocoding remote tables. This information is designed for users who do not have access to MapInfo Pro.

MapInfo Pro users would create a MapInfo Map Catalog automatically.

- Creating a Map Catalog in the DBMS to Work with Data
- Making a DBMS Table Mappable to Display it on a Map

You or your database administrator must create one MapInfo Map Catalog for each database you wish to access in MapInfo Pro.

In this section

Manually Creating a MapInfo_MapCatalog 590
Manually Making a Remote Table Mappable 592
To create a MAPINFO_MAPCATALOG manually:

1. If the RDBMS requires owners and users, then create the user MAPINFO with the PASSWORD MAPINFO in the specific database where the mappable tables are located.
2. Create the table MAPINFO_MAPCATALOG in the database.

The Create Table statement must be equivalent to the following SQL Create Table statement:

```
Create Table MAPINFO_MAPCATALOG(
    SPATIALTYPE Float,
    TABLENAME Char(32),
    OWNERNAME Char(32),
    SPATIALCOLUMN Char(32),
    DB_X_LL Float,
    DB_Y_LL Float,
    DB_X_UR Float,
    DB_Y_UR Float,
    VIEW_X_LL Float,
    VIEW_Y_LL Float,
    VIEW_X_UR Float,
    VIEW_Y_UR Float,
    COORDINATESYSTEM Char(254),
    SYMBOL Char(254),
    XCOLUMNNAME Char(32),
    YCOLUMNNAME Char(32),
    RENDITIONTYPE Integer,
    RENDITIONCOLUMN VarChar(32),
    RENDITIONTABLE VarChar(32),
    NUMBER_ROWS Integer
);
```
It is important that the structure of the table is exactly like this statement. The only substitution that can be made is for databases that support varchar or text data types; these data types can be substituted for the Char data type.

3. Create a unique index on the TABLENAME and the OWNERNAME, so only one table for each owner can be made mappable.

4. Grant Select privileges to all users on the MAPINFO_MAPCATALOG. This allows users to make tables mappable. The Update, Insert, and Delete privileges must be granted at the discretion of the database administrator.

**Spatial Index Types**

The spatial index type applies to the column that has the spatial information in the DBMS table. The spatial index provides a fast way for MapInfo Pro to access the spatial data in the table. The index types to choose from are:

<table>
<thead>
<tr>
<th>Spatial Index Type</th>
<th>Type Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>MapInfo MICODE schema (any database)</td>
<td>1</td>
</tr>
<tr>
<td>XY schema (any database)</td>
<td>4</td>
</tr>
<tr>
<td>Oracle Spatial Geometry</td>
<td>13</td>
</tr>
<tr>
<td>SpatialWare for SQL Server</td>
<td>14</td>
</tr>
<tr>
<td>Oracle Spatial Annotation Text</td>
<td>16</td>
</tr>
<tr>
<td>SQL Server Spatial (for geometry)</td>
<td>17</td>
</tr>
<tr>
<td>SQL Server Spatial (for geography)</td>
<td>18</td>
</tr>
<tr>
<td>PostGIS for PostgreSQL</td>
<td>19</td>
</tr>
<tr>
<td>SQL Server Spatial with M and Z values (for geometry)</td>
<td>20</td>
</tr>
<tr>
<td>SQL Server Spatial with M and Z values (for geography)</td>
<td>21</td>
</tr>
</tbody>
</table>
You use the XY Coordinates option when there is no index

Manually Making a Remote Table Mappable

For each spatial table in the remote database that you want to access in MapInfo Pro, you must add a row to the MAPINFO_MAPCATALOG table. This is carried out in MapInfo Pro when you select **Table > Maintenance > Make DBMS Table Mappable**.

If you do not use MapInfo Pro to manage the Map Catalog, you must manually add rows to the MAPINFO_MAPCATALOG table for each spatial table in the database that you want to geocode. Each entry must contain the following information about the table.
<table>
<thead>
<tr>
<th>Column Name</th>
<th>Values to Assign</th>
<th>Example</th>
</tr>
</thead>
</table>
| SPATIALTYPE    | 4.0 for X,Y spatial index tables  
(Support for additional spatial servers is under development)                                                                                                                                             | 4.0           |
| TABLENAME      | Name of the table.                                                                                                                                                                                                 | Drainage      |
| OWNERNAME      | Owner name.                                                                                                                                                                                                       | Georgetown    |
| SPATIALCOLUMN  | Name of the column, if any containing spatial features. The name is:  
• NO_COLUMN (for mappable tables using X,Y)                                                                                                                                                                  | NO_COLUMN     |
<p>| DB_X_LL        | X coordinate of the lower left corner of the layer's bounding rectangle, in units indicated by the COORDINATESYSTEM as defined by MapInfo Pro.                                                                 | -360          |
| DB_Y_LL        | Lower left bounding Y value.                                                                                                                                                                                     | -90           |
| DB_X_UR        | Upper right bounding X value.                                                                                                                                                                                     | 360           |
| DB_Y_UR        | Upper right bounding Y value.                                                                                                                                                                                     | 90            |
| VIEW_X_LL      | X coordinate of the lower left corner of the view's bounding rectangle, in units indicated by the COORDINATESYSTEM as defined by MapInfo Pro.                                                                     | -360          |
| VIEW_Y_LL      | Lower left bounding Y value.                                                                                                                                                                                     |               |</p>
<table>
<thead>
<tr>
<th>Column Name</th>
<th>Values to Assign</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>VIEW_X_UR</td>
<td>Upper right bounding X value.</td>
<td>-90</td>
</tr>
<tr>
<td>VIEW_Y_UR</td>
<td>Upper right bounding Y value.</td>
<td>360</td>
</tr>
<tr>
<td>VIEW_Y_UR</td>
<td>Upper right bounding Y value.</td>
<td>90</td>
</tr>
<tr>
<td>COORDINATESYSTEM</td>
<td>A string representing a MapInfo-supported coordinate system that specifies a map projection, coordinate units, etc. Values are one of:</td>
<td>Earth Projection 1,0</td>
</tr>
<tr>
<td></td>
<td>• Earth Projection 1,0 (for NAD27)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Earth Projection 1,62 (for NAD27)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Earth Projection 1,33 (for NAD 83) or</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Earth Projection 1,74 (for NAD 83)</td>
<td></td>
</tr>
<tr>
<td>SYMBOL</td>
<td>A MapInfo Symbol clause (for a layer containing points)</td>
<td>Symbol (35,0,12)</td>
</tr>
<tr>
<td>XCOLUMNNAME</td>
<td>Specify the name of the column containing X coordinates.</td>
<td>NO_COLUMN</td>
</tr>
<tr>
<td>YCOLUMNNAME</td>
<td>Specify the name of the column containing Y coordinates.</td>
<td>NO_COLUMN</td>
</tr>
<tr>
<td>RENDITIONTYPE</td>
<td>Specify 1 if on, 0 if off.</td>
<td>1</td>
</tr>
<tr>
<td>Column Name</td>
<td>Values to Assign</td>
<td>Example</td>
</tr>
<tr>
<td>---------------------</td>
<td>--------------------------------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>RENDITIONCOLUMN</td>
<td>Specify the name of the rendition column.</td>
<td>MI_STYLE</td>
</tr>
<tr>
<td>RENDITIONTABLE</td>
<td>Specify the name of the rendition table.</td>
<td>left empty</td>
</tr>
<tr>
<td></td>
<td>This field is not used.</td>
<td></td>
</tr>
<tr>
<td>NUMBER_ROWS</td>
<td>Specify the number of rows in the table.</td>
<td>11</td>
</tr>
</tbody>
</table>
D - MapInfo Map Interchange Format

To ensure file format backward compatibility we provide a file version comparison in this Appendix.

In this section

File Versions and TAB, MIF/MID, and WOR Support 597
File Versions and TAB, MIF/MID, and WOR Support

The following table lists changes (and their implications) to versions in .tab, workspace, and other files used by MapInfo Pro.

- TAB files are always saved as 300 unless noted in the table
- WOR files are always saved as 400 unless noted in the table
- Once a table is 'upgraded' to a later version, MapInfo Pro does not 'downgrade' it to an earlier version if the feature which forced the 'upgrade' is removed.
- Workspaces are written fresh each time, and Workspace versions can be decreased if there are no features in them that require using a higher version.

- Pen(0,0,0) and Brush(0,0,0), which were valid in MapInfo Pro 4.1 tables are not valid in MapInfo Pro 4.5 and later.
- Line widths in points is encoded in the Pen clause by multiplying the line width value by 10 and adding 10 to the result (.2 -> 12, 1.0 -> 20, etc.). This forces a 450 in the MIF file header.
- Interleaved line styles are encoded in the Pen clause by increasing the line style value by 128. This does not force a 450 workspace, it is 4.x compatible, and is saved as 400 TAB.

### Version 4.0.0 (400)

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Table is a linked ODBC table.</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>Tab version stays at 300 with interleaved.</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Saved queries are implemented as straight Select statements. (Saved queries are controlled by the Save Queries in Workspaces check box on the Options menu, point to Preferences and click Startup.)</td>
</tr>
</tbody>
</table>

### Version 4.1.0 (410)

::
### Version 4.5.0 (450)

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>Table uses MS Access DB's.</td>
</tr>
</tbody>
</table>

Region and polyline objects, that have more than 32K nodes (actually !edit_version 450 and !version 300).

Table uses point sized line widths.

Table is a query table.

Workspaces that specify dot density color (shade ... density... color).

Workspaces that specify interleaved line style, width in points (Pen (1,2,x)).

Table uses a Datum or ellipsoid released in a specific version.

### Version 4.5.2 (452)

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>Regional Mercator projection - number 26.</td>
</tr>
</tbody>
</table>

### Version 5.0.0 (500)

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TAB</td>
<td>MIF-MID</td>
<td>WOR</td>
<td>Action</td>
</tr>
<tr>
<td>-----</td>
<td>---------</td>
<td>-----</td>
<td>--------</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>Table specifies a 'grid' file (*.MIG, raster style = 6 1)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>X</td>
<td>Workspaces that contain surface thematic layers (inflection).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>X</td>
<td>Workspaces that contain cartographic legends (Create Cartographic Legend).</td>
</tr>
</tbody>
</table>

**Version 5.5.0 (550)**

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>Polyconic projection - number 27.</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>Irish (WOFO) ellipsoid - number 49.</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>Table is a linked/live Oracle 8i table.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>X</td>
<td>Workspaces with Oracle 8i connection information.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>X</td>
<td>Workspaces that include surface thematics with Hillshading.</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>Table uses a Datum or ellipsoid released in a specific version.</td>
</tr>
</tbody>
</table>

**Version 6.0.0 (600)**

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Save a workspace with a 3D Map.</td>
</tr>
<tr>
<td>TAB</td>
<td>MIF-MID</td>
<td>WOR</td>
<td>Action</td>
</tr>
<tr>
<td>-----</td>
<td>---------</td>
<td>-----</td>
<td>--------</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>Azimuthal Equidistant projection, Oblique aspect - number 28.</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>Everest (Pakistan) ellipsoid - number 50.</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>ATS 77 ellipsoid - number 51.</td>
</tr>
</tbody>
</table>

New Datums introduced in Version 6.0. Their numbers are in a range 115-150 (115 and 150 included) and 1004-1011 (1004 and 1011 included).

As of this release MapInfo Pro writes the Datum number if all the parameters match to the parameters of our internal Datum table. The application writes the FIRST datum number with these parameters, that are in our internal table. That means that if a table was created using Datums EUREF89 (115), GDA94 (116) or NZGD2000 (117), the MIF file will have Datum GRS 80 (33) written into it and MIF file version would not be incremented.

Since MapInfo Pro does not write datum number into TAB file, version will be incremented only if ellipsoid is new.

As of version 8.0, MapInfo Pro now writes a datum index number into MAP file, so this is no longer always the case.

| X   |     |     | Workspace includes Advanced Printer settings. |
| X   |     |     | Workspace includes a Hotlink. |
| X   |     |     | Workspace includes a 3D Mapper window. |
| X   |     |     | Workspaces that include new clip region settings. |
| X   | X    |     | Table uses a Datum or ellipsoid released in a specific version. |

**Version 6.5.0 (650)**
<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>New object types: Multipoint and Collection (actually ledit_version 650 and lversion 300).</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>Cassini-Soldner projection (number 30).</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>Lambert Azimuthal Equal-Area projection - Oblique aspect (number 29).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Cassini-Soldner projection for the map window.</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Lambert Azimuthal Equal-Area projection (Oblique aspect) for the map window.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>New object types (Multipoint and Collection) created in a cosmetic layer or in a layout.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>X</td>
<td>Save a workspace with a Prism Map.</td>
</tr>
</tbody>
</table>

Version 7.0.0 (700):

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>TAB file linked to a shapefile.</td>
</tr>
</tbody>
</table>
| X   | X       | X   | • #152 - JGD2000 datum used in Japan.  
• #1012 - PZ90 datum based on PZ90 ellipsoid. This datum is used in Russia.  
• #1013 - SK42 datum based on PZ90 ellipsoid. This datum is used in Russia.  
• #1014 - SK95 datum based on PZ90 ellipsoid. This datum is used in Russia.  
• "Longitude / Latitude (Russia PZ90)", 1, 1012.  
• "Longitude / Latitude (Russia SK42)", 1, 1013.  
• "Longitude / Latitude (Russia SK95)", 1, 1014. |
<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
</table>
|     |         | X   | • Double Stereographic projection.  
|     |         |     | • ATS77 (which uses ATS77 ellipsoid).  
|     |         |     | • Prince Edward Island and New Brunswick Projection.  
| X   |         |     | ROP Method selected for advanced options for Save Window As or Printing  

**Version 7.5.0 (750)**

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
</table>
| X   |         |     | TAB files can include Web Map Service (WMS) data.  
|     |         | X   | Workspaces can include Advanced Printer settings (scale patterns).  
|     |         | X   | Workspaces can include cartographic legends with custom layouts.  

**Version 7.8.0 (780)**

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
</table>
| X   | X       |     | TAB files can include Web Feature Service (WFS) data.  
|     |         | X   | Workspaces can include cartographic legends. The workspace will always include a clause for swatch size that cannot be parsed by earlier versions of MapInfo Pro.  
|     |         | X   | Workspaces can include mappers with dot-density thematics. The workspace will always include a clause for dot size that cannot be parsed by earlier versions of MapInfo Pro.  

### Version 8.0.0 (800)

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>X</td>
<td>X</td>
<td>Workspaces using custom ordered Individual Value Legends.</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Workspaces using Replace layer style.</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Workspaces using different legend swatch styles.</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Workspaces using thematic Legend alignment.</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>Ellipsoid#: 53 Name: Xian 1980 - used in China.</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Datum#: 1017 Name: XIAN 1980 - based on Xian 1980 ellipsoid #53 for China.</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Datum#: 154 Name: Beijing 1954 - used in China.</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Datum#: 153 Name: HGRS87 - used in Greece.</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Datum#: 1018 Name: Lithuanian Pulkovo 1942 - used in Lithuania.</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Datum#: 1019 Name: Belgian 1972 7 parameters - used in Belgium.</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Objects with greater than 1M nodes, &gt;32K polygons/polylines.</td>
</tr>
</tbody>
</table>

800 Edit Version

:
### Version 8.5.0 (850)

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Objects with greater than 1M nodes, &gt;32K polygons/polylines.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>SHP/TAB files that contain Z/M values.</td>
</tr>
</tbody>
</table>

### Version 9.0.0 (900)

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>Open Table as VMGrid or VMRaster.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Raster Image Reprojection, Image Resampling.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Export with Anti-Aliasing.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Redistricting with Percentages.</td>
</tr>
</tbody>
</table>

### New to MapBasic:

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>DateTime type.</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>JTSK Projection #32.</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td>X</td>
<td>Datum# 1020 Name: S-JTSK (Ferro Prime Meridian).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>New to MapBasic:</td>
</tr>
</tbody>
</table>
### Version 9.5.0 (950)

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
</table>
|     | X       |     | • RegionInfo - The GELink tool needs a way to determine the orientation of points in polygons  
|     |         |     | • SystemInfo - Extend SystemInfo to return the build number |
|     | X       |     | Curved Labels. |
|     |         |     | Open Universal Tables. |

### Version 9.5.0 (950)

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Enhanced Labels <em>(Map &gt; Options)</em>.</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Enhanced Layouts (Smoothed Text, Smooth Lines and Borders, Image smoothing)</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Translucent Labels (Requires Enhanced Mappers)</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Set Map Layer Label Percent Over token for curved labels</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Enhanced Browsers (smoothed text, antialias)</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Enhanced Mappers (Smoothed Labels and Text, Smooth Lines and Borders, Image smoothing)</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td></td>
<td>Vector Translucency (Mapper Layers and Layout Objects)</td>
</tr>
</tbody>
</table>
|     | X       | X   | Datum#: 155 Name: LGD 2006) - Used in Libya  
<p>|     |         |     | Datum#: 156 Name: Dealul Piscului 1970 - Used in Romania |</p>
<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>Addition to Create Text statement for Pen clause for callout lines</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td>X</td>
<td>WFS-T</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Popular Visualization Ellipsoid #54</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Popular Visualization Datum #157</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Oracle's Annotation Text type</td>
</tr>
</tbody>
</table>

**Version 10.0.0 (1000)**

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Table from a PostGIS Database</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Table from a SQL 2008 Database</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Table containing UTF-8 charset definition</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Table that opens Excel 2007 *.xlsx file</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Table that opens Access 2007 *.accdb file</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Workspace with a Group Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Workspace with ScaleBar Adornment</td>
</tr>
</tbody>
</table>
### Version 10.5.0 (1050)

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Workspace that uses USNG Grid reference system</td>
</tr>
</tbody>
</table>

### Version 11.0.0 (1100)

- No File version upgrades in 11.0

### Version 11.0.3 (1103)

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>Equidistant Cylindrical Projection #33</td>
</tr>
</tbody>
</table>

### Version 11.5.0 (1150)

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>X</td>
<td>Any Browser that is sorted via the Browser Context menu</td>
</tr>
<tr>
<td>TAB</td>
<td>MIF-MID</td>
<td>WOR</td>
<td>Action</td>
</tr>
<tr>
<td>-----</td>
<td>---------</td>
<td>-----</td>
<td>--------</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>MGI 1901 Datum #1021</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>CH1903 Datum #158</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>Schwarzeck (updated) datum for Namibia #159</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>North Sahara #1022</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Browser window with Filter conditions (Set Browse Filter statement)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Browser window with hidden toolbar (Set Window FrontWindow( ) Toolbar Off statement)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Legend Designer legend windows (Create Designer Legend statement)</td>
</tr>
</tbody>
</table>

**Version 11.5.1 (1151)**

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Legend Designer window with hidden toolbar (Set Window FrontWindow( ) Toolbar Off statement)</td>
</tr>
</tbody>
</table>

**Version 11.5.2 (1152)**

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>The Create Designer Legend statement with a sorted legend (Create Designer Legend statement with an Order clause inside a Frame clause), or a legend specifying visibility of individual rows (Create Designer Legend statement with a Display clause inside a Style clause)</td>
</tr>
<tr>
<td>TAB</td>
<td>MIF-MID</td>
<td>WOR</td>
<td>Action</td>
</tr>
<tr>
<td>-----</td>
<td>---------</td>
<td>-----</td>
<td>--------</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Saving SQLite tables</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Saving tables containing Autodesk Text Objects</td>
</tr>
<tr>
<td></td>
<td></td>
<td>X</td>
<td>Browser window that is sorted with a five column sort condition</td>
</tr>
</tbody>
</table>

**Version 12.0 (1200)**

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>Extended Transverse Mercator projection. In MapBasic, using CSYS_TM_EXTENDED (34).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Saving a Map window with a Cartographic scale, and calling the MapBasic Set Map statement with the Display Scale Cartographic clause.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>X</td>
<td>Auto position turned on for polygon labels.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>X</td>
<td>Auto position along line or fallback position turned on for curved labels.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>X</td>
<td>Abbreviations turned on for labels.</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>Tables with record lengths that exceed 4000 bytes.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>X</td>
<td>The MapBasic Set Map statement with Label Selection or Label Priority clauses.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Exporting a table that is using SIRGAS 2000 datum.</td>
</tr>
</tbody>
</table>
### Version 12.0.3 (1203)

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>X</td>
<td>X</td>
<td>When the coordinate system of the map is using SIRGAS 2000 datum.</td>
</tr>
</tbody>
</table>

### Version 12.5.0 (1250)

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>GCS_Sphere Datum #161</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>GCS_Sphere Ellipsoid #55</td>
</tr>
</tbody>
</table>

### Version 12.5.2 (1252)

<table>
<thead>
<tr>
<th>TAB</th>
<th>MIF-MID</th>
<th>WOR</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>Layout Designer windows force a workspace version to 12.5 (1250). You can still use the classic Layout window, which does not force a workspace version to 12.5.</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>Updated Hungarian Datum 1023</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>Updated Czech Datum 1024</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>JTSK03 (Slovak Republic) Datum 1025</td>
</tr>
</tbody>
</table>
### CharSet

The CharSet clause specifies which character set was used to create text in the table. For example: Specify "WindowsLatin1" to indicate that the file was created using the Windows US & Western Europe character set; specify "MacRoman" to specify the Macintosh US & Western Europe character set; or specify "Neutral" to avoid converting the text into another character set. If you are not using one of these character sets, you can determine the correct syntax for your character set by exporting a table and examining the .MIF file in a text editor.

### Delimiter

Specify the delimiting character in quotation marks, for example:

```
DELIMITER ";"
```

The default delimiter is Tab; if you are using the default, you do not need the DELIMITER line.

### Unique

Specify a number. This number refers to a database column; 3 is the third column, 7 is the seventh column, and so forth. What happens to columns in the UNIQUE list is subtle. For example, imagine that you have a database with highways in it. Each highway has only one name, but it might be represented by several segments. You would put the NAME column in the UNIQUE list, while the column containing data for the individual segments would not be in that list. This has the effect of creating two related tables; one with names, and one with the other attributes of the objects. This is how Pitney Bowes Software Inc.'s various street maps (StreetPro) are prepared.

### Index

To indicate that columns in the table are indexed, include a number (or a comma-separated list of numbers) in the Index clause. Each number refers to a database column; 3 is the third column, 7 is the seventh column, and so forth. Columns in the INDEX list will have indexes prepared for them.
CoordSys Clause

Specify the COORDSYS clause to note that the data is not stored in longitude/latitude form. When no COORDSYS clause is specified, data is assumed to be stored in longitude/latitude form.

All coordinates are stored with respect to the northeast quadrant. The coordinates for points in the United States have a negative X while coordinates for points in Europe (east of Greenwich) have a positive X. Coordinates for points in the Northern hemisphere have a positive Y while coordinates for points in the Southern hemisphere have a negative Y.

Syntax1

CoordSys Earth
    [ Projection type,  
      datum,  
      unitname  
      [, origin_longitude ]  
      [, origin_latitude ]  
      [, standard_parallel_1 [ , standard_parallel_2 ] ]  
      [, azimuth ]  
      [, scale_factor ]  
      [, false_easting ]  
      [, false_northing ]  
      [, range ] ]  
    [ Affine Units unitname, A, B, C, D, E, F ]  
    [ Bounds ( minx, miny ) ( maxx, maxy ) ]

Syntax2

CoordSys Nonearth  
    [ Affine Units unitname, A, B, C, D, E, F ]  
    Units unitname  
    Bounds ( minx, miny ) ( maxx, maxy )

Syntax3

CoordSys Layout Units paperunitname

Syntax4

CoordSys Table tablename

Syntax5

CoordSys Window window_id

type is a positive integer value representing which coordinate system to use
datum is a positive integer value identifying which datum to reference
unitname is a string representing a distance unit of measure (for example, \textdegree m\textquoteright for meters); for a list of unit names, see Set Distance Units
origin\_longitude is a float longitude value, in degrees
origin\_latitude is a float latitude value, in degrees
standard\_parallel\_1 and standard\_parallel\_2 are float latitude values, in degrees
azimuth is a float angle measurement, in degrees
scale\_factor is a float scale factor
range is a float value from 1 to 180, dictating how much of the Earth will be seen
minx is a float specifying the minimum x value
miny is a float specifying the minimum y value
maxx is a float specifying the maximum x value
maxy is a float specifying the maximum y value
paperunitname is a string representing a paper unit of measure (for example, \textdegree in\textquoteright for inches); for a list of unit names, see Set Paper Units
tablename is the name of an open table
window\_id is an Integer window identifier corresponding to a Map or Layout window
A performs scaling or stretching along the X axis.
B performs rotation or skewing along the X axis.
C performs shifting along the X axis.
D performs scaling or stretching along the Y axis.
E performs rotation or skewing along the Y axis.
F performs shifting along the Y axis.

**Transform Clause**

When you have MIF files with coordinates stored with respect to the northwest quadrant (quadrant 2), you can transform them to the northeast quadrant (quadrant 1) with a transform clause.
The transform clause has the following syntax:

```
TRANSFORM Xmultiplier, Ymultiplier, Xdisplacement, Ydisplacement
```

To transform quadrant 2 data into quadrant 1 data, use the following transform clause:

```
TRANSFORM -1,0,0,0
```

The zeroes instruct MapInfo Pro to ignore that parameter.

When you have an application which creates MIF files in quadrant 2, you can:

- Add the TRANSFORM clause to the MIF files
- Change the application so that it creates coordinates in quadrant 1
- Change the application so that it adds a TRANSFORM clause to the MIF files

### Columns

Specify the number of columns. Then, for each column, create a row containing the column name, the column type, and, for character and decimal columns, a number to indicate the width of the field.

**Note:** Field names cannot have spaces.

Valid column types are:

- char (width)
- integer (which is 4 bytes)
- smallint (which is 2 bytes, so it can only store numbers between -32767 and +32767)
- decimal (width, decimals)
- float
- date
- logical

This is an example of the columns section of the header:

```
COLUMNS 3
STATE char (15)
POPULATION integer
AREA decimal (8,4)
```

For the database specified in this header, the MID file has three columns:

- a 15 character field that represents the STATE column,
- an integer field that represents the POPULATION column,
- an AREA column that consists of a decimal field with up to 8 total characters (digits, decimals points, and optional sign) and 4 digits after the decimal.
## In this section

<table>
<thead>
<tr>
<th>Glossary of Terms</th>
<th>616</th>
</tr>
</thead>
</table>
## Glossary of Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>3DMap</td>
<td>A window that allows you to view your maps containing continuous grids from various viewpoints in 3D Format.</td>
</tr>
<tr>
<td>Add Node button</td>
<td>Use the Add Node button to add a node to regions, polylines, and arcs. You can add nodes when the Reshape tool is in effect. Adding nodes can give more precision to your object.</td>
</tr>
<tr>
<td>address dictionary</td>
<td>The search dictionary used for matching addresses during geocoding.</td>
</tr>
<tr>
<td>adornment</td>
<td>A map decoration, such as a title, scale bar, or company logo, that provides contextual information for the map view.</td>
</tr>
<tr>
<td>alias</td>
<td>The name assigned to an expression or a column when you are working in the Select Columns field in the SQL Select dialog box. This name appears as the column title for that expression or column in a Browser.</td>
</tr>
<tr>
<td>application</td>
<td>A computer program used for a particular kind of work, such as word processing. Application is often interchangeable with the word program.</td>
</tr>
<tr>
<td>Arc button</td>
<td>The Arc button allows you to access the Arc tool. Use the Arc tool to draw an arc the size and shape of one quarter of an ellipse. Once you have created an arc, you can reshape it to the desired size.</td>
</tr>
<tr>
<td>ASCII</td>
<td>The acronym for American Standard Code for Information Interchange. ASCII is a standard code used in most microcomputers, computer terminals, and printers for representing characters as numbers. It not only includes</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>printable characters</td>
<td>printable characters, but also control codes to indicate carriage return, backspace, and so forth.</td>
</tr>
<tr>
<td><strong>Assign Selected Objects button</strong></td>
<td>Use this button to permanently assign all selected map objects to the target district.</td>
</tr>
<tr>
<td>attribution text</td>
<td>Text added to a tile server table definition that automatically displays when a tile server layer is in a map window. Some tile servers require attribution text, such as origin and copyrights information (the tile server author or distributor provides attribution text requirements).</td>
</tr>
<tr>
<td>axis</td>
<td>Used in a graph, these are graduated lines bordering the plot area of a graph. Location coordinates are measured relative to the axes. By convention the X-axis is horizontal, the Y-axis is vertical.</td>
</tr>
<tr>
<td>bar chart</td>
<td>A type of thematic map that displays a bar chart of thematic variables for each record in a table from which the map is based.</td>
</tr>
<tr>
<td>base map</td>
<td>Usually the dominant or underlying layer in a given map. (These are typically the data layers that Pitney Bowes Software Inc. offers as ready products.) Users usually layer their own data on top of these base maps or use these base maps to geocode or to make new layers. Examples are joining industry data to postal code boundaries for analysis and then combining arrangements of the postal codes into new territory layers.</td>
</tr>
<tr>
<td>base table</td>
<td>A permanent table, which is part of a map, as opposed to a query table, which is temporary. You can edit the contents of base tables, and you can change their structure (by editing, deleting, reordering columns and adding or deleting graphic objects).</td>
</tr>
<tr>
<td>Bitmap</td>
<td>A screen image displayed as an array of dots or bits. Software usually generates either bit-mapped (raster) or object-oriented (vectored) files. MapInfo Pro can work with both.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>boundary region</td>
<td>In GIS a boundary is a region on a map enclosed by a border. Cambria County, Manitoba, and Argentina would all be represented as boundaries on a map. Note that a single boundary could encompass several polygons. Thus, Indonesia is a single boundary but consists of many polygons.</td>
</tr>
<tr>
<td>Boundary Select button</td>
<td>The Boundary Select button allows you to access the Boundary Select tool. Use the Boundary Select Tool to search for and choose all the objects within a given region, such as a state or county boundary, a police patrol district, a sales territory, and so forth.</td>
</tr>
<tr>
<td>browser</td>
<td>A window for viewing a table (or database, spreadsheet or text file) in tabular form.</td>
</tr>
<tr>
<td>buffer</td>
<td>A type of proximity analysis where areas or zones of a given distance are generated around selected map objects. Buffers are user-defined or can be generated for a set of objects based on those objects' attribute values. The resulting buffer zones form region objects representing the area that is within the specified buffer distance from the object.</td>
</tr>
<tr>
<td>cadastral</td>
<td>A map set used to graphically define the cadastre or land ownership in a given area. A tax map is an example of a cadastral map. The land registration, assessment roles, and tax maps comprise the cadastre.</td>
</tr>
<tr>
<td>Cancel button</td>
<td>A command button for closing a dialog box without making changes.</td>
</tr>
<tr>
<td>Cartesian</td>
<td>A coordinate system using an x,y scale not tied to any &quot;real-world&quot; system. Most CAD drawing uses this method of registering objects (for example, a drawing of a ball-bearing assembly, floor plans). If a drawing uses Cartesian coordinates, one corner of the drawing probably has coordinates 0, 0.</td>
</tr>
<tr>
<td>Cartesian Coordinates</td>
<td>The conventional representation of geometric objects by x and y values on a plane.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>cartographic scale</td>
<td>A map scale that does not include distance units, such as 1:63,360 or 1:1,000,000.</td>
</tr>
<tr>
<td>cartography</td>
<td>The art and science of making maps. In GIS it is also the graphic presentation and visual interpretation of data.</td>
</tr>
<tr>
<td>centroid</td>
<td>Usually the center of a map object. For most map objects, the centroid is located at the middle of the object (the location halfway between the northern and southern extents and halfway between the eastern and western extents of the object). In some cases, the centroid is not at the middle point because there is a restriction that the centroid must be located on the object itself. Thus, in the case of a crescent-shaped region object, the middle point of the object may actually lie outside the limits of the region; however, the centroid is always within the limits of the region. In MapInfo Pro, the centroid represents the location used for automatic labeling, geocoding, and placement of thematic pie and bar charts. If you edit a map in Reshape mode, you can reposition region centroids by dragging them.</td>
</tr>
<tr>
<td>Change View button</td>
<td>This button allows you to change the zoom, map scale, and window centering aspects of the Map or classic Layout window that currently displays.</td>
</tr>
<tr>
<td>check box</td>
<td>A small square box that appears in a dialog box. You can click in the check box or on the text in order to select the option. Check boxes are generally present when multiple options can be selected at one time.</td>
</tr>
<tr>
<td>click</td>
<td>To press and release a mouse button quickly.</td>
</tr>
<tr>
<td>column</td>
<td>A column in a Browser corresponds to a field in a table. A column contains a specific type of information about an object, such as Name, Abbreviation, Land area, Price, Population, and so forth. The information for each object is listed on a row in the Browser.</td>
</tr>
<tr>
<td>command</td>
<td>A word or phrase, usually found in a menu, that displays a dialog box and/or carries out an action.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>conflict resolution</td>
<td>When conflicts exist between the data residing on a remote database and new data that you want to upload to the remote database via a MapInfo Pro linked table. The conflict resolution process is invoked whenever an attempt to save the linked table detects a conflict in an update.</td>
</tr>
<tr>
<td>Control menu</td>
<td>A menu activated through the Control Menu Box located in the upper left corner of all windows. The control menu is used to resize, move, maximize, minimize, or close the window.</td>
</tr>
<tr>
<td>control points</td>
<td>The points on a raster image whose coordinates serve as a reference for associating earth coordinates with any location on the image. See registration.</td>
</tr>
<tr>
<td>coordinate</td>
<td>An x,y location in a Cartesian coordinate system, or a Latitude, Longitude location in an earth coordinate system. Coordinates represent locations on a map relative to other locations. Earth coordinate systems may use the equator and the Greenwich prime meridian as fixed reference points. Plane coordinate systems describe a two-dimensional x,y location in terms of distance from a fixed reference and are usually in the first quadrant so that all coordinates are positive numbers.</td>
</tr>
<tr>
<td>coordinate system</td>
<td>A coordinate system is used to create a numerical representation of geometric objects. Each point in a geometric object is represented by a pair of numbers. Those numbers are the coordinates for that point. In cartography, coordinate systems are closely related to projections. You create a coordinate system by supplying specific values for the parameters of a projection. See Cartesian Coordinates, projection, and spherical coordinates.</td>
</tr>
<tr>
<td>cosmetic layer</td>
<td>The topmost layer of a Map window. Objects may be placed in this layer such as map titles and graphic objects. It is always displayed, and all objects placed in the Cosmetic Layer must be saved to a new or existing layer.</td>
</tr>
<tr>
<td>data aggregation</td>
<td>A process that occurs when combining separate map objects into a single object. MapInfo Pro calculates what the column</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>values for the new object</td>
<td>should be, based on sums or averages of the values of the original objects.</td>
</tr>
<tr>
<td>data disaggregation</td>
<td>A process that occurs when splitting a map object(s) into smaller parts where MapInfo Pro splits the data associated with the map object(s) into smaller parts to match the new map objects.</td>
</tr>
<tr>
<td>data sources</td>
<td>An ODBC data source is an SQL database and the information you need to access that database. For example, an SQL Server data source is the SQL Server database, the server on which it resides, and the network used to access that server.</td>
</tr>
<tr>
<td>database</td>
<td>Any organized collection of data. The term is often used to refer to a single file or table of information in MapInfo Pro.</td>
</tr>
<tr>
<td>decimal degree</td>
<td>The decimal representation of fractions of degrees. Many paper maps express coordinates in degrees, minutes, seconds (for example, 40_30/10), where minutes and seconds are fractions of degrees. 30 minutes equal half a degree, and 30 seconds equal half a minute. MapInfo Pro, however, expresses coordinates in decimal degrees (for example, 72.558 degrees), where fractions of degrees are expressed as decimals. Thus, the longitude: 40 degrees, 30 minutes, would be expressed in MapInfo Pro as 40.5 degrees.</td>
</tr>
<tr>
<td>default</td>
<td>The value or option used in the absence of explicit specification. Often the original setting or value for a variable.</td>
</tr>
<tr>
<td>degrees longitude, degrees latitude, decimal degrees</td>
<td>Degrees (longitude and latitude) are coordinates used to represent locations on the surface of the earth. Longitude, or X-coordinate, represents a location's east-west position, where any location west of the prime meridian has a negative X value. Latitude, or Y-coordinate, represents a location's north-south position, where any location south of the equator has a negative Y value.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>derived column</td>
<td>In a table created through the SQL Select, a derived column is one created by using an expression. The column is derived in the sense that it is not just a copy of the data in one of the tables being accessed by the SQL Select command.</td>
</tr>
<tr>
<td>derived field</td>
<td>The same as a derived column.</td>
</tr>
<tr>
<td>deselect</td>
<td>The process of undoing a selection. The object or area you deselect will not be affected by subsequent commands. Performed by selecting another area, by clicking in a blank area, or by executing the Unselect All command.</td>
</tr>
<tr>
<td>digitizer, digitizing tablet</td>
<td>An electronic device that lets you trace a paper map into a GIS or CAD package. The digitizer consists of a table (or tablet) onto which you attach a paper map. You then can trace the map by moving a hand-held, mouse-like device known as a cursor, or puck, across the surface. Digitizing a map produces vector data as the end result.</td>
</tr>
<tr>
<td>districts browser</td>
<td>A special browser that displays when redistricting. It differs from other Browser windows in the following respects: one row can only be selected at one time, one row is always selected, and the selected row becomes the target district into which you can add other objects.</td>
</tr>
<tr>
<td>dot density map</td>
<td>A type of thematic map that carries information by showing a large number of tiny dots, wherein each dot represents some specific unit quantity. For example, for a population dot density map each dot might represent 10,000 people.</td>
</tr>
<tr>
<td>Drawing toolbar</td>
<td>A MapInfo Pro window containing twelve buttons that access tools for drawing and modifying objects on your map.</td>
</tr>
<tr>
<td>edit handle</td>
<td>The small boxes that appear at the four corners of the minimum bounding rectangle of an object in an editable layer of a Map window or in a Layout window.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Ellipse button</td>
<td>The Ellipse button allows you to access the Ellipse tool. Use the Ellipse tool to create elliptical and round objects.</td>
</tr>
<tr>
<td>export</td>
<td>The process whereby a program saves information in a file to be used by another program.</td>
</tr>
<tr>
<td>expression</td>
<td>A statement containing two parts: 1) column names and constants (for example, specific data values), and 2) functions (for example, area) and operators (for example, +, -, &gt;), in order to extract or derive information from a database. Expressions are used in Select, SQL Select, Update Column, Create Thematic Map, and Label with Column.</td>
</tr>
<tr>
<td>field</td>
<td>A field in a table corresponds to a column in a Browser. A field contains a specific type of information about an object, such as, name, abbreviation, land area, price, population, and so forth. The record for each object consists of that object's values for each of the fields in the database.</td>
</tr>
<tr>
<td>file</td>
<td>A collection of information that has been given a name and is stored on some electronic medium such as a tape or disk. A file can be a document or an application.</td>
</tr>
<tr>
<td>fill pattern</td>
<td>The design and color used to fill a closed object.</td>
</tr>
<tr>
<td>FLEXNet Operations module (FNO)</td>
<td>The Pitney Bowes Software database that maintains product entitlements and information about their activation.</td>
</tr>
<tr>
<td>font</td>
<td>A character set based on a particular style used for text characters.</td>
</tr>
<tr>
<td>Frame button</td>
<td>The Frame button allows you to create frames in a classic Layout window. Each frame can display a map, graph, Browser, map legend, graph legend, Info window, Statistics window, and message window or, it can be an empty frame.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>generalization</td>
<td>The process of simplifying a data set to a size that can be easily manipulated and represented. For example, a river may have many twists and turns; however, if a map covers a very large area, the river may be represented as a straight line. Similarly, in a map of a very large area, a city might be represented as a point marker.</td>
</tr>
<tr>
<td>geocode</td>
<td>The process of assigning X and Y coordinates to records in a table or database so that the records can be displayed as objects on a map.</td>
</tr>
<tr>
<td>Geographic Information System (GIS)</td>
<td>An organized collection of computer hardware and software designed to efficiently create, manipulate, analyze, and display all types of geographically or spatially referenced data. A GIS allows complex spatial operations that are very difficult to do otherwise.</td>
</tr>
<tr>
<td>Georegistered PDF</td>
<td>A PDF file that has geospatial information (bounds and coordinate systems) of Map or Layout Designer window that it prints.</td>
</tr>
<tr>
<td>Grabber button</td>
<td>The Grabber Button allows you to access the Grabber tool. Use the Grabber tool to reposition a map within its window or the contents of a map frame in the Layout Designer window.</td>
</tr>
<tr>
<td>Graduated Symbols map</td>
<td>A type of thematic map that shows symbols (point objects) in a variety of sizes to indicate which objects have higher or lower numerical values.</td>
</tr>
<tr>
<td>Graph window</td>
<td>A window that displays numerical data in the form of a graph.</td>
</tr>
<tr>
<td>graticule</td>
<td>A grid of horizontal (latitude) and vertical (longitude) lines displayed on an earth map, spaced at a regular distance (for example, every five degrees, every fifteen degrees). Used to establish a frame of reference.</td>
</tr>
<tr>
<td>Grid Surface map</td>
<td>A type of thematic map that displays data as continuous color gradations across the map. This type of thematic map</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>DefinitionTerm</td>
<td>is produced by an interpolation of point data from the source table. A grid file from the data interpolation is generated and displays as a raster image in a Map window.</td>
</tr>
<tr>
<td>heads-up digitizing</td>
<td>A method of digitizing where the user creates vector objects by tracing over a raster image displayed on the screen. Thus, heads-up digitizing does not require a digitizing tablet.</td>
</tr>
<tr>
<td>Help Button bar</td>
<td>A bar located at the top of the Help Window that contains buttons you use to move to Help topics.</td>
</tr>
<tr>
<td>horizontal scroll bar</td>
<td>The Horizontal scroll bar appears at the bottom of the MapInfo Pro window. Use the horizontal scroll bar to move left and right. The scroll box inside the scroll bar indicates your horizontal location. You can use the mouse to scroll to other parts of the window.</td>
</tr>
<tr>
<td>hot views</td>
<td>MapInfo Pro technology that automatically updates all the windows you have open for a particular table when you make a change in any one of the windows. For example, if an item is selected in a Map window, it will be selected in all other Map windows and Browsers you have open for that table.</td>
</tr>
<tr>
<td>import</td>
<td>The process whereby a program loads a file that is the output of another program.</td>
</tr>
<tr>
<td>Individual Values map</td>
<td>A type of thematic map that shades records according to individual values.</td>
</tr>
<tr>
<td>inflection</td>
<td>The process of deviating the color in ranged thematic maps to emphasize some numerical significance. In thematic mapping we insert a new color between the top and bottom color for second interpolation of data.</td>
</tr>
<tr>
<td></td>
<td>For example, suppose we were showing population growth with blue representing an increase in population growth and red representing a decrease in population growth.</td>
</tr>
<tr>
<td></td>
<td>We could have white as the inflection color for a range that has zero or almost zero population growth, so that lighter shades of blue would represent a smaller population growth.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>and lighter shades of red would represent a smaller decline in population.</td>
<td>Info button: The Info button allows you to access the Info tool. Use the Info tool to select a location on your map, including multiple overlapping objects and display a list of all objects at that location. You can then choose an object from the list and view the tabular data for that object.</td>
</tr>
<tr>
<td>islands</td>
<td>Small areas outside the main boundary that can be reached within the specified time or distance.</td>
</tr>
<tr>
<td>IsoChrone</td>
<td>An IsoChrone is a polygon or set of points representing an area that can be traversed from a starting point in a given amount of time along a given road network.</td>
</tr>
<tr>
<td>IsoDistance</td>
<td>An IsoDistance is a polygon or set of points representing an area that can be traversed from a starting point travelling a given distance along a given road network.</td>
</tr>
<tr>
<td>Isogram</td>
<td>An Isogram is a map that displays a set of points that satisfy a distance or time condition. Isograms are either IsoChrones or IsoDistances.</td>
</tr>
<tr>
<td>join</td>
<td>The process of creating a relational link between two tables (databases).</td>
</tr>
<tr>
<td>Latitude</td>
<td>The horizontal lines on a map that increase from 0 degrees at the Equator to 90 degrees at both the North (+90.0 degrees) and South (-90.0 degrees) poles. Used to describe the North-South position of a point as measured usually in degrees or decimal degrees above or below the equator.</td>
</tr>
<tr>
<td>layer</td>
<td>A layer is a basic building block of MapInfo Pro maps and consists of a table with graphic and text settings like style override, labeling, and zoom layering. Maps are made of one or more superimposed layers (for example, a layer of street data superimposed over a layer of county or postal code boundaries) which you can design to convey</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>geographical or statistical information.</strong></td>
<td>Typically, each map layer corresponds to one open table. Cosmetic Layers contain map objects that represent temporary map annotations (for example, text objects). Cosmetic Layers contain map objects that represent temporary map annotations (for example, labels). See cosmetic layer and table.</td>
</tr>
<tr>
<td><strong>Layer Control button</strong></td>
<td>The Layer Control Button allows you to access the Layer Control window. This dialog box allows you to specify how the various tables in a Map window are layered and displayed. See Accessing Layer Control.</td>
</tr>
<tr>
<td><strong>Layout window</strong></td>
<td>A window where you arrange and annotate the contents of one or several windows for printing.</td>
</tr>
<tr>
<td><strong>legend</strong></td>
<td>The part of a map, which explains the meaning of different colors, shapes, or fill patterns used on the map. See also What is a Legend?.</td>
</tr>
<tr>
<td><strong>legend frames</strong></td>
<td>Each Legend Designer window contains one or more legend frames each corresponding to a style or theme layer in the Map window.</td>
</tr>
<tr>
<td><strong>Legend Designer window</strong></td>
<td>A window containing legend frames. You can create more than one Legend Designer window for each map. The Legend Designer window can contain more than one frame. For example, you can have one Legend Designer window containing four legend frames, or you can have four Legend Designer windows, each containing one legend frame.</td>
</tr>
<tr>
<td><strong>Legend Window button</strong></td>
<td>Use the Legend Window button to display the floating thematic legend window.</td>
</tr>
<tr>
<td><strong>line, line object</strong></td>
<td>A map object defined by a set of sequential coordinates that may represent the generalized shape of a geographic feature (for example, street centerlines, railroads, cables). A Pitney Bowes Software Inc. street map is a collection of thousands of line objects.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>---------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Line button</td>
<td>The Line button allows you to access the Line tool. Use the Line tool to draw straight lines.</td>
</tr>
<tr>
<td>Line Style button</td>
<td>Use the Line Style button to access the Line Style dialog box. The Line Style dialog box allows you to set the line type, thickness and color of line objects (lines, arcs and polylines) and borders of closed objects. You can also change the type, thickness and color of objects you are editing.</td>
</tr>
<tr>
<td>linked table</td>
<td>A linked table is a special kind of MapInfo table that is downloaded from a remote database and retains connections to its remote database table. You can perform most operations on a linked table that you do for a regular MapInfo table.</td>
</tr>
<tr>
<td>Longitude</td>
<td>The vertical lines on a map, running from the North to South poles, used to describe the east-west position of a point. The position is reported as the number of degrees east (to -180.0 degrees) or west (to +180.0 degrees) of the prime meridian (0 degrees). Lines of longitude are farthest apart at the Equator and intersect at both poles, and therefore, are not parallel.</td>
</tr>
<tr>
<td>Longitude/ Latitude</td>
<td>MapInfo Pro's default coordinate system for representing geographic objects in a map.</td>
</tr>
<tr>
<td>Main toolbar</td>
<td>A window containing buttons for choosing tools, accessing dialog boxes, and showing or hiding windows.</td>
</tr>
<tr>
<td>MapBasic</td>
<td>The programming language used to customize and/or automate MapInfo Pro. To create MapBasic applications, you need the MapBasic compiler, which is a separate product. However, you do not need the MapBasic compiler to run a compiled MapBasic application.</td>
</tr>
<tr>
<td>Map Catalog</td>
<td>The MapInfo map catalog stores information about the location of spatial columns on the DBMS. There must be one catalog per database. The EasyLoader application can create this catalog for each database: Oracle, SQL Server,</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>PostGIS, and MS Access. Additionally, you can create a map catalog manually with instructions in the <em>MapInfo Pro User Guide</em>. This is a one-time only task per database and is required before any tables on that database can be mapped in MapInfo Pro.</td>
<td></td>
</tr>
<tr>
<td>map scale</td>
<td>A statement of a measure of the map and the equivalent measure on the earth. Often expressed as a representative ratio of distance, such as 1:10,000. This means that one unit of distance on the map (for example, one inch) represents 10,000 of the same units of distance on the earth. The term <em>scale</em> must be used carefully. Technically, a map of a single city block is <em>large-scale</em> (for example, 1:12,000), while a map of an entire country is <em>small-scale</em> (for example, 1:1,000,000). A 1:1,000,000 map is considered small-scale because of the small numeric value obtained when you divide 1 by 1,000,000.</td>
</tr>
<tr>
<td>map segment</td>
<td>In a street map, a segment is a single section of the street. In urban maps, segments are generally one block long. Address ranges are stored at the segment level.</td>
</tr>
<tr>
<td>map scale</td>
<td>A ratio or representative fraction (RF), expressed as 1 inch = 63,360 mile or 1:1,000,000 (1 cm to 10 km), that indicates the relationship between a distance on the map and the distance on the ground. See also Cartographic Scale.</td>
</tr>
<tr>
<td>Map window</td>
<td>A window that allows you to view a table as a map.</td>
</tr>
<tr>
<td>meridian</td>
<td>A line or a portion of a line running from the North to the South pole. A longitudinal line.</td>
</tr>
<tr>
<td>Military Grid Reference System</td>
<td>The U.S. Military Grid Reference System (MGRS) is a grid reference system that MapInfo Pro supports when displaying maps in a Map window. It is the military version of the civilian-use Universal Transverse Mercator (UTM) grid system. Military grid references are very similar to the mathematical Cartesian x,y system in which coordinates are giving in terms of x (easting) and y (northing). In this system, the world is generally divided into 6° by 8° geographic areas, each of which is given a unique</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Minimum Bounding Rectangle (MBR)</td>
<td>For any given map object, the smallest rectangle that completely encompasses the object.</td>
</tr>
<tr>
<td>native projection</td>
<td>The projection in which a map's coordinate points are stored. MapInfo Pro allows you to display maps in other projections, but not as fast as displaying maps in their native projection.</td>
</tr>
<tr>
<td>node</td>
<td>An end-point of a line object, or an end-point of a line segment which is part of a polyline or region object.</td>
</tr>
<tr>
<td>Non-Earth map</td>
<td>A map in which objects are not explicitly referenced to locations on the earth's surface. Floor plans are typical examples.</td>
</tr>
<tr>
<td>ODBC drivers</td>
<td>An ODBC driver is a dynamic-link library (.DLL) file that MapInfo Pro uses to connect to an SQL database. Each type of SQL database requires a different ODBC driver.</td>
</tr>
<tr>
<td>ODBC table</td>
<td>An ODBC table is a table residing in a remote SQL database.</td>
</tr>
<tr>
<td>OSGB MasterMap GML Files</td>
<td>Many of our international customers want to display MasterMap GML files developed by the Ordnance Survey of Great Britain (OSGB). We provide support for some of the Topography features (OSGB version 2.0), Topographic Area, Lines and Points, Cartographic Symbols and Boundary Lines.</td>
</tr>
</tbody>
</table>
We maintain support for these features and add support for Cartographic Text and Departed Features. MapInfo Pro will continue to support GML files as the OSGB updates the schema that underlies the GML technology.

As the GML format gets more sophisticated in its support of additional layers, feature types, and attributes, we will continue to provide full support for those changes. Currently, we support the OSGB recommended styles by mapping the style definitions to existing MapInfo Pro styles. Where it is not possible to render complicated fill patterns, we use the simple dot screen that the OSGB recommended to us. The OSGB style mapping to MapInfo styles is hard coded so it cannot be changed.

For more information about OS MasterMap see [www.ordsvy.gov.uk/os_mastermap/home/home.htm](http://www.ordsvy.gov.uk/os_mastermap/home/home.htm).

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>outer join</td>
<td>A type of multi-table join where all the records in the specified tables are included in the result table, even records that do not match the join criteria. MapInfo Pro does not perform outer joins.</td>
</tr>
<tr>
<td>pack</td>
<td>The process of compressing MapInfo tables so that they use less disk space.</td>
</tr>
<tr>
<td>Pie Chart map</td>
<td>A type of thematic map that displays a pie chart of thematic variables for each record in the table from which the map is based.</td>
</tr>
<tr>
<td>Pin Map, Push-Pin map</td>
<td>A type of map named after the practice of inserting push-pins into a wall map. A pin map features point objects. Geocoding a database is one way of creating a pin map.</td>
</tr>
<tr>
<td>pixel</td>
<td>The acronym for picture element. The smallest dot that can be displayed on a computer screen. If a screen is described as having a resolution of 1,024 x 768, the screen shows 1,024 pixels from right to left, and 768 pixels from top to bottom. Each character, object, or line on the screen is composed of numerous pixels.</td>
</tr>
<tr>
<td>point, point object</td>
<td>A map object defined by a single X,Y coordinate pair. Each point object is represented by a symbol style (for example, circle, square, triangle, etc.).</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>point size</td>
<td>A unit of measurement equal to 1/72 of an inch. Used to measure character size.</td>
</tr>
<tr>
<td>pointer</td>
<td>An arrow-shaped cursor on the screen that can be manipulated by a mouse.</td>
</tr>
<tr>
<td>polygon, polygon object</td>
<td>A simple bounded region, simple in the sense that it does not consist of more than one polygon (where a boundary can consist of more than one polygon). The Polygon tool creates a single polygon.</td>
</tr>
<tr>
<td>Polygon button</td>
<td>The Polygon button allows you to access the Polygon tool. Use the Polygon tool to draw polygons one side at a time.</td>
</tr>
<tr>
<td>polygon overlay</td>
<td>A spatial operation that merges overlapping polygons from two layers to analyze those intersected areas or to create a third layer of new polygons.</td>
</tr>
<tr>
<td>polyline, polyline object</td>
<td>A linetype object made up of many line segments. It contains more than two nodes, that is, more than its end points. The Polyline tool creates a single polyline. In contrast, the Line tool only draws a single straight line (that is, a line defined by two nodes).</td>
</tr>
<tr>
<td>Polyline button</td>
<td>The Polyline button allows you to access the Polyline tool. Use the Polyline Tool to draw polylines (a connected sequence of lines that are not closed).</td>
</tr>
<tr>
<td>projection</td>
<td>A mathematical model that transforms the locations of features on the earth’s surface to locations on a two-dimensional surface, such as a paper map. Since a map is an attempt to represent a spherical object (the earth) on a flat surface, all projections have some degree of distortion. A map projection can preserve area, distance, shape or direction but only a globe can preserve all of these attributes. Some projections (for example, Mercator) produce maps well suited for navigation. Other projections (for example, equal-area projections, such as Lambert) produce maps well suited for visual analysis.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>query table</td>
<td>A temporary table produced as the result of a Select, SQL Query, or by choosing objects in a Map window or records in a Browser and mapping, graphing, or browsing that selection. You cannot make edits and structural changes on query tables, but you can edit a selected set of rows in your source table through a query table. See selection and base table.</td>
</tr>
<tr>
<td>Radius Select button</td>
<td>The Radius Select button allows you to access the Radius Select tool. Use this tool to select all of the objects within a certain radius. See Using the Radius Select Tool.</td>
</tr>
<tr>
<td>Ranged map</td>
<td>A type of thematic map that displays data according to ranges set by the user. The ranges are shaded using colors or patterns.</td>
</tr>
<tr>
<td>raster image</td>
<td>A type of computerized picture consisting of row after row of tiny dots (pixels). Raster images are sometimes known as bitmaps. Aerial photographs and satellite imagery are common types of raster data found in GIS. A computer image can be represented in raster format or in vector format. See scanning and vector image.</td>
</tr>
<tr>
<td>record</td>
<td>All the information about one object in a database or table. A record in a table corresponds to a row in a Browser.</td>
</tr>
<tr>
<td>Rectangle button</td>
<td>The Rectangle button allows you to access the Rectangle tool. Use the Rectangle tool to draw rectangles and squares.</td>
</tr>
<tr>
<td>redistricting</td>
<td>The process of assigning map objects to groups. As you assign map objects, MapInfo Pro automatically calculates totals for each group and displays the totals in a special Districts Browser. This process is sometimes known as load-balancing.</td>
</tr>
<tr>
<td>reference grids</td>
<td>A matrix of letters and numbers that assist users in some style dialog boxes that identify specific line styles, colors, and patterns.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>region, region object</td>
<td>An enclosed area defined by one or more polygons. If a region contains one or more lakes or islands, each lake or island is a separate polygon. A region is an object created with the Polygon tool.</td>
</tr>
<tr>
<td>Region Style button</td>
<td>Use the Region Style button to access the Region Style dialog box. The Region Style dialog box allows you to specify the color, pattern, and borderline style of closed objects. You can also change the color and pattern of objects you are currently editing.</td>
</tr>
<tr>
<td>registration</td>
<td>Usually the first stage of the digitizing process or when opening a raster image for the first time in MapInfo Pro. Before you can digitize a paper map or work with a raster image, you must point to several control points across the map, and enter their coordinates (for example, longitude, latitude). After you have registered the map, MapInfo Pro can associate a longitude, latitude position with any point on the map surface; this allows MapInfo Pro to perform area and distance calculations, and overlay multiple map layers in a single map. CAD systems as well as GIS systems utilize this process. See control points.</td>
</tr>
<tr>
<td>Reshape button</td>
<td>The Reshape button toggles you in and out of Reshape mode. Use reshape to edit regions, polylines, lines, and points by moving, adding, and deleting nodes that define line segments. You can also copy and paste selected nodes to create new polylines. Reshape is very useful when you are creating sales territories or other merged boundaries. For example, you are merging ZIP Code boundaries to create school districts. Some ZIP Code boundaries fall into more than one school district. Use the Reshape button to reshape the school district to incorporate a section of the ZIP Code boundary. See Reshaping Map Objects.</td>
</tr>
<tr>
<td>result code</td>
<td>Result codes indicate whether a geocode match was made and the type of match it was, and conveys information about the quality of the match. The result code is an alphanumeric code of 1-10 characters.</td>
</tr>
<tr>
<td>Rounded Rectangle button</td>
<td>The Rounded Rectangle button allows you to access the Rounded Rectangle tool. Use the Rounded Rectangle tool to draw rounded rectangles and squares.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Ruler button</strong></td>
<td>The Ruler button allows you to determine the distance between two points and the length of some path.</td>
</tr>
<tr>
<td><strong>Run MapBasic Program button</strong></td>
<td>The Run MapBasic Program button accesses the Run MapBasic Application dialog box where you specify the MapBasic program you want to run.</td>
</tr>
<tr>
<td><strong>scale bar</strong></td>
<td>An adornment on the map that shows the scale of map representation relative to the portion of the Earth's surface.</td>
</tr>
<tr>
<td><strong>scanning</strong></td>
<td>The process of inputting data into a raster format using an optical device called a scanner.</td>
</tr>
<tr>
<td><strong>scroll Bar</strong></td>
<td>Bars along the right and bottom sides of each window that allow you to scroll the window view. Clicking on the shaded area moves one window screen at a time.</td>
</tr>
<tr>
<td><strong>seamless layer</strong></td>
<td>A seamless layer treats a group of base tables as if they are one. It allows you to change display attributes, apply or change labeling or use the Layer Control window for an entire group of tables at once. A base table can be any regular MapInfo Pro table. Grid layers cannot be made seamless.</td>
</tr>
<tr>
<td><strong>Select button</strong></td>
<td>The Select button allows you to access the Select tool. Use the Select tool to select one or more objects or records for analysis. You can also use the Select tool to edit a map or browser. See Selecting a Single Object from a Map or Layout.</td>
</tr>
<tr>
<td><strong>selection</strong></td>
<td>A data item or set of data items chosen for inspection and/or analysis. Regardless of the kinds of windows on the screen, selections can be made using the Select and SQL Select Query commands in MapInfo Pro's Query menu. In Browsers and Map windows, items can be placed in the selection set by clicking on them individually. Map windows also have special tools for selecting multiple items on a spatial basis.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Set Target District from Map button</td>
<td>Use this button to make the selected object’s district the new target district. See redistricting.</td>
</tr>
<tr>
<td>Show MapBasic Window button</td>
<td>The MapBasic window button allows you to display or hide the MapBasic window. You can perform many different tasks by typing commands into the MapBasic window. Choosing items from MapInfo Pro’s menus could instead perform those same tasks. There are times, however, when it is easier to type commands into the command window.</td>
</tr>
<tr>
<td>snap to nodes</td>
<td>A feature that helps in drawing, moving and positioning map objects. In Snap mode (S key) the cursor snaps to a node of a map object when it comes within a certain distance.</td>
</tr>
<tr>
<td>source table</td>
<td>A permanent table, as opposed to a query table, which is temporary. You can edit the contents of source tables and you can change their structure (by editing, deleting, reordering columns and adding or deleting graphic objects). You cannot make edits and structural changes on query tables but you can edit a selected set of rows in your source table through a query table.</td>
</tr>
<tr>
<td>spatial analysis</td>
<td>An operation that examines data with the intent to extract or create new data that fulfills some required condition or conditions. It includes such GIS functions as polygon overlay or buffer generation and the concepts of contains, intersects, within or adjacent.</td>
</tr>
<tr>
<td>spherical coordinates</td>
<td>Latitude and longitude values that represent objects on the surface of the globe.</td>
</tr>
<tr>
<td>SQL (Structured Query Language)</td>
<td>A standard language used for analyzing information stored in relational databases. MapInfo Pro’s database engine is based on the SQL standard.</td>
</tr>
<tr>
<td>SQL query</td>
<td>The selection of information from a database according to the textual attributes and object relationships of the items. In MapInfo Pro, queries are created with the SQL Select and Select commands or with MapBasic commands in the MapBasic window.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>stacked style</td>
<td>A list of styles drawn on top of each other to create a more complex or interesting map feature. Stacked styles apply to points, polylines, and polygon features.</td>
</tr>
<tr>
<td>standard deviation</td>
<td>A measurement of the variation of a set of data values around the mean.</td>
</tr>
<tr>
<td>Standard toolbar</td>
<td>A window containing buttons for quick access to the most commonly used menu commands such as Cut, Copy, and Paste.</td>
</tr>
<tr>
<td>Statistics button</td>
<td>Use the Statistics button to display the Statistics window. The Statistics window tallies the sum and average of all numeric fields for the currently chosen objects/records. The number of records chosen is also displayed. As the selection changes, the data is re-tallied, and the statistics window is updated automatically. See <a href="#">redistricting</a></td>
</tr>
<tr>
<td>Statistics window</td>
<td>A window containing the sum and average of all numeric fields for the currently selected objects/records. The number of records selected is also displayed. As the selection changes, the data is re-tallied, and the statistics window updates automatically.</td>
</tr>
<tr>
<td>StatusBar</td>
<td>A bar at the bottom of the screen that displays messages that help in using MapInfo Pro. The StatusBar also displays messages that pertain to the active window. In a Map window, the StatusBar indicates what layer is editable, the zoom display of the map, and the status of Snap and Digitizing modes. In a Browser window, the StatusBar indicates the number of records currently displaying and the total number of records. In a Layout window, the StatusBar indicates the zoom display as a percentage of the actual size of the map.</td>
</tr>
<tr>
<td>Structured Query Language (SQL)</td>
<td>A standard language used for analyzing information stored in relational databases. MapInfo Pro's database engine is based on the SQL standard.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------</td>
<td>---------------------------------------------------------------------------</td>
</tr>
<tr>
<td>subselect</td>
<td>A select statement that is placed inside the Where Condition field of the SQL Select dialog box. MapInfo Pro first evaluates the subselect and then uses the results of the subselect to evaluate the main SQL Select statement.</td>
</tr>
<tr>
<td>symbol, symbol object</td>
<td>A small, relatively simple shape (for example, square, circle, star, push-pin) used to graphically represent a point object (for example, a customer location).</td>
</tr>
<tr>
<td>Symbol button</td>
<td>The Symbol button allows you to access the Symbol tool. Use the Symbol tool to place point symbols (push pins) on your map.</td>
</tr>
<tr>
<td>Symbol Style button</td>
<td>Use the Symbol Style button to access the Symbol Style dialog box. The Symbol Style dialog box allows you to display symbols and specify attributes for symbols. The attributes you can specify are size, color, and symbol type. You can change the attributes of existing symbols and specify attributes for new point objects before you create them. The point objects must reside, or be created in an editable layer. See symbol, symbol object.</td>
</tr>
<tr>
<td>table</td>
<td>A table is made up of data in rows and columns. Each row contains information about a particular geographic feature, event, etc. Each column contains a particular kind of information about the items in the table. You can display tables with graphic information stored in them as maps. See base table and query table. See also layer.</td>
</tr>
<tr>
<td>table row</td>
<td>In a table, a row contains all the information for a single item. It corresponds to a record in a table.</td>
</tr>
<tr>
<td>target district</td>
<td>The district that is selected in a Districts Browser to be affected by subsequent redistricting operations.</td>
</tr>
<tr>
<td>Text button</td>
<td>Use the Text Button to add titles, labels, and annotations to maps and Layouts. You can also use the Text Tool to rotate text with its edit handle.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>text cursor</td>
<td>A blinking vertical bar that shows the position where text can be edited, inserted, or deleted.</td>
</tr>
<tr>
<td>Text Style button</td>
<td>Use the Text Style button to access the Text Style dialog box. The Text Style dialog box allows you to choose a font and font settings for your text.</td>
</tr>
<tr>
<td>thematic layer</td>
<td>A layer containing the thematic settings for a map layer. Thematic layers are drawn directly over the map layer on which the thematic settings are based. They are also drawn in a particular order, depending on the number of thematic layers you have and the type of thematic map objects you are creating.</td>
</tr>
<tr>
<td>thematic map</td>
<td>A type of map that uses a variety of graphic styles (for example, colors or fill patterns) to graphically display information about the map's underlying data. Thus, a thematic map of sales territories might show one region in deep red (to indicate the region has a large number of customers), while showing another region in very pale red (to indicate the region has relatively few customers).</td>
</tr>
<tr>
<td>thematic shading</td>
<td>Map objects - points, lines, regions - that have been shaded, using a pattern and/or color, according to some point of information about the object, or theme (population, size, annual rainfall, date, and so forth).</td>
</tr>
<tr>
<td>thematic variable</td>
<td>The data values displayed on a thematic map. A thematic variable can be a field or expression.</td>
</tr>
<tr>
<td>theme legend</td>
<td>MapInfo Pro's original style legend that allows you to display legends for thematic maps and graphs. MapInfo Pro automatically creates a theme Legend Designer window for a thematic map. Customize its display through the Modify Thematic Map dialog box. See What is a Legend?.</td>
</tr>
<tr>
<td>tile server</td>
<td>A tile server is an online server that contains a collection of raster tile images that cover a place on the earth. Tiles are organized in a row and/or column grid fashion. There are multiple levels of tiles, each level representing a different</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>resolution of data</td>
<td>resolution of data covering the same place on the earth. The level determines the number of tiles (number of rows and columns). Zooming in or out may change the level of data. Panning may change the number of tiles that are needed on the map.</td>
</tr>
<tr>
<td>toolbars</td>
<td>MapInfo Pro windows that contain a variety of buttons used to access tools and commands for mapping and drawing. There are four Toolbars: the Standard Toolbar provides tools for commonly performed tasks, the Main Toolbar provides primary tools (for example, Zoom-in, Select, Info, etc.) and the Drawing Toolbar contains all drawing tools. The Tools Toolbar contains the Run MapBasic Program and the Show/Hide MapBasic Window buttons. Toolbars may be reshaped and hidden.</td>
</tr>
<tr>
<td>transformation</td>
<td>The process of converting coverage coordinates from one coordinate system to another through programmatic translation. The transformation of CAD generated Cartesian coordinates into earth coordinates is an example.</td>
</tr>
<tr>
<td>ungeocode</td>
<td>The process of removing X and Y coordinates from records in a table or database. Can also describe a table that has not been geocoded, such as an ungeocoded table.</td>
</tr>
<tr>
<td>United States National Grid</td>
<td>The United States National Grid for Spatial Addressing (USNG) is a grid reference system that defines how to present Universal Transverse Mercator(UTM) coordinates at various levels of precision by specifying the use of those coordinates within the grid system defined by the Military Grid Reference System (MGRS). Additionally, it addresses specific presentation issues such as grid spacing. The UTM coordinate representation, the MGRS grid, and the specific grid presentation requirements together define the USNG.</td>
</tr>
<tr>
<td>vector image</td>
<td>A coordinate-based data structure commonly used to represent map features. Each object is represented as a list of sequential x,y coordinates. Attributes may be associated with the objects. A computer image can be represented in vector format or in raster format. See raster image.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>--------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>vertical scroll bar</td>
<td>The Vertical scroll bar appears at the right of the most windows. Use the vertical scroll bar to move up and down. The scroll box inside the scroll bar indicates your vertical location. You can use the mouse to scroll to other parts of the window.</td>
</tr>
<tr>
<td>Web Feature Services</td>
<td>A Web Feature Service (WFS) client retrieves geospatial GML (Geography Markup Language) data using HTTP GET and HTTP POST requests over the Internet or through a private intranet. The WFS client was developed in accordance with the 1.0.0 OpenGIS Web Feature Service Implementation Specification, which is available online: <a href="http://www.opengeospatial.org/standards/wfs">http://www.opengeospatial.org/standards/wfs</a>.</td>
</tr>
<tr>
<td>Web Map Services</td>
<td>A Web Map Service (WMS) is a technology that gives you a source for data over your Intranet or over the Internet. This innovation is based on a specification from the Open GIS Consortium (OGC) and allows you to use raster images from servers that also comply with the specification. An important element of this is that the WMS images are registered using the data's coordinate system so the WMS layer can be used with vector and other registered raster images. This specification supports transparent pixel definition for image formats as well. This allows you to use the images you retrieve as overlays and not solely as the bottom layer of your map. This is a very new technology and WMS may not exist for the geography you are looking for. Further, the WMS Server determines the data that is provided. See Retrieving Map Data from Web Map Services in the Help System.</td>
</tr>
<tr>
<td>web service</td>
<td>A web service is a software system that is accessible using an intranet or Internet connection. Web services allow you to retrieve data that others are sharing internally or world-wide. The power of web services is that you can use them to create more powerful maps or in the case of geocoding or drive region services get more accurate and precise results using the same data.</td>
</tr>
<tr>
<td>weighted average</td>
<td>An average that gives more weight to one value over another when averaging. A method of averaging that uses a separate</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>----------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| column of information to define the relative importance of each data value. The formula for a weighted average is: | \[
\text{SUM(} DATA \times \text{WEIGHT}) / \text{SUM(WEIGHT)}
\]
|                      | where DATA is the column of data values and WEIGHT is the column of weights. If WEIGHT contains all 1’s (or other non-zero values) this reduces to a simple average. |
| window               | In MapInfo Pro, Map windows, Browser windows, Graph windows and Layout windows are the major types of windows. They display the data stored in tables. The Toolbars, map legends, and the Info tool window are other types of windows. |
| workspace            | A saved configuration of open MapInfo tables and windows.                                                                                     |
| Zoom-In button       | The Zoom-in button allows you to access the Zoom-in tool. Use the Zoom-in Tool to get a closer area view of a map. See zoom layering.            |
| Zoom-Out button      | The Zoom-out button allows you to access the Zoom-out tool. Use the Zoom-out tool to get a wider area view of a map. See zoom layering.         |
| zoom layering        | A setting that determines the range (for example, 0-3 miles, 2-5 miles, etc.) at which a layer is visible in a Map window.                   |
Index

.*,pcx files 416
raster format 416

3D graphs 160, 172–175
choosing a 3D graph viewing angle 175
customizing cube walls 174
moving at an angle 174–175
panning 173
rotating 173
templates 160
using the 3D viewing angle 172–173
3DMaps 126, 616
defined 616
setting hardware acceleration defaults 126

A
Access tables 38, 428
creating .tab files from 428
opening 38
accessing secure Web sites 487
active objects 514
summary 514
Add Frames menu option 406
Add Horizontal Guidelines button 405
Add Node button 226, 616
Add Text Frame menu option 406
Add to Library 63
Table List menu option 63
Add Vertical Guidelines button 405
adding
images in Layout Designer 377
layers to Map windows 72
legend to Layout Designer 374
nodes 226
open windows to Layout window 394
records in browser windows 156
rows to tables 149
shapes in Layout Designer 380
temporary columns to tables 143
text in Layout Designer 378
adding (continued)
themetic in Layout Designer 375
address dictionary 616
address matching, setting preferences 122
address ranges 448
matching to street number 448
addresses 444
gocoding precision 444
adornment 370, 616
adding to map 370
defined 616
ADRG Format (*.gen) files 416
raster format 416
Affine Transformations 480–481
coordinate systems 480
description 481
aggregate functions 154
update column command 154
aggregating data 285–286, 341
SQL select command 285–286
with set target model 341
AirPhotoUSA Conterminous Coordinate System 37
AirPhotoUSA raster support 37
aliases 284, 616
defined 616
for columns 284
aligning 384–385
frames in Layout Designer 384
to grid lines in Layout Designer 385
to guidelines in Layout Designer 385
Aligning Layout Objects 381
Layout Objects 381
Arc button 616
Arc Grid handler 416
arc objects 212
reshaping 212
specifying object attributes 212
area 128, 160
calculation default settings 128
graphs 160
arrow keys, positioning selected objects 238
ASCII files 92
exporting to 92
ASCII tables 38, 435
opening 38
registering 435
ASCII, defined 616
ASRP Format (*.gen) files 416
raster format 416
Assign Selected Objects button 617
attributes 241, 305
graduated symbols 305
map object 241
attribute text 617
defined 617
authentication, tile servers 504
AutoCAD 91, 438
DXF export 91
opening in MapInfo Pro 438
Autolabeler tool 359
creating labels as text objects 359
automatic 360–361, 364, 366
labeling 360–361, 364, 366
autotrace 246
tracing existing objects 246
axis, defined 617
Azimuthal projections, range 475, 586

B
bar charts 303, 312, 617
defined 617
maps 303
template 312
bar graphs 160–161
base maps, defined 617
base tables, defined 617
BIL files, raster format 416
Bing Aerial tile server 504
adding layer to map 504
Bing Hybrid tile server 504
adding layer to map 504
Bing Roads tile server 504
adding layer to map 504
bitmap (*.bmp) files 91, 416, 617
defined 617
export format 91
raster format 416
boundaries 444, 449, 618
boundary region defined 618
geocoding 444, 449
Boundary Select button 258, 618
Bring to Front command 392
Browse menu, options 56
Browser 376–377
editing in a layout 377
opening in Layout Designer 376
Browser windows 54, 56, 60, 84, 149, 155–156, 618
adding records 156
Browse menu options 56
defined 618
displaying tables in 155
format 54
mouse wheel support 60, 149
opening a table 54
opening tables in 54
seamless tables 84
toolbar description 56
viewing graphic information 149
bubble graphs 161
buffer regions 332–338, 618
calculation types 336
concentric ring 337
convex hull 338
creating 332–334
defined 618
methods in creating 336
radius 335
saving as new layer 334–335
segments per circle 335
width distance 335

cadastral, defined 618
CADRG Format files 416
raster format 416
callout lines 365
Cancel command 618
cancelling selections 259
Cartesian calculations 128, 335
as default setting 128
buffer regions 335
Cartesian coordinates defined 618
cartographic scale, defined 619
cartography, defined 619
centroids 75, 244, 619
defined 619
centroids (continued)
displaying 75
selecting using snap mode 244
Change Grid Size slider 405
Change View button 619
CharSet clause 611
CIB format files 416
raster format 416
Clear All Sort & Filters menu option 56
Clear Filter menu option 58
Clear Filters menu option 56
Clear Sort menu option 56
clearing a target 344
clip region 126
preferences, setting defaults 126
closing tables 90
collection objects 349
grouping objects using 349
color 420–421
raster image options 420–421
column aliases 284
creating 284
column graphs 161
columns in a table 143, 149, 266, 284, 292, 347, 359, 614
adding temporary columns 143
combining objects with 347
creating expressions 266
deriving 284
finding duplicate values in 292
labeling with 359
MIF files 614
placing graphic information in 149
combining objects 342, 348–349
creating territories 348
multipoint and collection 349
overview 342
set target 342
comparison operators 527
concentric ring buffers 337
accessing tool 337
conflict resolution 212–214, 620
conic projections, about 474, 585
control points 417, 620
defined 620
raster image registration 417
converting 233
objects into polyline objects 233
convex hull 338
buffers 338
coordinate systems 469–471, 473–474, 478–481, 565, 568, 585, 620
coordinate systems (continued)
converting from one datum to another 473
creating 480
defined 620
elements of 481
entering a new projection for 479
origin point 474, 585
parameters of 469
projection types 565, 568
projections 469, 471
specifying the bounds in 470
using a new projection in 478
coordinates 128, 414, 417, 441, 463, 483, 503, 620
defined 620
determining map 414
displaying 463
geocoding 441
raster image control points 417
setting display defaults 128
specifying in non-earth maps 483
tile servers 503
copying 102
objects to clipboard 102
cosmetic layer 75
about 75
Create a Query from the Browser Contents menu option 56
Create Table statement 590
creating 150, 156, 269, 371, 590
a MapInfo_MapCatalog 590
a table, using subset of a file 269
layouts 371
reports 156
tables 150
creating expressions 266–267, 521, 526, 528, 531
constructing 521
numerical comparison 526
operator precedence 531
operators 528
using Expression dialog 266–267
using Select command 266
creating points 426, 453–455
displaying points a map 455
displaying points on a map 455
for intersections 454
placing longitude/latitude coordinates 453
vs. geocoding 426
creating territories 346, 349
combining objects 349
see also redistricting 346
cropping images 92
Crystal Reports 107, 156
creating reports 156
setting default open and save directories 107
CSV

- 431–432
- displaying 432
- opening comma delimited files 431
- custom symbols 235

D

data

- 25
- file import formats supported 25
- data aggregation 285–286, 620
- defined 620
- SQL Select command 285–286
- data disaggregation 621
- defined 621
- data map with MapInfo tables 513
- data sources 182, 621
- connecting to 182
- defined 621
- databases 33, 621
- defined 621
- defining terminology in 33
- date 527
- comparison 527
- DateTime feature 275–282
- adding data types to existing data 276
- converting to a new data type 277
- creating a _ column from two columns 278
- creating thematic maps using 279
- interpreting Access data 282
- interpreting dBase data 282
- interpreting Excel data 281
- understanding 275
- using arithmetic operators with 280
- using comparison operators with 281
- using logical operators with 281
- using the new data type for 275
- datum projection parameter 568, 583
- datums 473
- mapinfow.prj id numbers 473
- Dbase files 38, 432
- creating .tab files from 432
- opening 38
- DBMS 104, 180
- connections, specifying default 104
- dDrivers 180
- DBMS SQL queries 107
- setting default open and save directories 107
- DBMS tables 45, 180–182, 197, 204, 206, 209, 212–215, 459, 590
- conflict resolution 212–214

DBMS tables (continued)

- connecting to a data source 182
- creating 209
- disconnecting from database 215
- linked 204
- linked tables 206
- live remote access 204
- mapinfo_mapcatalog 590
- opening 45, 206
- per-row styles 215
- requirements 197, 204
- saving 213
- spatial index columns 181
- storing and retrieving spatial objects 180
- storing coordinate values 181
- symbol styles in mappable tables 215
- unlinking 459
- DBMS Toolbar 32
- decimal degrees 128, 621
- defined 621
- setting display coordinate defaults 128
- default, defined 621
- degrees latitude defined 621
- degrees longitude defined 621
- degrees/minutes/seconds 128
- setting default coordinate display 128
- Delete Selected Frames menu option 407
- deleting 153, 228, 383
- frames in Layout Designer 383
- nodes 228
- tables 153
- derived columns 272, 284, 622
- defined 622
- described 272
- using 284
- digitizer 622
- defined 622
- digitizing 420, 622
- raster images 420
- tablet 622
- directory preferences 97, 107
- defined 97
- specifying 107
- Disable Guidelines menu option 406
- disaggregating data 341, 621
- data disaggregation defined 621
- with set target model 341
- distance calculations 128, 335
- buffer regions 335
- setting default 128
- districts 342, 516
- grouping map objects into 516
districts (continued)
ordering and grid display 342
districts browser 518, 622
defined 622
using 518
DMS 621
documentation set 12
dot density maps 307–308, 313, 622
defined 622
description 307
template 313
thematic 308
drawing objects on a map 226, 229–230, 233, 235
custom symbols 235
styles 230
symbols 233
types of shapes 230
using ruler window 229
Drawing toolbar 30–31, 622
defined 622
region style button 31
drivetime web service 500
driving regions 119, 502
creating buffers for objects 502
routing server setup and preferences 119
drop shadow for object 400

E
Earth maps 483
ECW raster handler 416
(*.ecw) raster format 416
edit handles, defined 622
editing 76, 152, 165, 167–169, 367, 373, 375, 377, 477, 480
Browser in a layout 377
graphs 165, 167–169
labels 367
legend in a layout 375
map display in a layout 373
mapinfo.wprj file 477, 480
maps in a layout 373
read-only tables 76
table structure 152
attributes 241
autotracing 246
commands 226
creating territories by combining 347
deleting 237
multipoint and collection 349
object conversion 247
object offset 238
positioning and sizing 238
editing objects (continued)
procedure 237
reshaping 242–244
rotating 240–241
set target model 341
smoothing/unsMOOTHING POLylINES 247
snap mode 245
splittinG 346
embedded maps 513
sharing documents 513
embedding 512
OLE objects 512
EMF Files, generating for printing 407
Enable Guidelines menu option 406
encapsulated postscript (*.eps) files 410
Enhanced Metafile Format (*.emf) files 91, 407, 416
export format 91
for printing 407
generating 407
Envinsa, geocoding web service 496
equal count range type 301
equal range type 301
ESRI ArcInfo Export 438
opening in MapInfo Pro 438
ESRI ArcSDE 438
opening in MapInfo Pro 438
ESRI grid files 416
ESRI Personal Geodatabase 438
opening in MapInfo Pro 438
ESRI shapefiles 107, 433
opening 433
setting default open and save directories 107
Excel files 38, 427
creating tab files from 427
opening 38
exiting MapInfo Pro 26
exporting 389
layout 389
exporting files 88, 91, 139, 409, 423, 432, 623
export defined 623
GeoTIFF format 88
layouts 409
setting output preferences 139
supported file formats 91
supported formats 91
to comma delimited (csv format) 432
translucent images 423
expressions 266–267, 359, 520–521, 523, 528, 531, 623
character strings in 523
creating 266–267, 521
date values in 523
expressions (continued)
defined 623
entering specific values (constants) 523
labeling with 359
numbers in 523
operator precedence 531
operators 528
where you can use them 520

F
false easting parameter 475, 585
coordinate systems 475
false northing parameter 475, 585
coordinate systems 475
fields, defined 623
file formats 25, 35–36, 91, 416, 425
MapInfo Pro supported 35–36, 425
raster images 416
supported export 91
supported types 25
files 38, 623
defined 623
opening 38
fill patterns 230, 353, 623
defined 623
printing 230
region styles dialog 353
Filter menu option 58
find 261, 456
an object or street address 261
find selection in one window or all windows 456
fonts 623
defined 623
frames 384, 391, 398
aligning in Layout Designer 384
Layout window 391, 398

G
GEN files 416
raster format 416
generalization, defined 624
geocoded points 447, 451, 455
displaying on a map 451, 455
street inset and offset 447
geocoding 116, 426, 441–443, 445, 451, 453, 497, 624
a single address using a server 497
appropriate map detail 442
assigning coordinates to records 441
defined 624
geocoding (continued)
geographic accuracy 442
precision 445
process overview 443
result codes 497
selecting ungeocoded records 451
setting up a server 116
ungeocoding 453
vs. creating points 426
geocoding server 112, 116
adding a 116
preferences 112
setting up 116
geocoding, matching 445, 448–449
address numbers 448
finding exact street matches 445
street names 448
to regions 449
graphic 528
operators 528
Geographic Information System, defined 624
GeoRegistered PDF 624
defined 624
GeoTIFF 88
export requirements 88
exporting 88
Get Info command 241
GIF files 416, 489
raster format 416
web map service, format 489
GML files, importing 436
GML2 data 492
web feature service client 492
graduated symbol maps 305, 313, 624
customizing 305
defined 624
description 305
template 313
Graph Select tool 176
Graph windows 178, 624
defined 624
saving as a template file 178
graph, support files and setting default directories 107
graphs 163–170, 172–178
axis attributes 167
creating 163–164
editing 165, 167–170
exploding a pie 170
general options 166
saving 177
selections 176
specifying titles 168
graphs (continued)
support file location 178
using 3D graphs 172–175
using series 169
using templates 177–178
graticule, defined 624
grid 313
template 313
Grid Converter 81
specifying inflection values 81
grid image files 107, 137, 328
setting default display 137
setting default open and save directories 107
using 328
grid layers 47, 80, 126
opening 47
setting zoom layering defaults 126
using layer control with 80
grid surface maps 81, 126, 327, 329, 624
adjusting translucency 81
defined 624
specifying default handlers 126
uses 327
vertical mapper grid handler 329
grouping by columns 274
creating subtotals 274
guidelines 386
removing in a layout 386
show or hide in Layout Designer 386

H
heads-up digitizing, defined 625
Help 625
button bar, defined 625
help system 16
using 16
Hide/Show Toolbar menu option 56
highlighting objects 120
histogram graphs 161
hot views, defined 625
Hotline Oblique Mercator projection 475, 585
Oblique Azimuth 585

I
Image Processing preferences, defined 97
images 377
adding to Layout Designer 377
importing files 25, 107, 146, 426, 441, 625
importing files (continued)
graphic files 441
import defined 625
parsing data across multiple columns 146
setting default open and save directories 107
types supported 25
web map service data 426
index files 38
individual values maps 309, 313, 320, 625
defined 625
saving categories in templates 320
template 313
thematic 309
inflection 81
values, specifying with Grid Converter 81
Info tool 60, 77, 84
changing a record's data, font, and style 60
seamless layers 84
using 77
interactive 367
labeling 367
interleaved line styles 230, 354
editing 230
styles 354
inverting selections 259, 289
IsoChrone, defined 626
IsoDistance, defined 626

J
joining tables 287–289, 291, 297, 626
geographically using geographic operators 289
join, defined 626
order of clauses 288
through thematic mapping 297
two or more tables 291
using SQL select 287
joins 144
geographic and descriptive 144
JPEG 2000 format (*.jp2) files 91, 416
export format 91
raster format 416
JPEG file interchange format (*.jpg) 91, 489
export format 91
web map service, format 489

L
label style 75, 358, 360, 364, 366
controlling display 364
customized 360
design 358
label style (continued)
size 75
styles 366
labels 74, 357, 359–361, 364–369
automatic 360–361, 364, 366
callout lines 365
content 359
editing 367
interactive 367
label tool button 368
map 357
position 74
saving 360, 369
using column information 359
using text objects 368
with expressions 359
Lambert Azimuthal Projection Map example 468
latitude, defined 626
Layer Control 66, 72–73, 78–80, 84
about 66
adding a layer to a map 72
ordering thematic layers 79
raster and grid layers 80
selectable layers 78
selecting objects in a layer 78
thematic layers 78
zoom layering 73
layers 15, 48, 72, 75, 77–78, 82–85, 298–299, 320, 335, 403, 504
adding a tile server to map 504
adding Bing Aerial/Hybrid tile to map 504
adding to a map 72
characteristics of seamless 84
creating buffer 335
defined 48
displaying layer of current selection 15
displaying object attributes 75
making layers selectable 78
objects in 48
opening seamless 83
reordering using layer control 72
saving thematic map 320
seamless 82, 84
search paths for seamless map tables 85
selecting for map legends 403
selecting objects in 78
thematic 298–299
with Info tool 77
working with thematic 78
layout 254, 383, 387–388
bringing objects to the front 383
moving 383
paper margins 388
paper orientation 388
paper size 388
print OSBM 388
selecting an object from 254
layout (continued)
sending objects to the back 383
setting margins when printing 387
subdivide printing 388
Layout Designer 372, 374–378, 380, 382, 384–386
adding images in 377
adding shapes in 380
adding text 378
aligning frames in 384
aligning to grid lines 385
aligning to guidelines 385
opening legend in 374
opening maps in 372
opening tables in 376
opening thematic maps in 375
saving 382
show or hide guidelines 386
Layout window 58, 318, 407, 409, 415, 459, 627
adding a logo to 415
browser display in 58
changing a map’s border and proportions in 318
defined 627
exporting 409
printing 407
text size in 459
Legend display in 374
preferences defined 97
preferences for 131
layout, classic window 61, 390–394, 398–400
adding a maximized window to 391
aligning objects in 391, 399
creating 394
creating drop shadows for 400
creating multiple map views 393
map scale 400
opening maps in 61
ordering overlapping objects 392
page layout 390
using legends 398
with labels 394
zoom level 392
changing text alignment 379
changing text frame orientation 380
changing text spacing 379
ingoing Browser 377
editing legend 375
ingoing map display 373
ingoing maps 373
exporting 389
legend display in 374
printing 387
refreshing legend 375
removing guidelines 386
text style 379
legend 374
legend (continued)
opening in Layout Designer 374
Legend Designer
  383, 404
move frames 383
toolbar 404
window, about 404
Legend Designer window 384
resize frames 384
legend frames 627
defined 627
Legend Window button 627
Legend window preferences 97, 132
defined 97
setting default 132
Legend windows 221, 398, 627
creating for live tables 221
defined 627
using in layouts 398
legend, definition 402
legends 283, 316, 375
deleting a frame from 283
editing in a layout 375
refresh in a layout 375
thematic maps 316
library services 114
preferences 114
line direction 75
line graphs 161
line objects 627
line styles 226, 230, 353–354
change styles tool button 226
editing 353
interleaved 230
linked tables 204, 206, 212, 628
conflict resolution 212
defined 628
resolving editing conflicts when saving 212
using 206
live access tables 204
logical 267
operators 267
logical operators 529
logos, adding to a layout 415
longitude, defined 628
longitude/latitude coordinates 453, 628
creating points on a map 453
longitude/latitude, defined 628
Longitude/Latitude Projection, map example 465
Lotus 1-2-3 tables 433
creating .tab files from 433
M
Main toolbar 28, 628
defined 628
map layers 48–49, 72, 75, 77–78, 83–85
adding 72
characteristics of seamless 84
displaying object attributes 75
making layers selectable 78
objects in 48
opening seamless 83
reordering using layer control 72
search paths for seamless tables 85
selecting objects in 78
using Layer Control 49
with Info tool 77
working with thematic 78
map legends 398, 402–403
choosing layers 403
creating 403
definition 402
in Layout window 398
map scale 15, 400, 629
defined 629
definition 629
displaying in status bar 15
in Layout windows 400
map segment, defined 629
Map window preferences 97, 125–126
defined 97
setting default 125–126
Map windows 52–53, 458, 629
defined 629
navigating in 53
opening tables in 52
printing 458
MapBasic language, defined 628
MapBasic programs 107, 535
running using a startup workspace 535
setting default open and save directories 107
MapBasic window 533–534
accessing 533–534
MapCatalog 193, 197, 202, 204, 215, 220, 589
creating 197
manually creating 589
Oracle data source setup 220
per row object styles 202
table per row styles, structure of 215
tables with Z and M values 193
updating data bounds 204
MapInfo Interchange Format (*.mif) files 597, 611–614
charset clause, summary 611
MapInfo Interchange Format (*.mif) files (continued)
columns 614
CoordSys clause 612–613
header version information 597
transform clause 613
MapInfo Map
511–512
commands 512
limitations 512
system requirements 511
MapInfo Map objects
513
sharing 513
MapInfo places, Open dialog box 45
MapInfo Pro
10–12, 17, 19–20, 25–26, 35–37, 51, 462–463
documentation set 12
exiting 26
features 11
new features and enhancements 19
new features and enhancements 20
purpose 10
starting 25
supported file formats 35–36
technical support 17
understanding the files associated with 37
window types 51
working with coordinate systems 463
working with coordinate systems/projections 462
MapInfo tables
150, 152, 513
creating 150
editing structure 152
with data map 513
MapInfo_MapCatalog
204, 220, 590–591
creating 590
Oracle data sources 220
spatial index types 591
updating data bounds 204
mapinfow.prj file
datum id numbers 473
datum ID numbers 568, 583
editing 477, 480
projection ID numbers 565, 567
unit ID numbers 474, 583–584
MapMarker geocoding web service 496
maps
adornment 370
determining coordinates 414
earth and non-earth 483
editing display in a layout 373
editing in a layout 373
how a legend displays in 375
inverting a selection 289
making labels call-outs 263
moving 383
opening in Layout Designer 372
opening in Layout windows 61
maps (continued)
printing 458
refresh legend display 375
saving a clipped region 177
selecting an object from 254
specifying coordinates for non-earth 483
specifying projection of 483
specifying units of measure 81
text size in 459
thematic types 300
Marquee Select tool button 257
Mastermap Topography Layer 440
measure new frame location 383
menu 537
shortcuts 537
menu shortcuts 538–541, 543
meridian, defined 629
message URL http 429
//fdo.osgeo.org 429
//www.sqlite.org 429
messages 127
controlling display of warnings 127
metadata 206
linked tables 206
Microsoft Access tables 38, 189
data sources 189
opening 38
Microsoft Bing Aerial tile server 504
Microsoft Bing Hybrid tile server 504
Microsoft Bing Roads tile server 504
Microsoft Data Map 513
with MapInfo tables 513
Microstation Design 438
opening in MapInfo Pro 438
Military Grid Reference System 128, 629
defined 629
setting default 128
minimum bounding rectangle 630
MBR, defined 630
Modify Thematic Map button 405
modifying 167, 318, 420
graph axis attributes 167
raster image control points 420
thematic maps 318
move frame to back 383
move frame to front 383
move frame using measurements 383
moving 165, 383
a map or a layout 383
graph objects 165
MrSID Raster Handler
   416
raster format 416
multi-touch support 94
Pan 94
Pan a 3D or Prism map 94
Zoom In 94
Zoom Out 94
multipoint objects 349
grouping objects using 349

N
native projections, defined 630
natural break, range type 302
new features and enhancements 19–20
New Row button 56
NITF Format (*.ntf) files 416
raster format 416
nodes 75, 127, 226–228, 243–245, 630
add node tool button 226
defined 630
deleting 228
displaying 75
duplicate 127
maximum number of 243
moving duplicate 245
reshape mode 243
selecting multiple 243
selecting using snap mode 244
using Overlay Nodes command 227
non-earth maps 483, 630
defined 630
specifying coordinates of 483
using 483
NTF files raster format 416

O
object linking and embedding (OLE) 511
registering objects with containers 511
objects 78, 80, 120, 228, 230, 232–233, 254–255, 258, 261–262, 340, 342, 344, 346
adding objects to search within polygon 258
clear target 344
converting to polyline objects 233
converting to region objects 80
deselecting 255
drawing 230
finding 261
finding selected 262
highlighting 120
object size 340
overview of combining 342
proportioning associated data after split 346
objects (continued)
selecting from a layout or map 254
selecting with tool buttons 255
selecting, using selectable layers 78
setting default style for 120
specifying geographic attributes 228
splitting polyline at node 232
attributes 241
autotrace 246
combining with set target 342
creating territories by combining 347
deleting 237
multipoint and collection 349
object conversion 247
object offset 238
positioning and sizing 238
procedure 237
reshaping 242–244
rotating 238, 240–241
set target model 341
smoothing/unsmoothing polylines 247
snap mode 245
splitting 346
styles 230
Oblique Azimuth projection parameter 475, 585
cordinate systems 475
ODBC connections 182
data sources 182
ODBC data types 193
ODBC drivers 630
defined 630
ODBC tables 630
defined 630
offsetting map objects 238
OGC 488, 492
GML2 data 492
web map service 488
opening 35–36, 38, 42, 45, 47, 52, 54, 61, 90, 157, 372, 376, 417, 433, 441
an existing report 157
ASCII files (.txt) 38
data files 38
dbase (.dbf) files 38
ESRI shapefiles 433
Excel (.xls, .xlsx) files 38
file formats supported 35–36
grid layers 47
MapInfo Pro grid files 441
maps in Layout Designer 372
maps in Layout windows 61
raster images 417
remote tables 45
tables 42
tables in Browser windows 54
opening (continued)
tables in Layout Designer 376
tables in Map windows 52
versus importing 90
operators 
267, 525, 527–529, 531
comparison 527
expressions 267
geographic 528
logical 529
operator precedence 531
string 525
string comparison 527
Options menu option, Browse menu 56
Oracle 
194–195, 221–222
converting unsupported geometries 222
data types 194–195
object map verification to support validation 221
Oracle Spatial 
219–220
tables 219
origin projection parameter 585
outer joins 631
defined 631
Output Settings preferences 
97, 137–138
defined 97
specifying 137–138
overview of combining map objects 342

P
packing a table 153, 360, 631
page layout 390
Layout windows 390
page setup 407, 458
Layout windows 407
preparing to print 458
paper size 388
layout 388
parameters, projections 476
per-row styles 215
Photoshop 3.0 (*.psd) files 91, 416
export format 91
raster format 416
Pick Fields button 56
Pick Fields menu option 56
pie chart maps 304, 312
template 312
pie charts 162, 170
exploding 170
graph type 162
pin map, defined 631
pixel 631
defined 631
PNG files 416
raster format 416
point objects 631
defined 631
point size, defined 632
pointer, defined 632
points 451, 453–454
creating for intersections 454
creating from coordinates 453
dispersing 454
displaying geocoded 451
Polyconic projection 
467, 475–476, 586
map example 467
polygon objects 230–231, 349, 632
creating Voronoi 349
defined 632
drawing 230
drawing orthogonal 231
tracing 231
polygon overlay, defined 632
Polygon Select tool button 258
polyline objects 230–232, 243, 247, 346, 632
converting regions to 247
converting to regions 232
defined 632
drawing 230
node limits 243
smoothing and unsmoothing 247
splitting at node 232
splitting map objects using 346
tracing 231
population density 273
computing with SQL select 273
Portable Network Graphics Format (*.png) files 91, 416
export format 91
preferences 
97–99, 104, 107, 109, 120, 122, 125–126, 131–132, 
134, 137–138, 178, 283
Address Matching 97, 122
detting default Legend Window 132
directories 283
directory, defined 97
graph support files location 178
Layout window 131
Legend Window 97
Map Window 97
Output Settings 97, 137–138
Printer 97, 134
setting 98
setting default directory search options 107
setting Directory 107
preferences (continued)
setting Legend Window 132
setting Map Window 125–126
setting Startup 104
setting System 99
setting Web Services 109
Startup 97, 104
Style 97, 120
System Settings 97
Web Services 97
print OSBM 388
layouts 388
Printer preferences 51, 97, 134
defined 97
specifying 134
storing information in workspaces 51
printing 138, 230, 387, 407, 423, 458–460
fill patterns 230
layout 387
Layout windows 407
map windows 458
page setup 458
setting defaults 138
text 459
translucent images 423
troubleshooting 460
prism maps 459
viewing a previous prism map 459
projections 422, 470, 473–474, 476–477, 558, 565, 567–568,
570, 572, 574, 576–577, 579, 581, 583, 585–587, 632
additional resources 587
creating mapinfow.prj file 477
datums 473, 568, 583
defined 632
examples of mapinfow.prj entries 476
mapinfow.prj ID numbers 565, 567
origin point 474, 585
parameters 558, 565, 567, 570, 572, 574, 576–577, 579, 581,
583, 585–586
raster images 422
resources 470
units 474
Properties menu option, legends 406
Proportion Weighted Average function 155
Update Column command 155
proxy server 116
PSD files 416
raster format 416
psubdivide printing 388
layouts 388
push-pin map, defined 631

Q
quantile range type 302
queries 104, 259–260, 262–264, 268, 274, 283, 523
collecting and deriving data 259
creating using SQL Select command 264
displaying results in Map window 262
entering specific values 523
saving as query tables 274
saving in workspaces 274
saving in workspaces startup preference 104
Select command 260, 268
using templates 283
using the Select command 263
query tables 107, 274, 633
defined 633
saving 274
setting default open and save directories 107
query templates 283
Quick Start dialog box 104
displaying on startup 104

R
Radius Select tool button 256
radius, calculating buffer 335
range parameter 475
coordinate systems 475
range projection parameter 586
ranged maps 300–301, 312
defined 300
template 312
types 301
raster format 409, 416
Arc Grid format 416
ECW format handler 416
emf files, (*.emf) 416
save window as to support more formats 409
adjusting the contrast or brightness of 422
adjusting translucency 422
color options 420–421
data limitations in 422
defined 633
displaying multiple images 420
modifying control points 420
opening 417
placing a logo on a page layout 415
projection limitations 422
registering 414, 417
setting default display 137
setting default ROP display method 138
setting zoom layering defaults 126
style override 421
support for 36
Supported file formats continued

- Transferring vector coordinates to translucent images
- What are translucent images?
- What is registering?
- Zoom layering
- Read-only tables
- Making editable
- Reapply button, Browser window
- Reapply Sort & Filter menu option
- Record, defined
- Redistricting
- ASCII data
- OLE objects with containers
- Registering a raster image
- Control point coordinates
- Modifying control points
- Registration, defined
- Remote database tables
- Conflict resolution
- Disconnecting from database
- Linked tables
- MapInfo_mapcatalog
- Opening
- Per-row styles
- Requirements
- Saving
- Setting default open and save directories
- Storing and retrieving spatial objects
- Storing coordinate values
- Symbol styles in mappable tables

Remove All Guidelines menu option, legends
- Renaming
- Tables
- Reports
- Creating
- Opening
- Opening an existing
- Reshape mode
- Moving duplicate nodes
- Reshape tool button
- Reshaping map objects
- Resize layout frames
- Resizing
- Graph objects
- Result codes
- Geocoding
- Understanding
- ROP display method
- Printing/exporting transparent images
- Rotating
- 3D graphs
- Map objects
- Objects
- Rows
- Adding to tables
- Appending to a table
- Ruler window
- With drawing tools

S
- S key
- Saving
- A clipped region of a map
- A graph
- A graph window as a template file
- Copies of tables
- DBMS tables
- Graph templates
- Graphs
- Labels
- Layout
- MapInfo workspaces
- Printer information to a workspace
- Queries
- Queries in workspaces, preference
- Query templates
- Thematic map layers
- Thematic templates
- Workspace as an XML-based file
- Workspace with a layout
scale  
about map scale 370  
cartographic scale 370  
displaying in status bar 15  
layout windows 400  
scale bar 370, 635  
adding to map 370  
defined 635  
scale factor 475  
parameter, coordinate systems 475  
Transverse Mercator 475  
scale factor parameter 585  
scanning, defined 635  
scatter graphs 162  
scroll bars 126, 635  
defined 635  
setting default display 126  
seamless map layers 81–85  
available features 84  
info tool 84  
opening 83  
specifying search paths for components 85  
turning on and off 82  
using 84  
searching 258  
adding objects to a selection set 258  
Select All menu option, Browser menu 56  
Select tool button 255  
aggregating data 285  
calculating distance to a fixed point 293  
expressions 266–267  
finding duplicate values in a column 292  
joining tables 287–288  
query templates 283  
saving queries 274  
Select command 268  
SQL Select command 253, 270  
SQL Select examples 273  
ungeocoded records 451  
where condition 289  
selecting from the screen 156, 165, 243, 253–255  
a single object from a map or layout 254  
graph objects 165  
in browser windows 156  
making layers selectable 253  
multiple nodes 243  
selectable layers 253  
tool buttons 255  
Selection menu button 56  
selection tools 84  
seamless layers 84  

selections 120, 176, 251, 259  
cancelling 259  
defined 251  
in graphed tables 176  
inverting 259  
specifying map highlighting 120  
Send to Back command 392  
server authentication 487  
web services 487  
servers 493–494  
web feature service 493–494  
setting 387  
margins for a layout when printing 387  
shapefiles 107, 433  
opening 433  
setting default open and save directories 107  
shapes 380  
adding in Layout Designer 380  
shortcuts 537–541, 543  
SID files 416  
raster format 416  
smoothing polylines 247  
snap 244  
selecting nodes and centroids 244  
Snap 405  
snap and thin settings 244  
saved in metadata 244  
snap radius 245  
display preference 245  
Snap to Closest Bottom Guideline button 406  
Snap to Closest Left Guideline button 405  
Snap to Closest Right Guideline button 405  
Snap to Closest Top Guideline button 405  
snap to nodes 244, 636  
defined 636  
snap tolerance 127, 245  
map window preference 245  
setting preference for 127  
Sort A to Z menu option 58  
Sort Largest to Smallest menu option 58  
Sort Multi-Column menu option 56  
Sort Smallest to Largest menu option 58  
Sort Z to A menu option 58  
Sort/Filter menu button 56  
spatial analysis, defined 636  
spatial index types 591  
specifying 81, 470, 483  
a map projection 483  
bounds of coordinate systems 470
specifying (continued)
coordinates for a non-earth map 483
inflection values with the grid converter 81
transparent fill patterns for regions 81
units in a Map window 81
spherical calculations
128, 335
as default setting 128
buffer regions 335
spherical coordinates, defined 636
splitting objects 346
SPOT image files 416
raster format 416
SQL queries
636
defined 636
SQL Select command
264, 270, 273, 287–289, 292–293
calculating distance to a fixed point 293
finding duplicate values in a column 292
formulating queries 264
joining tables 287–288
population density 273
selecting by querying 270
where condition 289
SQL Server
216, 222
converting unsupported geometries 216, 222
SSL protocol 487
stacked styles
637
defined 637
standard deviation
302, 637
defined 637
ranged thematic maps 302
standard parallels parameter
474, 585
coordinate systems 474
Standard toolbar 27
starting MapInfo Pro 25
startup preferences
97, 104
defined 97
specifying default 104
Statistics button, defined 637
Statistics window, defined 637
status bar
15, 637
defined 637
using 15
street
444–445, 447–448
finding exact matches 445
gEOCODING prestige 444
inset, placing geocoded points 447
names, geocoding matches 448
numbers, matching to address range 448
street address, finding 261
string comparison operators 527
string operators 525
Structured Query Language (SQL), defined 637
style preferences
97, 120
defined 97
specifying 120
styles
changing symbol 234
custom symbols 235
districts 519
drawn objects 230
interleaved line 230
labels 366
line 353–354
overriding for raster and grid images 421
region 352
symbol 354–355
text 356
using per row 215
subselect, defined 638
support
17
technical support 17
supported file formats
416, 425
opening files in MapInfo Pro 425
raster images 416
surface graphs 162
Symbol button, defined 638
Symbol Style button, defined 638
symbol styles
215, 227, 234, 354–355
changing 234, 354
mappable DBMS tables 215
style change tool button 227
symbols
233–235, 638
custom 235
defined 638
drawing 233
supported fonts 234
system requirements
220, 511
MapInfo Map application 511
Oracle Spatial 220
system settings preferences
97, 99–100
defined 97
setting 99–100

T

Table List
62–63, 65–66
button descriptions 63
docking 65
drag and drop 65
menu options 63
searching 66
selecting records 65
sorting 65
working with 62
table row
   638
defined 638
tables
   37, 50, 63, 90, 146, 150, 152, 209, 269, 289, 293, 326, 334, 376–377, 452, 456, 459, 638
adding new temporary columns 326
appending one table to another 146
associated files 37
closing 90
creating 150
creating a new DBMS 209
creating using Combine Objects Using Column command 152
creating, using subset of a file 269
defined 638
editing in a layout 377
inverting a selection 289
opening in Layout Designer 376
renaming 50
structure 63
table list window 456
ungeocoding 452
unlinking a dbms table 459
variables 334
tables, managing
   38, 43, 76, 144, 153, 155, 263, 265
browsing 155
deleting 153
exporting 623
importing 625
indices 38
making read-only tables editable 76
packing 153
renaming 153
setting preferred view 43
updating 144
tables, modifying
   143, 145–146, 149, 152, 154, 287, 297
adding rows 149
adding temporary columns 143
appending rows to 145
collecting data using update column 154
editing structure 152
joining 287, 297
parsing data to multiple columns 146
tables, opening
   42–43, 54, 107
in browser windows 54
in workspaces 107
procedure for 42
setting default directories 107
setting preferred view options 43
tables, remote database
   45, 180–181, 190, 197, 204, 206, 212–215, 590
conflict resolution 212–214
disconnecting from database 215
linked tables 206
live access 190, 204
mapinfo_mapcatalog 590
opening 45, 206
per-row styles 215
requirements 197, 204
tables, remote database (continued)
saving 213
storing and retrieving spatial objects 180
storing coordinate values 181
symbol styles in mappable tables 215
tables, saving
   107
setting default directories 107
Tagged Image file format (*.tif) files
   91, 416
export format 91
Targa (*.tga) files 416
raster format 416
target district
   638
defined 638
technical support
   17
obtaining 17
offerings 17
templates
   177–178, 283, 318, 320
deleting 283
graph 177–178
renaming 283
samples 318
saving thematic 320
temporary tables. See selecting by querying, selections 252
territories, creating by combining objects 349
text
   378–379, 459
adding in Layout Designer 378
aligning in a layout 379
spacing in a layout 379
style in a layout 379
viewing and printing 459
text cursor deinition 639
text frame
   380
orientation in a layout 380
text objects
   236, 368
using text in maps 236
with labels 368
Text Style button 639
Text Style button, Browser window 56
Text Style menu option, Browser menu 56
text styles 227, 356
Text tool
   523
entering text using 523
TGA files, raster format 416
thematic layers
   76–79
setting order using layer control 79
using with layer control 78
thematic maps
as layers 317
defined 639
thematic maps (continued)
expressions with 296
grid surface 327
joining tables in 297
layers 298–299, 639
modifying 318
multi-variable 314
obtaining data 297
one-variable 314
opening in Layout Designer 375
saving 320
shading 639
step 1 choosing a template type 312
step 2 choosing thematic values 313
step 3 customizing 315
thematic mapping defined 296
types of 300
using Update Column command 321
variables 314
theme legends defined 398, 639
in Layout window 398
theme templates 107, 320
saving 320
setting default open and save directories 107
thin, settings saved in metadata 244
TIF files 416
raster format 416
TIFF files 91, 489
(CMYK files) export format 91
web map service, format 489
Tile Server, defined 639
tile servers 503–504
about 503
authentication 504
Time feature 275–282
adding data types to existing data 276
converting to a new data type 277
creating a datetime column from two separate columns 278
creating thematic maps using 279
interpreting Access data 282
interpreting dBase data 282
interpreting Excel data 281
understanding 275
using arithmetic operators with 280
using comparison operators with 281
using logical operators with 281
using the new data type for 275
Toggle Grid Lines button 405
Toggle Snap to Grid 405
Toggle Sort & Filter Off/On menu option 56
Tool Manager 93
listing of tools 93
toolbars (continued)
Browser window 56
DBMS toolbar, buttons on 32
drawing toolbar buttons 30
hide/display 26
Legend Designer 404
main toolbar buttons 28
overview 27
reshaping 26
standard toolbar buttons 27
web services 486
tools 232, 523
split polyline at node 232
text 523
Topography layer 440
tracing polylines and polygons 231
transformation, defined 640
translucent images 423
printing and exporting 423
transparent fill patterns 81
setting for regions 81
transparent images 423
rop display method 423
Transverse Mercator projection 466, 475, 585
example 466
scale factor 475, 585

U
ungeocoding 452, 640
tables 452
ungecode, defined 640
United States National Grid 640
defined 640
units 474, 583
mapinfow.prj ID numbers 474
projection parameter 583
units projection parameter 584
universal data 438, 440
opening 438
working with FME Suite 440
Universal Translator utility 25
file types supported 25
Unselect All menu option 56
Unselect All tool 255
unsmoothing polylines 247
Update Column command 143–144, 146, 149, 154–155, 297
adding temporary columns 143
parsing data to multiple columns 146
placing graphic information in columns 149
updating tables 144
Update Column command (continued)
using aggregate functions 154
using proportion weighted average 155
with thematic mapping 297
US National Grid Reference, setting default 128
US_ZIPS.TAB, geocoding to postal code centroids 445
USGS Spatial Data Transfer Standard 438
opening in MapInfo Pro 438
USNG, defined 640
UTM projection map example 469

V
Value Axis options 159
using 159
vector image, defined 640
vector maps 419
transferring coordinates to raster 419
Vertical Mapper Grid Handler 329
View/Edit Metadata 63
Table List 63
voronoi polygons 349
VPF NIMA/NGA Data 438
opening in MapInfo Pro 438

W
warning messages, controlling display of 127
web feature service 109, 487, 492–494, 641
defined 641
retrieving coordinate data 492
server authentication 487
server requirements 493–494
setting preferences 109
web map service 109, 426, 487–491, 641
defined 641
error messages 490–491
importing files 426
layers, default projection 489
obtaining raster map images from servers 488
server authentication 487
setting preferences 109
supported image formats 489
web services 97, 109, 116, 486, 496
accessing 486
geocoding 496
web services (continued)
preferences 97
proxy server 116
setting access to timeouts and proxy server 109
types 486
weighted average 641
defined 641
where condition 288
wildcard 267
characters 267
window, defined 642
Windows Bitmap (*.bmp) files, raster format 416
Windows Metafile format (*.wmf) files 91, 416
export format 91
raster format 416
workspaces 50–51, 107, 320, 642
default open and save directories 107
default search paths 107
defined 642
opening 50
thematic maps 320
using 51
with renamed tables 50
workspaces, saving 51, 88, 104, 107, 274–275, 382
as .mws file (xml-based) 88
as xml-based file 88
default open and save directories 107
layout in Layout Designer 382
printer information 104
printer information in 51
queries 104
queries to 274–275

Z
Zoom Designer Area 405
zoom layering 73, 126, 421, 642
defined 642
raster layers 421
setting raster and grid layer defaults 126
specifying in layer control 73
zoom level 15, 392
displaying in status bar 15
Layout windows 392
Zsoft Paintbrush (*.pcx) files 416
raster format 416