"Ink Low" message displays after you replace your ink cartridge on the DM50-DM60
Troubleshoot issues with your newly installed ink cartridge to resolve the "Ink Low" message.
Products affected: DM50™, DM55™, DM60™ (K721, K722)
Issue
The "Ink Low" message displays after you install a new ink cartridge.
Cause
The newly installed ink cartridge is:
- low on ink
- damaged or old
Resolution
Troubleshoot issues with your newly installed ink cartridge to resolve the "Ink Low" message.
To order a genuine Pitney Bowes replacement ink cartridge visit the Pitney Bowes UK Online Shop page.
- Ensure that the newly installed ink cartridge is brand new.
- Ensure that all of the plastic wrapping has been removed from the ink cartridge.
- Ensure the cartridge has been purchased within the last two years, as the ink inside the cartridge can dry up over time.
To order a genuine Pitney Bowes replacement ink cartridge visit the Pitney Bowes UK Online Shop page.
UPDATED: 14 August 2021