"Select a Carrier" message on the DM50-DM60

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Products affected: DM50™, DM55™ (K721), DM60™ (K722)

Issue

When attempting to select a class, the message Select a Carrier appears.

Cause

The “Select a Carrier” message indicates a class needs to be selected before franking.

Resolution

  1. Royal Mail appears on the screen. Press Enter/Yes.
  2. 1st Class appears. Press Enter/Yes if you want to send your post by First Class. Press Review Down to select a different class.
  3. Depending on your class selection, the size of the mailpiece appears. Press Enter/Yes. Press Review Down to select a different size. 
  4. You are returned to the Home screen. Feed the envelope or tape sheet into the franking machine to print the frank.
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UPDATED: November 02, 2020