System Fault 'FLASH NEEDS INIT' on DM Series franking machines

Learn how to resolve System Fault 'FLASH NEEDS INIT' on these franking machines: DM50/DM55 (K721), DM60 (K722), DM100i/DM150i/DM200i (P720) DM110i/DM160i/DM220i (PR20) DM300c, DM400c, DM475 (G920, G925) DM300M, DM400M, DM475M (G922)
Products affected: DM50™, DM55™ (K721), DM60™ (K722), DM110i™, DM160i™, DM220i™ (PR20), DM300c™, DM400c™, DM475™ (G920), DM300M™, DM400M™, DM475M™ (G922)

Issue

The franking machine displays the System Fault 'FLASH NEEDS INIT'.

Cause

This issue is due to a software fault.

Resolution

  1. Turn the franking machine off by removing the power lead from the rear of the franking machine.
  2. Wait 30 seconds.
  3. Replace the power lead and wait for it to initialise.

 

If you need further assistance, please use the Contact Us options below.

UPDATED: 14 August 2021

Contact Us
Create a case
Submit support requests (Sign in required)
Get More Help
View support topics or reach us through other options.