No power or a blank screen on the DM100i-DM200i and DM110i-DM220i
Learn how to resolve no power or a blank screen on the DM100i / DM150i / DM200i (P720, P725) and DM110i / DM160i / DM220i (PR20).
Products affected: DM100™, DM150™, DM200™ (P720); DM110i™, DM160i™, DM220i™ (PR20)
Issue
The display screen is blank or black.
Cause
The franking machine is in sleep mode, is not receiving power, or the contrast is too low.
Resolution
Check the power LED light:
- If the LED is amber, the franking machine is in sleep mode:
- Press any button to wake the franking machine.
- If the LED is off, the franking machine is either turned off or does not have power:
- If there is a power switch on the back of the machine, check that it is set to the ON position ( | ).
- Check that the power cable is plugged into the back of the franking machine and into a functioning electrical outlet.

- If the LED is green, and/or the machine makes noises like it is booting up when first plugged in, it may be a display issue where the contrast needs altering.
- Unplug the franking machine for 10 seconds.
- Hold down the number 4 button while plugging the franking machine back in. This will reset the contrast to the default setting.

UPDATED: 04 April 2022