Black or blank touchscreen on the SendPro 300
Learn how to resolve a black or blank touchscreen on the SendPro 300.
Products affected: SendPro® 300
Issue
The touchscreen appears black or blank.
Cause
The touchscreen has no power.
Resolution
- Verify that the power switch on the back of the meter is in the "on" position (the 'I' side should be pushed in).
- Press the power button on the front of the meter.
- Remove the large power cord.
- Plug the large power cord back in, making sure that it is plugged into a working outlet.
UPDATED: August 14, 2021
Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests
(Sign in required)