Envelope printing issues in the SendPro Online software for Mac

Learn how to troubleshoot envelope printing issues in the SendPro Online software for Mac.
Products affected: SendPro® Online software for Mac

Issue

Envelopes do not print correctly from the SendPro Online software on a Mac. They may be misaligned, have parts missing, or print to the wrong tray.

Cause

The printer settings are not correct.

Resolution

If the envelope prints to the wrong tray:

Tray selection is not supported in the SendPro Online software with Mac OS X. Auto Select is the only tray available in the SendPro Online software.


If envelope is not aligned, is cut off, or the envelope prints blank:

Try setting the printer you are using as the default in Mac OS:

  1. Select the Apple icon.
  2. Select System Preferences.
  3. Open Printers & Scanners.
  4. From the Default Printer menu, select your printer.
  5. Restart the SendPro Online software.

Ensure that the correct tray and envelope settings are selected in the SendPro Online software:​​

  1. From the Print Envelopes screen, select Test Print.
  2. Select the printer in question.
  3. Ensure that the correct tray is selected from the Tray menu for your printer.
  4. Select Set Printer Settings.
  5. Select whether the printer uses Bottom Feed or Top Feed.
  6. Select the printer alignment: Left Align, Center Align, or Right Align.
  7. Select whether the envelopes are fed Face Up or Face Down.
  8. Select Test Print.

If the issue is not resolved, try changing the envelope size to #9, even if you are using a #10 envelope:

  1. From the Print Envelopes screen in SendPro, select the Change size link at the top next to the envelope size.
  2. Select Envelope #9.
  3. Select Test Print.

If the issue is not resolved, ensure that the correct paper size is selected:​

  1. Select the Apple icon.
  2. Select System Preferences.
  3. Open Printers & Scanners.
  4. Select the envelope printer.
  5. From the Default paper size menu, select Envelope.
  6. Return to the SendPro Online software and select Test Print.

If issue is not resolved, install a second instance of the printer with a generic printer driver:

  1. Select the Apple icon.
  2. Select System Preferences.
  3. Open Printers & Scanners.
  4. Click the "+" to add a printer.
  5. Select the printer you are using.
  6. From the Use menu, select a Generic Print Driver (i.e. Generic PCL Printer, Generic PS Printer etc.).
  7. Select Add.
  8. Right-click on the printer that was just added and select Rename Printer...
  9. In the Name field, rename the printer SendPro Envelope.
  10. Click OK.
  11. Restart the SendPro Online software so the program can find the new printer. 
  12. Start troubleshooting again from the beginning if this article as if this is a different printer.

If issue is not resolved, you can try creating a custom paper size if the print is slightly cut off:

  1. Open a new text document in a program like Microsoft Word or Notepad.
  2. Go to File > Print.
  3. Choose your envelope printer in the Printer menu.
  4. If the Paper Size menu does not populate, click on Show Details.
  5. Click on the Paper Size menu and choose Manage Custom Sizes.
  6. Click the + icon to create a new size.
  7. Set the Width to 4.13 and the Height to 10.
  8. Double-click on the name for the new paper size and rename it to Envelope.
  9. Click OK.
  10. Click Cancel.
  11. Close the document window.
  12. Click the Apple icon.
  13. Click System Preferences.
  14. Open Printers & Scanners.
  15. Select the envelope printer.
  16. Click the Default paper size menu and choose the custom Envelope paper size you created.

UPDATED: August 14, 2021