DFWorks:Apache Tomcat Maxing out Memory

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Product Feature: General

Operating System: Windows Platform

Issue

DFWorks functionality is impacted sporadically by a Java Heap Space (JVM ran out of memory) issue. This issue consist of Apache maxing memory usage causing the Tomcat7.exe to lock up.
Impact: The End-User will be unable to log into the DFWorks Application and/or will be unable to complete enrollment functions. Apache supports the WEB Server functionality of the DFWorks solution. If the Apache Service is "Hung up" The DFWorks end-user will not be able to log in.

Cause

Tomcat7.exe maxed out memory usage 

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Resolution


 
Tomcat can run out memory when
  1. A report with a very wide date range is generated.

    Action: Check the report_*.log for errors
  2. A dispatch report fails. Each time a report fails memory is allocated within the Tomcat JVM and is not released immediately. The report dispatcher will continue to dispatch the broken report causing more memory to be allocated in the Tomcat JVM. I’ve seen this happen before to the point where the Tomcat JVM runs out of memory.

    Action: Check the ReportEngine_*.log for errors.
  3. Someone runs a query from the System Admin Tools/SQL Query Editor

    Action: Check the report_*.log for errors
Tech note: 
The Report Engine runs on the UDHApp service. It sends a request to Tomcat like in the same way that a report page would when someone clicks the Export button. The “Connection refused: connect” message likely means that Tomcat was already hosed/out-of-memory and couldn’t respond. 
 
Go to the beginning of the ReportEngine_*.log and  search on “(ERROR)”.  See how many different errors you see. Is it multiple reports? One particular report? Try to do these searches prior to Tomcat losing control but leading up to it losing control.
 
Example Error : 

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UPDATED: April 03, 2017

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