"You have not completed your account registration" message in SendPro Online or PitneyShip

The message "You have not completed your account registration" means that the username is inactive because the account still needs to be activated.
Products affected: SendPro® Online, PitneyShip™

Issue

When signing in to SendPro Online or PitneyShip, the message "You have not completed your account registration" appears.

Cause

The username being used is not active.

Resolution

In the message, there is a "Resend email" option. Select Resend email to resend the registration email. Follow the prompts in the email to activate the SendPro Online or PitneyShip account.

If you do not receive the email, check your spam/junk email folder. The email comes from no-reply@pb.com.

If you need further assistance, please contact us.

UPDATED: April 25, 2022

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