Issue
Your scale does not weigh and your scale line on the display is missing, or the number is missing for the pounds and ounces.
Cause
- Your meter does not communicate with your scale.
- Your scale is defective.
Resolution
There are two ways to troubleshoot this issue; try them in this order:
- Zero your scale
- Reboot your meter
Solution 1: Zero your scale
- Select SCALE.
- Select Zero the scale.
- Test your scale with an item of known weight.
See
Zeroing your scale for more help with zeroing issues.
If this does not resolve your issue, try Solution 2.
Solution 2: Reboot your meter
- Lift your scale off of your meter.
- Unplug your power cord.
- Wait three minutes. During this time:
- Turn your scale upside down.
- Verify that your scale pins are not bent.
- Remove the 4 rubber pads from the bottom of your scale.
- Plug your meter back in, and place your scale back on top of your meter.
- Test your scale with an item of known weight.
Use the
Contact Us options below if you need further assistance. Have your model and serial number ready.
UPDATED: February 23, 2021