Issue
Your meter displays error code 110C and does not rate your mail.
Cause
Your rate manager software has an error.
Resolution
Follow these steps to to clear your error by restarting your meter:
- Unplug your power cord.
- Wait one to three minutes.
- Plug your power cord back in, ensuring that it is plugged directly into a wall outlet.
Use the
Contact Us options below if you need further assistance. Have your model and serial number ready.
UPDATED: February 11, 2021