"Bad Request" message when performing End of Day for PB Shipping API USPS carrier in SendPro Enterprise

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Products affected: SendPro® Enterprise

Issue

When performing End of Day for the PB Shipping API - USPS carrier, the error "Bad Request" appears and the Manifest Scan Form is not generated. The diagnostics show the following errors:

"errorCode": "5000001",

    "message": "Mismatch in partnerId for original transaction.",

    "additionalInfo": "PackageId XXX, Mismatch in partnerId for original transaction."

  },

  {

    "errorCode": "1110011",

    "message": "Invalid parcelTrackingNumber in request.",

    "additionalInfo": "PackageId XXX, Package not eligible for scanform."

  }

Cause

Return Labels are included in the End of Day query, which causes it to fail to generate the manifest scan form.

Resolution

The issue has been escalated. The current workaround is to process all shipments, perform End of Day, then process all return labels at a separate time. Note that End of Day is not required by the carrier.

UPDATED: January 22, 2019