"We can't process your request" when signing up for a UPS Rate Account in SendPro Online or PitneyShip

When signing up for UPS Rate Account in SendPro Online or PitneyShip, the message "We can't process your request. wait a moment and try again. If the issue persists, contact SendPro Support" may appear if you use a P.O. Box address, abbreviate the city name, or exceed the character limits in the fields on the sign-up form.
Products affected: SendPro® Online, PitneyShip™

Issue

When signing up for UPS Rate Account in SendPro Online or PitneyShip, the message "We can't process your request. wait a moment and try again. If the issue persists, contact SendPro Support" appears.

Cause

  • You may have used a P.O. Box address.
  • You may have abbreviated the city name.
  • You may have exceeded the character limits in the fields on the sign-up form.
  • You entered an address in Hawaii, Puerto Rico, or Alaska, where these special rates are not available.

Resolution

  • Do not use a P.O. Box address when signing up.
  • Avoid abbreviated city names. For example, use "Mount Pleasant" instead of "Mt. Pleasant", or "Saint Louis" instead of "St. Louis".
  • Do not exceed 30 characters (including spaces) in each field on the sign-up form.
  • Enter Unit/Apt/Suite numbers on the second address line.
  • Omit any periods or commas in any address, city, or state field.
  • Do not use an address in Hawaii, Puerto Rico, or Alaska.

If you need further assistance, please contact us.

UPDATED: April 25, 2022