Resolve "Your request cannot be processed at this time, please try again later" on pitneybowes.com
Learn how to resolve the error "Your request cannot be processed at this time, please try again later" on pitneybowes.com.
Products affected: pb.com, www.pb.com, pitneybowes.com, www.pitneybowes.com, My Account, Your Account
Issue
When attempting to use the Pitney Bowes website, the message "Your request cannot be processed at this time, please try again later" is displayed.
Cause
Your account number has not been linked to your online profile on the Pitney Bowes website.
Resolution
Follow these steps to link your account number to your online profile on the Pitney Bowes website:
If this does not resolve the issue, contact customer support.
- Sign in to the Pitney Bowes website.
- Select Add Products.
- In the Add account number box, enter your account number and select Continue.
- When prompted to Confirm Your Company Information, select one of the following options:
- Serial Number
- Invoice Number
- Invoice Amount
- Web Registration Number
- Based on the selection you made, enter the appropriate value and select Submit.
If this does not resolve the issue, contact customer support.
UPDATED: June 20, 2022