"Street must be no longer than 40 characters" in SendPro Online or PitneyShip

If you get the message "Street must be no longer than 40 characters" in SendPro Online or PitneyShip, it is because one or more lines in your sender or recipient address is longer than 40 characters.
Products affected: Connect+ 500W®, Connect+ 1000®, Connect+ 2000®, Connect+ 3000®, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000, SendPro® Online, PitneyShip™

Issue

When entering an address in SendPro Online or PitneyShip, the message "Street must be no longer than 40 characters" appears. The software may also become frozen.

Cause

One or more lines in the sender or recipient address is longer than 40 characters (including spaces).

Resolution

If SendPro Online or PitneyShip is still working

Reduce all lines of the sender and recipient address to be 40 characters or less, including spaces. If the address cannot be shortened, separate it into more than one line.

If SendPro Online or PitneyShip is frozen

If SendPro Online or PitneyShip is frozen, you will need to close and reopen it. If you are pasting the address in, edit it before pasting.

If you need further assistance, please contact us.

UPDATED: April 25, 2022

Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests (Sign in required)