Resolve a frozen software download or rate update on the DM100i-DM225

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Products affected: DM100®i, DM125™, DM200L™, DM225™

Issue

Your update stops progressing or stays on one screen for more than 20 minutes.

Cause

Your meter cannot connect to the server.

Resolution

Follow these steps to safely restart your meter and retry your download:
  1. Unplug the power cord.
  2. Wait three minutes.
  3. Plug the power cord back in, ensuring that it is plugged directly into a wall outlet.
  4. Attempt your software download again.
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UPDATED: February 07, 2021