Resolve a frozen software download or rate update on the DM100i-DM225
Learn how to resolve a frozen download or update on the DM100i, DM125, DM200L and DM225.
Products affected: DM100®i, DM125™, DM200L™, DM225™
Issue
Your update stops progressing or stays on one screen for more than 20 minutes.
Cause
Your meter cannot connect to the server.
Resolution
Follow these steps to safely restart your meter and retry your download:
- Unplug the power cord.
- Wait three minutes.
- Plug the power cord back in, ensuring that it is plugged directly into a wall outlet.
- Attempt your software download again.
- See Resolving connection errors if your issue has not been resolved.
UPDATED: October 26, 2021
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