Scale not weighing correctly on the DM100i-DM225

Learn how to resolve the scale not weighing correctly on the DM100i, DM125, DM200L and DM225.
Products affected: DM100®i, DM125™, DM200L™, DM225™

Issue

Your mailpiece is not weighed correctly by your scale.

Cause

  • Your scale may not communicate with your meter.
  • Your scale may not be level.

Resolution

There are three ways to troubleshoot this issue; try them in this order:
  1. Zero your scale
  2. Make sure your scale is level
  3. Restart your meter
 

Solution 1: Zero your scale

  1. Remove any items from your scale.
  2. Select Scale from the Home screen.
  3. Select Zero the scale.
  4. Test your scale with an item of known weight.

If this does not resolve your issue, try Solution 2.
 

Solution 2: Make sure that the platform is level if you have a MP30 or MP49 external weighing platform that sits beside your meter

  1. Take the top cover off of your weighing platform.
  2. Locate the round glass level.
Scale level
  1. The dot should be located inside of the black circle. If the dot is not inside of the black circle, adjust the feet on the weighing platform until the dot is inside of the circle.
  2. Test your scale with an item of known weight.

If this does not resolve your issue, try Solution 3.
 

Solution 3: Restart your meter if your scale still does not weigh correctly

  1. Remove your scale from the top of your meter, or, if you have an external weighing platform, unplug the cable from the back of your meter.
  2. Unplug your power cord.
  3. Wait one to three minutes.
  4. While waiting, put your scale back on top of your meter or plug the external weighing platform back into your meter.
  5. Plug your power cord back in, ensuring that it is plugged directly into a wall outlet.
  6. Test your scale with an item of known weight.

Use the Contact Us options below if you need further assistance. Have your model and serial number ready.

 

UPDATED: January 03, 2023