"The password you provided was not recognized. Please try again." in SendPro Online

If you get the message "The password you provided was not . Please try again." in SendPro Online, try changing your password.
Products affected: Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000, SendPro® Online

Issue

When signing in to SendPro Online, the message "The password you provided was not recognized. Please try again." is displayed.

Cause

The password being used is not a valid password for SendPro.

Resolution

Try changing your SendPro password.

Related topics

UPDATED: August 14, 2021

Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests (Sign in required)