"The password you provided was not recognized. Please try again." in SendPro Online or PitneyShip

If you get the message "The password you provided was not recognized. Please try again.", try changing your password.
Products affected: Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000, SendPro® Online, PitneyShip™

Issue

When signing in to SendPro Online or PitneyShip, the message "The password you provided was not recognized. Please try again." appears.

Cause

The password being used is not valid.

Resolution

Try changing your SendPro Online or PitneyShip password.

If you need further assistance, please contact us.

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UPDATED: April 25, 2022