Skip to main content
Support
Track A Package
Ship & Mail
Financial Services
Resources
Buy Supplies
Sign In
Sign In
Support
United States
Office Ship & Mail
Postage Meters
Online Postage
Mail Accounting & Expense Management
Ecommerce & Retail Solutions
Order Fulfillment
Delivery Services
Returns
Parcels & Packages
Parcel Locker
Package Tracking Solutions
Consumer Connect
Mailing Services
First Class Mail
Marketing Mail / Direct Mail
Bound Printed Matter
Mailing Equipment & Software
Mailing Software
Addressing Equipment & Printers
Letter Openers & Folders
Folders Inserters
Shredders
Shipping & Postage Payments
Line of Credit
Prepaid Deposit Account
Financing
Equipment Financing
Working Capital
Industries
Manufacturing
Healthcare
Construction
Postal Resources
Postal Rate Change
Postal Information
Support
Postage Meters Support
Account Support
Mailing Equipment Support
Connectivity Support
Communications
Blog
News
Events
Back to Top
Top
Pitney Bowes Support
"The password you provided was not recognized. Please try again." in SendPro Online
"The password you provided was not recognized. Please try again." in SendPro Online
Products affected: Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000, SendPro® Online
Issue
When signing in to SendPro Online, the message "The password you provided was not recognized. Please try again." is displayed.
Cause
The password being used is not a valid password for SendPro.
Resolution
Try changing your SendPro password.
Related topics
Changing or resetting your password for SendPro Online and the SendPro Tablet
UPDATED: February 16, 2021
Contact Us
Live Chat
Open Now
Mon - Fri, 8am - 8pm ET
Sales team hours are 8am - 6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon - Fri, 8am - 8pm ET
Create a case
Submit support requests
(Sign in required)