"We were unable to print your label" message when printing a UPS label in SendPro Online

If the message "We were unable to print your label" appears if you try to print a UPS label, your UPS account needs to be relinked in SendPro Online.
Products affected: SendPro® Online

Issue

The message "We were unable to print your label" appears when printing a UPS label.

Cause

  • The UPS account needs to be relinked to PitneyShip or PitneyShip Pro, or
  • There is an issue with your UPS account.

Resolution

Remove and reconnect your UPS account. Make sure that you have your latest UPS invoice ready before removing the account.

  1. In SendPro, click Settings > Shipping Carriers.
  2. Select Manage next to your UPS account.
  3. Select the delete icon.
  4. Select Delete.
  5. Re-add your UPS account to SendPro. See Setting up a UPS account.

If the issue is not resolved, contact UPS to check on the status of your UPS account.

UPDATED: August 30, 2023