"Error issuing certificate! - Policy cannot be created - name already exists" message in PitneyShip or PitneyShip Pro
The message "Error issuing certificate! - Policy cannot be created - name already exists" occurs because DeviceHub is out of date and unable to update.
Products affected: PitneyShip™, PitneyShip™ Pro
Issue
The message "Error issuing certificate! - Policy cannot be created - the name already exists" appears.
Cause
DeviceHub is out of date and unable to update.
Resolution
- Solution 1: Turn off ZScaler and retry onboarding
- Solution 2: Restart DeviceHub
- Solution 3: Reinstall DeviceHub
- Solution 4: Check virus protection or firewall settings and reinstall DeviceHub
Solution 1: Turn off ZScaler and retry onboarding
If using ZScaler, turn ZScaler off and retry onboarding
Solution 2: Restart DeviceHub
- For Windows, select the system tray (small icons near the clock) and right-click the DeviceHub icon. For MacOS, select the DeviceHub icon from the menu bar.
- Select Exit.
- Delete certificates in this path - (C:\ProgramData\PB\devicehub\DeviceHub_v1\certifi).
- Change the “is generated” value to “false” in the folder (dhaMQTConfig.json) located in this path - (C:\ProgramData\PB\devicehub\DeviceHub_v1\devicehubagent\config).
- Restart DeviceHub.
Solution 3: Reinstall DeviceHub
Reinstall Devicehub. See Installing DeviceHub for PitneyShip, PitneyShip Pro, or PitneyShip Cube.
Solution 4: Check virus protection or firewall settings and reinstall DeviceHub
Check your virus protection or firewall settings, and then reinstall DeviceHub.
UPDATED: August 18, 2023