"There was a connection issue" message when running or activating DeviceHub in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise

Learn how to resolve the error "There was a connection issue. Contact PitneyBowes. Error-Port 8091 is in use by another application.".
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise

Issue

When trying to run or activate DeviceHub, the message "There was a connection issue. Contact Pitney Bowes. Error-Port 8091 is in use by another application." appears.

Cause

Port 8091 is being used by another device other than DeviceHub.

Resolution

Port 8091 needs to be isolated for DeviceHub. If another application is using port 8091, DeviceHub will not be usable. Have your IT department review the DeviceHub Networking Requirements and Technical Specifications:

  1. While signed in to PitneyShip, PitneyShip Pro, or PitneyShip Enterprise, open a new tab in your browser.
  2. In the address bar of the browser, type localhost:8091and press Enter.
  3. If the message "DeviceHub registered successfully!" appears, then return to the browser tab in which PitneyShip is open and continue to step 4. If an error message appears, contact your IT department to discuss unblocking port 8091.
  4. Go to Settings > My Devices.
  5. If the list of devices is till not populated, select Refresh.

UPDATED: April 15, 2024