How to resolve a low sector message on the DM300C, DM400C and more

Learn how to resolve a low sector message on the DM300C, DM400C, and DM475.
Products affected: DM300C™, DM400C™, and DM475™

Issue

The meter displays the message Low Sector and will not turn on.

Cause

The meter has experienced an internal error preventing normal operation.

Resolution

You may be able to clear the error by simply restarting your meter.  Here are the steps to follow for a safe restart:
  1. Unplug the power cord; wait one minute
  2. Plug the power cord back in, ensuring that it is plugged directly into a wall outlet
If your issue is not resolved, contact customer support from 8 am to 8 pm Eastern Time. Have your model number ready.

UPDATED: 14 June 2021