"ConvertPositionToBinary method is not supported for this device" message with UPS Consolidated in SendSuite Live

Learn how to resolve the message "Error Printing Document ConvertPositionToBinary method is not supported for this device" when shipping with UPS Consolidated in SendSuite Live. No label is generated.
Products affected: SendSuite® Live

Issue

When printing a UPS Consolidated label, the message "Error Printing Document ConvertPositionToBinary method is not supported for this device" is displayed and the label is not generated.

In the diagnostics, the debug logs show an error similar to the following:

<ERRORSEVERITY>Partial Success</ERRORSEVERITY>

<ERRORCODE>2427</ERRORCODE>

<ERRORDESCRIPTION>Error Printing Document ConvertPositionToBinary method is not supported for this device (6). No Label was Generated!</ERRORDESCRIPTION>

 

Cause

The printer's Printer Model setting is not correct.

Resolution

Change the Printer Model setting:

  1. Open the SendSuite Live Shipment Server Configuration Administrator page.
  2. Select the Shipment Server Configuration tab.
  3. Expand Device.
  4. Select Printer Queues.
  5. Select the affected printer.
  6. Change the Printer Model to Zebra 2844-Z.
  7. Click OK to save.

UPDATED: August 14, 2021