Jamming mail on the Connect+ Series and SendPro P

Learn how to resolve jammed mail on the Connect+ Series and SendPro P.
Products affected: Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro™ P1000, SendPro™ P1500, SendPro™ P2000, SendPro™ P3000

Issue

A mailpiece jammed.

Cause

A mailpiece piece entered the machine but did not exit.

Resolution

Follow these steps to remove your jammed mailpiece:

  1. Open the top cover and printer cover.
  2. Open the blue jam release that holds your mailpiece.
  3. Remove your mailpiece.
  4. Use a can of non-flammable canned air and, working from the left side of the machine to the exit, blow air on the feed deck that the envelopes and tape sheets travel on. Ensure that you spend enough time in this step to thoroughly remove dust and debris.
  5. Close all jam releases and covers.
If you need further assistance, please contact us.

UPDATED: August 04, 2022