"No PSD" message on the SendPro C

Print this support article
Products affected: SendPro® C (2H25)

Issue

The device gives the message "No PSD" and will not function.

Cause

An internal component has malfunctioned.

Resolution

  1. Turn off the network connection:
    • For wired networks, unplug the network cable.
    • For Wi-Fi networks:
    1. Tap Settings on the toolbar.
      settings-icon
    2. Tap Wi-Fi.
    3. Tap the slider so that it moves to the off position.
  2. Reboot the device:
    1. Unplug the power cord.
    2. Wait one minute. The screen should turn off after 10 seconds.
    3. Plug the power cord directly back into a wall outlet. Check that the wall outlet is working correctly.
    4. Quickly tap and release the power button to turn the device back on.
  3. Reconnect the network cable.
  4. Manually upload your Print on Envelopes transactions.
    1. Tap Settings on the toolbar.
      settings-icon
    2. Scroll down to the Envelope Printer Settings section.
    3. Tap Sync Transaction Data.
  5. Perform a postage refill for your Print on Envelopes balance.
    1. Tap Print on Envelopes on the Home screen.
    2. Tap Postage Balance at the top of the Print on Envelopes screen.
    3. Tap Refill Postage.
    4. Enter the amount of postage you wish to add to your device.
    5. Tap Refill Mail Postage. A message appears telling you your device is refilling postage.
If you need further assistance, please use the Contact Us options below.

UPDATED: 23 April 2021