Scale not weighing correctly on the mailstation and mailstation2

Learn how to resolve the scale not weighing correctly on the mailstation and mailstation2.
Products affected: mailstation™, mailstation2™

Issue

Mailpieces are not being weighed correctly on the meter scale.

Cause

This issue may be caused by a communication issue between the scale and the meter.

Resolution

To fix this issue, try resetting the scale.
  1. Remove any items from the scale.
  2. Press Menu.
  3. Press Review (down) until the display says Reset the Scale to Zero?.
  4. Press Enter / yes.
  5. Test with an item of known weight. If the scale is still not weighing correctly:
    1. Unscrew the thumb screws on the scale cable and disconnect the cable.
    2. Unplug the power cord.
    3. Wait one to three minutes.
    4. While waiting, reconnect the scale cable and tighten the thumb screws.
  6. Plug the power cord back in, verifying it is plugged directly into a wall outlet.
If your issue is still not resolved, contact technical support.  Please have your model number and serial number ready.

UPDATED: 14 August 2021

Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests (Sign in required)