"Double feed" message on the Relay 2500, 3500, and 4500
Learn how to resolve "Double feed" message on the Relay 2500, 3500, and 4500.
Products affected: Relay™ 2500, Relay™ 3500, Relay™ 4500
Issue
The inserter displays the message "Double feed."
Cause
A double feed has been detected from the feed tray indicated.
Resolution
- Remove the material from the inserter and restart
- If double feeds persist, request another trial piece
UPDATED: 30 June 2021
Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests
(Sign in required)