How to resolve 'flash needed init version' on the DM300C, and DM400C, and more

Learn how to resolve the message 'flash needed init version' or 'flash needs init' on the DM300C, DM400C, and DM475.
Products affected: DM300C™, DM400C™, and DM475™

Issue

The meter displays error message flash needed init version or flash needed init and will not boot.

Cause

The meter has experienced an internal error preventing normal operation.

Resolution

You may be able to clear the error by simply restarting your meter.  Here are the steps to follow for a safe restart:
  1. Unplug the power cord; wait one minute
  2. Plug the power cord back in, ensuring that it is plugged directly into a wall outlet
If your issue is not resolved, contact customer support from 8 am to 8 pm Eastern Time. Have your model number ready.

UPDATED: 30 June 2021

Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests (Sign in required)