How to resolve Low Battery messages on the DM100i and DM125
Learn how to resolve Low Battery and other battery messages on the DM100i and DM125.
Product affected: DM100®i and DM125™
Issue
The message UIC Battery Low, PSD Battery Low or Urgent Battery Warning means your meter must be replaced.
Cause
The internal battery is close to end of life.
Resolution
- Press the Clear button to clear the message temporarily
- Once cleared, contact customer support from 8 am to 8 pm Eastern Time. Have your model number ready. Your meter needs to be replaced.
Note: You may continue using your meter until the replacement meter arrives.
UPDATED: 14 August 2021
Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests
(Sign in required)