How to resolve initializing malfunction error on the mailstation or mailstation2

Learn how to resolve stuck on initializing on the mailstation or mailstation2.
Products affected: mailstation™ and mailstation2™

Issue

The meter displays Initializing, the Home screen does not display.

Cause

The internal meter software has malfunctioned.  The meter froze when it is powering up.

Resolution

You may be able to clear the error by simply restarting your meter.  Here are the steps to follow for a safe restart:
  1. Unplug the power cord; wait one minute
  2. Plug the power cord back in, ensuring that it is plugged directly into a wall outlet
If your issue is not resolved, contact customer support from 8 am to 8 pm Eastern Time. Have your model number ready.

UPDATED: 07 June 2021

Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests (Sign in required)