"Device hub connection timeout" message when printing in PitneyShip Pro
If you see the message "Device hub connection timeout" when printing, try moving the printer to a different USB port.
Products affected: PitneyShip™ Pro
Issue
"Device hub connection timeout" message when printing in PitneyShip Pro.
Cause
There is a USB issue with the connected printer.
Resolution
Move the printer to a different USB port and try again.
If you need further assistance, please contact us.
UPDATED: 30 November 2022