"There was an error generating your label... [120121] The Shipper number cannot be used for this shipment" message when printing a UPS label in PitneyShip Pro

There was an error generating your label... [120121] The Shipper number cannot be used for this shipment" message when printing a UPS label means that there is an issue with the UPS account.
Products affected: PitneyShip™ Pro

Issue

When printing a UPS label, the message "There was an error generating your label. Something went wrong. Please try again later.[120121] The Shipper's shipper number cannot be used for the shipment" appears.

Cause

There is an issue with UPS account being used.

Resolution

Solution 1: Delete and re-add the UPS account

  1. Select Settings > Carriers.
  2. Select the delete icon next to the UPS carrier account.
  3. Select Delete.
  4. Select Add Carrier and enter the UPS account details to re-add it.

Solution 2: Contact UPS

Contact UPS to find out if there is an issue with the status of the UPS account you are using.

UPDATED: 18 August 2023