Weight not appearing in PitneyShip Pro when using a scale
If the item weight does not appear in PitneyShip Pro when using a scale, follow these troubleshooting steps.
Products affected: PitneyShip™ Pro
Issue
When weighing an items on the scale, the weight does not appear in PitneyShip Pro.
Cause
- The scale may not be connected to the computer.
- DeviceHub may not be connected or activated.
- The scale may need to be zeroed.
Resolution
- Solution 1: Make sure that you are using a compatible scale
- Solution 2: Check the scale connection
- Solution 3: Verify that DeviceHub is connected
- Solution 4: Activate DeviceHub
- Solution 5: Zero the scale
Solution 1: Make sure that you are using a compatible scale
Solution 2: Check the scale connection
Check the scale and make sure that the USB cable is securely connected to your computer.
Solution 3: Verify that DeviceHub is connected
- Select Settings > My Devices.
- On the My Devices page, check that your scale is online. There should be a green check mark next to your scale.
Solution 4: Activate DeviceHub
- Select Settings > My Devices.
- Select Activate DeviceHub.
- Once DeviceHub is registered successfully, select Close.
- Go back to the My Devices page and select Refresh.
Solution 5: Zero the scale
- Select Settings > My Devices.
- Find your scale in the list of connected devices.
- Click on the zero scale arrow.
UPDATED: 18 August 2023