"Please enter a valid 10-digit or 16-digit Account number" appears when adding accounts in Your Account
Learn how to resolve the error "Please enter a valid 10-digit or 16-digit Account number" when adding accounts in Your Account
Issue
The error message "Please enter a valid 10-digit or 16-digit Account number" appears when adding an account to your online profile.
Cause
The account you are trying to add to your online profile is invalid.
Resolution
Confirm the account number you entered is correct. If the account number is correct, please chat with us.
UPDATED: 17 March 2025