"Did you forget your password?" message appears when signing in to Your Account
Learn how to resolve the error message "Did you forget your password?" when signing in to Your Account.
Issue
The message "Did you forget your password?" appears when signing in to the Your Account portal.
Cause
You have attempted to log in with an incorrect password more than 7 times.
Resolution
- Click Reset your password now.
- Enter your email address in the Email or Username field.
- Click Continue.
- Click Reset Password in the email sent to you.
- Enter your new password and confirm your new password.
- Click SUBMIT.
UPDATED: 08 May 2025