PDF not appearing when creating a shipping label in PitneyShip Pro

If the PDF is not appearing when creating a shipping label, the pop-up blocker in your web browser may be blocking the window.
Products affected: PitneyShip™ Pro

Issue

When creating a shipping label, the PDF is not appearing.

Cause

The pop-up blocker in your web browser may be blocking the window.

Resolution

Firefox

Firefox may be blocking pop-ups, preventing the label from being created. When blocking a pop-up, Firefox displays an information bar. If you see this bar, follow the steps below.Notification bar from Firefox when it is preventing popups

  1. Click the Options button in the notification bar and choose Allow pop-ups for sendpro360.pitneybowes.com.
  2. After allowing pop-ups, reprint the label. See Reprinting a shipping label.

Safari

  1. From the Safari menu, choose Preferences.
  2. Click Websites.
  3. Find the address sendpro360.pitneybowes.com and change the settings to Allow.
  4. After allowing pop-ups, reprint the label. See Reprinting a shipping label.

Chrome

  1. Click on the three dots in the upper right and select Settings.
    Chrome 3 dots menu
  2. Select Privacy and security on the left.
  3. Select Site Settings.
  4. Select Pop-ups and redirects (you may need to scroll down to see it).
  5. Under Allowed to send pop-ups and use redirects, click Add, enter sendpro360.pitneybowes.com, and click Add.
    Add exception for pop-ups and use redirects in Chrome

Microsoft Edge

  1. Click on the three dots in the upper right and select Settings.
    Microsoft Edge 3 dots menu
  2. Select Cookies and site permissions on the left.
  3. Select Pop-ups and redirects (you may need to scroll down to see it).
  4. In the Allow section, select Add.
    Microsoft Edge Add button
  5. Enter https://sendpro360.pitneybowes.com and select Add.
    Microsoft Edge add site window

If you need further assistance, please contact us.

UPDATED: 30 November 2022