Issue
The Envelope Printing screen says, "Not Ready to Print" and will not print.
Cause
Several things can cause "Not Ready to Print":
- A jam may not have cleared.
- The jam release may be open.
- The ink tank may be missing or empty.
- The print head may be missing.
- You may need to select an account.
- You may need to upload transactions.
Resolution
Alerts:Look for a red exclamation point (!) with a notification that the print head or ink tank is missing or empty, a jam may be present in the device or the jam release is open.
Accounting:If you have accounting, you must select an account.
Check the scale:
- Tap Reset to default.
- Put something on the scale.
- If you do not have a scale:
- Tap the weight button.
- Choose Manual.
- Tap the 1 key.
- Tap Apply.
- Open and close the jam release lever.
Upload any pending transactions:
- Tap Settings on the toolbar.

- Tap Sync USPS Transaction Data.
- Any pending transactions will now be uploaded.
- Tap Reset to Default.
Change the print mode:
- Tap Print Mode.
- Tap Date Correction.
- Tap Apply.
- Tap Reset to default.
Reboot the device:
- Unplug the power cable. The screen should turn off after 10 seconds.
- Wait 2 minutes.
- Plug the power cord directly back into a wall outlet. Check that the wall outlet is working correctly.
- Quickly tap and release the power button to turn the device back on.
- Tap Envelope Printing.
- Verify that the device says ready to print.
If you need further assistance, please use the
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UPDATED: February 16, 2021