Error code BA03 on the SendPro C Lite, SendPro C, SendPro+, SendPro C Auto

Applies to all SendPro C Lite, SendPro C, SendPro+ and SendPro C Auto models. If you see error BA03, do this to resolve the issue.

Products affected: SendPro® C Lite, SendPro® C, SendPro®+, SendPro® C Auto (2H00, 8H00, 9H00)

 

Issue

The meter displays BA03 when trying to refill.

Cause

There has been an internal error.

Resolution

Please use the Contact Us options below. Please have your model and serial number ready.

UPDATED: January 10, 2022

Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests (Sign in required)
1-800-522-0020
Mon-Fri, 8am - 8pm ET