"Exception from HRESULT: 0x800A017D (CTL_E_INVALIDPROPERTYARRAYINDEX)" when viewing transactions in Business Manager

Learn how to resolve the error "Exception from HRESULT: 0x800A017D (CTL_E_INVALIDPROPERTYARRAYINDEX)" when viewing transactions in Business Manager.
Products affected: Business Manager version 7.x

Issue

In Business Manager under Manage Transactions, when selecting hierarchy view without an account code, sub account code, or sub sub account code selected, then selecting Display, the error "Exception from HRESULT: 0x800A017D (CTL_E_INVALIDPROPERTYARRAYINDEX)" is displayed.

Cause

This is a known issue in Business Manager version 7.x, which should be corrected in a future release.

Resolution

An account field must be included in the manage transactions query. To add the account:
  1. Under Manage Transactions, select Grid View, then select the options for account code, sub account code, or sub sub account code.
  2. Select the Memory button to save the criteria.
  3. (Optional) Change back to hierarchy view if desired.
If the issue is not resolved, contact software support.

UPDATED: October 25, 2021

Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests (Sign in required)