Resolve "List index out of bounds (-1)" and job not printing in PlanetPress

Learn how to resolve the error "List index out of bounds (-1)" and the job not printing in PlanetPress.
Products affected: PlanetPress®, PBFirst™

Issue

When running a job in PlanetPress®, the job will not print and the error "List index out of bounds (-1)" will be displayed on or after PBFirst™.

Example:

User-added image

Cause

The Windows user account does not have rights to access the PlanetPress folder.

Resolution

Note: Your Windows account must have administrator permission to continue. If you do not have administrator rights, contact your IT department.
  1. Navigate to the Objectif Lune folder:
    • For Windows 7 and later:
      1. On your keyboard press Windows key + R, or select Start > Run.
      2. Type C:\ProgramData in the Open field.
      3. Select the OK button.
    • For Windows XP:
      1. On your keyboard press Windows key + R, or select Start > Run.
      2. Type C:\Documents and Settings\All Users\Application Data in the Open field.
      3. Select the OK button.
  2. Right-click on the Objectif Lune folder and select Properties.
  3. Select the Security tab.
  4. Select the Edit button.
  5. Select the Add button.
  6. Type Everyone and select the OK button.
  7. Select Everyone and check the Full Control box.
  8. Select the OK button.
  9. Select the OK button.
  10. Restart the computer and test.
If issue is not resolved, contact software support for further assistance.

UPDATED: August 14, 2021

Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests (Sign in required)