Resolve an E-Z Seal leak on the Connect+ Series and SendPro P Series
Learn how to resolve an E-Z Seal leak on the Connect+ 500W, Connect+ 1000, Connect+ 2000, Connect+ 3000, SendPro P1000, SendPro P1500, SendPro P2000, and SendPro P3000.
Products affected: Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000
Issue
The meter is leaking E-Z Seal®.
Cause
- The bottle may be leaking.
- There may be an internal leak.
Resolution
- Ensure that the cap is tight and not cross-threaded.
- With the cap face up, press the valve in the center of the cap. It should go down and spring back up.
If the issue is not resolved, contact technical support. Please have your model and serial number ready.
UPDATED: August 14, 2021
Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests
(Sign in required)