PDF not appearing when creating a shipping label in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise

If the PDF is not appearing when creating a shipping label, the pop-up blocker in your web browser may be blocking the window.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise

Issue

When creating a shipping label, the PDF is not appearing for the label, the summary receipt, or the FedEx customs invoice.

Cause

The pop-up blocker in your web browser may be blocking the window.

Resolution

Solution 1: Verify that "Print to PDF" is selected

  1. In PitneyShip, PitneyShip Pro, or PitneyShip Enterprise, select Settings > Print Options.
  2. Verify that the Print to PDF option is selected. The Print to PDF option generates a PDF, which you can then print using your web browser's print function.
  3. Attempt to print again.

Solution 2: Check for a pop-up blocker

Make sure your web browser isn't blocking the pop-up window. See:

Solution 3: Manage browser privacy exceptions in Firefox

If you are using Firefox, and you get signed out when the PDF doesn't open, add this privacy exception.

  1. Go to Settings in Firefox.
  2. Select Privacy & Security.
  3. Under Enhanced Tracking Protection, select Manage Exceptions.
  4. In the box for Address of website, enter https://sendpro360.pitneybowes.com, then click Add Exception.
  5. Select Save Changes.
  6. Restart Firefox and try printing your label again.

The features and options you see may vary depending upon your role and subscription. If you have any questions regarding your permissions, please contact your administrator.

UPDATED: April 24, 2026