"UPS rates could not be retrieved" message in PitneyShip, PitneyShip Pro, PitneyShip Enterprise, or ShipAccel

If you receive the message "UPS rates could not be retrieved. Wait a moment and try again. Get Rates.", the UPS account may need to be verified.

Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise, ShipAccel

Issue

When trying to select UPS rates, the message "UPS rates could not be retrieved. Wait a moment and try again. Get Rates." appears.

Cause

The UPS account may not be verified.

Resolution

  1. Select Settings > Carriers.
  2. If the UPS carrier listed shows a Verify link in the Account#/Partner ID column, follow these instructions to verify it:
    UPS Verify link on Carriers page

UPDATED: June 12, 2025