"We can't find that serial number or meter number in our system" message displays when registering for Your Account
Learn how to resolve the error message "We can't find that serial number or meter number in our system" when registering for Your Account.
Issue
The message " We can't find that serial number or account number in our system" displays when registering for the Your Account portal.
Cause
The serial number you have entered to validate your account is incorrect.
Resolution
Solution 1: Ensure the account number is correct
Confirm the serial number you have entered is correct. Your account number will either be 10 or 16 digits and can be located on the top of your invoice.
Solution 2: Confirm you are registering for the correct country
Confirm the country flag in the top right corner of the registration page matches the location of the account you are trying to register.
If you require access to accounts for different countries, you will need to create individual profiles for each country.
UPDATED: November 05, 2024