"Do not challenge me on this device again" not working or MFA prompts happening too often in PitneyShip, PitneyShip Pro, PitneyTrack Asset, PitneyTrack Inbound, PitneyAnalytics, and the Locker Management Module

If the "Do not challenge me on this device again" option is not working or you get MFA prompts happening too often, you may need to adjust your browser settings.

Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise, PitneyTrack® Asset, PitneyTrack® Inbound, PitneyAnalytics®, Locker Management Module

Issue

The "Do not challenge me on this device again" option is not working, or Multi-Factor Authentication (MFA) prompts are occurring too frequently.

Cause

When you select the "Do not challenge me on this device again" option during Multi-Factor Authentication, a device token cookie is created to store your preference. This cookie is essential for preventing repeated MFA prompts on that device.

  • The necessary cookies may have been cleared. If the cookie is erased or cannot be stored, a new token will be generated for each session, and you will be prompted to authenticate again.
  • Incognito (Chrome) or InPrivate (Edge) browsing mode may have been used. If the application is accessed in Incognito or InPrivate mode, the feature may not work as intended because the cookie cannot be stored.
  • Safari’s "Prevent cross-site tracking" setting may be preventing the site from working correctly by interfering with the storage of the cookie. See below for details on how to turn this setting off.
  • An embedded browser may have been used. This is where web browser functionality is integrated into another application, allowing you to browse web content without opening a separate browser window.

Resolution

To ensure that this feature functions correctly:

  • Do not clear your browser cookies between sessions.
  • Do not use Incognito (Chrome) or InPrivate (Edge) browsing mode when accessing PitneyShip, PitneyShip Pro, PitneyTrack Asset, PitneyTrack Inbound, PitneyAnalytics, and the Locker Management Module.
  • Avoid using embedded browsers.
  • If you use Safari, turn off “Prevent cross-site tracking”:
    1. Open Safari.
    2. In the Menu bar, select Safari > Preferences
    3. Select Privacy.
    4. Uncheck Prevent cross-site tracking.
      Safari Privacy window
    5. Close the Privacy window.
    6. Reload the web page that was not working correctly.

UPDATED: May 02, 2025